Windows installer/nl

From Gramps
Revision as of 12:13, 15 June 2011 by Romjerome (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

GRAMPS is niet ontworpen om op Microsoft Windows te werken, en dat moet dan ook als experimenteel beschouwd worden.

Omdat het is ontworpen met de multi-platform componenten Python en GTK, hebben een aantal vrijwilligers een test installatiepakket gecreëerd waarvan sommige gebruikers verklaard hebben dat het werkt zonder teveel vanzelfsprekende problemen. Dit is evenwl niet formeel getest, en je zou kunnen ondervinden dat het gedrag van GRAMPS op Windows opeens onstabiel wordt of subtiel je data compromitteerd over een bepaalde periode zonder dat je er erg in hebt. Elke nieuwe versie kan fouten bevatten die verschillend zijn van wat eerder gekend was. Als je bijgevolg ervoor kiest GRAMPS onder Windows te gebruiken, hou dan rekening met hetvolgende:

  • Werk met een kopie van je hoofd databank, en doe regelmatig een backup van je data in het GRAMPS XML formaat (de export optie in het bestand menu).
  • Prijs het niet aan bij Windows-gebruikers als een stabiele of bruikbare genealogie applicatie.
  • Word lid van de GRAMPS Windows mailing list om je ervaringen te delen of, indien je een ontwikkelaar bent, om bij te dragen aan de Windows port van GRAMPS.

Installatie

1. GRAMPS is afhankelijk van de volgende software pakketten, die je moet installeren alvorens GRAMPS te installeren. Wij hebben de beste resultaten gehad door de volgende pakketten te installeren in de volgorde zoals hier gegeven:

2. Herstart je computer na het installeren van de bovenstaande pakketten, alvorens over te gaan op de installatie van GRAMPS.

3. gramps-3.3.1 -- GRAMPS één-klik installatieprogramma voor Windows, met support voor 20 talen. Merk op: Het installatieprogramma heeft vaak de fout dat pygtk niet geïnstalleerd is, ondanks het feit dat dat wel het geval is. Onderbreek de installatie en herstart ze. Dit blijkt het probleem op te lossen.

Limitaties

Op dit moment is er geen intentie om alle afhankelijkheden van GRAMPS en GRAMPS zelf in één enkel installatieprogramma aan te bieden. Dit creëert immers een complex coördinatieprobleem tussen GRAMPS en deze projecten. Het zou ook betekenen dat een upgrade van GRAMPS telkens een 19Mb download zou zijn, waar het nu minder dan 3Mb is.

Er is recent discussie geweest over het werken met dll's (dynamic link libraries) voor deze kernafhankelijkheden, en zo te vermijden dat de volledige Python en GTK omgevingnen nodig zijn, maar dit werk is nog niet afgerond. Meer discussie hierover alsook andere Windows gerelateerde zaken kunnen gevonden worden op de email list archieven.