Difference between revisions of "Sv:Gramps:Installation"

From Gramps
Jump to: navigation, search
(Live CD)
m (Gramps)
(42 intermediate revisions by 5 users not shown)
Line 1: Line 1:
==Live CD==
+
{{languages|Installation|Gramps:Installation}}
  
Om du är intresserad av GRAMPS men inte vill- eller kan installera det (datorn är inte din, datorn kör Windows, du har inget Internet hemma, du sitter vid en arbetsdator etc) så kan du testa vår {{call lang|Linux Genealogy CD|sv|Linux Genealogy CD}}. Den körs utan att installeras på hårddisken och innehåller en samling fria genealogiprogram licensierade som Open Source. Du kan sedan installera [http://ubuntu.com Ubuntu 7.04 LTS] och GRAMPS från CD:n när du vill.
 
  
==Enkel nedladdning och installation av GRAMPS 2.2.7==
+
=Live CD=
  
Innan du laddar ner så bör du först kontrollera så att inte den version av GRAMPS som medföljer din distribution är den senaste:
+
Om du är intresserad av Gramps men inte vill- eller kan installera det (datorn är inte din, datorn kör Windows, du har inget Internet hemma, du sitter vid en arbetsdator etc) så kan du testa vår {{call lang|Linux Genealogy CD|sv|Linux Genealogy CD}}. Den körs utan att installeras på hårddisken och innehåller en samling fria genealogiprogram licensierade som Open Source. Du kan sedan installera [http://www.ubuntulinux.org/ Ubuntu 10.10] och Gramps från CD:n när du vill.
 +
 
 +
=Enkel nedladdning och installation av Gramps=
 +
 
 +
Innan du laddar ner så bör du först kontrollera så att inte den version av Gramps som medföljer din distribution är den senaste:
 
* Debian, (K, X, Edu)Ubuntu, Mepis, Suse: <code>
 
* Debian, (K, X, Edu)Ubuntu, Mepis, Suse: <code>
   apt-get install gramps</code>
+
   sudo apt-get install gramps</code>
* Fedora: <code>
+
* Gentoo (and Sabayon):<code>
   yum install gramps</code>
+
  sudo emerge gramps </code>
 +
* Mandriva: <code>
 +
  sudo urpmi gramps</code>
 +
* Redhat, Fedora, CentOS...: <code>
 +
   sudo yum install gramps</code>
  
==Uppgradera till den senaste versionen==
+
=Uppgradera till den senaste versionen=
  
Om din version av GRAMPS inte är den senaste så erbjuder en del användare uppdaterade paket för vissa distributioner:
+
Om din version av Gramps inte är den senaste så erbjuder en del användare uppdaterade paket för vissa distributioner:
  
 
* '''Ubuntu''': På sourceforge så kan du [http://sourceforge.net/project/showfiles.php?group_id=25770 ladda ner] gramps_zzz.deb och gramps-help_zzz.deb. Installera med din pakethanterare.
 
* '''Ubuntu''': På sourceforge så kan du [http://sourceforge.net/project/showfiles.php?group_id=25770 ladda ner] gramps_zzz.deb och gramps-help_zzz.deb. Installera med din pakethanterare.
* '''SuSE''': Richard Bos har tillhandahållit en variant av GRAMPS för SuSEs apt-förråd. I [http://software.opensuse.org/download/home:/rbos/ hans förråd] finns alltid den senaste versionen. Se även [http://www.suseforums.net/index.php?s=22f80a050a1e3cffffd590db0813dea9&showtopic=28727&pid=152093&st=0&#entry152093. den här forumtråden].
+
* '''SuSE''': Richard Bos har tillhandahållit en variant av Gramps för SuSEs apt-förråd. I [http://software.opensuse.org/download/home:/rbos/ hans förråd] finns alltid den senaste versionen. Se även [http://www.suseforums.net/index.php?s=22f80a050a1e3cffffd590db0813dea9&showtopic=28727&pid=152093&st=0&#entry152093. den här forumtråden].
 
* '''Mandriva''': Paket för Mandriva finns tillgängliga via urpmi från [http://seerofsouls.com/ SeerOfSouls.com].
 
* '''Mandriva''': Paket för Mandriva finns tillgängliga via urpmi från [http://seerofsouls.com/ SeerOfSouls.com].
* '''Fedora''': Alternativet till att installera från källkod (beskrivs längre ner) är att {{call lang|fedora rpm|sv|bygga ett paket}} från en rpm spec-fil, eller installera en binärfil från Fedora testing.
+
* '''Fedora''': FC6->FC8 [http://sourceforge.net/project/showfiles.php?group_id=25770 ladda ner]. Alternativet till att installera från källkod (beskrivs längre ner) är att {{call lang|fedora rpm|sv|bygga ett paket}} från en rpm spec-fil, eller installera en binärfil från Fedora testing.
 
* '''Debian''': den senaste versionen installeras direkt i unstable och kan uppgraderas från din pakethanterare. Testing uppdateras 10 dagar senare (förutom strax innan en stabil version).
 
* '''Debian''': den senaste versionen installeras direkt i unstable och kan uppgraderas från din pakethanterare. Testing uppdateras 10 dagar senare (förutom strax innan en stabil version).
  
''Notera: Vissa linuxdistributioner kan använda en något annorlunda metod för att ladda ner- och installera GRAMPS-paket. Var vänlig läs din distributions särskilda installationsanvisningar innan du laddar ner.''
+
''Notera: Vissa linuxdistributioner kan använda en något annorlunda metod för att ladda ner- och installera Gramps-paket. Var vänlig läs din distributions särskilda installationsanvisningar innan du laddar ner.''
  
I alla övriga fall så måste du [http://sourceforge.net/project/showfiles.php?group_id=25770 ladda ner] källkodspaketet zzz.tar.gz, och installera GRAMPS manuellt. Se detaljer nedan.
+
I alla övriga fall så måste du [http://sourceforge.net/projects/gramps/files/Stable/ ladda ner] källkodspaketet zzz.tar.gz, och installera Gramps manuellt. Se detaljer nedan.
  
==Windows, BSD, MacOs, Solaris==
+
=Windows=
  
För Windows finns ett experimentellt {{call lang|Windows installer|sv|installationsprogram}}. Vill du ha nyare versioner av GRAMPS till Windows så måste du vänta tills ett nytt installationsprogram har gjort dem tillgängliga.
+
==Ladda hem Gramps för Windows==
 +
 
 +
Ta först reda på vilken variant av Windows Du har på din dator. Är det en 32-bitars eller en 64-bitars dator?
 +
 
 +
Gramps installationsfiler finns på [http://sourceforge.net/projects/gramps/files/Stable/3.4.1/ http://sourceforge.net/projects/gramps/files/Stable/3.4.1/]
 +
 
 +
Har Du en 32-bitars dator väljer du filen med 'AIO32' i namnet och för en 64-bitars filen med 'AIO64' i namnet. Spara ned filen i 'tmp'-katalogen eller en 'downloads'-katalog om Du använder en sådan.
 +
 
 +
==Installera Gramps på din dator==
 +
 
 +
 
 +
==Starta Gramps för första gången==
 +
 
 +
==Inställningar i Gramps==
 +
 
 +
=BSD, MacOs, Solaris=
  
 
För BSD, MacOS och Solaris så återfinner du experimentella installationsanvisningar här nedan.
 
För BSD, MacOS och Solaris så återfinner du experimentella installationsanvisningar här nedan.
 +
FreeBSD, [http://portsmon.freebsd.org/portoverview.py?category=science&portname=gramps /usr/ports/science/gramps]
  
==Gnome och KDE==
+
=Gnome och KDE=
  
Du kan använda båda, men GRAMPS passar bättre ihop med GNOME. För KDE finns några mindre problem vilka beror på egenskaper hos (GTK) och ligger utanför GRAMPS kontroll. Se {{call lang|KDE page|sv|sidan om KDE}} för att läsa om vilka dessa problem kan vara.
+
Du kan använda båda, men Gramps passar bättre ihop med GNOME. För KDE finns några mindre problem vilka beror på egenskaper hos (GTK) och ligger utanför Gramps kontroll. Se {{call lang|KDE page|sv|sidan om KDE}} för att läsa om vilka dessa problem kan vara.
  
=Ytterligare programvara som GRAMPS kan dra nytta av=
+
=Ytterligare programvara som Gramps kan dra nytta av=
GRAMPS är inte beroende av följande program, men att ha dem installerade kan öka din produktivitet:
+
Gramps är inte beroende av följande program, men att ha dem installerade kan öka din produktivitet:
  
 
* '''Gnome-print''': Lägger till möjligheten att skriva ut direkt, att förhandsgranska och att generera fullt internationaliserade PS- och PDF-utskrifter. I dag så måste man installera gnome-python-desktop för att komma över detta paket (det kan också finnas under andra namn, exempelvis python-gnome2-desktop hos Debian).
 
* '''Gnome-print''': Lägger till möjligheten att skriva ut direkt, att förhandsgranska och att generera fullt internationaliserade PS- och PDF-utskrifter. I dag så måste man installera gnome-python-desktop för att komma över detta paket (det kan också finnas under andra namn, exempelvis python-gnome2-desktop hos Debian).
Line 42: Line 65:
 
* '''Graphviz''', '''Inkscape''': Gramps kan skapa fina släktträd (relationsgrafer). Dessa genereras av Graphviz, vilken definierar en kod (dot), likväl som program för att producera grafer (dotty, kan anropas från kommandoraden). Det här ger dig som forskare största möjliga kontroll över ditt träds utseende, men har samtidigt en inlärningskurva. Ett alternativ är att skapa en grafisk rapport, konvertera trädet till en svg-fil, som i sin tur kan öppnas/redigeras/förbättras i till exempel Inkscape.
 
* '''Graphviz''', '''Inkscape''': Gramps kan skapa fina släktträd (relationsgrafer). Dessa genereras av Graphviz, vilken definierar en kod (dot), likväl som program för att producera grafer (dotty, kan anropas från kommandoraden). Det här ger dig som forskare största möjliga kontroll över ditt träds utseende, men har samtidigt en inlärningskurva. Ett alternativ är att skapa en grafisk rapport, konvertera trädet till en svg-fil, som i sin tur kan öppnas/redigeras/förbättras i till exempel Inkscape.
 
* '''ttf-freefont''': Användbart True-Type-teckensnitt som stödjer en stor delmängd av Unicode. Fungerar bra med utskrifter från både gnomeprint och graphviz.
 
* '''ttf-freefont''': Användbart True-Type-teckensnitt som stödjer en stor delmängd av Unicode. Fungerar bra med utskrifter från både gnomeprint och graphviz.
 
+
* '''[http://tilloy.net/dev/pyexiv2/overview.html pyexiv2]''' is a module that allows Gramps to read and write metadata embedded in image files. It is used in the Metadata Viewer and Image Metadata gramplets.
Det finns även andra paket som kan vara till användning:
+
 
+
* '''Yelp''': Gnomes hjälpläsare. Tillåter dig att se och läsa GRAMPS-dokumentation på din dator.
+
  
 
=Installera från källkod=
 
=Installera från källkod=
 
==Generella krav==
 
==Generella krav==
  
GRAMPS 2.0 kräver python 2.3 och paketen gnome-python och pygtk2. Modulen gnome-python bör vara version 2.6.0 eller högre. Paketet pygtk bör vara version 2.5.0 eller högre.
+
Gramps {{version}} kräver python 2.6 och paketen pygtk 2.16. Modulen python-gnome-extras/gnome-python2-gtkspell behövs för stavningskontrollen.
  
 
==Att erhålla källkoden==
 
==Att erhålla källkoden==
  
* Den senaste stabila versionen av GRAMPS kan laddas ner från [http://sourceforge.net/projects/gramps GRAMPS SourceForge page]. Just nu så är detta gramps-2.2.7.tar.gz. Extrahera denna fil i en mapp: <code>
+
* Den senaste stabila versionen av Gramps kan laddas ner från [http://sourceforge.net/projects/gramps Gramps SourceForge page]. Extrahera denna fil i en mapp: <code>
 
   tar xzvf gramps-zzz.tar.gz
 
   tar xzvf gramps-zzz.tar.gz
 
</code> och gå sedan till denna mapp:<code>
 
</code> och gå sedan till denna mapp:<code>
 
   cd gramps-zzz
 
   cd gramps-zzz
 
</code>
 
</code>
* Om du är intresserad av att prova de senaste utvecklingsversionerna av GRAMPS så kan dessa införskaffas från SVN, se {{call lang|Brief introduction to SVN|sv|kort introduktion till SVN}}. SVN-versionen av GRAMPS kan vara mycket farlig eftersom den inte har genomgått några genomgripande tester. Den kan vara benägen att krascha och orsaka omfattande dataförluster. Använd den med försiktighet.
+
* Om du är intresserad av att prova de senaste utvecklingsversionerna av Gramps så kan dessa införskaffas från SVN, se {{call lang|Brief introduction to SVN|sv|kort introduktion till SVN}}. SVN-versionen av Gramps kan vara mycket farlig eftersom den inte har genomgått några genomgripande tester. Den kan vara benägen att krascha och orsaka omfattande dataförluster. Använd den med försiktighet.
  
 
Nu är tiden kommen att läsa filerna INSTALL och README som medföljer koden. De innehåller den mest aktuella informationen.
 
Nu är tiden kommen att läsa filerna INSTALL och README som medföljer koden. De innehåller den mest aktuella informationen.
Line 65: Line 85:
 
==Installera från källkod på Linux==
 
==Installera från källkod på Linux==
  
GRAMPS tillhandahåller ett skript som kan användas för att förbereda koden innan den byggs. Detta skript anropar automatiskt standardkonfigurationsskriptet:<code>
+
Gramps tillhandahåller ett skript som kan användas för att förbereda koden innan den byggs. Detta skript anropar automatiskt standardkonfigurationsskriptet:<code>
 
   ./autogen.sh</code>
 
   ./autogen.sh</code>
  
Detta skript kommer att rapportera eventuella saknade beroenden. Installera dessa (se även filen INSTALL). Att bygga från källkod kräver vanligtvis att utvecklingsversionerna av de nödvändiga biblioteken finns installerade. Du kanske överväger att ställa in en prefix path med autogen.sh, se filen INSTALL för instruktioner. Standard install is in
+
Detta skript kommer att rapportera eventuella saknade beroenden. Installera dessa (se även filen INSTALL). Att bygga från källkod kräver vanligtvis att utvecklingsversionerna av de nödvändiga biblioteken finns installerade. Du kanske överväger att ställa in en prefix path med autogen.sh, se filen INSTALL för instruktioner.
  
 
Så snart en lyckad körning av autogen.sh har utförts så kan du som vanligt genomföra:<code>
 
Så snart en lyckad körning av autogen.sh har utförts så kan du som vanligt genomföra:<code>
 
   make
 
   make
   make install</code>
+
   sudo make install</code>
  
 
==Installera från källkod på BSD==
 
==Installera från källkod på BSD==
Line 80: Line 100:
 
==Installera från källkod på Mac OS X==
 
==Installera från källkod på Mac OS X==
  
En del användare har lyckats installera GRAMPS på Mac OS X. Se {{call lang|Mac OS X|sv|sidan om Mac OS X}} för detaljer. Skriv gärna en rad här på wikin om du har lyckats installera GRAMPS på OS X.
+
En del användare har lyckats installera Gramps på Mac OS X. Se {{call lang|Mac OS X|sv|sidan om Mac OS X}} för detaljer. Skriv gärna en rad här på wikin om du har lyckats installera Gramps på OS X.
  
 
==Installera från källkod på Windows==
 
==Installera från källkod på Windows==
  
På grund av beroenden så är det svårt att installera GRAMPS på Windows. Lyckligtvis så har några användare skapat ett installationsprogram som förenklar detta. Se {{call lang|Windows installer|sv|sidan om Windows installationsprogram}} för mer information. Använd denna på egen risk! Utvecklarna av GRAMPS tillhandahåller plats för denna installationssida men är inte ansvariga för den!
+
På grund av beroenden så är det svårt att installera Gramps på Windows. Lyckligtvis så har några användare skapat ett installationsprogram som förenklar detta. Se {{call lang|Windows installer|sv|sidan om Windows installationsprogram}} för mer information. Använd denna på egen risk! Utvecklarna av Gramps tillhandahåller plats för denna installationssida men är inte ansvariga för den!
 +
 
 +
Det finns numera också AIO-versioner av Gramps för Windows. (AIO = All In One.) Här finns samtliga beroende med och installeras med Gramps i en egen katalog.
 +
Se http://www.gramps-project.org/wiki/index.php?title=Download
  
 
==Installera från källkod på Solaris==
 
==Installera från källkod på Solaris==
  
Tidigare versioner av GRAMPS kunde köras på Solaris men vi känner inte till några nyare fall där detta har skett. Om du med lyckat resultat har installerat GRAMPS på Solaris, var god uppdatera {{call lang|Solaris page|sv|sidan om Solaris}}.
+
Tidigare versioner av Gramps kunde köras på Solaris men vi känner inte till några nyare fall där detta har skett. Om du med lyckat resultat har installerat Gramps på Solaris, var god uppdatera {{call lang|Solaris page|sv|sidan om Solaris}}.
  
 
[[Category:Sv:Dokumentation|Installation]]
 
[[Category:Sv:Dokumentation|Installation]]
 
{{languages|Installation|GRAMPS:Installation}}
 

Revision as of 23:04, 25 January 2013


Live CD

Om du är intresserad av Gramps men inte vill- eller kan installera det (datorn är inte din, datorn kör Windows, du har inget Internet hemma, du sitter vid en arbetsdator etc) så kan du testa vår Linux Genealogy CD. Den körs utan att installeras på hårddisken och innehåller en samling fria genealogiprogram licensierade som Open Source. Du kan sedan installera Ubuntu 10.10 och Gramps från CD:n när du vill.

Enkel nedladdning och installation av Gramps

Innan du laddar ner så bör du först kontrollera så att inte den version av Gramps som medföljer din distribution är den senaste:

  • Debian, (K, X, Edu)Ubuntu, Mepis, Suse:
  sudo apt-get install gramps
  • Gentoo (and Sabayon):
  sudo emerge gramps 
  • Mandriva:
  sudo urpmi gramps
  • Redhat, Fedora, CentOS...:
  sudo yum install gramps

Uppgradera till den senaste versionen

Om din version av Gramps inte är den senaste så erbjuder en del användare uppdaterade paket för vissa distributioner:

  • Ubuntu: På sourceforge så kan du ladda ner gramps_zzz.deb och gramps-help_zzz.deb. Installera med din pakethanterare.
  • SuSE: Richard Bos har tillhandahållit en variant av Gramps för SuSEs apt-förråd. I hans förråd finns alltid den senaste versionen. Se även den här forumtråden.
  • Mandriva: Paket för Mandriva finns tillgängliga via urpmi från SeerOfSouls.com.
  • Fedora: FC6->FC8 ladda ner. Alternativet till att installera från källkod (beskrivs längre ner) är att bygga ett paket från en rpm spec-fil, eller installera en binärfil från Fedora testing.
  • Debian: den senaste versionen installeras direkt i unstable och kan uppgraderas från din pakethanterare. Testing uppdateras 10 dagar senare (förutom strax innan en stabil version).

Notera: Vissa linuxdistributioner kan använda en något annorlunda metod för att ladda ner- och installera Gramps-paket. Var vänlig läs din distributions särskilda installationsanvisningar innan du laddar ner.

I alla övriga fall så måste du ladda ner källkodspaketet zzz.tar.gz, och installera Gramps manuellt. Se detaljer nedan.

Windows

Ladda hem Gramps för Windows

Ta först reda på vilken variant av Windows Du har på din dator. Är det en 32-bitars eller en 64-bitars dator?

Gramps installationsfiler finns på http://sourceforge.net/projects/gramps/files/Stable/3.4.1/

Har Du en 32-bitars dator väljer du filen med 'AIO32' i namnet och för en 64-bitars filen med 'AIO64' i namnet. Spara ned filen i 'tmp'-katalogen eller en 'downloads'-katalog om Du använder en sådan.

Installera Gramps på din dator

Starta Gramps för första gången

Inställningar i Gramps

BSD, MacOs, Solaris

För BSD, MacOS och Solaris så återfinner du experimentella installationsanvisningar här nedan. FreeBSD, /usr/ports/science/gramps

Gnome och KDE

Du kan använda båda, men Gramps passar bättre ihop med GNOME. För KDE finns några mindre problem vilka beror på egenskaper hos (GTK) och ligger utanför Gramps kontroll. Se sidan om KDE för att läsa om vilka dessa problem kan vara.

Ytterligare programvara som Gramps kan dra nytta av

Gramps är inte beroende av följande program, men att ha dem installerade kan öka din produktivitet:

  • Gnome-print: Lägger till möjligheten att skriva ut direkt, att förhandsgranska och att generera fullt internationaliserade PS- och PDF-utskrifter. I dag så måste man installera gnome-python-desktop för att komma över detta paket (det kan också finnas under andra namn, exempelvis python-gnome2-desktop hos Debian).
  • Stavningskontroll: Genom att installera python-gnome2-extras så får du modulen gtkspell, vilken lägger till stavningskontroll i noteringar
  • Graphviz, Inkscape: Gramps kan skapa fina släktträd (relationsgrafer). Dessa genereras av Graphviz, vilken definierar en kod (dot), likväl som program för att producera grafer (dotty, kan anropas från kommandoraden). Det här ger dig som forskare största möjliga kontroll över ditt träds utseende, men har samtidigt en inlärningskurva. Ett alternativ är att skapa en grafisk rapport, konvertera trädet till en svg-fil, som i sin tur kan öppnas/redigeras/förbättras i till exempel Inkscape.
  • ttf-freefont: Användbart True-Type-teckensnitt som stödjer en stor delmängd av Unicode. Fungerar bra med utskrifter från både gnomeprint och graphviz.
  • pyexiv2 is a module that allows Gramps to read and write metadata embedded in image files. It is used in the Metadata Viewer and Image Metadata gramplets.

Installera från källkod

Generella krav

Gramps 4.1.3 kräver python 2.6 och paketen pygtk 2.16. Modulen python-gnome-extras/gnome-python2-gtkspell behövs för stavningskontrollen.

Att erhålla källkoden

  • Den senaste stabila versionen av Gramps kan laddas ner från Gramps SourceForge page. Extrahera denna fil i en mapp:
  tar xzvf gramps-zzz.tar.gz

och gå sedan till denna mapp:

  cd gramps-zzz

  • Om du är intresserad av att prova de senaste utvecklingsversionerna av Gramps så kan dessa införskaffas från SVN, se kort introduktion till SVN. SVN-versionen av Gramps kan vara mycket farlig eftersom den inte har genomgått några genomgripande tester. Den kan vara benägen att krascha och orsaka omfattande dataförluster. Använd den med försiktighet.

Nu är tiden kommen att läsa filerna INSTALL och README som medföljer koden. De innehåller den mest aktuella informationen.

Installera från källkod på Linux

Gramps tillhandahåller ett skript som kan användas för att förbereda koden innan den byggs. Detta skript anropar automatiskt standardkonfigurationsskriptet:

  ./autogen.sh

Detta skript kommer att rapportera eventuella saknade beroenden. Installera dessa (se även filen INSTALL). Att bygga från källkod kräver vanligtvis att utvecklingsversionerna av de nödvändiga biblioteken finns installerade. Du kanske överväger att ställa in en prefix path med autogen.sh, se filen INSTALL för instruktioner.

Så snart en lyckad körning av autogen.sh har utförts så kan du som vanligt genomföra:

  make
  sudo make install

Installera från källkod på BSD

Att installera på BSD är lika rättframt som på Linux, frånsett några småsaker som att verktyg kan ha andra namn. Se sidan om BSD för detaljer.

Installera från källkod på Mac OS X

En del användare har lyckats installera Gramps på Mac OS X. Se sidan om Mac OS X för detaljer. Skriv gärna en rad här på wikin om du har lyckats installera Gramps på OS X.

Installera från källkod på Windows

På grund av beroenden så är det svårt att installera Gramps på Windows. Lyckligtvis så har några användare skapat ett installationsprogram som förenklar detta. Se sidan om Windows installationsprogram för mer information. Använd denna på egen risk! Utvecklarna av Gramps tillhandahåller plats för denna installationssida men är inte ansvariga för den!

Det finns numera också AIO-versioner av Gramps för Windows. (AIO = All In One.) Här finns samtliga beroende med och installeras med Gramps i en egen katalog. Se http://www.gramps-project.org/wiki/index.php?title=Download

Installera från källkod på Solaris

Tidigare versioner av Gramps kunde köras på Solaris men vi känner inte till några nyare fall där detta har skett. Om du med lyckat resultat har installerat Gramps på Solaris, var god uppdatera sidan om Solaris.