Start with Genealogy/pl

From Gramps
Jump to: navigation, search

Jak zacząć z Genealogią za pomocą Gramps?

Przygotowania

If you are just starting your genealogy, it's best to begin with yourself, and add other people as they connect with you.

One of the most important things in genealogy is that you record how and where you found/deduced the information. This is known as a Source. What makes this so important is at a later time you will need or want to revisit this information. Having a source for your information will also create trust with other researchers

So, if you begin with yourself, you are interviewing yourself, which is a primary source on the subject. From this primary source you obtain events such as birth day, baptize day, graduation, ... . The source of the events allows you to deduce a person existed, as part of a family. With this, we have our main terms for genealogy: sources, events, persons and families. Apart from these, Gramps allows you to store Notes, Places, Media (pictures, movies, documents), and Repository.

So, let's now start with adding information into Gramps.

Tworzenie drzewa rodzin

(Ver. 3.3.1-1)

It is assumed here, that you have just installed Gramps and starting your first family tree.

As a first step, in the toolbar click on the family tree icon to open the family tree manager called Family Trees - Gramps. In the pop up window click on the New button (on the right). Now under the title Family tree name (to the left) enter a name for your tree and then click on the Load Family Tree button (bottom right). Gramps will now open with your newly created tree.

Gramps Main page is divided into separate panes, a Toolbar at the top, a left side bar (Navigator) allowing you to navigate different views of your data, a view area showing the data (center), and the right side pane (Sidebar) and a bottom bar (Bottombar) that can be used for Gramplets, (Gramplets covered later). Most of these panes can be turned on or off by going to the word View at the top of the window and check (on) or uncheck (off) the view.

Tworzenie źródła

(Ver. 3.3.1-1)

As you start with yourself, and the source is the interview with yourself, in the left sidebar called Navigator click on the source icon. In the toolbar click on Add (or CTRL+INSERT on the keyboard) to open the source editor.

Assuming your name is John Doe, you now make a source for the interview with yourself! So enter:

  • Title: Interview with John Doe
  • Author: John Doe

And click on OK.

That is it, your first source. In the source view you will see Gramps added an ID to your source. You can change the format of this ID in Edit->Preferences->ID Formats.

Before continuing, let's show how to change the interface. In the toolbar of Gramps, the last icon is the Configure the active view, so click it to see how you can adapt the view. Activate the 'Last Changed' Column and by dragging, change eg 'Author' to be the second column. Most views have this configuration option, so change these to your liking!

Dodawanie danych do źródła

(Ver. 3.3.1-1)

Before you begin, you should know that Gramps does not store your media, it only stores a link to where the media is on your hard disk. So decide where you will store your pictures, videos, sounds, and documents. Then on the menu bar select Edit->Preferences and the General tab. Set the value of Base path for relative media paths to this directory. Click on the Close button to save your changes. Keep your media documents well structured in this directory.

Now lets continue with adding some more data to the source. Double click on it (or press Enter) to open the source 'Interview with John Doe'. Look at the tab pages at the bottom of the source editor: Notes, Gallery, Data, Repositories, References. Surely you have a picture of yourself! Let's add it to the Gallery of this source.

Click on the Gallery tab, and then on the little Add icon just below the Notes tab. This opens a dialog to select the image of yourself. At the bottom of this dialog is a box Title: to set a nice title such as 'Picture of John Doe'. Entering a title does not change the file name. Make sure you select 'Convert to a relative path'. Press OK. You will now see the Media Reference Editor. The top of this dialog allows to select a region of the picture, eg when you have selected a group photo, it makes sense to indicate who on the photo is John Doe. You can use the mouse in the preview picture to select the part of the picture of interest (click down is corner 1 and click release is corner 2). Click OK to save the image and go back to the source editor you where working on.

Suppose you have a typed out text of the interview. In that case you can add the textual document (odt, doc, rtf, etc ...) in the Gallery, but you can also store the text as a Note in Gramps. The good thing about using a note is that Gramps can search the text of notes with filters. So, click on the Notes tab, click the Add icon, and you are presented with a basic editor that you can type or past text into.

When finished, press OK on the source editor, and your source 'Interview with John Doe' now has also a note and picture.

To see these, you would have to open the editor again. However, Gramps has a bottom pane that can show you information on the selected entry in the source view. For that, activate in the menu View the Bottombar. You will see a number of tabs which allow to show information. The elements showing information are called Gramplets in Gramps. Gramplets are small plugins that can perform all kinds of tasks. You can add one to the bottombar by using left-click with the mouse on the bottombar next to the tabs.

Czas na pierwszą osobę

(Ver. 3.3.1-1)

So much done, and not yet one single person is present in your family tree! Time to change that. Let's add yourself. As all information you will add comes from the source 'Interview with John Doe', we first store this in an easy to reach place. In the toolbar click on the Clipboard icon to open the clipboard. Drag and drop, from the source view, the source 'Interview with John Doe', into the Clipboard. Your source is now stored in the Clipboard and this window can be closed.

In the Navigator, click on the Person icon to see the person view. Note that on the Toolbar there is a pressed in button (3rd button from the right) indicating the type of person view you have activated. Try the other possibility once to see what changes. Many Categories in the Navigator have more than one view!

Click now on the Add button on the Toolbar to add your first person. You now see the person editor, and the top part of this should be what you expect: all information about the name of this person. So, type in your given name, and your surname. If you are eg. Spanish and have a very long surname, then click on the Add icon after the surname to enter multiple surnames. See the manual for more details. Now select your Gender.

As you enter data, you need to add where you obtained this data (Source). For this, click on the Sources tab, then open the Cliboard form the Toolbar, drag the source you stored in the clipboard, into the area under ID |Title | Auth | Page of the Person Editor. This will open up the 'Source Reference Editor'. The bottom part of this editor is the same source as already entered, but the top part is new, and contains the data on how the information of the person was found in this source and how certain you are of it. For this interview you can set Confidence to Very High.

You already have a picture of yourself, as you added it to the source. You can now add this same picture to this Person record you are creating. For this, click on the Gallery tab of the person editor, and click on the Share button. This will open a list of all media objects. Select the one you made earlier and click OK to store everything. You could also have used the clipboard: or by adding the picture there from the media view, or by adding the media reference in the clipboard by dragging it from the gallery of an object to the clipboard, and then using it from there where you need it.

Save everything by clicking OK until you see the main Gramps view again.

Zdarzenia

(Ver. 3.3.1-1)

Next, you will want to add your birthday. For this, open the person editor of yourself, by double clicking on your name. Note that the Events tab is open. Click on the Add icon to add an event. Gramps preselects the birth event for the first event that you want to add. Enter your birth date as: (12/31/1900 - Month/Day/Year) or (1 Jan 1900 - Day Month Year). If you use Day Month Year, the Month must be entered with the first 3 letters only or it must be spelled out completely.

You can also click on the Calendar button on the right. This window allows you to select the Day Month and Year with a drop down menu. When using this make sure that the Quality is set to Regular and Type is set to Regular. After entering your birth date click on OK to save it.

Next, because you have no Places in your database you need to create one. Knowing the place where you where born, click on the Add icon after the Place entry to create this place. Enter places as City/Town, Township, County, State, Country or any combination of these. Such as Germantown, German Township (Twp), Montgomery County (Co.), Ohio, USA. Being consistent when adding places will be helpful later when you can select these from the Select an existing place icon. Adding latitude and longitude will allow these places to be positioned on a map later.

Don't forget to Source this. Click the Source tab, open the Clipboard, drag and drop your source, select the Confidence level, and save with the OK button.

Note that the editor that has opened is the Event Reference Editor. This means that there is a global part that you can share with other people (the bottom of the editor), and a top part which is unique to the person. This top part is used to enter the Role of the person in the event. In your own birth, you have the primary role. If you know the name of people helping in the birth, and you want to store these people also, you can share this event with them, with a Role of Aide. You can type a custom role in the Role field if you are not happy with the predefined possibilities.

Again, add a source to the event via the Sources tab, like you did before. As you have no real recollection of your own birth, the interview should not have confidence 'Very High'! You would need to add a birth document as source for that.

When done, click OK to save the event, and then again to safe the person, and you have your first full person record.

Rodzina

You now have entered yourself, time to add your parents. You could add your father and mother as you added yourself, and then connect them in a family, but most people will do things in one go via the RelationshipsRelationship View or one of the AncestryPedigree View. Let's go to the Relationship view: select yourself in the person view, and then in the navigator, select the relationship view. This view has a toolbar that allows to add parents or to add a spouse. Click on the Add parents icon to open the family editor.

In the family editor you will see that you are present in the Children tab. Use the Add icon next to father and mother to add them as you have added yourself. Use the Add icon in the Children tab to add your siblings. You need to use drag and drop to sort siblings in the order as you want them to appear in reports (normally oldest to youngest I suppose).

In the family editor you can also add events. We call these family events as they are shared by the two parents. Typically this is Engagement, Marriage, .... In these the Role is 'Family'. It is not needed to add these events also individually to the two parents!

When done, click OK to safe the family, and you will return to the relationship view with all the extra information visible. From within this view you can navigate to other people and keep enlarging your family tree.

Raport

Now that you have a first small family tree, make a report. Go to the oldest grandparent you have in the relationship view or the person view (you can set bookmarks on people and set a home person!). With this person selected, go in the menu Reports->Text Reports->Detailed descendant report, to create a nice textual descendant report.

Co dalej?

Gramps has many features, as you improve, take the time to go over the manual and learn more. Use the mailing list to discuss issues.

Powiązane artykuły

Screencasts