Solaris Platforms

From Gramps
Revision as of 12:41, 22 June 2008 by Martinch (Talk | contribs)

Jump to: navigation, search

GRAMPS 3.0.1 has been successfully installed on both Solaris SPARC and X86 platforms by building from source, no known packages exist for installation. The latest release of the OpenSolaris X86 is available here.

  • Install dependencies. Even with the latest releases of OpenSolaris a number of missing dependencies need to be resolved before you can install GRAMPS Berkeley DB, Python BSDDB Interface, Python ReportLab. You will need to install these dependencies before you can move forward and install GRAMPS.
    • Installing Berkeley DB. Download the latest BSDDB core from Oracle.

Note: the --prefix=/usr is a must under Solaris, without it being listed at this location the Python BSDDB interface fails to locate the db location.

% gtar zxfB db-4.5.20.tar.gz
% cd db-4.5.20/build_unix
% ../dist/configure --prefix=/usr
% gmake
% su
# gmake install

  • Configure GRAMPS. All you need to do is run the configure script:

If you have built Gnome or Python with iconv libraries other than what Solaris comes with (the GNU version for example), you can specify to GRAMPS where to find them:

  ICONV=/dir/to/iconv ./configure

Other options to configure that are useful include telling it to setup GRAMPS to install in a directory of your choosing instead of the default:

  ./configure --prefix=/your/dest/dir
  • make and install
  make install