Difference between revisions of "Solaris Platforms"

From Gramps
Jump to: navigation, search
Line 5: Line 5:
 
** '''Installing Berkeley DB'''. Download the latest BSDDB core from [http://www.oracle.com/technology/software/products/berkeley-db/db Oracle].   
 
** '''Installing Berkeley DB'''. Download the latest BSDDB core from [http://www.oracle.com/technology/software/products/berkeley-db/db Oracle].   
 
'''Note:''' the ''--prefix=/usr'' is a must under Solaris, without it being listed at this location the Python BSDDB interface fails to locate the db location.
 
'''Note:''' the ''--prefix=/usr'' is a must under Solaris, without it being listed at this location the Python BSDDB interface fails to locate the db location.
 
 
  % gtar zxfB db-4.7.25.tar.gz
 
  % gtar zxfB db-4.7.25.tar.gz
 
  % cd db-4.7.25/build_unix
 
  % cd db-4.7.25/build_unix
Line 16: Line 15:
 
  % cd bsddb3-4.7.0
 
  % cd bsddb3-4.7.0
 
  % python setup.py build
 
  % python setup.py build
 +
Found Berkeley DB 4.7 installation.
 +
  include files in /usr/include
 +
  library files in /usr/lib
 +
  library name is libdb-4.7
 +
  running build
 +
  running build_py
 +
  running build_ext
 
   
 
   
this should find your installed bsddb3 returning something like:
 
 
    Found BerkeleyDB 4.5 installation.
 
      include files in /usr/local/BerkeleyDB.4.5/include
 
      library files in /usr/local/BerkeleyDB.4.5/lib
 
  library name is libdb-4.5
 
 
Finally install Python BSDDB Interface
 
 
 
  % su
 
  % su
 
  # python setup.py install
 
  # python setup.py install

Revision as of 12:50, 22 June 2008

GRAMPS 3.0.1 has been successfully installed on both Solaris SPARC and X86 platforms by building from source, no known packages exist for installation. The latest release of the OpenSolaris X86 is available here.

  • Install dependencies. Even with the latest releases of OpenSolaris a number of missing dependencies need to be resolved before you can install GRAMPS Berkeley DB, Python BSDDB Interface, Python ReportLab. You will need to install these dependencies before you can move forward and install GRAMPS.
    • Installing Berkeley DB. Download the latest BSDDB core from Oracle.

Note: the --prefix=/usr is a must under Solaris, without it being listed at this location the Python BSDDB interface fails to locate the db location.

% gtar zxfB db-4.7.25.tar.gz
% cd db-4.7.25/build_unix
% ../dist/configure --prefix=/usr
% gmake
% su
# gmake install
    • Installing Python BSDDB Interface. Download bsddb3-4.7.0.tar.gz (version at the time of writing), from [1]
% gtar zxfB bsddb3-4.7.0.tar.gz
% cd bsddb3-4.7.0
% python setup.py build
Found Berkeley DB 4.7 installation.
  include files in /usr/include
  library files in /usr/lib
  library name is libdb-4.7
  running build
  running build_py
  running build_ext

% su
# python setup.py install


  • Configure GRAMPS. All you need to do is run the configure script:
  ./configure

If you have built Gnome or Python with iconv libraries other than what Solaris comes with (the GNU version for example), you can specify to GRAMPS where to find them:

  ICONV=/dir/to/iconv ./configure

Other options to configure that are useful include telling it to setup GRAMPS to install in a directory of your choosing instead of the default:

  ./configure --prefix=/your/dest/dir
  • make and install
  make
  make install