Difference between revisions of "Solaris Platforms"

From Gramps
Jump to: navigation, search
(New page: {{cleanup}} Category:Documentation It is unknown if GRAMPS 2.2.x can be made to work on Solaris. This page contains the old contents for the unspecified Solaris version and unspecified...)
 
Line 5: Line 5:
 
* '''Install dependencies'''. Since Solaris doesn't come with Gnome, Python, or any Python modules by default, you will need to install all this stuff. Gnome might be on one of the extra CDs, but I usually just bring it down from the original site.
 
* '''Install dependencies'''. Since Solaris doesn't come with Gnome, Python, or any Python modules by default, you will need to install all this stuff. Gnome might be on one of the extra CDs, but I usually just bring it down from the original site.
  
* '''Configure GRAMPS'''. All you need to do is run the configure script:
+
* '''Configure GRAMPS'''. All you need to do is run the configure script:<code>
<code>   ./configure</code>
+
  ./configure</code>
If you have built Gnome or Python with <code>iconv</code> libraries other than what Solaris comes with (the GNU version for example), you can specify to GRAMPS where to find them:
+
If you have built Gnome or Python with <code>iconv</code> libraries other than what Solaris comes with (the GNU version for example), you can specify to GRAMPS where to find them:<code>
<code>   ICONV=/dir/to/iconv ./configure</code>
+
  ICONV=/dir/to/iconv ./configure</code>
Other options to configure that are useful include telling it to setup GRAMPS to install in a directory of your choosing instead of the default:
+
Other options to configure that are useful include telling it to setup GRAMPS to install in a directory of your choosing instead of the default:<code>
<code>   ./configure --prefix=/your/dest/dir</code>
+
  ./configure --prefix=/your/dest/dir</code>
  
* '''make and install'''
+
* '''make and install''' <code>
<code>   make
+
  make
 
   make install</code>
 
   make install</code>

Revision as of 19:31, 28 February 2007

Gramps-notes.png
This page needs a cleanup. Please help keep Gramps Wiki a useful resource by refactoring this page. Consider also updating the screenshots.

It is unknown if GRAMPS 2.2.x can be made to work on Solaris. This page contains the old contents for the unspecified Solaris version and unspecified GRAMPS version.

  • Install dependencies. Since Solaris doesn't come with Gnome, Python, or any Python modules by default, you will need to install all this stuff. Gnome might be on one of the extra CDs, but I usually just bring it down from the original site.
  • Configure GRAMPS. All you need to do is run the configure script:
  ./configure

If you have built Gnome or Python with iconv libraries other than what Solaris comes with (the GNU version for example), you can specify to GRAMPS where to find them:

  ICONV=/dir/to/iconv ./configure

Other options to configure that are useful include telling it to setup GRAMPS to install in a directory of your choosing instead of the default:

  ./configure --prefix=/your/dest/dir
  • make and install
  make
  make install