Difference between revisions of "Nl:Bouwen vanuit de broncode"

From Gramps
Jump to: navigation, search
m (Ubuntu en alle afgeleide versies)
Line 63: Line 63:
 
(Kubuntu, Edubuntu, Mepis,LinuxMint,...):  De ubuntu-pakketten kunnen opgehaald worden op [http://sourceforge.net/project/showfiles.php?group_id=25770 Gramps downloadpagina].
 
(Kubuntu, Edubuntu, Mepis,LinuxMint,...):  De ubuntu-pakketten kunnen opgehaald worden op [http://sourceforge.net/project/showfiles.php?group_id=25770 Gramps downloadpagina].
  
{{cleanup|nl}}
+
{{cleanup/nl}}
  
 
{|{{prettytable}}
 
{|{{prettytable}}
Line 175: Line 175:
 
===Free/OpenBSD en Solaris===
 
===Free/OpenBSD en Solaris===
 
Zowel voor BSD en Solaris zijn er experimentele installeerinstructies.  
 
Zowel voor BSD en Solaris zijn er experimentele installeerinstructies.  
* Voor FreeBSD gebruikt u de [http://portsmon.freebsd.org/portoverview.py?category=science&portname=gramps /usr/ports/science/gramps] port.
+
* Voor FreeBSD gebruikt u de [http://portsmon.freebsd.org/portoverview.py?c
* Voor openBSD gebruikt u de [http://openports.se/misc/gramps grampsport]
+
 
+
Indien er toch iets mis gaat in FreeBSD 8.0, lees dan zeker [http://www.gramps-project.org/bugs/view.php?id=3228 ticket 3228]
+
 
+
==Installatie via de broncode==
+
===Algemene vereisten===
+
 
+
GRAMPS {{version}}  vereist python 2.6 of een hogere versie, pygtk 2.16 of hoger, en librsvg2.
+
 
+
====Linux pakketvereisten====
+
 
+
 
+
 
+
 
+
 
+
{|{{Prettytable}}
+
|-
+
|Debian      /Ubuntu
+
|Fedora      /Redhat
+
|Opmerkingen
+
|-
+
| python
+
| python
+
| Vereist (heeft versie 2.6 of hoger nodig)
+
|-
+
| python-gtk2
+
| pygtk2
+
| Vereist (heeft versie 2.16 of hoger nodig)
+
|-
+
| xdg-utils
+
| xdg-utils
+
| Vereist voor Gramps-3.1.x of hoger
+
|-
+
|[http://docs.python.org/library/bsddb.html BSDDB]
+
|[http://docs.python.org/library/bsddb.html BSDDB]
+
| Huidige 'backend'
+
|-
+
| librsvg2-common
+
| librsvg2
+
| Vereist om compileren
+
|-
+
| intltool
+
| intltool
+
| Vereist om te compileren
+
|-
+
| python-pyexiv2
+
| pyexiv2
+
| Vereist voor het metagegevensscherm en de Exif-gramplets
+
|-
+
| libosmgpsmap-dev python-osmgpsmap
+
| osm-gps-map
+
| Vereist voor de geografische schermen
+
|-
+
| libglib2.0-dev
+
| glib2-devel
+
| nodig om te compileren
+
|-
+
|
+
| librsvg2-devel
+
| nodig om te compileren
+
|-
+
|
+
| gcc, make, gettext
+
| nodig om te compileren
+
|-
+
| python-webkit python-gtkmozembed
+
| WebKit-gtk pywebkitgtk
+
| Nodig voor de HTML-scherm
+
|-
+
| python-pygoocanvas
+
| goocanvas pygoocanvas
+
| nodig voor de [[Graph View|kaart]]
+
|-
+
| graphviz
+
| graphviz graphviz-python
+
| nodig voor sommige verslagen en schermen
+
|-
+
|
+
| Django
+
| nodig voor http://gramps-connect.org
+
|-
+
| python-gtkspell
+
| gnome-python2-gtkspell
+
| Aangewezen voor normaal gebruik (spellingscontrole).  Is inbegrepen in het 'python-gnome2-extras'-pakket in oudere Debian distro's.
+
|-
+
| rcs
+
| rcs
+
| Aangewezen voor normaal gebruik
+
|}
+
 
+
Voor Redhat/Fedora kunt u alle bovenstaande nodige programma's installeren met:
+
 
+
<pre>
+
sudo yum install python pygtk2 xdg-utils rcs gnome-python2-gtkspell librsvg2 \
+
  librsvg2-devel gnome-common intltool gnome-doc-utils gcc make gettext WebKit-gtk \
+
  pywebkitgtk goocanvas pygoocanvas graphviz graphviz-python Django
+
</pre>
+
 
+
====De broncode verkrijgen====
+
 
+
Er zijn twee manieren om de broncode te verkrijgen: een stabiele versie ''downloaden'' of de broncode ophalen via '''SVN'''. Dit is dan ook het juiste moment om de [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/INSTALL?view=markup INSTALL] en de [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/README?view=markup README] bestanden te lezen die bij de broncode horen. Ze bevatten de meest recente informatie. Verdere gegevens over de twee manieren:
+
 
+
'''1. Download een stabiele versie'''
+
 
+
* De laatste stabiele versie van Gramps kan verkregen worden via de [http://sourceforge.net/projects/gramps Gramps SourceForge pagina]. Bv. ''gramps-{{version}}.tar.gz''. Unzip dit bestand in een map :
+
<code>
+
  tar xzvf gramps-zzz.tar.gz
+
</code> ga dan naar deze map die aangemaakt werd:<code>
+
  cd gramps-zzz
+
</code>
+
* Indien u geïnteresseerd bent in het testen van de laatste ontwikkelingsversie van GRAMPS, dan kunt u deze versie verkregen via '''SVN''', zie hiervoor de Engelstalige pagina [[Brief introduction to SVN|Introductie tot SVN ]]. Vermits deze pagina tot het ontwikkelingsportaal behoort, wordt deze niet vertaald. De SVN versie van Gramps is potentieel gevaarlijk voor uw normaal gegevensbestand en is hoe dan ook '''niet''' extensief getest. Deze versie kan zonder waarschuwingen vastlopen wat kan leiden tot totaal verlies van de gegevens waarmee u werkt. Gelieve dus met voorzichtigheid te behandelen. Gebruik deze versie enkel voor testdoeleinden.
+
 
+
'''2. Download via SVN'''
+
 
+
U verkrijgt de ''branch''-versie (dezelfde als de hier boven genoemde versie) of de superlaatste ontwikkelingsversie via SVN door het volgende te doen:
+
 
+
svn co https://gramps.svn.sourceforge.net/svnroot/gramps gramps
+
of
+
svn co https://gramps.svn.sourceforge.net/svnroot/gramps/tags/gramps-3.1.3 gramps
+
 
+
om de laatste stabiele ontwikkelingsversie op te halen zie ook [[running a development version of Gramps| hoe een ontwikkelingsversie van Gramps draaien]].
+
 
+
'''3. Tarball via SVN'''
+
 
+
U kunt een gecomprimeerd ''tarball''-bestand met de laatste broncode ophalen:
+
 
+
* [http://gramps.svn.sourceforge.net/viewvc/gramps/branches/maintenance/gramps32/?view=tar 3.2.x]
+
 
+
* [http://gramps.svn.sourceforge.net/viewvc/gramps/branches/maintenance/gramps33/?view=tar 3.3.x]
+
 
+
* [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/?view=tar Trunk]
+
 
+
====GRAMPS opwaarderen====
+
 
+
Indien u reeds een oudere versie van de broncode hebt geïnstalleerd op uw systeem, moet u een beslissing nemen wat u met deze oudere versie wilt doen, voor u een nieuwere versie ophaalt. Wenst u deze oudere versie te behouden, moet u zeker eerst het INSTALL-bestand lezen om de juiste ''--prefix''-optie te gebruiken. Deze optie bepaalt waar de nieuwere versie wordt geïnstalleerd.
+
 
+
Wenst u echter een gewone vervanging te doen, maak dan zeker dan de oudere versie eerst verwijderd wordt. Installeer niet bovenop de oudere versie. De reden hiervoor is dat in de nieuwe versies van Gramps het best kan dat sommige functies in een andere vorm worden geprogrammeerd. Door de oudere versie niet te verwijderen kan het zijn dat de functies die aangepast werden, niet goed werken. Indien u de broncode installeerde via bovenstaande methode kunt u dus best de oude versie verwijderen door<code>
+
  make uninstall</code>
+
 
+
te doen als ''root'' '''maar wel in de map waar u de oude versie installeerde'''. Gebruik de pakketbeheerder van uw distributie indien u de oudere versie via deze weg als een pakket installeerde.
+
 
+
'''Opmerking: u dient uw oude Gramps-versie te gebruiken om eerst via export een reservekopie naar Gramps-XML te maken, voor u de oude versie verwijderd.'''
+
 
+
===Linux===
+
 
+
Gramps voorziet in een 'script' dat gebruikt kan worden om de broncode voor te bereiden op het bouwproces. Dit 'script' roept automatisch het standaard configuratiescript op:<code>
+
  ./autogen.sh als normale gebruiker</code>
+
 
+
Dit script zal eventuele ontbrekende componenten rapporteren. Installeer deze noodzakelijke componenten eerst (zie ook het INSTALL-bestand). Software bouwen vanuit de broncode vereist normaal dat de ontwikkelingsversies (-dev pakketten) van de vereiste bibliotheken geïnstalleerd zijn. U kunt overwegen om een 'prefix'-pad met het autogen.sh script mee te geven, zie het INSTALL-bestand voor instructies. De normale installatie zal gebeuren onder het pad '''usr/local'''.
+
Eenmaal autogen.sh succesvol beëindigd is, kunt u de gebruikelijke<code>
+
make (als normale gebruiker)</code>
+
en vervolgens <code>
+
  make install (als root)</code>
+
methode uitvoeren.
+
 
+
===BSD===
+
 
+
Installatie op BSD is even gemakkelijk als op Linux, op enkele kleine wijzigingen na zoals hulpprogramma's die andere namen hebben. Zie de [[BSD page|BSD pagina (en)]] voor details.
+
 
+
===Mac OS X===
+
Hier vindt u een [[Mac_OS_X|Engelstalig overzicht]] van de installatie vanaf de bron op een Mac.
+
 
+
===Windows===
+
 
+
Gelukkig voor de gebruikers van Microsoft Windows hebben sommige gebruikers een [[Windows installer/nl|windowsinstallatieprogramma]] gemaakt. Tot nu toe zijn eer geen verschillen opgemerkt tussen de officiële ''builds'' en het windowsinstallatieprogramma, dat ziet er dus veelbelovend uit, maar gebruik ervan is toch op uw eigen risico.
+
 
+
===Solaris===
+
 
+
Gramps werd al met succes geïnstalleerd op zowel Solaris 10 (SPARC) en OpenSolaris X86 (2008.05). Zie de [[Solaris Platforms|Solaris pagina]] voor details.
+
 
+
 
+
[[Category:Nl:Documentatie|Installatie]][[Category:Developers/Installation]][[Category:Developers/Packaging]]
+

Revision as of 11:34, 20 May 2012


Laatste uitgegeven versie

De laatste versie is GRAMPS 4.2.0. Misschien is deze versie nog niet beschikbaar voor installatie op uw platform. Kijk ook op deze download-pagina.

GRAMPS opwaarderen

Wanneer u Gramps opwaardeert vanuit een vorige versie, is het aangewezen eerst het volgende doen:

  1. Gebruik uw oude Gramps-versie om uw familiestamboom te exporteren naar het Gramps-XML bestandsformaat (vink de privaat-opties in de exportdialoog uit)
  2. Deinstalleer uw oude Gramps-versie
  3. Installeer de nieuwe versie met onderstaande instructies
  4. Maak een nieuwe familiestamboom aan
  5. Importeer uw oude Gramps XML gegevens

Extra software waar Gramps voordeel uit kan halen

Gramps heeft deze programma's niet echt nodig, maar als u ze beschikbaar heeft zal dat uw productiviteit zeker verhogen.

  • Spellingscontrole: Installatie van gnome-python2-extras en python-enchant maakt de gtkspell- en de enchantmodule beschikbaar. Hiermee is een spellingscontrole mogelijk in opmerkingen die u in Gramps aanmaakt.
  • Graphviz, Inkscape: Gramps kan mooie genealogische stambomen maken (relatiegrafieken). Deze worden gegenereerd met het Graphviz-pakket, dewelke een schema (dot) aanmaakt, alsook programma's om de gemaakte grafieken te editeren (dotty, beschikbaar via een opdrachtregel). Dit heeft u als onderzoeker meer mogelijkheden om te bepalen hoe uw stamboom eruit zal zien (maar let op voor de leercurve). Een alternatief is om een grafisch verslag te maken en uw stamboom om te vormen tot een svg-bestand. Dit bestand kunt u dan openen/aanpassen/verbeteren via bv Inkscape.
  • ttf-freefont: Een set van vrije, hoge-kwaliteit 'TrueType'-lettertypen dat de UCS-tekenset beslaat. Deze lettertypen werken goed voor het normale afdrukken en 'graphviz'-afdrukken.
  • XdgUtils is een verzameling van hulpmiddelen die u via een terminalvenster kan invoeren. Ongeveer de helft van de hulpmiddelen helpt bij het installatie van een desktop omgeving en de andere helft werkt aan de integratie van een toepassing wanneer de desktop omgeving draait. Zelfs wanneer de desktopcomponenten van uw toepassing beperkt zijn tot enkel een installeerder, configuratie of beheerder kan Xdg-utils u toch op een eenvoudige manier een aantal integratieproblemen oplossen.
  • pyexiv2 is een module die het mogelijk maakt om metagegevens die zich in beeldbestanden bevinden, te lezen en te bewerken. Deze module wordt gebruikt voor het scherm dat deze metagegevens toont en in de 'metagegevens'-gramplets.
  • osmgpsmap is een bibliotheek die een GPS-functionaliteit biedt. Dit wordt gebruikt in het geografisch scherm.


Andere pakketten die ook nuttig kunnen zijn:

  • desktop-file-utils: wanneer u rechtsklikt op een mediabestand, geeft dit hulpprogramma lijst van programma's waarmee u dit mediabestand kunt openen.

Linux

Automatisch downloaden en installeren van Gramps

Voor u Gramps downloadt van deze site, kijkt u best eerst na of de pakketbronnen van het Linux systeem van uw computer nog niet de allernieuwste versie beschikbaar heeft. Om te zien welke de huidige versie is, kijkt u op stabiele versie van Gramps op Sourceforge en kijk naar het versienummer van het bovenste pakket in de lijst.

Om te kijken wat er specifiek voor uw Linux-systeem beschikbaar is zijn hieronder een aantal methodes gelijst:

Linux OS Opdrachtregel
Debian gebaseerde systemen
(Ubuntu en alle varianten, Mepis,...)
sudo apt-get install gramps
Gentoo (en Sabayon) sudo emerge gramps
Mandriva sudo urpmi gramps
Redhat gebaseerde systemen
(Fedora, CentOS...)
sudo yum install gramps
OpenSUSE sudo zypper install gramps

Manueel downloaden en installeren van Gramps

Indien u niet via de pakketbronnen van uw distributie de laatste versie kunt halen, moet u deze versie op de site zoeken. Sommige gebruikers hebben pakketten gemaakt voor verschillende systemen. Indien u uw systeem in de lijst ziet staan, hebt u geluk. Indien dat niet zo is, kunt u best de ontwikkelaarspostlijst om hulp vragen.

Ubuntu en alle afgeleide versies

(Kubuntu, Edubuntu, Mepis,LinuxMint,...): De ubuntu-pakketten kunnen opgehaald worden op Gramps downloadpagina.

Gramps-notes.png
Deze bladzijde kan mogelijk geactualiseerd worden. U kan meewerken om deze wiki-Gramps bladzijden bruikbaar te houden door deze pagina van recentere informatie te voorzien. Bekijk zeker ook de schermvoorbeelden en de engelstalige pagina's.
Ubuntu (Versie) Gramps
Versie
Download
(10.10) 3.3.2 gramps_3.3.2-1.deb
(10.04) 3.3.2 gramps_3.3.2-1.deb
(9.10) 3.2.6 gramps_3.2.6-1_Ubuntu09.deb
Jaunty Jackalope (9.04) 3.2.6 gramps_3.2.6-1_Ubuntu09.deb
Intrepid Ibex (8.10) 3.1.3 gramps_3.1.2-1_Ubuntu08.deb
Hardy (8.04) 3.1.3 gramps-3.1.2-1_Ubuntu804.deb
Gutsy (7.10) 3.0.3 gramps_3.0.3-1_ubuntu710.deb
Feisty (7.04) 2.2.10 enkel GRAMPS 2.2.10 beschikbaar, download gramps_2.2.10-1_all.deb
en gramps-help_2.2.10-1_all.deb en installeer met uw pakketbeheerder.
Dapper, Edgy
en vroegere versies Ubuntu
2.2.8 enkel GRAMPS 2.2.8 beschikbaar , download gramps_2.2.8-1dapper1_all.deb
en gramps-help_2.2.8-1dapper1_all.deb en installeer met uw pakketbeheerder.

Debian

Debian: De laatste versie van Gramps is beschikbaar via unstable (Sid Gramps) en kan zo via uw pakketbeheerder geïnstalleerd worden. Testing wordt 10 dagen na unstable aangepast (uitgenomen als er een stabiele Debian release aankomt). Zie ook Gramps testen.


SuSE

SuSE: Richard Bos onderhoudt de Gramps-uitgaven voor OpenSUSE. De pakketbronnen voor OpenSUSE 11.1 zijn beschikbaar op [1]. Let op dat wanneer dit geschreven werd, deze pakketbron niet dezelfde is dan de pakketbronnenlijst: dus moet Education manueel toegevoegd worden aan de URL. De pakketbron voor 11.0 is [2] en voor 10.3 is [3]. Voor eerdere versies van (10.2) zie ook deze forumdiscussie. Zie ook een ander alternatief met openSUSE BuildService in het Engels.

Mandriva

Mandriva: Nieuwere versies van Gramps worden soms omgezet via backports. Om deze backportspakketten te kunnen installeren moet u toelaten dat deze backports kunnen geladen worden via de pakketbronbeheerder. Stel zeker dat u de instructies begrijpt van deze Mandriva wiki. Is de allerlaatste versie niet beschikbaar in de backports pakketbronnen, zoek dan bij de contrib pakketbronnen.

Fedora

Fedora: Voor Fedora Core gaat u naar Gramps-downloadpagina en zoek naar een pakket met fc met het juiste nummer en die eindigt in .rpm. Het andere alternatief is bouwen van de broncode, kijk op het bouwen van een pakket via een rpm spec bestand of een binair bestand installeren via fedora testing.

Slackware

Slackware 13.0: Gramps 3.2.3 is beschikbaar via LinuxPackages.

Andere GNU/Linux distributies

Andere GNU/Linux distributies kunnen licht afwijkende download- en installatiemethodes hebben. Gelieve de specifieke installatie-instructies voor uw distributie te raadplegen alvorens Gramps te downloaden.

In alle andere gevallen moet u de broncode downloaden. Dat is het bronpakket dat eindigt in '.tar.gz'. Dit moet u dan manueel installeren om Gramps op uw computer beschikbaar te stellen. Zie verder voor meer details.

Gnome en KDE

U kunt beide gebruiken, maar GRAMPS past iets beter in de GNOME omgeving.

Voor KDE zijn er enkele kleine probleempjes ten gevolge van (GTK) problemen die buiten de verantwoordelijkheid van GRAMPS liggen. Controleer de Engelstalige KDE pagina om te weten wat die problemen kunnen zijn.

Voor GNOME zijn er enkele problemen met ATK/GAIL die ook niet onder de verantwoordelijkheid van GRAMPS vallen. Controleer daarom de Engelstalige gekende problemen om te weten welke problemen dat juist kan veroorzaken.

Ook kunt u misschien eens kijken naar XdgUtils.

GRAMPS op handhelds

Gramps werkt perfect op sommige kleine pc's. Gebruikers waren succesvol om Gramps te gebruiken op:

Live cd

Bent u geïnteresseerd in Gramps, maar bent u bang om het effectief te installeren, of hebt u niet de mogelijkheid het te installeren (geen eigen computer, geen ondersteunde OS, geen internet thuis, ...), dan kunt u onze Linux Genealogie cd uitproberen. Deze cd laat u toe met Gramps te werken, zonder het programma op uw harde schijf te kopiëren. Verder staat een brede waaier aan OSS-programma's op de CD, allemaal vrij om te gebruiken. U kunt indien, u dit wenst, Ubuntu 10.10 en Gramps vanaf de cd op uw computer installeren.

Windows, FreeBSD, Mac Os X en Solaris

Windows

Kijk op de download pagina voor de Windows installer. Maak zeker dat u alle Windows afhankelijkheden hebt gedownload en geïnstalleerd.

  • Bijkomende informatie voor Windows gebruikers op de voorlopig Engelse pagina GRAMPS and Windows.

Mac OS X

Reeds gebouwde binaire toepassing

Een nieuwe geporteerde versie van Gramps voor Mac is beschikbaar (september 2010). Deze versie is redelijk nieuw en ongetest en zoals steeds is het raadzaam om uw gegevens te kopiëren voor u dit programma gebruikt. Het is beschikbaar als een reeds gebouwde binaire toepassing voor zowel Intel en PPC Macs.

Mac voor Gramps wordt op deze Engelstalige ontwikkelingspagina beschreven.

Bouwen vanaf bronbestanden

Er is ook de mogelijkheid een bouwomgeving te gebruiken voor gelijk welke Mac met de Apple Xcode toolset.

Macports en Fink versies werden vroeger gebruikt.

Een overzicht van de installatie van Gramps op een Mac wordt Installing from source code on Mac OS X hier beschreven.

De laatste versie van MacPorts Gramps is 3.2.0. De laatste officiële stabiele fink versie is 1.0.10 voor Mac OS X 10.4. De laatste officiële onstabiele fink versie is 3.0.4 voor Mac OS X 10.5.

Free/OpenBSD en Solaris

Zowel voor BSD en Solaris zijn er experimentele installeerinstructies.