Nl:GRAMPS 3.0 Wiki Handleiding - Familiestambomen beheren

From Gramps
Jump to: navigation, search

Nu gaan we naar een gedetailleerde verkenning van het dagelijks gebruik van GRAMPS. In dit gedeelte geven we een overzicht van hoe u uw familiestambomen kunt organiseren en uw gegevens te delen met andere genealogen.

Vorige Index Volgende


Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.<br\> Also, only use the known conventions



Een nieuwe familiestamboom starten

Fig 3.1: Familiestambomen beheren


Om een nieuwe familiestamboom te starten kiest u ofwel Familiestambomen ->Familiestambomen beheren ofwel klik de knop Familiestambomen in de werkbalk.

Dit opent het venster familiestambomen.



Selecteer de knop Nieuw en GRAMPS zal een nieuwe item aan de lijst toevoegen.



Om de standaardnaam Family Tree1 te veranderen, klikt u op de naam en voert een nieuwe naam in.


Vervolgens selecteert u de knop Laad familiestamboom om de nieuwe, lege familiestamboom te openen.

Een bestaande familiestamboom openen

Om een familiestamboom te openen, kiest u ofwel Familiestambomen ->Familiestambomen beheren ofwel klikt u op de knop Familiestambomen in de werkbalk. Het Family Tree Manager-venster wordt dan getoond en u krijgt een lijst te zien van alle familiestambomen die GRAMPS kent.


Voor elke geopende familiestamboom wordt een icoon getoond in de kolom: Status. Kies de familiestamboom die u wilt openen en open het bestand met de knop Familiestamboom laden. Of u kan dubbelklikken op de gewenste stamboom.

Op een onlangs geopende stamboom opnieuw te openen, kiest u ofwel Familiestambomen ->Onlangs geopend ofwel de pijl naar beneden die zich rechts van de knop Familiestambomen bevindt. Vervolgens selecteert u de gewenste stamboom uit de lijst.

Indien u geen schrijfrechten hebt voor een bepaalde familiestamboom, wordt het bestand enkel in de modus 'enkel lezen' geopend. Gegevens kunnen dan wel gelezen worden, maar niet veranderd. In de titelbalk van het venster zal, om deze modus aan te geven, de tekst (Enkel lezen) verschijnen.

Een XML-gegevensbestand of een GEDCOM-bestand openen

GRAMPS laat u toe om bepaalde gegevensbestanden die niet opgeslagen zijn in het GRAMPS-formaat, toch te openen. via een opdrachtregel.

TODO link to page explaining how. 

Dit kunnen zowel XML- als GEDCOM-bestanden zijn. Maar u moet beseffen dat, indien deze bestanden vrij groot zijn, er prestatieproblemen kunnen optreden. Bovendien is het zo dat wanneer uw computer crasht al uw gegevens kunnen beschadigd worden. Daarom is het normaal gezien veel beter om een nieuwe familiestamboom aan te maken en dan uw XML/GEDCOM-bestand hierin te importeren.

Gramps-notes.png
Gegevensbestanden openen

XML- en GEDCOM-gegevensbestanden vereisen dat alle gegevens in het computergeheugen aanwezig zijn en geen indexen bevatten. Het eigen GRAMPS-formaat is een gegevensbestand dat enkel de gegevens die nodig zijn in het geheugen behoudt. Dit heeft als voordeel dat voor een groot bestand de gegevens veel sneller toegankelijk zijn en het dus efficiënt is om geen XML/GEDCOM-formaat te gebruiken.

Gnome-important.png
Bewerken van GEDCOM-bestanden

Let op: sommige gegevens kunnen verloren gaan wanneer een GEDCOM-bestand geïmporteerd of geëxporteerd wordt in of uit GRAMPS.

Het bestand enkel openen en raadplegen zal het bestand echter niet veranderen. Als er echter veranderingen gebeurd zijn en die zijn niet geannuleerd voor het sluiten van het bestand, zal GRAMPS bij het afsluiten van het programma, de gegevens opslaan met mogelijk gegevensverlies tot gevolg.

Een familiestamboom verwijderen

Selecteer de familiestamboom die u wenst te verwijderen en klik op de knop: Verwijderen.

Dit zal de familiestamboom volledig verwijderen. U hebt geen mogelijkheid meer om de gegevens op te vragen. U kunt overwegen om een reservekopie van uw gegevens te nemen door uw gegevens te exporteren naar het GRAMPS XML-formaat en dit bestand vervolgens op te slaan.

Een familiestamboom herbenoemen

U kunt een familiestamboom (of een archief) herbenoemen. Dit doet u door de stamboom te selecteren en op Herbenoem te klikken.

U kunt ook op de naam in de lijst van stambomen klikken.

In beide gevallen, geeft u gewoon de nieuwe naam in en de stamboom is herbenoemd.

Een reservekopie van een familiestamboom maken

De veiligste methode om een reservekopie te maken van uw familiestamboom is een export naar het GRAMPS-XML formaat (of het GRAMPS Pakket waar ook bestanden voor uw galerij worden opgeslagen). Vervolgens kopieert u de onstane bestand op een veilige plaats, liefst zelfs in een ander gebouw.

U kunt de archiefeigenschappen benutten om momentopnames te maken van uw familiestamboom. Deze momentopnamen kunnen gebruikt worden als eenvoudige reservekopieën. Ze zijn zeer handig om iets uit te proberen om dan later deze acties misschien te annuleren. Let echter op: deze methode is niet aangewezen om een normale reservekopie te maken. Deze methode overleeft een defect aan uw harde schijf niet, net zomin als de meeste van de andere rampen die bij een computersysteem kunnen voorkomen.

Voor meer ervaren gebruikers: elk gegevensbestand wordt onder een eigen submap geplaast in de /home/user/.gramps map. U kunt een manuele reservekopie maken door deze map te kopieren.

Een familiestamboom archiveren

U kunt zeer eenvoudig familiestambomen archiveren en voorzien van een tijdstempel door gebruik te maken van GNU Revisie Controle Systeem of RCS. Dan moet u wel nakijken of dit programma op uw computer is geïnstalleerd. Het is een klein bestand: voor Ubuntu 8.04 is de versie 5.7-21.

Het GNU RCS systeem controleert de verscheidene bestandsrevisies. RCS automatiseert de opslag, het opnieuw terughalen, het bijhouden van een logboek, de identificatie en het samenvoegen van revisies. RCS is bruikbaar voor tekst die zeer vaak aangepast wordt, zoals in programmabestanden, documentatie, grafieken en brieven.

Om een archief aan te maken moet u eerst zeker stellen dat de familiestamboom geopend is. Selecteer vervolgens de geopende stamboom en klik op de Archiveer knop. Het archief wordt nu getoond in de lijst, onder de oorspronkelijke stamboom. Archieven kunnen eveneens verwijderd en herbeneoemd worden.

Een familiestamboom herstellen

Een versie kiezen om te herstellen
Herstelde versie




Dit kan eenvoudig door het archief te selecteren en dan op de Herstellen knop te klikken.






GRAMPS zal het archief importeren in een nieuwe familiestamboom. De naam van deze stamboom zal gebaseerd zijn op de originele naam en de archiefnaam.

Een familiestamboom ontgrendelen

Wanneer GRAMPS een familiestamboom opent, wordt deze stamboom vergrendeld zodat niemand, ook uzelf, deze familiestamboom opnieuw zou openen. Een tweede versie van GRAMPS kan een familiestamboom openen, maar de familiestamboom die reeds geopend is, zal met een slot icoon verschijnen zodat u weet dat u deze familiestamboom niet kunt openen. Door in de eerste GRAMPS-versie de stamboom te sluiten, wordt de familiestamboom in de tweede GRAMPS-versie opnieuw beschikbaar

Door eenzelfde familiestamboom in twee versies van GRAMPS te openen is de kans groot dat uw gegevens beschadigd worden.


In het onwaarschijnlijke geval dat GRAMPS zou crashen, wordt de familiestamboom vergrendeld afgesloten. Om deze stamboom opnieuw toegankelijk te maken, selecteert u deze stamboom en klikt u op de knop ontgrendelen die dan beschikbaar wordt. Doe dit echter enkel indien u er zeker van bent dat geen andere GRAMPS-versie de familiestamboom momenteel gebruikt.

Een beschadigde familiestamboom herstellen

Een stamboom herstellen

Indien uw familiestamboom toch beschadigd werd, wordt een rood fouticoon getoond in de Status kolom.





Door op de Herstellen knop te klikken zal, GRAMPS proberen de familiestamboom te herstellen.





De stamboom wordt opnieuw opgebouwd vanuit de reservekopieën die automatisch worden aangemaakt als het programma verlaten wordt.

Aanpassingen opslaan

GRAMPS saves your changes as soon as you apply them. This means, for example, that any time you click OK when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command.

You can undo changes you've made by selecting Edit ->Undo . If you select this command repeatedly, your most recent changes will be undone one at a time. To roll back multiple commands at a time, you can using the Undo History dialog available from the Edit menu.

If you want to return your Family Tree to the way it was when you opened it, select Familiestambomen ->Abandon changes and quit . (This is just like quitting without saving in other programs.)

If you would like to save a copy of your Family Tree under a different name, you will need to export it and then import it into a new Family Tree. The GRAMPS XML database format is recommended for this purpose.

Gegevens importeren

Importing allows you to bring data from other genealogy programs into a GRAMPS database. Currently, GRAMPS can import data from the following formats:

GRAMPS V2.x database (.grdb file extension)

GEDCOM (.ged file extension)

GRAMPS XML (.gramps file extension)

GRAMPS package (.gpkg file extension)

GeneWeb (.gw file extension)

GRAMPS CSV Spreadsheet - comma separated values (.csv file extension)

Gramps-notes.png
Importing vs. opening

Please recognize that importing a database is different from opening a database. When you import, you are actually bringing data from one database into a GRAMPS database. When you open a file, you are editing your original file.

To import data, select Familiestambomen ->Import . The Import database dialog will open, asking you to specify the file you wish to import.

Gnome-important.png
Data loss with some formats

It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databases. There is a chance that some of the data in these databases will not be imported into GRAMPS.

The GRAMPS V2.x database, GRAMPS XML, and GRAMPS package are all native GRAMPS formats. There is no risk of information loss when importing from or exporting to these formats.

  • GRAMPS V2.x database (grdb): Prior to Version 3.0, this native GRAMPS database format was a specific form of Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).
  • GRAMPS XML: The GRAMPS XML file was the default format for older (pre 2.x) versions of GRAMPS. Unlike the grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable. The GRAMPS XML database is created by exporting ( Familiestambomen ->Export... ) to that format.
  • GRAMPS package: The GRAMPS package is a compressed archive containing the GRAMPS XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The GRAMPS package is created by exporting ( Familiestambomen ->Export... ) data in that format.

If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress of the operation in the progress bar of GRAMPS' main window.

The GRAMPS CSV Spreadsheet format allows importing and exporting of a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information.

Gegevens exporteren

Wait to update manual: The exporter is undergoing a major rewrite.

Fig.3.xx Export assistent

Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS database (grdb), GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.

Gramps-notes.png
Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your GRAMPS window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

To export data, choose File ->Export . This will bring up the Export assistant. Its pages will guide you through the format selection (see export-druid-fig ), file selection, and format specific export options (see gedcom-export-fig ). After a final confirmation page, the export will be performed according to the choices you have made. At any time, you can click the Back button and revise any selection, and then go forward to redo the export.

Exporteren naar het GEDCOM formaat

Fig.3.xx.Export assistant: GEDCOM options

GRAMPS laat u toe om een gegevensbestand te exporteren naar het gekende GEDCOM-formaat. Er zijn verscheidene opties om uw export te verfijnen.

  • Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
  • Target: While GEDCOM is a standard, not every program implements it in the same way. This can lead to data loss. GRAMPS can reduce the data loss in some cases. You can tell GRAMPS what program is the target, and GRAMPS will customize the exported file for that program. If your program is not listed, choose the "GEDCOM 5.5 Standard".
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported GEDCOM file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word "Living" for the first name; you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. GRAMPS uses an advanced algorithm to try to determine if a person could still be alive. Remember, GRAMPS is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

  • Reference images from path: Check this box to tell GRAMPS to use the specific path for your images when writing image references in GEDCOM.

This option allows specify where your image files are located. This is useful when you are transferring your GEDCOM file from one computer to another. It tells the program that is importing the data where your images are.

Exporteren naar GRAMPS formaten

Gnome-important.png
Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for GRAMPS XML backups.

  • GRAMPS XML database export: Exporting into GRAMPS XML format will produce a database compatible with the previous versions of GRAMPS. As XML is a text-based human-readable format, you may also use it to take a look at your data.
  • GRAMPS package export: Exporting to the GRAMPS package format will create a compressed file that contains the database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Exporten naar andere formaten

  • Web Family Tree: Exporting to Web Family Tree will create a text file that can be used by the Web Family Tree program. Export options include filter selection and the ability to limit data on living people to that of their family ties.
  • vCalendar and vCard: Exporting to vCalendar or vCard will save information in a format used in many calendaring and addressbook applications, sometimes called PIM for Personal Information Manager.
  • GRAMPS CSV Spreadsheet format: Allows exporting (and importing) a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information.


Vorige Index Volgende