Mac OS X:Build from source:fink

From Gramps
Revision as of 00:35, 22 July 2007 by Romjerome (Talk | contribs)

Jump to: navigation, search

Introduction

This page describes how to install Gramps on OSX using X11. The process uses fink or a similar program called macports to install the packages that gramps depends on. Gramps does work, although there are some glitches which are described below.

The author of the fink guide thanks the original author from which that part of the guide was written, and for the help of people on the Gramps list for helping them work through the stumbling blocks!

The fink guide applies to Mac OS X 10.4.8, and Gramps 2.2.8, but might work with other versions.

The macports guide applied to Mac OS X 10.4.8 and Gramps 2.2.8, but should work otherwise.

General Caveats

  • As stated above, these instructions were for installing 2.2.8 on Mac OS X 10.4.8, but should work more widely.
  • Production of a guide like this should really only be done after repeating the installation from a clean machine, and repeating again till the guide exactly matches the actual process - doing so would take a lot of time; the authors have each only done the installation once, so your experience will almost certainly differ from theirs.
  • The process is not very straightforward, and there will almost certainly be problems like unresolved dependencies, files not found on the various servers, download of files just stalls indefinitely and questions asked by scripts to which you don't know the answer. Nevertheless, installation is possible and I think gramps is worth the trouble. I suggest you have a look at the instructions for SoulSeek - this is a similar process, but actually SoulSeek is easier because it is fully integrated into the fink process. This might give you some idea of the requirements for perseverance. If you don't think you could install SoulSeek then you certainly won't be able to install Gramps. The converse is not true

Installing Gramps on Mac OS X via fink to use X11

  • You are installing from the 'unstable' fink tree, so the versions of the packages you install may vary from day to day, and there could be problems with them.

Installation instructions

Install X11

If you have not already installed X11, install it from the Apple OS X installation disks.

Install Developer Tools

If you have not already installed the Developer Tools, install them from a recent Apple OS X installation disks (there may be a CD labelled XCode Tools, or an XCode folder on the install DVD). If your installation disk is not very recent, it may be better to download the tools from the Apple web-site (free registration required to access the development tools) because some of the build process will not work with an old version of the tools.

Install and update fink

This was much more difficult than it should have been. From reading some of the fink mailing lists, I think there may have been some problems with updates to the fink mirrors at the time.

  1. Download the appropriate version of fink. These instructions were tried with fink 0.8.1. You may need the Fink User's Guide.
  2. Install fink by opening the disk image and double clicking on the installer.pkg.
  3. You could use FinkCommander to provide a GUI to fink, but it is not worth the trouble, because I wasn't sure that it actually offered all the packages that I wanted, and sometimes did not allow me to type in responses to questions (this is presumably a bug). I suggest you use Terminal. In Terminal type fink self-update This should download package descriptions and update core packages including fink itself. I thought it would be best to do this update before switching from source to binary distribution, but I had to try the whole updating process several times before I actually managed to get it to succeed, so this may be a bad choice.
  4. In Terminal type fink configure This should run the fink configuration process (or it may have been run automatically before). You need to choose source distribution (not binary). This will set the list of Trees in /sw/etc/fink.conf to have unstable/main at the end. If not you need to add this manually. Because fink.conf is owned by root, if you do this manually you will have to do sudo pico /sw/etc/fink.conf. During the configuration process you will also have to choose between the CVS (Concurrent Versions System or Concurrent Versioning System) and rsync update methods. Rsync is a very fast protocol. It will update the description files faster than the old CVS update method. Furthermore, CVS updates are always done from sourceforge.net while rsync updates can be done from a mirror close to you. I found that CVS often stalled trying to access files, though rsync had the disadvantage that sometimes files were not found (and perhaps as CVS uses the master copy the files should be found). Nevertheless, I suggest you use rsync. If you are behind a firewall (even the firewall in a broadband router), you may need to set ProxyPassiveFTP to true to help get around the firewall.
  5. In Terminal type fink selfupdate-rsync This should make sure all the package descriptions are downloaded, and the core packages correctly updated. I found I had to repeat this command several times, trying different mirrors when problems arose with accessing files, before the update succeeded. Fortunately, once a file has been downloaded, if you quit the process (ctrl-C), then on typing the command again, it starts from where it left off.
  6. I also got the following error, and carried out the suggested instructions (I had to use sudo apt-get in each case), which installed some extra packages and seemed to work.
      The following inconsistencies found:
      Unsatisfied dependency in gettext-tools: gettext (= 0.10.40-19)
     
      Trying to resolve dependencies...
      Could not resolve inconsistent dependencies!
    
      Fink isn't sure how to install the above packages safely.
      You may be able to fix things by running:
    
      fink scanpackages
      apt-get update
      apt-get install gettext=0.10.40-25{CODE}
    

Install the Gramps dependencies

In Terminal, successively type in the following instructions:

 sudo fink install pygtk2-py24
 sudo fink install gnome-python2-py24
 sudo fink install librsvg2-gtk

I found that a number of the files could not be found on the first mirror that was tried, or the files would not download. Sometimes, I could follow the suggestions and get the file from the next mirror that was suggested. However I also quit out of the install process by ctrl-C (twice) and started again. Fortunately files already downloaded are remembered.

Later on, I found that the gramps build process complained about another package missing, so in Terminal I had to type:

 sudo fink install gnome-doc-utils

In attempting to resolve some of the glitches, I also installed a number of other packages. These are not essential and did not resolve the issue with the spell checker, but somewhere along the way I seem to have resolved the assert warnings. In Terminal type:

 sudo fink install gtkspell2
 sudo install gnome-spell
 sudo fink install gnome-spell
 sudo fink install gnome-python2-py24-dev
 sudo fink install gnome-python2-py24-vfsmodule
 sudo fink install gtkspell2-dev

Download and install Gramps

  1. Download gramps for example to ~/Downloads. On the Gramps page, you need to scroll down to find a file like gramps-2.2.8.tar.gz.
  2. Unpack the file; assuming you download to the suggested place, in Terminal type:
      cd ~/Downloads
      tar -xzf gramps-2.2.8.tar.gz
    
    [According to the fink User's Guide "It is important that you don't use StuffIt Expander to extract the tar archive. For some reason StuffIt still can't handle long file names. If StuffIt Expander already extracted the archive, throw away the folder it created"].
  3. Optional: You can either install gramps in the default directory (which is /usr/local/share/gramps), or you can read the instructions in the gramps files about "how to install in a non-default prefix" so that you can install gramps into your users own folder rather than into /usr/local/. One user has found that it is best not to put things into /usr/local as it can be difficult to uninstall them afterwards. The following instructions assume you install in the default directory.
  4. Modify the configuration script in the download directory by changing configure. Replace:
      imp.find_module('gnome/ui')
    with
      imp.find_module('ui', gnome.__path__)
    Also replace:
     imp.find_module('gtk/glade')
    

    with:

     imp.find_module('glade', [imp.find_module('gtk')[1]])
    
  5. Configure gramps by typing in Terminal:
      ./configure
  6. In the file po/Makefile, which is generated by configure, make sure that GMSGFMT has the value:
      GMSGFMT = /sw/bin/msgfmt
    [I do not know why this is not detected and set by configure run as above].
  7. Build and install gramps by typing in Terminal:
      make
      sudo make install
  8. In one of the updates along the way, I had installed Python version 2.5, which is not good because all the library packages are for 2.4. You will need to switch the default version that Python picks up. In Terminal type:
    sudo ln -sf /sw/bin/python2.4 python
  9. In /usr/local/share/gramps/GrampsWidgets.py put:
      try:
          INFO_ICON = gtk.STOCK_INFO
      except:
          INFO_ICON = gtk.STOCK_DIALOG_INFO
    Somewhere after import gtk in the section labelled: Constants. Then change every reference to
    gtk.STOCK_INFO
    to
    INFO_ICON

Start Gramps

This is how Gramps has to be started each time, because there is no tool to start X11 and Gramps together. One way to get around this is to have the system launch X11 at startup, and then forget about it. This kills one of the steps and takes up little memory (I think).

  1. Start X11 by double clicking on the X11 icon in Applications/Utilities (or in Applications, depending on the version of Mac OS X).
  2. Start Gramps, by typing, in xterm: gramps. After a pause "Spelling checker is not installed" appears on the xterm, and then Gramps should start.


Installing gramps for X11 using MacPorts

Right now, I will just get the basic information down as to the troubles I ran into and how I fixed them. I will later put in more detailed instructions on using MacPorts and the rest.

Starting

So, assuming you have MacPorts installed and updated, you might as well try: sudo port install gramps Now, if you're like me and didn't have GNOME or anything like that installed, calling that command will attempt to go through all of the dependencies and install them all. This will take a while, and you might be at this installing gramps for a couple hours (there are a lot of dependencies)

What I did instead was run port deps gramps, which listed the major dependencies that gramps has. Then, I installed each separately. They are: shared-mime-info py-gnome py-bsddb I installed them in the following order:

  1. shared-mime-info
  2. py-bsddb
  3. py-gnome (the tough one)

shared-mime-info

In order to successfully install this, I first had to run: sudo port install p5-xml-sax sudo port install p5-xml-sax-expat After that, things installed smoothly

py-bsddb

This actually installed smoothly on my computer.

py-gnome

For now, I merely list the libraries and what I did to fix the problem.

  1. py-gtk2
    • I had to make sure to upgrade expat. After that, it installed fine.
  2. py-orbit
    • This installed without any problems for me.
  3. libzvt
    • This package needs "dbus" which in turn needs "xmlto". It appears, however, that "xmlto" is not listed as a dependent of "dbus". Hence, I ran sudo port install xmlto by hand. This installed without any problems on my computer.
    • After installing that, and upgrading gtk2 (do this first), this seems to be installing correctly.
  4. gnome-desktop
    • This was the next problem for me. I installed p5-libxml-perl, p5-xml-simple, py-xml by hand, cleaned gnome-desktop, and then tried the installation again. Worked fine!
  5. gstreamer
    • This was the next problem for me. I installed p5-xml-libxslt, py-libxslt by hand, cleaned gstreamer, and then tried the installation again. Worked fine!
  6. liboil
    • First, I ran sudo port upgrade gtk-doc
    • Then, I installed the newest version of the liboil library from [1] and then tried to make the liboil library again. (From the manual download). This worked. I would assume it would work for the port version as well.
  7. nautilus
    • This was the last problem for me. To get around the error, I had to create a soft link for the libintl.3.dylib file in my /opt/local/lib/ directory.

Conclusion

Those errors were the ones I ran into. I was able to get gramps to work after that, with some of the same glitches as described below.

Glitches

There are some problems, some from the fink installation.

  • Help does not work (clicking Help or FAQ etc on the Help menu does nothing).
  • 'Enter' or 'return' does not act as OK for closing windows (the button has to be pressed with the mouse). However Esc does work to exit from the window.
  • The browser and email links under the help menu do nothing.
  • It is not possible to start Gramps by double clicking on a Mac OS icon, nor by double clicking on a Gramps database that is associated with the application. (It should be possible to create an installation that allows this, just as it is available for OpenOffice).
  • The PdfDoc.py plugin cannot be installed because ReportLab is not installed.
    • Note, using macports, run sudo port install py-reportlab . This will take care of this problem.
  • The LPRDoc.py plugin cannot be loaded because the python bindings for GNOME print are not installed.
  • Spell checking does not work (on starting Gramps, an error warning "Spelling checker is not installed" appears on the xterm). The python "bindings for [GNOME print and spell checking] are probably in fink's gnome-python2-desktop-py24 and gnome-python2-extras-py24 packages. Or would be, if fink had them at all, which we don't. They are only viable for for newer versions of gnome itself than fink presently has, or have other dependencies that are not yet satisfiable within fink. We're working on it".
  • (Gramps bug 0000940) On starting Gramps, the following assert warnings are output:
/usr/local/share/gramps/DbLoader.py:99: 
     GtkWarning: gtk_file_system_unix_get_folder: 
         assertion `g_path_is_absolute (filename)' failed
            choose.set_current_folder(get_default_dir())
/usr/local/share/gramps/DbLoader.py:153: 
     GtkWarning: gtk_file_system_unix_get_folder: 
        assertion `g_path_is_absolute (filename)' failed
            choose.set_current_folder(default_dir)
  • (Gramps bug 0000940) When running gramps, the following warning is output on xterm - this appears to be when I open a new window:
(gramps:516): libglade-WARNING **: unknown property `urgency_hint' 
                                for class `GtkDialog'
  • (Gramps bug 0000939) Detection of the availability of gsignal is flawed. In GrampsWidgets.py, there is some code to cater for different versions of gtk.pygtk. I have fink packages pygtk2-gtk-py* version 2.6.3-1 and pygtk2-py* version 2.6.3-2000 installed, so this certainly seems to be version 2.6, and is presumably causing HAVE_2_6 to be set to true. However, on running gramps, I get:
[name G5:~] name% gramps
Traceback (most recent call last):
  File "/usr/local/share/gramps/gramps.py", line 97, in ? 
    import gramps_main
  File "/usr/local/share/gramps/gramps_main.py", line 47, in ?
    import ViewManager
  File "/usr/local/share/gramps/ViewManager.py", line 68, in ?
    import GrampsCfg
  File "/usr/local/share/gramps/GrampsCfg.py", line 47, in ?
    from GrampsWidgets import *
  File "/usr/local/share/gramps/GrampsWidgets.py", line 1162, in ?
    class MaskedEntry(gtk.Entry):
  File "/usr/local/share/gramps/GrampsWidgets.py", line 1216, in MaskedEntry
    gsignal('size-allocate', 'override')
NameError: name 'gsignal' is not defined

The problem is worked around as described above. It also seems to work if you replace or follow the line

HAVE_2_6 = gtk.pygtk_version[:2] == (2, 6)

with

HAVE_2_6 = False


  • (Gramps-users report 19 Feb 2007) Output of (for example charts) to OpenOffice causes OpenOffice to crash due to a problem with Gramps handling of '&'.
  • (Gramps bug 0000938) Import of a GEDCOM file that contains an invalid date of the form 2 DATE BET ABT 1912 AND 1915 causes the date to appear as blank.
  • (Gramps-devel mailing list 11 Feb 2007) Gramps aborts at startup with the following error:
 File "/usr/local/share/gramps/GrampsWidgets.py", line 2010, in ?
   MANDATORY_ICON = gtk.STOCK_INFO
AttributeError: 'module' object has no attribute 'STOCK_INFO'{CODE}

This stock item is added in Gtk 2.8 and fink an older Gtk, for more info see: http://www.pygtk.org/docs/pygtk/gtk-stock-items.html.

This is worked around by patching the application as above.