Difference between revisions of "Mac OS X:Build from source:MacPorts"

From Gramps
Jump to: navigation, search
(Installing Gramps using MacPorts: working link)
(Installing Gramps using MacPorts)
Line 12: Line 12:
 
If you are running a recent version of OS X (Snow Leopard, or later, at this point), much of the support software is pre-compiled and will install as quickly as it is downloaded.
 
If you are running a recent version of OS X (Snow Leopard, or later, at this point), much of the support software is pre-compiled and will install as quickly as it is downloaded.
  
If you have been using Version 3 of Gramps and are not ready to upgrade, the most recent version available is 3.49.  You can install it with:
+
If you have been using Version 3 of Gramps and are not ready to upgrade, the last version available was 3.49.  You can install it with:
  
 
  sudo port install gramps3
 
  sudo port install gramps3
  
{{man note|Note|that gramps3 will be retired at some point in the not too distant future.}}
+
{{man warn|Note|That gramps3 and gramps4 are obsolete.}}
  
 
==Running Gramps==
 
==Running Gramps==

Revision as of 06:00, 9 February 2019

Installing Gramps using MacPorts

Current version available from MacPorts is: 4.2.8

  1. Download and install the latest Xcode tools from https://developer.apple.com/xcode/
  2. Download and install Macports from http://www.macports.org/install.php
  3. Open Terminal.app from /Applications/Utilities and enter these commands:
sudo port selfupdate
sudo port install gramps

If you are running a recent version of OS X (Snow Leopard, or later, at this point), much of the support software is pre-compiled and will install as quickly as it is downloaded.

If you have been using Version 3 of Gramps and are not ready to upgrade, the last version available was 3.49. You can install it with:

sudo port install gramps3
Gnome-important.png
Note

That gramps3 and gramps4 are obsolete.

Running Gramps

Use Terminal to start gramps:

gramps

Graphviz

You may wish to install Graphviz to handle some of the graphical reports that Gramps can produce. MacPorts can provide you with either graphical or command-line based versions of either a 'stable' or 'development' release of Graphviz. 'graphviz-gui' is recommended unless you know that you have a need for the development version. Install with:

sudo port install graphviz-gui

Issues

You can search the MacPorts bug tracker for any issues related to the Gramps port:

https://trac.macports.org/search?portsummarysearch=on

Please don't hesitate to create a ticket if you find a problem that you believe is related to the MacPorts build process.