Howto: Make a relationship chart

From Gramps
Revision as of 15:38, 13 February 2013 by Patsyblefebre (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Gramps-notes.png
This page's factual accuracy may be compromised due to out-of-date information. Please help improve the Gramps Wiki as a useful resource by updating it.
This is a Howto on how to make a relationship chart (can be ancestors, descendants, ...) with Gramps 2.2.x. and the Relationship plugin.
An example chart

The report is made with the graphviz backend, so you need to install graphviz (on linux, use your package manager).

Before you start

Gramps can produce charts, but to view them, you need other programs. We recommend that you install the following:

Filters: what persons to print ?

What are filters?

In Gramps you can define filters to make a selection of individuals, see Examples of filters. In the relationship chart all custom person filters you made will be available, as well as the standard descendants and ancestors filters. These last start from the active person.

Gnome-important.png
Tip

You can add to a family stepchildren by setting the relationship of the child to the mother to step child. In doing so, these children will be part of a descendant report without the need to create a custom filter to include them.


How many people ?

Your filter can contain as many people as you want. Note however that printing or viewing of large charts can be very problematic.

Example 1-A: a descendant chart

A descendant chart, click for details

Download example.gramps, on this page use the Download link, create a new database in Gramps called example, and import the example.gramps data into it.

If not the case, set the active person to Garner, Lewis Anderson.

To make a descendant chart with the relationship report, choose the menu item Reports -> Graphical reports -> Relationship graph...

In the dialog, set the format to .png and chose the following in the tabs available:

  1. Paper Options -> Size : Custom Size (Set width and height to 10000 cm, or some other large value)
  2. Report Options -> Filter: Descendants of Garner, Lewis Andersson
  3. Layout optons -> Aspect ratio: minimal size

(I sometimes experience problems setting the sizes in the Paper options dialog. A workaround is to use the example using graphviz code in example 3 below.)

The result (using gramps 2.2.7) can be seen to the right. You can use print this on a dedicated printer (check dpi of png!), or you can use this image on a website to share. In the last case, you can use the trick explained in Make flash plugin from a png, to make the resulting graph easier to navigate.

In the image you see males in blue, females in pink and the yellow balloons indicate a family node in which a marriage date is printed (if known). You can select not to see this family node by deselecting in the Graphviz Options tab the option Show family nodes.

Example 1-B: a chart with ancestors

Download and open the example.gramps file as in Example 1

Set Warner, Carl Thomas to be the active person.

Repeat the process in Example 1-a, but choose the filter Ancestors of Warner, Carl Thomas this time.

Fig. An ancestor chart. For the detailed image, click here (853kb!)

You can see the result to the right.

This is already an extremely large graph.

It can only be readily viewed in a good image viewer.

For printing you need to resort to printing on several pages, or you need access to a large plotter.

Example 2: A chart with ancestors, descendants and their families

Note: This example uses filters. See Examples of filters for an introductory example.

Open the file example.gramps and select Cristiansen, Frances as the active person.

First we create a helper filter: Open the filter editor and create a new filter, called Frances1. The filter should contain the rules

  • Ancestors of <person> choose Christiansen, Frances and check inclusive.
  • Descendants of <person> chose Christiansen, Frances

Make sure that "At least one rule must be fulfilled" is chosen, so that we get both ancestors and descendants!

Now we create the filter we will actually use for the report. It will be based on the previous filter: Create a new filter, called Frances2. This filter should contain the rules:

  • People matching the filter, choose Frances1
  • Parents of filter Frances1
  • Siblings of filter Frances1
  • Spouses of filter Frances1

Now close the filter editor, and follow the instructions given in Examples 1a and 1b, but this time choosing the filter Frances2 in the Report Options tab.

Fig. A large chart. For the detailed image, click here (363kb!)

The result is visible to the right (363kb, large file !)

Example 3, Generating the graph by using the Graphviz command line tool

Gnome-important.png
Note: The current stable version of Graphviz (v2.12) has a bug. In order to correctly display the family nodes (yellow balloons), all occurrences of the word ellipse should be changed to egg (see bug report 1078).

In the menu, select Reports -> Graphs -> Relationship Graph....

Select in file format: graphviz file, which defaults to the gv extension. This file is then a dot file which can be processed by graphviz.

Eg, to make from the gv file a ps file, Gramps uses:

dot -Tps:cairo -o"file.ps" "file.gv"

for svg:

dot -Tsvg -o"file.svg" "file.gv"

Choose the filter you want to use, and set also as many of the other options as possible to the desired values (as explained in Example 1-A)

This file is a text file, so it can be opened in any text-editor.

Manual changes

The dot file is a text file with a well explained structure, for extra info: www.graphviz.org

digraph GRAMPS_graph
{
 bgcolor=white;
 center="true"; 
 charset="iso-8859-1";
 concentrate="false";
 dpi="75";
 graph [fontsize=12];

...

then the actual Gramps data are shown:

I3493 [ shape="box" fillcolor="pink" style="solid,filled" label="Blancke, Charlotte\n(1801)" ];

... You can optimize the layout by making changes in the file.

  • For paper size: look for the "page" (paper size) and "size" (area of paper to use), and change these to some large values. This is important as otherwise the figure will be wrongly scaled giving bad picture quality (eg unreadable text).
  • You can also change the font by adding a font family. Look for the lines
node [style=filled fontsize="12"];
and change that into eg
node [style=filled fontsize="12" fontname="Sans"];
to use the Sans font. On the command line you will see which ttf font Graphviz finds on your PC (using the verbose flag, see below).

Generation of the Image

Save the modified file under the name report.dot, and run the command

dot -Tpng -oreport.png report.dot

This should use the graphviz "dot" tool to generate the .png file containing the report.

To see information messages (like font) use the -v flag. You can also output other image formats, eg, for jpeg with verbose output:

dot -Tjpg -oreport.jpg report.dot -v

...

Activated plugin library: libgvplugin_pango.so.5
Using textlayout: textlayout:cairo
Activated plugin library: libgvplugin_dot_layout.so.5
Using layout: dot:dot_layout
Using render: cairo:cairo
Activated plugin library: libgvplugin_gd.so.5
Using device: jpg:cairo:gd
The plugin configuration file:	/usr/lib/graphviz/config4 was successfully loaded.
   render	:  cairo dot fig gd map ps svg vml vrml xdot
   layout	:  circo dot fdp neato nop nop1 nop2 twopi
   textlayout	:  textlayout
   device	:  canon cmap cmapx cmapx_np dia dot fig gd gd2 gif hpgl imap imap_np ismap jpe jpeg jpg mif mp pcl pdf pic plain plain-ext png ps ps2 svg svgz vml vmlz vrml vtx wbmp xdot xlib
   loadimage	:  (lib) gd gd2 gif jpe jpeg jpg png ps
dot: fontname "Times-Roman" resolved to: "Times New Roman, Normal" /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman.ttf
network simplex: 11 nodes 10 edges 0 iter 0.00 sec
mincross: pass 0 iter 0 trying 0 cur_cross 0 best_cross 0
mincross GRAMPS_graph: 0 crossings, 0.00 secs.
network simplex: 23 nodes 37 edges 7 iter 0.00 sec
routesplines: 10 edges, 30 boxes 0.00 sec
Using render: cairo:cairo
Using device: jpg:cairo:gd

...

Printing large graphs

If you want to print large graphs (especially with photos and other details) in reasonable readable quality, the following steps should work:

  1. In Document Options choose SVG as output format.
  2. Setup paper format to fit graph into one sheet (SVG cannot handle more than one sheet), so choose A0 or custom size.
  3. Use Inkscape for opening SVG graph.
  4. Menu File/Document properties, use "Fit page to selection" function (fix size accordingly to graph size).
  5. Menu File/Save as, choose PDF format.

You now have a large poster you could print. Inkscape cannot tile PDF for printing large graphs on many A4/A3 sheets, so you must use another software to do it for you. At home, you can print this on multiple A4/A3 sheets with other programs:

  • In Linux, the poster command line utility can split a poster over A4/A3/Letter.
    1. Install it via your package manager (or on CLI type for eg Ubuntu: sudo apt-get install poster
    2. Read the man page, to eg split an A0 poster which is in postscript format, over 16 A4 do:
   poster -iA0 -mA4 -pA0 posterA0.ps > posterA4.ps 
  • For Linux, Windows and Mac, you can also use the program PosterRazor, which has an easy to use interface.
  • For Windows, you can use Govert's PDF Tiler (can maybe run on Linux too using Mono, needs .NET 1.1)

Troubleshooting

  • If you encounter bad fonts (missing characters) or wrong fontsizes, see Example 3 on how you can set the font yourself.
  • If you have a bad resolution of png, eg unreadable text, this is probably because you have set a paper size which is to small. See Exampe 1-A: set the papersize of number of pages to a high number, but select in Layout Options, in Aspect ratio: automatically use optimal number pages, or use minimal size
Gnome-important.png
Reports and custom IDs

After a GEDCOM import, your database can use some non-standard IDs (ie. 123I or 456U not set on Edit --> Preferences --> Identifiants ID). If generated reports do not properly display data, then try Reorder GRAMPS IDs tool (Tools-->Database Processing-->Reorder GRAMPS IDs).

Further cool things to do

  • You can make descendant charts and add them to the media gallery of the person. Like that, the chart is available from the website.
  • offer a chart on your website as a flash relationship graph, enabling zooming, moving, ... over your data or just use SVG for Firefox and Opera, see DenominoViso

Want to help developing ?

If you go through the dot specifications, you will note that more can be done with graphics. If you have programming skills you can add some functionality:

  • more/better text in the boxes: what text and how to organize it?
  • coloring. See the Familylines plugin: a color per family, for specific relations, for the central person, ...

Link to the manual