Difference between revisions of "Gramps 5.1 Wiki Manual - Tools/sk"

From Gramps
Jump to: navigation, search
(Ladenie)
(Tags: Mobile edit, Mobile web edit)
(Čistenie vstupných údajov)
(Tags: Mobile edit, Mobile web edit)
Line 431: Line 431:
  
  
===<u>Čisté vstupné údaje</u>===
+
===<u>Čistenie vstupných údajov</u>===
 
<!-- je potrebné premenovať odkaz v nástroji tak, aby zodpovedal možnosti v ponuke (potom odstráňte názov sekcie nižšie-->
 
<!-- je potrebné premenovať odkaz v nástroji tak, aby zodpovedal možnosti v ponuke (potom odstráňte názov sekcie nižšie-->
 +
 
===<u>Odstrániť úvodné a koncové medzery</u>===
 
===<u>Odstrániť úvodné a koncové medzery</u>===
  

Revision as of 13:06, 22 November 2021

Predchádzajúca Index Nasledujúca


Fig. 14.1 "Nástroje >..." Panel ponuky - Prehľad nástrojov

Táto kapitola opisuje rôzne Nástroje dostupné v programe Gramps.

Gramps Nástroje vám umožňuje vykonávať rôzne typy analýz vašich genealogických údajov. Nástroje zvyčajne nevytvárajú výstup vo forme výtlačkov alebo súborov. Namiesto toho vytvárajú výstup na obrazovke, ktorý je okamžite k dispozícii bádateľovi. V prípade potreby však môžete výsledky spustenia nástroja uložiť do súboru.

Contents

Nástroje

Fig. 14.2 Ikona panela nástrojov pre "Otvoriť dialógové okno nástrojov"

K nástrojom sa dostanete výberom ponuky Nástroje ->Sekcia nástrojov ->Konkrétny nástroj .

Prípadne si môžete prezrieť kompletný výber dostupných nástrojov spolu s ich stručným popisom v dialógovom okne Výber nástrojov , ktoré vyvoláte kliknutím na Otvoriť dialógové okno Nástroje ikonu na paneli nástrojov z ktorejkoľvek kategórie.

Gramps-notes.png
Dodatočné nástroje

Gramy umožňuje nainštalovať ešte viac nástrojov. Tento systém sa ovláda pomocou Správca zásuvných modulov. Ďalšie nástroje nájdete v časti Doplnky.

Dialógové okno Výber nástrojov

Fig. 14.3 Výber nástroja - dialógové okno - príklad zobrazujúci informácie "Nájsť možné duplicitné osoby"

Dialógové okno Výber nástrojov umožňuje prechádzať kompletný výber dostupných nástrojov spolu s ich stručným popisom, keď ho vyvoláte kliknutím na ikonu Otvoriť dialógové okno nástrojov na paneli nástrojov z ktorejkoľvek kategórie a pomocou šípok rozbalíte zoznamy.

Analýza a prieskum

Táto časť obsahuje nástroje, ktoré analyzujú a skúmajú databázu, ale nemenia ju. V súčasnosti sú v programe Gramps k dispozícii nasledujúce nástroje na analýzu a prieskum:

Porovnanie jednotlivých udalostí

Obrázok 14.4 "Porovnanie jednotlivých udalostí" - "Výber filtra na porovnanie udalostí" - dialógové okno
Gramps-notes.png

Please update or expand this section.


Tento nástroj porovnáva udalosti vo vybranej skupine osôb.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje->Analýza a skúmanie > Porovnať jednotlivé udalosti...}, ktorá otvorí dialógové okno Výber filtra porovnania udalostí.

Osoby pre toto porovnanie môžete vybrať z predtým vytvorených vlastných filtrov výberom z rozbaľovacieho zoznamu Filter:, ktorý je predvolene nastavený na Celá databáza. Alebo výberom tlačidla Upravovač vlastných filtrov, čím vytvoríte vlastné filtre v editore Filtre osôb. Ak chcete správu spustiť, vyberte Použiť a výsledky sa zobrazia v dialógovom okne Výsledky porovnania udalostí.


V dialógovom okne Výsledky porovnania udalostí môžete zobraziť výsledky alebo Uložiť ako výslednú tabuľku ako tabuľku (formát ODS). Výberom Zatvoriť ukončíte správu.

Fig. 14.5 "Porovnanie jednotlivých udalostí" - "Výsledky porovnania udalostí" - dialógové okno - rozšírený príklad


Spracovanie rodokmeňa

Táto časť obsahuje nástroje, ktoré môžu upravovať vašu databázu. Nástroje z tejto časti sa používajú najmä na vyhľadávanie a opravu chýb v údajoch. V súčasnosti sú v programe Gramps k dispozícii nasledujúce nástroje na spracovanie rodokmeňa:

{}}} Úpravy sa vykonajú len na základe vášho výslovného súhlasu, s výnimkou automatických opráv vykonávaných nástrojom Kontrola a oprava databázy.

Upraviť informácie o vlastníkovi databázy

Fig. 14.6 "Editor vlastníka databázy" - dialógové okno - zobrazenie kontextového menu

Tento nástroj upravuje všetky existujúce Informácie o vyhľadávači.

Vyberte ponuku Nástroje->Spracovanie rodokmeňa->Upraviť informácie o vlastníkovi databázy.... Zobrazí sa okno Upravovač vlastníka databázy, v ktorom môžete vyplniť potrebné informácie.

  • Názov:
  • Ulica:
  • Miesto:
  • Mesto:
  • štát/okres:
  • Country:
  • PSČ/poštové smerovacie číslo:
  • Telefón:
  • Email:

Tieto informácie sú špecifické pre rodokmeň a použijú sa pri exporte údajov vo formáte GEDCOM.

V kontextovej ponuke (pravé tlačidlo myši) sú k dispozícii dve možnosti:

  • Kopírovať z DB do Predvolieb -
  • Kopírovať z Predvolieb do DB -


Opis extraktu udalosti

Gramps-notes.png
Poznámka

Formát názvu v poli Popis udalosti závisí od definovaného formátu názvu v Upraviť->Nastavenia->Zobrazenie->Formát názvu

Fig. 14.7 Extract Event Description's - Modifications Made - window - example result

Extrahuje popisy udalostí z údajov o udalostiach pomocou modelu :

{typ udalosti} z {Prímeno}, {Dané meno}

Ak popis udalosti chýba, nástroj použije tento model poľa popisu udalosti.

Prístup k tomuto nástroju je možný cez ponuku Nástroje->Spracovanie rodokmeňa->Vyťažiť popis udalosti...}

Zobrazí sa upozornenie Zrušiť históriu a môžete buď Zastaviť alebo Pokračovať v práci s nástrojom.

Keď Pokračovať s nástrojom, tento nástroj prehľadá a upraví váš rodokmeň a zobrazí vám okno Uskutočnené úpravy s výsledkom, v ktorom je uvedený celkový počet pridaných opisov udalostí.

Výber informácií z mien

Tento nástroj prehľadáva celú databázu a pokúša sa extrahovať tituly a prezývky, ktoré môžu byť vložené v poli Dané meno osoby. Ak sa podarilo vyextrahovať nejaké informácie, v tabuľke sa zobrazia kandidáti na opravu. Potom sa môžete rozhodnúť, ktoré z nich opravíte podľa návrhu a ktoré nie.

Prístup k tomuto nástroju je možný cez ponuku Nástroje->Spracovanie rodokmeňa->Vyberanie informácií z mien....

Zobrazí sa Undo history warning dialógové okno a môžete buď Stop alebo Proceed with the tool.

Fig. 14.8 "Predvolené nastavenia prefixu a konektora" - dialógové okno pre nástroj "Extrahovanie informácií z názvov"

Zobrazí sa dialógové okno Predvolené nastavenia prefixu a konektora, v ktorom môžete upraviť jednotlivé možnosti podľa potreby:

  • Prefixy na vyhľadávanie:} de, van, von, di, le, du, dela, della, des, vande, ten, da, af, den, das, dello, del, en, ein, elet, les, lo, los, un, um, una, uno, der, ter, te, die (predvolené)
  • Prípony rozdeľujúce priezviská: e, y (predvolené)
  • Konektory nerozdeľujúce priezviská: de, van (predvolené)

Po dokončení vyberte OK na spustenie nástroja.

Fig. 14.8.8+1}}}} "Nástroj na extrakciu názvov a názvov" - okno s výsledkami dialógového okna pre nástroj "Extrakcia informácií z názvov"

Po dokončení správy sa zobrazí okno výsledkov dialógu Nástroj na extrakciu informácií o názvoch a tituloch.

Gramps-notes.png

Please update or expand this section.



Extrahovať údaje o mieste z názvu miesta

Gnome-important.png
Už nie je súčasťou programu Gramps, tento nástroj si môžete stiahnuť z doplnkov tretích strán
Pozrite si: Extrahovať údaje o mieste z názvu miesta

Vyhľadanie možných duplicitných osôb

Fig. 14.9 Nájsť možných duplicitných ľudí - dialógové okno - predvolené

Tento nástroj prehľadáva celú databázu a hľadá záznamy, ktoré môžu predstavovať tú istú osobu.

Prístup k tomuto nástroju je možný cez ponuku Nástroje->Spracovanie rodokmeňa->Najsť možné duplicitné osoby....

Zobrazí sa dialógové okno Vyhľadať možné duplicitné osoby, v ktorom môžete nastaviť nasledujúce možnosti:

  • Práhová hodnota priradenia : z rozbaľovacej ponuky vyberte medzi možnosťami Nízka' (predvolené nastavenie), Stredná a Vysoká. (Poznámka:Toto vypočíta šancu na zhodu ako číslo s pohyblivou rádovou čiarkou. Pre každú zhodnú informáciu sa šanca zvyšuje. Ak je šanca väčšia ako prahová hodnota, potom sa oznámi zhoda. Prahové hodnoty sú Nízka=0,25, Stredná=1,0 a Vysoká=2,0. Takže s prahovou hodnotou nastavenou na High (Vysoká) sa očakáva menej zhody).

Options

  • Použiť soundex kódy na porovnanie možných duplicitných osôb. (štandardne začiarknuté políčko)

K dispozícii sú nasledujúce tlačidlá: Tlačidlo Pomoc vás prenesie na túto stránku, tlačidlo Zrušiť na zastavenie spracovania a tlačidlo OK na začatie spracovania údajov.

Výberom tlačidla OK spustíte nástroj a údaje sa spracujú v dvoch priechodoch.

  • Prechod 1: Vytvorenie predbežných zoznamov
  • Posun 2: Výpočet potenciálnych zhody.

Zobrazí sa ukazovateľ priebehu a v závislosti od rýchlosti vášho počítača a počtu osôb v databáze to môže trvať určitý čas.


Fig. 14.10 Dialógové okno výsledkov "Potenciálne zlúčenia" pre "Nájsť možné duplicitné osoby" - dialóg - príklad

Po dokončení hlásenia sa zobrazí okno zoznamu výsledkov Potenciálne zlúčenia s nasledujúcimi zobrazenými stĺpcami:

  • Ohodnotenie : poskytuje predstavu o podobnosti medzi dvoma osobami. Čím vyššie je hodnotenie, tým vyššia je pravdepodobnosť, že ide o duplicitné osoby.
  • Prvá osoba
  • Druhá osoba

Na vybraný riadok môžete buď dvakrát kliknúť, alebo vybrať tlačidlo Porovnať a skontrolovať podrobnosti.

K dispozícii sú tri tlačidlá: {Pomoc, ktorým sa dostanete na túto stránku, {Zatvoriť na zatvorenie okna, ktoré vás vráti do okna {Vyhľadanie možných duplicitných osôb a {Porovnať, ktorým sa zobrazí okno {Spojiť osoby, ktoré bolo podrobne vysvetlené v Zlúčenie_ľudí Dialógové okno. Tu môžete vybrať pomocou prepínačov jednu z osôb a prípadne použiť tlačidlo OK na zlúčenie údajov, ak zistíte, že tieto dve osoby sú duplicitné.

Výberom tlačidla Zrušiť sa vrátite do okna Potenciálne zlúčenia zoznamu výsledkov.

Oprava písania veľkých písmen v rodinných menách

Tento nástroj prehľadá celú databázu a pokúsi sa opraviť písanie veľkých písmen v rodinných menách.

Cieľom je dosiahnuť konvenčnú kapitalizáciu: veľké prvé písmeno a malé písmeno pre zvyšok priezviska. Ak sa zistia odchýlky od tohto pravidla, v tabuľke sa zobrazia kandidáti na opravu.

Potom sa môžete rozhodnúť, ktoré opraviť podľa návrhu a ktoré nie.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje->Spracovanie rodokmeňa->Oprava písania veľkých písmen v rodinných menách....

Gnome-important.png
História zrušenia

Pri použití tohto nástroja sa vymaže história zrušenia pre túto reláciu. Konkrétne nebudete môcť vrátiť zmeny vykonané týmto nástrojom ani žiadne zmeny vykonané pred ním. Odporúčame vám, aby ste sa tu zastavili a zálohovali svoju databázu; aby ste mohli vrátiť proces spustenia tohto nástroja.

Zobrazí sa Upozornenie na zrušenie histórie a môžete buď Zastaviť alebo Pokračovať v práci s nástrojom.


Fig. 14.11 "Zmeny písania veľkých písmen" - dialógové okno - príklad výsledkov pre nástroj "Oprava písania veľkých písmen v rodinných menách"

Ak došlo k zmenám v písaní veľkých písmen v niektorom z mien, zobrazí sa okno s výsledkami Zmeny kapitalizácie. V okne sa zobrazí zoznam rodinných mien, ktoré Gramps môže previesť na (podľa Gramps) správnu kapitalizáciu (skontrolujte, či je pre vás správna.). V zozname okna Zmeny kapitalizácie výsledkov sú k dispozícii nasledujúce stĺpce:

  • Vyberte - začiarknite alebo zrušte začiarknutie týchto políčok na základe mena, ak sa rozhodnete neprijať odporúčanie (políčko je predvolene začiarknuté)
  • Pôvodný názov - Názov, ako je aktuálne zaznamenaný.
  • Zmena kapitalizácie - Názov so zmenou, ak sa použije.

Vyberte názvy, ktoré chcete zmeniť, a potom vyberte tlačidlo Accept changes and close. Alebo použite tlačidlo Zrušiť na zrušenie zmien.

Môžete si tiež nainštalovať doplnok "Opraviť písanie veľkých písmen v daných menách", ktorý po nainštalovaní funguje takmer identicky ako tento nástroj, ale funguje pre "Dané mená"

Zlúčenie citácií

Tango-Dialog-information.png
Nástroj Zlúčiť citácie funguje tak, že kombinuje poznámky, mediálne objekty a dátové položky zhodných citácií.


Môžete ho vybrať prostredníctvom ponuky Nástroje > Spracovanie rodokmeňa > Zlúčiť citácie... .

Zobrazí sa upozornenie Zrušiť históriu a môžete buď Zastaviť alebo Pokračovať v nástroji.

Fig. 14.12 "Zlúčiť citácie" - dialógové okno - predvolené

Potom sa zobrazí dialógové okno Zlúčiť citácie (Názov dialógového okna zobrazuje:Poznámky, mediálne objekty a dátové položky zhodných citácií sa spoja.)

K dispozícii sú nasledujúce možnosti:

  • Práhová hodnota pre zhodu rozbaľovací zoznam:
    • Zhoda na základe strany/zväzku, dátumu a dôveryhodnosti
    • Ignorovať dátum (predvolené)
    • Ignorovať dôveru
    • Ignorovať dátum a dôveru
  • Options
    • Nezlúčiť, ak má citácia poznámky (predvolene nezačiarknuté políčko)


Fig. 14.13 Dialógové okno s výsledkom "Počet vykonaných zlúčení" pre "Zlúčiť citácie" - dialógové okno - Nástroj - príklad

Výberom OK spustíte nástroj a po dokončení vám oznámi celkový počet pomocou dialógového okna Počet vykonaných zlúčení výsledku.
Pozrite si tiež možnosť Zlúčenie citácií dostupnú v zobrazení zoznamu Kategória citácií

Premenovať typy udalostí

Tento nástroj premenuje všetky udalosti jedného typu na iný typ.

Prístup k tomuto nástroju je možný cez ponuku {{manu{Nástroje->Zpracovanie rodokmeňa->Premenovať typy udalostí....}}

Zobrazí sa upozornenie Zrušiť históriu a môžete buď Zastaviť alebo Pokračovať v nástroji.

Gnome-important.png
Undo history

Pokračovanie s týmto nástrojom vymaže históriu zrušenia pre túto reláciu. Konkrétne nebudete môcť vrátiť späť zmeny vykonané týmto nástrojom ani žiadne zmeny vykonané pred ním. Ak si myslíte, že budete chcieť vrátiť spustenie tohto nástroja, zastavte sa tu a zálohujte svoju databázu.


Fig. 14.14 "Zmena typov udalostí" - dialógové okno - príklad pre nástroj "Premenovanie typov udalostí"

Zobrazí sa dialógové okno Zmena typov udalostí.

  • Pôvodný typ udalosti: vyplňte textové pole alebo použite rozbaľovaciu ponuku a vyberte pôvodný typ udalosti.
  • Nový typ udalosti: vyplňte textové pole (môžete tu vytvoriť úplne nový typ) alebo použite rozbaľovaciu ponuku a vyberte nový typ

Príklad ukazuje premenovanie udalosti Narodenie na udalosť Krst'.

Gramps-notes.png
Vlastné typy

Keďže sa vlastné typy nezobrazujú v rozbaľovacom zozname, môžete ich prepísať alebo vložiť do niektorého z výberových polí a previesť z jedného na druhý.



Fig. 14.15 "Zmena typov" - dialógové okno s výsledkom - príklad pre nástroj "Premenovanie typov udalostí"

Nakoniec použite Zrušiť na ukončenie alebo vyberte OK na spustenie nástroja a po jeho dokončení sa zobrazí správa o celkovom počte zmenených udalostí s dialógovým oknom Zmeniť typy výsledkov.

Gnome-important.png
Premenovanie udalostí

Po dokončení sa to nedá vrátiť späť bežnou funkciou Undo.

Pozri tiež:

Zmena poradia Gramps ID

Tento nástroj môžete použiť na zmenu poradia preukazov Gramps ID. K dispozícii je niekoľko možností.

Gnome-important.png
Custom IDs'

Ak ste si prispôsobili svoje IDs', všetky tieto ID môžu byť nahradené týmto nástrojom. Pred použitím tohto nástroja si preto dávajte pozor!

Obrázok 14.16 ID preusporiadania

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje->Spracovanie rodokmeňa->Preusporiadanie ID-čiek...}.

V stĺpci "Objekt" sa uvádza typ ID. Hneď naľavo od tohto stĺpca sa nachádzajú začiarkávacie políčka, ktoré umožňujú povoliť zmeny jednotlivých typov objektov. Po začiarknutí je možné zmeniť poradie typu. Označenie "Objekt" je vlastne tlačidlo, ktorým možno prepínať všetky začiarkávacie políčka naraz.

V stĺpci "Actual" (Skutočný) je uvedený príklad aktuálneho ID. V stĺpci "Množstvo" sa zobrazuje počet objektov.

Stĺpec "Formát" možno použiť na zmenu formátu ID pre každý typ objektu. Všimnite si, že formát sa skladá z prefixu, znaku "%04d" a prípony. MUSÍ existovať aspoň prefix alebo prípona, povolené sú oba. Odporúča sa, aby boli relatívne krátke. "%04d" definuje dĺžku číselnej časti ID, "4" sa môže meniť, povolené je čokoľvek od "3" (čo umožňuje čísla od 000-999) po "9" (000000000-999999999). Tu vykonané zmeny sú rovnaké ako zmeny vykonané v ponuke Edit->Preferences... a potom vyberte záložku 'ID Formats. Štítok 'Formát' je v skutočnosti tlačidlo, ktoré môžete použiť na obnovenie všetkých formátov na poslednú použitú hodnotu.

Stĺpec 'Zmeniť' obsahuje začiarkávacie políčka pre každý typ objektu. Ak je začiarknuté, ID pre daný objekt sa nahradia novými ID štýlu 'Format' (Formát), pokiaľ nie je začiarknuté aj 'Keep' (Ponechať). Ak nie je začiarknuté žiadne políčko, formáty ID sa NEAKTUALIZUJÚ, ale číselné pole v rámci formátu sa prečísluje. Štítok "Zmeniť" je v skutočnosti tlačidlo, ktoré možno použiť na prepínanie všetkých zaškrtávacích polí naraz.

Pole "Začiatok" označuje počiatočné číslo použité počas operácie prečíslovania. Štítok "Začiatok" je vlastne tlačidlo, ktoré možno použiť na prepínanie medzi začiatkom od 0 a začiatkom za posledným aktuálnym číslom.

Pole "Krok" označuje interval medzi číslami počas prečíslovania, "1" je jednoduchý prírastok, "2" bude prírastok o 2 atď. Označenie "Krok" je vlastne tlačidlo, ktoré možno použiť na prepínanie medzi "1", "2", "5" a "10".

Stĺpec "Keep" (Zachovať) obsahuje zaškrtávacie políčka pre každý typ objektu. Ak je začiarknuté toto políčko a políčko "Zmeniť", formáty ID pre daný objekt sa zachovajú a číselné pole v rámci formátu sa prečísluje. Štítok "Zachovať" je v skutočnosti tlačidlo, ktorým možno prepínať všetky zaškrtávacie políčka naraz.

Zobrazí sa upozornenie Zrušiť históriu a môžete buď Zastaviť, alebo Pokračovať s nástrojom.

Gnome-important.png
Undo history

Pokračovanie s týmto nástrojom vymaže históriu zrušenia pre túto reláciu. Konkrétne nebudete môcť vrátiť späť zmeny vykonané týmto nástrojom ani žiadne zmeny vykonané pred ním. Ak si myslíte, že budete chcieť vrátiť spustenie tohto nástroja, zastavte sa tu a zálohujte svoju databázu.

Keď kliknete na tlačidlo "OK", nástroj zobrazí ukazovateľ priebehu.

V rôznych fázach sa zmení poradie nasledujúcich ID': Preusporiadanie ID osôb", Preusporiadanie ID rodiny", Preusporiadanie ID udalosti", Preusporiadanie ID mediálneho objektu", Preusporiadanie ID zdroja", Preusporiadanie ID citácie", Preusporiadanie ID miesta", Preusporiadanie ID úložiska" a nakoniec Preusporiadanie ID poznámky".

V ďalšom kroku sa vyhľadajú a priradia nepoužívané ID.

Počas tohto procesu nástroj preskúma každé ID, aby zistil, či nevyzerá ako "prispôsobené", či nevyzerá ako predchádzajúci formát ID alebo predvolený formát ID. Môže to byť v prípade, ak používateľ pri úprave objektu zadal do poľa ID svoj vlastný text. Môže sa to vyskytnúť aj vtedy, ak bol použitý doplnok tretej strany GetGOV Addon alebo GeoName Addon, pretože tento nástroj ukladá ID GOV do poľa ID. Ak sa nájde "vlastné" ID, spýta sa používateľa, či chce ID naozaj nahradiť. Dialógové okno tiež umožňuje používateľovi použiť rovnakú odpoveď pre iné nájdené prispôsobené ID.

Triedenie udalostí

Udalosti zobrazené na karte Udalosť v editore osôb alebo rodín nie sú zoradené v inom konkrétnom poradí ako v poradí, v akom boli udalosti pridané. Dôvodom nevynútenia žiadneho konkrétneho zoradenia, najmä zoradenia podľa dátumu, je umožniť situáciu, keď sa o udalosti vedelo, že sa stala, ale presná chronológia nie je známa. Importovanie alebo spájanie údajov z externého zdroja môže viesť k pridaniu ďalších udalostí do existujúceho súboru udalostí osoby alebo rodiny, ale mimo ich poradia.

Udalosti môžete ručne preusporiadať potiahnutím a pustením alebo pomocou tlačidiel na preusporiadanie na karte Events. Tak či onak, udalosť možno v zozname udalostí presunúť nahor alebo nadol a program Gramps si po uložení zmien zapamätá nové poradie. Nové poradie sa použije všade tam, kde sa udalosti zobrazujú inde v programe Gramps, napríklad v správe.

Poradie všetkých udalostí na karte možno zmeniť aj kliknutím na názov stĺpca. Napríklad kliknutím na nadpis stĺpca "Dátum" sa všetky udalosti zoradia v poradí podľa dátumu. Tento spôsob zoradenia udalostí je však dočasný a zmeny poradia udalostí sa po zatvorení okna nezachovajú.

Prístup potiahni a pusť k triedeniu udalostí je vhodný na presun malého počtu udalostí, ale nie je praktický na rozsiahle zmeny. Nástroj Triediť udalosti bol navrhnutý špeciálne na tento účel, pričom pretriedi všetky udalosti v databáze alebo len tie, ktoré sú spojené s cieleným výberom osôb vybraných pomocou filtra.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje->Spracovanie rodokmeňa->Triediť udalosti....

Zobrazí sa upozornenie Zrušiť históriu a môžete buď Zastaviť alebo Pokračovať v nástroji.

Gnome-important.png
Undo history

Pokračovanie s týmto nástrojom vymaže históriu zrušenia pre túto reláciu. Konkrétne nebudete môcť vrátiť späť zmeny vykonané týmto nástrojom ani žiadne zmeny vykonané pred ním. Ak si myslíte, že budete chcieť vrátiť spustenie tohto nástroja, zastavte sa tu a zálohujte svoju databázu.


Fig. 14.17 "Triedenie udalostí" - dialógové okno - zobrazenie karty "Možnosti nástroja" pre nástroj "Triedenie udalostí"

Prvá možnosť v dialógovom okne Triedenie udalostí slúži na definovanie rozsahu osôb, ktorých udalosti sa majú triediť. Prvá voľba v zozname je použiť triedenie na všetkých ľudí v databáze. Alternatívne možnosti sú použiť triedenie na predkov a potomkov vybranej osoby alebo na rozsah osôb vybraných pomocou vlastného vytvoreného filtra osôb. Po výbere, na koho sa má triedenie použiť, je potrebné zvážiť, ako sa majú udalosti triediť. Prvou možnosťou je triedenie podľa dátumu. Je to pravdepodobne najpravdepodobnejšia voľba, ale je možné zvoliť aj iné atribúty udalostí. Poslednou voľbou je, či majú byť udalosti zoradené vzostupne alebo zostupne a či sa má triedenie aplikovať aj na rodinné udalosti, ku ktorým vybrané osoby patria.


Gnome-important.png
Triedenie udalostí

Po dokončení sa nedá vrátiť späť bežnou funkciou Undo.

Oprava rodokmeňa

Kontrola a oprava databázy

Gnome-important.png
Upozornenie

Nástroj Kontrola a oprava databázy vykonáva automatické opravy. Po dokončení sa nedá vrátiť späť bežnou funkciou Undo.

Tento nástroj kontroluje databázu na problémy s integritou a opravuje problémy, ktoré môže. Konkrétne nástroj kontroluje:

  • Porušené rodinné väzby. Ide o prípady, keď záznam osoby odkazuje na rodinu, pričom záznam rodiny neodkazuje na túto osobu a naopak.
  • Chýbajúce mediálne objekty. Chýbajúci mediálny objekt je objekt, na ktorého súbor sa odkazuje v databáze, ale neexistuje. Môže sa to stať, keď sa súbor omylom vymaže, premenuje alebo presunie na iné miesto.
  • Prázdne rodiny. Ide o záznamy rodín, ktoré nemajú odkaz na žiadnu osobu ako svojho člena.
  • Vzťahy medzi rodičmi. Týmto sa kontrolujú všetky rodiny, aby sa zabezpečilo, že otec a matka nie sú zamenené. Kontroluje sa tiež, či rodičia majú rozdielne pohlavie. Ak majú spoločné pohlavie, ich vzťah sa premenuje na "Partneri".

Tento nástroj môžete použiť cez ponuku Nástroje->Oprava rodokmeňa->Kontrola a oprava databázy....

Gnome-important.png
História zrušenia

Pri použití tohto nástroja sa vymaže história zrušenia pre túto reláciu. Nebudete môcť vrátiť späť najmä zmeny vykonané týmto nástrojom alebo akékoľvek zmeny vykonané pred ním. Odporúčame vám, aby ste sa tu zastavili a zálohovali svoju databázu; aby ste mohli vrátiť proces spustenia tohto nástroja.

Zobrazí sa Upozornenie na zrušenie histórie a môžete buď Zastaviť alebo Pokračovať v práci s nástrojom.


Fig. 14.18 "Výsledky kontroly integrity" - príklad dialógového okna s výsledkami - pre nástroj "Kontrola a oprava databázy"

Všetky nájdené problémy sa automaticky opravia a zobrazí sa dialógové okno {Výsledky kontroly integrity so súhrnom vykonaných činností.
V opačnom prípade sa zobrazí dialógové okno Nenašli sa žiadne chyby, v ktorom sa uvádza, že Databáza prešla internými kontrolami.

Obnoviť rodové štatistiky

Fig. 14.19 "Obnovené štatistiky pohlaví" - dialógové okno výsledku pre nástroj "Obnoviť štatistiky pohlaví"

Prebuduje rodové štatistiky pre odhadnutie pohlavia mena...

Tento nástroj môžete použiť cez ponuku Nástroje->Oprava rodokmeňa->Prebudovať rodové štatistiky....

Po dokončení sa zobrazí dialógové okno Prebudovanie rodových štatistík s výsledkom.

Prestaviť referenčné mapy

Fig. 14.20 "Referenčné mapy prebudované" - dialógové okno výsledku pre nástroj "Prebudovať referenčné mapy"

Tento nástroj prebuduje tabuľky referenčných máp. Tým sa riadi zoznam položiek Referencie v editoroch.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje ➡ Oprava rodokmeňa ▶ Prebudovať referenčné mapy....

Po dokončení sa zobrazí dialógové okno Referenčné mapy prebudované s výsledkom.

Pozrite tiež


Obnoviť sekundárne indexy

Fig. 14.21 "Prebudované sekundárne indexy" - dialógové okno s výsledkom pre nástroj "Prebudovať sekundárne indexy"

Tento nástroj prebuduje sekundárne indexy.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje ➡ Family Tree Repair ▶ Rebuild Secondary Indexes....

Po dokončení sa zobrazí dialógové okno Secondary indexes rebuilt s výsledkom.

V ponuke Prebudovať sekundárne indexy... sa znovu skonštruujú sekundárne tabuľky v db Stromu. Tieto tabuľky obsahujú veci ako štatistiky pohlavia (Given Name versus gender), aby bolo možné odhadnúť pohlavie mien pri ich zadávaní, priezviská (pre rýchlejšie vyhľadávanie možných priezvisk a aby fungovalo zobrazenie stromu osôb), rôzne ID pre objekty (pre uľahčenie vyhľadávania podľa ID), tabuľky príloh miest, aby fungovalo zobrazenie stromu miest, a niekoľko ďalších.

Teoreticky sa tieto tabuľky neustále aktualizujú, keď sa niečo zmení. Preto by nemalo byť potrebné obnovovať referenčné mapy a sekundárne indexy. Ale najmä na začiatku histórie programu Gramps chyby niekedy bránili správnemu dokončeniu aktualizácií. Takže tieto nástroje zostávajú k dispozícii... ‘pre prípad’.

Pozrite si tiež


Odstrániť nepoužívané objekty

Tento nástroj vyhľadá vo vašej databáze časti informácií, ktoré nie sú spojené s ničím iným, a potom vám umožní upraviť a pripojiť informácie alebo ich odstrániť.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje->Oprava rodokmeňa->Odstrániť nepoužívané objekty....


Fig. 14.22 "Nepoužívané objekty" - príklad výsledkov dialógového okna pre nástroj "Odstrániť nepoužívané objekty"

Zobrazí sa dialógové okno Nevyužité objekty.

V hornej časti dialógového okna Nepoužívané objekty si môžete vybrať z možností vyhľadávania, ktoré chcete použiť:

  • Hľadať udalosti (predvolene začiarknuté políčko)
  • Vyhľadávanie zdrojov (štandardne začiarknuté políčko)
  • Vyhľadávanie citácií (štandardne začiarknuté políčko)
  • Vyhľadávanie miest (štandardne začiarknuté políčko)
  • Vyhľadávanie médií (políčko je predvolene začiarknuté)
  • Vyhľadávanie úložísk (štandardne začiarknuté políčko)
  • Vyhľadávanie poznámok (políčko je predvolene začiarknuté)

Výberom tlačidla Vyhľadať spustíte hlásenie a po dokončení sa prípadné výsledky zobrazia v dolnej časti dialógového okna Nepoužívané objekty s nasledujúcimi zobrazenými stĺpcami:

  • Označenie Vyberte riadok, ak chcete objekt vymazať (začiarkávacie políčko je štandardne nezačiarknuté)
  • - Ikona reprezentujúca typ objektu.
  • ID - Interný názov objektu v gramatike.
  • Name - objektu.

Ak chcete preskúmať objekt, musíte dvakrát kliknúť na riadok a zobrazí sa príslušný editor pre objekt, ktorý vám v prípade potreby umožní úpravy.

Označte objekty, ktoré chcete odstrániť, buď pomocou jednotlivých zaškrtávacích políčok, alebo pomocou príslušných tlačidiel:

  • Označiť všetko
  • Unmark all
  • Invert marks

Po výbere možností vymazania vyberte tlačidlo Vymazať, aby ste vymazali objekty.

Po dokončení môžete nástroj ukončiť pomocou tlačidla Zatvoriť.

Nástroje

Táto časť obsahuje nástroje, ktoré vám umožňujú vykonať jednoduchú operáciu s časťou údajov. Výsledky môžete uložiť do databázy, ale nezmenia vaše existujúce údaje. V súčasnosti sú v programe Gramps k dispozícii nasledujúce nástroje:


Čistenie vstupných údajov

Odstrániť úvodné a koncové medzery

Fig. 14.23 Čisté vstupné údaje
Gramps-notes.png

Please update or expand this section.


Nástroj na potlačenie počiatočných a koncových medzier.    Nástroj vyhľadáva názvy miest s úvodnými a/alebo koncovými medzerami. Vyhľadáva tiež v mene a priezvisku.

Prístup k nemu je možný z ponuky {{manu{Nástroje > Nástroje > Čistenie vstupných údajov...}}}.

Pozrite si tiež:

Vyhľadanie slučky databázy

Fig. 14.24 Nájsť možnú slučku

Nástroj Nájdenie slučky v databáze umožňuje overiť, či sa v databáze nachádzajú slučky predkov.

Ak ho vyberiete cez ponuku Nástroje->Užitky->Nájsť slučku databázy...}, zobrazí sa okno Nájsť slučku databázy. Okno má päť záložiek: Gramps_ID, Parent, Gramps_ID, Child, Family ID.

  1. Prvé Gramps_ID je odkaz na Rodiča.
  2. Rodič (Predok na obrázku) je osoba, ktorej hľadáme slučku.
  3. Druhé ID_rodiča je odkaz na dieťa.
  4. Dieťa (Potomok) je pôvodca slučky.
  5. Family_ID je odkaz na príslušnú rodinu


Fig. 14.25 Nájsť možnú slučku v zložitom príklade

V nasledujúcom zložitom príklade máme viacero predchodcovských slučiek :

Ak sa pozrieme na druhý riadok, máme :

  1. Prvé Gramps_ID : I0002
  2. Rodič je : Otec, Dieťa2
  3. Second Gramps_ID : I0001
  4. Child is : Otec, Otec
  5. Family_ID je : F0000

Aby ste pochopili, čo sa deje :

  1. začneme na [I0002] Otec, Dieťa2.
  2. Pokračujeme jeho synom [I0003] Otec, dieťa3.
  3. Pokračujeme jeho synom : [I0000] Dieťa, Dieťa.
  4. Pokračujeme jeho synom : [I0001] Otec, Otec.
  5. Pokračujeme jeho synom : [I0002] Otec, Dieťa2 ==> TU máme rodovú slučku.


Viac informácií o rodových slučkách nájdete na stránke:

Mediálny manažér

Gramps-notes.png

Please update or expand this section.


Fig. 14.26 Úvod - stránka pre "Gramps Media Manager" - Sprievodca nástrojmi

Gramps Media Manager je skupina štyroch samostatných nástrojov prístupných prostredníctvom dialógového okna podobného sprievodcovi, ku ktorému sa dostanete cez menu Tools->Utilities->Media Manager..., ktoré zobrazí prvú Úvodnú' dialógovú stránku s nasledujúcimi informáciami o schopnostiach nástrojov.

Gramps-notes.png
Úvod

Tento nástroj umožňuje dávkové operácie s mediálnymi objektmi uloženými v programe Gramps. Je potrebné urobiť dôležitý rozdiel medzi mediálnym objektom Gramps a jeho súborom.

Mediálny objekt Gramps je zbierka údajov o súbore mediálneho objektu: názov a/alebo cesta k nemu, jeho popis, ID, poznámky, odkazy na zdroj atď. Tieto údaje neobsahujú samotný súbor.

Súbory obsahujúce obrázok, zvuk, video atď. existujú samostatne na vašom pevnom disku. Tieto súbory nie sú spravované programom Gramps a nie sú zahrnuté v databáze Gramps. Databáza Gramps ukladá iba cestu a názvy súborov.

Tento nástroj vám umožňuje upravovať iba záznamy v rámci databázy Gramps. Ak chcete súbory presunúť alebo premenovať, musíte to urobiť sami, mimo programu Gramps. Potom môžete pomocou tohto nástroja upraviť cesty tak, aby objekty médií ukladali správne umiestnenie súborov.


Na stránke Úvod sa výberom tlačidla Ďalej (alebo použitím klávesovej skratky Alt+N) zobrazí okno stránky Výber.

Fig. 14.27 Výber - stránka pre "Gramps Media Manager" - Sprievodca nástrojmi - predvolené

V okne stránky Výber vyberte zo štyroch možností jednu z akcií, ktoré chcete vykonať, a potom vyberte tlačidlo Ďalej:


Nahradenie podreťazcov v ceste

Obrázok 14.28 Nahradiť nastavenia podreťazca - stránka pre "Gramps Media Manager" - Sprievodca nástrojmi - predvolené

Tento nástroj umožňuje nahradiť zadaný podreťazec v ceste k mediálnym objektom iným podreťazcom. Môže to byť užitočné pri presúvaní mediálnych súborov z jedného adresára do druhého.

Výberom tohto prepínača sa zobrazí okno Nastavenie nahradenia podreťazca, v ktorom môžete do textového poľa Nahradiť a do textového poľa Spomocou zadať ľubovoľný reťazec. Kedykoľvek môžete kliknúť na tlačidlo Zrušiť alebo na tlačidlo Späť. Kliknutím na tlačidlo Prechod sa zobrazí okno Konečné potvrdenie.


Konverzia ciest z relatívnych na absolútne

Fig. 14.29 "Convert paths from relative to absolute": "Final Confirmation" page for "Gramps Media Manager" - Tool wizard - example

Tento nástroj umožňuje konvertovať relatívne cesty k médiám na absolútne. Robí to tak, že predvyplní Základná cesta pre relatívne cesty k médiám:, ako je uvedené na karte Upraviť > Predvoľby > Všeobecné ], alebo ak táto nie je nastavená, predvyplní predvolený Adresár užívateľa.



Konverzia ciest z absolútnych na relatívne

Fig. 14.30 "Convert paths from absolute to relative": "Final Confirmation" page for "Gramps Media Manager" - Tool wizard - example

Tento nástroj umožňuje konvertovať absolútne cesty k médiám na relatívne cesty. Relatívna cesta je relatívna voči zadanej základnej ceste v nastavení Základná cesta pre relatívne cesty k médiám: ako z karty Upraviť > Predvoľby > Všeobecné , alebo ak nie je nastavená, použije sa adresár používateľa. Relatívna cesta umožňuje naviazať umiestnenie súboru na základnú cestu, ktorá sa môže meniť podľa vašich potrieb.


Pridanie obrázkov, ktoré nie sú zahrnuté v databáze

Fig. 14.31 "Add images not included in database": "Final Confirmation" page for "Gramps Media Manager" - Tool wizard - example

Kontrola adresárov na obrázky, ktoré nie sú zahrnuté v databáze, tento nástroj pridáva obrázky do adresárov, na ktoré odkazujú existujúce obrázky v databáze. Budete musieť manuálne importovať jeden mediálny prvok z každého podadresára. Správca médií nezahŕňa podadresáre automaticky. Prehľadajú sa všetky cesty k adresárom zobrazené v nástroji.

Nesúvisí

Fig. 14.32. "Nesúvisí s "..." - dialógové okno - zobrazenie výsledkov pre nástroj "Nesúvisí"

Tento nástroj zobrazí zoznam osôb, ktoré nie sú prepojené s vybranou aktívnou osobou. Spojenia môžu zahŕňať prepojenia v reťazci referencie alebo prepojenia vytvorené pomocou editor odkazov v Poznámkach.

Tento nástroj môžete použiť prostredníctvom ponuky Nástroje->Utility->Nesúvisí...}.

Zobrazí sa dialógové okno Nesúvisí s '...' výsledkov, v ktorom sa zobrazí zoznam všetkých osôb, ktoré nie sú NESÚVISIACE s vybranou osobou.

Tento zoznam vám poskytne:

  • Meno
  • ID
  • Rodičia
  • Značky

V stĺpci Názov môžete použiť tlačidlá šipka doprava a šipka nadol na zbalenie alebo rozbalenie zoskupeného zoznamu Názov. Dvojitým kliknutím na osobu sa zobrazí dialógové okno úprava osoby alebo úprava rodiny.

Ak vyberiete osobu, môžete použiť textové pole značka (môžete vyplniť ľubovoľný vlastný názov značky, ktorý chcete použiť) alebo použiť rozbaľovací zoznam a vybrať existujúcu značku, napr. Pomocou tlačidla Použiť pridajte vybraný tag k osobe (osobám). Tento tag sa potom zobrazí v stĺpci Tagy.

Kalkulátor vzťahov

Fig. 14.33 "Vzťah k "... " - dialógové okno - zobrazenie výsledkov pre nástroj "Kalkulátor vzťahov"

Tento nástroj môžete použiť prostredníctvom ponuky {{manu{nabídka|Nástroje->Utility->Kalkulátor vzťahov...}}.

Výberom nástroja Kalkulátor vzťahov sa otvorí zoznam filtrovaný na všetky osoby spojené, ale nie nevyhnutne príbuzné, s Active Person. Ak chcete vypočítať vzťah k inej osobe, zatvorte okno, urobte túto osobu Aktívnou a znovu vyberte nástroj z ponuky.

Vyberte osobu z filtrovaného zoznamu, aby ste mohli oznámiť, či existuje vzťah. Presný vzťah sa zobrazí v dolnom paneli spolu so spoločnými predkami tohto nahláseného vzťahu. Zobrazia sa len pokrvné vzťahy (okrem vzťahov medzi manželom a manželkou). Všimnite si, že sa nezobrazia vzťahy "príbuzenský vzťah".

Filtrovaný zoznam bude zoskupený a abecedne zoradený podľa priezviska. (Bez ohľadu na to, či bolo nastavenie ponuky Zobraziť v kategórii Osoba nastavené na možnosť Zoskupené). Stĺpce zoznamu nie je možné opätovne zoradiť.

Stupeň oddelenia (generačná vzdialenosť), ktorý bude rozpoznaný, sa riadi hodnotou Max. generácie pre vzťahy v záložke Všeobecné v ponuke Upraviť->Predvoľby.... (Predvolená hodnota 15 generácií oznámi vzťah 12 prarodičov, ale nie ich rodičov. Aktívna osoba sa počíta ako jedna z generácií.)

V podstate sú akékoľvek dve osoby priamo pokrvne príbuzné, ak majú spoločného predka. Jedna z týchto osôb môže byť v skutočnosti predkom druhej osoby - napríklad prastarým rodičom. Aj v prípadoch tiet a strýkov môžete príbuzenský vzťah vypočítať tak, že vyhľadáte spoločného predka. V tomto prípade bude otec alebo matka tety alebo strýka starým rodičom synovca alebo netere.

Najzákladnejším pokrvným príbuzenským vzťahom prostredníctvom spoločných predkov je príbuzenský vzťah súrodencov (bratov a sestier), ktorí sú od spoločného predka vzdialení len jednu generáciu. Ďalším osobitným vzťahom je vzťah jedného z týchto súrodencov k potomkom ostatných súrodencov. Ak je Aktívna osoba vnukom spoločného predka, súrodenec by bol tetou alebo strýkom. Okrem tejto generácie potomkov existujú dva rovnocenné spôsoby opisu vzťahu. Dcéra prastarých rodičov by sa mohla nazývať buď babička, alebo prateta. (V kalkulačke vzťahov sa používa variant "grand".) Táto osoba je prababičkou pre druhých prapravnukov, ktorí sú od spoločného predka vzdialení štyri generácie. (Môže sa nazývať aj druhá prateta.) Opačným príbuzenským vzťahom tety alebo strýka je synovec alebo neter.

Bratranci a sesternice (nazývaní aj "prví" bratranci a sesternice) sú vzdialení dve generácie od spoločného predka prostredníctvom rôznych súrodencov. "Druhí" bratranci a sesternice sú teda tri generácie po spoločnom predkovi - a tak ďalej.

Potom sa každý považuje za "bratranca a sesternicu", ale na označenie toho, že nie sú v rovnakej generácii, používame slovo "vzdialený", ktoré označuje počet generácií, ktoré sa medzi nimi líšia. Napríklad "prvý" bratranec môjho otca je aj môj "prvý" bratranec, ale "raz vzdialený" (rozdiel medzi nami je jedna generácia). "Prvý" bratranec môjho otca je "dvakrát vzdialený" bratranec môjho vlastného dieťaťa - rozdiel dvoch generácií.

Ak existuje viacero pokrvných príbuzenských vzťahov v dôsledku zrútenia rodokmeňa, všetky budú uvedené.

Úplný textový zoznam všetkých pokrvných príbuzných a ich manželských partnerov si môžete pozrieť pomocou Správa o príbuzenstve.

Pozri tiež:

  • Voľba Vzťah k domovskej osobe Predvoľby zobrazenia pre stavový riadok
  • Vzťah k domovskej osobe Rýchle zobrazenie.
  • 'Hlboké spojenia gramplet: Ak je nainštalovaný tento doplnok tretej strany, zobrazí zoznam generácií, ktoré zasahujú do spoločného predka prostredníctvom súrodeneckých potomkov. (Nevypíše však spoločného predka ani to, či sú obe osoby prepojené cez toho istého manžela/manželku.) Gramplet uvádza aj podrobné údaje o nepriamych príbuzenských vzťahoch.


Overenie údajov

Fig. 14.34 "Overenie údajov..." - Dialógové okno "Nástroj na overenie údajov" - karta "Všeobecné" - predvolené nastavenia

Tento nástroj umožňuje overiť databázu na základe súboru vami zadaných kritérií.

Môžete sa napríklad uistiť, že nikto vo vašej databáze nemal deti vo veku 98 rokov. Na základe zdravého rozumu by takýto záznam znamenal chybu. Nejde však o chybu konzistencie v databáze. Okrem toho niekto môže mať dieťa vo veku 98 rokov (hoci sa to stáva zriedkavo). Nástroj Overiť zobrazí všetko, čo porušuje vaše kritériá, aby ste mohli skontrolovať, či je záznam chybný alebo nie. Konečné rozhodnutie je na vás.

Ak ho vyberiete cez ponuku Nástroje->Užitočnosť->Overiť údaje..., zobrazí sa okno Nástroj na overenie údajov. Okno má štyri záložky: Všeobecné, Ženy, Muži, Rodiny. Na týchto záložkách sa zobrazuje zoznam s kritériami a vstupné pole, v ktorom môžete zmeniť hodnotu kritérií. V nasledujúcich zoznamoch uvádzam niektoré použiteľné hodnoty.

Overenie stránok karty Údaje

Z nasledujúcich kariet vyberte kritériá, s ktorými chcete nástroj spustiť. Ak sú kritériá v poriadku, kliknite na tlačidlo Spustiť (alebo stlačte Alt+R a zobrazí sa vám okno Výsledky overovania údajov.

V závislosti od vašich kritérií a údajov sa zobrazí zoznam. Niektoré možnosti zistení sú uvedené nižšie. Existujú však aj ďalšie.

  • Odpojené osoby (osoby bez rodiča alebo manžela/manželky, dieťaťa alebo súrodenca)
  • Starý/mŕtvy otec
  • manželstvo po smrti/pred narodením
  • veľké rozpätie rokov pre všetky deti
  • skoré/neskoré manželstvo
  • mladá/nezadaná matka
  • manžel a manželka s rovnakým priezviskom
  • manželstvo rovnakého pohlavia/manželka
  • ...
Všeobecné
  • Maximálny vek: 90
  • Minimálny vek na uzavretie manželstva: 17
  • Maximálny vek na uzavretie manželstva: 50
  • Maximálny počet manželov pre jednu osobu: 3
  • Maximálny počet po sebe nasledujúcich rokov vdovstva pred ďalším sobášom: 30
  • Maximálny vek slobodnej osoby: 99

Prvé začiarkávacie políčko: Odhadnúť chýbajúce alebo nepresné dátumy spôsobí, že nástroj akceptuje dátum krstu, ak nie je známy dátum narodenia, a akceptuje dátum pohrebu, ak nie je známy dátum úmrtia. Taktiež spôsobí, že nástroj akceptuje "nepresné" dátumy (t. j. akýkoľvek "zákonný" dátum Gramps, ktorý nie je plne špecifikovaný (s explicitným dňom a mesiacom a rokom)).

Druhé začiarkávacie políčko: Identifikovať neplatné dátumy skontroluje, či sú dátumy neplatné.

Ženy
  • Minimálny vek na splodenie dieťaťa: 17
  • Maximálny vek na donosenie dieťaťa: 48
  • Maximálny počet detí: 12
Muž
  • Minimálny vek otca dieťaťa: 18
  • Maximálny vek otca dieťaťa: 65
  • Maximálny počet detí: 15
Rodiny
  • Maximálny vekový rozdiel medzi manželom a manželkou: 30
  • Maximálny počet rokov medzi deťmi: 8
  • Maximálne rozpätie rokov pre všetky deti: 25


Okienko s výsledkami overovania údajov

Fig. 14.35 Okno výsledkov overovania údajov

.

Po spustení nástroja sa vám zobrazí okno Výsledky overenia údajov.

V spodnej časti okna sú k dispozícii štyri tlačidlá na uľahčenie výberu. Sú to Označiť všetko, Odznačiť všetko, Invertovať značky a Skryť označené.

Dvojkliknutím na riadok získate možnosť zobraziť a prípadne upraviť údaje.

Pomocou tlačidla Zatvoriť (alebo vyberte klávesovú skratku Alt+C) zatvoríte okno Výsledky.

Príklady

Dva príklady z používania skutočných údajov s týmto nástrojom:

  • Pri kontrole údajov som našiel rodinu s otcom : Anna Roelants. Našťastie v Opis som si prečítal: Manželstvo Adama Roelantsa a Cornelie Crabbeovej. Bol to zjavne preklep: Anna i.s.o. Adam. Bez tejto pomôcky' by sa to veľmi ťažko hľadalo.
  • Upozornenie ukazovalo 'neskoré manželstvo': kontrola údajov: mužská osoba °1738 ženská osoba °1756 : sobáš X 1804 [gregoriánsky kalendár] : Všetko sa zdalo byť v poriadku: takže sa (znovu)vzali vo veku 66 a 48 rokov! Upozornenie sa objavilo, pretože Všeobecné kritériá boli nastavené na hodnotu 60.
Tango-Dialog-information.png
Rozdiel medzi nástrojmi Overiť údaje a Nástroj Kontrola a oprava databázy

Nástroj Kontrola a oprava databázy zisťuje nezrovnalosti v štruktúre databázy. Nástroj Overiť údaje však zisťuje záznamy, ktoré nespĺňajú vaše konkrétne kritériá.


Ladenie

Gnome-important.png
Varovanie Nepoužívajte nástroje Ladenie na pracovnom rodinnom strome.

Vždy vytvorte nový prázdny Rodinný strom alebo kópiu vášho končiaceho Rodinného stromu pre testovanie.
Nástroje dostupné v tomto rozšírenom menu slúžia len na testovanie.

Fig. 14.36 "Nástroje >Debug>..." Menubar - Nástroje - Prehľad menu Ladenie

Ak nie je zapnutý príznak optimalizácie pythonu -O, v ponuke Debug sa objaví ďalšia položka Nástroje.

Pozrite si Príkazový riadok: Možnosti Pythonu.

Kontrola lokalizovaného zobrazovača a analyzátora dátumu

Fig. 14.37 Dialógové okno "Spustiť test dátumu?" - pre "Kontrolu lokalizovaného zobrazovača a analyzátora dátumu" - nástroj

Tento testovací nástroj vytvorí mnoho ľudí, ktorí zobrazia všetky rôzne varianty dátumu ako narodenia. Dátum úmrtia sa vytvorí rozborom výsledku zobrazovača dátumu pre dátum narodenia. Týmto spôsobom sa môžete uistiť, že vytlačené dátumy sa dajú správne analyzovať späť.

Gramps-notes.png

Please update or expand this section.