Fr:Manuel wiki pour Gramps 4.1 - Catégories

From Gramps
Jump to: navigation, search
Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions


Précédent Index Suivant



Catégories du navigateur

L'information généalogique est très large et peut être extrêmement détaillée. L'afficher est un défi que Gramps relève en divisant et organisant l'information à travers une série de catégories. Chaque catégorie, possédant sa propre vue, affiche une partie de l'information totale, sélectionnée selon une catégorie particulière. Cela deviendra plus clair quand nous aurons exploré les différentes catégories, listées ci-dessous:

  • Gramplets Tableau de bord : affiche les différents gramplets, petits widgets pouvant aider à la recherche généalogique.
  • People Individus : affiche les individus de l'arbre familial sans leurs connections. Cette catégorie contient une vue sous forme de liste et une vue hiérarchisée.
  • Relationships Relations : affiche les relations entre la personne active et les autre individus sous forme de texte. Ceci inclut les parent, conjoints, et enfants.
  • Family Familles : affiche les familles de l'arbre familial
  • Ancestry Lignée : affiche un graphique pour la personne sélectionnée
  • Events Événements : affiche les événements de l'arbre familial
  • Places Lieux : affiche les lieux de l'arbre familial
  • Geography Géographie : affiche les données de votre arbre sur une carte
  • Media Media : affiche les objets media de l'arbre familial
  • Sources (v3.4.x) Sources : affiche les sources de l'arbre familial
  • Citations Citations : affiche les citations de l'arbre familial
  • Repositories Dépôts : affiche les dépôts de l'arbre familial
  • Notes Notes : affiche les notes de l'arbre familial

Ces catégories peuvent contenir plusieurs représentations de vos données. Chaque présentation spécifique est appelée une Vue. Avant de se lancer dans la description de chaque vue, commençons par expliquer comment changer de vue.

Tableau de bord

Fig. 4.1 Gramplets

Cette catégorie affiche un nombre de widgets, appelés Gramplets, qui peuvent vous aider dans vos recherches. Deux gramplets sont affichés au démarrage (Bienvenue et Principaux noms de famille), avec un clic-droit dans la vue, vous aurez la possibilité d'en ajouter d'autres à travers une liste de choix.

Pour obtenir plus d'informations sur l'utilisation des Gramplets, voir Gramplets. Voici un aperçu des fonctionnalités :

  • Arbre : affiche un arbre généalogique compressé des ascendants directs, ainsi qu'un résumé par génération. Cliquez sur les liens pour voir les entrées correspondantes.
  • Âge à la date : ce gramplet calcule les âges des individus de votre arbre familial, en vie à cette date donnée.
  • À faire : dans cette fenêtre vous pouvez ajouter votre liste "À faire", ou toute autre note. Plusieurs gramplets "À faire" peuvent vous organiser dans vos recherches.
  • Bienvenue : est une fenêtre Bienvenue dans GRAMPS
  • Calendrier : affiche les événements pour ces jours/mois et années.
  • Noms de famille : affiche votre top 10 des noms de famille.
  • Nuage de noms : affiche une fenêtre avec une nuée de noms de famille les plus courants.
  • Statistiques : affiche une fenêtre avec un résumé de l'Arbre Familial : nombre d'individus, hommes et femmes, nombre de familles, media, etc.

D'autres Gramplets peuvent être installés. Voir Third-party Plugins pour plus de détails.

Individus

La catégorie Individus liste les individus stockés dans la base de données. Elle permet d'afficher plusieurs colonnes d'information sur chaque individu:

  • Son nom
  • Son Id Gramps
  • Son genre
  • Sa date de naissance
  • Son lieu de naissance
  • Sa date de décès
  • Son lieu de décès
  • Le nom de son conjoint
  • Les étiquettes qui lui sont liées
  • Sa date de modification

Types de vues

Deux types de vues existent dans cette catégorie:

  • La vue hiérarchisée des individus : Les individus sont groupés d'après leur nom de famille. A gauche de chaque nom de famille il y a une flèche ou un autre indicateur du type +. Cliquez sur l'indicateur pour déployer l'ensemble de la liste d'individus partageant le même nom de famille. Cliquez une nouvelle fois sur l'indicateur compactera la liste et n'affichera que le nom de famille.
  • La vue sous forme de liste d'individus : Les individus sont présentés sous forme d'une liste.
Fig. 4.2 Vue hiérarchisée des individus (défaut)
Fig. 4.3 Liste des individus


Relations

La vue Relations affiche toutes les relations autour de la personne active (la personne sélectionnée). En particulier, cette vue montre ses parents, ses frères et sœurs, ses conjoints et ses enfants.

La vue Relations est adaptée pour permettre une navigation rapide. Vous pouvez changer rapidement de personne active simplement en cliquant sur le nom de n'importe laquelle des personnes listées. Chaque nom est un lien hypertexte, similaire à une page internet.

Le style pour le nom de la personne active est gras. Les autres noms sont affichés avec ou sans le style gras, italique selon les relations existantes pour la personne active.

  • Pour un individu noté comme parent ou conjoint de la personne active, le nom utilise un style typographique différent si cet individu a au moins un parent.
  • Pour un individu noté comme enfant, frère ou sœur de la personne active, le nom utilise un style typographique différent si cet individu a au moins un enfant.
Fig. 4.4 Vue Relations
Fig. 4.5 Vue Relations

La vue Relations affiche ces différentes sections :

  • La personne active : en haut de l'écran, est affiché le nom, l'id, les informations de naissance et de décès ainsi que le calcul de l'âge de la personne active. Si une photo de l'individu est disponible, elle est affichée sur le côté droit. A côté du nom de la personne il y a un symbole indiquant le genre, et un bouton Gramps-notes.pngÉditer. Cliquer sur le bouton Gramps-notes.pngÉditer vous permettra d'éditer toutes les informations de l'individu dans un dialogue d'Édition de l'individu.
  • Les parents : la section suivante, la section parents, affiche les familles dont la personne est l'enfant. Puisqu'il est possible pour une personne d'avoir plusieurs couple de parents, il est possible d'avoir plusieurs sections parents.

A côté de chaque individu listé il y a un bouton Gramps-notes.pngÉditer, lequel vous permettra d'éditer tous les détails d'une personne particulière.

Vous pouvez ajouter un nouveau couple de parents soit en sélectionnant Ajouter des parents ou Partager des parents. Le bouton Ajouter des parents produira une nouvelle famille dont la personne active sera listée comme enfant. Le bouton Partager des parents vous permettra de choisir à partir d'une liste de familles existantes, puis d'ajouter la personne comme enfant de la famille.

Vous pouvez éditer des parents existants en sélectionnant le bouton Gramps-notes.pngÉditer à côté des parents. Si vous sélectionnez - à côté du couple de parents, alors la personne active ne sera plus l'enfant des parents. Ce bouton ne supprime pas la relation entre les parents.

Gnome-important.png
Attention

Si vous n'êtes pas prudent, il est possible de créer plusieurs familles avec le même individu. C'est rarement ce que prévoyait l'utilisateur. Si vous essayez d'ajouter une nouvelle famille ayant les mêmes parents qu'une famille existante, Gramps affichera une fenêtre de mise en garde. Si vous voyez ce message, vous devriez sans doute annuler l'édition, et utiliser le bouton Sélectionner pour choisir cette famille existante.

  • La famille : cette section est similaire à la section parents, laquelle affiche les familles où la personne active est un parent. Parce qu'il est possible d'avoir de multiples familles, il est possible d'avoir de multiples sections famille. Chaque section famille affiche le conjoint et les enfants.
Gramps-notes.png
Conjoints

On utilise le terme de conjoint pour plus de simplicité. Notez, que conjoint peut désigner un partenaire sous le même toit, en union civile, ou toute autre relations similaires entre deux individus. Les relations entre conjoints ne sont pas nécessairement entre un homme et une femme.

Vous pouvez ajouter une famille en sélectionnant Ajouter un conjoint dans la barre d'outils. Ceci créera une nouvelle famille dont la personne active sera le père ou la mère.

Sélectionner le bouton Gramps-notes.pngÉditer à côté du conjoint vous permettra d'éditer la famille affichée. Cliquer sur le bouton - enlèvera la personne de la famille affichée.

Gnome-important.png
Enlever une personne

Enlever un individu de la famille ne supprime pas la famille. La personne n'est plus la mère ou le père, mais les autres relations au sein de la famille existent toujours.

Gramps-notes.png
Note

Nous utilisons le terme de mère et père pour plus de simplicité. Même s'il n'y a pas d'enfant dans la famille, cette terminologie est utilisée. Dans le cas où nous avons des relations homme/homme ou femme/femme, le père et la mère doivent être considérés comme des noms de convenance.

Fig. 4.6 Réorganiser les relations

Vous pouvez réorganiser les parents et les conjoints en sélectionnant Réorganiser. Cette option ne sera active que si plus d'un couple de parents ou plus d'un conjoint existe pour la personne active. Sélectionner ce bouton affichera un dialogue qui vous permettra de réorganiser les relations au sein de la famille.


Configuration

Fig. 4.7 Configuration de la vue Relations

Vous pouvez contrôler le nombre d'information à afficher en utilisant le menu Affichage -> Configurer la vue active... ou en cliquant sur le bouton Configurer la vue active...). Ce dialogue vous permet d' :

  • afficher ou de cacher les détails (dates de naissance et de décès) et d'afficher ou de cacher les frères et sœurs
  • utiliser ou non des nuances de couleurs permettant de mettre en avant les informations, afficher ou de cacher les boutons d'éditions à côté des individus et d'afficher les liens vers les individus sous forme de liens internet (hypertexte).


Familles

Fig. 4.8 Vue Familles

La vue Familles affiche une liste de toutes les familles de la base de données. Depuis cette vue, vous pourrez ajouter, éditer, ou supprimer les familles. Par défaut, Gramps affiche id, père, mère, et relations. Les enfants ne pouvant pas être affichés à l'écran dans cette vue.

Gnome-important.png
Le bouton Supprimer

Contrairement à la vue Relations, cliquer sur le bouton supprimer dans cette vue supprimera cette famille de la base de données. Tous les individus resteront, mais les relations entre eux seront supprimés.


Lignée

La catégorie Lignée affiche différentes représentations graphiques des ascendants de la personne active. Par défaut il y a la Vue Arbre et la Vue Roue, mais des greffons supplémentaires à télécharger permettent d'obtenir d'autres vues.

Vue Arbre

Fig. 4.9 Vue Arbre
Fig. 4.10 Vue Arbre - mise en page
Fig. 4.11 Vue Arbre 2
Fig. 4.12 Vue Arbre 3
Fig. 4.13 Vue Arbre 4

Le vue Arbre affiche un graphique familial de l'individu actif.

Chaque individu est délimité par un rectangle avec son nom, ses informations de naissance (défini par un astérisque *) et de décès (défini par un signe +), un ruban noir dans le coin supérieur gauche indique une personne décédée (ou supposé comme tel par Gramps), ainsi qu'une image si elle existe. Deux lignes partent de ce rectangle. En haut, l'une se dirige vers le père et en bas la deuxième vers la mère. Les lignes complètes représentent les relations de naissance, les lignes en pointillé les autres relations, tel que l'adoption, la tutelle, etc.

A la gauche de la personne active il y a une flèche. Si l'individu actif a des enfants, cliquer sur le bouton va déployer une liste de ses enfants. En sélectionner un le rendra actif.

Fig. 4.14 Menu enfants

L'apparence du menu des enfants est différent par le fait qu'il prolonge les branches.

Les enfants qui ne sont pas parents vont apparaître grisés et en italique, alors que ceux qui sont parents seront en gras. Si l'individu actif n'a qu'un seul enfant, aucun menu ne sera affiché (puisqu'il n'y a qu'un seul choix) et l'enfant sera la personne active si l'on clique sur la flèche.

Deux flèches vers la droite sont affichées dans la partie droite de la fenêtre. Celle du haut prend comme personne active le père de la personne active. Celle du bas met comme nouvelle personne active la mère de la personne active. Comme précédemment, tout l'affichage change alors en conséquence.

Fig. 4.15 Contexte personnel

Un clic-droit sur n'importe lequel des individus dans la vue arbre généalogique appelera le "menu contextuel".

Entre les autres items, le menu contextuel a des sous-menus notés Conjoints, Frères et soeurs, Enfants, Parents de l'individu.

Les sous-menu "grisés" indiquent l'absence de données dans la catégorie. Similaire au menu des enfants, ce dernier et le menu de parents se distinguent par des lignes continus aux extrémités.

Gnome-important.png
Vidéos d'écran

Vous pouvez voir des vidéos pour l'ajout ou l'édition d'une famille (parents, enfants, frères et sœurs) depuis la vue Arbre.



Vue Roue

Fig. 4.16 Vue Roue

Cette vue affiche les ascendants mais dans une roue. Cliquer dans la roue va doubler la section liée à l'ascendant. Un deuxième clic ramènera la roue à son état originel. Un clic sur le bouton droit appelle le menu contextuel, comme dans la vue Arbre, permettant de naviguer vers d'autres individus.

Cette vue permet d'obtenir une ascendance élargie de manière plus compacte, and to see very quickly which parts of an ancestry need further research.

You can rotate the view by click and drag outside the fan chart. You can move the view by click and drag inside the inner (white) region.

  1. La vue peut être un cercle, un demi-cercle ou un quart de cercle. The last are always attached to the bottom or side of the view
  2. Children of the center person are shown with a nice children ring at the center
  3. Drag and drop people to the center to change the active person
  4. Options de couleur
  1. Couleur des boîtes basées sur l'âge des personnes
  2. Les couleurs des boîtes dépendent de la durée de vie de la personne
  3. Palettes de couleurs définies: blanc, classique, basées sur le genre, et définies par l'utilisateur
  1. Filtrage: utilisez le filtre pour obtenir rapidement insight in the people shown. Par exemple: combien de personnes ont des événements de naissance, qui a l'attribut « yeux bleus », etc. Les résultats filtrés sont en gras, ceux qui ne correspondent pas au filtre sont affichés de manière transparente.
  2. Affichage: jusqu'à 11 générations.
  3. Imprimez depuis la barre d'outils. La roue comme vous la voyez (après rotation, changement de couleur, changement de génération) peut être imprimée via le bouton «imprimer» ou bien sauvegardée au format svg (pour édition avec Inkscape, ou visualisation p.e. avec Firefox), pdf ou ps.
  4. La fonte utilisée peut être sélectionée, et se redimensionne automatiquement à la taille des cases. Sur une couleur sombre, la couleur de police est blanche, sinon, noire.

To understand all, watch the screencast


Événements

Une nouveauté dans la version 2.2 fut l'ajout d'une vue Événements.

Les événements peuvent être partagés entre plusieurs individus et familles. La vue des événéments liste tous les événéments enregistrés dans la base de données.

Les colonnes disponibles dans la vue sont : Description, ID, Type, Acteurs principaux, Date, Lieu et Dernière modification de l'événement.

Fig. 4.17 Vue Événements

Par défaut la vue affiche les colonnes Description , ID , Type , Date et Lieu de l'événement. Le dialogue de l'Éditeur de colonne peut être utilisé pour ajouter, enlever et réarranger les colonnes affichées. Cette fonction est accessible depuis le bouton Configurer la vue... dans la barre d'outils.

Gnome-important.png
Signification de la description de l'événement

Comme les événements peuvent être partagés, vous pouvez prendre un peu de votre temps pour définir une description unique et significative. Ceci vous aidera pour trouver correctement l'événement que vous souhaitez partager.

La liste des événements peut être triée de plusieurs façons, en cliquant sur l'en-tête de la colonne. Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant.


Sources

La catégorie Sources liste les sources stockées dans la base de données.

Deux types de vues existent dans cette catégorie :

  • La vue par défaut (hiérarchisée avec citations) : A gauche de chaque Source il y a une flèche ou un autre indicateur du type +. Cliquez sur l'indicateur pour déployer l'ensemble des Citations partageant la même Source. Cliquez une nouvelle fois sur l'indicateur compactera la liste et n'affichera que la Source.
  • La vue alternative : Les sources sont présentés sous forme d'une liste.
Fig. 4.18 Vue hiérarchisée avec citations
Fig. 4.19 vue Sources


Ceci peut inclure différents documents (naissance, décès, actes de mariage, etc.), livres, films, journaux - tout ce qui peut vous aider dans vos recherches. Gramps vous offre une option pour définir une source pour chaque événement (naissances, décès, mariages, etc.). La vue des sources utilise un Titre, ID, et un Auteur pour cette source, ainsi que toute information de Publication pouvant y être associée.

La liste des sources peut être triée en cliquant sur l'en-tête de la colonne.

Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant. Le dialogue Éditeur de colonnes peut être utilisé pour enlever ou changer l'affichage des colonnes.


Citations

Fig. 4.20 Vue Citations

La catégorie Citations liste les citations des informations stockées dans la base de données.

Les citations spécifient quelles parties d'une Source sont applicables pour un événement donné. Par exemple, une Source peut être un livre, et la Citation peut être une page de ce livre. Gramps offre la possibilité d'associer une Citation différente pour chaque Événement (naissances, décès, mariages, etc.). La vue Citations liste le Volume/Page , l'ID , et la Date de la citation, ainsi que le Niveau de confiance.

La liste de Citations peut être triée en cliquant sur l'en-tête de la colonne.

Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant. Le dialogue Éditeur de colonnes peut être utilisé pour enlever ou changer l'affichage des colonnes.


Lieux

Fig. 4.21 Vue Lieux

Les vues des lieux listent les endroits géographiques où ont lieu les événements. Cela peut être les lieux de naissance, décès, mariage des individus ainsi que leur adresse, leur travail ou toute autre référence géographique. La vue des lieux affiche les lieux et avec le Nom, ID, Paroisse, Ville, Département et Pays. Toutes ces colonnes peuvent être triées en cliquant sur leur en-tête.

Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant. Le dialogue Éditeur de colonnes peut être utilisé pour ajouter, enlever ou changer l'affichage des colonnes.

Si un lieu est activé, vous pouvez sélectionner le bouton OpenStreet Maps ou Google Maps pour essayer d'afficher le lieu dans votre navigateur internet.

Votre navigateur internet va utiliser le nom ou la longitude et la latitude du lieu pour afficher l'emplacement via le site internet de votre choix. Cette fonction est limitée, et peut ne pas produire le résultat désiré.

Vue hiérarchisée ou liste

Fig. 4.22 Vue hiérarchisée des lieux
Fig. 4.23 Liste des lieux

Les deux vues de cette catégorie montrent les lieux groupés ou non. La vue en arbre ou hiérarchisée tente de grouper les lieux dans des groupes logiques : pays, région ou province, ... .

Cette vue est apparue dans la version 4.1.0. Dans les futures versions l'objectif est de rendre le groupage encore plus intelligent.

L'autre vue ne fait que afficher tous les lieux dans une longue liste.

Géographie

Gnome-important.png
Note

La catégorie Géographie est seulement présente si vous avez OsmGpsMap d'installé.


Cette catégorie est une représentation de vos données sur une carte. Elle contient la vue Géographie, qui permet de voir tous les individus et leurs événements localisés sur une carte via un fournisseur de carte sur internet (OpenStreetMap, Google maps ... ).

Fig. 4.24 vue Géographie

La vue Géographie peut afficher :

  • Tous les lieux liés à l'individu actif
  • Tous les lieux liés à la famille active
  • Tous les lieux liés aux événements
  • Tous les lieux connus dans votre arbre
  • Montre si deux individus ont pu se rencontrer
  • Montre si deux familles ont pu se rencontrer
  • Montre tous les déplacements ou résidences pour un individu et ses descendants.

Ces options sont accessibles via les boutons de la barre d'outils. Pour filtrer les lieux ou événements, activez la barre latérale de filtrage (Affichage -> Barre de filtres)

Pour que cette vue fonctionne correctement, des évènements doivent être associés à des lieux. Ces lieux doivent posséder des coordonnées : latitude et longitude.

Si un lieu n'a pas de coordonnées associées, vous ne le visualiserez pas sur la carte.

Si internet est actif, pour tous les déplacements sur la carte et à toutes les niveaux de zoom, toutes les tuiles sont sauvées. Si internet n'est plus disponible, toutes les tuiles déjà sauvées dans une session précédente seront ré-utilisées. La carte peut donc être utilisée sans internet et tous les sites visités seront toujours disponibles aux différent niveaux de zoom déjà utilisés.

La seule chose à faire pour cela est, pour chaque lieu ou zone que vous souhaitez utiliser sans internet, de changer le zoom de la carte. Vous pourrez alors les utiliser à nouveau sans internet.

Gnome-important.png
ATTENTION

Cela peut utiliser des gigaoctets sur votre disque dur. Si vous utilisez plusieurs cartes, il vous sera nécessaire d'avoir cette taille réservée multipliée par le nombre de cartes que vous êtes susceptibles d'utiliser.

Les différentes vues

Tous les lieux connus pour un individu
Fig. 4.25 L'individu

Cette vue montre toutes les lieux visités par un individu durant sa vie.

Cette vue n'est pas connectée aux filtres. Elle ne dépend donc que de l'individu actif et de l'historique.

Si vous souhaitez utiliser la fonctionalité "Animation", cliquez sur le bouton droit de la souris. Vous obtiendrez un menu. Dans ce menu, vous pouvez sélectionner "Animation" pour visualiser les différents déplacements de l'individu actif.

Si l'individu actif a plusieurs évènements, vous pourrez visualiser les déplacements entre ces différents lieux. Le déplacement est relatif aux dates ou à la distance et peux être adapté dans les préférences de la carte. Si la distance entre deux lieux est supérieure à la valeur en dixièmes de degré, le déplacement sera calculé en fonction de la distance à la place des dates. Dans ce cas, le nombre de pas entre les deux lieux peuvent être modifiés. Vous pouvez modifier la vitesse d'animation entre deux pas. Les déplacement démarrent à la date du premier évènement pour se terminer à la date du dernier évènement.

Dans le menu de configuration, vous pouvez modifier :

  1. La vitesse d'animation en millisecondes.
  2. Combien de pas seront nécessaire entre deux marqueurs pour les grandes distances.
  3. La valeur minimum (latitude/longitude) pour sélectionner une grande distance. Cette valeur est exprimée en dixième de degré.
Fig. 4.26 L'animation
Tous les lieux connus pour une famille
Fig. 4.27 La famille

Cette vue permet de visualiser toutes les lieux visités par tous les membres d'une famille pendant leur vie.

Cette vue n'est pas connectée aux filtres. Elle ne dépend donc que de la famille active et de l'historique.

Il n'y a pas d'options complémentaires dans le menu de configuration.

Se sont-ils rencontrés ?
Fig. 4.28 Se sont-ils rencontrés?

Cette vue est utilisée pour montrer si deux individus ont pu se rencontrer durant leur vie.

Vous devez sélectionner un individu de référence :

  1. À partir du menu popup (bouton droit de la souris) : Choisir l'individu de référence
  2. À partir de la barre d'outils

Quand l'individu de référence est choisie, vous verrez tous les lieux qui lui sont associés. Pour chaque lieu connu avec des coordonnées, un "cercle" ou un "ovale" sera affiché en fonction de la longitude.

Le rayon du cercle peut être réglé dans la configuration de la géographie. Cette valeur est exprimée en dixième de degré.

Fig. 4.29 La sélection
Ces deux familles se sont-elles rencontrées ?
Fig. 4.30 Ces deux familles se sont-elles rencontrées?

Cette vue est utilisée pour montrer si deux familles ont pu se rencontrer durant leur vie.

Vous devez sélectionner une famille de référence :

  1. À partir du menu popup (bouton droit de la souris) : Choisir la famille de référence
  2. À partir de la barre d'outils

Quand la famille de référence est choisie, vous verrez tous les déplacements associés à ses membres . Pour chaque lieu connu avec coordonnées, vous verrez un "cercle" ou un "ovale" en fonction de la longitude.

Le rayon du cercle peut être réglé dans la configuration de la géographie. Cette valeur est exprimée en dixième de degré.

Fig. 4.31 La sélection
Toutes les résidences ou déplacements d'un individu et ses descendants
Fig. 4.32 Toutes les résidences ou déplacements d'un individu et ses descendants

Cette vue est utilisée pour montrer les déplacements ou résidences d'un individu et de tous ses descendants.

Une visualisation est réalisée par génération. Il est possible de modifier le temps entre deux visualisations de génération dans la configuration de la géographie.

Cette vue n'est pas connectée aux filtres. Elle ne dépend donc que de l'individu actif et de l'historique.

Dans le menu de configuration, vous pouvez :

  1. Changer le nombre de génération à montrer
  2. Changer le temps en millisecondes entre deux affichages de générations.
Fig. 4.33 Paramètres de déplacements
Tous les lieux liées aux évènements
Fig. 4.34 Évènements

Cette vue est utilisée pour montrer toutes les lieux liés aux évènements. L'affichage peut être long lorsqu'il y a beaucoup d'évènements.

Il n'y a pas d'options complémentaires dans le menu de configuration.

Tous les lieux avec coordonnées
Fig. 4.35 Lieux

Cette vue montre toutes les lieux connus de la base de données. Ces lieux doivent posséder des coordonnées.

Il n'y a pas d'options complémentaires dans le menu de configuration.

Utilisation

La configuration

Via le bouton de la barre d'outils Configurer la vue... (ou via le menu Affichage -> Configuration...)

Toutes les vues
Fig. 4.36 La carte
  1. Dans quel répertoire sauvegarder les tuiles de la carte (défaut est $HOME/.gramps/maps). ATTENTION, cela peux prendre plusieurs gigaoctets sur le disque dur.
  2. Le niveau de zoom par défaut lorsqu'on centre la carte ou lorsqu'on sélectionne un marqueur. À chaque fois que la vue graphique redessinera la carte, ce niveau de zoom sera utilisé.
  3. Utiliser le clavier numérique pour les raccourcis. Soit on choisit le + et le - sur le clavier numérique (défaut), soit sur le clavier alpha.
Vues spécifiques

Voir la description de la vue.

Comment zoomer et déplacer la carte ?

Zoomer et dézoomer la carte

Pour cela, on utilisera :

  1. Les boutons +/- en haut et à gauche de la carte
  2. La molette de la souris.
  3. Les touches + et - du clavier numérique (défaut).

On peut remplacer le clavier numérique par le clavier alphanumérique dans la configuration de la géographie.

Déplacer la carte

Pour déplacer la carte, il suffit de :

  1. Cliquer et de déplacer la souris.
  2. Utiliser les flèches.

L'action de la souris sur la carte

Le bouton droit ci-dessous correspond à une personne droitière. Ce sera le bouton de gauche pour une personne gauchère.

bouton 1 (gauche)

Vous avez deux usages pour le bouton 1 :

  1. La sélection d'un marqueur.
  2. Valider une sélection de région.
bouton 2 (milieu)

Le seul usage de ce bouton est de sélectionner une zone sur la carte.

  1. Lorsque enfoncé : démarrer la sélection de la zone ou région.
  2. Lorsque relaché, fin de la sélection.

Vous devez alors cliquer sur le bouton 1 pour terminer la sélection.

bouton 3 (droit)

Le seul usage de ce bouton :

  1. Montrer le menu popup.
La souris survole un marqueur

Lorsque la souris survole un marqueur, le nom du lieu ou des lieux est affiché dans la barre de statut.

Le menu popup

De ce menu, vous avez les fonctions suivantes pour les vues : From this menu, you have the following functions available for views :

  1. Cacher ou montrer la cible (le viseur).
  2. Verrouiller ou déverrouiller le zoom.
  3. Changer la carte par défaut (fournisseur).
  4. Ajouter un lieu ou lier un lieu existant dans la base de donnée à la position de la souris.
  5. Centrer la carte à la position de la souris.
  6. Effacer toutes les tuiles déjà mémorisées pour ce fournisseur d'accès.

Cliquer sur un marqueur

Nous avons deux cas :

  1. évènements : pour chaque évènement, nous pouvons éditer cet évènement ou centrer la carte sur le lieu associé.
  2. lieux : pour chaque lieu, nous pouvons éditer ce lieu ou centrer la carte sur ce lieu.

Quand on centre la carte, le zoom utilisé est celui défini dans les préférences de la vue géographie.

Nous pouvons avoir plusieurs marqueurs dans la zone cliquée en fonction du zoom. Dans ce cas, pour un emplacement sélectionné, tous les évènements ou lieux relatifs à ce marqueur seront affichés. On peut dans ce cas avoir un mixage des deux cas décrit ci-dessus.

Ajouter ou Lier à un lieu

Pour cela, cliquer sur le bouton de la souris, vous aurez le menu popup. Dans ce menu, vous pouvez sélectionner "Ajouter un lieu" ou "Lier à un lieu"

Quand vous ajoutez ou essayez de lier un lieu à la position de la souris, vous obtenez une fenêtre de sélection de région. Vous verrez sur la carte un cercle ou ovale dans lequel vous pourrez choisir les noms de lieu des marqueurs. Vous pourrez ajuster le rayon de ce cercle avec le curseur situé dans cette fenêtre de sélection. En fonction du diamètre de ce cercle, une liste est crée. Si le lieu choisi contient des champs déjà entrés, ces valeurs seront affichées dans une rangée de la liste de couleur verte. Si vous acceptez ces valeurs double cliquez sur cette rangée. Si vous ne souhaitez pas réutiliser ces valeurs, choisissez une autre rangée qui contient ce qui vous semble plus réaliste.

Une autre méthode pour ajouter une latitude et une longitude :

  • Téléchargez le Arrangement des lieux via le menu Aide->Gestionnaire de greffons. Si vous téléchargez les données associées à votre pays, cet outil pourra ajouter la latitude-longitude à tous vos lieux.

Comment changer de fournisseur de carte ?

Nous avons plusieurs fournisseurs de carte disponible. Cliquez sur le bouton 3 de la souris, vous obtenez un menu popup. En bas de ce menu, choisissez "Remplacer <fournisseur actuel> par =>"

Les fournisseurs suivant sont disponible :

  1. OpenStreetMap (défaut) : l'avantage de OpenStreetMap est que c'est un projet libre. Vous pouvez donc mettre à jour la carte avec les informations manquantes sur leur site web.
  2. Maps For Free
  3. OpenCycleMap
  4. Public Transport
  5. Google street
  6. Google sat
  7. Google hybrid
  8. Virtualearth street
  9. Virtualearth sat
  10. Virtualearth hybrid
Gnome-important.png
Certaines cartes ne sont pas libres, Lisez attentivement les Conditions d'utilisation :

Google street, Google sat, Google hybrid, Virtualearth street, Virtualearth sat, and Virtualearth hybrid

Souvenez vous que virtualearth est désormais bing maps


Pouvons nous changer la couleur des marqueurs ?

Non. Les couleurs sont fixées en dur dans gramps. La couleur verte est associée aux fournisseurs suivants : openstreetmap, Maps for free, Opencyclemap and Public transport. Tous les autres fournissuers sont de couleur rouge. A

Comment ajouter/enlever la cible ?

Elle est aussi appelée mire ou viseur. Il est souvent pratique de savoir ou la carte est centrée. Cette fonctionalité est disponible à partir du bouton 3 de la souris. Dans le menu popup obtenu, choisissez "Retirer/Ajouter la cible" Cela peut être utile pour ajouter ou lier un lieu aux bonnes coordonnées géographiques.

Comment verrouiller/Déverrouiller la carte ?

Lorsqu'on change de carte, de vue, le zoom est recalculé. Il peut être utile dans certains cas de garder le même zoom et la même position. Pour cela, cliquez sur le bouton 3 de la souris Dans le menu popup, sélectionnez "Déverrouillez/Verrouillez le zoom et la position"

Prérequis pour obtenir la vue Géographie

Pour gramps 4.x, vous devez installer osmgpsmap version 1.0 et au dessus et le paquet gir associé.

Par exemple, sur *Ubuntu, vous devez installer : gir1.2-osmgpsmap-1.0 et libosmgpsmap-1.0-0

Problèmes possible

  1. Pas de vue : Avez vous installé osmgpsmap ? (gramps -v peut vous aider)
  2. Pas de tuiles : Avez vous une connection internet active ?
  3. Pas de tuiles pour un fournisseur : Si les autres fournisseurs s'affichent correctement, soumettez un rapport de bogue.
  4. Tuiles manquantes : Vous n'avez pas internet et c'est la première fois que vous voulez afficher ce lieu.
  5. Tuiles manquantes : Ce peut être la même chose que pas de tuiles pour un fournisseur s'ils modifient les règles d'accès aux tuiles (i.e user-agent)
  6. Autres cas : soumettez un rapport de bogue.

Media

Fig. 4.37 Vue Media

La vue des media liste les objets media utilisés dans la base de données.

Les objets media ne sont que des fichiers reliés aux données généalogiques.

Techniquement, chaque fichier peut être stocké comme objet media.

La plupart du temps, ce sont des images, des fichiers sons, des animations, etc. Les en-têtes sont Nom, ID, Type, et Chemin de l'objet media.

Le dialogue Éditeur de colonnes peut être utilisé pour réarranger l'affichage des colonnes, lesquelles obéissent aux règles de tri. La partie haute de la fenêtre GRAMPS affiche un aperçu (si il existe un objet media) et les informations sur ce dernier.


Dépôts

Fig. 4.38 Vue Dépôts

La version 2.2 a ajouté le support des dépôts.

Un dépôt peut être défini comme une collection de sources.

Chaque source dans la base de données peut référencer un dépôt (comme une bibliothèque) dans lequel elle est présente. Le fonctionnement de la vue dépôts est similaire à celui des autres vues.


Notes

Fig. 4.39 Vue Notes

Une note est un texte brut, stockée comme les autres objets.

Le fonctionnement des notes est similaire aux autres vues. La vue liste toutes les Notes stockées dans un Arbre familial. Sous Édition->Éditeur de colonnes vous pouvez changer l'affichage des colonnes. Les possibilités sont Aperçu, ID, Type et Marqueur.

Le Type peut être : Note de l'événement, Transcription, Note de l'adresse, Texte de la source, Note du lieu.

Cliquer deux fois sur la note dans la liste va ouvrir une fenêtre dans laquelle vous pourrez éditer cette dernière. Vous pouvez changer les polices de caractère, leurs couleurs, ainsi que la couleur de fond. Un vérificateur d'orthographe est disponible en anglais et dans votre langue de système.


Internet

Fig. 4.40 Vue HTML
Fig. 4.41 Archive sur internet

Cette vue est cachée par défaut. Elle permet d'ouvrir une page internet depuis Gramps. Ceci peut être intéressant si vous voulez accéder à des sources sur internet sans avoir à basculer entre Gramps et votre navigateur internet. Afin d'afficher et d'utiliser cette catégorie, il est nécessaire de :

  • s'assurer qu'une connexion internet active
  • s'assurer qu'un kit HTML (webkit ou gtkmozembed) est installé.
  • d'activer la vue en utilisant le menu Aide -> Gestionnaire de greffons, rechercher la vue Html dans la liste, de la sélectionner et de l'activer en utilisant le boutton Cacher/Afficher.
  • de quitter Gramps
  • de redémarrer Gramps.

Quand ce processus est réalisé, la nouvelle Catégorie Internet est disponible.


Précédent Index Suivant