Gramps 3.4 Wiki Manual - Manage Family Trees (revised by Girarda)

From Gramps
Jump to: navigation, search
Gramps-notes.png
Background information regarding the development of this page

The present page is a proposal for the revision of the page entitled "Manage Family Trees" in the GRAMPS 3.4 Wiki Manual.
The present page is written with the GRAMPS end-user in mind. The goal is to give him/her the essential information "to have the job done".
To avoid overloading the GRAMPS manual, the manual editors, the translators, the end-users, and to facilitate the mantainance of the manual, information, although useful and valuable, that is not considered necessary to "have the job done", should be placed elsewhere (there are currently plenty of other suitable locations in GRAMPS Wiki).
Gramps-notes.png
Progress Status

  • I think I am pretty much done with sections 1 up to 8.
  • I am working on Import and Export (a big chunk, hard to make user-friendly).
Gramps-notes.png
Feedback

  • What do you think? Please let me know.
  • Qu'est ce que tu en penses? Dis-moi.
  • Che cosa ne pensi? Dimmi.
Gnome-important.png
To leave me a message

  • Click on the "discussion" tab, at the top of the present page.

This opens the "discussion" page.

  • Click on "log in / create account" on the upper right corner of the page.
  • Log in, or create an account, as the case may be.
Creating an account logs you in immediately.
  • Return to the present page.
  • Click on the + tab, at the top of the present page.
  • Type in your message.
  • Click on "Show preview", towards the bottom of the page.

When you are happy with the result:

  • Click on "Save page", towards the bottom of the page.
- Thank you for your message -

Creating a new Family Tree

Fig. 3.4. Family Trees window

To create a new Family Tree:

  • Either select Family Trees -> Manage Family Trees... menu,
or click on the Family Trees icon on the Toolbar.

This opens the Family Trees window.

  • Click on the New button.
This adds a new Family Tree entry (named by default Family Tree 1) to the list of Family Trees.

To change the name of the Family Tree:

  • Select Family Tree 1.
  • Click on the Rename button.
  • Type the new "Name for the Family Tree".
  • Hit the Enter key.

To load the Family Tree in GRAMPS:

  • Click on the Load Family Tree button.

This opens the new, empty, Family Tree, in the GRAMPS main window.

Gnome-important.png
The new Family Tree is empty!

Keep in mind that, at this stage, the new Family Tree has a name, is opened in the GRAMPS main window, but is EMPTY. To populate it with data, data can be:


Opening an existing Family Tree

To open an existing Family Tree:

  • Either select Family Trees -> Manage Family Trees... menu,
or click the Family Trees icon on the Toolbar.

This opens the Family Trees window.

It lists all the Family Trees known to GRAMPS, with indication of each Family Tree:

  • Name.
  • Status.
  • Date of last modification.

The Family Tree status is identified, in the Status column, by one of the following icons:

Icon: Meaning: What to do?
Blank/No icon It is safe to open The Family Tree You may open the Family Tree
Folder icon The Family Tree is locked Unlock the Family Tree
Red error icon The Family Tree is damaged Repair the Family Tree
Gnome-important.png
Data corruption alert!

Open a Family Tree only when its status is clear (i.e.: No status icon in the Status column of the Family Trees manager).

To open a Family Tree:

  • Select the Family Tree you want to open.
  • Click on the Load Family Tree button.

This opens the Family Tree, in the GRAMPS main window.

Opening a recently accessed Family Tree

To open a recently accessed Family Tree:

  • Either select Family Trees -> Open Recent -> Name of the Family Tree you want to open ,
or, select the down arrow next to the Family Trees icon on the Toolbar, and the Name of the Family Tree you want to open.

This opens the Family Tree, in the GRAMPS main window.

Remarks
  • There is no risk of data loss when opening a Family Tree while a DIFFERENT one is already open in the GRAMPS main window, because GRAMPS saves changes to Family Trees as soon as they are applied.
  • If you do not have "write permission" for the selected Family Tree, it will open in Read Only mode. In this mode, the data may be viewed, but no change can be made to the Family Tree. To indicate this mode, "(Read Only)" is appended to the name of the Family Tree in the title of the GRAMPS main window.

Saving changes to a Family Tree

GRAMPS saves changes as soon as they are applied. This means, for example, that any time you click on an OK button when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command.

  • To undo the lastest change, go to Edit -> Undo. Each additional click on Undo, undoes the previous change in time.
  • To cancel the latest undo, go to Edit -> Redo. Each additional click on Redo, re-establishes the next change in time.
  • To jump to a specific moment in time, go to Edit -> Undo History.... This opens the Undo History window. Select the moment in time you would like to jump to. Click on the Undo or Redo button (witch ever is active).
  • To return the Family Tree to the way it was when you opened it, select Family Trees -> Abandon changes and quit.

To save a copy of the Family Tree under a different name, back it up and then restore it into a new Family Tree with the new name. The Gramps XML file format is recommended for this purpose.

Deleting a Family Tree

To delete a Family Tree:

  • Either select the Family Trees -> Manage Family Trees... menu,
or click the Family Trees icon on the Toolbar.

This opens the Family Trees window.

  • Select the Family Tree you want removed.
  • Click on the Delete button.
Gnome-important.png
Data loss risk!

Deleting a Family Tree removes the database COMPLETELY, with NO possibility to retrieve the data. Consider:

Remark: Media objects (images, audios, videos ...), are not affected by the Delete command, because the Media files are not stored in the database.

Renaming a Family Tree

To rename a Family Tree:

  • Either select Family Trees -> Manage Family Trees... menu,
or click the Family Trees icon on the Toolbar.

This opens the Family Trees window.

  • Select the Family Tree you want renamed.
  • Click on the Rename button.
  • Type in the new name.

Unlocking a Family Tree

Several copies of GRAMPS can run at the same time. In case they use the same Family Tree, its data will very likely become corrupted.

To avoid this undesirable configuration, when GRAMPS opens a Family Tree, it locks it, and warns any potential user that the Family Tree is already in use. A locked Family Tree is identified in the Family Trees window by a folder icon displayed in the Status column.

In the unlikely event of a crash of GRAMPS, an open Family Tree will be left in a locked state.

To unlock a Family Tree:

  • Select the locked Family Tree in the Family Trees window.
  • Click on the Load Family Tree button.

This opens a message box, warning you of the potential risks involved by unlocking a Family Tree. Read the message carefully.

Gnome-important.png
Data corruption risk!

Unlock a Family Tree only if you are sure no other copy of GRAMPS is running and using that same Family Tree.

  • Click on the Break the lock button, only if you are sure no other copy of GRAMPS is running and using that same Family Tree.
In case of doubt:
  • Clicking on the Cancel button.
This closes the message box.
  • Investigate.

When you are satisfied that it is safe to break the lock:

  • Restart the unlocking procedure.

Repairing a damaged Family Tree

Fig. 3.4 Repairing a Family Tree

Should a Family Tree become damaged or corrupted in some way, the Family Tree window will display a red error icon in the Status column.

To attempt to repair the damage, select the affected Family Tree and then click the Repair button.

GRAMPS will attempt to rebuild the Family Tree from the backup files that are automatically created by GRAMPS each time the GRAMPS main window is closed.

Backing up and restoring a Family Tree

Overview

To back up a Family Tree,

To restore a Family Tree,

  • import the backup file in a new Family Tree.

Backing up a Family Tree

Gramps-notes.png
The following procedure performs a back up that is both exhaustive and portable.

  • Exhaustive: ALL your GRAMPS genealogical data, including the Media files (images, audios, videos ...), are backed up in a single file.
  • Portable: The backup file can be run by GRAMPS on any computer.

To back up the Family Tree you are editing:

  • Go to the Family Trees -> Export... menu.

This opens the Export Assistant window.

  • Click the Forward button.

This opens Choose the output format page.

  • Select Gramps XML Package (family tree and media).
Gnome-important.png
Confusion alert! Select Gramps XML (family tree and media)

For an exhaustive and portable back up,

select Gramps XML package (family tree and media)
and NOT Gramps XML (family tree).
  • Click the Forward button.

This opens the GRAMPS package Export Option page.

Set the options as follows:
  • Person Filter: Select Entire Database
  • Note Filter: Select Entire Database
  • Do not include records marked private: Uncheck (blank)
  • Restrict data on living person: Uncheck (blank)
  • Do not include unlinked records: Uncheck (blank)
  • Click the Forward button.

This opens the Select Save File page.

  • Type in the name of the backup file.
Gramps XML (family tree and media) file extension is: .gpkg.
Gnome-important.png
It is recommended to include the back up date in the file name

This will facilitate the retrieval of the backup file in case it needs to be restored.


  • Select the folder where to save the backup file.
  • Click the Forward button.

This opens the Final confirmation page.

  • Click the Apply button to start backing up.

When back up is complete the Your data has been saved page opens.

Gnome-important.png
Store the backup file (or a copy) in a safe place.

Leaving the backup file on the same storage device as the GRAMPS database would be useless in case the storage device fails.

At any stage of the process you can:

  • go back to a previous stage by clicking on the Back button,
  • or abort the process by clicking on the Cancel button.
Alternative, less safe, back up procedure
Gnome-important.png
For advanced users: Use of the Gramps XML file format (extension: .gramps)

Use the same procedure as above,

but use the Gramps XML (family tree) file format,
instead of the Gramps XML package (family tree and media) file format.
Gnome-important.png
Data loss risk!

Compared to the Gramps XML package file format, the Gramps XML file format does NOT back up the Media files (images, audios, videos ...).

Gramps-notes.png
Keep in mind that:

  • Media files (images, audios, videos ...) are NOT stored in the GRAMPS database.
  • The GRAMPS database stores the genealogical data AND the path to retrieve each Media file.

Benefits (for back up purposes):

  • Backing up takes less time: Because the Media files are not backed up.
  • The backup file is smaller: Because the Media files are not backed up.
  • The backup file is human readable: The content of the backup file, after decompression, using your favorite decompression software, can be read in a text editor (XML format).

Shortfalls (for back up purposes):

  • The Media files are not backed up: Other arrangements must be set-up to back up the Media files.
  • The backup files is not portable: The paths between the restored database and each Media file must be identical to the one that existed, at the time of back up, between the original database and each Media file.
Gnome-important.png
Data loss risk!

  • In most cases, an advanced user should be able to re-establish the path between the GRAMPS database and the Media files, if necessary.
  • In case you do not know how to do it, that probably tells that you should use the safe back up method described above.
  • In some cases, re-establishing the path might be a major project, even for an advanced user.


Restoring a Family Tree

Gnome-important.png
The backup file must be restored in an EMPTY Family Tree.

If the backup file is restored in an existing Family Tree, the backup data will be added to the data already in the Family Tree ... this could be messy ...

To restore a Family Tree:

This opens a file selection window.

  • Find and select the backup file to restore (this is when a backup date in the file name can be handy).
  • Click the Import button.

This starts file restoration.

Wait for the file to load... The Import Statistics window opens when restore is complete.
  • Click the OK button.

This opens the restored Family Tree, in the GRAMPS main window.

Alternatively, double-click on the backup file. This will start GRAMPS. Follow the instructions on the screen.

Importing data

Importing brings in the GRAMPS database, data stored in an electronic file that GRAMPS can read. GRAMPS can read the following file formats:

  • GRAMPS XML (.gramps file extension)
  • GRAMPS package (.gpkg file extension)
  • GRAMPS CSV Spreadsheet - comma separated values (.csv file extension)
  • GRAMPS V2.x database (.grdb file extension)
  • GEDCOM (.ged file extension)
  • GeneWeb (.gw file extension)
Gramps-notes.png
Importing vs. opening

Please recognize that importing a database is different from opening a database. When you import, you are actually bringing data from one database into a GRAMPS database. When you open a file, you are editing your original file.

To import genealogical data from a file readable by GRAMPS:

This opens a file selection window.

  • Find and select the file to restore.
  • Click the Import button.

This starts file import.

Wait for the file to load... The Import Statistics window opens when import is complete.
  • Click the OK button.

This opens the populated Family Tree, in the GRAMPS main window.


Note that you can only import data into an existing database so if you are transferring all your data from another program or from an older version of GRAMPS, then first create a new empty database and then import the data into it.

Gnome-important.png
Data loss alert:

It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databases. There is a chance that some of the data in these databases will not be imported into GRAMPS.

Expect some grooming

The GRAMPS XML, GRAMPS package and GRAMPS V2.x database are all native GRAMPS formats. There is no risk of information loss when importing from or exporting to these formats.

  • GRAMPS XML (.gramps): The GRAMPS XML file is the standard GRAMPS data-exchange and backups format, and was also the default working-database format for older (pre 2.x) versions of GRAMPS. Unlike the grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable (for full portability including media objects the GRAMPS package (.gpkg) should be used). The GRAMPS XML database is created by exporting ( Family Trees ->Export... ) to that format.
  • GRAMPS package (.gpkg): The GRAMPS package is a compressed archive containing the GRAMPS XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The GRAMPS package is created by exporting ( Family Trees ->Export... ) data in that format.
  • GRAMPS V2.x database (.grdb): Prior to Version 3.4, this native GRAMPS database format was a specific form of Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).

If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress of the operation in the progress bar of GRAMPS' main window.

The GRAMPS CSV Spreadsheet format allows importing and exporting of a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information.

Gnome-important.png
Caution in Importing XML

If you need to combine two family trees (for instance, in rebuilding a database), it is important that you do not import XML data into the same family tree data. For example, if a person in your existing family tree is also in an XML import, then you may end up with mixed up data. Imports do not "merge" data (except for the Spreadsheet Import). As the current version 3.4.2 stands, you could corrupt your database irretrievably if you XML import into duplicated data. If you must import duplicated data, you could export the data in, say, the GEDCOM format and import that; however, GEDCOM does not faithfully export all GRAMPS data. Additionally, you would need to edit your data to remove any duplicates, and re-add some information which may have not been included in the GEDCOM export (such as media). However, importing from the GEDCOM format will not corrupt duplicated data as does the XML import will on duplicated data. If you want to merge basic genealogy data, consider the Spreadsheet Export/Import.

Exporting data

Fig. 3.5 Export assistant: format selection

Exporting copies all, or a selection, of the data found in the GRAMPS database into an electronic file that can be read by a genealogy software.

For the purpose of the GRAMPS end-user, the exporting process could be described as follows:

  1. Selection, on the basis of the criteria set by the user. of the data to be copied from the GRAMPS database. The data not selected will not be exported.
  2. Conversion of the selected data into the format selected by the user. During the conversion process, data might be lost if the structure of the GRAMPS data cannot precisely fit into the structure of the export file format.
  3. Storage of the resulting file at the location selected by the used.


Exporting does not affect the database.


Filters and privacy settings

Filters and privacy settings, prescribe which data should be exported, or not exported.

The following options are available:

  • Person Filter: Only the Persons that match the criteria of the filter will be exported.
The user can select between:
  • Standard filters, available by default in the GRAMPS application. They include:
  • Entire database.
  • Descendants of the Active Person.
  • Descendant families of th Active Person.
  • Ancestors of the Active Person.
  • People with common ancestor with the Active Person.
  • Customized filters, created by the user using the Person Filter Editor.
  • Note Filter: Only the Notes that match the criteria of the filter will be exported.
The user can select between:
  • Standard filters, available by default in the GRAMPS application. They include:
  • Entire database.
  • Customized filters, created by the user using the Note Filter Editor.
  • Do not include records marked private: When checked, records marked as private will not be exported.

When checked, additional options relevant to living people are available: For example, you can choose to substitute the word Living for the first name (see your settings); you can exclude notes; and you can exclude sources for living people.

  • Do not include unlinked records: When checked, records related to notes will not be exported.
Gnome-important.png
Privacy and security alert!

  • Do not send living people personal data if their is a chance that it might end-up on Internet.
  • Check the content of the export file.

Export file formats

GRAMPS can export data in file formats: GRAMPS XML GEDCOM GRAMPS package Web Family Tree GeneWeb CSV Spreadsheet formats

Gnome-important.png
Data loss alert! Export is generally lossy

Data can be truncated, misplaced (i.e.: assigned to a different category) or dropped altogether by the transfer process.

Loss could be Transfer can be lossy for multiple reason, and in particular when the structure of the GRAMPS data cannot easily fit into the structure of a foreign (e.i.: not GRAMPS native) the file format standard.


Gramps-notes.png
Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your GRAMPS window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

Export

To export the Family Tree you are editing (or a portion of it):

  • Go to the Family Trees -> Export... menu.

This opens the Export Assistant window.

  • Click the Forward button.

This opens Choose the output format page.

  • Select the file format you want to export to.
  • Click the Forward button.

This opens the GRAMPS package Export Option page.

Set the filters and privacy settings to match the data you want to export.
  • Click the Forward button.

This opens the Select Save File page.

  • Type in the name of the backup file.
  • Select the folder where to save the export file.
  • Click the Forward button.

This opens the Final confirmation page.

  • Click the Apply button to start exporting.

When export is complete the Your data has been saved page opens.

Gnome-important.png
Data loss alert! Export is generally lossy

Check the content of your export file. How??


Export into GRAMPS formats

Gnome-important.png
Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for GRAMPS XML backups.

  • GRAMPS XML database export (.gramps): This format is the standard format for data-exchange and backups (see the related .gpkg format below for full portability including media objects). Exporting into GRAMPS XML format will produce a portable database. As XML is a text-based human-readable format, you may also use it to take a look at your data. This format is compatible with the previous versions of GRAMPS.
  • GRAMPS package export (.gpkg): Exporting to the GRAMPS package format will create a compressed file that contains the GRAMPS XML database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Exporting into the GEDCOM format

Fig. 3.6 Export assistant: GEDCOM options

GRAMPS allows you to export a database into the common GEDCOM format. It provides options that allow you to fine tune your export (see Fig.3.5.gedcom-export-fig ).

Export into other formats

  • Web Family Tree: Exporting to Web Family Tree will create a text file that can be used by the Web Family Tree program. Export options include filter selection and the ability to limit data on living people to that of their family ties.
  • vCalendar and vCard: Exporting to vCalendar or vCard will save information in a format used in many calendaring and addressbook applications, sometimes called PIM for Personal Information Manager.
  • CSV Spreadsheet format: Allows exporting (and importing) a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information. Also, see Export Display

Data import & export considerations

Export / import can be used:

  • To share electronically data with other genealogists.
  • To back up et restore data (because back up and restore have specific requirements, thee matter is addressed in a different section of the GRAMPS manual).
  • To transfer data between computers.

Exporting and Importing cannot be considered in isolation

When deciding which file format to use, the following is consideration:

  • An export file is generally destined to be imported, at some point in time.
  • The origin and destination software are limited in the file format they can used as well as they are at exporting and importing data.

Knowing the origin and destination