Gramps 3.4 Wiki Manual - Manage Family Trees/pl

From Gramps
Jump to: navigation, search

W tej sekcji zapoznasz się ze dokładnym wyjaśnieniem codziennego użycia GRAMPSa. W rodziale tym uzyskasz szczegółowe wyjaśnienie jak możesz zarządzać swoimi drzewami rodzinnymi, jak również współdzielić swoje informacje z innymi genealogami.

Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.<br\> Also, only use the known conventions


Poprzednia Indeks Następna



Tworzenie nowego drzewa rodzinnego

Rys. 3.4. Tworzenie drzewa genealogicznego


W celu utworzenia nowego drzewa rodzinnego, wybierz Drzewa rodzinne - >Zarządzaj drzewami rodzinnymi albo użyj przycisku Zarządzaj drzewami z paska narzędziowego. Spowoduje to otwarcie okna menadżera Drzew genealogicznych.



Wybierz przycisk Nowy i GRAMPS doda nowe drzewo rodzinne do listy dostępnych drzew. Aby zmienić jego nazwę z domyślnego Drzewo genealogiczne 1, kliknij na nazwę i wprowadź nową nazwę zastępując starą.

Teraz użyj przycisku Otwórz wybrane drzewo aby otworzyć nowe, puste drzewo rodzinne.

Otwieranie drzewa rodzinnego

W celu otwarcia drzewa rodzinnego, wybierz Drzewa rodzinne -> Zarządzaj drzewami rodzinnymi albo kliknij na przycisk Zarządzaj drzewami na pasku narzędzi. Menadżer drzew rodzinnych pojawi się i zobaczysz listę wszystkich drzew rodzinnych, o których program wie. Ikona wyświetlona w kolumnie Status obok drzewa rodzinnego oznacza aktualnie otwarte drzew. Wybierz teraz drzewo, które chcesz otworzyć i kliknij na przycisku Otwórz wybrane drzewo. Możesz także podwójnie kliknąć na wybranym drzewie, aby je otworzyć.

Aby otworzyć ostatnio otwierane drzewo, wybierz albo Drzewa rodzinne ->Otwórz poprzednie albo przy pomocy strzałki w dół obok przycisku Zarządzaj drzewami rozwiń listę i z niej wybierz szukane drzewo.

Jeśli nie posiadasz "praw zapisu" do danego drzewa rodzinnego, zostanie ono otwarte w trybie tylko do odczytu. W tym trybie dane mogą być przeglądane, ale żadne zmiany nie zostaną zapisane do drzewa. W tym trybie pasek menu GRAMPSa będzie zawierał nazwę drzewa wraz ze tekstem (Read Only).

Otwieranie bazy GEDCOM albo XML

GRAMPS pozwala Cię na otwarcie kilku typów baz danych z poziomu linii poleceń, a które nie zostały zapisane w natywnym formacie GRAMPSa. TODO dodać link do strony wyjaśniającej jak. Wśród tych formatów są XML oraz GEDCOM. Powinieneś jednak być świadomym, że bazy te są dosyć duże i możesz napotkać problemy wydajnościowe, a w przypadku błędu Twoje dane mogą zostać uszkodzone. Dlatego zalecane jest utworzenie nowej bazy danych GRAMPS i zaimportowanie do niej danych z pliku GEDCOM/XML.

Gramps-notes.png
Otwieranie bazy danych

Bazy XML oraz GEDCOM wymagają aby wszystkie dane były przetrzymywane w pamięci i nie zawierały indeksów. Natywny format GRAMPS' odczytuje tylko dane, które aktualnie potrzebuje. Dlatego - duże drzewa rodzinne mogą być odczytywane szybciej i efektywniej niż w przypadku użycia XML albo GEDCOMa.

Gnome-important.png
Edycja GEDCOM

Proszę pamiętać, że część informacji w pliku GEDCOM może być utracona podczas importu do formatu GRAMPS jak również przy eksporcie do formatu GEDCOM. Zwykłe przeglądanie danych nie wpływa na to. Jednakże - jakiekolwiek zmiany nie będą porzucone aż do zamknięcia GRAMPSa, kiedy to zostaną one zapisane z możliwą utraty danych.

Usuwanie drzewa rodzinnego

Wybierz drzewo, które chcesz usunąć i kliknij na przycisk Usuń.

Ta operacja całkowicie usunie drzewo rodzinne, i nie będzie możliwe odzyskanie danych z niego. Nim to zrobisz, rozważ eksport danych z niego do formatu GRAMPS XML, i zachowanie ich jako pliku.

Zmiana nazwy drzewa rodzinnego

Możesz zmienić nazwę drzewa rodzinnego (albo jego archiwum) poprzez wybranie konkretnego drzewa i kliknięcie na przycisk Rename. Możesz także kliknąć na nazwie danego drzewa na liście drzew.

W obu przypadkach, wystarczy wpisać nową nazwę drzewa, aby zmiany odniosły skutek.

Kopia zapasowa drzewa rodzinnego

  • Najbezpieczniejszą metodą stworzenia kopii zapasowej jest wyeksportowanie do formatu GRAMPS XML (albo GRAMPS Package aby dołączyć elementy z galerii) i skopiowanie pliku wynikowego do bezpiecznego miejsca, najlepiej w innym budynku.

Backup dialog

Simply select "Make Backup..." from the "Family Trees" menu item.

MakeBackup.png

You can either choose to include the media or not.

Note that this is just a regular XML export, except that no data is filtered out. You can import these as usual with any exported file.

You can also define the pattern for the backup filename by setting the paths.quick-backup-filename in the ~/.gramps/gramps34/gramps.ini key file like the following:

[paths]
quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%(extension)s'

You can use any of the following keywords in the pattern: year, month, day, hour, minutes, seconds, filename, extension.


  • Możesz też użyć opcji Archiwizacji aby zachowywać snapshoty swojego drzewa. Te snapohoty mogą być później użyte jako proste kopie zapasowe, co jest przydatne, jeśli chcesz coś przetestować i móc później wycofać zmiany. Jednakże, ta metoda nie powinna być używana do normalnych kopii zapasowych, jako że nie jest odporna na awarie dysku twardego albo inne awarie, które mogą dotknąć komputer.
  • Dla zaawansowanych użytkowników: Każda baza danych jest zapisywana w swoim własnym podkatalogu w katalogu ~/.gramps (Unix/Linux). Ręczna kopia zapasowa może być dokonana przez kopiowanie tego folderu. Zobacz także stronę man programu i szczegóły opcji GRAMPSHOME.

Archiwizacja drzewa rodzinnego

Możesz w prosty sposób archiwizować i tworzyć znaczniki swojego drzewa rodzinnego za pomocą wbudowanej w GRAMPS GNU Revision Control System, w skrócie RCS. Aby skorzystać z tej możliwości, to narzędzie musi być zainstalowane na Twoim komputerze.

Aby zrobić archiwum, najpierw upewnij się, że drzewo, które chcesz zarchiwizować, jest otwarte. Następnie otwórz listę drzew rodzinnych i kliknij na przycisk Archiwizuj. Archiwum będzie wyświetlone poniżej drzewa, dla którego zostało ono utworzone. Archiwa mogą mieć zmieniane nazwy albo być usuwane.

Przywracanie drzewa rodzinnego

Fig. 3.4 Wybór wersji do przywrócenia

Wystarczy podświetlić wersję archiwum, którą chcesz przywrócić, i wcisnąć przycisk Przywróć.

Fig. 3.4 Przywrócona wersja




GRAMPS przetransferuje archiwum do nowego drzewa rodzinnego. Nazwa drzewa bazować będzie na oryginalnej nazwie drzewa i nazwie archiwum.

Odblokowywanie drzewa rodzinnego

Kiedy GRAMPS otwiera drzewo rodzinne, to je blokuje zapobiegając w ten sposób przed otwarciem tego drzewa przez Ciebie albo inną osobę w tym samym czasie. Druga kopia GRAMPSa będzie w stanie otworzyć inne drzewo rodzinne, ale drzewo aktualnie otwarte oznaczone będzie ikoną blokady, wskazując w ten sposób że nie możesz tego drzewa otworzyć. Zamknięcie instancji GRAMPSa, która pierwsza otwarła to drzewo pozwoli Ci zwolnić to drzewo i otworzyć w innej kopii programu.

Jeśli jednak zechesz otworzyć to samo drzewo w dwóch instancjach programu GRAMPS, to jest duża szansa, że Twoje dane zostaną uszkodzone.

W przypadku awarii GRAMPSa, co jest mało prawdopodobne, drzewo rodzinne pozostanie zablokowane. Aby je odblokować. wskaż zablokowane drzewo i następnie kliknij przycisk Odblokuj, który wtedy będzie dostępny. Używaj tej opcji tylko wtedy, gdy jesteś pewien, że żadna inna kopia GRAMPSa nie używa tego drzewa.

Naprawianie uszkodzonego drzewa rodzinnego

Fig. 3.4 Naprawianie drzewa rodzinnego




Jeśli twoje drzewo rodzinne zostanie uszkodzone, to w oknie zarządzania drzewami GRAMPS wyświetli ikonę błędu w kolumnie Status przy takim drzewie.

Można nakazać GRAMPSowi podjąć próbę naprawy takiej bazy poprzez wskazanie danego drzewa i następnie kliknięcie na przycisk Napraw.

Spowoduje to podjęcie próby przebudowy drzewa na podstawie plików kopii, które są tworzone automatycznie podczas zamykania programu.

Zapisywanie zmian do drzewa rodzinnego

GRAMPS zapisuje zmiany automatycznie, zaraz po tym jak je zatwierdzisz. Oznacza to, że za każdym razem, jak klikniesz przycisk OK podczas pracy z programem, to twoje zmiany są logowane i zapisywane. Nie ma oddzielnego polecenia "Zapisz".

Możesz wycofać swoje zmiany przez wybranie opcji Edycja->Cofnij. Jeśli będziesz używał tej opcji parę razy z rzędu, to za każdym razem najbardziej najnowsza zmiana w historii zostanie wycofana. Aby cofnąć wiele poleceń za jednym razem, możesz skorzystać z dialogu Historia cofania dostępnego z menu Edycja.

Jeśli chcesz całkowicie porzucić zmiany, które wprowadziłeś od momentu otwarcia programu, wybierz opcję z menu Drzewa rodzinne -> Porzuć zmiany i wyjdź . (To jest tak jak wyjście bez zapisywania zmian w innych programach).

Gdy chcesz zapisać kopię swojego drzewa rodzinnego pod inną nazwą, możesz to zrobić poprzez wyeksportowanie i zaimportowanie danych do nowego drzewa. Do tej akcji format GRAMPS XML database jest tutaj zalecanym.

Importowanie danych

Importowanie pozwala Ci na przeniesienie danych z innego programu genealogicznego do bazy GRAMPSa. Aktualnie, GRAMPS może importować dane z następujących formatów:

GRAMPS V2.x database (rozszerzenie pliku .grdb)

GEDCOM (rozszerzenie pliku .ged)

GRAMPS XML (rozszerzenie pliku .gramps)

Pakiet GRAMPS (rozszerzenie pliku .gpkg)

GeneWeb (rozszerzenie pliku .gw)

Arkusz CSV GRAMPS (rozszerzenie pliku .csv)

Pro-Gen (rozszerzenie pliku .def)

Gramps-notes.png
Importowanie a otwieranie

Proszę zauważyć, że importowanie jest inną operacją niż otwieranie bazy. Kiedy importujesz, to przenosisz dane z jednej bazy do bazy GRAMPSa. Kiedy otwierasz plik, to edytujesz oryginalny plik.

Aby zaimportować dane, wybierz Drzewa rodzinne ->Import . Pojawi się okno dialogowe Importowanie bazy danych, prosząc Cię o wskazanie pliku, który ma być importowany. Zauważ, że możesz tylko zaimportować dane do istniejącej bazy, tak że jeśli przenosisz dane z innego programu albo starszej wersji GRAMPSa to musisz najpierw stworzyć nową pustą bazę, do której będziesz importował dane i ją otworzyć.

Gnome-important.png
Utrata danych z niektórych formatów

Należy pamiętać, że proces importu nie jest doskonały dla baz GEDCOM oraz GeneWeb. Występuje tutaj możliwość, że niektóre dane nie zostaną zaimportowane do GRAMPS.

Baza GRAMPS V2.x, GRAMPS XML, oraz pakiet GRAMPS są natywnymi formatami GRAMPS. Dlatego w tych przypadkach nie występuje możliwość utraty informacji podczas importu albo eksportu do tych formatów.

  • Baza GRAMPS V2.x (grdb): Przed wersją 3.0, ten natywny format bazy był oparty na specyficznej formie bazy Berkeley (BSDDB) ze specjalną strukturą tabel. Jest to format binarny i zależny od architektury. Pomimo że był szybki i wydajny, nie był on przenośnym formatem pomiędzy komputerami o różnych architekturach (np. i386 vs. alpha).
  • GRAMPS XML: Plik GRAMPS XML jest domyślnym formatem dla starszych wersji (przed 2.x) GRAMPS. W przeciwieństwie do formatu grdb, jest on niezależny od architektury oraz zrozumiały dla ludzi. Baza może także posiadać odniesienia do obiektów medialnych nie będących lokalnie, dlatego nie jest on całkowicie przenośnym. Baza GRAMPS XML jest tworzona podczas eksportu ( Drzewa Rodzinne ->Eksport... ) do tego formatu.
  • Pakiet GRAMPS: Pakiet GRAMPS jest skompresowanym archiwum zawierającym plik GRAMPS XML oraz wszystkie obiekty medialne (obrazy, pliki dźwiękowe, itp.) do których baza się odnosi. Ponieważ zawiera ona wszystkie obiekty medialne, ten format jest całkowicie przenośnym. Pakiet GRAMPS jest tworzony przez eksport danych ( Drzewa rodzinne ->Eksport... ) do tego formatu.

Jeśli importujesz dane z innej bazy GRAMPS albo pliku GRAMPS XML, to zobaczysz pasek postępu w głównym oknie GRAMPSa.

Format skoroszytu GRAMPS CSV pozwala na import i eksport części danych z GRAMPSa w prostej arkuszowej formie. Zobacz Importowanie i eksportowanie CSV po więcej informacji.

Exporting Data

Fig.3.4 Export assistant: format selection


Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.

Gramps-notes.png
Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your GRAMPS window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

To export data, choose Family Trees ->Export . This will bring up the Export assistant. Its pages will guide you through the format selection (see export-druid-fig ), file selection, and format specific export options (see gedcom-export-fig ). After a final confirmation page, the export will be performed according to the choices you have made. At any time, you can click the Back button and revise any selection, and then go forward to redo the export.

Filters and Privacy

GRAMPS allows you to export a database into the common format. It provides options that allow you to fine tune your export.

  • Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported GEDCOM file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word "Living" for the first name; you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. GRAMPS uses an advanced algorithm to try to determine if a person could still be alive. Remember, GRAMPS is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

Export into GRAMPS formats

Gnome-important.png
Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for GRAMPS XML backups.

  • GRAMPS XML database export: Exporting into GRAMPS XML format will produce a database compatible with the previous versions of GRAMPS. As XML is a text-based human-readable format, you may also use it to take a look at your data.
  • GRAMPS package export: Exporting to the GRAMPS package format will create a compressed file that contains the database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

If a media file is not found during export, you will see a Missing Media dialog.

Exporting into the GEDCOM format

Fig.3.5.Export assistant: GEDCOM options

GRAMPS allows you to export a database into the common GEDCOM format. It provides options that allow you to fine tune your export (see Fig.3.5.gedcom-export-fig ).

  • Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported GEDCOM file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word "Living" for the first name; you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. GRAMPS uses an advanced algorithm to try to determine if a person could still be alive. Remember, GRAMPS is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

Export into other formats

  • Web Family Tree: Exporting to Web Family Tree will create a text file that can be used by the Web Family Tree program. Export options include filter selection and the ability to limit data on living people to that of their family ties.
  • vCalendar and vCard: Exporting to vCalendar or vCard will save information in a format used in many calendaring and addressbook applications, sometimes called PIM for Personal Information Manager.
  • GRAMPS CSV Spreadsheet format: Allows exporting (and importing) a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information. Also, see Export Display .

Konwersja bazy z 2.2 do wersji 3

Są dwa sposoby przeniesienia danych z wersji 2.2 do wersji 3; poprzez bezpośredni import pliku grdb z wersji 2.2 albo poprzez eksport do formatu XML i następnie jego import. Z powodu złożoności, w jaki sposób wersja 2.2 przechowywała dane, eksport do XML jest zazwyczaj najlepszą i najmniej problematyczną drogą na przeniesienie Twoich danych do wersji 3.

  • Import pliku grdb 2.2 : W bazie Gramps 2.2, Twoje dane były przechowywane w pliku grdb wraz z jednym lub większą ilością plików logów, które znajdowały się w podkatalogach w katalogu .gramps/env. Aby zaimportować dane bezpośrednio z 2.2 do Gramps 3, powinieneś utworzyć nową bazę danych i wybrać opcję importu bazy Gramps 2.2. Wymaga to upewnienia się, że uruchamiasz Gramps 3 jako ten sam użytkownik co uruchamiałeś Gramps 2.2 aby mieć dostęp do plików logów przechowywanych w katalogu .gramps/env, które są częścią Twej bazy. Jeśli uruchomiłeś Gramps 3 jako inny użytkownik albo na innym komputerze, będziesz musiał zapewnić, że wymagane pliki i katalog .gramps/env zawiera wymagane pliki. Jeśli widzisz błąd mówiący, że "/tmp/tmpDkI5pO could not be opened" albo coś podobnego, to oznacza, że Gramps 3 nie widzi wszystkich plików składających się na twoją bazę danych.
  • Gramps XML: Przy tym podejściu musisz najpierw uruchomić Gramps 2.2 i wyeksportować swoje dane do pliku Gramps XML. Ten plik XML jest skompresowany i posiada rozszerzenie .gramps. Jest on przenośny i nie zależy od innych plików, przez co może być przeniesiony na komputer, gdzie masz zainstalowaną wersję Gramps 3. Następnie musisz uruchomić Gramps 3 i po utworzeniu pustej bazy zaimportować ten plik za pomocą menadżera drzew rodzinnych.


Poprzednia Indeks Następna