Nl:GRAMPS 3.4 Wiki Handleiding - Familiestambomen beheren

From Gramps
Jump to: navigation, search
Gnome-important.png Opmerking over speciale auteursrechten: Alle aanpassingen aan deze pagina vallen onder twee verschillende auteursrechtlicenties:

Deze licenties geven het Gramps-project de maximale vrijheid om het wikihandboek als vrije inhoud voor toekomstige Gramps versies te gebruiken. Indien u niet akkoord gaat met deze dubbele licentie, pas dan de inhoud van deze pagina niet aan. U mag slechts middels externe links (gebruik: [http://www.gramps-project.org/...]) naar andere wikipagina's verwijzen die enkel onder de GFDL licentie vallen, en niet via interne links.
Gebruik daarnaast enkel de bekende conventies.


Vorige Index Volgende


Nu gaan we naar een gedetailleerde verkenning van het dagelijks gebruik van GRAMPS. In dit gedeelte geven we een overzicht van hoe u uw familiestambomen kunt organiseren en uw gegevens te delen met andere genealogen.

Een nieuwe familiestamboom starten

Fig. 1. Familiestambomen beheren

Om een nieuwe familiestamboom te starten kiest u ofwel Familiestambomen ->Familiestambomen beheren... ofwel klik de knop Familiestambomen in de werkbalk. Dit opent het venster familiestambomen.

Selecteer de knop Nieuw en Gramps zal een nieuw item aan de lijst toevoegen. Om de standaardnaam Familiestamboom 1 te veranderen, klikt u op de naam en voert een nieuwe naam in.

Vervolgens selecteert u de knop Laad familiestamboom om de nieuwe, lege familiestamboom te openen.


Een familiestamboom openen

Om een familiestamboom te openen, kiest u ofwel Familiestambomen ->Familiestambomen beheren... ofwel klikt u op de knop met het Gramps-logo Familiestambomen in de werkbalk. Het Familiestambomen-venster wordt dan getoond en u krijgt een lijst te zien van alle familiestambomen die Gramps kent. Voor elke geopende familiestamboom wordt een icoon getoond in de kolom: Status. Kies de familiestamboom die u wilt openen en open het bestand met de knop Familiestamboom laden. Of u kan dubbelklikken op de gewenste stamboom.

Om een onlangs geopende stamboom opnieuw te openen, kiest u ofwel Familiestambomen ->Onlangs geopend... ofwel de pijl naar beneden die zich rechts van de knop Familiestambomen bevindt. Vervolgens selecteert u de gewenste stamboom uit de lijst.

Indien u geen schrijfrechten hebt voor een bepaalde familiestamboom, wordt het bestand enkel in de modus 'enkel lezen' geopend. Gegevens kunnen dan wel gelezen worden, maar niet veranderd. In de titelbalk van het venster zal, om deze modus aan te geven, de tekst (Enkel lezen) verschijnen.

Een XML-gegevensbestand of een GEDCOM-bestand openen

GRAMPS laat u toe om bepaalde gegevensbestanden die niet opgeslagen zijn in het Gramps-formaat, toch te openen. via een opdrachtregel. Zie Opdrachtregelreferenties. Dit kunnen zowel XML- als GEDCOM-bestanden zijn. Maar u moet beseffen dat, indien deze bestanden vrij groot zijn, er prestatieproblemen kunnen optreden. Bovendien is het zo dat wanneer uw computer crasht al uw gegevens kunnen beschadigd worden. Daarom is het normaal gezien veel beter om een nieuwe familiestamboom aan te maken en dan uw XML/GEDCOM-bestand hierin te importeren.

Gramps-notes.png
Gegevensbestanden openen

XML- en GEDCOM-gegevensbestanden vereisen dat alle gegevens in het computergeheugen aanwezig zijn en geen indexen bevatten. Het eigen Gramps-formaat is een gegevensbestand dat enkel de gegevens die nodig zijn in het geheugen behoudt. Dit heeft als voordeel dat voor een groot bestand de gegevens veel sneller toegankelijk zijn en het dus efficiënt is om geen XML/GEDCOM-formaat te gebruiken.

Gnome-important.png
Bewerken van GEDCOM-bestanden

Let op: sommige gegevens kunnen verloren gaan wanneer een GEDCOM-bestand geïmporteerd of geëxporteerd wordt in of uit Gramps. Het bestand enkel openen en raadplegen zal het bestand echter niet veranderen. Als er echter veranderingen gebeurd zijn en die zijn niet geannuleerd voor het sluiten van het bestand, zal GRAMPS bij het afsluiten van het programma, de gegevens opslaan met mogelijk gegevensverlies tot gevolg.

Een familiestamboom verwijderen

Selecteer de familiestamboom die u wenst te verwijderen en klik op de knop: Verwijderen.

Dit zal de familiestamboom volledig verwijderen. U hebt geen mogelijkheid meer om de gegevens op te vragen. U kunt overwegen om een reservekopie van uw gegevens te nemen door uw gegevens te exporteren naar het Gramps XML-formaat en dit bestand vervolgens op te slaan.

Een familiestamboom herbenoemen

U kunt een familiestamboom (of een archief ervan) herbenoemen. Dit doet u door de stamboom te selecteren en op Herbenoem te klikken. U kunt ook op de naam in de lijst van stambomen klikken.

In beide gevallen, geeft u gewoon de nieuwe naam in en de stamboom is direct herbenoemd.

Een reservekopie van een familiestamboom maken

  • De veiligste methode om een reservekopie te maken van uw familiestamboom is een export naar het Gramps-XML formaat, zonder persoonlijke instellingen of filters, (of het Gramps-pakket waar ook bestanden voor uw galerij worden opgeslagen). Vervolgens kopieert u het onstane bestand op een veilige plaats, liefst zelfs in een ander gebouw.

Reservekopie dialoog

Fig. 2. Reservekopie aanmaken...

In het menu kiest u Familiestambomen en het item Reservekopie aanmaken....

U kunt de mediabestanden toevoegen of weglaten.

Dit is een gewone 'XML' export. Het enige verschil is dat er geen gegevens zijn uitgefilterd. U kunt dit bestand zoals een normaal bestand importeren.


U kunt een patroon voor de bestandsnaam definiëren door een variabele paths.quick-backup-filename in het ~/.gramps/gramps34/gramps.ini sleutelbestand op te nemen:

[paths]
quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%(extension)s'

Volgende sleutelbegrippen kunt u gebruiken: year, month, day, hour, minutes, seconds, filename en extension.

  • U kunt de archiefeigenschappen benutten om momentopnames te maken van uw familiestamboom. Deze momentopnamen kunnen gebruikt worden als eenvoudige reservekopieën. Ze zijn zeer handig om iets uit te proberen om dan later deze acties misschien te annuleren.

Let echter op: deze methode is niet aangewezen om een normale reservekopie te maken. Deze methode overleeft een defect aan uw harde schijf niet, net zomin als de meeste van de andere rampen die bij een computersysteem kunnen voorkomen.

  • Voor meer ervaren gebruikers: elk gegevensbestand wordt onder een eigen map geplaatst in de '/home/user/.gramps' map. U kunt een manuele reservekopie maken door deze map te kopieren.

Een familiestamboom archiveren

U kunt zeer eenvoudig familiestambomen archiveren en voorzien van een tijdstempel door gebruik te maken van GNU Revisie Controle Systeem of RCS. Gramps kan met dit systeem overweg maar dan moet u wel nakijken of dit programma op uw computer is geïnstalleerd.

Om een archief aan te maken dient u:

  1. de familiestamboom te laden
  2. op de familiestamboom knop klikken (deze met het gramps-logo en die gegevensbestanden beheren toont wanneer u er met de muis over gaat).
  3. op de familiestamboom die u daarnet geladen hebt, klikken: de Archiveer knop zou moeten verschijnen.
  4. op Archief klikken en er wordt een archiefnaam gevraagd.

Na het archiveren zal de lijst van de familiestambomen de oorspronkelijke familiestamboom tonen met een driehoek die naar rechts wijst. Deze bevindt zich links in de lijst.

  • Klikt u op de driehoek dan verschijnt de archiefnaam.(Klikt u opnieuw dan wordt de archieflijst samengevouwd).

Archieven kunnen verwijderd worden, herbenoemd of opgehaald.

Als u op een archief klikt, wordt de Ophalen knop zichtbaar. Klikt u op deze knop dan wordt het archief opgehaald. Het archief wordt getoond in de lijst met familiestambomen in de vorm <naam van de originele stamboom>:<archiefnaam> en het archief is nu een volledig onafhankelijke familiestamboom. Dit is een handige manier om een archief te bewaren, omdat archieven verdwijnen als de oorspronkelijk familiestamboom wordt verwijderd. ze worden niet meegenomen in de XML-export van de familiestamboom.

Een archief terug ophalen

Fig. 2. Een versie selecteren
Fig. 3. Opgehaalde versie

U hoeft enkel het archief aan te duiden en dan op de {man button|Ophalen}} knop klikken.

Gramps zal het archief naar een nieuwe familiestamboom verplaatsen. De naam van deze stamboom zal gebaseerd zijn op de originele naam en de archiefnaam (zie ook archiveren).

{-}}

Een familiestamboom ontgrendelen

Wanneer Gramps een familiestamboom opent, wordt deze stamboom vergrendeld zodat niemand, ook uzelf, deze familiestamboom opnieuw zou kunnen openen. Een tweede versie van GRAMPS kan een familiestamboom openen, maar de familiestamboom die reeds geopend is, zal met een slot icoon verschijnen zodat u weet dat u deze familiestamboom niet kunt openen. Door in de eerste Gramps-versie de stamboom te sluiten, wordt de familiestamboom in de tweede Gramps-versie opnieuw beschikbaar. Stel dat het mogelijk was om eenzelfde familiestamboom in twee versies van Gramps te openen, dan is de kans groot dat uw gegevens beschadigd worden. In het onwaarschijnlijke geval dat het Gramps-programma zou crashen, dan wordt de familiestamboom vergrendeld afgesloten. Om deze stamboom opnieuw toegankelijk te maken, selecteert u deze stamboom en klikt u op de knop Ontgrendelen die dan beschikbaar wordt. Doe dit echter enkel indien u er zeker van bent dat geen andere Gramps-versie de familiestamboom momenteel gebruikt.

Een beschadigde familiestamboom herstellen

Fig. 4. Een stamboom herstellen

Indien uw familiestamboom toch beschadigd werd, wordt een rood fouticoon getoond in de Status kolom. Door op de Herstellen knop te klikken, zal Gramps proberen de familiestamboom te herstellen. De stamboom wordt opnieuw opgebouwd vanuit de reservekopieën die automatisch worden aangemaakt als het programma verlaten wordt.


Aanpassingen aan uw familiestamboom opslaan

Gramps slaat uw aanpassingen direct op. Dit wil zeggen dat elke maal u de OK knop aanklikt, uw veranderingen worden genoteerd en opgeslagen. Er is dus geen aparte "opslaanfunctie". U kunt uw wijzigingen ongedaan maken door Bewerken ->Ongedaan maken te kiezen. Wanneer u dit commando meerdere gebruikt, kunt u uw recente aanpassingen één voor één teniet doen. Om meerdere aanpassingen tegelijk teniet te doen kan u de Geschiedenis wissen dialoog gebruiken die beschikbaar is via het Bewerken menu. Wenst u terug te keren naar de oorspronkelijke vorm van uw familiestamboom, kies dan Familiestambomen ->Wijzigingen annuleren en sluiten . (Dit komt overeen met vele andere programma's: het programma verlaten zonder wijzigingen op te slaan). Wenst u een kopie van uw familiestamboom onder een andere naam op te slaan, dient u de familiestamboom te exporteren en vervolgens te importeren in een nieuwe familiestamboom. Het GRAMPS XML formaat is voor dit doel aangewezen.

Gegevens importeren

Importeren laat u toe om gegevens van andere genealogische programma's te transfereren naar een Gramps-gegevensbestand. Momenteel kan Gramps volgende formaten importeren:

  • Gramps V2.x gegevensbestand (.grdb bestandsextensie)
  • GEDCOM (.ged bestandsextensie)
  • Gramps-XML (.gramps bestandsextensie)
  • Gramps-pakket (.gpkg bestandsextensie)
  • GeneWeb (.gw bestandsextensie)
  • Gramps CSV rekenblad - comma separated values (.csv bestandsextensie)
  • Pro-Gen (.def bestandsextensie)
Gramps-notes.png
Importeren en openen van een bestand

Merk het verschil op tussen het importeren en het openen van een gegevensbestand. Wanneer u gegevens importeert, brengt u gegevens van één gegevensbestand in een Gramps-gegevensbestand. Wanneer u echter een bestand opent, past u uw originele bestand aan.

Om gegevens te importeren, kiest u Template:Amn menu. De dialoog gegevensbestand importeren wordt geopend en er wordt u gevraagd welk bestand u wenst te importeren. Let op: u kunt enkel gegevens importeren in een bestaand gegevensbestand. Als u dus al uw gegevens verplaatst van een ander programma of van een oudere Gramps-versie, dient u eerst een nieuw gegevensbestand aan te maken en dan dient u de gegevens daarin te importeren.

Gnome-important.png
Gegevensverlies met sommige formaten mogelijk

Het is belangrijk te weten dat het importproces niet perfect is voor de formaten GEDCOM en GeneWeb. Het blijft steeds mogelijk dat sommige gevens niet geimporteerd worden in het Gramps-gegevensbestand.

Gnome-important.png
Ordenen van gebeurtenissen aangemaakt met andere programma's

Gramps voorziet in een hulpgereedschap om gebeurtenissen volgens uw voorkeur te ordenen. Kijk hiervoor naargebeurtenissen sorteren.


Het Gramps V2.x gegevensbestand, Gramps-XML en Gramps-pakket zijn allemaal normale Gramps-formaten. Hier bestaat geen risico voor gegevensverlies wanneer gegevens geimporteerd of geexporteerd worden.

  • Gramps V2.x gegevensbestand (.grdb): Voor de versie 3.4, was dit bestandsformaat een specifieke vorm van een Berkeley database (BSDDB) met een speciale structuur van de gegevenstabellen. Dit formaat was binair en onafhankelijk van de computerarchitectuur. dit bestandsformaat was efficient en snel maar was over het algemeen niet volledig omzetbaar tussen computers met verschillende binaire architecturen zoals een i386 en een alpha.
  • Gramps-XML: (.gramps): Het Gramps-XML bestand is het standaardformaat voor gegevensuitwisseling en reservekopieen en tevens het normale werkformaat voor oudere Gramps-versies (pre 2.x). In tegenstelling tot het grdb-formaat, is dit formaat onafhankelijk van de architectuur en door mensen te lezen. Het gegevensbestand kan ook externe verwijzingen naar media-objecten bevatten. Dit maakt dat dit formaat ook niet volledig omzetbaar kan zijn. Een GRAMPS XML-gegevensbestand wordt aangemaakt door Familiestambomen ->Exporteren... ) naar dit formaat.
  • Gramps-pakket '.gpkg): Het Gramps-pakket is een gecomprimeerd archief dat het Gramps-XML bestand bevat samen met alle media-objecten (beelden, geluidsbestanden, enz.) waarnaar het gegevensbestand verwijst.

Omdat alle media-objecten vervat zijn, is dit formaat volledig overzetbaar. Een Gramps-pakket wordt aangemaakt door ( Familiestambomen -> Exporteren... ).

Indien u informatie importeert van een ander Gramps-gegevensbestand of een Gramps-XML bestand, zal de vooruitgang van de gegevenstransfer getoond worden in de voortschrijdingsbalk van het hoofdscherm. Als het importeren gedaan is, wordt een venster getoond en wordt aangegeven hoeveel objecten werden geïmporteerd. Indien de geïmporteerde gegevens afkomstig zijn van dezelfde familiestamboom als die waarin u de gegevens importeerde, zal ook in dit venster enkele suggesties gegeven worden hoe u bepaalde gegevens kunt samenvoegen. Dit samenvoegen wordt niet automatisch uitgevoerd.

Wenst u deze samenvoeging van de basisgegevens toch automatisch te laten verlopen, unt u misschien beter een CSV rekenblad export/import gebruiken.

Het Gramps-CSV rekenbladformaat laat u toe om gegevens of een deel van uw Gramps-gegevens te importeren of te exporteren in een eenvoudig rekenbladformaat. Zie importeren van exporteren van CSV voor meer informatie.

Gegevens exporteren

Fig. 5. Export assistent

Exporteren laat u toe om gelijk welk deel van uw gegevensbestand te delen met andere onderzoekers. Bovendien hebt u de mogelijkheid om uw gegevens te transferen naar een andere computer. Momenteel kan GRAMPS gegevens exporteren naar de volgende formaten: Gramps-XML, GEDCOM, Gramps-pakket, Web Family Tree, GeneWeb en het Gramps-CSV rekenbladformaat.


Gramps-notes.png
Exporteren is een kopie opslaan

Wanneer u gegevens exporteert, slaat u een kopij van uw huidig geopend gegevensbestand op. Exporteren maakt dus een ander bestand aan. Dit bestand bevat een kopie van uw gegevens. Let op: het gegevensbestand dat geopend werd in uw Gramps-scherm is NIET het bestand dat aangemaakt werd door de exportactie. Bijkomende aanpassingen in het huidig geopende gegevensbestand zullen dus de kopie door de exportactie aangemaakt, NIET veranderen.

Om gegevens te exporteren kiest u Familiestambomen ->Exporteren.... Vervolgens wordt een Export Assistent scherm getoond. De verschillende opeenvolgende schermen zullen u leiden door de formaatkeuze (zie Fig. 5 ), de bestandsselectie en enkele specifieke exportfuncties.

Na een laatste bevestigingsscherm zal de export uitgevoerd worden volgens de keuzes die u maakte. U kunt steeds de Terug knop aanklikken en de keuze herzien om vervolgens opnieuw verder te gaan en de export over te doen.

Filters en privacy

GRAMPS laat u toe om uw gegevensbestand te exporteren naar enkele gekende bestandsformaten. Er zijn bovendien een aantal opties die u toelaten om de exportfunctie te verfijnen.

  • Filters voor personen en opmerkingen: Filters laten u toe om een controleerde hoeveelheid gegevens gebaseerd op criteria die u kiest, te exporteren.
  • Gegevens met de aanduiding privé niet bijvoegen: Klik deze keuze aan indien u wilt voorkomen dat private gegevens (zijn die gegevens die een aanduiding privé meekregen) worden geëxporteerd.
  • Gegevens over levende personen beperken: klik deze optie aan indien u de informatie over nog levende personen wilt beperken. Dit betekent dat alle informatie met betrekking tot geboorte, overlijden, adressen en belangrijke gebeurtenissen weggelaten worden in het exportbestand. Indien u voor deze optie kiest, worden bijkomende opties gegeven om de informatie verder te beperken. Zo kunt u ter vervangen van de voornaam het woord Levend' gebruiken (zie uw Voorkeuren); u kunt opmerkingen uitsluiten en bronnen van nog in leven zijnde personen uitsluiten.
  • Gegevens zonder verbindingen niet bijvoegen: klik deze optie aan om gegevens zonder verbindingen niet op te nemen in het exportbestand.

Het is niet altijd eenvoudig om uit te gegevens af te leiden of een persoon nog al of niet in leven is. Gramps gebruikt hiervoor een ingewikkeld algoritme om te trachten uit te zoeken of iemand nog in leven zou kunnen zijn. Maar Gramps maakt een best mogelijke gok en het is best mogelijk dat deze gissing fout is. Gelieve daarom steeds uw gegevens nog eens te controleren.

Exporteren naar Gramps-formaten

Gnome-important.png
Filters voor private gegevens

Het is belangrijk om de opties voor private gegevens te controleren voor u gegevens exporteert. Gebruik geen filters of opties voor private gegevens voor een Gramps-XML reservekopie.

  • Gramps-XML gegevensbestand export (.gramps): Dit is het basisformaat voor gegevensuitwisseling en reservekopies (zie ook het aanverwante .gpkg-formaat hieronder beschreven voor media-objecten over te zetten). Exporten naar het Gramps-XML formaat levert een overzetbaar gegevensbestand op. Omdat XML een tekstbestand is, kunt u uw gegevens bekijken door het bestand met een teksteditor te openen. Dit formaat is ook compatibel met vorige Gramps-versies.
  • Gramps-pakket export (.gpkg): Exporteren naar het Gramps-pakket formaat zal een gearchiveerd XML-bestand bevatten samen met alle met Gramps verbonden mediabestanden. dit is zeker handig wanneer u uw gegevens wilt delen met iemand of uw gegevens wenst over te zetten naar een andere computer.
  • Naar CD exporteren: Exporteren naar CD kopieert alle gegevens en media-objecten naar het cd-aanmaakprogramma. U kunt dan later een gegevens-cd branden. Om de cd te branden gaat u naar de GNOME branden:/// locatie, die bereikt kan worden door te navigeren door Nautilus. Nadat het exporteren naar CD, kiest u Ga naar ->CD Aanmaken in het Nautilus menu. Uw gegevensbestandsmap zal getoond worden. Om de cd te branden klikt u op het cd-icoontje in de gereedschapsbalk van Nautilus of kiest u Bestand ->Naar cd schrijven in het Nautilus menu.

Wordt een mediabestand niet gevonden tijdens het exporteren, zal u dezelfde dialoog zien als bij een GEDCOM-export.

Exporteren naar het GEDCOM-formaat

Fig. 6. GEDCOM-opties

Gramps laat u toe om uw gegevensbestand te exporteren naar het gekende GEDCOM-formaat. Er zijn opties voorzien om uw exportactie te verfijnen.

  • Filters voor personen en opmerkingen: Filters laten u toe om een controleerde hoeveelheid gegevens gebaseerd op criteria die u kiest, te exporteren.
  • Gegevens met de aanduiding privé niet bijvoegen: Klik deze keuze aan indien u wilt voorkomen dat private gegevens (zijn die gegevens die een aanduiding privé meekregen) worden geëxporteerd.
  • Gegevens over levende personen beperken: klik deze optie aan indien u de informatie over nog levende personen wilt beperken. Dit betekent dat alle informatie met betrekking tot geboorte, overlijden, adressen en belangrijke gebeurtenissen weggelaten worden in het exportbestand. Indien u voor deze optie kiest, worden bijkomende opties gegeven om de informatie verder te beperken. Zo kan u ter vervangen van de voornaam het woord Levend' gebruiken (zie uw Voorkeuren); u kan opmerkingen uitsluiten en u kan bronnen van nog in leven zijnde personen uitsluiten.
  • Gegevens zonder verbindingen niet bijvoegen: klik deze optie aan om gegevens zonder verbindingen niet op te nemen in het exportbestand.


Exporteren naar andere formaten

  • Web Family Tree: Exporteren naar het Web Family Tree-formaat zal een tekstbestand aanmaken dat dan gebruikt kan worden i het Web Family Tree-programma. Exportopties bevatten filterselecties en de mogelijkheid om gegevens over nog in leven zijnde personen te beperken tot hun familiebanden.
  • vCalendar en vCard: Exporteren naar vCalendar of vCard zal informatie opslaan in een formaat dat voornamelijk gebruikt wordt voor kalenders en adresboektoepassingen. Soms wordt dit ook een PIM: personal information manager systeem genoemd.
  • Gramps-CSV rekenbladformaat: laat toe om een deel van uw gegevens te exporteren (ook te importeren) in een eenvoudig rekenbladformaat. Zie CSV import en export voor meer info. Zie ook hoe u een scherm kunt exporteren.
  • GRAMPS XML (.gramps): het GRAMPS XML-bestand is de standaard voor gegevens uit te wisselen of op te slaan. Het is tevens het standaard gegevensbestandsformaat voor oudere (pre 2.x) Gramps-versies.

In tegenstelling tot het grdb-formaat, is dit formaat architectuur onafhankelijk en kan door mensen gelezen worden. Het gegevensbestand kan ook verwijzingen bevatten naar niet-lokale (externe) media-objecten. daarom is er geen garantie dat dit formaat volledig porteerbaar is. Voor volledige overzetbaarheid dient u het Gramps-pakketformaat (.gpkg) te gebruiken. Het GRAMPS XML-gegevensbestand wordt aangemaakt door ( Familiestambomen ->Exporteren... ) en dan door dit formaat te kiezen.

Gegevensbestanden verplaatsen van versie 2.2 naar Gramps 3

Er zijn twee methoden om uw Gramps-gegevens te verplaatsen van versie 2.2 naar versie 3; ofwel rechtstreeks uw versie 2.2 grdb-bestand laden ofwel eerst exporting naar het XML-formaat. Wegens het relatieve ingewikkelde schema waarmee de gegevens van versie 2.2 worden opgeslagen, is eerst exporteren naar XML gewoonlijk de eenvoudigste en foutvrije manier om uw gegevens te verplaatsen naar versie 3.

  • Importeren van een 2.2 grdb bestand: In een versie 2.2 gegevensbestand worden uw gegevens opgeslagen in een grdb-bestand samen met één of meer logbestanden die verzameld zijn in de .gramps/env map.

Om uw 2.2 gegevens rechtstreeks in Gramps 3 te importeren, maakt u eerst een nieuw gegevensbestand aan en selecteert u vervolgens importeren van een Gramps 2.2 gegevensbestand. U moet er zeker van zijn stellen dat het dezelfde gebruiker is die beide versie draait, omdat u toegang dient te hebben tot dezelfde .grams/env map, die de logbestanden die uw gegevensbestand aanvullen, bevatten. Indien u Gramps 3 als andere gebruiker draait of een andere machine gebruikt, dient u de nodige voorzorgen in acht te nemen om de map en de logbestanden toegankelijk te maken. Indien u een foutmelding krijgt in de zin van "/tmp/tmpDkI5pO kon niet worden geopend" wanneer u probeert om een gegevensbestand te importeren wil dit zeggen dat Gramps 3 niet alle nodige bestanden die uw gegevensbestand vormen, kan zien.

  • Gramps XML: Om deze methode te volgen, start u eerst Gramps 2.2 op en exporteert u uw gegevens naar het Gramps-XML-formaat. Dit XML-bestand is gecomprimeerd en bevat een .gramps-bestand. Dit bestand is overzetbaar en het bestand is onafhankelijk van andere bestanden. Het is bovendien verplaatsbaar naar een Gramps 3 installatie. Vervolgens start u Gramps 3, maakt u een leeg gegevensbestand aan via de familiestamboombeheerder en importeert u het .gramps-bestand.



Vorige Index Volgende