Fi:Gramps 3.4 Wiki-käyttöohje - Sukupuiden hallinta

From Gramps
Jump to: navigation, search

Nyt suuntaamme yksityiskohtaiselle tutkimusmatkalle päivittäiseen GRAMPS:in käyttöön. Tässä kappaleessa esitämme yksityiskohtaisen katsauksen miten voit hallita sukupuitasi kuten myös miten jaat tietosi muiden sukututkijoiden kanssa.

Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.<br\> Also, only use the known conventions


Edellinen Hakemisto Seuraava


Uuden sukupuun aloittaminen

Kuva 3.4. Sukupuut

Aloittaaksesi uuden sukupuun, valitse Sukupuut ->Hallinnoi sukupuita tai valitse Sukupuut painike työkaluriviltä. Tämä avaa sukupuiden hallintaikkunan.

Valitse Uusi ja GRAMPS luo uuden sukupuun sukupuiden listalle. Vahtaaksesi sen nimen oletusnimestä Sukupuu 1, napauta nimeä ja kirjoita uusi nimi.

Valitse Lataa sukupuu ladataksesi uuden tyhjän sukupuun.

Sukupuun avaaminen

Avataksesi sukupuun, valitse joko Sukupuut -> Hallinnoi sukupuita tai napsauta Sukupuut painiketta työkaluriviltä. Sukupuut ikkuna tule näkyviin ja näet listan kaikista GRAMPS:in tuntemista sukupuista. Kuvake näyttää Tila sarakkeessa sukupuun vieressä että se on tällä hetkellä avoimena. Valitse puu jonka haluat avata ja avaa se valitsemalla Lataa sukupuu painike. Vaihtoehtoisesti voit kaksoisnapsauttaa haluttua puuta.

Avataksesi viimeksi käytetyn sukupuun, valitse joko Sukupuut -> Viimeksi avattu tai nuoli alaspäin seuraavana Sukupuut painikkeesta ja valitse sukupuu listalta.

Jos sinulla ei ole "kirjoitus oikeutta" valittuun sukupuuhun, se avataan Kirjoitussuojattu-tilaan. Tässä tilassa tietoja voi katsella, mutta muutoksia ei tehdä puuhun. Merkkinä tästä tilasta, pääikkunan otsikkoon lisätään teksti (Kirjoitussuojattu)

GEDCOM tai XML tietokannan avaaminen

GRAMPS mahdollistaa avata erilaisia tietokantoja joita ei ole tallennettu GRAMPSin omaan tiedostomuotoon komentoriviltä. TODO linkki sivulle missä kerrotaan miten. Näihin kuluu XML ja GEDCOM tietokannat. Mutta sinun pitää olla valveutunut että jos XML tai GEDCOM tietokanta on suhteellisen suuri, sinä tulet kohtaamaan suorituskyky ongelmia ja kaatumisen tapahtuessa sinun tietosi voi korruptoitua. Tästä johtuen on tavallisesti parempi luoda uusi GRAMPS sukupuu (tietokanta) ja tuoda XML/GEDCOM tiedot siihen.

Gramps-notes.png
Tietokannan avaus

XML ja GEDCOM tietokannat vaativat kaiken tiedon pitämistä muistissa ja se ei sisällä hakemistoa. GRAMPSin oma tiedostomuoto lukee vain tarvittavan tiedon. Näin ollen suuren sukupuun tiedot ovat käytettävissä nopeammin ja paljon tehokkaammin kuin käytettäessä XML- tai GEDCOM-tiedostoja.

Gnome-important.png
GEDCOMin muokkaaminen

Pidä mielessä että jotkin tiedoista GEDCOM tiedostosta voi kadota tuotaessa GRAMPSiin kuten myös vietäessä takaisin GEDCOMiin. Yksinkertainen avaaminen ja katseleminen ei muuta sitä. Kuitenkin jos jotakin muutoksia on tehty ja niitä ei ole peruttu, poistuminen GRAMPSista tallettaa tiedot ja mahdollisesti tietoja katoaa.

Sukupuun poistaminen

Valitse sukupuu jonka haluat poistaa ja napauta Poista painiketta.

Tämä poistaa kokonaan puun, ilman mahdollisuutta palauttaa tietoja. Harkitse varmuuskopion ottamista viemällä tietosi GRAMPS XML-muotoon ja säilyttämällä tiedosto.

Sukupuun uudelleen nimeäminen

Voit uudelleen nimetä sukupuusi (tai sen arkistoidun version) valitsemalla uudelleen nimettävän puun ja napsauttamalla Nimeä uudelleen. voit myös napsauttaa nimeä puiden listassa.

Molemmissa tapauksissa, kirjoita vain uusi haluamasi nimi.

Sukupuun varmuuskopiointi

Turvallisin tapa varmuuskopioida GRAMPS sukupuusi on viedä se GRAMPS XML' muotoon (tai GRAMPS paketti sisältää tiedostot galleriasta) ja kopioida syntynyt tiedosto turvalliseen paikkaan, mieluummin eri rakennukseen.

Voit käyttää arkistointia tallentaaksesi tilannekuvan puustasi. Näitä tilannekuvia voi käyttää yksinkertaisina varmuuskopiona, erittäin käyttökelpoinen jos haluat kokeilla jotakin minkä myöhemmin saatat haluta perua. Kuitenkin tätä tapaa ei tule käyttää normaaliin varmuuskopiointiin, se ei selviä kiintolevy rikosta eikä useimmistakaan muista tuhoista joita voi tapahtua tietokoneelle.

Kokeneille käyttäjille: jokainen tietokanta on talletettu omaan alihakemistoonsa hakemiston ~/.gramps alle. Käsin tehtävä varmuuskopiointi voidaan tehdä varmistamalla tämä hakemisto.

Backup dialog

Fig. 4.2 Making a backup

Simply select the menu Family Trees->Make Backup...".

You can either choose to include the media or not.

Note that this is just a regular XML export, except that no data is filtered out. You can import these as usual with any exported file.


You can also define the pattern for the backup filename by setting the paths.quick-backup-filename in the ~/.gramps/gramps34/gramps.ini key file like the following:

[paths]
quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%(extension)s'

You can use any of the following keywords in the pattern: year, month, day, hour, minutes, seconds, filename, extension.


  • You can use the Archive feature (see next section) to store snapshots of your Family Tree. These snapshots can be used as simple backups, very useful if you want to try something that you might later want to undo. However this method should not be used for standard backups, as it will not survive a hard disk crash or most of the other disasters that can befall a computer.
  • For advanced users: each database is stored in its own subdirectory under ~/.gramps. A manual backup can be made by backing up this directory.

Sukupuun arkistointi

Voit helposti arkistoida ja aikaleimata sukupuun GRAMPSin sisäänrakennetun GNU Revision Control System tai RCS avulla. Jotta tämä on mahdollista tämä työkalu tulee olla asennettuna tietokoneelle.

Arkiston teossa, ensimmäisenä varmista että puu josta haluat tehdä arkiston on avattuna. Sitten valitse avattu sukupuu ja napsauta Arkistoi painiketta. Arkisto listataan puun alla josta se on tehty. Arkistoja voidaan poistaa ja uudelleen nimetä.

Sukupuu arkiston palauttaminen

Kuva 3.4 Palautettavan version valinta

Yksinkertaisesti valitse arkisto jonka haluat palauttaa ja valitse Pura painike.

Kuva 3.4 Korjattu sukupuu

GRAMPS siirtää arkiston uudeksi sukupuuksi. Sukupuun nimi perustuu alkuperäiseen ja arkiston nimeen.

Sukupuun lukon avaaminen

Kun GRAMPS avaa puun, se lukitsee sen, estääkseen sinun tai kenenkään muun avaamasta sitä samanaikaisesti. Toisella käynnissä olevalla GRAMPSilla voit avata toisen sukupuun, mutta avoinna oleva puu näkyy lukittu ikonilla, osoittaen että et voi avata sitä. Puun sulkeminen toisessa GRAMPSissa antaa mahdollisuuden avata se toisessa käynnissä olevassa GRAMPSissa.

Jos voit avata saman sukupuun kahdessa GRAMPSissa yhtaikaa, se todennäköisesti voittaisi tietojasi.

Epätodennäköisessä GRAMPSin kaatumisessa, sukupuu jää lukituksi. Puun lukon avaaminen, valitse lukittu sukupuu ja napauta Riko lukko painike joka tulee saataviille. Tee tämä vain jos olet varma ettei sukupuuta käytetä toisessa GRAMPSissa.

Vioittuneet sukupuun korjaaminen

Kuva 3.4 Sukupuun korjaamien

Jos sukupuusi vaurioitui jostakin syystä, GRAMPSin sukupuiden hallinta ikkunassa näet punaisen virhe ikonin Tila sarakkeessa.

Saadaksesi GRAMPSin yrittämään korjausta vioittuneelle, valitse puu ja sitten napsauta Korjaa painiketta.

Tämä yrittää korjata puun varmuuskopiosta joka on automaattisesti luotu poistuttaessa.

Muutosten tallettaminen sukupuuhun

GRAMPS tallettaa muutokset heti kun olet hyväksynyt ne. Tämä tarkoittaa, esimerkiksi, että joka kerta kun napautat OK painiketta kun käytät GRAMPSia, muutokset on välittömästi kirjattu ja talletettu. Täällä ei ole erillistä "tallenna" komentoa.

Voit peruuttaa tekemäsi muutokset valitsemalla Muokkaa -> Peru. Jos valitset komennon toistuvasti, uusimmat muutokset perutaan yksittäin. Palataksesi useampia komentoja kerrallaan, voit käyttää Muokkaushistoria ikkunaa joka löytyy Muokkaa valikosta.

Jos haluat palauttaa sukupuusi tilaan jossa se oli avatessa, valitse Sukupuut -> Hylkää muutokset ja lopeta. (Tämä on samanlainen kuin lopettaminen ilman tallennusta muissa ohjelmissa.)

Jos haluat tallettaa kopion sukupuustasi eri nimellä, sinun tarvitsee viedä sukupuu ja sitten tuoda se sitten uuteen sukupuuhun. 'GRAMPS XML tietokanta on suositeltavin tähän tarkoitukseen.

Tietojen tuonti

Tuonti sallii tuoda tietoja muista sukututkimusohjelmista GRAMPS tietokantaan. Tällä hetkellä GRAMPS voi tuoda tietoja seuraavista tiedostomuodoista:

GRAMPS V2.x tietokanta (.grdb tiedostopääte)

GEDCOM (.ged tiedostopääte)

GRAMPS XML (.gramps tiedostopääte)

GRAMPS paketti (.gpkg tiedostopääte)

GeneWeb (.gw tiedostopääte)

GRAMPS CSV taulukkolaskenta - pilkulla erotetut arvot (.csv tiedostopääte)

Gramps-notes.png
Tuonti vai avaus

Huomaathan että tuonti tietokantaan on eri kuin tietokannan avaaminen. Kun tuot, olet itseasiassa tuomassa tietoja toisesta tietokannasta GRAMPS tietokantaan. Kun avaat tiedoston, olet muokkaamassa alkuperäistä tiedostoa.

Tuodaksi tiedot, valitse Sukupuut -> Tuonti. Tuo tietokanta ikkuna aukeaa, kysyy valitsemaan tiedoston jonka haluat tuodat. Huomaa että voit tuoda vain tietoja olemassa olevaan tietokanttaan joten jos olet siirtämässä kaikki tietosi toisesta ohjelmasta tai vanhemmasta GRAMPS versiosta, niin ensin luo tyhjä tietokanta ja sitten tuot tiedot siihen.

Gnome-important.png
Tiedon katoamina joistakin tiedostomuodosta

On tärkeää huomata että tuotin ei ole täydellinen GEDCOM ja GeneWeb tietokannoista. On mahdollista että jotkin tietoja näistä tietokannoista ei tuoda GRAMPSiin.

GRAMPS V2.x tietokannat, GRAMPS XML ja GRAMPS paketit ovat kaikki alkuperäisiä GRAMPS tiedostomuotoja. Tässä ei ole vaaraa tietojen katoamisesta kun tuodaan tai viedään näihin tiedostomuotoihin.

  • GRAMPS V2.x tietokanta (grdb): Ennen versiota 3.4, tämä alkuperäinen GRAMPS tietokantamuoto on erityinen Brkeley tietokanta (BSDDB) jossa erikoisrakenne tietotauluissa. Tämä tiedostomuoto on binääri ja arkkitehtuuri riippumaton. Se on erittäin nopea ja tehokas, mutta ei yleisesti siirrettävissä ristiin eri tietokoneilla joilla on erilainen binääri arkkitehtuuri (esim. i386 tai alpha).
  • GRAMPS XML: GRAMPS XML tiedosto oli oletus tiedostomuoto vanhemmilla (ennen 2.x) GRAMPS versioilla. Toisin kuin grdb tiedostomuoto, se on arkkitehtuuri riippumaton ja ihmisluettava. Tietokanassa voi olla myös viittauksia ei-paikallisiin (ulkoisiin) mediatiedostoihin, jolloin ei ole varmuutta täydelliseen siirrettävyyteen. GRAMPS XML tietokanta luodaan viemällä ('Sukupuut -> Vienti) tiedot tähän tiedostomuotoon.
  • GRAMPS paketti: GRAMPS paketti on pakattu tiedosto joka sisältää GRAMPS XML tiedoston ja kaikki mediatiedostot (kuvat, äänet, jne.) joihin tietokanta viittaa. Koska se sisältää kaikki mediatiedostot, tämä tiedostomuoto on täysin siirrettävä. GRAMPS paketti luodaan viemällä (Sukupuut -> Vienti) tiedot tähän tiedostomuotoon.

Jos sinun tuot tiedot toisessa GRAMPS tietokannasta tai GRAMPS XML tietokannasta, näet tapahtuman edistymisen GRAMPSin pääikkunan edistymispalkissa.

GRAMPS CSV taulukkolaskenta tiedostomuoto sallii tuoda ja viedä osan GRAMPS tiedoista yksinkertaiseen taulukkolaskenta muotoon. Katso lisätietoja CSV Import and Export.

Tietojen vienti

Fig.3.4 Export assistant: format selection

Wait to update manual: The exporter is undergoing a major rewrite.

Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.

Gramps-notes.png
Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your GRAMPS window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

To export data, choose Family Trees ->Export . This will bring up the Export assistant. Its pages will guide you through the format selection (see Fig.3.4 ), file selection, and format specific export options. After a final confirmation page, the export will be performed according to the choices you have made. At any time, you can click the Back button and revise any selection, and then go forward to redo the export.

Export into GRAMPS formats

  • GRAMPS database (grdb) export: Exporting to the GRAMPS native format will simply make a copy of your data under another name. Exporting to this format can also be useful if you have directly opened an XML or GEDCOM file and would like to save it as the grdb file.
  • GRAMPS XML database export: Exporting into GRAMPS XML format will produce a database compatible with the previous versions of GRAMPS. As XML is a text-based human-readable format, you may also use it to take a look at your data.
  • GRAMPS package export: Exporting to the GRAMPS package format will create a compressed file that contains the database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Exporting into the GEDCOM format

Fig.3.5.Export assistant: GEDCOM options

GRAMPS allows you to export a database into the common GEDCOM format. It provides options that allow you to fine tune your export (see Fig.3.5.gedcom-export-fig ).

  • Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
  • Target: While GEDCOM is a standard, not every program implements it in the same way. This can lead to data loss. GRAMPS can reduce the data loss in some cases. You can tell GRAMPS what program is the target, and GRAMPS will customize the exported file for that program. If your program is not listed, choose the "GEDCOM 5.5 Standard".
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported GEDCOM file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word "Living" for the first name; you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. GRAMPS uses an advanced algorithm to try to determine if a person could still be alive. Remember, GRAMPS is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

  • Reference images from path: Check this box to tell GRAMPS to use the specific path for your images when writing image references in GEDCOM.

This option allows specify where your image files are located. This is useful when you are transferring your GEDCOM file from one computer to another. It tells the program that is importing the data where your images are.

Export into other formats

  • Web Family Tree: Exporting to Web Family Tree will create a text file that can be used by the Web Family Tree program. Export options include filter selection and the ability to limit data on living people to that of their family ties.
  • vCalendar and vCard: Exporting to vCalendar or vCard will save information in a format used in many calendaring and addressbook applications, sometimes called PIM for Personal Information Manager.
  • GRAMPS CSV Spreadsheet format: Allows exporting (and importing) a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information. Also, see Export Display .

Siirtyminen 2.2 tietokannasta GRAMPS 3:een

On olemassa kaksi tapaa siirtää Gramps tiedot versiosta 2.2 versioon 3; joko suora tuonti version 2.2 grdb tiedostosta tai viemällä ensin XML tiedostomuotoon. Koska version 2.2 tallentaa tiedot monimutkaisesti, vienti XML muotoon on tavallisesti kätevin ja ongelmattomin tapa siirtää tiedot versioon 3.

  • Tiedoston 2.2 tuonti: Gramps 2.2 tietokanassa, tiedot on tallennettu grdb tiedostoon yhdessä yhden tai useamman lokitiedoston kanssa hakemistoon joka löytyy hakemistosta .gramps/env. Tuodaksesi version 2.2 tiedot suoraan Gramps 3:een, luo uusi tietokanta ja valitse vaihtoehto tuo Gramps 2.2 tietokanta. Sinun täytyy olla varma että käytät Gramps 3 samana käyttäjä kuin käytit Gramps 2.2 niin että on käyttöoikeus samaan .gramps/env hakemistoon sisältäen lokitiedostot jotka täydentävät tietokantaasi. Jos käytät Gramps 3 eri käyttäjänä tai eri tietokoneella sinun täytyy antaa käyttöoikeudet saadaksesi .gramps/env hakemistolle ja lokitiedostoille. Jos saat virheilmoituksen sanotaampa "/tmp/tmpDkl5pO ei voida avata" tai samantapaisen kun yrität tuoda tietokantaa, se tarkoittaa että Gramps 3 ei ole pääsyä kaikkiin tiedostoihin joista tietokantasi koostuu.
  • GRAMPS XML: Tällä menettelytavalla käynnistä ensin Gramps 2.2 ja vie tietokantasi Gramps XML muotoon. XML tiedosto on itseasiassa pakattu ja sisältyy .gramps tiedostoon. Tämä tiedosto on siirrettävä, eikä sillä ole riippuvuuksia toisiin tiedostoihin ja voidaan siirtää sinne missä sinulla on Gramps 3 asennettuna. Seuraavaksi käynnistä Gramps 3 ja luo tyhjä tietokanta käyttäen sukupuiden hallinta ikkunaa ja tuo .gramps tiedosto.


Edellinen Hakemisto Seuraava