De:Gramps 3.3 Wiki Handbuch - Werkzeuge

From Gramps
Jump to: navigation, search

Dieses Kapitel beschreibt die verschiedenen Werkzeuge von Gramps.

Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.
Außerdem verwende nur die Bekannten Drucktechnische Konventionen

Zurück Index Nächste


Einleitung

Gramps Werkzeuge ermöglichen dir verschiedene Arten der Analyse deine Genealogiedaten durchzuführen. Typischerweise erzeugen Werkzeuge keine Ausgaben in der Form von Ausdrucken oder Dateien. Stattdessen erzeugen sie Bildschirmausgaben die dem Forscher sofort zur Verfügung stehen. Allerdings kannst du wenn es dienlich ist,die Ergebnisse eines laufenden Werkzeug in einer Datei speichern. Werkzeuge sind eine der Hauptstärken von Gramps gegenüber den meisten anderen Genealogieprogrammen.

Auf die Werkzeuge kann über das Menü Werkzeuge ->Werkzeugabschnitt ->Jeweilige Werkzeug zugegriffen werden. Alternativ kannst du die komplette Liste der verfügbaren Werkzeuge mit einer kurzen Beschreibung im Werkzeugauswahl Dialog, der über die Werkzeuge Schaltfläche in der Werkzeugleiste aufgerufen wird, durchsuchen.

Gramps-notes.png
Zusätzliche Werkzeuge

Mit Gramps 3.3 wurde ein neues System implementiert um sogar mehr Werkzeuge zur Verfügung zu haben. Dieses System wird über die Zusatzmodulverwaltung gesteuert. Die Zusatzmodulverwaltung kann zusätzliche Erweiterungen für dich holen. Überprüfe die Liste verfügbarer Werkzeuge hier.

Gemeinsame Optionen

  • id: = ID

Gramps ID der zentralen Person.

Analyse und Untersuchen

Dieser Abschnitt enthält Werkzeuge die die Datenbank Analysieren und untersuchen sie aber nicht verändern. Die folgenden Analyse und Untersuchungswerkzeuge stehen aktuell in Gramps zur Verfügung:

Einzelne Ereignisse vergleichen...

Dieses Werkzeug vergleicht quer über die gewählte Gruppe von Personen. Die Personen für diesen Vergleich werden durch die Verwendung von Anwenderfilter definiert. Die Anwenderfilter können im Anwenderfiltereditor (siehe Anwenderfiltereditor), welcher über die Schaltfläche Anwenderfiltereditor aufgerufen werden kann, erstellt werden. Die von diesem Werkzeug erstellte Tabelle kann als Datei zur Verwendung in einem Tabellenkalkulationsprogramm gespeichert werden.

Interaktiver Nachkommenbrowser...

Abb. 9.1 Nachkommenbrowser

Zuerst musst du eine Person wählen oder beginnst mit der aktuell aktiven Person.

Wähle aus dem Menü Werkzeuge->Analysieren und Untersuchen->Interaktiver Nachkommenbrowser....

Dieses Werkzeug erzeugt einen Baum mit der aktiven Person als Wurzel. Kinder verzweigen auf die übliche Art von ihren Eltern.

Du kannst die abwärts oder > Schaltflächen klicken um die Knoten auf oder zu zuklappen.

Verwende dieses Werkzeug für einen schnellen Blick auf die Nachkommen einer Person.

Gnome-important.png
Tipp

Doppelt klicken auf einen Knoten öffnet den Person bearbeiten Dialog der das Ansehen und Bearbeiten der Daten der Person ermöglicht.


Die Hilfe Schaltfläche bringt dich auf diese Seite und mit der Schließen Schaltfläche schließt du das Nachkommenbrowser Fenster.

Stammbaumverarbeitung

Dieser Abschnitt enthält Werkzeuge die deine Daten ändern können. Die Werkzeuge aus diesem Abschnitt werden Hauptsächlich dazu verwendet Fehler in den Daten zu finden und zu beheben. Die folgenden Stammbaumverarbeitungswerkzeuge stehen aktuell in Gramps zur Verfügung:

Gramps-notes.png
Hinweis

Die Änderungen werden außer bei den automatischen Fehlerkorrekturen durch das Datenbank überprüfen und reparieren Werkzeug erst nach deinem ausdrücklichen Einverständnis durchgeführt.

Datenbankeigner Informationen bearbeiten

Abb. 4.3 Eignerinformation

Klicken von Werkzeuge-->Datenbankverarbeiung-->Datenbankeigner Informationen bearbeiten öffnet das Datenbankeignereditor Fenster, in das du die benötigten Informationen eingeben kannst.

  • Name:
  • Straße:
  • Lokation:
  • Ort:
  • Bundesland/Kreis:
  • Land:
  • PLZ/Postleitzahl:
  • Telefon:
  • E-mail:

Diese Information ist stammbaumspezifisch und wird verwendet, wenn du deine Daten im GEDCOM Format exportierst.


Informationen aus dem Namen extrahieren

Dieses Werkzeug durchsucht die gesamte Datenbank und versucht Titel und Spitznamen die in dem Vornamenfeld einer Person enthalten sein können zu extrahieren. Wenn irgendeine Information extrahiert werden konnte, werden die Kandidaten für eine Korrektur in einer Tabelle dargestellt. Du kannst dann entscheiden welche wie vorgeschlagen korrigiert werden und welche nicht.

Extrahiere Ortsdaten aus Ortstitel

Ortsdaten extrahieren

Dieses Werkzeug versucht Ort, Staat/Provinz und Postleitzahl aus dem Ortstitel zu extrahieren.

Das Werkzeug arbeitet mit Orten bei denen alle Felder der Hauptlokation leer sind.

Die Beschreibung muss folgenden Kategorien entsprechen:

New York, NY 10000

Nur verfügbar für:

  • USA
  • Kanada
  • Schweden
Stockholm (A)
  • Frankreich
Paris, IDF 75000, FRA oder Paris, ILE DE FRANCE 75000, FRA

Der Dialog ermöglicht dir einzelne Änderungen vorher anzuschauen und zu bestätigen.

Ereignisbeschreibung aus Ereignisdaten extrahieren

Extrahiert Ereignisbeschreibungen aus Ereignisdaten nach folgendem Schema:

{Ereignistyp} von {Familienname}, {Vorname}

Wenn eine Ereignisbeschreibung fehlt, füllt dieses Werkzeug das Feld nach oben genanntem Schema.

Mögliche doppelte Personen finden...

Abb. 4.4 Doppelte Personen

Dieses Werkzeug durchsucht die gesamte Datenbank auf der Suche nach Einträgen die der selben Person entsprechen könnten.

Du kannst auf dieses Werkzeug über Werkzeug->Datenbankverarbeitung...->Mögliche doppelte Personen finden zugreifen.

Zwei Optionen sind verfügbar:

  • Vergleichsschwellwert: wähle zwischen Hoch, Mittel und Niedrig aus dem Aufklappmenü.
  • Optionen: ein Kontrollkästchen aktiviert oder deaktiviert die Verwendung von Soundex Code für mögliche übereinstimmende Personen.

Es gibt nur drei Schaltflächen Hilfe bringt dich auf diese Seite, Abbrechen zum Beenden der Verarbeitung und OK zum Start der Verarbeitung der Daten.

Wenn du auf die OK Schaltfläche klickst, werden die Daten in zwei Durchgängen verarbeitet.

  • Durchgang 1: vorläufige Listen erstellen
  • Durchgang 2: mögliche Übereinstimmungen berechnen.

Es wird ein Fortschrittsbalken angezeigt und abhängig von der Geschwindigkeit deines Rechners und der Anzahl der Personen in deiner Datenbank kann dies eine Weile dauern.

Zum Schluss wird ein Mögliche Zusammenführungen Fenster angezeigt. Dieses Fenster enthält eine Liste mit drei Spalten:

  • Bewertung: dies gibt dir eine Vorstellung von der Ähnlichkeit der beiden Personen. Je höher die Bewertung desto größer ist die Wahrscheinlichkeit, das diese Personen identisch sind.
  • Erste Person
  • Zweite Person

Wenn du eine Zeile auswählst, kannst du die Details mit der Vergleichen Schaltfläche überprüfen oder du kannst die gewählte Zeile doppelklicken.

Das Fenster besitzt drei Schaltflächen: Hilfe bringt dich auf diese Seite, Schließen um das Fenster zuschließen und eine Vergleichen Schaltfläche die ein Personen vergleichen Fenster öffnet, welches in Personen zusammenfassen im Detail beschrieben wurde. Hier kannst du mit den Optionsschaltflächen eine der Personen wählen und eventuell die Zusammenfassen und schließen Schaltfläche verwenden um die Daten zusammenzufassen wenn du herausgefunden hast, das diese Personen identisch sind.

Klicken auf die Abbrechen Schaltfläche bringt dich zurück zu der Liste.

Großschreibung von Familiennamen korrigieren...

Abb. 5.5 Großschreibung korrigieren

Dieses Werkzeug durchsucht die gesamte Datenbank und versucht die Großschreibung von Familiennamen zu korrigieren.

Das Ziel ist es, eine übliche Groß/Kleinschreibung zu erreichen: erste Buchstabe groß und die restlichen Buchstaben des Familiennamens klein. Wenn Abweichungen von dieser Regel festgestellt werden, werden die Kandidaten für die Korrektur in der Tabelle angezeigt.

Du kannst dann entscheiden, welche wie vorgeschlagen korrigiert werden sollen und welche nicht.

Du kannst dieses Werkzeug über Werkzeuge->Stammbaumverarbeitung->Großschreibung von Familiennamen korrigieren... aufrufen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Du kannst wählen zwischen Abbrechen und Mit dem Werkzeug fortfahren.

Wenn es Änderungen in der Großschreibung von Namen gab, wird das Änderungen der Großschreibung Fenster geöffnet. Das Fenster zeigt eine Liste von Familiennamen die Gramps in die korrekte Schreibweise ändern kann. In der Liste siehst du drei Spalten: Auswählen Kontrollkästchen, Ursprünglicher Name und Änderungen der Großschreibung.

Wähle die Namen, die du ändern möchtest dann klicke auf die Änderungen akzeptieren und schließen Schaltfläche. Oder verwende die Abbrechen Schaltfläche um die Änderungen zu verwerfen.

Großschreibung von Vornamen korrigieren...

Diese Option ist eine Werkzeugerweiterung und arbeitet fast identisch zu dem obigen Nachnamen Werkzeug.

Ereignistarten umbenennen

Abb. 4.6 Art ändern

Dieses Werkzeug erlaubt das umbenennen aller Ereignisse mit einem bestimmten Namen in einen neuen Namen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Das Ereignisdaten ändern Fenster wird angezeigt. Dieses Werkzeug ändert alle Ereignisse einer Art in eine andere Art.

  • Ursprüngliche Ereignisart: schreibe in das Textfeld oder verwende das Aufklappmenü um eine originale Ereignisart zu wählen.
  • Neue Ereignisart: Schreibe in das Textfeld (du kannst hier eine völlig neue Art erstellen) oder verwende das Aufklappmenü um eine neue Art zu wählen.

Das Beispiel zeigt das Umbenennen des Geburt Ereignis in Taufe Ereignis.

Zum Abschluss verwende die Abbrechen oder OK Schaltfläche.

Gramps-IDs neu ordnen

Das Werkzeug Gramps-IDs neu ordnen ändert alle Elemente in der Datenbank so das ihre IDs den vorgegebenen Schema in Präferenzen Datenbank IDs entsprechen.

Du kannst diese Vorgaben unter Bearbeiten->Präferenzen... und dann im ID-Formatreiter ändern.

Du kannst dieses Werkzeug über das Menü Werkzeuge->Stammbaumverarbeitung->Gramps-IDs neu ordnen aufrufen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Das Fenster zeigt einen Fortschrittsbalken.

In verschiedenen Schritten werden die folgenden IDs neu geordnet: Neuordnung Personen IDs, Neuordnen Familien IDs, Neuordnen Ereignis IDs, Neuordnen Medionobjekt IDs, Neuordnen Quellen IDs, Neuordnen Orte IDs, Neuordnen Aufbewahrungsorte IDs und zum Schluss Neuordnen Notiz IDs.

In einem nächsten Schritt werden unbenutzte IDs gesucht und zugeteilt.

Gnome-important.png
Anwender IDs

Wenn du deine IDs angepasst hast, werden all diese Änderungen durch die Standardeinstellungen überschrieben. Pass also auf bevor du dieses Werkzeug anwendest!

Ereignisse sortieren

Abb. 4.7 Ereignisse sortieren

Ereignisse im Ereignisreiter vom Personen und Familieneditor erscheinen in keiner bestimmten Reihenfolge außer in der Reihenfolge in der sie hinzugefügt wurden. Der Grund warum die Ereignisse nicht auf eine bestimmte Art wie zum Beispiel nach Datum sortiert werden, ist das ein Ereignis eingeordnet werden kann auch wenn kein genaues Datum oder Reihenfolge bekannt sind. Der Import oder das Zusammenfassen von Daten aus einer externen Quelle kann auch zu zusätzlich hinzugefügten Ereignissen, die außerhalb der Reihenfolge bestehender Ereignisse einer Person oder Familie liegen führen.

Ereignisse können manuell via Drag & Drop oder durch Verwendung der neu-ordnen Schaltflächen im Ereignisse Reiter neu angeordnet werden. So oder so kann ein Ereignis in der Ereignisliste hoch oder runter bewegt werden und Gramps merkt sich die neue Anordnung, wenn die Änderungen gespeichert werden. Die neue Reihenfolge wird überall dort verwendet, wo Ereignisse in Gramps angezeigt werden zum Beispiel in einem Bericht.

Die Reihenfolge von allen Ereignissen in einem Reiter kann auch durch klicken auf den Spaltentitel geändert werden. Zum Beispiel klicken auf den 'Datum' Spaltentitel sortiert alle Ereignisse nach Datum. Jedoch ist diese Art der Sortierung nicht von Dauer beim Schließen des Fensters werden diese Änderungen rückgängig gemacht.

Die Drag & Drop Methode zum Sortieren von Ereignissen ist gut wenn eine kleine Anzahl sortiert wird aber für große Mengen ungeeignet. Das Ereignisse sortieren Werkzeug wurde speziell für diesen Zweck entwickelt, alle Ereignisse in der Datenbank neu sortieren oder nur jene die mit über einen Filter ausgewählten Personen zusammenhängen.

Die erste Option im Ereignisse sortieren Fenster wird verwendet um die Auswahl der Personen, deren Ereignisse sortiert werden, festzulegen. Die erste Möglichkeit in der Liste ist, alle Personen der Datenbank zu sortieren. Alternative Möglichkeiten sind die Sortierung auf Vorfahren oder Nachkommen einer bestimmten Person oder eine Reihe von Personen aus einem vom Anwender erstellten Filter anzuwenden. Nach der Wahl, wen die Sortierung betreffen soll, ist der nächste Schritt festzulegen, wie die Ereignisse sortiert werden sollen. Die erste Möglichkeit ist, sie nach dem Datum zu sortieren,. Das ist wohl die wahrscheinlichste Auswahl, es können aber auch andere Ereigniseigenschaften ausgewählt werden. Die letzten Auswahlen betreffen die Sortierreihenfolge (aufsteigen oder absteigend) und ob die zur Person gehörenden Familienereignisse auch sortiert werden sollen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Datenbank reparieren

Datenbank prüfen und reparieren

Dieses Werkzeug überprüft die Datenbank auf Integritätsprobleme und behebt sie wenn es ihm möglich ist. Im Besonderen sucht es nach:

  • Kaputten Familienverknüpfungen. Dies sind die Fälle in denen ein Personendatensatz auf eine Familie verweist, der Familiendatensatz aber nicht auf die Person verweist und umgekehrt.
  • Fehlende Medienobjekte. Das fehlende Medienobjekt ist das Objekt dessen Datei in der Datenbank verknüpft ist aber nicht existiert. Dies kann passieren wenn eine Datei versehentlich gelöscht, umbenannt oder an einen anderen Ort verschoben wird.
  • Leere Familien. Dies sind die Familieneinträge die keine Verknüpfungen zu Personen als ihre Angehörige besitzt.
  • Elternbeziehung. Dies überprüft alle Familien um sicherzustellen, das Vater und Mutter nicht verwechselt wurden. Der Test überprüft auch ob die Eltern ein unterschiedliches Geschlecht haben. Wenn sie das gleiche Geschlecht haben, wird die Beziehung in "Partner" umbenannt.

Referenzen neu erstellen...

Dieses Werkzeug erstellt die Referenz Abbildtabellen neu (Referenzen Elemente in Editoren).

Neuaufbau sekundäre Indexe...

Dieses Werkzeug erstellt die sekundären Indices neu.

Unbenutzte Objekte entfernen...

Dieses Werkzeug durchsucht deine Datenbank nach nicht verwendeten Informationen und entfernt diese anschließend.

Werkzeuge

Dieser Abschnitt enthält Werkzeuge die es dir ermöglichen einfache Transaktionen mit einem Teil der Daten durchzuführen. Die Ergebnisse können in deiner Datenbank gespeichert werden, sie ändern aber nicht deine bestehenden Daten. Die folgenden Werkzeuge stehen aktuell in Gramps zur Verfügung:

SoundEx-Codes erstellen

Dieses Werkzeug erzeugt Soundex Codes für die Namen der Personen in der Datenbank. Bitte schaue hier um mehr über die Soundex Indizierung zu erfahren.

Soundex was ist das?

Soundex ist der bekannteste Algorithmus für die phonetische Suche welche das indizieren von Worten nach ihrem Klang (im englischen) ermöglicht.

Der Soundex ist ein kodierter Nachnamenindex mehr darauf basierend wie ein Name ausgesprochen wird als darauf wie er buchstabiert wird. Nachnamen die gleich klingen aber unterschiedlich geschrieben werden wie MAYER und MEIER werden gleich kodiert und zusammen abgelegt. Das Soundex Code System wurde entwickelt so das du Nachnamen finden kannst auch wenn sie in verschiedenen Schreibweisen aufgezeichnet wurden.

Zuerst beim US Census von 1880 eingesetzt ist Soundex ein phonetischer Index kein strikt alphabetischer. Its key feature is that it codes surnames (last names) based on the way a name sounds rather than on how it is spelled. It was to help researchers find a surname quickly even though it may have received different spellings.

Those doing census lookups must use the same method to encode surnames as the census takers did when they generated the database.

Um nach einem bestimmten Nachnamen zu suchen musst du erst seinen Code berechnen.

  • Grundregeln zur Soundexkodierung:

Jeder Soundex-Code besteht aus einem Buchstaben gefolgt von drei Ziffern, z. B. W-213. Hat das zu codierende Wort so viele Buchstaben, dass man mehr Ziffern erzeugen könnte, bricht man nach der dritten Ziffer ab. Hat das Wort zu wenige Buchstaben, füllt man die letzten Ziffern mit Nullen auf. Der asiatische Name Lee wird also als L-000 codiert.

Nummer Repräsentiert die Buchstaben
1 B, F, P, V
2 C, G, J, K, Q, S, X, Z
3 D, T
4 L
5 M, N
6 R

Klammert die Buchstaben A, E, I, O, U, H, W, und Y aus.

  • Erweiterte Regeln zur Soundexkodierung:
    • Namen mit doppelten Buchstaben: Wenn ein Nachname doppelte Buchstaben hat, werden sie wie ein Buchstabe behandelt werden. Zum Beispiel:
      • Gutierrez wird kodiert als G-362 (G, 3 für das T, 6 für das erste R, zweite R wird ignoriert, 2 für das Z).
    • Namen mit Buchstaben nacheinander mit dem selben Soundex-Code: Wenn ein Nachname mehrere Buchstaben hintereinander mit dem selben Soundex-Code besitzt, werden diese als ein Buchstabe kodiert. Beispiele:
      • Pfister wird kodiert als P-236 (P, F ignoriert, 2 für das S, 3 für das T, 6 für das R).
      • Jackson wird kodiert als J-250 (J, 2 für das C, K ignoriert, S ignoriert, 5 für das N, 0 hinzugefügt).
      • Tymczak wird kodiert als T-522 (T, 5 für das M, 2 für das C, Z ignoriert, 2 für das K). Da der Vokal "A" das Z und das K trennt, wird das K kodiert.
    • Names with Prefixes: If a surname has a prefix, such as Van, Con, De, Di, La, or Le, code both with and without the prefix because the surname might be listed under either code. Note, however, that Mc and Mac are not considered prefixes.For example, VanDeusen might be coded two ways:V-532 (V, 5 for N, 3 for D, 2 for S) or D-250 (D, 2 for the S, 5 for the N, 0 added).
    • Consonant Separators: If a vowel (A, E, I, O, U) separates two consonants that have the same Soundex code, the consonant to the right of the vowel is coded. Example:Tymczak is coded as T-522 (T, 5 for the M, 2 for the C, Z ignored (see "Side-by-Side" rule above), 2 for the K). Since the vowel "A" separates the Z and K, the K is coded. If "H" or "W" separate two consonants that have the same Soundex code, the consonant to the right of the vowel is not coded. Example: Ashcraft is coded A-261 (A, 2 for the S, C ignored, 6 for the R, 1 for the F). It is not coded A-226.

Verwendung des SoundEx Modul in Gramps

Abb. 4.8 SoundEx Codegenerator

Select via the menu Tools->Utilities->Generate SoundEx Codes... the dialog for the SoundEx code generator window opens. In the Name text field you can type in a name or you could use the down arrow where you can choose a name from the drop down list.

Der Namen den du eingibst, kann ein beliebiger Name sein, er muss nicht in deinem Stammbaum vorkommen.

Das Ergebnis wird automatisch angezeigt z.B.: der Soundex Kode für James ist J520

Es ist eine Hilfe Schaltfläche verfügbar die dich auf diese Seite bringt. Mit der Schließen Schaltfläche (oder drücken von ALT+C) schließt du das SoundEx Code Generator Fenster.


Medienmanager...

Abb. 4.9 Final confirmation window

This tool allows batch operations on media objects stored in GRAMPS. An important distinction must be made between a GRAMPS media object and its file.

The GRAMPS media object is a collection of data about the media object file: its filename and/or path, its description, its ID, notes, source references, etc. These data do not include the file itself.

The files containing image, sound, video, etc. exist separately on your hard drive. These files are not managed by GRAMPS and are not included in the GRAMPS database. The GRAMPS database only stores the path and file names.

This tool allows you to only modify the records within your GRAMPS database. If you want to move or rename the files then you need to do it on your own, outside of GRAMPS. Then you can adjust the paths using this tool so that th media objects store the correct file locations.

If you click the Forward button (or using the keyboard shortcut Alt+F) you will get a window with three radio buttons:

  • Replace substrings in the path: Selecting this radio button will bring up a Replace substring settings window where you can type in any string in the Replace text field and the With text field. At any time you can click on the Cancel button or the Back button. Clicking the Forward button will bring up the Final confirmation window.
  • Convert paths from relative to absolute
  • Convert paths from absolute to relative


Nicht verwandt

Abb. 4.10 Nicht verwandt

This report will find people who are not related to the selected person. You can run this view via the menu Tool->Database Processing-->Not Related....

You will get a Not related to '...' window which shows a list of all the people that are NOT related to the selected person.

This list gives you:

  • Name
  • ID
  • Eltern
  • Marker

With the right arrow button and down arrow button you can collapse or expand the list. Double clicking on a person will bring up the detailed person edit window or family edit window.

If you select a person you can use the Marker text field: 3 choices are possible: blank (you can fill in whatever suits you), TODO, and NotRelated. With the Apply you can apply the selected marker to the person. This marker will then show up in the right hand side column.


Verwandschaftrechner

Dieses Dienstprogramm berechnet und zeigt das Verwandschaftsverhältnis jeder Person zur aktuellen Person.


Die Daten überprüfen...

Abb. 4.11 Die Daten überprüfen...

This utility allows you to verify the database based on the set of criteria specified by you.

For example, you may want to make sure that nobody in your database had children at the age of 98. Based on common sense, such a record would indicate an error. However, it is not a consistency error in the database. Besides, someone might have a child at the age of 98 (although this rarely happens). The Verify tool will display everything that violates your criteria so that you can check whether the record is erroneous or not. The ultimate decision is yours.

Select this via the menu Tools->Utilities->Verify the Data... you will get a Database Verify Tool window. The window has four tabs; General, Women, Men, Families. Those tabs show a list with criteria and a input field where you can alter the criteria value. In the lists below I show some workable values.

  • General:
    • maximum age: 95
    • minimum age to marry: 16
    • maximum age to marry: 60
    • maximum spouses for a person: 4
    • maximum number of consecutive years of widowhood before next marriage: 30
    • maximum age for an unmarried person: 99

There is a check box: estimate missing dates. This causes the tool to accept a baptism date if a birth date is not known, and to accept a burial date if a death date is not known. In addition, starting in gramps version 3.3.0, it also causes the tool to accept "inexact" dates (i.e., any "legal" gramps date which is not a fully-specified one (with an explicit day and month and year)).

  • Frauen:
    • minimum age to bear a child 16
    • maximum age to bear a child 51
    • maximum number of children 15
  • Männer
    • minimum age to father a child 18
    • maximum age to father a child 65
    • maximum number of children 15
  • Familien
    • maximum husband-wife age difference 41
    • maximum number of years between children 11
    • maximum span of years for all children 32

If you are OK with the criteria click the Run button (or hit <Alt+R> and you will be presented with a Database Verification Results window.

Depending on your criteria and your data a list will be shown. Some possibilities of findings are listed below. But there are others.

  • Disconnected individuals (ones with no parent or spouse or child or sibling)
  • old/dead father
  • marriage after death/ before birth
  • large year span for all children
  • early/late marriage
  • young/unborn mother
  • husband and wife with the same surname
  • same sex marriage/ female husband
  • ...

To show how handy this Utility is, here two examples from real data:

The warning showed 'female husband': checking the data I found a family with father : Anna Roelants. Luckily in the Description I read: The marriage of Adam Roelants and Cornelia Crabbe. It was clearly a typo: Anna i.s.o. Adam. Without this Tool it would be very hard to find.
The warning showed 'late marriage': checking the data: male person °1738 female person °1756 : marriage X 1804 [Gregorian Calender] : Everything seemed to be OK: so they (re)married at the age of 66 and 48 years! The warning showed up because the General criteria was set to 60.

On the bottom of the window four check boxes are available to make a selection easier. Those are Mark All, Unmark All, Invert Marks, and Hide Marked.

Double-clicking on a row will give you a possibility to view and or edit the data.

With the Close button (or select the keyboard shortcut Alt+C) you close the Results window.

With the Help button (or select the keyboard shortcut Alt+H) you will get to this page.

Gnome-important.png
Difference between Verify tool and previously described Check tool

The Check tool detects inconsistencies in the database structure. The Verify tool,however, is detecting the records that do not satisfy your particular criteria.


For example, you may want to make sure that nobody in your database had children at the age of 98. Based on common sense, such a record would indicate an error. However, it is not a consistency error in the database. Besides, someone might have a child at the age of 98 (although this rarely happens). The Verify tool will display everything that violates your criteria so that you can check whether the record is erroneous or not. The ultimate decision is yours.

Zurück Index Nächste