Ru:Gramps 3.3 Вики Руководство - Управление Семейными деревьями

From Gramps
Jump to: navigation, search

Теперь перейдем к детальному рассмотрению вопросов повседневного использования GRAMPS. В этой главе мы даём подробный обзор того, как Вы можете управлять Вашими семейными деревьями и обмениваться Вашей информацией с другими людьми, занимающимися генеалогией.

Gnome-important.png Особое уведомление об авторских правах: Все правки на этой странице должны удовлетворять требованиям двух следующих лицензий:

Указанные лицензии позволяют проекту Gramps максимально использовать настоящее вики-руководство в качестве свободного и бесплатного источника информации для будущих версий Gramps. Если Вы не согласны с условиями такого двойного лицензирования размещаемых на страницах вики-руководства материалов, то не редактируйте эту страницу. В этом случае Вы имеете право лишь создавать ссылки на другие страницы настоящего вики-руководства, которые соответствуют требованиям только лицензии GFDL, с использованием внешних ссылок (используя синтаксис: [http://www.gramps-project.org/...]), но не внутренних ссылок.<br\> Также, используйте только принятые соглашения по оформлению текста.


Пред Содержание След



Создание нового Семейного дерева

Рис. 3.2. Начало работы с Семейными деревьями

Новое Семейное дерево создаётся через меню Семейные деревья -> Управление Семейными деревьями или нажатием клавиши Семейные деревья на панели инструментов. Это действие открывает диспетчер Семейных деревьев.

Выберите клавишу Создать и GRAMPS добавит новое Семейное дерево в список семейных деревьев. Для изменения созданного по умолчанию названия "Семейное дерево 1", щелкните на нем и введите новое имя.

Теперь нажмите Загрузить семейное дерево для его открытия.

Открытие Семейного дерева

Чтобы открыть Семейное дерево, либо выберите Семейные деревья -> Управление Семейными деревьями, либо щелкните по кнопке Семейные деревья на панели инструментов.

Откроется окно Управление семейными деревьями и Вы увидите список всех семейных деревьев, известных GRAMPS. Значок в столбце Статус указывает на открытое в настоящее время семейное дерево. Выберите дерево, которое хотите открыть и откройте его, нажав кнопку Загрузить семейное дерево. Также можно дважды щелкнуть на строке с нужным Вам деревом.

Для открытия недавно открывавшегося семейного дерева выберите Семейные деревья -> Открыть недавнее или нажмите на кнопку со стрелкой вниз справа от кнопки Семейные деревья на панели инструментов и выберите семейное дерево из списка.

Если у Вас нет прав на запись для выбранного семейного дерева, то оно будет открыто в режиме чтения. В этом режиме доступен только просмотр информации без возможности внесения изменений в Дерево. Заголовок главного окна программы в этом случае дополняется пометкой только чтение .

Открытие баз данных (файлов) GEDCOM или XML

GRAMPS позволяет Вам открывать из командной строки некоторые типы баз данных, сохраненных не в формате GRAMPS. TODO ссылка на страницу, объясняющую как. К таким базам данных относятся XML и GEDCOM файлы. Однако Вы должны знать, что если база данных XML или GEDCOM относительно велика, то Вы столкнетесь с проблемами производительности и в случае аварийного завершения программы ваша информация может быть повреждена. Поэтому обычно лучше создавать новое семейное дерево GRAMPS (базу данных) и импортировать в нее информацию из ваших баз данных XML/GEDCOM.

Gramps-notes.png
Открытие баз данных

Базы данных XML и GEDCOM хранят всю информацию в оперативной памяти компьютера и не поддерживают индексы. Собственный формат файлов GRAMPS - это база данных, из которой извлекается только необходимая для работы информация. Поэтому при работе с большими семейными деревьями доступ к информации может осуществляться быстрее и более эффективным способом, чем при использовании XML или GEDCOM.

Gnome-important.png
Редактирование GEDCOM

Пожалуйста, помните о том, что во время импорта в GRAMPS некоторая информация, имеющаяся в файле GEDCOM, вероятно, будет утрачена, также как и во время экспорта из GRAMPS в GEDCOM. Открытие и просмотр файлов GEDCOM не вносят в них изменений. Однако если все же какие-либо изменения были внесены в файл GEDCOM и они не были отменены перед завершением работы GRAMPS, то программа сохранит их в файл GEDCOM, что, возможно, приведет к утрате части имевшейся в файле информации.

Удаление Семейного дерева

Выберите семейное дерево, которое нужно удалить, и щелкните по кнопке Удалить.

Это полностью удалит дерево и всю имевшуюся в нем информацию без возможности ее восстановления. Полезно создавать резервные копии Вашей информации в виде экспорта базы данных GRAMPS в файл формата GRAMPS XML и обеспечивать его сохранность.

Переименование Семейного дерева

Вы можете переименовать Семейное дерево (или его архив), выбрав его в списке и нажав Переименовать. Также можно щелкнуть на названии дерева в списке деревьев.

В любом случае, достаточно всего лишь ввести новое название.

Резервное копирование Семейного дерева

  • Самый надежный способ создания резервной копии Семейного дерева GRAMPS - сделать его экспорт в формате GRAMPS XML (или GRAMPS XML Package, чтобы включить в экспорт объекты из Вашей Галереи) и скопировать полученный в результате экспорта файл в безопасное место, лучше всего на другой физический носитель информации.

Backup dialog

Simply select "Make Backup..." from the "Family Trees" menu item.

MakeBackup.png

You can either choose to include the media or not.

Note that this is just a regular XML export, except that no data is filtered out. You can import these as usual with any exported file.

You can also define the pattern for the backup filename by setting the paths.quick-backup-filename in the ~/.gramps/gramps33/gramps.ini key file like the following:

[paths]
quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%(extension)s'

You can use any of the following keywords in the pattern: year, month, day, hour, minutes, seconds, filename, extension.


  • Вы можете использовать архивы для создания снимков Вашего дерева. Такие снимки можно использовать как обычные резервные копии, если Вы хотите попробовать сделать что-нибудь, что позднее захотите отменить. Однако этот способ не заменяет собой резервное копирование, так как он не переживет поломку жесткого диска компьютера и большинство серьезных проблем в его работе.
  • Для опытных пользователей: каждая база данных хранится в своем собственном подкаталоге в ~/.gramps. Резервные копии баз данных можно делать также, вручную сохраняя эти подкаталоги.

Архивирование Семейного дерева

Вы можете легко архивировать семейные деревья при помощи встроенного в GRAMPS GNU Revision Control System или RCS. Для этого необходимо установить данную утилиту на Ваш компьютер.


Перед созданием архива удостоверьтесь, что архивируемое дерево открыто. Затем выделите открытое семейное дерево и нажмите кнопку Архивировать. Архив появится в списке под деревом, для которого он был создан. Архивы можно удалять и переименовывать.

Восстановление архива Семейного дерева

Рис. 3.2 Выбор версии для восстановления

Просто выделите архив, который вы хотите восстановить, и нажмите на кнопку Восстановить.

Рис. 3.3 Восстановленная версия




GRAMPS восстановит архив в новое Семейное дерево, создав его название из сочетания названий исходного дерева и названия архива.

Разблокирование Семейного дерева

Когда GRAMPS открывает дерево, он его блокирует для предотвращения одновременной работы с ним разных пользователей. Вторая копия GRAMPS сможет открыть другое семейное дерево, но ранее открытое дерево будет отображаться в GRAMPS с значком замка, который означает, что Вы не можете его открыть. Закрытие дерева в первой копии GRAMPS позволит открыть его во второй копии GRAMPS.

Если бы было возможно открывать одно и то же Семейное дерево в двух копиях GRAMPS одновременно, то, скорее всего, Ваша информация в дереве была бы повреждена.


В маловероятном случае аварийного завершения работы GRAMPS семейное дерево будет находиться в заблокированном состоянии. Для разблокирования семейного дерева выделите его и нажмите кнопку Разблокировать. Делайте это только тогда, когда Вы уверены, что это дерево не открыто в другой копии GRAMPS.

Восстановление поврежденного Семейного дерева

Рис. 3.4 Восстановление семейного дерева


Если семейное дерево по какой-либо причине повреждено, то в окне управления Семейными деревьями GRAMPS отобразит красный значок ошибки в столбце Статус.

Для того, чтобы GRAMPS попытался устранить повреждения, выберите поврежденное дерево и нажмите кнопку Исправить.

В результате GRAMPS попробует воссоздать Ваше дерево из файлов резервных копий, которые создаются автоматически во время завершения работы программы.

Сохранение изменений в Семейном дереве

GRAMPS сохраняет изменения сразу после их внесения в базу данных. Это значит, что всякий раз, когда Вы нажимаете в GRAMPS OK, Ваши изменения применяются и сохраняются немедленно. В GRAMPS нет отдельной команды "Сохранить".

Вы можете отменить внесенные Вами изменения, выбрав пункт меню Правка ->Откатить . При этом выполняется в пошаговом режиме отмена последних внесенных изменений. Также можно отменить несколько изменений одновременно с помощью диалога История Откатов из меню Правка.

Если Вы хотите вернуть Ваше семейное дерево к исходному состоянию, в котором оно было сразу после его последнего открытия в GRAMPS, выберите пункт меню Семейные деревья ->Отказаться от изменений и выйти . (Эта команда аналогична завершению работы без сохранения изменений в других программах.)

Если Вы хотите сохранить копию Вашего семейного дерева под другим названием, то Вам нужно сделать его экспорт и затем импортировать назад в GRAMPS в виде нового семейного дерева. Лучше всего это делать в формате файлов GRAMPS XML.

Импорт информации

Импорт позволяет внести в базу даннных GRAMPS информацию из других генеалогических программ. В настоящее время GRAMPS может импортировать следующие форматы данных:

GRAMPS XML (расширение файла - .gramps)

GRAMPS package (расширение файла - .gpkg)

GRAMPS CSV Spreadsheet - comma separated values (расширение файла - .csv)

GRAMPS V2.x database (расширение файла - .grdb)

GEDCOM (расширение файла - .ged)

GeneWeb (расширение файла - .gw)

Pro-Gen (расширение файла - .def)

Gramps-notes.png
Импортировать или открывать?

Пожалуйста, имейте в виду, что импорт информации отличается от открытия баз данных. Импорт информации означает ее извлечение из одной базы данных и сохранение ее в базе данных GRAMPS. Открытие баз данных (файлов) подразумевает работу с исходным (открываемым) файлом.

Для выполнения импорта информации выберите Семейные деревья ->Импорт . Откроется окно диалога Импорт базы данных, в котором нужно выбрать импортируемый в GRAMPS файл базы данных. Обратите внимание, что импортировать информацию можно только в уже созданную базу данных GRAMPS, поэтому если Вы хотите перенести в GRAMPS данные из другой программы или из предыдущей версии GRAMPS, то сначала создайте новую пустую базу данных GRAMPS и затем уже импортируйте в нее информацию.

Gnome-important.png
Утрата информации при импорте из баз данных некоторых форматов

Важно отметить, что процесс импорта несовершенен для форматов баз данных GEDCOM и GeneWeb. Существует вероятность того, что часть информации в базах данных этих форматов не будет импортирована в GRAMPS.

GRAMPS XML, пакеты GRAMPS и базы данных GRAMPS 2.x являются "родными" для GRAMPS форматами баз данных. Риск утраты информации при их использовании во время импорта или экспорта информации отсутствует.

  • GRAMPS XML (.gramps): Формат файлов GRAMPS XML является стандартным форматом GRAMPS для обмена информацией и создания резервных копий, а также был стандартным форматом рабочих баз данных предыдущих версий GRAMPS (до версий 2.x). В отличие от формата grdb, GRAMPS XML не зависит от системной архитектуры компьютеров и доступен для обработки в текстовых редакторах. Так как базы данных в этом формате могут также содержать ссылки на нелокальные (внешние) по отношению к базе данных медиа- объекты, которые не сохраняются в формате GRAMPS XML, то при использовании GRAMPS XML невозможно гарантировать полную переносимость баз данных GRAMPS (для обеспечения полной переносимости баз данных GRAMPS, включая медиа- объекты, необходимо использовать формат пакета GRAMPS (.gpkg)). База данных в формате GRAMPS XML создается с помощью пункта меню Семейные деревья ->Экспорт... .
  • пакет GRAMPS (.gpkg): пакет GRAMPS представляет собой сжатый архив, содержащий файл базы данных GRAMPS в формате GRAMPS XML и все медиа- объекты базы данных (изображения, звуковые файлы и т.п.). Так как такой пакет содержит все необходимые медиа- объекты базы данных, этот формат является полностью переносимым. Пакет GRAMPS создается с помощью пункта меню Семейные деревья ->Экспорт... .
  • база данных GRAMPS 2.x (.grdb): До GRAMPS версии 3.1 этот "родной" для GRAMPS формат базы данных представлял собой модифицированную форму базы данных Беркли (Berkeley database (BSDDB)) с модифицированной стуктурой таблиц базы. Этот формат базы данных был двоичным и архитектурно-зависимым. Хотя он был очень быстрым и эффективным, но, в основном, был непереносимым между компьютерами с различными архитектурами (например, i386 и альфа).

Если Вы импортируете информацию из другой базы данных, сохраненной в формате GRAMPS или GRAMPS XML, то прогресс выполнения операции будет отображаться в строке состояния в главном окне GRAMPS.

  • формат GRAMPS CSV Spreadsheet позволяет импортировать и экспортировать часть базы данных GRAMPS в виде простой таблицы. Для получения подробной информации см. CSV Import and Export.

Экспорт информации

Рис.3.4 Помощник Экспорта: выбор формата данных

Экспорт позволяет Вам поделиться любой частью Вашей базы данных с другими исследователями, равно как и перенести вашу информацию на другой компьютер. В настоящее время, GRAMPS может экспортировать информацию в базы данных следующих форматов: GRAMPS XML, GEDCOM, пакет GRAMPS, Web Family Tree, GeneWeb и GRAMPS CSV Spreadsheet.

Gramps-notes.png
Экспорт - это создание копии

Когда Вы экспортируете информацию из GRAMPS, Вы сохраняете копию открытой базы данных. Операция экспорта создает новый файл с копией Вашей информации. Обратите внимание, что открытая в окне GRAMPS база данных НЕ является файлом, создаваемым во время экспорта. Дальнейшее редактирование текущей открытой базы данных не внесет изменения в файл копии базы данных, созданный во время экспорта.

Для экспорта информации выберите пункт меню Семейные деревья ->Экспорт . На экране появится Помощник Экспорта. Его страницы проведут Вас по этапам экспорта: выбор формата базы данных (см. Рис.3.4 ), выбор пути и названия нового файла базы данных, указание специфичных для выбранного формата базы данных параметров. После закрытия Вами последней страницы Помощника Экспорта с подтверждением выбранных Вами параметров экспорта, операция экспорта будет выполнена в соответствии с указанными Вами настройками. Можно в любое время нажать кнопку Назад для пересмотра ранее указанных параметров экспорта, чтобы затем повторить экспорт с новыми параметрами.

Фильтры и неприкосновенность личной жизни

GRAMPS позволяет экспортировать базу данных в общеупотребимые форматы баз данных и предоставляет возможности по тонкой настройке параметров экспорта.

  • Фильтр: Использование фильтра позволяет ограничить количество экспортируемой информации в соответствии с указанными параметрами фильтра.
  • Не включать записи помеченные как личные: Установите этот флажок, чтобы не включать личные записи в файл экспорта.
  • Ограничить данные о ныне живущих людях: Установите этот флажок, чтобы ограничить количество экспортируемой информации, касающейся ныне живущих людей. При этом вся информация о их рождении, смерти, адресах, значимых событиях жизни и т.п. не будет включена в файл экспорта. Включение этого параметра активирует дополнительные настройки ограничения экспортируемой информации для ныне живущих людей. Например, можно присвоить слово "Живущий" имени человека; можно исключить из экспорта заметки; можно исключить источники информации для ныне живущих людей.

Иногда из имеющейся информации не очевидно, жив ли человек на самом деле. GRAMPS использует сложный алгоритм для определения того, является ли человек ныне живущим )). Помните, GRAMPS здесь делает лишь наилучшие возможные предположения и не может всегда угадывать правильно. Пожалуйста, перепроверяйте экспортируемую информацию.

Экспорт в форматы баз данных GRAMPS

Gnome-important.png
Фильтры для защиты личной жизни

Важно проверять в Помощнике Экспорта настройки, призванные охранять тайну Вашей личной жизни. Не включайте фильтры или настройки безопасности личной жизни при создании резервных копий в формате базы данных GRAMPS XML.

  • GRAMPS XML (.gramps): Это стандартный формат для обмена информацией и создания резервных копий (для обеспечения полной переносимости информации, включая медиа- объекты, используйте формат .gpkg). Экспорт в формат GRAMPS XML создает базу данных в одном файле. Так как файлы в формате XML являются текстовыми файлами, то Вы также можете использовать его для того, чтобы изучить хранящуюся информацию в Вашей базе данных. Формат совместим с предыдущими версиями GRAMPS.
  • GRAMPS XML пакет (GRAMPS XML package - .gpkg): Экспорт в формат пакета GRAMPS создает сжатый файл, содержащий базу данных в формате GRAMPS XML и копии всех связанных с базой мультимедиа файлов. Этот формат полезен при переносе базы данных на другой компьютер или для передачи ее другим людям.
  • Экспорт на CD: Экспорт на CD-диск подготавливает Вашу базу данных и копирует все мультимедиа файлы во временный каталог для последующей их записи на CD-диск. Для записи CD-диска необходимо открыть закладку GNOME burn:///, доступную в программе Наутилус: после завершения Экспорта на CD в GRAMPS выберите в меню Наутилуса Переход ->Записать CD . Будет открыт каталог с Вашей базой данных. Для записи ее на CD-диск нажмите на значок CD в панели инструментов Наутилуса или выберите в меню Наутилуса Файл ->Записать на CD .

Если GRAMPS во время экспорта не может найти мультимедиа файлы, то Вы увидите тот же диалог Отсутствуют мультимедиа файлы, который можно увидеть и при экспорте информации в формат GEDCOM.

Экспорт в формат GEDCOM

Рис.3.5.Помощник Экспорта: параметры GEDCOM

GRAMPS может экспортировать базы данных в общепризнанный формат GEDCOM. При этом доступна тонкая настройка параметров экспорта.(см. Рис.3.5.gedcom-export-fig ).

  • Фильтр: Использование фильтра позволяет ограничить количество экспортируемой информации в соответствии с указанными параметрами фильтра.

Не включать записи помеченные как личные: Установите этот флажок, чтобы не включать личные записи в файл экспорта. Ограничить данные о ныне живущих людях: Установите этот флажок, чтобы ограничить количество экспортируемой информации, касающейся ныне живущих людей. При этом вся информация о их рождении, смерти, адресах, значимых событиях жизни и т.п. не будет включена в файл экспорта. Включение этого параметра активирует дополнительные настройки ограничения экспортируемой информации для ныне живущих людей. Например, можно присвоить слово "Живущий" имени человека; можно исключить из экспорта заметки; можно исключить источники информации для ныне живущих людей.

Иногда из имеющейся информации не очевидно, жив ли человек на самом деле. GRAMPS использует сложный алгоритм для определения того, является ли человек ныне живущим )). Помните, GRAMPS здесь делает лишь наилучшие возможные предположения и не может всегда угадывать правильно. Пожалуйста, перепроверяйте экспортируемую информацию.

Экспорт в другие форматы

  • Web Family Tree: Экспорт в формат Web Family Tree создает текстовый файл для использования в программе Web Family Tree. Среди параметров экспорта доступны фильтр и возможность ограничения экспортируемой информации для ныне живущих людей пределами их семейного круга.
  • GeneWeb: Экспорт в формат GeneWeb создает копию информации базы данных в популярном в интернете генеалогическом формате. Подробнее о GeneWeb и формате см. http://cristal.inria.fr/~ddr/GeneWeb/en/.
  • vCalendar и vCard: Экспорт в vCalendar или vCard сохраняет информацию в форматах, используемых многими программами-календарями и адресными книгами (т.е. ПИМ - Персональный Информационный Менеджер).

Перенос баз данных из Gramps 2.2 в Gramps 3

Есть два способа переноса Вашей информации из Gramps версии 2.2 в Gramps версии 3: прямой импорт базы данных версии 2.2 в виде файла grdb или импорт предварительно выгруженной базы данных из Gramps 2.2 в виде файла в формате XML. Вследствие сложности внутреннего устройства хранения информации в базах данных Gramps версии 2.2, экспорт базы данных в XML формат обычно является наиболее удобным и беспроблемным способом переноса информации в Gramps версии 3.

  • Импорт файла базы данных в формате Gramps 2.2 (grdb): В базе данных Gramps версии 2.2 информация хранится в файле с расширением grdb и в одном и более лог-файлах, которые хранятся в подкаталогах в .gramps/env. Для импорта информации из базы данных в формате 2.2 в Gramps 3 создайте новую базу данных и импортируйте информацию из базы данных Gramps 2.2. Важно запустить Gramps 3 от имени того же пользователя системы, под которым ранее запускался Gramps 2.2, для того, чтобы Gramps 3 имел право доступа в каталог .gramps/env с лог-файлами, необходимыми для поддержки работы базы данных, который использовался базой данных Gramps 2.2. Если запускать Gramps 3 от имени другого пользователя или на другом компьютере, то Вам будет необходимо самостоятельно обеспечить выполнение всех необходимых действий по обеспечению доступности .gramps/env и лог-файлов. Если во время импорта базы данных формата Gramps 2.2 появляется сообщение вида "невозможно открыть /tmp/tmpDkI5pO", то это значит, что Gramps 3 не может открыть все файлы, которые входят в состав импортируемой базы данных.
  • Gramps XML: При использовании этого способа сначала необходимо сделать экспорт базы данных из Gramps 2.2 в формат Gramps XML. Будет создан файл с расширением .gramps, содержащий в сжатом виде файл базы данных в формате XML. Этот файл не имеет зависящих от него файлов и может быть перенесен туда, где будет установлен Gramps 3. После завершения экспорта запустите Gramps 3, создайте в нем пустую базу данных и импортируйте в нее файл .gramps.


Пред Содержание След