Gramps 3.2 Wiki Manual - Manage Family Trees

From Gramps
Jump to: navigation, search

Now we turn to a detailed exploration of the day-to-day use of GRAMPS. In this Chapter we give a detailed overview of how you can manage your family trees, as well as share your data with other genealogists.

Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.<br\> Also, only use the known conventions


Previous Index Next



Starting a new Family Tree

Fig. 3.2. Starting Family Trees


To start a new Family Tree, choose Family Trees ->Manage Family Trees or select the Family Trees button from the toolbar. This will open the Family Tree Manager.



Select the New button and GRAMPS will add a new Family Tree entry to the list of Family Trees. To change its name from the default Family Tree 1, click on the name and type in a new name.

Now select Load Family Tree to open the new, empty Family Tree.

Opening a Family Tree

To open a Family Tree, either choose Family Trees ->Manage Family Trees or click the Family Trees button on the Toolbar. The Family Tree Manager will appear and you'll see a list of all the Family Trees known to GRAMPS. An icon will display in the Status column beside any Family Tree that is currently open. Select the tree you want to open, and open it by selecting the Load Family Tree button. Alternatively you can double-click on the desired Tree.

To open a recently accessed Family Tree, choose either Family Trees ->Open Recent or the down arrow next to the Family Trees button and select the Family Tree from the list.

If you do not have "write permissions" for the selected Family Tree, it will be opened in a Read Only mode. In this mode, the data may be viewed, but no changes will be made to the Tree. To indicate this mode, the title of the main window will be appended with (Read Only) text.

Opening a GEDCOM or XML database

GRAMPS allows you to open certain databases that have not been saved in GRAMPS' own file format from the command line, see Command line references. These include XML and GEDCOM databases. But you should be aware that if the XML or GEDCOM database is relatively large, you will encounter performance problems, and in the event of a crash your data can be corrupted. Hence, it is normally better to create a new GRAMPS family tree (database) and import your XML/GEDCOM data into it.

Gramps-notes.png
Opening databases

XML and GEDCOM databases require all data to be held in memory and don't contain indexes. GRAMPS' native format is a database that only reads the data needed. Thus, for a large family tree the data can be accessed quicker and more efficiently by not using XML or GEDCOM.

Gnome-important.png
GEDCOM Editing

Please keep in mind that some information in a GEDCOM file may be lost during import into GRAMPS as well as export back to GEDCOM. Simply opening and viewing the file will not change it. However, if any changes were made and they were not abandoned upon exit, exiting GRAMPS will save the data, with possible data loss.

Deleting a Family Tree

Select the family tree you want removed, and click the Delete button.

This will completely remove the tree, with no possibility to retrieve the data. Consider taking a backup of your data by exporting to the GRAMPS XML format, and storing that file.

Renaming a Family Tree

You can rename a Family Tree (or an archive of it) by selecting the tree you want to rename and clicking Rename. You can also click on the name in the list of trees.

In either case, you just type in the new name to have it take effect.

Backing up a Family Tree

  • The safest way to backup your GRAMPS Family Tree is to export without privacy options and filters to GRAMPS XML format (or GRAMPS Package to include items from your Gallery) and copy the resultant file to a safe place, preferably in a different building.
  • You can use the Archive feature (see next section) to store snapshots of your tree. These snapshots can be used as simple backups, very useful if you want to try something that you might later want to undo. However this method should not be used for standard backups, as it will not survive a hard disk crash or most of the other disasters that can befall a computer.
  • For advanced users: each database is stored in its own subdirectory under ~/.gramps. A manual backup can be made by backing up this directory.

Archiving a Family Tree

You can easily archive and timestamp family trees with GRAMPS built-in use of GNU Revision Control System or RCS. For this to be possible this utility must be installed on your computer.

To make an archive :

  1. load your family tree.
  2. click on the Family Trees button (it has the gramps logo and displays Manage databases when you hover over it).
  3. click on the family tree you've just loaded: the Archive button should appear.
  4. click on Archive and you will be asked for an archive name.

After archiving, the list of family trees will now show your original family tree with a right-pointing triangle on its left.

  • Click on the triangle to display the archive name.(Click again to collapse the archive list).

Archives can be deleted, renamed and Extracted.


If you click on an archive, the Extract button becomes visible. Click on this to obtain the extracted archive. It will appear in the family tree list as <name of original tree>:<name of archive> and is now an independent family tree. This can be a useful way of preserving an archive, because archives disappear if the originating tree is deleted; and they are not incorporated into a Portable XML export of the tree.

Extracting a Family Tree Archive

Fig. 3.2 Selecting a version to extract

Simply highlight the archive you want to restore, and select the Extract button.

Fig. 3.3 Extracted version




GRAMPS will transfer the archive into a new Family Tree. The Family Tree name is based on the original name and the archive name (see also Archiving a Family Tree).


Unlocking a Family Tree

When GRAMPS opens a tree, it locks the tree, preventing you or anyone else opening it at the same time. A second copy of GRAMPS will be able to open another family tree, but the tree already open will appear with the lock icon, indicating you cannot open it. Closing the tree in the first copy of GRAMPS will make it available to be opened in the second copy.

If you could open the same Family Tree in two GRAMPS at once, it is likely your data would be damaged.

In the unlikely event of a crash of GRAMPS, the family tree will be left in a locked state. To unlock the tree, select the locked family tree, and click the Unlock button that will be available. Only do this if you are sure no other copy of GRAMPS is using this family tree.

Repairing a damaged Family Tree

Fig. 3.4 Repairing a Family Tree




Should your Family Tree become damaged or corrupted in some way, GRAMPS' Family Tree Manager will display a red Error icon in the Status column.

To tell GRAMPS to attempt to repair the damage, select the Tree and then click the Repair button.

This will attempt to rebuild your tree from the backup files that are automatically created on exit.

Saving changes to your Family Tree

GRAMPS saves your changes as soon as you apply them. This means, for example, that any time you click OK when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command.

You can undo changes you've made by selecting Edit ->Undo . If you select this command repeatedly, your most recent changes will be undone one at a time. To roll back multiple commands at a time, you can using the Undo History dialog available from the Edit menu.

If you want to return your Family Tree to the way it was when you opened it, select Family Trees ->Abandon changes and quit . (This is just like quitting without saving in other programs.)

If you would like to save a copy of your Family Tree under a different name, you will need to export it and then import it into a new Family Tree. The GRAMPS XML database format is recommended for this purpose.

Importing data

Importing allows you to bring data from other genealogy programs into a GRAMPS database. Currently, GRAMPS can import data from the following formats:

  • GRAMPS XML (.gramps file extension)
  • GRAMPS package (.gpkg file extension)
  • GRAMPS CSV Spreadsheet - comma separated values (.csv file extension)
  • GRAMPS V2.x database (.grdb file extension)
  • GEDCOM (.ged file extension)
  • GeneWeb (.gw file extension)
Gramps-notes.png
Importing vs. opening

Please recognize that importing a database is different from opening a database. When you import, you are actually bringing data from one database into a GRAMPS database. When you open a file, you are editing your original file.

To import data, select Family Trees ->Import . The Import database dialog will open, asking you to specify the file you wish to import. Note that you can only import data into an existing database so if you are transferring all your data from another program or from an older version of GRAMPS, then first create a new empty database and then import the data into it.

Gnome-important.png
Data loss with some formats

It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databases. There is a chance that some of the data in these databases will not be imported into GRAMPS.

Gnome-important.png
Order "up side down" Events generated under other programs

Gramps provides an help for ordering events according to your preferences. See Sort Events tool.


The GRAMPS XML, GRAMPS package and GRAMPS V2.x database are all native GRAMPS formats. There is no risk of information loss when importing from or exporting to these formats.

  • GRAMPS XML (.gramps): The GRAMPS XML file is the standard GRAMPS data-exchange and backups format, and was also the default working-database format for older (pre 2.x) versions of GRAMPS. Unlike the grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable (for full portability including media objects the GRAMPS package (.gpkg) should be used). The GRAMPS XML database is created by exporting ( Family Trees ->Export... ) to that format.
  • GRAMPS package (.gpkg): The GRAMPS package is a compressed archive containing the GRAMPS XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The GRAMPS package is created by exporting ( Family Trees ->Export... ) data in that format.
  • GRAMPS V2.x database (.grdb): Prior to Version 3.2, this native GRAMPS database format was a specific form of Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).

If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress of the operation in the progress bar of GRAMPS' main window.

The GRAMPS CSV Spreadsheet format allows importing and exporting of a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information.

Gnome-important.png
Caution in Importing XML

If you need to combine two family trees (for instance, in rebuilding a database), it is important that you do not import XML data into the same family tree data. For example, if a person in your existing family tree is also in an XML import, then you may end up with mixed up data. Imports do not "merge" data (except for the Spreadsheet Import). As the current version 3.2.2 stands, you could corrupt your database irretrievably if you XML import into duplicated data. If you must import duplicated data, you could export the data in, say, the GEDCOM format and import that; however, GEDCOM does not faithfully export all GRAMPS data. Additionally, you would need to edit your data to remove any duplicates, and re-add some information which may have not been included in the GEDCOM export (such as media). However, importing from the GEDCOM format will not corrupt duplicated data as does the XML import will on duplicated data. If you want to merge basic genealogy data, consider the Spreadsheet Export/Import.

Exporting data

Fig. 3.5 Export assistant: format selection

Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.

Gramps-notes.png
Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your GRAMPS window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

To export data, choose Family Trees ->Export . This will bring up the Export assistant. Its pages will guide you through the format selection (see Fig.3.4 ), file selection, and format specific export options. After a final confirmation page, the export will be performed according to the choices you have made. At any time, you can click the Back button and revise any selection, and then go forward to redo the export.

Filters and privacy

GRAMPS allows you to export a database into common file formats. It provides options that allow you to fine tune your export.

  • Filters on People and Notes: Filters allow you to export a limited amount of data, based on the criteria you select.
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word Living for the first name (see your settings); you can exclude notes; and you can exclude sources for living people.
  • Do not include not related records: Check this box to prevent not related records from being included in the exported file.

Sometimes, it is not always obvious from the data if someone is actually alive. GRAMPS uses an advanced algorithm to try to determine if a person could still be alive. Remember, GRAMPS is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

Export into GRAMPS formats

Gnome-important.png
Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for GRAMPS XML backups.

  • GRAMPS XML database export (.gramps): This format is the standard format for data-exchange and backups (see the related .gpkg format below for full portability including media objects). Exporting into GRAMPS XML format will produce a portable database. As XML is a text-based human-readable format, you may also use it to take a look at your data. This format is compatible with the previous versions of GRAMPS.
  • GRAMPS package export (.gpkg): Exporting to the GRAMPS package format will create a compressed file that contains the GRAMPS XML database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Exporting into the GEDCOM format

Fig. 3.6 Export assistant: GEDCOM options

GRAMPS allows you to export a database into the common GEDCOM format. It provides options that allow you to fine tune your export (see Fig.3.5.gedcom-export-fig ).

  • Filters on People and Notes: Filters allow you to export a limited amount of data, based on the criteria you select.
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word Living for the first name (see your settings); you can exclude notes; and you can exclude sources for living people.
  • Do not include not related records: Check this box to prevent not related records from being included in the exported file.

Export into other formats

  • Web Family Tree: Exporting to Web Family Tree will create a text file that can be used by the Web Family Tree program. Export options include filter selection and the ability to limit data on living people to that of their family ties.
  • vCalendar and vCard: Exporting to vCalendar or vCard will save information in a format used in many calendaring and addressbook applications, sometimes called PIM for Personal Information Manager.
  • GRAMPS CSV Spreadsheet format: Allows exporting (and importing) a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information. Also, see Export Display .

Moving 2.2 databases to Gramps 3

There are two ways of moving your Gramps data from version 2.2 to version 3; either directly importing your version 2.2 grdb file or by exporting to XML format first. Because of complexity in the way that version 2.2 stores data, exporting to XML is usually the most convenient and problem free way of moving your data to version 3.

  • Import 2.2 grdb file: In a Gramps 2.2 database, your data is stored in a grdb file along with one or more log files that are kept in directories found in the .gramps/env directory. To import your 2.2 data directly into Gramps 3, create a new database and select the option to import a Gramps 2.2 database. You need to make sure that you are running Gramps 3 from the same user you used to run Gramps 2.2 so that it has access to the same .gramps/env directory containing the log files that supplement your database. If you are running Gramps 3 from a different user or on another machine you need to make provisions to make the same .gramps/env directory and log files available. If you get an error saying "/tmp/tmpDkI5pO could not be opened" or something similar when attempt to import your database then it means that Gramps 3 cannot see all of the files that constitute your database.
  • Gramps XML: With this approach firstly start up Gramps 2.2 and export your database to the Gramps XML format. The XML file is actually compressed and contained in a .gramps file. This file is portable, has no other dependent files and can be moved to wherever you have Gramps 3 installed. Next, start Gramps 3 and create an empty database using the Family Tree Manager and import the .gramps file.


Previous Index Next