Fr:Manuel wiki pour Gramps 3.1 - Fenêtre principale

From Gramps
Jump to: navigation, search
Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.<br\> Also, only use the known conventions


Précédent Index Suivant


Introduction

Quand vous ouvrez une base de données (existante ou non), la fenêtre suivante s'affiche :

Fig. 1.1 La fenêtre principale de GRAMPS

La fenêtre de GRAMPS contient les éléments suivants:

  • Barre de menu : elle est placée tout en haut de la fenêtre (juste à droite du titre de la fenêtre) et donne accès à toutes les fonctions de GRAMPS à travers ses menus.
  • Barre d'outils : elle est placée juste sous la barre de menu. Elle donne accès aux fonctions les plus utilisées de GRAMPS. Sa présentation peut être changée dans le menu Edition -> Préférences . Vous pouvez également la cacher entièrement en allant sous Affichage -> Barre d'outils .
  • Barre de progression : elle se trouve en bas, à gauche de la fenêtre principale de GRAMPS. Elle montre l'avancement des opérations longues comme le chargement ou l'écriture de grosses bases de données, l'importation ou l'exportation d'autres formats ou la génération de sites web, etc. Quand vous ne réalisez pas ce types d'opérations, la barre de progression n'est pas affichée.
  • Barre d'état : elle est placée à droite de la barre de progression, tout en bas de la fenêtre de GRAMPS. Elle informe sur le travail en cours avec GRAMPS et affiche une information contextuelle sur les items sélectionnés.
  • L'aire d'affichage : le plus grand espace dans la fenêtre de GRAMPS est la zone d'affichage. Elle montre une vue des données généalogiques, selon le type d'affichage en cours.

Les différentes vues

L'information généalogique est très large et peut être extrêmement détaillée. L'afficher est un challenge que GRAMPS accepte en divisant et organisant l'information à travers une série de vues. Chaque vue affiche une partie de l'information totale, sélectionnée selon une catégorie particulière. Cela deviendra plus clair quand nous aurons exploré les différentes vues, listées ci-dessous:

  • La vue Gramplets : affiche les différents gramplets, petits widgets pouvant aider à la recherche généalogique.
  • La vue Individus : affiche une liste d'individus dans l'arbre familial.
  • La vue Relations : affiche les relations entre la personne active et les autre individus. Ceci inclut les parent, conjoints, et enfants.
  • La vue Familles : affiche la liste de famille dans l'arbre familial
  • La vue Sources : affiche une liste de sources dans l'arbre familal
  • La vue Lieux : affiche une liste de lieux dans l'arbre familal
  • La vue Media :affiche une liste d'objets media dans l'arbre familal
  • La vue Dépôts : affiche une liste de dépôts dans l'arbre familal
  • La vue Notes : affiche une liste de notes dans l'arbre familal

Avant de se lancer dans la description de chaque vue, commençons par expliquer comment changer de vue.

Changer de vue et de modes

Fig. 3.1. mode standard
Fig. 3.2. mode onglets

Comme mentioné précédement il y a 11 vues différentes. En plus, il y a deux modes de vision. Si vous voyez les icônes dans la barre latérale à gauche de la fenêtre, vous êtes dans le mode standard.

Si au contraire vous voyez une suite d' "onglets" (notés Individus, Relations, Famille, Arbre généalogique, Evénements, Sources, Lieux, Media, Dépôts et Notes) au-dessus de la fenête, alors vous êtes en mode onglet. Vous pouvez passer d'une vue à l'autre en sélectionnant Affichage -> Barre latérale depuis le menu.

Pour changer de vue dans la barre latérale, cliquez sur l'icône de la vue que vous désirez.

Pour changer de vue en mode onglet, cliquez sur l'onglet désiré.


Vue Gramplets

Fig. 4.1 Vue Gramplets

La vue gramplets affiche un nombre de widgets, appelés Gramplets, ils peuvent vous aider dans vos recherches. Deux gramplets sont affichés au démarrage (Bienvenu et Principaux noms de famille), avec un clic-droit dans la vue, vous aurez la possibilité d'en ajouter d'autres à travers une liste de choix.

Pour plus d'information détaillée voir Gramplets. Voici un aperçu des fonctionnalités.

  • Arbre : affiche un arbre généalogique compressé des ascendants directs. Ainsi qu'un résumé par génération. Cliquez sur les liens pour voir les entrées correspondantes.
  • Âge à la date : ce gramplet calcule les âges des individus de votre arbre familial, en vie à cette date donnée.
  • À faire : dans cette fenêtre vous pouvez ajouter votre liste "À faire", ou toute autre note. Plusieurs gramplets "À faire" peuvent vous organiser dans vos recherches.
  • Bienvenu : est une fenêtre Bienvenu dans GRAMPS
  • Calendrier : affiche les événements pour ces jours/mois et années.
  • Noms de famille : affiche votre top 10 des noms de famille
  • Nuage de noms : affiche une fenêtre avec une nuée de noms de famille les plus courants.
  • Statistiques : affiche une fenêtre avec un résumé de l'Arbre Familial : nombre d'individus, hommes et femmes, nombre de familles, media, etc.

Vue Individus

Fig. 5.1 L'éditeur de colonnes

La vue Individus liste les individus stockés dans la base de données. Vous noterez qu'ils sont groupés d'après leur nom de famille. A gauche de chaque nom de famille il y a une flèche ou d'autres indicateurs. Cliquez sur l'un d'eux pour déployer l'ensemble de la liste d'individus partageant ce nom. Cliquez une nouvelle fois sur l'indicateur compactera la liste et n'affichera que le nom de famille.

Par défaut, la vue Individus, affiche plusieurs colonnes d'information sur chaque personne. Vous pouvez ajouter ou enlever des colonnes de l'affichage en appelant l'Éditeur de colonnes (Édition -> Éditeur de colonnes) puis en cochant et décochant dans la liste. Vous pouvez également changer la position des colonnes dans la vue individus avec un glisser-déposer vers la nouvelle position dans l'éditeur. Une fois que vous avez réalisé les changements désirés, cliquez sur Valider pour quitter l'éditeur et voir vos changements dans la vue individus.

Gramps-notes.png
Éditeur de colonnes

L'éditeur de colonnes est disponible dans toutes les vues et fonctionne de la même façon dans chacune d'elles.

Filtres

Fig. 5.1.1 Filtrage activé

Les bases de données généalogiques peuvent contenir des informations sur de nombreux individus, familles, lieux, et objets. Comme les longues énumérations sont suceptibles d'être une longue liste difficile à traiter mentalement. GRAMPS vous propose deux moyens différents pour contrôler cette situation en vous permettant de filtrer une liste pour une gestion adaptée.

Ces méthodes sont Rechercher et Filtrer.

Rechercher cherchera le texte affiché dans une liste, alors que les filtres affichent les individus dont les données correspondent au critère du filtre. Rechercher est une méthode simple mais rapide pour rechercher dans l'affichage des colonnes. Taper les caractères dans la boîte de recherche et cliquer sur le bouton Rechercher affichera seulement les lignes où le texte est présent.

Alternativement, vous pouvez activer la barre de filtre, laquelle s'affichera à la droite de l'affichage. Quand la barre de filtre est affichée, la barre de recherche ne l'est plus. La barre de filtre vous permet de construire un ensemble de règles de filtrage interactives pouvant être appliquées à l'affichage. Le filtre est basé sur les règles et les données, pas sur l'affichage à l'écran.

Gnome-important.png
Rechercher ou filtrer

Rechercher trouve les correspondances exactes. Si la date affichée est "1 Jan 2000" une recherche sur "1/1/2000" va échouer, mais un filtrage sur "1/1/2000" trouvera.


Quand GRAMPS ouvre une base de données, aucun filtrage n'est actif. Dans la vue des individus, tout le monde est listé par défaut.


Vue Relations

La vue Relations affiche toutes les relations autour de la personne active (la personne sélectionnée). En particulier, cette vue montre ses parents, ses frères et soeurs, ses conjoints et ses enfants.

La vue Relations est adaptée pour permettre une navigation rapide. Vous pouvez changer rapidement de peronne active simplement en cliquant sur le nom de n'importe laquelle des personnes listées. Chaque nom est un lien hypertexte, similaire à une page internet.

Fig. 6.1 Vue Relations
Fig. 6.2 Vue Relations

La vue Relations affiche ces différentes sections:

  • La personne active : en haut de l'écran, est affiché le nom, l'id, les informations de naissance et de décès ainsi que le calcul de l'âge de la personne active. Si une photo de l'individu est disponible, elle est affichée sur le côté droit. A côté du nom de la personne il y a un symbole indiquant le genre, et un bouton Éditer. Cliquer sur le bouton Éditer vous permettra d'éditer toutes les informations de l'individu dans un dialogue d'Édition de l'individu.
  • Les parents : la section suivante, la section parents, affiche les familles dont la personne est l'enfant. Puisqu'il est possible pour une personne d'avoir plusieurs couple de parents, il est possible d'avoir plusieurs sections parents.

Vous pouvez contrôler le nombre d'information à afficher en utilisant le menu Affichage. Ce menu d'affichage vous permet de montrer ou de cacher les détails (naissance et information de décès) et de montrer ou de cacher les frères et soeurs. A côté de chaque individu listé il y a un bouton Éditer, lequel vous permettra d'éditer tous les détails d'une personne particulière.

Vous pouvez ajouter un nouveau couple de parents soit en sélectionnant Ajouter des parents ou Partager des parents. Le bouton Ajouter des parents produira une nouvelle famille dont la personne active sera listée comme enfant. Le bouton Partager des parents vous permettra de choisir à partir d'une liste de familles existantes, puis d'ajouter la personne comme enfant de la famille.

Vous pouvez éditer des parents existants en sélectionnant le bouton Éditer à côté des parents. Si vous sélectionnez Supprimer à côté du couple de parents, alors la personne active ne sera plus l'enfant des parents. Ce bouton ne supprime pas la relation entre les parents.

Gnome-important.png
Attention

Si vous n'êtes pas prudent, il est possible de créer plusieurs familles avec le même individu. C'est rarement ce que prévoyait l'utilisateur. Si vous essayez d'ajouter une nouvelle famille ayant les mêmes parents qu'une famille existante, GRAMPS affichera une fenêtre de mise en garde. Si vous voyez ce message, vous devriez sans doute annuler l'édition, et utiliser le bouton Sélectionner pour choisir cette famille existante.

  • La famille : cette section est similaire à la section parents, laquelle affiche les familles où la personne active est un parent. Parce qu'il est possible d'avoir de multiples familles, il est possible d'avoir de multiples sections famille. Chaque section famille affiche le conjoint et les enfants.
Gramps-notes.png
Conjoints

On utilise le terme de conjoint pour plus de simplicité. Notez, que conjoint peut désigner un partenaire sous le même toit, en union civile, ou toute autre relations similaires entre deux individus. Les relations entre conjoints ne sont pas nécessairement entre un homme et une femme.

Fig. 6.3 Réorganiser une relation

Vous pouvez ajouter une famille en sélectionnant Ajouter un conjoint dans la barre d'outils. Ceci créera une nouvelle famille dont la personne active sera le père ou la mère.

Sélectionner le bouton Éditer à côté du conjoint vous permettra d'éditer la famille affichée. Cliquer sur le bouton Supprimer enlèvera la personne de la famille affichée.

Gnome-important.png
Enlever une personne

Enlever un individu de la famille ne supprime pas la famille. La personne n'est plus la mère ou le père, mais les autres relations au sein de la famille existent toujours.

Gramps-notes.png
Note

Nous utilisons le terme de mère et père pour plus de simplicité. Même s'il n'y a pas d'enfant dans la famille, cette terminologie est utilisée. Dans le cas où nous avons des relations homme/homme ou femme/femme, le père et la mère doivent être considérés comme des noms de convenance.

Vous pouvez réorganiser les parents et les conjoints en sélectionnant Réorganiser. Cette option ne sera active que si plus d'un couple de parents ou plus d'un conjoint existe pour la personne active. Sélectionner ce bouton affichera un dialogue qui vous permettra de réorganiser les familles.


Vue Familles

Fig. 7.1 Vue Familles

La vue Familles affiche une liste de toutes les familles de la base de données. Depuis cette vue, vous pourrez ajouter, éditer, ou supprimer les familles. Par défaut GRAMPS affiche id, père, mère, et relations. Les enfants ne pouvant pas être affichés à l'écran dans cette vue.

Gnome-important.png
Le bouton Supprimer

Contrairement à la vue Relations, cliquer sur le bouton supprimer dans cette vue supprimera cette famille de la base de données. Tous les individus resteront, mais les relations entre eux seront supprimés.


Vue Arbre généalogique

Fig 8.1 Vue arbre généalogique

La vue arbre généalogique affiche un arbre familial des ascendants de l'individu actif. Elle affiche 5 générations, selon la taille de la fenêtre. Chaque individu est delimité par un rectangle avec son nom, ses informations de naissance et décès, et une image si elle existe. Deux lignes partent de ce rectangle. En haut, l'une se dirige vers le père et en bas la deuxième vers la mère. Les lignes complètes représentent les relations de naissance, les lignes en pointillé les autres relations, tel que l'adoption, la tutelle, etc.

A la gauche de la personne active il y a une flèche. Si l'individu actif a des enfants, cliquer sur le bouton va déployer une liste de ses enfants. En sélectionner un le rendra actif.

Fig 8.2 Menu enfants

L'apparence du menu des enfants est différent par le fait qu'il prolonge les branches.

Les enfants qui ne sont pas parents vont apparaître grisés et en italique, alors que ceux qui sont parents seront en gras. Si l'individu actif n'a qu'un seul enfant, aucun menu ne sera affiché (puisqu'il n'y a qu'un seul choix) et l'enfant sera la personne active si l'on clique sur la flèche.

Deux flèches vers la droite sont affichées dans la partie droite de la fenêtre. Celle du haut prend comme personne active le père de la personne active. Celle du bas met comme nouvelle personne active la mère de la personne active. Comme précédemment, tout l'affichage change alors en conséquence.

Fig 8.3 Contexte personnel

Un clic-droit sur n'importe lequel des individus dans la vue arbre généalogique appelera le "menu contextuel".

Entre les autres items, le menu contextuel a des sous-menus notés Conjoints, Frères et soeurs, Enfants, Parents de l'individu.

Les sous-menu "grisés" indiquent l'absence de données dans la catégorie. Similaire au menu des enfants, ce dernier et le menu de parents se distinguent par des lignes continus aux extrémités.


Vue Événements

Une nouveauté dans la version 2.2 fut l'ajout d'une vue Événements.

Les événements peuvent être partagés entre plusieurs individus et familles. La vue des événéments liste tous les événéments enregistrés dans la base de données.

La vue affichée par défaut est Description, ID, Type, Date, Lieu et Cause de l'événement.

Fig. 9.1 Vue Événements
Gnome-important.png
Signification de la description de l'événement

Comme les événements peuvent être partagés, vous pouvez prendre un peu de votre temps pour définir une description unique et significative. Ceci vous aidera pour trouver correctement l'événement que vous souhaitez partager.

La liste des événements peut être triée de plusieurs façons, en cliquant sur l'en-tête de la colonne. Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant. Le dialogue Éditeur de colonnes peut être utilisé pour ajouter, enlever ou changer l'affichage des colonnes.


Vue Sources

Fig. 10.1 vue Sources

La vue Sources liste les sources stockées dans la base de données.

Ceci peut inclure différents documents (naissance, décès, actes de mariage, etc.), livres, films, journaux - tout ce qui peut vous aider dans vos recherches. GRAMPS vous offre une option pour définir une source pour chaque événement (naissances, décès, mariages, etc.). La vue des sources utilise un Titre, ID, et un Auteur pour cette source, ainsi que toute information de Publication pouvant y être associée.

La liste des sources peut être triée en cliquant sur l'en-tête de la colonne.

Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant. Le dialogue Éditeur de colonnes peut être utilisé pour enlever ou changer l'affichage des colonnes.


Vue Lieux

Fig. 11.1 Vue Lieux

La vue des lieux liste les endroits géographiques où ont lieu les événements. Cela peut être les lieux de naissance, décès, mariage des individus ainsi que leur adresse, leur travail ou toute autre référence géographique. La vue des lieux affiche les lieux et avec le Nom, ID, Paroisse, Ville, Département et Pays. Toutes ces colonnes peuvent être triées en cliquant sur leur en-tête.

Cliquer une fois va trier dans le sens croissant, re-cliquer va trier dans le sens décroissant. Le dialogue Éditeur de colonnes peut être utilisé pour ajouter, enlever ou changer l'affichage des colonnes.

Si un lieu est activé, vous pouvez sélectionner le bouton OpenStreet Maps ou Google Maps pour essayer d'afficher le lieu dans votre navigateur internet.

Votre navigateur internet va utiliser la longitude et la latitude du lieu pour afficher l'emplacement via le site internet de votre choix. Cette fonction est limitée, et peut ne pas produire le résultat désiré.


Vue Media

Fig. 12.1 Vue Media

La vue des media liste les objets media utilisés dans la base de données.

Les objets media ne sont que des fichiers reliés aux données généalogiques.

Techniquement, chaque fichier peut être stocké comme objet media.

La plupart du temps, ce sont des images, des fichiers sons, des animations, etc. Les en-têtes sont Nom, ID, Type, et Chemin de l'objet media.

Le dialogue Éditeur de colonnes peut être utilisé pour réarranger l'affichage des colonnes, lesquelles obéissent aux règles de tri. La partie haute de la fenêtre GRAMPS affiche un aperçu (si il existe un objet media) et les informations sur ce dernier.


Vue Dépôts

Fig. 13.1 Vue Dépôts

La version 2.2 a ajouté le support des dépôts.

Un dépôt peut être défini comme une collection de sources.

Chaque source dans la base de données peut référencer un dépôt (comme une bibliothèque) dans lequel elle est présente. Le fonctionnement de la vue dépôts est similaire à celui des autres vues.


Vue Notes

Fig. 14.1 Vue Notes

La version 3.1 liste les notes. Une note est un texte brut, stockée comme les autres objets.

Le fonctionnement des notes est similaire aux autres vues. La vue liste toutes les Notes stockées dans un Arbre familial. Sous Édition->Éditeur de colonnes vous pouvez changer l'affichage des colonnes. Les possibilités sont Aperçu, ID, Type et Marqueur.

Le Type peut être : Note de l'événement, Transcription, Note de l'adresse, Texte de la source, Note du lieu.

Cliquer deux fois sur la note dans la liste va ouvrir une fenêtre dans laquelle vous pourrez éditer cette dernière. Vous pouvez changer les polices de caractère, leurs couleurs, ainsi que la couleur de fond. Un vérificateur d'orthographe est disponible en anglais et dans votre langue de système.

Vue Cartes (option)

La vue Cartes (ou GeoView) nécessite une connexion internet active et un kit HTML (webkit ou gtkmozembed).

Cette vue est expérimentale et doit permettre d'afficher ses données sur des cartes disponibles via internet.

Fig. 15.1 Vue HTML
Fig. 15.2 Vue Cartes




Précédent Index Suivant