Gramps on the Eee

From Gramps
(Redirected from GRAMPS on the Eee)
Jump to: navigation, search

GRAMPS on the ASUS Eee PC

GRAMPS 3.x

The version of Xandros that comes installed on the Eee is quite old and would require upgrades to various underlying software to allow GRAMPS 3 to run. Changing the whole operating system might seem extreme but is actually not difficult and brings a whole host of other advantages.

Ubuntu packages of the latest version of GRAMPS are always available from the GRAMPS website. Ubuntu furthermore is the most popular linux distro at the moment, so it makes sense to just install Ubuntu on the Eee, and then install the GRAMPS 3.x package for Ubuntu.

If you go that road, backup all your data you created in Xandros linux, then proceed to overwrite the base Xandros linux with Easy Peasy or Eeebuntu, both Ubuntu derivatives for the Eee.

If all goes well you have after this a good working Eee, with security updates, and access to the largest repositories of linux software. Download the ubuntu package of GRAMPS from sourceforge to a directory, open the directory in your file browser, right click on the icon of the package to open the context menu, and choose the install action to install GRAMPS (root password will be asked).

Improvements have been made in GRAMPS 3.1 that will allow GRAMPS to work better with the small screen size of the Eee. Some of the larger windows have been re-designed to take up less screen space and other improvements allow windows to resize smaller. Also GRAMPS 3.1 can work in full screen mode too.

User accounts

Installing Gramps 2.2.x on the ASUS Eee PC 4G under Xandros

First follow the suggestions in http://wiki.eeeuser.com/howto:beginners_guide

  • get connected
  • back-up simpleui.rc
  • install SublimePorte's Launcher Tools
  • download Derred's pimpmyeee.sh - remember where you saved it
    • run it - sh path to file/pimpmyee.sh
    • chose 4 to enable extra software repositories and create a preferences file reducing the liklihood of updating files from the wrong repository.

Then, in a terminal window, sudo apt-get install gramps to install the Gramps 2.2.3-1 package. This is not the latest version but it will install the all necessary support software along with Gramps. I did it from a terminal because I couldn't access the OK button in Synaptic's pop-up window.[*]

Use SublimePorte's Launch Tools to add a Gramps lanucher to the simple interface tab of your choice. The path to the executable is: /usr/bin/gramps.

If you would like to run the latest stable Gramps download gramps_2.2.10-1_all.deb package from http://packages.debian.org/squeeze/gramps . Navigate to the downloaded file, right click it and chose Install DEB file. This will update the version that you previously installed. This WILL NOT substitute for apt-get's package installation.

Dave Rowell - 1 Mar 2008

[*] Hold down Alt++Mouse and you can move the window up with the mouse so that the buttons become accessible. Too late for you now but good to know. Richard Hollands - 16 June 2008