2021-12-04 - Sorry the Gramps wiki is currently being upgraded to a newer software version. Please check back after the 2021-12-08.

Difference between revisions of "Fr:Vue Graphique"

From Gramps
Jump to: navigation, search
(Graph View partiel)
(Graph View partiel)
Line 22: Line 22:
  
 
=== Barre d'outils de Vue Graphique ===
 
=== Barre d'outils de Vue Graphique ===
 +
[[File:Graphviewboutonsant_51_fr.png|600px|thumb|right|La barre d'outils]]
 +
 +
Vue Graphique a sa propre petite barre d'outils avec les options suivantes (de gauche à droite) :
 +
 +
* {{man button|'''+'''(Zoom avant)}} bouton - Zoom avant.
 +
* {{man button|'''-'''(Zoom arrière)}} bouton - Zoom arrière.
 +
* {{man button|'''1'''(Zoom vers l’original)}} bouton pour ramener la vue à sa taille originale.
 +
* {{man button|'''☐'''(Zoom vers l'affichage adapté)}} bouton pour ajuster l'arbre affiché à la taille de l'affichage.
 +
* {{man button|'''⏎''' (Aller à la personne active)}}
 +
* {{man button|Aller vers le signet}} bouton - Centrer la vue sur le signet sélectionné - affiche "Bookmarks for current graph:" (qui sont affichés) et "Other Bookmarks:" (qui ne seront pas affichés) - avec deux boutons pour "Add active person", ajouter la personne active aux signets et "Édition" des signets.
 +
* {{man button|🔍 Search...}} Rechercher- en tapant, s'affiche au fur et à mesure, une boite avec "Persons from current graph:" (individus qui sont affichés) et "Other persons from the database:" (d'autres individus qui ne sont pas affichés) ainsi que les signets enregistrés. Le raccourci <Ctrl+F> active le champ de recherche.
 +
* {{man button|Générations}} - réglage du nombre de générations affichées, pour les ascendants 3 générations par défaut et pour les descendants 10 générations par défaut.
 +
* {{man button|Spacing}} - modifie l'espace vertical (5 par défaut) et horizontal (2 par défaut) entre les générations.
 +
 +
Dans la barre d'outils principale, vous avez aussi :
 +
* {{man button|'''⎙'''(Imprimante)}} bouton qui n'imprime pas mais permet d'enregistrer l'affichage graphique en cours sous un format de fichier par points pour une impression ultérieure. L'enregistrement est fait en fichier .gv ou  svg. Sélectionnez plutôt un format .gv.
 +
* {{man button|[[File:Gramps-config.png|20px]](Configurer les vue active)}} bouton avec les options décrites plus bas.
 +
 +
=== Options de configuration ===
 +
Select {{man menu|View > Configure...}} from the menu to change the settings on the following four tabs:
 +
 +
*Layout
 +
**{{checkbox|1}}{{man label|Show images}} (checkbox selected by default)
 +
**{{checkbox|1}}{{man label|Show avatars}} (checkbox selected by default)
 +
**{{checkbox|1}}{{man label|Highlight the home person}} (checkbox selected by default)
 +
**{{checkbox|0}}{{man label|Show full dates}} (checkbox unselected by default)
 +
**{{checkbox|0}}{{man label|Show places}} (checkbox unselected by default)
 +
**{{checkbox|0}}{{man label|Show tags}} (checkbox unselected by default)
 +
 +
*Themes
 +
**{{man label|Person theme:}}
 +
***'''Default'''
 +
*** Image on right side
 +
*** Image on left side
 +
**{{man label|Path color to home person:}} '''<code>#000000</code>'''(default)
 +
**{{man label|Font:}} - shows the default that can be changed by selecting from the
 +
*** {{man label|Pick a Font}} dialog
 +
 +
*Animation
 +
**{{checkbox|1}}{{man label|Show animation}} (checkbox selected by default)
 +
***{{man label|Animation speed (1..5 and 5 is the slower):}} (default is 3)
 +
***{{man label|Animation count (0..8 use 0 to turn off):}} (default is 4)
 +
 +
*Search
 +
**{{checkbox|1}}{{man label|Search in all database}}(checkbox selected by default)
 +
**{{checkbox|1}}{{man label|Show person image}}(checkbox selected by default)
 +
**{{checkbox|1}}{{man label|Show bookmarked first}}(checkbox selected by default)
 +
 +
===Context menus===
 +
Graph view has three [https://en.wikipedia.org/wiki/Context_menu context menus] that allow the following
 +
{{-}}
 +
====Empty section====
 +
* Right click an empty section of the view to choose the type of connecting {{man label|Lines type}}, options are ''Direct'', ''Curves'', ''Ortho''
 +
[[File:Graph View Empty context menu.png|thumb|450px|Right click menu shown when selecting an empty section of the chart.]]
 +
{{-}}
 +
====Person node====
 +
* Right click a person (node) to do the following.
 +
[[File:Graph View person context menu.png|thumb|450px|Right click menu shown when selecting a Person on the chart.]]
 +
{{-}}
 +
====Family node====
 +
* Right click a family (node) to add or delete a spouse or child.
 +
[[File:Graph View family context menu.png|thumb|450px|Right click menu shown when selecting a Family (node) on the chart.]]
 +
{{-}}
 +
 +
== Prerequisites ==
 +
Before '''Graph View''' can be used you will need the following installed:
 +
* Graphviz. If you can run the Gramps [[Gramps_{{Version manual}}_Wiki_Manual_-_Reports_-_part_5|Graph reports]] then you already have this installed.
 +
* [http://live.gnome.org/PyGoocanvas PyGoocanvas] (Gramps3) or [https://wiki.gnome.org/Projects/GObjectIntrospection Goocanvas2 or gir1.2-goocanvas] (Gramps4)
 +
* [http://live.gnome.org/GooCanvas Goocanvas]
 +
 +
=== Linux ===
 +
 +
All of these should be available in common Linux distributions.
 +
 +
For example,
 +
 +
;Debian
 +
Packages Goocanvas/PyGoocanvas as libgoocanvas3 and python-pygoocanvas.
 +
 +
Note: As of May 2020 the required packages for Debian Testing are gir1.2-goocanvas-2.0 and libgoocanvas-2.0-9 from the official repositories.
 +
 +
;Linux Mint Debian Edition (LMDE)
 +
These packages are not available for Linux Mint Debian Edition (LMDE). You can download these as .deb files from [https://launchpad.net/ubuntu/+source/goocanvas-2.0/2.0.2-0ubuntu2 launchpad] and install them in the usual manner. You need the Binary packages shown at the bottom of that pages, except for the development libraries.
 +
 +
Please make sure to download these for the proper architecture, like amd64 for 64-bit PCs (Intel included).
 +
 +
;Opensuse
 +
You may need to install <i>typelib-1_0-GooCanvas-2_0</i> as mentioned in issue {{bug|8076}}.
 +
 +
== Issues ==
 +
You can see related issues at [https://gramps-project.org/bugs/search.php?tag_string=GraphView bug tracker].
 +
* {{bug|8054#c44291}} - print options.
 +
* {{bug|9806}} - Subprocess on [GraphView] can generate a memory issue
 +
* {{bug|8054}} - Better label positioning in Graphview
 +
* [https://github.com/gramps-project/addons-source/pull/459 &#91;GraphView&#93; add custom avatars #459]<br />[https://gramps.discourse.group/t/customizable-avatars-for-graphview/696 Themed avatar discussion]

Revision as of 21:33, 4 June 2021

Error creating thumbnail: Unable to save thumbnail to destination
Ceci est un greffon d'origine tierce

Utilisez-le avec prudence sur des données sauvegardées et aidez à l'améliorer en rapportant vos commentaires ou les problèmes rencontrés à l'auteur ou sur le bug tracker.

Ce greffon a des pré-requis, notamment l'installation de GooCanvas.

Error creating thumbnail: Unable to save thumbnail to destination
Plus il y a d'individus dans l'arbre familial

plus le graphique mettra de temps à s'afficher : 7000 individus peut prendre 10 minutes.

Error creating thumbnail: Unable to save thumbnail to destination
Certaines options ne sont apparues qu'avec la nouvelle version 5.x.x de Gramps

Error creating thumbnail: Unable to save thumbnail to destination
Greffon Graph View (pour Gramps 5.1.3)

GraphView, en français Vue Graphique est un greffon tiers qui permet de disposer d'une vue supplémentaire de votre arbre familial dans la catégorie Graphique de Gramps. Il permet l'affichage d'un arbre interactif des ascendants et des descendants dans lequel on peut naviguer, la personne active étant le point de départ. Un click sur un individu de l'arbre en fait la nouvelle personne active et redessine l'arbre autour de cet individu.

Utilisation

Dans la Catégorie Graphiques, cliquez sur le bouton Vue Graphique ou sélectionnez le menu Affichage > Vue Graphique.

De façon générale, Vue Graphique est :

  • interactif : le graphique se redessine en réponse aux modifications d'individu ou de famille.
  • la personne active est contrastée.
  • cliquer sur un individu va redessiner l'arbre centré sur cet individu.
  • cliquer sur la personne active va afficher la famille des parents de la personne active permettant ainsi d'afficher les générations précédentes.
  • un clic-droit sur un individu ou un nœud familial ouvre la fenêtre de modification de l'individu ou de la famille correspondante.
  • capable d'afficher l'arbre des ascendants ET des descendants (ajustable dans la barre d'outils du greffon)

Barre d'outils de Vue Graphique

Error creating thumbnail: Unable to save thumbnail to destination
La barre d'outils

Vue Graphique a sa propre petite barre d'outils avec les options suivantes (de gauche à droite) :

  • +(Zoom avant) bouton - Zoom avant.
  • -(Zoom arrière) bouton - Zoom arrière.
  • 1(Zoom vers l’original) bouton pour ramener la vue à sa taille originale.
  • (Zoom vers l'affichage adapté) bouton pour ajuster l'arbre affiché à la taille de l'affichage.
  • (Aller à la personne active)
  • Aller vers le signet bouton - Centrer la vue sur le signet sélectionné - affiche "Bookmarks for current graph:" (qui sont affichés) et "Other Bookmarks:" (qui ne seront pas affichés) - avec deux boutons pour "Add active person", ajouter la personne active aux signets et "Édition" des signets.
  • 🔍 Search... Rechercher- en tapant, s'affiche au fur et à mesure, une boite avec "Persons from current graph:" (individus qui sont affichés) et "Other persons from the database:" (d'autres individus qui ne sont pas affichés) ainsi que les signets enregistrés. Le raccourci <Ctrl+F> active le champ de recherche.
  • Générations - réglage du nombre de générations affichées, pour les ascendants 3 générations par défaut et pour les descendants 10 générations par défaut.
  • Spacing - modifie l'espace vertical (5 par défaut) et horizontal (2 par défaut) entre les générations.

Dans la barre d'outils principale, vous avez aussi :

  • (Imprimante) bouton qui n'imprime pas mais permet d'enregistrer l'affichage graphique en cours sous un format de fichier par points pour une impression ultérieure. L'enregistrement est fait en fichier .gv ou svg. Sélectionnez plutôt un format .gv.
  • Error creating thumbnail: Unable to save thumbnail to destination
    (Configurer les vue active)
    bouton avec les options décrites plus bas.

Options de configuration

Select View > Configure... from the menu to change the settings on the following four tabs:

  • Layout
    • Show images (checkbox selected by default)
    • Show avatars (checkbox selected by default)
    • Highlight the home person (checkbox selected by default)
    • Show full dates (checkbox unselected by default)
    • Show places (checkbox unselected by default)
    • Show tags (checkbox unselected by default)
  • Themes
    • Person theme:
      • Default
      • Image on right side
      • Image on left side
    • Path color to home person: #000000(default)
    • Font: - shows the default that can be changed by selecting from the
      • Pick a Font dialog
  • Animation
    • Show animation (checkbox selected by default)
      • Animation speed (1..5 and 5 is the slower): (default is 3)
      • Animation count (0..8 use 0 to turn off): (default is 4)
  • Search
    • Search in all database(checkbox selected by default)
    • Show person image(checkbox selected by default)
    • Show bookmarked first(checkbox selected by default)

Context menus

Graph view has three context menus that allow the following

Empty section

  • Right click an empty section of the view to choose the type of connecting Lines type, options are Direct, Curves, Ortho
Error creating thumbnail: Unable to save thumbnail to destination
Right click menu shown when selecting an empty section of the chart.


Person node

  • Right click a person (node) to do the following.
Error creating thumbnail: Unable to save thumbnail to destination
Right click menu shown when selecting a Person on the chart.


Family node

  • Right click a family (node) to add or delete a spouse or child.
Error creating thumbnail: Unable to save thumbnail to destination
Right click menu shown when selecting a Family (node) on the chart.


Prerequisites

Before Graph View can be used you will need the following installed:

Linux

All of these should be available in common Linux distributions.

For example,

Debian

Packages Goocanvas/PyGoocanvas as libgoocanvas3 and python-pygoocanvas.

Note: As of May 2020 the required packages for Debian Testing are gir1.2-goocanvas-2.0 and libgoocanvas-2.0-9 from the official repositories.

Linux Mint Debian Edition (LMDE)

These packages are not available for Linux Mint Debian Edition (LMDE). You can download these as .deb files from launchpad and install them in the usual manner. You need the Binary packages shown at the bottom of that pages, except for the development libraries.

Please make sure to download these for the proper architecture, like amd64 for 64-bit PCs (Intel included).

Opensuse

You may need to install typelib-1_0-GooCanvas-2_0 as mentioned in issue 8076.

Issues

You can see related issues at bug tracker.