Fr:Manuel wiki pour Gramps 3.4 - Navigation

From Gramps
Jump to: navigation, search

Tant qu'une base de données est ouverte, GRAMPS reste centré sur une personne désignée comme la personne active. Vous pouvez modifier ou voir les données de cette personne et de sa famille proche. La navigation dans la base de données consiste en fait à changer de personne active. Cette section décrit tous les moyens pour parcourir la base de données en utilisant l'interface utilisateur riche et pratique de GRAMPS. Toutes les méthodes produisent finalement le même résultat mais le choix du meilleur outil à utiliser dépend de ce que vous faites.

Gnome-important.png Notice spéciale pour le droit à la copie: Toutes les éditions de cette page ont besoin des deux différentes licences pour la réutilisation:

Ces licences permettent au projet Gramps de maximiser l'utilisation du manuel wiki en tant que contenu libre pour les prochaines versions de Gramps. Si vous êtes en désaccord avec cette double licence, alors n'éditez pas cette page. Vous pouvez ajouter un lien pour cette page, ce dernier sera sous licence GFDL via le lien externe (utilisant la syntaxe: [http://www.gramps-project.org/...]), et non via les liens internes.<br\> Utilisez également les conventions typographiques.


Précédent Index Suivant


Utilisation de la catégorie Individus

La méthode la plus intuitive pour sélectionner l'individu actif est d'utiliser la catégorie Individus. Quand vous êtes dans cette vue, simplement sélectionnez le nom de la personne désirée depuis la liste en cliquant dessus. Cet individu devient alors actif. La barre de statut est mise à jour en tenant compte de ce changement de personne active.

Utilisation de la catégorie Familles

Quand vous êtes dans la catégorie Relations, vous pouvez facilement naviguer d'une personne à une autre dans la famille affichée comme suit :

Pour définir comme actif le conjoint de la personne sélectionnée, cliquez sur la flèche double à la droite de la personne. Puis, un clic droit sur le conjoint et sélectionnez Définir le conjoint comme la personne active depuis le menu contextuel.

Pour définir les parents actuellement sélectionnés comme famille active (le père comme individu actif et son conjoint), cliquez sur la flèche à la droite de l'individu actif. Ou, un clic-droit sur l'individu actif et sélectionnez Définir les parents comme famille active dans le menu contextuel.

Pour définir le conjoint actuellement sélectionné comme famille active (le père comme individu actif et la mère étant son conjoint), cliquez sur la flèche à la droite du conjoint et sélectionnez Définir les parents comme famille active depuis le menu contextuel.

Pour définir l'enfant actuellement sélectionné comme individu actif, cliquez sur la flèche à la droite de l'enfant. Ou, un clic-droit sur l'enfant et sélectionnez Définir l'enfant comme individu actif depuis le menu contextuel.

En plus de tout cela, GRAMPS propose de nombreux raccourcis-claviers pour la navigation. Lisez la documentation de référence de ces commandes dans raccourcis clavier.

Utilisation de la catégorie Lignée

La catégorie Lignée permet également de vous déplacer à travers votre arbre familial. Le bénéfice de cette méthode étant que vous pouvez voir plus qu'une génération dans votre arbre. Par ailleurs, vous pouvez sauter directement d'un petit-fils à son grand-père sans passer par les générations intermédiaires.

Notez qu'après avoir changé de personne active dans les vues Lignée, l'affichage est mis à jour pour montrer cinq générations, au-dessus de la nouvelle personne active. Dans les vues Lignée, vous pouvez facilement naviguer entre les personnes affichées comme suit :

Pour définir une personne affichée comme étant la personne active, un clic-droit sur la boîte correspondante et choisissez la première entrée dans le menu contextuel.

Pour désigner comme personne active un enfant de la personne active en cours (la racine à gauche de l'arbre), cliquez sur la flèche vers la gauche située à gauche de sa boîte. Si cette personne a plusieurs enfants, le bouton se développe en un menu déroulant proposant le choix entre les enfants.

Pour déplacer le graphique d'une génération en arrière, cliquez sur le bouton correspondant à droite de l'arbre. Le bouton du haut fera suivre la lignée paternelle alors que le bouton du bas fera suivre la lignée maternelle.

Cliquer sur un de ces boutons est rigoureusement équivalent à double cliquer sur les lignes issues de la personne active (racine de l'arbre affiché) vers ses parents.

Vous pouvez également accéder aux conjoints, enfants, ou parents de chaque individus. Il vous suffit de cliquer sur le bouton droit de la souris, pour appeler un menu. Ce menu liste les conjoints, les enfants et les parents de l'individu actif.

Gnome-important.png
Avantages du menu contextuel

Un accès direct aux conjoints et frères ou soeurs. Des listes complètes de tous les acteurs de toutes les catégories, pas seulement les individus préférés.


Utilisation des Gramplets

Fig. Relatives gramplet into People View

Quelques Gramplets fournissent un support des liens uri/url (souvent la couleur par défaut des liens internet).

On Barres latérale et inférieure vous pouvez activer des gramplets comme:

pour avoir la possibilité de naviguer avec les proches, les descendants et les ascendants de la personne active dans la vue.

En cliquant sur un lien vous allez changer la personne active.



Choisir le de Cujus, la souche

Une personne seulement peut être sélectionnée comme souche, de Cujus. C'est l'affaire d'un seul clic dans n'importe quelle vue.

Pour choisir le de Cujus, sélectionnez d'abord ,par le moyen de votre choix, la personne voulue comme personne active. Faites Édition->Définir comme la souche. À partir de ce moment, vous pouvez retourner à cette personne simplement en cliquant sur l'icône Souche dans la barre d'outils. Vous pouvez également choisir Aller à->Souche dans le menu ou choisir l'élément Souche dans n'importe quel menu contextuel accessible par un clic droit de la souris.

Utilisation de l'historique

GRAMPS dispose aussi d'un ensemble puissant d'outils reposant sur l'historique de navigation. Ces outils ressemblent à ceux des navigateur sur le Web. Ceci comprend les éléments Précédent et Suivant disponibles dans le menu Aller à les menus contextuels et les boutons de la barre d'outils. Il y a aussi la liste des sélections récentes accessible par le menu Aller à qui vous permet d'aller directement vers n'importe quelle personne sélectionnée récemment. Enfin, cliquer avec le bouton droit de la souris sur les boutons < Précédent et Suivant > de la barre d'outils active un menu déroulant avec les personnes correspondantes dans l'historique. Sélectionnez l'une d'elles et vous irez directement vers elle.

Signets

Fig. 8.6.1 Organiser vos signets

Similaire à l'action de définir la souche, vous pouvez marquer d'autres individus dans la base de données pour une navigation simplifiée. Pour marquer un individu, tout d'abord allez sur cet individu, puis choisissez Signets -> Ajouter un signet. Pour aller vers cette personne n'importe quand, choisissez Signets -> nom de l'individu.

Vous pouvez gérer vos signets en choisissant Signets ->Gérer les signets .... Ceci lance la fenêtre de Gestion des signets avec la liste des signets et les contrôle pour la modifier.

Utilisez les boutons Haut et Bas pour changer la séquence de la liste. Utilisez le bouton Enlever pour supprimer le signet. L'Aide vous conduit vers cette page, et vous pouvez fermer la fenêtre Édition des signets avec le bouton Fermer.

Les individus marqués peuvent être sélectionnés dans les vues individus, comme expliqué plus haut, mais également depuis les catégories relations, familles et lignée.

Sur les mêmes bases vous pouvez également marquer : les événements, sources, citations, lieux, media, dépôts, et notes.

Trouver les enregistrements

Fig. 8.7.1 Rechercher une donnée

Pour trouver un enregistrement dans la base de données, tout d'abord choisissez la vue désirée pour votre enregistrement : individus, sources, lieux, media, dépôts, notes. Puis commencez par saisir le nom ou le titre que vous recherchez. Vous pouvez également utiliser Ctrl+F pour ouvrir le mode recherche, mais commencer par saisir avec le clavier doit être suffisant.

Les premières lettres que vous tapez sont recherchées.

Gnome-important.png
Trouver les individus

Pour des recherches d'individus plus complexes vous pouvez utiliser les filtres.


Activez le contrôle de filtre par Affichage -> Barre latérale, sélectionnez le filtre désiré, et cliquez sur Appliquer. Voir les filtres pour plus de détails.

Utiliser le presse-papiers

Fig. 8.8.1 Presse-papiers

Cet outil fournit une note temporaire pour stocker des enregistrements de la base de données et une réutilisation plus facile. En résumé, il s'agit de la fonction glisser-déposer étendue aux objets et autres types d'enregistrements présents dans Gramps.

Gnome-important.png
Le presse-papiers est optimisé avec la technique du glisser-déposer

Pour utiliser le presse-papiers, soit choisissez Édition -> Presse-papiers soit cliquez sur le bouton Presse-papiers de la barre d'outils.


On peut stocker des adresses, des attributs (personnel et famille), des événements (personnel et famille), des noms, les objets media, des références, des citations, des URLs, et naturellement l'information textuelle des notes et des commentaires. Pour stocker, glisser simplement le texte dans la boîte de dialogue. Pour réutiliser l'information, glisser-la à l'endroit correspondant, par exemple onglet d'adresse, onglet d'attribut, etc...

Gnome-important.png
Astuce

Quelques objets montrent l'icône de lien du côté gauche. Ceci indique que déposer un tel choix produira une référence à un objet existant, pour ne pas copier l'objet lui-même. Par exemple, le fichier medium ne sera pas reproduit. Au lieu de cela, la référence sera faite à un objet existant, qui aura comme conséquence l'entrée locale.


Gnome-important.png
Astuce

Le stockage est persistant dans une session simple de Gramps. La fermeture de la fenêtre ne perdra pas les informations stockées. Seulement, sortir de Gramps .

Le raccourci clavier est maintenant Ctrl+B. Pour une application comme Gramps, le presse-papiers est important.

Juste un exemple : vous trouvez l'acte de naissance d'un individu. Ce dernier mentionne également les témoins. Et cet acte est une source avec ses informations. La meilleure solution étant d'ouvrir le presse-papiers et de glisser la source. Puis d'utiliser la fonction glisser-déposer chaque fois que vous en avez besoin.

Vous finalisez les informations dans l'Éditeur d'individu. Glissez ces informations dans le presse-papiers. Vous ajoutez deux individus comme témoins (si ils ne sont pas déjà présents dans la base de données). Un simple glisser-déposer depuis l'information sur la naissance dans l'événement du témoin. Vous changez le rôle en témoin de la naissance. Vous pouvez reproduire ce schéma pour d'autres témoins.

Ceci vous évite de longues saisies et erreurs possibles.

Gestionnaire de fenêtres

Fig. 8.9.1 Gestionnaire de fenêtres

Le menu Fenêtres -> fournit un accès rapide aux fenêtres ouvertes.


Les étiquettes

Allez dans le Menu -> Édition -> Étiquette.

Fig. 6.5 Tag actions from Edit menu


Ou cliquez sur le bouton Étiquette dans la barre d'outils.

Fig. 6.6 Tag actions from Toolbar button


Le concept

Fig. 6.7 Organiser les étiquettes
  • Pour les personnes utilisant gmail ou thunderbird, les étiquettes sont familières.

Au lieu de classer les messages dans des répertoires Outlook (Windows) ou Evolution (Linux), ils sont classés en assignant des étiquettes. Ainsi au lieu d'avoir une classification disjointe N:1 (un message ne peut être que dans 1 répertoire, un répertoire peut contenir plusieurs messages), dans gmail et thunderbird il y a une classifiaction N:M (un message peut avoir plusieurs étiquettes, et une étiquette peut être appliquée sur plusieurs messages électroniques).

Dans la même logique, quand vous avez un grand arbre, vous pouvez avoir besoin de générer des sous-ensembles de l'arbre, et ces derniers peuvent se superposer. Par exemple, avec les sous-ensembles de votre côté paternel et maternel, un sous-ensemble qui a émigré vers les États-Unis, ou des personnes connues dans votre arbe.

L'idée est d'assigner des étiquettes différentes pour chaque groupes : PÈRE, MÈRE, USA et CONNU(E) par exemple.

Différences avec les marqueurs

Fig. 6.8 Sélection de l'étiquette depuis l'éditeur d'individu
  • Les Marqueurs sont comme les répertoires pour les messages électroniques. Un individu ne peut avoir qu'un seul marqueur. Les étiquettes sont plutôt des marqueurs à valeurs multiples.


Étiquettes et filtres

  • Les étiquettes et filtres créent tous les deux des groupe dans l'arbre. Néanmoins il y a des différences dans l'utilisation.
Fig. 6.9 Un filtre sur l'étiquette depuis la barre latérale de filtrage

Spécifier votre branche paternelle en utilisant les filtres est relativement simple; il existe déjà des filtres basés sur cette logique pour le faire. D'un autre côté, spécifier les individus qui ont émigré vers les États-Unis est plus compliqué, tout comme pour les personnes connues il est impossible d'avoir une règle logique. Les étiquettes sont bien plus pratiques dans ce cas là.

Par ailleurs les filtres ont l'avantage d'être dynamique. Si vous avez un nouvel ancêtre de votre père dans votre base de données, il sera automatiquement ajouté au filtrage.

À l'inverse, les étiquettes sont statiques. Lorsque l'on ajoute une personne connue dans l'arbre, vous avez explicitement besoin étiqueter avec l'étiquette CONNU(E).

  • Le premier objet qui vient à l'esprit est l'individu, et c'est également là où les étiquettes sont les plus utilisées. Néanmoins, on peut ajouter des étiquettes à d'autres objets:
   Lieux: par exemple "Lieux à visiter",
   Source: par exemple "Sources en allemand",
   Notes: par exemple "Notes en cours", ou "Notes en allemand",
   Media: par exemple "Image appartenant à l'oncle Alfred". 

Les étiquettes ont été ajoutées aux Individus, Familles, Notes et Media.


Opérations avec les étiquettes

Voici quelques idées et opérations possibles avec les étiquettes.

Filtrage

L'utilisation la plus évidente est celui du filtrage.

Étiqueter une sélection d'objets

Fig. 6.10 Assigne une étiquette à une sélection multiple

Du fait de la nature statique des étiquettes, il est parfois utile d'ajouter une étiquette à une sélection d'objets via Ctrl, Maj, Ctrl+A. Par exemple on devrait être capable de sélectionner un nombre de personnes dans la vue Individus, puis d'ajouter une étiquette nouvelle ou existante.


La colonne étiquettes

Fig. 6.8 Colonne Étiquettes et lignes colorées

Il est pratique d'avoir une colonne Tags dans les vues des objets qui supportent les étiquettes. Le nom des étiquettes se présente comme une liste séparée par des virgules.


Précédent Index Suivant