Fr:Manuel wiki pour Gramps 3.0 - Outils

From Gramps
Jump to: navigation, search

Ce chapitre décrit les différents outils disponibles dans GRAMPS.

Les outils de GRAMPS vous permettent d'exécuter divers types d'analyses de vos données généalogiques. Typiquement, les outils ne produisent pas le rendement sous la forme de liste imprimée ou de dossiers. Au lieu de cela, ils produisent le rendement d'écran immédiatement disponible pour le chercheur. Cependant vous pouvez enregistrer le résultat d'un outil dans un fichier. Les outils sont une des grandes forces de GRAMPS par rapport à la plupart des logiciels de généalogie.

Les outils peuvent être consultés par le menu en choisissant Outils --> Section Outil --> Outil Particulier. Vous pouvez aussi avoir accès à la liste complète des outils avec leur brève description en utilisant l'icône Outils de la barre d'outils.

Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.<br\> Also, only use the known conventions



Analyse et exploration

Ce groupe comprend les outils qui analysent et explorent la base de données sans la modifier. Les outils suivants sont actuellement disponibles dans GRAMPS :

Comparaison d'événements individuels

Cet outil compare des événements dans un ensemble de personnes. Les personnes à prendre en compte sont choisies par des filtres personnalisés. Ces filtres sont créés avec l'éditeur de filtres personnalisés (voir tools-util-cfe). La liste d'événements produite peut être enregistrée comme tableau.

Navigation parmi les descendants

Fig. z.z Navigateur de descendants

Tout d'abord, vous devez sélectionner un individu ou démarrer avec la personne active.

Cliquez sur le menu Outils --> Analyse et Exploration --> Navigateur interactif des descendants.

Cet outil construit un arbre descendant de la personne active. Les enfants sont les branches de l'arbre. Utiliser cet outil pour avoir une vue rapide sur la descendance d'une personne.

Vous pouvez cliquer sur les boutons flèche vers en bas ou > pour dérouler ou compresser les noeuds.

Utilisez cet outil pour un aperçu rapide des descendants d'un individu.

Gnome-important.png
Astuce

Double-cliquer sur les noeuds de l'arbre, ouvre la fenêtre Edition de l'individu, permettant de voir ou modifier les données individuelles.


Le bouton Aide vous conduira vers cette page et avec le bouton Fermer, vous fermez la fenêtre du navigateur des descendants.

Modification de la base de données

Cette section décrit des outils qui peuvent modifier la base de données. Les modifications ne seront faites qu'avec votre accord explicite. Les outils décrits ici servent principalement à trouver et corriger les erreurs dans les données. Les outils suivants sont actuellement disponibles dans GRAMPS :

Gramps-notes.png
Note

Les modifications seront seulement effectuées avec votre consentement explicite, excepté pour les contrôles et les outils réparation de la base de données.

Calcul des dates estimées

Fig. z.z Calcul des dates

Cliquer sur Outils --> Modification de la base de données --> Calcul des dates estimées..., ouvre la fenêtre de Mise en garde sur les modifications :

Gnome-important.png
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

Cliquez sur Annuler ou Valider.

Il vous sera présenté la fenêtre Calcul des dates estimées. Elle se décompose en trois parties.

  • Options :
    • Filtre : dans le menu déroulant vous pouvez choisir quelle partie de la base de données sera utilisée : vous pouvez également sélectionner toute la base de données, les descendants de l'individu, les familles descendantes de l'individu, les personnes ayant un ascendant commun avec l'individu, ou tout autre filtre personnalisé (voir filtres personnalisés).
    • Filtre sur l'individu : la personne active est présente dans le champ, mais cliquer sur le bouton Sélectionner un autre individu ouvrira la fenêtre de sélection de l'individu. Elle liste les personnes pouvant être sélectionnée. Utilisez la flèche vers le bas ou > pour déployer ou compresser les noeuds.

Dans le coin gauche en bas il y a une case à cocher Tout montrer. Cliquer sur ce bouton affichera tous les individus de la base de données.

    • Source : dans ce champ vous pouvez saisir le texte utilisé dans la référence de la source. La valeur par défaut est : Estimation des dates calculées.

Quatre cases à cocher sont disponibles :

    • Enlever les dates précédemment ajoutées** Ajouter les dates de naissance estimées
    • Ajouter les dates de décès estimées
    • Afficher les résultats détaillés : affichera les détails pour chaque date entrée.
  • Configuration :
    • Age maximun :
    • Ecart d'âge maximun entre les frères et soeurs :
    • Années minimum entre les générations :
    • Age moyen entre les générations :

Cliquer sur Outils --> Modification de la base de données --> Calcul des dates estimées..., ouvre la fenêtre de Mise en garde sur les modifications :

Editer les informations sur le propriétaire de la base de données

Fig. z.z Information sur le propriétaire

Cliquer sur Outils --> Modification de la base de données --> Edition des données sur le propriétaire de la base..., ouvre la fenêtre de Editeur de données sur le propriétaire, dans laquelle vous pouvez saisir les informations.

  • Nom :
  • Adresse :
  • Ville :
  • Département :
  • Région :
  • Code postal / INSEE :
  • Téléphone :
  • Email :

Extraire les données depuis le champ prénom...

Cet outil parcourt le base de données et cherche à extraire des titres et surnoms qui pourraient être inclus dans les champs Noms. Si des informations sont à extraire, les candidats pour la modification seront présentés dans un tableau. Vous pouvez alors décider de les modifier ou non.

Extraire les données du lieu depuis son titre...

Cet outil essaye d'extraire la ville et la région depuis le titre du lieu.

Extrait les descriptions de l'événement depuis ses données

Cet outil essaye d'extraire les descriptions de l'événement depuis ses données.

Trouver d'éventuels doublons...

Fig. z.z Individus présents plusieurs fois

Cet outil parcourt le base de données et cherche les enregistrements qui pourraient décrire en réalité la même personne.

Vous pouvez accéder à cet outil via Outils --> Modification de la base de donnée... -> Trouver d'éventuels doublons....

Deux options sont disponibles :

  • La correspondance : choisir entre élevée, moyenne, et basse depuis le menu déroulant.
  • Les options : une case à cocher permettant d'activer ou non l'utilisation des codes soundex.

Seulement trois boutons sont présents : l'Aide vous conduisant à cette page, Annuler pour arrêter le processus et le bouton Valider pour lancer l'outil.

Si vous cliquez sur le bouton Valider, les données suivront deux étapes.

Étape 1 : Construction d'une liste préliminaire Étape 2 : Calcul des correspondances possibles. Une barre de progression s'affichera et sa rapidité dépendra de votre processeur et de nombre d'individus dans votre base de données, ceci pouvant prendre un peu de temps.

Enfin, une fenêtre Fusions potentielles sera présentée. Elle affiche une liste avec trois colonnes :

  • Evaluation : ceci vous donne une idée de la ressemblance entre les deux individus. Plus le rang est élévé, plus vous pouvez rencontrer un individu déjà présent.
  • Le premier individu
  • Le second individu

Si vous sélectionnez une ligne ou un rang, vous pourrez vérifier les détails avec le bouton Comparer ou vous pouvez cliquer deux fois sur la ligne.

Trois boutons sont présents : Aide vous conduisant à cette page, Fermer pour quitter et le bouton Comparer, expliqué en détail dans le dialogue fusion des individus.

Appuyer sur le bouton Annuler vous ramènera à la liste.

Réparer la casse des noms de famille...

Fig. z.z Correction de la casse

Cet outil recherche dans la base de données les noms de famille pour les normaliser. Le but est d'avoir la norme conventionnelle: premières lettre en capital et des minuscules pour le reste du nom de famille. Si des déviations de cette règle sont détectées, les candidats pour la modification seront présentés dans un tableau. Vous pouvez alors décider de les modifier ou non.

Vous pouvez utiliser cet outil via Outils --> Modification de la base de données --> Réparer la casse des noms de famille....

Gnome-important.png
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

Vous pouvez choisir le bouton Arrêter ou Utiliser l'outil.

Si des changements sont possibles sur les lettres capitales vous verrez la fenêtre Changements de la casse. Elle affiche une liste des noms de famille pouvant être convertis par GRAMPS. Dans la liste il y a trois colonnes : les cases à cocherSélectionner, le nom original et le changement.

Sélectionnez les noms que vous souhaitez modifier, puis appuyez sur le bouton Accepter les modifications et quitter. Ou utilisez le bouton Annuler pour ne rien changer.

Renommer les types d'événement

Fig. z.z Changement de type

Cet outil renomme tous les événements d'un type avec un nouveau nom.

Gnome-important.png
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

La fenêtre Changement des types d'événement est présentée. Cet outil renommera tous les événements de ce type avec un nom différent.

  • Type d'événement original : saisir dans le champ texte ou utilisez le menu déroulant et sélectionnez le type d'événement à renommer
  • Nouvel événement : saisir dans le champ text (vous pouvez créer un type d'événement nouveau) ou utilisez le menu déroulant et sélectionnez un nouveau type.

L'exemple montre le changement de l'événement Naissance vers l'événement Baptême.

Cliquez sur Valider pour poursuivre, Annuler pour abandonner, ou Précédent pour revoir vos choix.

Gnome-important.png
Renommer les événements

Cet outil renommera le type d'événement pour toute la base. Aucun retour en arrière ne sera alors possible avec la fonction Annuler.

Réorganiser les identifiants GRAMPS

Cet outil réordonne les identifiants des objets de la base de données selon le schéma spécifié par GRAMPS.

Vous pouvez changer les préférences dans le menu Edition --> Préférences --> Identifiants ID.

Gnome-important.png
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

La fenêtre affichera une barre de progression.

Les identifiants sont réordonnés en plusieurs étapes : les identifiants individuels, les identifiants familiaux, les identifiants événements, les identifiants objets média, les identifiants sources, les identifiants lieux, les identifiants dépôts et enfin les identifiants notes.

L'étape suivante consiste à rechercher les identifiants non-utilisés et les assigner.

Gnome-important.png
Identifiants personnalisés

Si vous personnalisez vos identifiants, vos modifications seront remplacées par la valeur par défaut. Attention avant d'utiliser cet outil !

Réparation de la base de données

Vérifier et réparer la base de données

Cet outil vérifie la base de données en recherchant les problèmes d'intégrité et en corrigeant ceux qu'il peut corriger. Dans le détail, cet outil détecte les défauts suivants :

Liens familiaux rompus. Ceci arrive quand une personne fait référence à une famille qui ne la connaît pas ou vice versa.

Media introuvable. Un média introuvable est un objet multimédia dont le fichier est référencé dans la base de données mais absent. Ceci arrive quand le fichier est détruit, renommé ou bien encore déplacé ailleurs.

Familles vides. Ce sont les entrées de famille qui n'ont aucune référence à toute personne en tant que leur membre.

Liens erronés entre parents. Ceci vérifie les liens de la famille vers le père et la mère. Le sexe des parents doit aussi être différent. Si cela est détecté, la relation est modifiée en "Partenaires".

Reconstruire les tables de références

Reconstruire les seconds indices

Supprimer les objets non référencés

Cet outil recherchera les informations non connectées à votre base de données et va les supprimer.

Déboguer

Terminal d'évaluation Python

Recharger les greffons

Comme l'indique le nom, ceci permet de charger les greffons. Dans le système de GRAMPS, tous les rapports et outils sont des greffons (plugins), ainsi vous pouvez ajouter au système des nouveaux greffons alors que GRAMPS est lancé.

Afficher les objets non chargés

Utilitaires

Cette section contient des outils vous permettant d'effectuer une opération simple sur une partie de données. Les résultats peuvent être sauvés dans votre base de données, mais ils ne modifieront pas vos données existantes. Les utilitaires suivants sont actuellement disponibles dans GRAMPS:

Générer les codes SoundEx

Qu'est ce que le Soundex ?

Cet utilitaire genère les codes soundex pour le nom des individus de la base de données. Vous pouvez en apprendre plus sur le système d'indexion soundex sur la page soundex NARA.

Le soundex est un nom de famille codé basé sur les sonorités et l'orthographe proche. Les noms qui semblent les mêmes, mais qui s'écrivent autrement, comme SMITH et SMYTH qui auront le même code mais sont classés différement. Le système de codage soundex a été développé pour pouvoir trouver un nom de famille avec différentes orthographes.

Appliqué pour la première fois au recensement de 1880, le soundex est un index phonétique, pas seulement alphabétique. La fonction clé étant que les codes des noms sont plus basés sur les sonorités plutôt que sur l'écriture. C'était pour aider les chercheurs à trouver un nom rapidement malgré différentes orthographes.

Those doing census lookups must use the same method to encode surnames as the census takers did when they generated the database.

To search for a particular surname, you must first work out its code.

  • Règle de base sur le codage Soundex :

Every soundex code consists of a letter and three numbers, such as W-252. The letter is always the first letter of the surname. The numbers are assigned to the remaining letters of the surname according to the soundex guide shown below. Zeroes are added at the end if necessary to produce a four-character code. Additional letters are disregarded. Examples: Washington is coded W-252 (W, 2 for the S, 5 for the N, 2 for the G, remaining letters disregarded). Lee is coded L-000 (L, 000 added).

Le nombre Représente les lettres

1 B, F, P, V

2 C, G, J, K, Q, S, X, Z

3 D, T

4 L

5 M, N

6 R

Ne pas faire attention aux lettres A, E, I, O, U, H, W, et Y.

  • Règles additionnelles sur le codage Soundex :
    • Les noms avec lettres doubles : si le nom de famille a deux lettres qui se suivent, ceci apparaîtra comme une lettre. Par exemple :

Gutierrez est codé G-362 (G, 3 pour le T, 6 pour le premier R, le second est ignoré, 2 pour le Z).

    • Les noms avec les lettres ayant le même numéro de code soundex que la précédente : si le nom de famille a différentes lettres ayant le même code soundex, alors une seule sera prise en compte d'après le guide de codeage. Exemples :
      • Pfister est codé P-236 (P, F ignoré, 2 pour le S, 3 pour le T, 6 pour le R).
      • Jackson est codé J-250 (J, 2 pour le C, K est ignoré, S est ignoré, 5 pour le N, le zéro est ajouté).
      • Tymczak est codé T-522 (T, 5 pour le M, 2 pour le C, z est ignoré, 2 pour le K). Tant que la voyelle "A" sépare le Z et le K, alors le K est codé.
    • Names with Prefixes: If a surname has a prefix, such as Van, Con, De, Di, La, or Le, code both with and without the prefix because the surname might be listed under either code. Note, however, that Mc and Mac are not considered prefixes.For example, VanDeusen might be coded two ways:V-532 (V, 5 for N, 3 for D, 2 for S) or D-250 (D, 2 for the S, 5 for the N, 0 added).
    • Consonant Separators: If a vowel (A, E, I, O, U) separates two consonants that have the same soundex code, the consonant to the right of the vowel is coded. Example:Tymczak is coded as T-522 (T, 5 for the M, 2 for the C, Z ignored (see "Side-by-Side" rule above), 2 for the K). Since the vowel "A" separates the Z and K, the K is coded. If "H" or "W" separate two consonants that have the same soundex code, the consonant to the right of the vowel is not coded. Example: Ashcraft is coded A-261 (A, 2 for the S, C ignored, 6 for the R, 1 for the F). It is not coded A-226.

Utilisation du module soundex

Fig. x.y Le générateur de code SoundEx

Cliquez dans la barre d'outils sur Outils --> Utilitaires --> Générer les codes Soundex... et vous obtiendrez la fenêtre Générateur de code soundex. Le champ textuel Nom vous permet de saisir un nom ou vous pouvez utiliser la flèche bas pour choisir un nom dans la liste déroulante.

The name you put in can by any name even a name not present in your Family Tree.

Le résultat affiché est automatiquement : R236

A Help button is available which brings you to this page. With the Close button (or hitting <alt+c>) you close this generator window.

Media Manager...

Fig. z.z Final confirmation window

This tool allows batch operations on media objects stored in GRAMPS. An important distinction must be made between a GRAMPS media object and its file.

The GRAMPS media object is a collection of data about the media object file: its filename and/or path, its description, its ID, notes, source references, etc. These data do not include the file itself.

The files containing image, sound, video, etc. exist separately on your hard drive. These files are not managed by GRAMPS and are not included in the GRAMPS database. The GRAMPS database only stores the path and file names.

This tool allows you to only modify the records within your GRAMPS database. If you want to move or rename the files then you need to do it on your own, outside of GRAMPS. Then you can adjust the paths using this tool so that th media objects store the correct file locations.

If you click the Forward button (or hit <Alt+F>) you will get a window with three radio buttons:

  • Replace substrings in the path: Selecting this radio button will bring up a Replace substring settings window where you can type in any string in the Replace text field and the With text field. At any time you can click on the Cancel button or the Back button. Clicking the Forward button will bring up the Final confirmation window.
  • Convert paths from relative to absolute
  • Convert paths from absolute to relative

Calcul relationnel

Cet utilitaire calcule la relation entre n'importe quelle personne et la personne active.

Vérifier les données...

Fig. z.z Verify the Data...

This utility allows you to verify the database based on the set of criteria specified by you.

Par exemple, vous voulez vous assurer qu'aucune personne dans votre base n'a des enfants à l'âge de 98 ans. Ceci serait le résultat d'une erreur de saisie de toute évidence, mais ne serait pas une erreur de structure de la base de données. A côté de cela, quelqu'un pourrait avoir un enfant à 98 ans même si c'est très improbable. L'outil de vérification affiche tout ce qui ne répond pas à vos critères pour que vous puissiez vérifier plus à fond les données.

Clicking on Tools-->Utilities-->Verify the Data... you will get a Database Verify Tool window. The window has four tabs. Those tabs show a list with criteria and a input field where you can alter the criteria value. In the lists below I show some workable values.

  • General:
    • maximum age: 95
    • minimum age to marry 16
    • maximum age to marry 60
    • maximum spouses for a person 4
    • maximum number of consecutive years of widowhood before next marriage 30
    • maximum age for an unmarried person 99

There is a check box: estimate missing dates.

  • Women:
    • minimum age to bear a child 16
    • maximum age to bear a child 51
    • maximum number of children 15
  • Men
    • minimum age to father a child 18
    • maximum age to father a child 65
    • maximum number of children 15
  • Families
    • maximum husband-wife age difference 41
    • maximum number of years between children 11
    • maximum span of years for all children 32

If you are OK with the criteria click the Run button (or hit <Alt+R> and you will be presented with a Database Verification Results window.

Depending on your criteria and your data a list will be shown. Some possibilities of findings are listed below. But there are others.

  • Disconnected individuals : TODO further explain what how
  • old/dead father
  • marriage after death/ before birth
  • large year span for all children
  • early/late marriage
  • young/unborn mother
  • husband and wife with the same surname
  • same sex marriage/ female husband
  • ...

To show how handy this Utility is, here two live examples from real data:

The warning showed 'female husband': checking the data I found a family with father : Anna Roelants. Luckily in the Description I read: The marriage of Adam Roelants and Cornelia Crabbe. It was clearly a typo: Anna i.s.o. Adam. Without this Tool it would be very hard to find.

The warning showed 'late marriage': checking the data: male person °1738 female person °1756 : marriage X 1804 [French Republican Calender] : Everything seemed to be OK: so they (re)married at the age of 66 and 48 years! The warning showed up because the General criteria was set to 60.

On the bottom of the window four check boxes are available to make a selection easier. Those are Mark All, Unmark All, Invert Marks, and Hide Marked.

Double-clicking on a row will give you a possibility to view and or edit the data.

With the Close button (or hit <Alt+C>) you close the Results window. With the Help button (or hitting <Alt+H>) you will get to this page.

Gnome-important.png
Difference between Verify tool and previously described Check tool

The Check tool detects inconsistencies in the database structure. The Verify tool,however, is detecting the records that do not satisfy your particular criteria.


Editeur de filtre personnalisé

Par exemple, vous voulez vous assurer qu'aucune personne dans votre base n'a des enfants à l'âge de 98 ans. Ceci serait le résultat d'une erreur de saisie de toute évidence, mais ne serait pas une erreur de structure de la base de données. A côté de cela, quelqu'un pourrait avoir un enfant à 98 ans même si c'est très improbable. L'outil de vérification affiche tout ce qui ne répond pas à vos critères pour que vous puissiez vérifier plus à fond les données.

Fig.3.x Définir le filtre

L'éditeur de filtre personnalisé génère des filtres selon ses besoins pouvant être utilisé pour trouver des individus dans les rapports, exportations, et autres outils et utilitaires. C'est un outil très puissant pour les analyses généalogiques.

Quand vous le lancez, la fenêtre des Filtres Personnalisés est affiché et liste tous les filtres que vous avez déjà définis (s'il y en a). Cliquez sur le bouton Ajouter... pour définir un nouveau filtre. Quand vous l'avez défini, vous pouvez modifier, tester et supprimer les filtres sélectionnés avec les boutons Editer..., Tester... et Supprimer. Tous les filtres affichés dans la liste seront automatiquement enregistrés avec votre base de données et seront disponibles pour les sessions suivantes de GRAMPS.

Gramps-notes.png
Les changements sur les filtres

Les changements sur les filtres prendront effet en appuyant sur le bouton Appliquer et fermer.

Le presse-papiers

Cet outil permet de stocker provisoirement des notes pour une réutilisation facile. En bref, c'est un presse-papiers étendu aux objets textuels utilisés dans GRAMPS.

Gnome-important.png
Astuce

Le presse-papiers utilise la technique du glisser-déposer.


Appeler le presse-papiers, par Outils->Utilitaires->Presse-Papiers ou cliquer sur Presse-Papiers dans la barre d'outils. La fenêtre suivante apparaîtra:

Fig.3.xx Le presse-papiers

On peut stocker des adresses, des attributs (personnel et famille), des événements (personnel et famille), des noms, les objets média, des références, des références de source, des URLs, et naturellement l'information textuelle des notes et des commentaires. Pour stocker, glisser simplement le texte dans la boîte de dialogue. Pour réutiliser l'information, glisser-la à l'endroit correspondant, par exemple onglet d'adresse, onglet d'attribut, etc...

Gnome-important.png
Astuce

Quelques objets montrent l'icône de lien du côté gauche. Ceci indique que déposer un tel choix produira une référence à un objet existant, pour ne pas copier l'objet lui-même.


Par exemple, le fichier média ne sera pas reproduit. Au lieu de cela, la référence sera faite à un objet existant, qui aura comme conséquence l'entrée locale.

Gnome-important.png
Astuce

Le stockage est persistant dans une session simple de GRAMPS. La fermeture de la fenêtre ne perdra pas les informations stockées. Seulement, sortir de GRAMPS .


Précédent Index Suivant