Download

From Gramps
Revision as of 04:21, 27 June 2013 by Erikdr (Talk | contribs)

Jump to: navigation, search

Linux

Linux 220x261.png

Before upgrading your distribution: Use your old version of Gramps to backup your Family Trees [1].

via Distributions      Latest version (4.0.3) (advanced users only)

MS Windows

Windows 180x160.png

Before download: Use your old version of Gramps to backup your Family Trees [1].

Windows Installer (32-bit) 3.4.7      Windows Installer (64-bit) 3.4.7

After download: double-click to install Gramps.

Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. However if this fails for any reason, Create a new Family Tree and Import the back-up into this new Tree.

Alternative independent MS Windows version [3].

Mac OS X

Macos 200x200.png

Before download: Use your old version of Gramps to backup your Family Trees [1]. Read the before installation instructions.

Mac OS X 10.5, 10.6 and 10.7    Intel 4.0.2      Mac OS X 10.5    Power PC 4.0.2

After download: Double-click the .dmg file to mount the disk (note: your browser may do this for you automatically). Next drag the Gramps application to your application folder and double-click to launch it [2].

Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. However if this fails for any reason, Create a new Family Tree and Import the back-up into this new Tree.


BSD

Before upgrading your distribution: Use your old version of Gramps to backup your Family Trees [1].

via Distributions      Latest version (advanced users only)

Live CD

Download link.png

Linux live CD Demonstration Obtaining the CD (727 MB) Linux Genealogy CD based on Ubuntu 10.10 (Maverick Meerkat). Allows you to trial a pre-installed Gramps 3.2.5, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn..). If you are interested in Gramps, but are afraid to actually install it or unable to install it (not your PC, windows, no internet at home, work laptop, ...), then try out our Linux Genealogy CD. It runs without installing on the hard disk and contains a collection of open source, free, genealogy programs. You can then install Ubuntu 10.10 and Gramps from the CD anytime you like.

Linux and BSD distributions

Most linux distributions come bundled with a version of Gramps, though it's not always the most recent version and it may not have been installed by default. Still it is recommended to use the Gramps version that comes with your distribution.

Below are ways to install Gramps on some of the more popular distributions:

Distribution GUI pkg manager Current versions Notes
Linux Mint Software Manager Nadia: Gramps 3.4.0-1
Lisa: Gramps 3.3.1-1
Isadora: Gramps 3.2.0-1
Mageia
Ubuntu 32x32.png Ubuntu Software Centre Quantal: Gramps 3.4.0-1 available versions
Fedora 32x32.png Fedora Add/Remove Software (Gnome) or
Software Management (KDE)
Fedora Rawhide: Gramps 3.4.3
Fedora 18: Gramps 3.4.2.
Debianopenlogo-32.png Debian Add/Remove Software squeeze (old stable): Gramps 3.2.3
wheezy (stable): Gramps 3.4.0
jessie (testing): Gramps 3.4.0
sid (unstable): Gramps 3.4.0
available versions
Mandriva 32x32.png Mandriva Software Management in the

Mandriva Linux Control Center

Mandriva 2010.1: Gramps 3.3.1
Mandriva 2011: Gramps 3.2.6
See also backports and contrib repository
Redhat 32x32.png Redhat
openSUSE YaST ?? openSUSE 12.3: Gramps 3.4.2 available versions
Slackware Slackware 14.0: Gramps 3.4.2 available versions
NetBSD NetBSD: Gramps 3.4.3 available versions
FreeBSD FreeBSD: Gramps 3.3.0 available versions
PC-BSD PC-BSD: Gramps 3.3.0


Linux: Install latest version

If your distribution doesn't ship with Gramps or you wish to install a different version than it ships with, you could try to install the latest version of Gramps manually. Instructions are given below for a number of distributions.

Gnome-important.png
Warning

This should only be attempted by experienced users, and after you have backed up your Family Tree.

The version of Gramps that has been included in your distribution will have been tested to work with the components in that distribution. If you try to install a different version of Gramps there is a possibility that the components needed for the new version of Gramps are not available for your distribution, or they are available, but don't work properly. You might not discover that there is a problem till you have already done some work with the new version of Gramps.

If you already have Gramps installed, and you are only making a 'point' upgrade (i.e. from Gramps x.y.z to x.y.z+1, e.g. from 3.4.3 to 3.4.4), then it is likely but not certain that Gramps will continue to work. However, if the change is much greater, especially if it is a major version change (e.g. from 2.y.z to 3.y.z), then the danger that it does not work properly is much greater.

Debianopenlogo-32.pngDebian and Ubuntu 32x32.png Ubuntu Download the .deb file. Double-click on the downloaded .deb file or (for some distributions, e.g. Mint Debian) run the following command from the directory where the file was saved (change the filename to match the one you downloaded).

sudo dpkg -i gramps_3.4.4-1_all.deb

For other distributions, Download link.png the source and follow the instructions for Linux:Build from source

Notes

[1] Backup to Gramps XML. You will find backup in the Family Tree menu of recent Gramps versions, otherwise use export in the same menu but uncheck privacy options in the Exporter Assistant in order to export all data

[2] Alternatively, you can click and hold on the disk icon at the top of the window of the mounted disk, and then option-drag to the Applications folder. This will create a new folder containing all the files, including the README and NEWS.

[3] An alternative independent version is GrampsPortable_3.4.5.paf.exe (20.3 MB) Portable Gramps from PortableApps.com includes all dependencies required for Windows. Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu. By Bart.S - Please report issues to the author. (2012-09-07)