Difference between revisions of "Download"

From Gramps
Jump to: navigation, search
(Linux and BSD distributions)
m (MS Windows)
(14 intermediate revisions by 5 users not shown)
Line 5: Line 5:
 
Gramps is a free software project and community. We strive to produce a genealogy program that is both intuitive for hobbyists and feature-complete for professional genealogists. It is a community project, created, developed and governed by genealogists.
 
Gramps is a free software project and community. We strive to produce a genealogy program that is both intuitive for hobbyists and feature-complete for professional genealogists. It is a community project, created, developed and governed by genealogists.
  
{{man note|{{Man menu|Gramps '''Current version: '''{{version}}''' Released: '''2020-01-10'''}}|''Different data format to the GRAMPS 3.4 series. Full Python 3 support only as Python 2 support dropped. Uses GTK+ 3 GUI. Default database is now SQlite. Lot of updates see: ''[[Gramps 5.1 Wiki Manual - What's new?|What's new?]]{{-}}
+
{{man note|{{Man menu|Gramps '''Current version: '''{{version}}''' Released: '''2020-01-10'''}}|''Different data format to the GRAMPS 3.4 series. Full Python 3 support only as [https://www.python.org/doc/sunset-python-2/ Python 2 support dropped]. Uses GTK+ 3 GUI. Default database is now SQlite. Lot of updates see: ''[[Gramps 5.1 Wiki Manual - What's new?|What's new?]]{{-}}
[[File:Linux_220x261.png|128px|link=Download#Linux]]  [[File:windows_180x160.png|128px|link=Download#MS_Windows]] [[File:macos_200x200.png|128px|link=Download#Mac_OS_X]]  [[File:Bsd daemon.jpg|128px|link=Download#BSD]]}}
+
[[File:Linux_220x261.png|128px|link=Download#Linux]]  [[File:windows_180x160.png|128px|link=Download#MS_Windows]] [[File:macos_200x200.png|128px|link=Download#macOS]]  [[File:Bsd daemon.png|128px|link=Download#BSD]]}}
  
 
== Linux ==
 
== Linux ==
Line 24: Line 24:
 
[[File:windows_180x160.png|128px|left|link=Download#MS_Windows]]
 
[[File:windows_180x160.png|128px|left|link=Download#MS_Windows]]
  
Before download: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]].  
+
Before downloading the [[All_In_One_Gramps_Software_Bundle_for_Windows|All-In-One software installer bundle for Windows]]: Use your '''earlier version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees to the hardy and portable [[#1|XML format<sup>1</sup>]].  
  
Supports Microsoft Windows in all versions [http://windows.microsoft.com/en-au/windows/lifecycle Vista/7] and later.(''Please note: Python-3.5 and Gtk-3.18 dropped support for Windows XP not Gramps itself. Gramps can still be run on Windows XP with older versions of those libraries eg:(Gtk-3.16 & Python3.4.4)'')
+
This installer supports Microsoft Windows in all versions [http://windows.microsoft.com/en-au/windows/lifecycle Vista/7] and later.
  
<big><u>[{{github_url}}/releases/download/v{{version_windows_AIO32}}/{{filename_windows_AIO32}}.exe Windows Installer (32-bit) {{version_windows_AIO32}}]</u>
+
(''Please note: Gramps prefers the Python-3.5 and Gtk-3.18 libraries and newer. Those libraries have dropped support for Windows XP. But Gramps can still be run on Windows XP with earlier library versions, i.e., Python3.4.4 and Gtk-3.16'')
&nbsp;&nbsp;&nbsp;&nbsp;
+
 
<u>[{{github_url}}/releases/download/v{{version_windows_AIO64}}/{{filename_windows_AIO64}}.exe Windows Installer (64-bit) {{version_windows_AIO64}}]</u></big>
+
<big>
 +
*<u>[{{github_url}}/releases/download/v{{version_windows_AIO32}}/{{filename_windows_AIO32}}.exe Windows Installer (32-bit) {{version_windows_AIO32}}]</u>
 +
*<u>[{{github_url}}/releases/download/v{{version_windows_AIO64}}/{{filename_windows_AIO64}}.exe Windows Installer (64-bit) {{version_windows_AIO64}}]</u></big>
  
After download: double-click to install Gramps. {{man menu|[[Download#Missing_other_languages|Missing other languages]] - Standard setup is British ''English only'' so if using a different language (or the American or Australian dialect of English) please ensure that you select extra dictionary and language files when asked during the installation process.}}
+
After download: '''double-click to install Gramps'''. <br>By default: new releases will be added in a new directory and earlier installations of Gramps will ''not'' be overwritten; the language will be a [[#Missing_other_languages|mix of British and US English]].
  
{{man tip|Shortcuts|Once installed one shortcut is placed on the desktop and in the Start menu two shortcuts are added, please only use the first shortcut, unless requested by a developer.<br>1) ''GrampsAIO'''XX''' ''{{version}}''      {{man menu|<--- Shortcut for everyday use of Gramps}}<br>2) ''GrampsAIO'''XX''' ''{{version}}''-console)}}
+
{{man tip|Shortcuts|During installation, one shortcut is placed on the desktop and two shortcuts are added the Start menu. <br>''Please only use the 'console' secondary shortcut when performing diagnostics requested by a developer.''<br>1) ''GrampsAIO'''XX''' ''{{version}}''      {{man menu| &larr; for normal use of Gramps}}<br>2) ''GrampsAIO'''XX''' ''{{version}}''-console}}
  
Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. However if this fails for any reason, '''Create''' a new Family Tree and '''Import''' the back-up into this new Tree.
+
Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. Should this fail for any reason, '''Create''' a new Family Tree and [[How_to_restore_a_backup|'''Import''' the back-up]] into this new Tree.
  
Use the Windows AIO version, please use the download links above. For more information about individual versions, console and debug modes, release notes, etc., look at [[GrampsAIO cx freeze-based|this page]] (English only).
+
Use the Windows AIO (All-In-One) version, please use the download links above. For more information about individual versions, console and debug modes, release notes, etc., look at [[GrampsAIO cx freeze-based|this page]] (English only).
  
Alternative independent '''Legacy''' MS Windows version [[#2|[2]]].
+
If necessary, there is an alternative independent '''Legacy''' MS Windows [[#2|portable version<sup>2</sup>]].
  
You may also install using the alternative independent Gramps Chocolatey Package [[#3|[3]]].
+
You may also install using the alternative independent Gramps [[#3|Chocolatey NuGet Package<sup>3</sup>]].
  
 
{{-}}
 
{{-}}
 
=== Missing other languages ===
 
=== Missing other languages ===
 
[[File:Microsoft Window Gramps AIO Installer Choose Components-Selection-51.png|right|thumb|450px|Microsoft Window Gramps AIO Installer Choose Components-Selection window.]]
 
[[File:Microsoft Window Gramps AIO Installer Choose Components-Selection-51.png|right|thumb|450px|Microsoft Window Gramps AIO Installer Choose Components-Selection window.]]
If you want to run Gramps in another language other than English using the Gramps AIO installer, then you must select it from the '''Translations''' during installation process.
+
The default Gramps AIO installer will embed the US dialect of English for the interface with the British spellcheck dictionary.
 +
 
 +
If you prefer a different language (or spell with the US or Australian dialects of English), please ensure that you pay special attention to the Choose Components phase of the installation.
 +
 
 +
To install a language other than English, select from both the '''Translations''' ''and'' '''Dictionaries''' during the Choose Components phase of the installation.
  
Likewise, if you anticipate the need to spellcheck Notes in other than the British dialect of English, be certain to select the appropriate language from '''Dictionaries'''. Gramps will not access your Operating System's native dictionary.
+
Even your primary language is installed by default, you might anticipate the need to spellcheck Notes in other than the British dialect of English. Be certain to select the appropriate languages from '''Dictionaries'''. Gramps will not access your Operating System's native dictionary.
  
Otherwise, that language option will not be available.
+
There is no simple facility for adding interface or dictionary languages after installation.
 
{{-}}
 
{{-}}
  
== Mac OS X ==
+
== macOS ==
  
 
[[File:macos_200x200.png|128px|left|link=Download#Mac_OS_X]]
 
[[File:macos_200x200.png|128px|left|link=Download#Mac_OS_X]]
Line 60: Line 66:
 
Before download: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]]. Read the [[Mac OS X:Application package|before installation]] instructions.
 
Before download: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]]. Read the [[Mac OS X:Application package|before installation]] instructions.
  
Supports Apple Mac OS X in all versions 10.5 (Leopard) and later.
+
Supports Apple macOS/Mac OS X in all versions 10.5 (Leopard) and later.
  
 
<big><u>[{{github_url}}/releases/download/v{{version_Mac}}/{{Filename_mac_intel}}.dmg Intel {{version_Mac}}]</u></big>  
 
<big><u>[{{github_url}}/releases/download/v{{version_Mac}}/{{Filename_mac_intel}}.dmg Intel {{version_Mac}}]</u></big>  
Line 87: Line 93:
 
!Notes
 
!Notes
 
|-
 
|-
|<!-- Distribution        -->[[File:Debianopenlogo-32.png]]''' [[Debian]] '''
+
|<!-- Distribution        -->[[File:Debianopenlogo-32.png|link=https://packages.debian.org/search?keywords=gramps]]''' [[Debian]] '''
 
|<!-- GUI Package manager -->Add/Remove Software
 
|<!-- GUI Package manager -->Add/Remove Software
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
Line 106: Line 112:
 
* Bionic Beaver (18.04 LTS): Gramps: 5.0.0
 
* Bionic Beaver (18.04 LTS): Gramps: 5.0.0
 
* Eoan (19.10): Gramps: 5.0.1
 
* Eoan (19.10): Gramps: 5.0.1
* Focal (Development: 20.04 LTS): Gramps: 5.1.2
+
* Focal (20.04 LTS): Gramps: 5.1.2
 +
* Groovy Gorilla (Development: 20.10): Gramps: 5.1.2
 
|<!-- Notes              -->[http://packages.ubuntu.com/search?keywords=gramps&searchon=names available versions]/ (Also see: [https://launchpad.net/~rosco2/+archive/ubuntu/backports Backports])
 
|<!-- Notes              -->[http://packages.ubuntu.com/search?keywords=gramps&searchon=names available versions]/ (Also see: [https://launchpad.net/~rosco2/+archive/ubuntu/backports Backports])
 
|-
 
|-
Line 128: Line 135:
 
|<!-- GUI Package manager -->|[https://wiki.mageia.org/en/Installing_and_removing_software drakrpm (or rpmdrake)]
 
|<!-- GUI Package manager -->|[https://wiki.mageia.org/en/Installing_and_removing_software drakrpm (or rpmdrake)]
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* Mageia [https://madb.mageia.org/package/show/name/gramps/release/cauldron/ Caulron]: Gramps 5.1.1
+
* Mageia [https://madb.mageia.org/package/show/name/gramps/release/cauldron/ Caulron]: Gramps 5.1.2
 
* Mageia 7.1: Gramps 5.0.1
 
* Mageia 7.1: Gramps 5.0.1
 
|<!-- Notes              -->[http://mageia.madb.org/package/show/name/gramps Mageia App Db - gramps]
 
|<!-- Notes              -->[http://mageia.madb.org/package/show/name/gramps Mageia App Db - gramps]
Line 237: Line 244:
 
== BSD ==
 
== BSD ==
  
[[File:Bsd daemon.jpg|128px|left|link=Download#BSD]]
+
[[File:Bsd daemon.png|128px|left|link=Download#BSD]]
  
 
Before upgrading your distribution: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]].
 
Before upgrading your distribution: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]].

Revision as of 22:37, 22 May 2020

Gramp-Small-background-wiki-2020.jpg

Research, organize and share your family tree with Gramps.

Gramps is a free software project and community. We strive to produce a genealogy program that is both intuitive for hobbyists and feature-complete for professional genealogists. It is a community project, created, developed and governed by genealogists.

Gramps-notes.png
Gramps Current version: 5.1.2 Released: 2020-01-10

Different data format to the GRAMPS 3.4 series. Full Python 3 support only as Python 2 support dropped. Uses GTK+ 3 GUI. Default database is now SQlite. Lot of updates see: What's new?
Linux 220x261.png Windows 180x160.png Macos 200x200.png Bsd daemon.png

Linux

Linux 220x261.png

Before upgrading your distribution: Use your old version of Gramps to backup your Family Trees [1].

via Distributions      Latest version (5.1.2) (advanced users only)

MS Windows

Windows 180x160.png

Before downloading the All-In-One software installer bundle for Windows: Use your earlier version of Gramps to backup your Family Trees to the hardy and portable XML format1.

This installer supports Microsoft Windows in all versions Vista/7 and later.

(Please note: Gramps prefers the Python-3.5 and Gtk-3.18 libraries and newer. Those libraries have dropped support for Windows XP. But Gramps can still be run on Windows XP with earlier library versions, i.e., Python3.4.4 and Gtk-3.16)

After download: double-click to install Gramps.
By default: new releases will be added in a new directory and earlier installations of Gramps will not be overwritten; the language will be a mix of British and US English.

Tango-Dialog-information.png
Shortcuts

During installation, one shortcut is placed on the desktop and two shortcuts are added the Start menu.
Please only use the 'console' secondary shortcut when performing diagnostics requested by a developer.
1) GrampsAIOXX 5.1.2 ← for normal use of Gramps
2)
GrampsAIOXX 5.1.2-console


Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. Should this fail for any reason, Create a new Family Tree and Import the back-up into this new Tree.

Use the Windows AIO (All-In-One) version, please use the download links above. For more information about individual versions, console and debug modes, release notes, etc., look at this page (English only).

If necessary, there is an alternative independent Legacy MS Windows portable version2.

You may also install using the alternative independent Gramps Chocolatey NuGet Package3.


Missing other languages

Microsoft Window Gramps AIO Installer Choose Components-Selection window.

The default Gramps AIO installer will embed the US dialect of English for the interface with the British spellcheck dictionary.

If you prefer a different language (or spell with the US or Australian dialects of English), please ensure that you pay special attention to the Choose Components phase of the installation.

To install a language other than English, select from both the Translations and Dictionaries during the Choose Components phase of the installation.

Even your primary language is installed by default, you might anticipate the need to spellcheck Notes in other than the British dialect of English. Be certain to select the appropriate languages from Dictionaries. Gramps will not access your Operating System's native dictionary.

There is no simple facility for adding interface or dictionary languages after installation.

macOS

Macos 200x200.png

Before download: Use your old version of Gramps to backup your Family Trees [1]. Read the before installation instructions.

Supports Apple macOS/Mac OS X in all versions 10.5 (Leopard) and later.

Intel 5.1.2     

After download: Double-click the .dmg file to mount the disk (note: your browser may do this for you automatically). Next drag the Gramps application to your application folder and double-click to launch it [4].

Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. However if this fails for any reason, Create a new Family Tree and Import the back-up into this new Tree.

Tango-Dialog-information.png
Spell Checking:

Gramps uses a different spell checker than the one provided by Mac OS X, with different spelling dictionary requirements. We can't easily provide dictionaries for all of the supported languages in the bundle, but they're easily downloaded from OpenOffice.org's website. Download the language you want and save it, then navigate to the download in Finder. Most browsers have a downloads window that offers "Show in Finder" in its context menu. Change the file extension from oxt to zip, then from the context menu select Open with... Archive Utility to decompress it. In the decompressed folder or perhaps in a subfolder you'll find the dictionary files in pairs, foo.aff and foo.dic. Some languages have more than one pair with a README file to explain why. Select a pair and copy it to /Library/Dictionaries (you'll have to authenticate with an administrator id and password), and if 'foo' isn't already a language or locale code, make it one. For example, the French package includes several pairs with names like fr-moderne.aff and fr-moderne.dic. The spell checker doesn't recognize those names, so when you copy them to /Library/Dictionaries you must rename them to fr.aff and fr.dic or fr_FR.aff and fr_FR.dic. You can have more than one dictionary pair installed if you use several languages, but one must match the language you use for Gramps or spell checking won't be enabled at all.


An alternative way to download and install Gramps on MacOS can be done using the MacPorts[5] framework.

Linux and BSD distributions

Gramps-notes.png
These packages are built and supported by the distros.

If your distribution is not listed you may possibly find it listed on Repology
Please report any problems with them to the package maintainer.

Most Linux distributions come bundled with a version of Gramps, though it's not always the most recent version and it may not have been installed by default. Still it is recommended to use the Gramps version that comes with your distribution.

Below are ways to install Gramps on some of the more popular distributions:

Distribution GUI Package manager Current versions Notes
Debianopenlogo-32.png Debian Add/Remove Software
  • Debian 8 ("jessie")(old old stable): Gramps 4.1.1
  • Debian 9 ("stretch") (old stable): Gramps 4.2.5
  • Debian 9 ("stretch")(backports): Gramps 5.0.1
  • Debian 10 ("buster") (stable): Gramps 5.0.1
  • Debian 10 ("buster")(backports) (stable): Gramps 5.1.2
  • bullseye (testing): Gramps 5.1.2
  • sid (unstable): Gramps 5.1.2
available versions
Ubuntu 32x32.png Ubuntu Software Centre
  • Xenial (16.04 LTS): Gramps: 4.2.2
  • Xenial (16.04 LTS): Gramps: 4.2.6 (Backport)
  • Bionic Beaver (18.04 LTS): Gramps: 5.0.0
  • Eoan (19.10): Gramps: 5.0.1
  • Focal (20.04 LTS): Gramps: 5.1.2
  • Groovy Gorilla (Development: 20.10): Gramps: 5.1.2
available versions/ (Also see: Backports)
Farm-Fresh linux mint.png Linux Mint Software Manager
  • 18.x(Gramps 4.2.2~dfsg-1)
  • 19.x(Gramps 4.2.8)
Install the most current version of Gramps using the following instructions from the Linux Mint Forums

Old versions available from Linuxmint
Fedora 32x32.png Fedora Add/Remove Software (Gnome)
or
Software Management (KDE)
  • Rawhide (Gramps 5.1.2)
  • Fedora 30 (Gramps 5.1.2)
  • Fedora 31 (Gramps 5.1.2)
  • Fedora 32 (Gramps 5.1.2)
available versions
Mageia drakrpm (or rpmdrake)
  • Mageia Caulron: Gramps 5.1.2
  • Mageia 7.1: Gramps 5.0.1
Mageia App Db - gramps
OpenSUSE-distribution-icon.png openSUSE YaST
  • openSUSE Tumbleweed: Gramps 5.1.2
  • openSUSE Leap 15.2: Gramps 4.2.8
  • openSUSE Leap 15.1: Gramps 4.2.8
  • openSUSE Leap 15.0: Gramps 4.2.8
available versions
The most recent version can usually be installed from the 'openSUSE BuildService - GNOME:Apps' repository
Slackware-distribution-icon.jpgSlackware available versions
Archlinux-icon-crystal-32.svgArch Linux
  • Gramps 5.1.2
available versions
Gentoo-distribution-icon.pngGentoo Linux
  • Gramps 5.1.2
available versions
NetBSD
FreeBSD available versions
OpenBSD
  • OpenBSD: Gramps 5.1.1
available versions



Linux: Install latest version

If your distribution doesn't ship with Gramps or you wish to install a different version than it ships with, you could try to install the latest version of Gramps manually.

Gnome-important.png
Warning before attempting this use your existing installation to make a Gramps XML backup

This should only be attempted by experienced users, and after you have backed up your Family Tree.

The version of Gramps that has been included in your distribution will have been tested to work with the components in that distribution. If you try to install a different version of Gramps there is a possibility that the components needed for the new version of Gramps are not available for your distribution, or they are available, but don't work properly. You might not discover that there is a problem till you have already done some work with the new version of Gramps.

If you already have Gramps installed, and you are only making a 'point' upgrade (i.e. from Gramps x.y.z to x.y.z+1, e.g. from 3.4.3 to 3.4.4), then it is likely but not certain that Gramps will continue to work. However, if the change is much greater, especially if it is a major version change (e.g. from 2.y.z to 3.y.z), then the danger that it does not work properly is much greater.

Debian-based

For Debianopenlogo-32.pngDebian-based linux distributions (Which includes Ubuntu 32x32.png Ubuntu ) Download the .deb file. Double-click on the downloaded .deb file or (for some distributions, e.g. Mint Debian) run the following command from the directory where the file was saved (change the filename to match the one you downloaded).

sudo dpkg -i python3-gramps_5.1.2-1_all.deb

If you have an error about having unmet dependencies run:

sudo apt-get -f install

to install the dependencies.

Useful command lines

Before upgrading you can[1]:

  • Find out what version you are running, by using this:
   dpkg-query -s python3-gramps

that queries the package and gives you info about it.

  • If you are committed to an upgrade then make sure you have backed up you Family Trees to Gramps XML then run :
   sudo dpkg -r python3-gramps

this will remove the current gramps package (assuming its a python3 version older versions could be python-gramps )

  • To stop Ubuntu updating gramps (to possibly an older version from Ubuntu!) you may need to run:
   sudo apt-mark hold gramps

Upgrade is then complete.

For other distributions

For other distributions, Download link.png the source and follow the instructions for Linux:Build from source

BSD

Bsd daemon.png

Before upgrading your distribution: Use your old version of Gramps to backup your Family Trees [1].

via Distributions      Latest version (advanced users only)


See also:


Live CD

Gnome-important.png
Note that both Live CD demonstrations use an old version of Gramps and it is not recommended for general use

Download link.png

Linux live CD Demonstration includes Gramps 3.2.5 pre-installed to trial, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn..). Download the CD (727 MB). The Linux Genealogy CD is based on Ubuntu 10.10 (Maverick Meerkat). If you are interested in Gramps, but are afraid to actually install it or unable to install it (not your PC, windows, no internet at home, work laptop, ...), then try out our Linux Genealogy CD. It runs without installing on the hard disk and contains a collection of open source, free, genealogy programs. You can then install latest Ubuntu and Gramps from the CD anytime you like.

Online Demonstration

You can also try an online demonstration of Gramps on rollApp:

Select Launch Online then Test Drive(Opening/saving files will not be available)

Gramps-notes.png
Note

This is a commercial limited trial and not endorsed by the Gramps-project. Beware of third parties having your genealogical data.


Notes

[1] Backup to Gramps XML. You will find backup in the Family Tree menu of recent Gramps versions, otherwise use export in the same menu but uncheck privacy options in the Exporter Assistant in order to export all data. See : How to make a backup

[2] Note that PortableApps.com use an old version of Gramps and it is not recommended for general use An alternative independent Legacy version is GrampsPortable_3.4.9.paf.exe (29.0 MB) Portable Gramps from PortableApps.com includes all dependencies required for Windows. Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu. By Bart.S - Please report packaging issues to the author. (2012-09-07)

[3] Chocolatey NuGet is a Machine Package Manager, somewhat like apt-get, but built with Windows in mind. Gramps Chocolatey Package

[4] For Apple Mac OS X, alternatively, you can click and hold on the disk icon at the top of the window of the mounted disk, and then option-drag to the Applications folder. This will create a new folder containing all the files, including the README and NEWS.

[5] The MacPorts Project is an open-source community initiative to design an easy-to-use system for compiling, installing, and upgrading open-source software on the Mac operating system. https://www.macports.org/ In order to do that run the following command: port install gramps see: Mac OS X:Build from source:MacPorts

See also