Difference between revisions of "Download"

From Gramps
Jump to: navigation, search
(make Windows AIO download link working with version template)
(Community supported: 2012-05-23 (64 bit only) no exe's for 32 bit versions available)
Line 40: Line 40:
 
|<!-- GRAMPS<br>Release -->{{version_windows_AIO64}}<br>(All In One)<br>{{Needs backup}}
 
|<!-- GRAMPS<br>Release -->{{version_windows_AIO64}}<br>(All In One)<br>{{Needs backup}}
 
|<!-- Download -->[http://sourceforge.net/projects/gramps/files/Stable/{{version_windows_AIO64}} GrampsAIO64-{{version_windows_AIO64}}.exe]<br>(46.0 MB)
 
|<!-- Download -->[http://sourceforge.net/projects/gramps/files/Stable/{{version_windows_AIO64}} GrampsAIO64-{{version_windows_AIO64}}.exe]<br>(46.0 MB)
|<!-- Note --> [[All In One Gramps Software Bundle for Windows |All In One GRAMPS]] includes all dependencies required for Windows x64<br>(2011-11-13)
+
|<!-- Note --> [[All In One Gramps Software Bundle for Windows |All In One GRAMPS]] includes all dependencies required for Windows x64<br>(2012-05-23)
 
|-
 
|-
 
|<!-- Platform -->Windows
 
|<!-- Platform -->Windows

Revision as of 00:35, 28 May 2012

The latest released version

Visit the following page for instructions on:

Officially supported

  • Only the Linux platform is officially supported as GRAMPS developers use and test the source code on that platform, fixing any problems that arise due to upgrades.
Platform GRAMPS
Release
Download Note
Linux Maintenance

Needs backup
Installation from source Building of GRAMPS from source required

Community supported

  • A platform is community supported when users have created an installable version for that platform. Full functionality of GRAMPS is not guaranteed and some components may be disabled. Developers are dependent on the community to fix any issues that arise. The GRAMPS developers aim to have GRAMPS working on all platforms, but have no resources to do specific testing to assure this is the case on release of a new version.
Platform GRAMPS
Release
Download Note
Windows, 32-bit 3.4.7
(All In One)

Needs backup
GrampsAIO-3.4.7-2.exe
(41.9 MB)
All In One GRAMPS includes all dependencies required for Windows
By Josip - Please report issues to the author. (2011-10-02)
Windows, 64-bit 3.4.7
(All In One)

Needs backup
GrampsAIO64-3.4.7.exe
(46.0 MB)
All In One GRAMPS includes all dependencies required for Windows x64
(2012-05-23)
Windows 3.3.1

Needs backup
gramps-3.3.1-1.exe (8.2 MB) Download and install Windows dependencies first
Windows 3.4.5

Needs backup
GrampsPortable_3.4.5.paf.exe
(18.7 MB)
Portable GRAMPS from PortableApps.com includes all dependencies required for Windows.
Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu.
By Bart.S - Please report issues to the author. (2011-05-17)
Linux 4.0.3

Needs backup
Automatic installation Depends on version of Linux used
Linux 4.0.3

Needs backup
Manual installation Depends on version of Linux used
Linux Live CD
Demonstration
3.2.5

Needs backup
ubuntu10.10 lgenealogy-6.1-desktop-i386.iso
(727 MB)
Linux Genealogy CD based on Ubuntu 10.10 (Maverick Meerkat)
Allows you to trial a pre-installed GRAMPS 3.2.5, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn..)
BSD 3.4.1

Needs backup
FreeBSD port BSD platforms
Solaris 3.2.0

Needs backup
Solaris Platforms Building of GRAMPS from source required
Mac OS X 4.0.2

Needs backup
Gramps-4.0.2-1_PPC.dmg (41 MB)
Or
Gramps-4.0.2-1_Intel.dmg (42 MB)
A single, stand-alone bundle which uses the native quartz windowing system instead of X11 and includes all dependencies required for Mac OS X (PPC or Intel). Please read the installation instructions at Mac OS X:Application package before you use the program.
By John Ralls - Report issues on the bug tracker (2011-10-02)
Mac OS X 3.4.7

Needs backup
Mac OS X:Build from source:MacPorts Requires installing X11 if using versions of Mac OS X older than Leopard(10.5).
Gramps:MacPorts Maintained by: devans openmaintainer