Difference between revisions of "Development using Eclipse and Pydev"

From Gramps
Jump to: navigation, search
Line 1: Line 1:
 +
[[Category:Developers/General]]
 
Prerequisites: a JRE has to be installed.
 
Prerequisites: a JRE has to be installed.
  

Revision as of 09:35, 11 October 2008

Prerequisites: a JRE has to be installed.

To use Eclipse you'll need two folders. One where you install Eclipse, the other one will be the workspace. E.g., /home/acraphae/devel/eclipse_installs/ and /home/acraphae/devel/eclipse_workspaces/gramps

Download an Eclipse package from Eclipse.org. Unzip the file into /home/acraphae/devel/eclipse_installs/ and run the eclipse binary in /home/acraphae/devel/eclipse_installs/eclipse when asked for a workspace, enter /home/acraphae/devel/eclipse_workspaces/gramps

Installing Pydev and Pylint

Follow the instructions on the pydev extensions site.

On my Ubuntu, the python interpreter can be found at /usr/bin/python

sudo apt-get install pylint Go to: window > preferences > pydev > pylint tick use pylint and enter /usr/bin/pylint as the pylint path.

Installing Subversion

Follow the guide on http://subclipse.tigris.org/install.html to install the Subclipse plugin.

Open the subversion perspective and add a repository. https://gramps.svn.sourceforge.net/svnroot/gramps/trunk for working on the trunk code. Select Checkout project using new project wizard. Select pydev project wizard.