De:Gramps 5.1 Wiki Handbuch - Navigation

From Gramps
Revision as of 00:24, 23 September 2023 by Patsyblefebre (talk | contribs) (Dokumentation)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Zurück Index Nächste


Solange ein Stammbnaum geöffnet ist, konzentriert sich Gramps auf eine Person gewöhnlich bezieht sich das auf eine aktive Person. Dies ermöglicht dir Daten diese Person betreffend anzuschauen und zu bearbeiten, seine oder ihre direkte Familie, usw. Navigation in der Stammbaumdatenbank (z.B. wechseln von einer Person zu einer anderen Person) ist tatsächlich nichts anderes als die aktive Person zu ändern.

Dieser Abschnitt beschreibt viele verschiedene Wege durch die Datenbank zu navigieren unter Verwendung beider, der komplexen und der praktischen Schnittstellen, die Gramps bietet. All diese Wege erreichen eventuell das Selbe, aber einige sind praktischer als andere, basierend darauf was du in Gramps in diesen Moment machst.

Die Personenkategorie verwenden

Der intuitive Weg zur Auswahl einer aktiven Person, ist die Verwendung der Personenkategorie. Wenn du dich in der Personenansicht befindest, wähle einfach den Namen der gewünschten Person durch klicken auf den Listeneintrag aus der Liste. Die Person die du gewählt hast wird die aktive Person. Die Statusleiste wird aktualisiert um die Änderung der aktiven Person widerzuspiegeln.

Siehe auch

Die Beziehungenkategorie verwenden

Wenn du dich in der Beziehungenkategorie befindest, kannst wie folgt ganz einfach zwischen den Mitgliedern der angezeigten Familie wechseln:

Klicke auf den unterstrichenen Namen der gewünschten Person und diese wird zur Hauptperson der Beziehungenansicht.

Der Name der zur Zeit aktiven Person ist nicht unterstrichen.

Zusätzlich dazu bietet Gramps eine reichhaltige Möglichkeit mit Hilfe der Tastatur zu navigieren. Die detaillierte über die Tastenkürzel findet sich in dem Anhang B: Tastenkürzel Referenz.

Die Familienkategorie verwenden

Wenn du dich in der Familienkategorie befindest, kannst du ganz einfach zwischen den angezeigten Familien navigieren.

Die Familien können verwendet werden, um eine Reihe von Familien visuell auf mögliche Duplikate und fehlende Daten zu vergleichen. Die Sortierung nach den verschiedenen Spalten ermöglicht es, ähnlich benannte Partner in unmittelbarer Nähe zu platzieren, so dass die Ehepartner verglichen werden können. Du kannst nach Vornamen oder Spitznamen suchen, indem du das "Namensformat" im Anzeige Reiter des Bearbeiten ▶ Einstellungen... Dialogs vorübergehend änderst. Zum Beispiel würde ein Namensformat "Vorname Nachname Nachname" dazu führen, dass die Spalte nach dem Spitznamen sortiert wird.

Bei der Zusammenführung zweier Familien werden nicht nur die sekundären Objekte der Familie, sondern auch die beiden Väter und die beiden Mütter zusammengeführt.

Das Filter Gramplet in der Familienansicht ermöglicht die Suche nach Personen in verschiedenen Familienrollen. Du könntest also nach Familien mit einem Vater namens "John", einer Mutter namens "Mary" und einem Kind namens "Thomas" suchen.

Die Schaubilderkategorie 22x22-gramps-pedigree.png verwenden

Abb. 10.1 Zeitleistestammbaum Ansicht- Zusatzmodul von Drittanbieter für Schaubilderkategorie - Kontextmenü Beispiel

Gramps stützt sich stark auf formularbasierte Layouts verknüpfter Listenelemente. Diese implizieren Beziehungen zwischen Datensätzen in deinem Stammbaum. Die Schaubildkategorie bietet eine alternative, visuellere Möglichkeit, diese Beziehungen darzustellen. Die Positionen, Formen und Farben von Behältern sowie ihre Verbindungslinien & Pfeile können eine zusätzliche Beziehungstiefe mit verschiedenen Faktoren aufweisen. Behälter können einfache farbgefüllte Kästchen, Bögen, Bänder oder viele andere Formen sein.

Aber die Schaubilderkategorie bietet jedoch auch eine alternative Möglichkeit, durch den Stammbaum zu navigieren. Der Vorteil dieser Methode besteht darin, dass du mehr als eine Generation des Stammbaums sehen kannst. So kannst du direkt von einem Urenkel zu einem Urgroßvater springen, ohne die Zwischengenerationen zu durchlaufen.

Beachte das nach dem wechseln der aktiven Person in der Schaubilderkategorie die Ansicht neu aufgebaut wird, um die eingestellte Anzahl von Generationen beginnend mit der neuen Hauptperson anzuzeigen. Wenn du dich in der Schaubilderkategorie befindest, kannst du wie folgt durch die Mitglieder des angezeigten Stammbaum navigieren:

Um eine angezeigte Person zum Fokus der aktiven Person zu machen, klicke mit der linken Maustaste auf den entsprechenden Behälter. Wenn du mit der rechten Maustaste auf den Behälter klickst, wird ein Kontextmenü mit Optionen aufgerufen, die dem Inhalt entsprechen.

Das Kontextmenü für einen Personenbehälter kann ▶Untermenüs enthalten, in denen alle Ehepartner, Geschwister, Kinder und Eltern der entsprechenden Person aufgelistet sind. Der erste Eintrag im Kontextmenü ist normalerweise der Name der Person in diesem Behälter. (Alternativ kann es sich auch um eine Bearbeitungsoption handeln.) Durch Auswahl des Personennamens wird der Fokus auf die gleiche Weise verschoben wie durch Klicken mit der linken Maustaste auf den Behälter. Du kannst den Fokus der aktiven Person auch auf einen der Ehepartner, Geschwister, Kinder oder Eltern einer angezeigten Person ändern.

Einige Schaubildansichten weisen eine offensichtliche Navigationskorrelation auf. Wenn du dich intuitiv durch Generationen bewegst, entspricht dies der Bewegung nach links, rechts, oben oder unten im Diagramm. Diese verfügen möglicherweise über benutzerdefinierte Richtungsnavigationsschaltflächen, um die Navigation durch Klicken und nicht durch Ziehen zu ermöglichen.

Um beispielsweise den Fokus der StammbaumansichChartst auf ein Kind (falls vorhanden) der aktuellen aktiven Person zu ändern, klicke auf die Schaltfläche (Linke Pfeilspitze) links neben dem Diagrammfeld der aktiven Person. Wenn es nur ein Kind gibt, ändert sich der Fokus sofort. Wenn die aktive Person mehr als ein Kind hat, wird die Schaltfläche (Linke Pfeilspitze) um ein Popup-Menü mit einer auswählbaren Liste der Kinder erweitert. (Für diese bestimmte Schaltfläche (Linke Pfeilspitze) wird die Popup-Menüliste der Kinder nach der Reihenfolge der Eheschließung der Eltern sortiert, sortiert nach der Reihenfolge der Geburt. Diese Reihenfolge kann global in der Kategorie Beziehungen geändert werden.)

Tango-Dialog-information.png
Vorteile der Verwendung von (rechts-Klick) Kontextmenüs

Direkter Zugriff auf Partner und Geschwister. Komplett alle Mitglieder aller Kategorien, nicht nur die bevorzugten Mitglieder.

Wie Behälter können Schaltflächen über alternative Funktionen verfügen, auf die du zugreifen kannst, indem du mit der rechten Maustaste klickst und aus einem Kontext-Popup-Menü auswählst.

Andere Schaltflächen sind weniger offensichtliche Hilfsmittel, um nicht zu Personen, sondern zu Funktionen von Gramps zu navigieren. Wenn du das Beispiel der StammbaumansichtCharts erneut verwendest, wird beim Überfahren der Zeilen zwischen den Feldern ein Hinweis mit allen bekannten grundlegenden Details zur Beziehung angezeigt. Wenn du auf diese Zeilen doppelklickst, wird der Editor für diese Familie geöffnet. Durch Doppelklicken auf das Feld Aktive Person wird der Editor für diese Person geöffnet. Es lohnt sich, die ausführliche Dokumentation in jeder Diagrammansicht zu lesen, um diese versteckten Verknüpfungen zu bevorzugten Funktionen zu entdecken.

Die integrierten Ansichten der Schaubildkategorie werden im Referenzabschnitt Kategorien vorgestellt. Einige werden ausführlicher in Artikeln beschrieben, die am Ende des Einführungsabschnitts der Ansicht aufgeführt sind.

Die Sammlung von Ansichten in der Schaubilderkategorie kann mithilfe der Zusatzmodulverwaltung Funktion von Gramps um Zusatzmodule von Drittanbietern erweitert werden. Die verfügbaren Zusatzmodule von Drittanbietern findest du in der Spalte Ansicht der Liste der Zusatzmodule. Die Pflege einiger Zusatzmodul-Ansichten von Drittanbietern wurde im Laufe der Jahre vom Gramps-Freiwilligenteam übernommen. Diese wurden nach der Überprüfung eingebaut und dann in die Hauptverteilungen von Gramps aufgenommen. Artikel zur Verwendung der einzelnen Zusatzmodul-Ansichten sind mit der Spalte Zusatzmodul/Dokumentation verknüpft. Die Qualität der Dokumentation variiert für diese Artikel erheblich.

Gramplets verwenden

Abb. 10.2 Werkzeugbankkategorieansicht - mit Beispiel Gramplets gezeigt

In der Seitenleiste und Fußleiste kannst du einige Gramplets wie diese aktivieren:

Diese Beispiele bieten die Möglichkeit, den Fokus der aktiven Person unter Verwendung der Perspektive einer familiären Beziehung... zu nahen Verwandten, Nachkommen oder Vorfahren zu navigieren. Zukünftige Gramplets ermöglichen möglicherweise die Navigation nach geografischer Nähe, DNA-Matching oder einer anderen Verbindung, die wir noch nicht berücksichtigt haben.

Die textbasierten Gramplets enthalten in der Regel Namen, die für die Navigation mit einem Hotlink verknüpft sind, während die grafischen Gramplets möglicherweise Kontextmenüs verwenden.

Die Hauptperson setzen

Eine (und nur eine Person) kann in der Datenbank als die Hauptperson gewählt werden. Sobald die Hauptperson festgelegt wurde, wird das Zurücksetzen des Fokus der aktiven Person auf diese Person mit einem einzigen Klick erledigt, unabhängig davon, welche Kategorie gerade verwendet wird.

Um die Hauptperson zu setzen, navigiere zuerst zu der Person wie ist egal. Dann gehe zur Personenkategorie und wähle Bearbeiten ->Hauptperson setzen. Wenn die Startperson gesetzt ist, kannst du jederzeit von überall in der Datenbank durch einfaches klicken auf die Start Schaltfläche in der Werkzeugleiste zu der Startperson navigieren. Du kannst auch Gehe zu ->Start aus dem Menü, den Start Eintrag aus jedem Kontextmenü welches mit rechts-Klick geöffnet wird oder das Tastenkürzel Alt+Pos1 verwenden.

Einstellen der aktiven Person

Es wird erwartet, dass die aktive Person im Kontext von Aktionen, Berichten und Änderungen steht. Sie sind das ausgewählte Element in der Personenansicht oder oben in der Beziehungsansicht.

Der Fokus Aktive Person kann direkt ausgewählt oder indirekt "angesteuert" werden. Die Methoden umfassen:

In der Personenansicht gibt es ein Auswahlhervorhebung als visuellen Hinweis auf die aktive Person. In der Beziehungsansicht wird die aktive Person in einem separaten Abschnitt oben angezeigt. Alle anderen unten aufgeführten Personen haben eine unmittelbare Beziehung (Eltern, Geschwister, Ehepartner, Kind) zur aktiven Person. Optional kann die Statusleiste so eingestellt werden, dass das Fokusobjekt für die Ansichtskategorie aufgelistet wird. (Die Aktive Person ist der Fokus für mehrere Ansichtskategorien.)

Hotlink Navigation

Normalerweise wird durch einfaches Klicken auf den Hotlink-Namen einer Person diese Person ausgewählt und der Kontextfokus auf diese als aktiven Person verschoben.

Abb. 10.3 Beziehungenkategorieansicht

Der Name jeder Person in den Kategorienansichten Personen und Beziehungen ist ein Hotlink. Durch Ändern des Fokus der aktiven Person in der Personenansicht wird lediglich geändert, welcher Datensatz hervorgehoben ist. Dies führt jedoch auch dazu, dass der Inhalt von Gramplets aktualisiert wird und die Ansichten Beziehungen, Schaubilder und Geografie neu auf die neue aktive Person ausgerichtet werden.

Die Auswahl eines anderen Hotlink-Namens in der Ansicht Beziehungenkategorie führt zu einer weniger subtilen Änderung. Die Perspektive, wie die Familiendaten dargestellt werden, ändert sich in Richtung dieses Fokus. Ihre Details werden in den oberen Bereich verschoben und ihre unmittelbare Familie wird unten neu angeordnet.



Kontextmenü-Navigation

Hotlink-Namen auf der Registerkarte Referenzen und in den Notizen (und in einigen Gramplets) öffnen jedoch lediglich das Fenster Personeneditor, ohne im Fokus der aktiven Person zu dieser Person zu navigieren. (Diese Links verhalten sich so, als hättest du auf eine STOCK_EDITBearbeiten Schaltfläche anstelle eines Hotlink-Namens geklickt.) Dies erleichtert das schnelle Bearbeiten von Personen um die aktive Person herum, ohne die Desorientierung eines Fokuswechsel.

Abb. 10.4 Kontextmenü im Personeditor

Der Fokus der aktiven Person kann im Dialogfeld Person bearbeiten mithilfe des Kontextmenüs (Rechtsklick) im leeren Bereich des Kopfbereichs festgelegt werden. Die Option Als aktive Person setzen in diesem Kontextmenü ändert den Fokus der aktiven Person auf die Person, die bearbeitet wird.


Verwendung verlaufbasierender Navigation

Abb. 10.5 Beispiel für die verlaufsbasierten Navigationswerkzeuge

Gramps bietet auch eine Reihe leistungsstarker verlaufbasierender Navigationswerkzeuge. Diese Werkzeuge ähneln denen , die normalerweise in in Webbrowsern verwendet werden.

Sie beinhalten Zurück und Vor Elemente vorhanden im Gehe zu Menü, Kontextmenüs (verfügbar in Personen-, Familien- und Vorfahrenansicht) und den Gramps Go-Previous48x48 win.pngGo-next48x48 win.pngWerkzeugleisteschaltflächen. Sie enthalten auch die Liste der letzten Auswahl verfügbar über das gehe zu Menü das dir ermöglicht direkt zu jeder der letzten Auswahl zu springen. Zum Schluss, rechts-klicken auf die Vor > und < Zurück Werkzeugleistenschaltflächen öffnet Aufklappmenüs mit den entsprechenden Abschnitten des Verlaufs. Durch Auswahl eines Eintrags, kannst du direkt dorthin springen.

Lesezeichen Navigation

Gramps Go-Home48x48 win.png

Die Haus-Schaltfläche in der Symbolleiste ist ein Lesezeichen für Sonderfälle. Dadurch wird der Fokus der aktiven Person auf die Person verschoben, die derzeit als Hauptperson festgelegt ist. Dies ist so häufig nützlich, dass diese Funktion auch eine Tastenkombination aufweist.

Ähnlich wie beim festlegen der Startperson, kannst du andere Personen aus der Datenbank mit einem Lesezeichen versehen, um die spätere Navigation zu dieser Person zu vereinfachen. Um ein Lesezeichen zu einer Person hinzuzufügen, navigiere zu der Person und wähle dann Lesezeichen ->Lesezeichen hinzufügen. Um zu dieser Person von überall in der Datenbank zu gelangen, wähle Lesezeichen ->Name der Person.

Abb. 10.6 Lesezeichen verwalten

Du kannst über Lesezeichen ->Lesezeichen organisieren... oder Tastenkürzel Shift+STRG+D deine Lesezeichen verwalten. Dies öffnet den folgenden Lesezeichen verwalten Dialog mit einer Liste der Lesezeichen und Bedienelemente diese zu modifizieren.

Verwende die Hoch und Runter Schaltflächen um die Reihenfolge in der Liste zu ändern. Verwende die Entfernen Schaltfläche um ein Lesezeichen zu löschen. Die Hilfe Schaltfläche bringt dich auf diese Seite und du schließt das Lesezeichen organisieren Fenster schließt du mit der Schließen Schaltfläche.

Die mit einem Lesezeichen versehene Person kann in der Personenkategorie, wie oben beschrieben, aber auch in der Beziehungenkategorie, Familienkategorie, und der Schaubilderkategorie ausgewählt werden.

Auf ähnliche Weise kannst du auch für folgendes Lesezeichen erstellen: Ereignisse, Quellen, Fundstellen, Orte, Medien, Aufbewahrungsorte und Notizen


Notizen als Navigationsverknüpfungen

Abb. 10.7 Notiz-Editor - Verknüpfen von Text

Es gibt separate Lesezeichenlisten in mehreren Kategorien. Aber es sind immer noch einfache Listen. Lange Listen von Lesezeichen werden schnell unhandlich.

Permanente Links können in Notizen erstellt werden. Verwende den Verknüpfungeditor in Notizen, um Navigationslinks zu verschiedenen Arten von Gramps-Datensätzen gemäß Ihren eigenen Organisationsmethoden zu organisieren. Sobald eine Notiz Text verknüpft hat, kann dieser verknüpfte Datensatz wie ein Lesezeichen verwendet werden. In Notiz-Gramplets, in denen die Bearbeitung nicht aktiv ist, öffnet ein Klick auf den Link den Objekteditor für diesen Link. (Es erfordert einen zusätzlichen Modifikator im Notizeditor: Navigiere zu diesem Datensatz, indem du die STRG Taste gedrückt hältst und auf den verknüpften Text klickst.) Eine Notiz kann als verknüpfter Index für andere Notizen mit unterschiedlichen Verknüpfungssätzen verwendet werden.

Ein Beispiel für eine verknüpfte Notiz könnte einen Nachruf enthalten, in dem alle Personen, Orte oder sogar die Ereignisse verknüpft sind. Dies erleichtert die Navigation zu den indirekt verwandten (oder sogar nicht verwandten) Sargträgern, Bestattungsunternehmen oder Teilnehmern.

Ein weiterer Hinweis könnte die transkribierte Bibliographie für die veröffentlichte Originalforschung eines anderen Genealogen sein. Wenn du digitale Kopien dieser ursprünglich zitierten Referenzen sammelst, kann die verknüpfte Bibliographie als Checkliste für die Quellenerfassung verwendet werden. Wenn die Bibliographie vollständig verknüpft ist, kann sie verwendet werden, um für jedes Zitat durch die Quellen zu navigieren und nach nicht unterstützten Schlussfolgerungen, Ungenauigkeiten oder Auslassungen zu suchen.


Datensätze finden

Tango-Dialog-information.png
Personen finden

Möglicherweise möchtest du zuerst Suchfilter anwenden, um die Größe der Liste zu verringern. Die Suchleiste kann für die Suche nach einzelnen Begriffen verwendet werden, wenn die Seitenleiste der Gramplets nicht aktiviert ist. Für komplexere Suchvorgänge erhältst du Zugriff auf die Filtersteuerelemente für mehrere Begriffe, indem du die Gramplet-Seitenleiste aktivierst (indem du das Menü Ansicht -> Seitenleiste auswählst) und die Registerkarte Filter-Gramplet auswählst. Wähle den gewünschten Filter aus und klicke auf Suchen. Weitere Informationen findest du unter Filter.


Abb. 10.8 Finde Personen Listenansicht Verwendung des interaktiven Suchtyp "Voraus" - Beispiel

Um einen Datensatz in der Datenbank zu finden, wechsle zuerst in die entsprechende Ansicht, die eine Liste der gewünschten Datensätze enthält: Personen, Quellen, Orte oder Medien. Wähle eine Zeile in der Liste aus, um den Fokus zu erhalten, und gib dann den Namen einer Person oder den Titel eines Quell-, Orts- oder Medienobjekts ein, nach dem du suchst.

Alternativ kannst du eine Zeile in der Liste auswählen, um den Fokus zu erhalten, und dann STRG+F drücken, um das Textfeld für den Suchmodus zu aktivieren. Es reicht jedoch auch aus, mit der Eingabe zu beginnen, um sowohl das Feld zu öffnen als auch den Suchbegriff einzugeben.

Während der Eingabe wird der erste übereinstimmende Datensatz in der Sortierspalte der Liste in die Mitte der Liste gescrollt und ausgewählt. Wenn du mehr Zeichen eingibst, wird die Übereinstimmung verfeinert. Solange das Textfeld für den Suchmodus sichtbar ist, wird durch Drücken der Cursortaste mit dem Abwärtspfeil zur nächsten Übereinstimmung gewechselt, während durch Drücken der Cursortaste mit dem Aufwärtspfeil zur vorherigen Übereinstimmung gewechselt wird. Die Box verschwindet, nachdem sie im Leerlauf ist. (Wenn zwischen 5 und 15 Sekunden lang keine Tastenanschläge aufgetreten sind.) Wenn das Feld Suchen nicht aktiviert ist, verschieben die Cursorsteuertasten die Datensatzauswahl in der Liste nach oben und unten.

Durch Ändern der Sortierspalte (durch Klicken auf die Überschrift) wird auch die übereinstimmende Spalte geändert. Die Suche in einer anderen Sortierspalte funktioniert am besten in flachen Listenansichten. (Personen- oder Ortskategorie-Ansichtsmodi mit hierarchischer Gruppierung sind weniger reaktionsschnell als die flache Listenansicht, die bereits alphabetisch sortiert ist).

Die Zwischenablage verwenden

Gramps-notes.png
Nicht deine gewöhnliche Zwischenablage

Beachte, dass die Gramps-Zwischenablage nicht wie eine Standard-Computer-Zwischenablage funktioniert. Sie funktioniert wie eine echtes Klemmbrett, indem du Dinge darauf ziehst und sie per Drag & Copy kopierst.

Gnome-important.png
Warnung

Der Speicher in der Zwischenablage bleibt innerhalb einer einzelnen Gramps-Sitzung erhalten. Durch Schließen des Fensters Zwischenablage gehen die gespeicherten Datensätze nicht verloren. Das Verlassen von Gramps wird jedoch.

Wenn du Elemente zwischen Sitzungen speichern musst, gibt es ein Drittanbieter Collections Clipboard Gramplet, das dies tut.

Abb. 10.9 Zwischenablage - Dialog - Zeigt Kontextmenü (Rechtsklick) Beispiel


Für eine Anwendung wie Gramps ist die Zwischenablage sehr wichtig, da sie dazu beiträgt, die wiederholte Dateneingabe zu reduzieren.

Das Zwischenablage Werkzeug bietet einen temporären Notizblock zum Speichern von Datenbankeinträgen zur einfachen Wiederverwendung während einer einzelnen Gramps-Sitzung, z.B.: Bis du Gramps beendest. Kurz gesagt, dies ist eine Art Kopier- und Einfügefunktion, die von Textobjekten auf andere Arten von Datensätzen erweitert wird, die in Gramps verwendet werden. In der Zwischenablage wird die Drag & Drop Technik in großem Umfang verwendet.

Um die Zwischenablage aufzurufen, wähle entweder das Menü Bearbeiten-> Zwischenablage oder klicke auf die Schaltfläche Zwischenablage in der Symbolleiste oder verwende die Tastenkombination STRG+B.


Die Zwischenablage unterstützt Adressen, Attribute (beide persönlich und familiär), Ereignisse (beide persönliche und familiäre), Namen, Medienobjektreferenzen, Fundstellen, URLs und natürlich Textinformationen von Notizen und Kommentaren. Zum speichern jeglicher Art dieser Datensätze, ziehe den entsprechenden Datensatz aus dem entsprechenden Bearbeiten Dialog in die Zwischenablage. Zur Wiederverwendung des Datensatz ziehe ihn von der Zwischenablage an die entsprechende Stelle im Editor z.B. Adressenreiter, Attributereiter, usw..

Tango-Dialog-information.png
Hinweis

Bei einigen Objekten wird in der linken Spalte ein Verknüpfungssymbol angezeigt und in der Beschriftung steht "ref". Dies zeigt an, dass das Ziehen einer solchen Auswahl einen Verweis auf ein gemeinsames Objekt erzeugt und nicht das Objekt selbst verknüpft. Alle gemeinsamen Attribute werden repliziert, z. B. wird die Datei des Medienobjekts nicht dupliziert. Stattdessen wird ein Verweis auf ein bestehendes Medienobjekt erstellt, was zu einem lokalen Galerieeintrag führt.

Zwischenablage Kontextmenü

Wenn du einen Datensatz über das Kontextmenü auswählst (Rechtsklick), werden die folgenden drei Optionen für jeden Datensatztyp angezeigt:

  • Siehe die [SATZTYP] Details
  • Aktiviere die [SATZTYP]
  • Erstelle Filter aus Auswahl [SATZTYP]...


Ein Beispiel
Du findest die Geburtsurkunde einer Person. In dieser Urkunde werden auch die Zeugen genannt. Und die Geburtsurkunde bestimmt wo diese Information aufbewahrt wird. Der beste Weg ist, die Zwischenablage zu öffnen, und die Quelle, mit der du arbeiten möchtest, dorthin zu ziehen. Dann verwende ziehen und ablegen um sie in neuen Objekten, die du verwendest, zu verwenden.

Jetzt kannst du die Informationen in dem Personeneditor vervollständigen. Ziehe diese Information auch in die Zwischenablage.

Nun fügst du zwei Personen für die Zeugen hinzu (wenn sie noch nicht in deiner Datenbank existieren). Ziehe die Geburtsinformation einfach in die Ereignisansicht der Zeugen und lege sie dort ab. Du siehst dann die Ansicht in der du die Rolle des Zeugen auf Zeuge für dieses Geburtsereignis ändern kannst. Wiederhole diesen Vorgang mit dem anderen Zeugen.

Dies erspart dir eine Menge Schreibarbeit und mögliche Fehler.

Hauptmenüs

Abb. 10.10 Menüleiste - Hauptmenü Übersicht - Kein Stammbaum geladen

Die Menüleiste zeigt die verfügbaren Gramps-Menüoptionen an.

Bevor ein Baum geladen wird, sind stark verkürzte Menüs verfügbar. Sie ermöglichen die Verwaltung von Bäumen, das Beenden von Gramps, das Bearbeiten von anwendungsweiten Einstellungen, das Aktivieren und Deaktivieren von Abschnitten der grafischen Benutzeroberfläche (GUI) sowie Hilfeoptionen.

Tango-Dialog-information.png
"Importieren" ist eine Stammbaum Menüoption, die nur erscheint, wenn ein Stammbaum geladen wurde

Gramps braucht einen vorbereiteten Ort, um genealogische Daten zu importieren. Erstelle und lade einen neuen, leeren Stammbaum, um Daten zu importieren, die aus einem anderen Genealogie-Werkzeug exportiert wurden. (z.B. eine GEDCOM-Datei.) Daten können auch direkt in einen Baum importiert werden, der bereits Daten enthält. Aber erstelle zuerst eine Sicherung!


Abb. 10.11 Menüleiste - Hauptmenü Übersicht - Stammbaum geladen
Abb. 10.12 Menüleiste - Hauptmenü Übersicht - Stammbaum geladen mit den verwendeten Menüeinträgen "Gehe zu" und "Fenster"

Nachdem ein Baum geladen wurde, haben die Menüs Stammbäume, Berichte, Werkzeuge und Hilfe immer die gleichen Optionen. Die Verfügbarkeit von Optionen in den anderen Menüs ist jedoch kontextabhängig. Die Optionen in den Menüs Hinzufügen, Bearbeiten und Ansicht ändern sich in Abhängigkeit von der aktiven Kategorie, und einige Menüpunkte erscheinen 'abgeblendet', wenn die Auswahlobjekte in der Ansicht die Aktion nicht zulassen.

Die Menüs Gehe zu und Lesezeichen sind speziell für die Navigation in jeder Ansicht konzipiert.

Ein Fenster-Menü erscheint, wenn es irgendwelche hervorgebrachte Fenster oder Dialoge gibt, die aufgelistet werden sollen.

Stammbäume

Abb. 10.13 Menüleiste - "Stammbäume" - Übersicht Beispiel
  • Stammbäume verwalten... - Öffnet das Stammbaumverwaltungsfenster
  • Zuletzt geöffnet - eine Verknüpfung zum Öffnen eines kürzlich bearbeiteten Stammbaums
  • Schließen - den aktuellen Baum sichern und schließen

  • Import... - Bringt Daten aus anderen Formaten ein.
    Erstelle vor dem Import eine Sicherung! Es gibt Importeinstellungen, um importierte Daten mit zeitgestempelter Markierung und/oder Quellattributen zu markieren. Diese Optionen verlangsamen den Importvorgang erheblich, sind jedoch für die anschließende Datenbereinigung hilfreich.
  • Export... - Daten exportieren ermöglicht dir einen beliebigen Teil deines Gramps-Stammbaums mit anderen Forschern zu teilen und deine Daten auf einen anderen Computer zu übertragen.

  • Ansicht exportieren... - Das Menü wird in den meisten Ansichten nur angezeigt, wenn die angezeigten Daten exportiert werden können. Gramps exportiert Daten auf dem Bildschirm nach deiner Wahl: CSV oder Open Document Tabellenformat.


  • Änderungen verwerfen und beenden -
  • Beenden -


Hinzufügen

Abb. 10.14 Menüleiste - Hinzufügen Übersicht






Bearbeiten

Abb. 10.15 Menüleiste - Bearbeiten Übersicht
  • Rückgängig -
  • Wiederherstellen -
  • Bearbeitungchronik... - Öffnet den Bearbeitungchronik Dialog

Hier werden zusätzliche Menüoptionen angezeigt, die von der Kategorieansicht abhängen.


  • Zwischenablage - Das Zwischenablagewerkzeug bietet einen temporären Notizblock zum Speichern von Datenbankeinträgen zur einfachen Wiederverwendung.

  • Einstellungen... - Zeigt das Dialogfeld Einstellungen an. Dies ermöglicht dir die meisten Einstellungen in Gramps zu ändern.
  • Hier werden zusätzliche Menüoptionen angezeigt, die von der Kategorieansicht abhängen.


Ansicht

Abb. 10.16 Menüleiste - "Ansicht" - Übersicht Beispiel
  • Konfigurieren... - Ermöglicht das Konfigurieren der aktiven Ansicht. Bietet Optionen zum Ausblenden, Anzeigen und Neuanordnen von Elementen.
  • Navigator... - Der Navigator ist ein Seitenleistencontainer für die Symbole der Navigatorkategorie. Bei Auswahl (Standard) wird die Seitenleiste links von der aktiven Ansicht angezeigt. Durch Deaktivieren wird die Navigator-Seitenleiste ausgeblendet. Wenn nicht alle Kategoriesymbole in den verfügbaren vertikalen Bereich passen, wird rechts neben der Seitenleiste eine ausgeblendete Bildlaufleiste erstellt, die beim Überrollen (Bewegen) angezeigt wird.
    Textbeschriftungen für die Symbole können über eine Option auf der Registerkarte Anzeige der Einstellungen ausgeblendet werden. Anzeigemodi können aus dem Einblendmenü unten in der Navigator-Seitenleiste ausgewählt werden.
  • Werkzeugleiste - Anzeigen (oder Ausblenden) eines Containers mit geteiltem Bildschirm für (häufig verwendete) Aktionssymbole über der Kategorieansicht. Die Auswahl der Aktionssymbole variiert je nach Kategorieansicht.
    Ein Zusatzmodul eines Drittanbieters kann installiert werden, um die Einstellungen durch eine Registerkarte Thema zu ergänzen, die eine Option zum Anzeigen von Textbeschriftungen für jede Symbolleistenschaltfläche bietet.
  • Seitenleiste - Ein- (oder Ausblenden) eines geteilten Bildschirmcontainers für Gramplets rechts neben der Kategorieansicht.
  • Fußleiste - Ein- (oder Ausblenden) eines geteilten Bildschirmcontainers für Gramplets am unteren Rand des Fensters direkt über der Statusleiste.
  • Vollbild - Erweitert das Fenster, um den gesamten verfügbaren Bildschirmbereich zu nutzen, während die Steuerelemente zum Ziehen und Ändern der Größe des Fensters deaktiviert werden. Durch Deaktivieren wird die vorherige Größe wiederhergestellt, während die Steuerelemente zum Ziehen und Ändern der Größe des Fensters wieder aktiviert werden.

  • Abhängig davon, welche Ansicht aktiv ist, werden hier andere Optionsmenüelemente angezeigt, mit denen du ändern kannst, wie die Ansicht Daten organisiert.


Gehe zu

Abb. 10.17 Menüleiste - Gehe zu Übersicht
  • Zurück - Navigiert durch die Auswahl der aktuellen Ansicht rückwärts zum vorherigen Element in deinem Navigationsverlauf
  • Vor - Navigiert durch die Auswahl der aktuellen Ansicht vorwärts zum nächsten Element in deinem Navigationsverlauf


  • Dynamische Liste der letzten 10 ausgewählten Datensätze (Personen, Familien usw.). Die Liste hängt von der angezeigten Kategorieansicht ab.
Gnome-important.png
Bekannter Fehler-Patch für Gramps Version 5.1.1 (behoben in Version 5.1.2)

Behebt das durch das letzte UIManager-Upgrade verursachte Durcheinander bei der Menüauswahl 'Gehe zu'
Gemeldet in Fehlerbericht: 11341 am 24. September 2019

Tango-Dialog-information.png
Du kannst das RestoreHist-Zusatzmodul eines Drittanbieters verwenden

Damit kann ein Teil des Gehe zu Menüs zwischen den Neustarts von Gramps beibehalten werden. Wenn installiert, kannst du den gespeicherten Status manuell löschen, indem du die Datei /gramps51/plugins/RestoreHist/hist_save.ini aus dem Anwenderverzeichnis (Ordner ~.gramps oder %Appdata% in Windows) suchst und löschst.



Lesezeichen

Abb. 10.18 Menüleiste - Lesezeichen Übersicht
  • Lesezeichen hinzufügen - Erstellt ein Lesezeichen aus dem aktuell ausgewählten Element, z.B.: Person, Familie usw..
  • Lesezeichen organisieren... - Öffnet das Fenster Lesezeichen organisieren.

  • Dynamischer Abschnitt, in dem die Lesezeichen angezeigt werden


Berichte

Abb. 10.19 Menüleiste - Berichte Übersicht
  • Bücher... - Mit dem Buchbericht kannst du ein benutzerdefiniertes Genealogiebuch erstellen, das eine Sammlung von Gramps-Text- und Grafikberichten in einem einzigen Dokument (z.B. Einem Buch) enthält.


Werkzeuge

Abb. 10.20 "Werkzeuge >..." Menüleiste - Werkzeuge Übersicht


Fenster

Abb. 10.21 Menüleiste - "Fenster" - Übersicht Beispiel
  • Fenster - Dieses Menü bietet schnellen Zugriff auf geöffnete Fenster, an denen du arbeitest.


Hilfe

Abb. 10.22 Menüleiste - "Hilfe" - Übersicht Beispiel
  • Benutzerhandbuch - Direkter Link zum Online-Gramps-Benutzerhandbuch, das du gerade anschaust. Ja, du benötigst eine Internetverbindung, um das Gramps-Benutzerhandbuch zu lesen.
  • Häufig gestellte Fragen - Ein Link zu den häufig gestellten Fragen zu Gramps.
  • Tastaturkürzel - Ein Link zur Tastenkürzel Referenz für Gramps.
  • Tip des Tages - Zeigt einen Dialog mit einem zufälligen Hinweis zur Verwendung der Gramps-Software an.
  • Zusatzmodulverwaltung - In diesem Menü kannst du die integrierten Module sowie alle von dir installierten Zusatzmodule von Drittanbietern verwalten.
  • Gramps Homepage - Dieses Element öffnet deinen Webbrowser und stellt eine Verbindung zur Gramps-Projektwebsite her.
  • Gramps Mailinglisten - Dieser Eintrag öffnet deinen Webbrowser für die Seite der Gramps-Mailingliste. Auf dieser Seite kannst du die Mailinglistenarchive durchsuchen und dich der Mailingliste der Gramps-Benutzer anschließen, um deine Erfahrungen mit anderen Gramps-Benutzern zu teilen.
  • Programmfehler melden - Wähle dieses Element aus, um einen Fehlerbericht im Gramps-Fehlerverfolgungssystem einzureichen. (Dazu musst du über ein registriertes Konto im Gramps-Fehlerberichterstattungssystem verfügen.) (Denke daran, dass Gramps ein lebendiges Projekt ist. Wir möchten alle auftretenden Probleme kennen, damit wir daran arbeiten können, sie für dich zu lösen, und alle anderen profitieren davon.)
  • Weitere Berichte/Werkzeuge - Ein Link zum Installieren von Zusatzmodulen von Drittanbietern in Gramps.
  • Info - Dieses Element zeigt einen Dialog mit allgemeinen Informationen zur von dir ausgeführten Gramps-Version an.

Werkzeugleiste

Abb. 10.23 Tipp für die Schaltfläche Werkzeuge in der Symbolleiste der Kategorie Dashboard

Die Werkzeugleiste ist ein horizontaler Satz von Schaltflächen, die sich direkt unter der Menüleiste befinden. Sie ermöglicht dir den Zugriff auf die am häufigsten verwendeten Funktionen von Gramps.

  • Die Auswahl der Werkzeugschaltflächen ist "kontextabhängig" - die angezeigten Symbole hängen davon ab, welche Kategorie Ansicht und welcher Ansichtsmodus aktiv ist
  • Wenn du den Mauszeiger über ein Symbol in der Symbolleiste bewegst, wird ein Hinweis auf dessen Funktion angezeigt.
  • Die Symbolleiste kann über die Option im Menü Ansicht ->Werkzeugleiste ein- oder ausgeblendet werden.
Tango-Dialog-information.png
Werkzeugleistenerweiterung im Themes-Drittanbieter-Zusstzmodul

Die Installation dieses Zusatzmodul von Drittanbietern ermöglicht es Gramps, Textbeschriftungen der Symbolleiste für jede Schaltfläche anzuzeigen. Das Zusatzmodul Themes erweitert den Voreinstellungsdialog um eine Registerkarte Thema.

Eine der Optionen auf der Registerkarte Thema ist das Kontrollkästchen Symbolleisten-Text. Wenn du das Kontrollkästchen aktivierst, werden die Textbeschriftungen angezeigt.
Dieses Kontrollkästchen ist standardmäßig deaktiviert.

Abb. 10.24 Optionen auf der Registerkarte "Thema" für den Dialog "Einstellungen" hinzugefügt.


Gemeinsame Schaltflächen in der Werkzeugleiste

Gramps.png Datenbanken verwalten

Abb. 10.25 Datenbanken verwalten - Symbol und Funktionshinweis in der Symbolleiste

Die 16x16-gramps-pedigree.png Schaltfläche ist die gleiche wie die Menüoption Stammbäume ▶ Stammbäume verwalten.... Der daraus resultierende Dialog ermöglicht das Umschalten zwischen den Bäumen (genealogischen Datenbanken),


Verbinden mit einer bestehenden Datenbank

Abb. 10.26 Schaltfläche "Mit einer bestehenden Datenbank verbinden" in der Werkzeugleiste

Diese Schaltfläche öffnet das Auswahlmenü Familienstammbäume ▶ Zuletzt geöffnet... in der Werkzeugleiste.


Gramps Go-Previous48x48 win.png Zum vorherigen Objekt in der Historie wechseln

Die Gramps Go-Previous48x48 win.png Schaltfläche in der Werkzeugleiste ist eine Alternative zur Menüoption Gehe zu ▶ Zurück oder zum Drücken der Tastenkürzel Zurück. Sie nutzt die historienbasierte Navigation, um den Fokus des aktiven Objekts auf das zuvor ausgewählte Objekt in dieser Kategorie zu verschieben.

Go-next48x48 win.png Zum nächsten Objekt in der Historie wechseln

Die Schaltfläche Go-next48x48 win.png in der Werkzeugleiste ist eine Alternative zur Menüoption Gehe zu ▶ Vor oder zum Drücken des Vor-Tastenkürzel. Sie verwendet die historienbasierte Navigation, um den Fokus des aktiven Objekts wiederherzustellen, der mit der Funktion Gehe zu ▶ Zurück verschoben wurde.

Diese Schaltfläche ist nur nach Verwendung der Funktion Gehe zu ▶ Zurück verfügbar.

Gramps Go-Home48x48 win.png Springe zur Hauptperson

Die Gramps Gramps Go-Home48x48 win.png Schaltfläche in der Werkzeugleiste ist eine Alternative zum Menüpunkt Gehe zu ▶ Anfang oder zum Drücken des Home-Tastenkürzel. Sie verschiebt den Fokus der Aktiven Person auf die Hauptperson.

Diese Schaltfläche ist nur funktionsfähig, wenn die Hauptperson eingestellt wurde.

Gramps Add48x48 win.png Neues ... hinzufügen

Die Schaltfläche STOCK_ADD in der Werkzeugleiste ist eine Alternative zum Menüpunkt Bearbeiten ▶ Hinzufügen... oder des Tastenkürzel Hinzufügen. Sie öffnet einen leeren Objekteditor, der der Objektkategorie der aktuellen Ansicht entspricht.

Photo-Tagging-Edit-icon.gif Das ausgewählte ... bearbeiten

Die STOCK_EDIT Schaltfläche ist eine Alternative zum Menüpunkt Bearbeiten ▶ Bearbeiten... oder zum Drücken des Tastenkürzel Bearbeiten. Sie öffnet einen Objekteditor für jedes ausgewählte Objekt in der Kategorieansicht.

Gramps Remove48x48 win.png Gewählte ... löschen

Die STOCK_REMOVE Schaltfläche in der Werkzeugleiste ist eine Alternative zur Menüoption Bearbeiten ▶ Löschen oder zum Drücken der Tastenkürzel Löschen. Sie öffnet einen Bestätigungsdialog zum Löschen.

Das Element, das gelöscht werden soll, wird identifiziert. Wenn mehrere Elemente ausgewählt wurden, erscheint für jedes ein Dialogfeld. Ein Kontrollkästchen bietet die Option "Diese Antwort für den Rest der Einträge verwenden".

Gramps Merge48x48 win.png Gewählte ... zusammenfassen

Diese Schaltfläche in der Symbolleiste ist eine Alternative zum Menüpunkt Bearbeiten ▶ Zusammenführen.... Sie öffnet den Zusammenführen-Dialog für diese bestimmte Kategorie von Datensätzen.

Die Schaltfläche Zusammenführen kann nur dann erfolgreich verwendet werden, wenn zwei (und nur 2) Datensätze in der Ansicht ausgewählt sind.

Gramps-tag.png Ausgewählte Zeilen markieren

Diese Schaltfläche in der Werkzeugleiste ist eine Alternative zum Untermenü Bearbeiten ▶ Markierung.

Die 16x16-gramps-tag.png Schaltfläche öffnet ein Aufklappmenü mit den folgenden Markierungsoptionen:

Es folgt eine Liste der aktuell verfügbaren Markierungen, die auf die ausgewählten Objekte in der Ansicht angewendet werden können.

Markierungen werden verwendet, um Zeilen in Listenansichten farblich zu kodieren, Markierungsfelder in einigen Diagrammen und dauerhafte Markierungen zum Filtern und Organisieren.

Gramps Clipboard48x48 win.png Öffnet den Zwischenablagedialog

Abb. 10.27 Zwischenablage - Dialog - Anzeigen (Rechtsklick) Kontextmenü

Diese Schaltfläche in der Werkzeugleiste ist eine Alternative zum Menüpunkt Bearbeiten ▶ Zwischenablage oder zum Drücken der Tastenkürzel Zwischenablage. Sie öffnet den Zwischenablage-Dialog, ohne das ausgewählte Objekt zu seiner Sammlung hinzuzufügen.

Gramps-config.png Die aktive Ansicht konfigurieren

Diese Schaltfläche in der Werkzeugleiste ist eine Alternative zur Auswahl des Menüpunkts Ansicht ▶ Konfigurieren... oder zum Drücken der Tastenkürzel Aktive Ansicht konfigurieren.

Die meisten Kategorieansichten haben ein ⚙ Konfigurierbare Optionen. Wenn Sie auf diese Schaltfläche klicken, öffnet sich der Dialog mit den Steuerelementen für die Anpassung dieser Optionen.

Diese Option öffnet ein Dialogfeld mit Auswahlmöglichkeiten für die Anzeige von Datensätzen in der Ansicht. (Das Dialogfeld enthält auch Registerkarten für alle Gramplets, die konfigurierbare Optionen haben, die in der Ansicht aktiv sind).

Gramps-reports.png Öffnet den Berichtsdialog

Abb. 10.28 Berichtsauswahl - Dialog

Dies ist eine dauerhafte Alternative zur Verwendung der Untermenüs Berichte.

Durch die Darstellung der verfügbaren Berichte in einem schwebenden Dialogfeld wird Raum für die Beschreibung der einzelnen Berichte, ihres Status und der Informationen für die Entwickler geschaffen. Der Dialog ermöglicht auch eine strukturiertere Erkundung der Berichte.

Gramps-tools.png Öffnet den Werkzeugdialog

Abb. 10.29 Werkzeugauswahl - Dialog

Dies ist eine dauerhafte Alternative zur Verwendung der Untermenüs Werkzeuge.

Indem die verfügbaren Werkzeuge in einem schwebenden Dialogfeld angezeigt werden, steht mehr Raum für die Beschreibung der einzelnen Werkzeuge, ihren Status und die Informationen für die Entwickler zur Verfügung. Der Dialog ermöglicht auch eine strukturiertere Erkundung der Werkzeuge.


Zurück Index Nächste
Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.
Außerdem verwende nur die Bekannten Drucktechnische Konventionen