De:Gramps 4.1 Wiki Handbuch - Werkzeuge

From Gramps
Jump to: navigation, search
Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.<br\> Außerdem verwende nur die Bekannten Drucktechnische Konventionen

Zurück Index Nächste




Dieses Kapitel beschreibt die verschiedenen Werkzeuge von Gramps.

Einleitung

Gramps Werkzeuge ermöglichen dir verschiedene Arten der Analyse deiner Genealogiedaten durchzuführen. Typischerweise erzeugen Werkzeuge keine Ausgaben in der Form von Ausdrucken oder Dateien. Stattdessen erzeugen sie Bildschirmausgaben die dem Forscher sofort zur Verfügung stehen. Allerdings kannst du, wenn es dienlich ist, die Ergebnisse eines laufenden Werkzeugs in einer Datei speichern. Werkzeuge sind eine der Hauptstärken von Gramps gegenüber den meisten anderen Genealogieprogrammen.

Auf die Werkzeuge kann über das Menü Werkzeuge ->Werkzeugabschnitt ->Jeweiliges Werkzeug zugegriffen werden. Alternativ kannst du die komplette Liste der verfügbaren Werkzeuge mit einer kurzen Beschreibung im Werkzeugauswahl Dialog, der über die Werkzeuge Schaltfläche in der Werkzeugleiste aufgerufen wird, durchsuchen.

Gramps-notes.png
Zusätzliche Werkzeuge

Mit Gramps 3.2 wurde ein neues System implementiert um sogar mehr Werkzeuge zur Verfügung zu haben. Dieses System wird über die Zusatzmodulverwaltung gesteuert. Die Zusatzmodulverwaltung kann zusätzliche Erweiterungen für dich holen.

Gemeinsame Optionen

  • id: = ID

Gramps ID der zentralen Person.

Analyse und Untersuchung

Dieser Abschnitt enthält Werkzeuge, die die Datenbank analysieren und untersuchen, sie aber nicht verändern. Die folgenden Analyse- und Untersuchungswerkzeuge stehen aktuell in Gramps zur Verfügung:

Einzelne Ereignisse vergleichen

Dieses Werkzeug vergleicht quer über die gewählte Gruppe von Personen. Die Personen für diesen Vergleich werden durch die Verwendung von Anwenderfilter definiert. Die Anwenderfilter können im Anwenderfiltereditor (siehe Anwenderfiltereditor), welcher über die Schaltfläche Anwenderfiltereditor aufgerufen werden kann, erstellt werden. Die von diesem Werkzeug erstellte Tabelle kann als Datei zur Verwendung in einem Tabellenkalkulationsprogramm gespeichert werden.

Stammbaumverarbeitung

Dieser Abschnitt enthält Werkzeuge die deine Daten ändern können. Die Werkzeuge aus diesem Abschnitt werden Hauptsächlich dazu verwendet Fehler in den Daten zu finden und zu beheben. Die folgenden Stammbaumverarbeitungswerkzeuge stehen aktuell in Gramps zur Verfügung:

Gramps-notes.png
Hinweis

Die Änderungen werden außer bei den automatischen Fehlerkorrekturen durch das Datenbank überprüfen und reparieren Werkzeug erst nach deinem ausdrücklichen Einverständnis durchgeführt.

Datenbankeigner Informationen bearbeiten

Abb. 12.1 Eignerinformation

Klicken von Werkzeuge-->Stammbaumverarbeiung-->Datenbankeigner Informationen bearbeiten öffnet das Datenbankeignereditor Fenster, in das du die benötigten Informationen eingeben kannst.

  • Name:
  • Straße:
  • Lokation:
  • Ort:
  • Bundesland/Kreis:
  • Land:
  • PLZ/Postleitzahl:
  • Telefon:
  • E-Mail:

Diese Information ist stammbaumspezifisch und wird verwendet, wenn du deine Daten im GEDCOM Format exportierst.


Ereignisarten umbenennen

Abb. 12.2 Art ändern

Dieses Werkzeug erlaubt das umbenennen aller Ereignisse mit einem bestimmten Namen in einen neuen Namen.


Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, dass du keine Änderungen dieses Werkzeugs oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern, so dass du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Das Ereignisdaten ändern Fenster wird angezeigt. Dieses Werkzeug ändert alle Ereignisse einer Art in eine andere Art.

  • Ursprüngliche Ereignisart: schreibe in das Textfeld oder verwende das Aufklappmenü, um eine originale Ereignisart zu wählen.
  • Neue Ereignisart: Schreibe in das Textfeld (du kannst hier eine völlig neue Art erstellen) oder verwende das Aufklappmenü, um eine neue Art zu wählen.

Zum Abschluss verwende die Abbrechen oder OK Schaltfläche.

Gnome-important.png
Ereignisarten umbenennen

Wenn es einmal abgeschlossen ist, kann es nicht mit der üblichen Rückgängig Funktion rückgängig gemacht werden.


Ereignisbeschreibung extrahieren

Extrahiert Ereignisbeschreibungen aus Ereignisdaten nach folgendem Schema:

{Ereignistyp} von {Familienname}, {Vorname}

Wenn eine Ereignisbeschreibung fehlt, füllt dieses Werkzeug das Feld nach oben genanntem Schema.


Extrahiere Ortsdaten aus Ortstitel

Abb. 12.3 Ortsdaten extrahieren

Dieses Werkzeug versucht Ort, Staat/Provinz und Postleitzahl aus dem Ortstitel zu extrahieren.

Das Werkzeug arbeitet mit Orten bei denen alle Felder der Hauptlokation leer sind.


Die Beschreibung muss folgenden Kategorien entsprechen:

New York, NY 10000

Nur verfügbar für:

  • USA
  • Kanada
  • Schweden
Stockholm (A)
  • Frankreich
Paris, IDF 75000, FRA oder Paris, ILE DE FRANCE 75000, FRA

Der Dialog ermöglicht dir einzelne Änderungen vorher anzuschauen und zu bestätigen.

Finde mögliche doppelte Personen

Abb. 12.4 Finde mögliche doppelte Personen - Dialog - Optionen
Abb. 12.5 Finde mögliche doppelte Personen - Mögliche Zusammenführungen - Ergebnisfenster

Dieses Werkzeug durchsucht die gesamte Datenbank auf der Suche nach Einträgen die der selben Person entsprechen könnten.

Du kannst auf dieses Werkzeug über Werkzeug->Datenbankverarbeitung->Finde mögliche doppelte Personen... zugreifen.

Zwei Optionen sind verfügbar:

  • Vergleichsschwellwert wähle zwischen Niedrig(Standard) Mittel und Hoch aus dem Aufklappmenü.
  • Optionen: ein Kontrollkästchen aktiviert oder deaktiviert die Verwendung von Soundex Code für mögliche übereinstimmende Personen.

Es gibt nur drei Schaltflächen Hilfe bringt dich auf diese Seite, Abbrechen zum Beenden der Verarbeitung und OK zum Start der Verarbeitung der Daten.

Wenn du auf die OK Schaltfläche klickst, werden die Daten in zwei Durchgängen verarbeitet.

  • Durchgang 1: vorläufige Listen erstellen
  • Durchgang 2: mögliche Übereinstimmungen berechnen.

Es wird ein Fortschrittsbalken angezeigt und abhängig von der Geschwindigkeit deines Rechners und der Anzahl der Personen in deiner Datenbank kann dies eine Weile dauern.

Zum Schluss wird ein Mögliche Zusammenführungen Fenster angezeigt. Dieses Fenster enthält eine Liste mit drei Spalten:

  • Bewertung: dies gibt dir eine Vorstellung von der Ähnlichkeit der beiden Personen. Je höher die Bewertung desto größer ist die Wahrscheinlichkeit, das diese Personen identisch sind.
  • Erste Person
  • Zweite Person

Wenn du eine Zeile auswählst, kannst du die Details mit der Vergleichen Schaltfläche überprüfen oder du kannst die gewählte Zeile doppelklicken.

Das Fenster besitzt drei Schaltflächen: Hilfe bringt dich auf diese Seite, Schließen um das Fenster zuschließen, was dich zurück zu dem Mögliche doppelte Personen finden Fenster bringt und eine Vergleichen Schaltfläche die ein Personen vergleichen Fenster öffnet, welches in Personen zusammenfassen im Detail beschrieben wurde. Hier kannst du mit den Optionsschaltflächen eine der Personen wählen und eventuell die Zusammenfassen und schließen Schaltfläche verwenden um die Daten zusammenzufassen wenn du herausgefunden hast, das diese Personen identisch sind.

Klicken auf die Abbrechen Schaltfläche bringt dich zurück zu der Liste.


Fundstellen zusammenfassen


Großschreibung von Nachnamen korrigieren

Abb. 12.6 Großschreibung korrigieren

Dieses Werkzeug durchsucht die gesamte Datenbank und versucht die Großschreibung von Familiennamen zu korrigieren.

Das Ziel ist es, eine übliche Groß/Kleinschreibung zu erreichen: erste Buchstabe groß und die restlichen Buchstaben des Familiennamens klein. Wenn Abweichungen von dieser Regel festgestellt werden, werden die Kandidaten für die Korrektur in der Tabelle angezeigt.

Du kannst dann entscheiden, welche wie vorgeschlagen korrigiert werden sollen und welche nicht.

Du kannst dieses Werkzeug über Werkzeuge->Stammbaumverarbeitung->Großschreibung von Nachnamen korrigieren... aufrufen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Du kannst wählen zwischen Abbrechen und Mit dem Werkzeug fortfahren.

Wenn es Änderungen in der Großschreibung von Namen gab, wird das Änderungen der Großschreibung Fenster geöffnet. Das Fenster zeigt eine Liste von Familiennamen die Gramps in die korrekte Schreibweise ändern kann. In der Liste siehst du drei Spalten: Auswählen Kontrollkästchen, Ursprünglicher Name und Änderungen der Großschreibung.

Wähle die Namen, die du ändern möchtest dann klicke auf die Änderungen akzeptieren und schließen Schaltfläche. Oder verwende die Abbrechen Schaltfläche um die Änderungen zu verwerfen.


Du kannst auch das "Großschreibung von Vornamen korrigieren" Werkzeugzusatzmodul installieren es arbeitet nahezu identisch wie dieses Werkzeug aber für "Vornamen".


Informationen aus Namen extrahieren

Dieses Werkzeug durchsucht die gesamte Datenbank und versucht Titel und Spitznamen die in dem Vornamenfeld einer Person enthalten sein können zu extrahieren. Wenn irgendeine Information extrahiert werden konnte, werden die Kandidaten für eine Korrektur in einer Tabelle dargestellt. Du kannst dann entscheiden welche wie vorgeschlagen korrigiert werden und welche nicht.

Du kannst auf dieses Werkzeug über das Menü Werkzeuge->Stammbaumverarbeitung->Informationen aus Namen extrahieren.... zugreifen.

Die Bearbeitungschronik zurücksetzen Warnung wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Abb. 12.7 Standard Präfix und Verbinder einstellen - Dialog

Der Standard Präfix und Verbinder einstellen - Dialog wird gezeigt und du kannst jede Option wie benötigt ändern, wenn du fertig bist, wähle OK um das Werkzeug zu starten, es wird eine Extrahiere Informationen aus Namen Fortschrittsanzeige angezeigt.


Abb. 12.8 Auszug von Name und Titel Werkzeug - Ergebnisdialogfenster

Anschließend wird das Auszug von Namen und Titeln - Ergebnisdialogfenster angezeigt.


Ordne Gramps-IDs neu

Das Werkzeug Gramps-IDs neu ordnen ändert alle Elemente in der Datenbank so das ihre IDs den vorgegebenen Schema in Präferenzen Datenbank IDs entsprechen.

Du kannst diese Vorgaben unter Bearbeiten->Präferenzen... und dann im ID-Formatreiter ändern.

Du kannst dieses Werkzeug über das Menü Werkzeuge->Stammbaumverarbeitung->Gramps-IDs neu ordnen aufrufen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Das Fenster zeigt einen Fortschrittsbalken.

In verschiedenen Schritten werden die folgenden IDs neu geordnet: Neuordnung Personen IDs, Neuordnen Familien IDs, Neuordnen Ereignis IDs, Neuordnen Medionobjekt IDs, Neuordnen Quellen IDs, Neuordnen Fundstellen IDs, Neuordnen Orte IDs, Neuordnen Aufbewahrungsorte IDs und zum Schluss Neuordnen Notiz IDs.

In einem nächsten Schritt werden unbenutzte IDs gesucht und zugeteilt.

Gnome-important.png
Anwender IDs

Wenn du deine IDs angepasst hast, werden all diese Änderungen durch die Standardeinstellungen überschrieben. Pass also auf bevor du dieses Werkzeug anwendest!

Sortiert Ereignisse

Abb. 12.9 Ereignisse sortieren

Ereignisse im Ereignisreiter vom Personen und Familieneditor erscheinen in keiner bestimmten Reihenfolge außer in der Reihenfolge in der sie hinzugefügt wurden. Der Grund warum die Ereignisse nicht auf eine bestimmte Art wie zum Beispiel nach Datum sortiert werden, ist das ein Ereignis eingeordnet werden kann auch wenn kein genaues Datum oder Reihenfolge bekannt sind. Der Import oder das Zusammenfassen von Daten aus einer externen Quelle kann auch zu zusätzlich hinzugefügten Ereignissen, die außerhalb der Reihenfolge bestehender Ereignisse einer Person oder Familie liegen führen.

Ereignisse können manuell via Drag & Drop oder durch Verwendung der neu-ordnen Schaltflächen im Ereignisse Reiter neu angeordnet werden. So oder so kann ein Ereignis in der Ereignisliste hoch oder runter bewegt werden und Gramps merkt sich die neue Anordnung, wenn die Änderungen gespeichert werden. Die neue Reihenfolge wird überall dort verwendet, wo Ereignisse in Gramps angezeigt werden zum Beispiel in einem Bericht.

Die Reihenfolge von allen Ereignissen in einem Reiter kann auch durch klicken auf den Spaltentitel geändert werden. Zum Beispiel klicken auf den 'Datum' Spaltentitel sortiert alle Ereignisse nach Datum. Jedoch ist diese Art der Sortierung nicht von Dauer beim Schließen des Fensters werden diese Änderungen rückgängig gemacht.

Die Drag & Drop Methode zum Sortieren von Ereignissen ist gut wenn eine kleine Anzahl sortiert wird aber für große Mengen ungeeignet. Das Ereignisse sortieren Werkzeug wurde speziell für diesen Zweck entwickelt, alle Ereignisse in der Datenbank neu sortieren oder nur jene die mit über einen Filter ausgewählten Personen zusammenhängen.

Die erste Option im Ereignisse sortieren Fenster wird verwendet um die Auswahl der Personen, deren Ereignisse sortiert werden, festzulegen. Die erste Möglichkeit in der Liste ist, alle Personen der Datenbank zu sortieren. Alternative Möglichkeiten sind die Sortierung auf Vorfahren oder Nachkommen einer bestimmten Person oder eine Reihe von Personen aus einem vom Anwender erstellten Filter anzuwenden. Nach der Wahl, wen die Sortierung betreffen soll, ist der nächste Schritt festzulegen, wie die Ereignisse sortiert werden sollen. Die erste Möglichkeit ist, sie nach dem Datum zu sortieren,. Das ist wohl die wahrscheinlichste Auswahl, es können aber auch andere Ereigniseigenschaften ausgewählt werden. Die letzten Auswahlen betreffen die Sortierreihenfolge (aufsteigen oder absteigend) und ob die zur Person gehörenden Familienereignisse auch sortiert werden sollen.


Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Stammbaumreparatur

Datenbank prüfen und reparieren

Dieses Werkzeug überprüft die Datenbank auf Integritätsprobleme und behebt sie wenn es ihm möglich ist. Im Besonderen sucht es nach:

  • Kaputten Familienverknüpfungen. Dies sind die Fälle in denen ein Personendatensatz auf eine Familie verweist, der Familiendatensatz aber nicht auf die Person verweist und umgekehrt.
  • Fehlende Medienobjekte. Das fehlende Medienobjekt ist das Objekt dessen Datei in der Datenbank verknüpft ist aber nicht existiert. Dies kann passieren wenn eine Datei versehentlich gelöscht, umbenannt oder an einen anderen Ort verschoben wird.
  • Leere Familien. Dies sind die Familieneinträge die keine Verknüpfungen zu Personen als ihre Angehörige besitzt.
  • Elternbeziehung. Dies überprüft alle Familien um sicherzustellen, das Vater und Mutter nicht verwechselt wurden. Der Test überprüft auch ob die Eltern ein unterschiedliches Geschlecht haben. Wenn sie das gleiche Geschlecht haben, wird die Beziehung in "Partner" umbenannt.

Geschlechtsstatistik neu erstellen

Erstellt die Statistiken, zur Bestimmung des Geschlechts anhand des Namen, neu...

Interne Referenzen neu erstellen

Dieses Werkzeug erstellt die Referenz Abbildtabellen neu (Referenzen Elemente in Editoren).

Neuaufbau sekundäre Indexe

Dieses Werkzeug erstellt die sekundären Indices neu.

Unbenutzte Objekte entfernen

Dieses Werkzeug durchsucht deine Datenbank nach nicht verwendeten Informationen und entfernt diese anschließend.

Werkzeuge

Dieser Abschnitt enthält Werkzeuge die es dir ermöglichen einfache Transaktionen mit einem Teil der Daten durchzuführen. Die Ergebnisse können in deiner Datenbank gespeichert werden, sie ändern aber nicht deine bestehenden Daten. Die folgenden Werkzeuge stehen aktuell in Gramps zur Verfügung:


Die Daten überprüfen

Abb. 12.10 Die Daten überprüfen

Dieses Werkzeug ermöglicht dir die Überprüfung der Datenbank auf der Grundlage einer Reihe von dir festgelegter Kriterien.

Zum Beispiel, du willst sicherstellen, das keiner in deiner Datenbank im Alter von 98 Kinder bekam. Nach gesundem Menschenverstand würde ein solcher Datensatz auf einen Fehler hinweisen. Jedoch ist dies kein Konsistenzfehler in der Datenbank. Außerdem könnte jemand im alter von 98 ein Kind bekommen haben (das ist wirklich passiert). Das überprüfen Werkzeug zeigt alles, was deine Kriterien verletzt, so das du überprüfen kannst, ob der Datensatz fehlerhaft ist oder nicht. Du triffst die endgültige Entscheidung.

Über das Menü Werkzeuge->Werkzeuge->Die Daten überprüfen... erhälts du das Daten überprüfen Fenster. Das Fenster enthält vier Reiter; Allgemeines, Frauen, Männer und Familien. Diese Reiter enthalten eine Liste von Kriterien und Eingabefelder in denen du die Werte für die Kriterien ändern kannst. In den Listen unten stehen einige brauchbare Werte.

Allgemeines

  • Maximales Alter: 95
  • Minimales Alter bei Heirat: 16
  • Maximales Alter bei Heirat: 60
  • Maximale Anzahl von (Ehe-)Partnern pro Person: 4
  • Maximale Anzahl aufeinander folgender Jahre der Witwenschaft, vor der nächsten Hochzeit: 30
  • Maximales Alter für eine unverheiratete Person: 99

Es gibt zwei Kontrollkästchen:

  • Fehlende oder ungenaue Daten schätzen.

Dies bewirkt, dass das Werkzeug das Taufdatum übernimmt, wenn das Geburtsdatum unbekannt ist und das Beerdigungsdatum übernimmt, wenn das Todesdatum unbekannt ist. Zusätzlich akzeptiert es ab Gramps auch "ungenaue" Daten (z.B. jedes "legale" Gramps Datum, welches kein komplett aufgeführtes Datum ist (mit explizitem Tag und Monat und Jahr)).

  • Ungültige Daten erkennen

Frauen

  • Mindestalter bei der Geburt eines Kindes: 16
  • Maximales Alterbei der Geburt eines Kindes: 51
  • Maximale Anzahl von Kindern: 15

Männer

  • Mindestalter um Vater zu werden: 18
  • Maximales Alter um Vater zu werden: 65
  • Maximale Anzahl von Kindern: 15

Familien

  • Maximale Altersunterschied zwischen Mann und Frau: 41
  • Maximale Altersunterschied zwischen Kindern: 11
  • Maximaler Zeitraum für die Geburt aller Kinder: 32

Wenn du mit den Kriterien zufrieden bist, klicke auf die Ausführen Schaltfläche oder drücke Alt+R und es wird dir ein {{man label|Daten prüfen Ergebnisse} Fenster gezeigt.

Abhängig von deinen Kriterien und Daten wird dir eine Liste angezeigt. Einige Möglichkeiten was gefunden werden kann siehst du unten. Es gibt aber auch andere.

  • Personen ohne Verbindungen (solche ohne Eltern, Partnern, Kindern oder Geschwister)
  • alter/toter Vater
  • Heirat nach Tod/ vor Geburt
  • Großer Zeitraum für alle Kinder
  • frühe/späte Heirat
  • junge/ungeborene Mutter
  • Mann und Frau mit dem selben Nachnamen
  • Homo Ehe / weiblicher Ehemann
  • ...

Um zu zeigen, wie praktisch dieses Werkzeug ist, hier zwei Beispiele von echten Daten:

Die Warnung zeigt 'weiblicher Ehemann': Beim Überprüfen der Daten fand ich eine Familie mit dem Vater: Anna Roelants. Glücklicherweise las ich in der Beschreibung: Die Hochzeit von Adam Roelants und Cornelia Crabbe. Es war also klar ein Tippfehler: Anna anstatt Adam. Ohne dieses Werkzeug wäre dies schwer zu finden.
Die Warnung zeigt 'späte Heirat': Überprüfung der Daten: männliche Person °1738 weibliche Person °1756 : Heirat X 1804 [Gregorian Calender|Gregorianischer Kalender] : Alles scheint OK. zu sein: Sie heirateten im alter von 66 und 48 Jahren! Die Warnung wurde gezeigt, weil die Allgemeinen Kriterien auf 60 gesetzt waren.

Im unteren Bereich des Fensters stehen vier Kontrollkästchen zur Verfügung, um die Auswahl zu vereinfachen. Diese sind: Alles markieren, Markierungen aufheben, Markierungen invertieren und Markierte ausblenden.

Doppel klicken auf eine Zeile gibt dir die Möglichkeit, die Daten anzuschauen und oder zu bearbeiten.

Mit der Schließen Schaltfläche oder dem Tastenkürzel Alt+C schließt du das Ergebnisse Fenster.

Über die Hilfe Schaltfläche oder das Tastenkürzel Alt+H gelangst du auf diese Seite.

Gnome-important.png
Unterschied zwischen Vergleichen Werkzeug und dem oben beschriebenen prüfen und reparieren

Das prüfen und reparieren Werkzeug entdeckt Inkonsistenzen in der Datenbankstruktur. Das Daten überprüfen Werkzeug entdeckt jedoch die Datensätze, die nicht deinen speziellen Kriterien entsprechen.



Medienverwaltung

Abb. 12.11 Endgültige Bestätigung Fenster

Dieses Werkzeug ermöglicht Stapelverarbeitungen an in Gramps gespeicherten Medienobjekten. Eine wichtige Unterscheidung muss gemacht werden, zwischen einem Gramps Medienobjekt und seiner Datei.

Das Gramps Medienobjekt ist eine Sammlung von Daten über die Medienobjektdatei: ihr Dateiname und/oder Pfad, ihre Beschreibung, ihre ID, Notizen, Quellenreferenzen, usw. Diese Daten enthalten nicht die Datei selbst.

Die Dateien, die Bilder, Klänge, Videos, usw. enthalten liegen separat auf deiner Festplatte. Diese Dateien werden nicht von Gramps verwaltet und sind nicht in der Gramps Datenbank enthalten. Die Gramps Datenbank speichert nur die Pfade und Dateinamen.

Dieses Werkzeug ermöglicht dir nur das Ändern der Datensätze in deiner Gramps Datenbank. Wenn du die Dateien verschieben oder umbenennen willst, muss du dies selbst außerhalb von Gramps erledigen. Dann kannst du die Pfade mit Hilfe dieses Werkzeugs korrigieren so das die Medienobjekte die korrekten Speicherorte der Dateien speichern.

Wenn du auf die Weiter Schaltfläche klickst (oder die Tastenkombination Alt+F verwendest), kommst du zu einem Fester mit drei Optionsfeldern:

  • Zeichenketten im Pfad ersetzen: Die Auswahl dieses Optionsfeldes, öffnet ein Zeichenkette ersetzen Einstellungen Fenster, wo du jede Zeichenkette in das Ersetzen und das Durch Textfeld eingeben kannst. Du kannst jederzeit auf die Abbrechen oder Zurück Schaltfläche klicken. Klicken auf die Weiter Schaltfläche öffnet das Endgültige Bestätigung Fenster.
  • Pfade von relativ nach absolut konvertieren
  • Pfade von absolut nach relativ konvertieren


Nicht verwandt

Abb. 12.12. Nicht verwandt

Dieser Bericht findet Personen, die nicht mit der ausgewählten Person verwandt sind. Du kannst diese Ansicht über Werkzeug->Werkzeuge->Nicht verwandt... öffnen.

Es öffnet sich ein Nicht verwandt mit '...' Fenster, welches eine Liste aller NICHT mit der gewählten Person verwandten Personen enthält.

Diese Liste enthält:

  • Name
  • ID
  • Eltern
  • Markierungen

Doppel klicken auf eine Person öffnet das Person bearbeiten oder Familie bearbeiten Fenster.

Wenn du eine Person wählst, kannst du das Marke Feld verwenden: Es gibt 3 Möglichkeiten: leer (du kannst reinschreiben was du willst), Zu erledigen, Nicht verwandt. Mit der Anwenden Schaltfläche kannst du die gewählte Marke der Person zuordnen. Diese Marke wird dann in der rechten Spalte angezeigt.


Verwandtschaftsrechner

Abb. 12.13 Verwandtschaftsrechner

Der Verwandtschaftsrechner öffnet, wenn er gestartet wird, eine Liste mit alle Personen, die mit der in der Personenansicht gewählten Person verknüpft, aber nicht unbedingt verwandt sind. Du wählst einfach die Person, über die du Informationen über die Verwandtschaft bekommen möchtest, und die Verwandtschaft wird im unteren Bereich angezeigt. Es werden nur Blutsverwandtschaften (außer bei Mann-Frau Beziehungen) angezeigt. Momentan können keine "verschwägert" Beziehungen angezeigt werden.

Prinzipiell sind zwei Personen miteinander verwandt, wenn sie einen gemeinsamen Vorfahren besitzen. Eine dieser Personen kann auch ein Vorfahre der anderen sein - wie eine Urgroßmutter. Auch bei Tanten und Onkeln kannst du die Verwandtschaft durch finden des gemeinsamen Vorfahren berechnen. In diesem Fall ist der Vater oder die Mutter der Tante oder des Onkels ein Großelternteil der Nichte oder des Neffen.

Prinzipiell sind Geschwister (Brüder und Schwestern) nur eine Generation unter den gemeinsamen Vorfahren. Cousins und Kusinen befinden sich zwei Generationen unter den gemeinsamen Vorfahren. Cousins und Kusinen zweiten Grades befinden sich drei Generationen unter den gemeinsamen Vorfahren - und so weiter. Wenn sich die zwei Personen aber in unterschiedlichen Generationen befinden, wird die Beziehung eine Tante oder ein Onkel, wenn sich diese Person nur eine Generation unter den gemeinsamen Vorfahren befindet. Das Gegenstück zu Tante und Onkel ist Nichte und Neffe.

Danach wird jeder als "Cousin(e)" angesehen um aber anzuzeigen, das sie sich nicht in der selben Generation befinden, verwenden wir das Wort "entfernt" um die Anzahl unterschiedlicher Generationen zwischen den beiden anzuzeigen. Zum Beispiel, Der Cousin ersten Grades meines Vaters ist auch der Cousin ersten Grades von mir aber "eins entfernt" (eine Generation Unterschied zwischen uns). Der Cousin ersten Grades ist von meinen Kindern "Cousin ersten Grades zwei entfernt" - zwei Generationen Unterschied.

Eine Volltextliste aller Blutsverwandtschaften und ihrer Partner kann sich durch Verwendung einer Verwandtschaftsliste anzeigen lassen.


Zurück Index Nächste