Difference between revisions of "De:Gramps 4.0 Wiki Handbuch - Was ist neu?"

From Gramps
Jump to: navigation, search
Line 54: Line 54:
 
 
 
=== Zu erledigen Gramplets ===
 
=== Zu erledigen Gramplets ===
Objects and the Dashboard now have a To Do gramplet, listing all the notes which have been indicated as with Note Type To Do. Neu: zu erledigen Notizen können direkt aus dem Gramplet erstellt werden.
+
Objekte und das Dashboard haben jetzt ein zu erledigen Gramplet, es listet alle Notizen, welchen von dem  Notiztyp zu erledigen sind. Neu: zu erledigen Notizen können direkt aus dem Gramplet erstellt werden.
  
 
== Ansichten ==
 
== Ansichten ==
Line 80: Line 80:
 
== Code Reorganisation ==
 
== Code Reorganisation ==
  
Gramps now has completed the code reorganization, making the code structure of Gramps much more cleaner.
+
Die Reorganisation des Code ist jetzt in Gramps abgeschlossen, welches die Struktur von Gramps viel klarer macht.
  
 
== Python basierte Installation ==
 
== Python basierte Installation ==
Line 89: Line 89:
 
  python setup.py install
 
  python setup.py install
  
See the INSTALL and README file for details. This means that once you installed gramps, you can use the code as a standard python module, eg:
+
Für Details siehe die INSTALL und README Datei. Dies bedeutet, wenn du Gramps installiert hast, kannst du den Code als Standardpythonmodul verwenden z.B.:
  
  from gramps.gen.lib.date import Date
+
  aus gramps.gen.lib.date import Date
  
to use the date computations as used by Gramps.
+
um die Datumsberechnungen wie in Gramps zu verwenden.
  
 
==Kommandozeilenschnittstelle==
 
==Kommandozeilenschnittstelle==
Line 99: Line 99:
 
= Weitere Informationen =
 
= Weitere Informationen =
  
== Roadmap ==
+
== Fahrplan ==
  
 
* [[Roadmap]]: [http://www.gramps-project.org/bugs/roadmap_page.php?version_id=34 4.0.0], [http://www.gramps-project.org/bugs/roadmap_page.php?version_id=25 trunk]
 
* [[Roadmap]]: [http://www.gramps-project.org/bugs/roadmap_page.php?version_id=34 4.0.0], [http://www.gramps-project.org/bugs/roadmap_page.php?version_id=25 trunk]

Revision as of 07:46, 14 February 2013

Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.<br\> Außerdem verwende nur die Bekannten Drucktechnische Konventionen

Zurück Index Nächste


Dieser Abschnitt gibt dir einen Überblick über die Änderungen seit Version 3.4. Diese Änderungen sind auch detailliert weiter hinten hier im Handbuch enthalten. Anwendern von Gramps Version 3.4 wird empfohlen, die Änderungen durchzusehen, um keine neuen Möglichkeiten zu übersehen.

Bevor du aktualisierst

Gnome-important.png
Warnung

Das Erstellen eines Archivs zum Sichern deiner Daten vor einer Aktualisierung könnte nicht ausreichend sein. In dem unwahrscheinlichen Fall, dass Gramps 4.0 deine Datenbank beschädigt, kann auch das Archiv verloren gehen. Ein Export wie in diesem Kapitel beschrieben wird empfohlen.

Bevor du aktualisierst, stelle sicher, dass du eine Sicherung deiner Stammbaumdaten besitzt. Die beste Möglichkeit dies zu tun ist folgende:

  1. starte Gramps 3.4
  2. öffne deinen Stammbaum
  3. exportiere den Stammbaum in das gramps xml Format oder das gramps xml Paket Format (enthält deine Mediendateien). Dies geht über das Menü Stammbäume->Export, stelle sicher, dass du alle Daten exportierst, schränke den Datenexport in keiner Weise ein.
  4. Schließe den Stammbaum und wiederhole die obigen Schritte mit all deinen Stammbäumen
  5. Bewahre die resultierende(en) Datei(en) an einem sicheren Ort auf

Für mehr Informationen siehe Einen Stammbaum sichern.

Nachdem du deine Daten gesichert hast, installiere Gramps 4.0. Verwende hierfür den für dein Betriebssystem vorgesehenen Prozess. Es wird auch empfohlen Gramps 3.4 vor der Installation von Gramps 4.0 zu deinstallieren oder stelle sicher, dass du Gramps 4.0 in einem anderen Verzeichnis installierst.

Nachdem du Gramps 4.0 installiert hast, kannst du direkt deine alten Stammbäume öffnen und mit der Arbeit fortfahren. Im Falle von Problemen (z.B. nach einer kompletten Systemaktualisierung), verwende die Sicherungsdatei, die du weiter oben erstellt hast um deinen Stammbaum wieder herzustellen.

Gnome-important.png
Achtung

Wenn du einmal einen Stammbaum mit einer neueren Version von Gramps geöffnet hast oder ein neueres Betriebssystem verwendest, solltest du generell nicht mehr versuchen diese Datenbank wieder mit einer älteren Version zu öffnen. Wie immer ist das Gramps-XML Format das Format für den Datenaustausch in solchen Fällen. Es gibt Werkzeuge um eine beschädigte Datenbank zu reparieren, die aber nur für erfahrene Anwender sind, also vermeide den Gebrauch durch Befolgen der obigen Schritte vor der Aktualisierung von Gramps oder deines Betriebssystems.

Sichtbare Änderungen am Kern

Die Änderungen von Gramps 3.4 zu Gramps 4.0 wurden auf ein Minimum reduziert da Gramps 4.0 eine Technologieupgradeveröffentlichung ist, keine Anwenderfunktionalitätverbesserung Veröffentlichung. Stammbäume in 3.4 und 4.0 sind identisch, ein Stammbaum kann also (vorausgesetzt es wird die identische Datenbanksoftware eingesetzt) ohne Aktualisierung oder Herabstufung mit beiden Versionen geöffnet werden.

Nichts desto trotz sind einige Änderungen nach der Umstellung erkennbar:

Das Dashboard

Die Grampletansicht wurde in Dashboard (Armaturentafel) umbenannt. Um eine zu häufige Verwendung des Wortes Gramplet zu vermeiden und um neuen Anwendern deutlicher zu machen, was sie von dieser Ansicht erwarten können.

Erscheinungsbild

Gramps verwendet jetzt GTK 3 für die Oberfläche du musst also ein GTK Thema mit dem GTK Themen Auswahlprogramm setzen, welches GTK 3 unterstützt. Wenn Gramps nach der Installation hässlich aussieht, liegt das daran, das du ein altes GTK Thema verwendest. Probiere einige GTK 3 Themen aus, um zu sehen welches dir in Gramps am besten gefällt.

Datenmodell

Es gibt keine Änderungen am Datenmodell. Eine mit Gramps 4.0 erstellte .gramps XML Datei ist identisch mit der von Gramps 3.4.

Zusatzmodule Änderungen

Alles über Zusatzmodule: Import/Export, Gramplets, Ansichten, Berichte, Werkzeuge.


Berichte

ErzählendesWeb

Eine große Umstrukturierung hat bei den erzählenden Webseiten stattgefunden. Sie sollten insgesamt wesentlich stabiler laufen.

Zu erledigen Gramplets

Objekte und das Dashboard haben jetzt ein zu erledigen Gramplet, es listet alle Notizen, welchen von dem Notiztyp zu erledigen sind. Neu: zu erledigen Notizen können direkt aus dem Gramplet erstellt werden.

Ansichten

Fächergrafiken

In the Charts category (Previously called the Ancestry category), you will see two new core Charts: Fan Chart and Descendant Fan. These are two Charts that give you a good overview of a family tree. The Fan charts shows the principal parents of every individual. The Descendant Fan shows you all children, all their families, and then so on to see the entire descendant tree.

The Fan Charts are powerfull, use the Configure button in the toolbar to investigate some posibilities:

  • colored filtering via filter sidebar
  • Gradient coloring to give extra information
  • Print to output (pdf, printer) from the toolbar

Werkzeuge

Keine Neuerungen

Änderungen unter der Haube

Technischer Kram

Python 3 Unterstützung

Gramps unterstützt Python 2.7+ und Python 3.2+ ab Version 4.0. Wir empfehlen wenn möglich Python 3.2 zu verwenden. Um beide Versionen zu unterstützen läuft mancher Code langsamer unter Python 2.x.

Code Reorganisation

Die Reorganisation des Code ist jetzt in Gramps abgeschlossen, welches die Struktur von Gramps viel klarer macht.

Python basierte Installation

Gramps has deprecated the use of autotools for installation, and now uses a python based installation. As a user you are advised to a package installer to install Gramps. Those installing from source code can do some now with the commands :

python setup.py build
python setup.py install

Für Details siehe die INSTALL und README Datei. Dies bedeutet, wenn du Gramps installiert hast, kannst du den Code als Standardpythonmodul verwenden z.B.:

aus gramps.gen.lib.date import Date

um die Datumsberechnungen wie in Gramps zu verwenden.

Kommandozeilenschnittstelle

Weitere Informationen

Fahrplan

Änderungsprotokoll

Zurück Index Nächste