De:Gramps 3.4 Wiki Handbuch - Navigation

From Gramps
Jump to: navigation, search
Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.<br\> Außerdem verwende nur die Bekannten Drucktechnische Konventionen

Zurück Index Nächste


Solange eine Datenbank geöffnet ist, konzentriert sich Gramps auf eine Person gewöhnlich bezieht sich das auf eine aktive Person. Dies ermöglicht dir Daten diese Person betreffend anzuschauen und zu bearbeiten, seine oder ihre direkte Familie, usw. Navigation in der Datenbank (z.B. wechseln von einer Person zu einer anderen Person) ist tatsächlich nichts anderes als die aktive Person zu ändern. Dieser Abschnitt beschreibt viele verschiedene Wege durch die Datenbank zu navigieren unter Verwendung beider, der komplexen und der praktischen Schnittstellen, die Gramps bietet. All diese Wege erreichen eventuell das Selbe, aber einige sind praktischer als andere, basierend darauf was du in Gramps in diesen Moment machst.

Die Personenansicht verwenden

Der intuitive Weg zur Auswahl einer aktiven Person, ist die Verwendung der Personenkategorie. Wenn du dich in der Personenansicht befindest, wähle einfach den Namen der gewünschten Person durch klicken auf den Listeneintrag aus der Liste. Die Person die du gewählt hast wird die aktive Person. Die Statusleiste wird aktualisiert um die Änderung der Aktiven Person widerzuspiegeln.

Die Familienansicht verwenden

Wenn du dich in der Beziehungenansicht befindest, kannst wie folgt ganz einfach zwischen den Mitgliedern der angezeigten Familie wechseln:

Klicke auf den unterstrichenen Namen der gewünschten Person und diese wird zur Hauptperson der Beziehungenansicht. Der Name der zur Zeit aktiven Person ist nicht unterstrichen.

Zusätzlich dazu bietet Gramps eine reichhaltige Möglichkeit mit Hilfe der Tastatur zu navigieren. Die detaillierte über die Tastenkürzel findet sich in der Tastenkürzel Referenz.

Die Ahnenansicht verwenden

Die Ahnenkategorie ermöglicht dir auch dich innerhalb des Stammbaum zu bewegen. Der Vorteil dieser Methode ist, das du mehr als eine Generation des Stammbaum sehen kannst. Außerdem kannst du vom Urenkel direkt zum Urgroßvater springen ohne durch die dazwischen liegenden Generationen zu gehen.

Beachte das nach dem wechseln der aktiven Person in der Ahnenansicht die Ansicht neu aufgebaut wird, um die eingestellte Anzahl von Generationen beginnend mit der neuen Hauptperson anzuzeigen. Wenn du dich in der Ahnenansicht befindest, kannst du wie folgt durch die Mitglieder des angezeigten Stammbaum navigieren:

Um eine angezeigte Person zur aktiven Person zu machen, rechts-klick in der entsprechenden Box und wähle den ersten Eintrag aus dem Kontextmenü.

Um ein Kind der aktuellen aktiven Person (wenn vorhanden) zur aktiven Person zu machen, klicke auf den Linkspfeil links neben der entsprechenden Box. Wenn es mehr als ein Kind gibt, klappt eine Liste auf mit allen Kindern aus denen gewählt werden kann.

Um den ganzen Stammbaum eine Generation nach hinten zu verschieben, klicke auf den entsprechenden Rechtspfeil an der rechten Seite des Anzeigebereichs. Klicken der oberen Schaltfläche bewegt den Baum entlang der väterlichen Linie. Klicken der unteren Schaltfläche bewegt den Baum entlang der mütterlichen Linie.

Klicken einer dieser Schaltflächen ist vollständig identisch mit doppelklicken der entsprechenden Verbindungslinien links neben den Boxen von Vater und Mutter.

Du kannst auch schnell auf alle Partner, Geschwister, Kinder oder Eltern jeder angezeigten Person zugreifen. Dafür gehe mit der Maus über die Box der gewünschten Person und öffne mit rechts-Klick ein Kontextmenü. Die entsprechenden Menüeinträge enthalten Untermenüs die alle Partner, Geschwister, Kinder und Eltern der dazugehörigen Person enthalten.

Gnome-important.png
Beispiel Ratschlag Vorteile der Verwendung von rechts-Klick Menüs

Direkter Zugriff auf Partner und Geschwister. Komplett alle Mitglieder aller Kategorien, nicht nur die bevorzugten Mitglieder.


Gramplets verwenden

Abb. Verwandtschaft Gramplet in der Personenansicht

Einige Gramplets bieten eine URI/URL Unterstützung (meistens die Standardfarbe für Web URL).

In der Seitenleiste und Fußleiste kannst du einige Gramplets wie diese aktivieren:

um die Möglichkeit zu erhalten, zu den Verwandten, Nachkommen oder Vorfahren der aktiven Person in dieser Ansicht zu navigieren.

Klicken auf einen Link ändert die aktive Person.


Die Startperson setzen

Eine und nur eine Person kann in der Datenbank als die Startperson gewählt werden. Wenn diese Person gewählt ist, kann man mit einem einzigen Klick zu dieser Person navigieren, egal in welcher Ansicht du dich gerade befindest.

Um die Startperson zu setzen, navigiere zuerst zu der Person wie ist egal. Dann gehe zur Personenkategorie und wähle Bearbeiten ->Hauptperson setzen. Wenn die Startperson gesetzt ist, kannst du jederzeit von überall in der Datenbank durch einfaches klicken auf die Start Schaltfläche in der Werkzeugleiste zu der Startperson navigieren. Du kannst auch Gehe zu ->Start aus dem Menü, den Start Eintrag aus jedem Kontextmenü welches mit rechts-Klick geöffnet wird oder das Tastenkürzel Alt+Home verwenden.

Verwendung verlaufbasierender Werkzeuge

Gramps bietet auch eine Reihe leistungsstarker verlaufbasierender Navigationswerkzeuge. Diese Werkzeuge ähneln denen , die normalerweise in in Webbrowsern verwendet werden.

Sie beinhalten Zurück und Vor Elemente vorhanden im Gehe zu Menü, Kontextmenüs (verfügbar in Personen-, Familien- und Vorfahrenansicht) und den Werkzeugleisteschaltflächen. Sie enthalten auch die Liste der letzten Auswahl verfügbar über das gehe zu Menü das dir ermöglicht direkt zu jeder der letzten Auswahl zu springen. Zum Schluss, rechts-klicken auf die Vor > und < Zurück Werkzeugleistenschaltflächen öffnet Aufklappmenüs mit den entsprechenden Abschnitten des Verlaufs. Durch Auswahl eines Eintrags, kannst du direkt dorthin springen.

Lesezeichen

Ähnlich wie beim festlegen der Startperson, kannst du andere Personen aus der Datenbank mit einem Lesezeichen versehen, um die spätere Navigation zu dieser Person zu vereinfachen. Um ein Lesezeichen zu einer Person hinzuzufügen, navigiere zu der Person und wähle dann Lesezeichen ->Lesezeichen hinzufügen. Um zu dieser Person von überall in der Datenbank zu gelangen, wähle Lesezeichen ->Name der Person.

Abb. 6.1 Lesezeichen verwalten

Du kannst über Lesezeichen ->Lesezeichen organisieren... deine Lesezeichen verwalten. Dies öffnet den folgenden Lesezeichen verwalten Dialog mit einer Liste der Lesezeichen und Bedienelemente diese zu modifizieren.

Verwende die Hoch und Runter Schaltflächen um die Reihenfolge in der Liste zu ändern. Verwende die Entfernen Schaltfläche um ein Lesezeichen zu löschen. Die Hilfe Schaltfläche bringt dich auf diese Seite und du schließt das Lesezeichen organisieren Fenster schließt du mit der Schließen Schaltfläche.

Die mit einem Lesezeichen versehene Person kann in der Personenansicht, wie oben beschrieben, aber auch in der Beziehungenansicht, Familienansicht, und der Ahnentafelansicht ausgewählt werden.

Auf ähnliche Weise kannst du auch für folgendes Lesezeichen erstellen: Ereignisse, Quellen, Fundstellen, Orte, Medien, Aufbewahrungsorte und Notizen


Datensätze finden

Abb. 6.2 Finden während Eingabe

Um einen Datensatz in der Datenbank zu finden, wechsle zuerst in die entsprechende Ansicht, die eine Liste der gewünschten Datensätze enthält: Personen, Quellen, Orte, Medien oder Notizen. Dann beginne mit der Eingabe des Namens einer Person oder dem Titel einer Quelle, Ort, Medium oder Notiz, nach dem du suchst. Du kannst auch Strg+F drücken um den Suchmodus an zuschalten, es reicht aber einfach mit der Eingabe zu beginnen.

Während du schreibst, wird der erste Eintrag aus der Liste, der mit deiner Eingabe übereinstimmt ausgewählt.


Gnome-important.png
Personen finden

Für komplexere Personensuche kannst du Filter verwenden. Aktiviere die Filtersteuerelemente über Ansicht -> Seitenleiste, wählen den gewünschten Filter und klicke Anwenden. Für Details siehe Filter.


Die Zwischenablage verwenden

Abb. 6.3 Zwischenablage

Diese Werkzeug liefert einen temporären Notizblock zum zwischenspeichern von Datensätzen zur einfachen Wiederverwendung. Kurz, dies ist eine Art von kopieren und Einfügen Funktionalität erweitert von Textobjekten auf andere Arten von Objekten, die in Gramps verwendet werden.

Gnome-important.png
Zwischenablage macht exzessiven Gebrauch von der ziehen und ablegen Technik

Zum öffnen der Zwischenablage wähle entweder Bearbeiten->Zwischenablage oder klicke auf die Zwischenablage Schaltfläche in der Werkzeugleiste.



Die Zwischenablage unterstützt Adressen, Attribute (beide persönlich und familiär), Ereignisse (beide persönliche und familiäre), Namen, Medienobjektreferenzen, Fundstellen, URLs und natürlich Textinformationen von Notizen und Kommentaren. Zum speichern jeglicher Art dieser Datensätze, ziehe den entsprechenden Datensatz aus dem entsprechenden Bearbeiten Dialog in die Zwischenablage. Zur Wiederverwendung des Datensatz ziehe ihn von der Zwischenablage an die entsprechende Stelle im Editor z.B. Adressenreiter, Attributereiter, usw..

Gnome-important.png
Hinweis

Einige Objekte zeigen das Verknüpfungsymbol auf der linken Seite. Dies zeigt an, das das ziehen dieser Auswahl eine Verknüpfung zu einem bestehenden Objekt erstellt keine Kopie des eigentlichen Objekts. Zum Beispiel die Medienobjektdatei wird nicht vervielfältigt. Stattdessen wird eine Verknüpfung zu einem bestehenden Medienobjekt erstellt, welche den lokalen Galerieeintrag ergibt.


Gnome-important.png
Hinweis

Der Inhalt der Zwischenablage bleibt während einer Gramps Sitzung erhalten. Schließen der Zwischenablage löscht ihren Inhalt nicht. Aber das Beenden von Gramps löscht ihn.


Die Zwischenablage kann durch das Tatsenkürzel Strg+B aufgerufen werden.

Für eine Anwendung wie Gramps ist die Zwischenablage sehr wichtig.

Ein Beispiel: Du findest die Geburtsurkunde einer Person. In dieser Urkunde werden auch die Zeugen genannt. Und die Geburtsurkunde bestimmt wo diese Information aufbewahrt wird. Der beste Weg ist, die Zwischenablage zu öffnen, und die Quelle, mit der du arbeiten möchtest, dorthin zu ziehen. Dann verwende ziehen und ablegen um sie in neuen Objekten, die du verwendest, zu verwenden.

Jetzt kannst du die Informationen in dem Personeneditor vervollständigen. Ziehe diese Information auch in die Zwischenablage.

Nun fügst du zwei Personen für die Zeugen hinzu (wenn sie noch nicht in deiner Datenbank existieren). Ziehe die Geburtsinformation einfach in die Ereignisansicht der Zeugen und lege sie dort ab. Du siehst dann die Ansicht in der du die Rolle des Zeugen auf Zeuge für dieses Geburtsereignis ändern kannst. Wiederhole diesen Vorgang mit dem anderen Zeugen.

Dies erspart dir eine Menge Schreibarbeit und mögliche Fehler.

Fensterverwaltung

Abb. 6.4 Fenstermanager

Das Fenster -> Menü bietet einen schnellen Zugriff auf die geöffneten Fenster mit denen du arbeitest.


Markieren

Gehe zu Menü -> Bearbeiten -> Markierung.

Abb. 6.5 Markierung Aktionen aus dem Bearbeitenmenü


Oder klicke auf die Markieren Schaltfläche in der Werkzeugleiste.

Abb. 6.6 Markierung Aktionen von der Werkzeugleistenschaltfläche


Konzept

Abb. 6.7 Markierungen Organisator
  • Für Personen, die Gmail oder Thunderbird verwenden, sind Markierungen nichts neues. Anstatt Mails in Ordner einzuordnen wie in Outlook (Windows) oder Evolution (Linux), werden Mails geordnet, indem ihnen Markierungen zugewiesen werden. Anstatt eine trennende N:1 Klassifizierung zu haben (eine Mail kann in einem Ordner und zwar nur einem Ordner sein und ein Ordner kann viele Mails enthalten), in Gmail oder Thunderbird existiert eine N:M Klassifikation (eine Mail kann mehrere Markierungen haben und eine Markierung kann mehreren Mails zugeordnet sein)

Ähnlich wenn du einen großen Baum hast, und du möchtest Untermengen dieses Baums erstellen und diese Untermengen können sich überschneiden. Zum Beispiel die Untermengen der Familie deines Vaters und der Familie deiner Mutter, eine Untermenge für die Personen, die in die USA ausgewandert sind und eine Untermenge der berühmten Personen in deinem Baum.

Die Idee ist jeder Untermenge eine Markierung zuzuweisen: Vater, Mutter, USA und Berühmt als Beispiel.

Unterschiede zu den alten Markierungen

Abb. 6.8 Markierungsauswahl im Personeneditor
  • Die alten Markierungen waren wie die Ordner für Mails. Einer Person konnte nur eine Markierung zugewiesen werden. Jetzt können einer Person mehrere Markierungen zugewiesen werden.


Markierungen und Filter

  • Markierungen und Filter erstellen beide Untermengen des Baums. Doch es gibt faktische Unterschiede in der Anwendung.
Abb. 6.9 Filtern nach Markierung in der Filterseitenleiste

Die Familie deines Vaters mit Hilfe von Filtern zu bestimmen ist einfach; es existieren bereits Filter mit bestimmter Logik, die dies erledigen. Auf der anderen Seite Personen zu bestimmen, die in die USA ausgewandert sind, ist erheblich schwieriger, während es für berühmte Personen in deiner Familie schlicht unmöglich ist, da keine schlüssige Regel existiert. Markierungen sind hier erheblich besser geeignet.

Dennoch haben Filter den Vorteil, das sie dynamisch sind. Wenn du einen Vorfahren deines Vaters der Datenbank hinzufügst, wird er automatisch dem Filter hinzugefügt.

Auf der anderen Seite sind Markierungen statisch. Wenn eine berühmte Person der Datenbank hinzugefügt wird, musst du sie explizit als berühmt markieren.

  • Die Objekte, die als erstes in den Sinn kommen, sind Personen und es sind die sinnvollsten. Aber es können auch andere Objekte markiert werden:
    • Orte: Zum Beispiel "Orte die besucht werden sollten",
    • Quellen: Zum Beispiel "Quellen in englisch",
    • Notizen: Zum Beispiel "Notizen in Arbeit", oder "Notizen in englisch",
    • Medien: Zum Beispiel "Bilder, die zu Onkel Alfred gehören".

Markierungen gibt es für Personen, Familien, Notizen und Medien.


Aktionen mit Markierungen

Hier sind einige Ideen für Operationen, die mit Markierungen durchgeführt werden können

Filtern

Die offensichtlichste ist filtern.

Eine Auswahl von Objekten markieren

Abb. 6.10 Neue Markierung zu einer Auswahl hinzufügen

Aufgrund der statischen Charakter von Markierungen kann es sinnvoll sein, eine Markierung einer Auswahl von Objekten zuzuweisen via Ctrl, Shift, Ctrl+A. Zum Beispiel sollte man eine Reihe von Personen in der Personenansicht auswählen können und ihnen eine neue oder bestehende Markierung zuweisen.


Markierungenspalte

Abb. 6.8 Markierungenspalte und farbige Zeilen

Es ist praktisch in den Ansichten von Objekten, die markiert werden können eine Markierungen Spalte zu haben. Der Inhalt besteht aus einer Komma-getrennten Liste der Markierungen des Objekts.


Zurück Index Nächste