Open main menu

Gramps β

De:Download

Gramp-Small-background-wiki-2020.jpg

Erforsche, organisiere und teile deinen Stammbaum mit Gramps.

Gramps ist ein freies Softwareprojekt und Gemeinschaft. Wir sind bestrebt, ein Genealogieprogramm zu erstellen, das beides ist intuitiv für Freizeitgenealogen und mit allen Funktionen für professionellen Genalogen. Es ist ein Gemeinschaftsprojekt erstellt, entwickelt und verwaltet von Genealogen.

Gramps-notes.png
Gramps Aktuelle Version: 5.1.4 Veröffentlicht: 2021-07-26

Anderes Datenformat als die Gramps 3.4 Serie. Volle Python 3 Unterstützung dadie Unterstützung für Python 2 beendet wurde. Verwendet GTK+ 3. Standard Datenbank ist jetzt SQLite. Viele Änderungen siehe:.Was ist neu?
Linux 220x261.png Windows 180x160.png Macos 200x200.png Bsd daemon.png

Contents

Linux

Bevor du du deine Distribution aktualisierst: verwende deine frühere Version von Gramps um eine Sicherung deiner Stammbäume im robusten und portablen XML-Format1 zu erstellen.

via Distributionen      via Flathub      Neueste Version (5.1.4) (nur erfahrene Anwender)

MS Windows

Vor dem Download des All-In-One Software Installationspaket für Windows: verwende deine vorherige Gramps Version um eine Sicherung deiner Stammbäume in dem robusten und portablen XML format1 zu erstellen.

Dieser Installer unterstützt Microsoft Windows in allen Versionen ab Vista/7 und neuer. Die 64-Bit-Versionen von Windows ermöglichen einen effizienteren Zugriff auf mehr Ressourcen.

(Bitte beachte: Gramps bevorzugt Python-3.5 und Gtk-3.18 Bibliotheken oder neuer. Diese Bibliotheken haben die Unterstützung für Windows XP beendet. Gramps kann weiterhin unter Windows XP mit älteren Versionen dieser Bibliotheken laufen z.B.:(Gtk-3.16 & Python3.4.4))

Nach dem Download: klicke doppelt um Gramps zu installieren.
Standard: neue Versionen werden in ein neue Verzeichnis installiert und ältere Installationen von Gramps werden nicht' überschrieben; die Sprache wird ein aus britischem und US Englischsein.

 
Verknüpfungen

Nach der Installation befinden sich eine Verknüpfungen auf dem Desktop und im Startmenü werden zwei Verknüpfungen hinzugefügt, bitte verwende nur die erste Verknüpfung, außer ein Entwickler verlangt etwas anderes.
1) GrampsAIOXX 5.1.4 <--- Verknüpfung für die tägliche Arbeit mit Gramps
2)
GrampsAIOXX 5.1.4-console


Normalerweise, wenn du versuchst den alten Stammbaum zu laden, kannst du erlauben, dass er wenn nötig aktualisiert wird, und er wird geöffnet. Wenn es dennoch aus irgendeinem Grund schief geht, Erstelle einen neuen Stammbaum und Importiere die Sicherung in diesen Stammbaum.

Verwende Windows AIO (All-In-One) Version, bitte verwende die Download-Links weiter oben für die Windows-AIO-Version. Für mehr Informationen über einzelne Versionen, Konsolen und Fehlersuche Modi, usw. siehe hier (englisch). Oder schaue dir die Beschreibung dessen an, was mit einem All-in-One-Paket gemeint ist.

Alternative unabhängige Installation

Bei Bedarf gibt es Alternativen zum All-In-One-Installer.

PortableApps.com

Eine PortableApps-Version wird von einem externen Gerät ausgeführt, ohne dass eine Installation auf dem Betriebssystemlaufwerk erforderlich ist. PortableApps-Installationen sind nicht für Touchscreen-basierte Mobilgeräte geeignet. Sie erlauben nur, dass die Anwendung von einem externen Speicher, USB-Sticks, ausgeführt wird.

Stand Wednesday, 8 December 2021, ist die aktuellste Version von Gramps 5.1.4.

Du kannst die (5.1.4) Gramps Portable Version herunterladen von:

Beachte, dass PortableApps.com auch eine alte Version 3.4.9 von Gramps zur Verfügung hat und diese nicht für den allgemeinen Gebrauch empfohlen wird; nur zur Wiederherstelleung von Datenbanken in älteren Format.

Portable Gramps von PortableApps.com enthält alle für Windows erforderlichen Abhängigkeiten. Hinweis: Du kannst es auf C: installieren und dann zum Ausführen von Gramps C:\PortableApps\GrampsPortable\GrampsPortable.exe (oder den Pfad, in dem du es installiert hast) eingeben oder eine Verknüpfung zu dieser Datei auf deinem Desktop oder Startmenü erstellen. Von Bart.S - Bitte melde paketierungs Probleme dem Autor. (2012-09-07)

Chocolatey NuGet Paket

Du kannst auch das unabhängige Gramps Chocolatey NuGet Paket installieren.


Chocolatey NuGet ist ein Maschinenpaket-Manager, ähnlich wie apt-get, aber für Windows entwickelt.


Gramps für Windows mit MSYS2


Fehlende andere Sprachen

 
Microsoft Window Gramps AIO Installer Komponentenauswahlfenster.

Das Standard-AIO-Installationsprogramm von Gramps bindet den US-amerikanischen Dialekt Englisch für die Schnittstelle zum britischen Rechtschreibprüfungswörterbuch ein.

Wenn du eine andere Sprache bevorzugst (oder mit den US-amerikanischen oder australischen Dialekten Englisch sprichst), achte bitte besonders auf die Phase Komponenten auswählen der Installation.

Um eine andere Sprache als Englisch zu installieren, wähle während der Phase Komponenten auswählen der Installation aus den Übersetzungen und Wörterbücher.

Selbst wenn deine Primärsprache standardmäßig installiert ist, kannst du die Rechtschreibprüfung von Notizen in einem anderen als dem britischen Dialekt Englisch erwarten. Stelle sicher, dass du die entsprechenden Sprachen aus den Wörterbüchern auswählst. Gramps greift nicht auf das native Wörterbuch deines Betriebssystems zu.

Es gibt keine einfache Möglichkeit, nach der Installation Schnittstellen- oder Wörterbuchsprachen hinzuzufügen.


macOS

Vor dem Herunterladen des betriebsbereiten Standalone-Bundles: verwende deine vorherige Gramps Version um eine Sicherung deiner Stammbäume in dem robusten und portablen XML format1 zu erstellen. Lies die vor der Installation Anweisungen.


Getestet auf Kompatibilität mit Apple MacOS/Mac OS X Versionen 10.5 (Leopard) bis 11 (Big Sur). "Hilfe zum Ermitteln Ihrer Betriebssystemversion finden Sie im Artikel zum Apple Support HT201260."

Nach dem Download: Klicke doppelt auf die .dmg Datei um sie als Laufwerk einzuhängen (beachte: es kein sein, das dein Browser dies automatisch für dich erledigt). Als nächstes ziehe die Gramps Anwendung in dein Anwendungenverzeichnis und klicke sie doppelt um sie zu starten. (Bei Apple Mac OS X kannst du alternativ auf das Festplattensymbol oben im Fenster der bereitgestellten Festplatte klicken und die Maustaste gedrückt halten und dann die Option zum Programme Ordner ziehen. Dadurch wird ein neuer Ordner erstellt, der alle Dateien enthält, einschließlich README und NEWS.)

Normalerweise, wenn du versuchst den alten Stammbaum zu laden, kannst du erlauben, dass er wenn nötig aktualisiert wird, und er wird geöffnet. Sollte dies aus irgendeinem Grund fehlschlagen, erstelle einen neuen Stammbaum und importiere die Sicherungskopie in diesen neuen Stammbaum.

Alternative unabhängige Installation

Alternativ kann Gramps auch auf macOS installiert werden, indem entweder die MacPorts- oder Homebrew-Paketverwaltungssysteme verwendet werden.


MacPorts

MacPorts ist ein Paketverwaltungssystem für Apple Mac.


Homebrew

Homebrew ist eine Open Source Paketverwaltung für macOS (und Linux).

Siehe https://github.com/homebrew/




Hinzufügen zusätzlicher Sprachen für die Rechtschreibprüfung unter macOS

 

Gramps verwendet eine andere Rechtschreibprüfung als mit Mac OS X mitgeliefert wird, mit anderen Wörterbuchanforderungen. Wir können nicht einfach Wörterbücher für alle unterstützten Sprachen im Paket liefern aber sie können einfach von OpenOffice.org's Website heruntergeladen werden. Laden die gewünschte Sprache herunter und speichern sie. Navigieren dann zum Download im Finder. Die meisten Browser haben ein Download-Fenster, in dessen Kontextmenü "Im Finder anzeigen" angezeigt wird. Ändere die Dateierweiterung von oxt in zip, dann wähle aus dem Kontextmenü Öffnen mit... Archivierungswerkzeug um es zu entpacken. Im dekomprimierten Ordner oder vielleicht in einem Unterordner findest du die Wörterbuchdateien paarweise, foo.aff und foo.dic. Einige Sprachen besitzen mehr als ein Paar mit einer README Datei mit einer Erklärung warum. Wähle ein Paar und kopiere es nach /Library/Dictionaries (du musst dich mit einer Administrator ID und Passwort autorisieren) und wenn 'foo' nicht bereits eine Sprache oder eine Regionskennung ist, mache es zu einer. Zum Beispiel, das französische Paket enthält mehrere Paare mit Namen wie fr-moderne.aff und fr-moderne.dic. Die Rechtschreibprüfung erkennt diese Namen nicht, also wenn du sie nach /Library/Dictionaries kopierst, musst du sie nach fr.aff und fr.dic oder fr_FR.aff und fr_FR.dic umbenennen. Du kannst mehr als ein Wörterbuchpaar installieren wenn du mehrere Sprachen verwendest aber eins muss der Sprache entsprechen, die du für Gramps verwendest oder die Rechtschreibkorrektur wird trotz alle dem nicht aktiviert.



Linux und BSD Distributionen

 
Diese Pakete werden von den Distributionen gebaut und gewartet.

Wenn deine Distribution nicht aufgeführt ist, kannst du sie eventuell auf "Repology" finden
Bitte berichte alle Probleme mit ihnen zu den Paket Versorgern.

Die meisten Linux Distributionen enthalten eine Version von Gramps, aber es ist meistens nicht die neueste Version und wird standardmäßig nicht installiert. Trotzdem wird empfohlen, die Gramps Version zu verwenden, die mit deiner Distribution ausgeliefert wird.

Unten findest du einige Möglichkeiten, Gramps auf einigen bekannteren Distributionen zu installieren:

Distribution GUI Paketverwaltung Aktuelle Versionen Notizen
  Debian Software hinzufügen/entfernen
  • Debian 8 ("jessie")(old old stable): Gramps 4.1.1
  • Debian 9 ("stretch") (old stable): Gramps 4.2.5
  • Debian 9 ("stretch")(backports): Gramps 5.0.1
  • Debian 10 ("buster") (stable): Gramps 5.0.1
  • Debian 10 ("buster")(backports) (stable): Gramps 5.1.2
  • bullseye (testing): Gramps 5.1.3
  • sid (unstable): Gramps 5.1.4
verfügbare Versionen
 Ubuntu Software Centre
  • Xenial (16.04 LTS): Gramps: 4.2.2
  • Xenial (16.04 LTS): Gramps: 4.2.6 (Backport)
  • Bionc Beaver (18.04 LTS): Gramps: 5.0.0
  • Eoan (19.10): Gramps: 5.0.1
  • Focal (20.04 LTS): Gramps: 5.1.2
  • Groovy Gorilla (Development: 20.10): Gramps: 5.1.3
verfügbare Versionen
  Linux Mint Software Manager
  • 18.x(Gramps 4.2.2~dfsg-1)
  • 19.x(Gramps 4.2.8)
  • 20.x(Gramps 5.1.2)
 Fedora Software hinzufügen/entfernen (Gnome) oder
Software Management (KDE)
  • Rawhide (Gramps 5.1.4)
  • Fedora 33 (Gramps 5.1.4)
  • Fedora 34 (Gramps 5.1.4)
  • Fedora 35 (Gramps 5.1.4)
verfügbare Versionen
Mageia drakrpm (oder rpmdrake)
  • Mageia Caulron: Gramps 5.1.4
  • Mageia 7.1: Gramps 5.0.1
Mageia App Db - gramps
 openSUSE YaST
  • openSUSE Tumbleweed: Gramps 5.1.4
  • openSUSE Leap 15.2: Gramps 4.2.8
  • openSUSE Leap 15.1: Gramps 4.2.8
  • openSUSE Leap 15.0: Gramps 4.2.8
verfügbare Versionen
Die aktuellste Version kann normalerweise aus dem 'openSUSE BuildService - GNOME:Apps' Repository installiert werden
 Slackware verfügbare Versionen
 Arch Linux pacman
  • Gramps 5.1.4
available versions
 Gentoo Linux
  • Gramps 5.1.4
available versions
NetBSD
FreeBSD
OpenBSD
  • OpenBSD: Gramps 5.1.3
verfügbare Versionen



Linux: Neueste Version installieren

Wenn deine Distribution nicht mit Gramps ausgeliefert wird, oder du willst eine andere Gramps Version als die mitgelieferte installieren, kannst du versuchen, die neueste Version von Gramps manuell zu installieren.

 
Warnung bevor du dies versuchst, verwende deine aktuelle Installation, um eine Gramps XML-Sicherung zu erstellen

Dies sollte nur von erfahrenen Anwendern versucht werde, und nachdem du deinen Stammbaum gesichert hast.

Die Version von Gramps, die in deiner Distribution enthalten ist, wurde darauf getestet, das sie mit den in der Distribution enthaltenen Komponenten funktioniert. Wenn du versuchst, eine andere Gramps Version zu installieren, besteht die Möglichkeit, das die Komponenten, welche für die neue Gramps Version benötigt werden, für deine Distribution nicht zur Verfügung stehen oder sie sind Verfügbar, funktionieren aber nicht korrekt. Es kann sein, das du die Probleme erst feststellst, nachdem du einige Zeit mit der neuen Gramps Version gearbeitet hast.

Wenn du Gramps bereits installiert hast, und nur eine Punktaktualisierung machst (z.B. von Gramps x.y.z nach x.y.z+1 z.B. von 3.4.3 nach 3.4.4), dann ist es üblich aber nicht sicher, das Gramps weiter funktioniert. Aber wenn die Änderung viel größer ausfällt, besonders wenn es sich um den Wechsel der Hauptversion handelt (z.B. von 3.y.z nach 4.y.z), dann ist die Gefahr, das es nicht einwandfrei funktioniert sehr viel Größer.

Debian basierend

Für  Debian-basierende Linux Distributionen (Was  ' Ubuntu einschließt) Download die .deb Datei. Klicke doppelt auf die .deb Datei oder (für einige Distributionen, wie z.B. Mint Debian) führe das folgende Kommando in dem Verzeichnis aus, indem sich deine heruntergeladene Datei befindet (ändere den Dateinamen, damit er mit deinem heruntergeladenen übereinstimmt).

sudo dpkg -i gramps_5.1.4-1_all.deb

wenn du einen Fehler wegen nicht aufgelösten Abhängigkeiten bekommst, starte:

sudo apt-get -f install

um die Abhängigkeiten zu installieren.

Wenn beim Starten von Gramps ein Fehler bezüglich der Sprachunterstützung angezeigt wird, führen aus

sudo apt install language-pack-gnome-en

um das richtige Sprachpaket zu installieren. Möglicherweise musst du 'de' durch deinen eigenen Sprachcode ersetzen, z. B. 'de' für Deutsch.

Hilfreiche Kommandozeilen

Bevor du aktualisierst, kannst du [1]:

  • Herausfinden, welche Version installiert ist:
   dpkg-query -s gramps

dies fragt nach dem Paket und gibt dir Informationen über es.

  • Wenn du sicher aktualisieren sollst, dann stelle sicher, das du deinen Stammbaum im Gramps-XML Format gesichert hast dann starte :
   sudo dpkg -r gramps

dies entfernt das aktuelle gramps Paket (unter der Annahme, das es ein python3 Version ist. ältere Versionen können python-gramps sein)

  • Um zu verhindern, dass Ubuntu Gramps aktualisiert (möglicherweise auf eine ältere Version von Ubuntu!), Musst du möglicherweise Folgendes ausführen:
   sudo apt-mark hold gramps

Update ist dann abgeschlossen.

Flathub

Gramps 5.1.4 ist in einem Flatpak bei Flathub erhältlich.

 
Bitte verwende deine vorhandene Installation, um deine Datenbank zu sichern, bevor du fortfährst.

Es ist auch eine gute Idee, Deine Datenbank in SQLite zu konvertieren, obwohl das Flatpak 5.1.4 derzeit BSDDB3-Unterstützung bietet.

Richte zuerst Flatpak und das Flathub-Repository auf deinem System ein. Anweisungen für verschiedene Distributionen findest du unter https://flatpak.org/setup/

Danach kannst du die blaue Installationsschaltfläche unter https://flathub.org/apps/details/org.gramps_project.Gramps verwenden, wenn du deinen Software-Manager für die Arbeit mit Flathub eingerichtet hast, oder den folgenden Befehl in einem Terminal für ein System weite Installation verwenden, wenn du Sudo-Berechtigungen hast:

flatpak install flathub org.gramps_project.Gramps


Für andere Distributionen

Für andere Distributionen,   die Quellen und folge den Anweisungen für erstellen aus den Quellen (englisch).

BSD

Vor dem Aktualisieren deiner Distribution: Verwende deine alte Gramps Version zur Sicherung deiner Stammbäume [1].

via Distributionen      Neueste Version (nur erfahrene Anwender)

Linux Live CD

Linux live CD Demonstration enthält Gramps 3.2.5 vorinstalliert zum Ausprobieren, ohne etwas an deiner Festplatte zu ändern. Um es zu starten, boote den Computer mit diesem Live Linux auf einer CD im CD/DVD-ROM Laufwerk. (Dies erfordert, das du diese Image mit einem CD-Brennprogramm auf eine CD-ROM schreibst z.B. mit:Nero, Imgburn..). |Die CD downloaden (727 MB) Die Linux Genealogie CD basiert auf Ubuntu 10.10 (Maverick Meerkat). Ermöglicht das Ausprobieren einer vorinstallierten Gramps Version 3.2.5, ohne dass Änderungen auf der Festplatte vorgenommen werden. Um die CD zu starten, boote den Rechner von der Linux Live CD. (Setzt voraus, das du das Image auf eine CD-ROM unter Verwendung eines Brennprogramms brennst z.B.:Nero, Imgburn..). Wenn du an Gramps interessiert bist, aber Angst hast oder unfähig bist es zu installieren (fremder PC, Windows, kein Internet zu Hause, Firmenlaptop) dann probiere unsere Linux Genealogie Live-CD. Sie läuft ohne Installation auf die Festplatte und enthält eine Reihe von quelloffenen, kostenlosen Genealogieprogrammen. Du kannst dann jederzeit, wenn du möchtest, Ubuntu und Gramps von der CD installieren.

Online Demonstration

 
Beachte

Dies ist ein kommerzieller begrenzter Test und nicht vom Gramps-project unterstützt. Vorsicht davor, das Drittparteien deine genealogischen Daten haben.

Du kannst auch eine Onlinedemonstartion von Gramps ausprobieren auf rollApp:

Wähle Launch Online dann Test Drive(Opening/saving files will not be available)


Notizen

[1] Sicherung nach Gramps-XML. Du findest Sicherung im Stammbaum Menü der aktuellen Gramps Versionen, anderenfalls verwende Export im selben Menü aber deaktiviere die vertraulich Option im Exportassistent um alle Daten zu exportieren. Siehe: Wie erstelle ich eine Sicherung

Siehe auch