Difference between revisions of "Common problems"

From Gramps
Jump to: navigation, search
Line 3: Line 3:
 
Many problems reported with GRAMPS turn out to be the consequence of installing a new version of GRAMPS "on top" of an older installed version (this is particularly important when installing from source). Such an install can lead to problems both in Windows and Linux. If you have done that and are experiencing problems, it might help uninstalling and installing again.
 
Many problems reported with GRAMPS turn out to be the consequence of installing a new version of GRAMPS "on top" of an older installed version (this is particularly important when installing from source). Such an install can lead to problems both in Windows and Linux. If you have done that and are experiencing problems, it might help uninstalling and installing again.
  
;GRAMPS provides only .gv output format on GraphViz based reports
+
;GRAMPS only properly generates .gv output format on GraphViz based reports
You have GraphViz package installed but you cannot use all availables output formats into GRAMPS' report based on GraphViz. Maybe your GraphViz package ignored some dependancies, which could be useful, like :
+
You have <u>GraphViz package installed</u> but you cannot use all availables output formats into GRAMPS' reports based on GraphViz, because generated files are missing or not very nice. Maybe your GraphViz package or version ignored some dependancies, which could be useful, like : [http://www.unifont.org/lasi/ LASi] [http://gts.sourceforge.net/ GTS], [http://openil.sourceforge.net/ DevIL], etc ...
* [http://www.unifont.org/lasi/ LASi]
+
Using the [http://www.graphviz.org/Download.php last available GraphViz package] for your distribution may often fix some issues.
* [http://gts.sourceforge.net/ GTS]
+
* [http://openil.sourceforge.net/ DevIL]
+
  
 
[[Category:Troubleshooting]]
 
[[Category:Troubleshooting]]

Revision as of 00:08, 3 July 2009

GRAMPS gives strange errors after new install or upgrade

Many problems reported with GRAMPS turn out to be the consequence of installing a new version of GRAMPS "on top" of an older installed version (this is particularly important when installing from source). Such an install can lead to problems both in Windows and Linux. If you have done that and are experiencing problems, it might help uninstalling and installing again.

GRAMPS only properly generates .gv output format on GraphViz based reports

You have GraphViz package installed but you cannot use all availables output formats into GRAMPS' reports based on GraphViz, because generated files are missing or not very nice. Maybe your GraphViz package or version ignored some dependancies, which could be useful, like : LASi GTS, DevIL, etc ... Using the last available GraphViz package for your distribution may often fix some issues.