Comment produire un graphique relationnel

From Gramps
Revision as of 13:57, 19 October 2012 by MathieuMD (Talk | contribs)

Jump to: navigation, search


Ceci est un tutoriel pour réaliser un graphique relationnel (pouvant être les ascendants, descendants, des individus filtrés, toute la base !) depuis Gramps-2.2.x avec un greffon (plugin) basé sur GraphViz.
Un exemple de graphique

Ce rapport est généré avec graphviz, ainsi vous avez besoin d'installer graphviz (sous linux, utilisez votre gestionnaire de paquets).

Avant de démarrer

Gramps peut produire des graphiques, mais pour les voir, vous avez besoin d'autres programmes. Nous vous recommandons :

Filtres : les personnes devant être imprimées ?

Qu'est ce que les filtres ?

Dans Gramps vous pouvez définir des filtres pour une sélection d'individus, voir les filtres. Dans la plupart des rapports, chaque filtre personnel que vous avez créé sera disponible, ainsi que les 'filtres standards' sur les descendants et ascendants. Ces derniers sont dépendants de la personne active lorsque que vous appelez le rapport.

Combien d'individus ?

Votre filtre peut contenir un nombre très important d'individus. De ce fait imprimer ou voir un très grand graphique peut être très problématique selon la capacité et la configuration de votre ordinateur.

Exemple 1-A: un graphique des descendants

Un graphique des descendants, cliquez pour les détails

Téléchargez example.gramps (clic droit 'Enregistrer sous ...'), créez une nouvelle base de données dans Gramps, et importez le fichier example.gramps.

Si ce n'est pas le cas, définissez la personne active : Garner, Lewis Anderson.

Pour générer un graphique des descendants avec le rapport relationnel, choisissez depuis le menu Rapports -> Graphiques -> Graphique relationnel....

Dans le dialogue, définissez le format .png et choisissez dans les onglets disponibles :

  1. Options Papier-> Taille : selon les nombre d'individus, choisissez la taille personnalisée (définir la hauteur et la largeur avec des grands nombres)
  2. Options du rapport-> Filtre : Descendants de Garner, Lewis Andersson
  3. Optons de mise en page-> Aspect : taille minimale

(Si vous avez des difficultés pour saisir une taille dans le dialogue. Une alternative étant d'utiliser le code graphviz de l'exemple 3, ci dessous.)

Le résultat (avec Gramps 2.2.7) est visible à la droite de l'écran. Vous pouvez utiliser la fonction imprimer liée à votre visualiseur d'image et votre imprimante (vérifiez la valeur DPI de votre fichier png !), ou vous pouvez utiliser cette image sur un site internet pour la partager. Dans ce dernier cas, vous pouvez également jetter un oeil sur faire un graphique relationnel en flash, pour rendre le graphique plus 'navigable'.

Dans l'image, vous voyez les hommes en bleu, et les femmes en rose. Les cercles jaunes indiquent un noeud familial permettant l'impression des données de mariage (si connues). Vous pouvez ignorer les noeuds familiaux en désélectionnant l'option Afficher les noeuds familiaux dans les Options de Graphviz.

Exemple 1-B: un graphique des ascendants

Fig. Le graphique des ascendants. Pour l'image détaillée, cliquez ici (853kb!)

Téléchargez et ouvrez le fichier example.gramps (voir l'exemple précédent)

Définissez Warner, Carl Thomas comme personne active.

Répétez les étapes des l'exemple précédent, mais choisissez juste le filtre Ascendants de Warner, Carl Thomas.

Ci-joint le résultat.

C'est un graphique très grand. Il peut être vu dans un bon visualiseur d'image.

Pour l'impression vous aurez sans doute besoin d'utiliser plusieurs pages (par exemple au format PDF via Ghostscript), ou une bonne table d'impression. L'impression sur une imprimante grand public est également possible avec des graphiques d'une taille raisonnable.


Exemple 2: un graphique avec ascendants, descendants et leurs familles

Fig. Un grand graphique. Pour l'image détaillée, cliquez ici (363kb!)

Notez que cet exemple utilise les filtres. Voir cette page pour plus d'informations sur les filtres.

Ouvrez le fichier example.gramps et sélectionnez Cristiansen, Frances comme personne active.

Tout d'abord, nous créons un filtre : Ouvrez l'éditeur de filtre et créez un nouveau filtre, appelé Frances1. Ce filtre contiendra les règles :

  • Ascendants de <individu> choisissez Christiansen, Frances et cochez inclusif.
  • Descendants de <individu> choisissez Christiansen, Frances

Puis, nous créons le filtre qui sera utilisé pour le rapport. Il sera basé sur le précédent filtre : créez ce filtre, appelé Frances2. Ce filtre contiendra les règles :

  • Individus correspondants au filtre, choisissez Frances1.
  • Parents du filtre Frances1
  • Frères et soeurs du filtre Frances1
  • Conjoints du filtre Frances1

Enfin, fermez l'éditeur de filtre, et suivez les instructions données dans les exemples 1a et 1b, mais choisissez le filtre Frances2 dans l'onglet Options du rapport (Graphique relationnel).

Le résultat est visible à droite (363kb, grand fichier !)

Exemple 3, générer un graphique en utilisant Graphviz et l'outil en ligne de commande

Préparation dans Gramps

Dans le menu, sélectionnez Rapports -> GraphViz -> Graphique relationnel....

Choisissez le filtre que vous souhaitez utiliser, définissez également autant d'options que possible aux valeurs voulues (comme expliqué dans l'exemple 1-A), mais le format sera "Graphviz (.gv)". Cliquez sur Valider. Vous devez obtenir un fichier ".gv".

Ce fichier est du type texte, ainsi il peut être ouvert avec un éditeur de texte.

Changements manuels

Le fichier dot (.gv) a une structure bien définie, pour plus d'informations, voir : www.graphviz.org

digraph GRAMPS_graph
{
 bgcolor=white;
 center="true"; 
 concentrate="false";
 dpi="75";
 graph [fontsize=12];

...

les données Gramps sont affichées :

I3493 [ shape="box" fillcolor="pink" style="solid,filled" label="Blancke, Charlotte\n(1801)" ];

...

Vous pouvez optimiser la mise en page en appliquant des changements au fichier.

  • La taille de la page : regardez la section "page" et "taille", et changez les informations par des valeurs plus grandes. Ceci est important, dans le cas contraire, les miniatures ne seront pas de bonne qualité ou le texte ne sera pas lisible.
  • Vous pouvez également changer la famille de police.

Regardez les lignes :

node [style=filled fontsize="12"];

et changez par :

node [style=filled fontsize="12" fontname="Sans"];

pour utiliser la police Sans. En ligne de commande regardez quelle police ttf, Graphviz trouve sur votre PC.

Génération de l'image

Sauvez votre fichier modifié sous le nom de rapport.dot, et lancez la commande :

dot -Tpng -orapport.png rapport.dot

Ceci va utiliser l'outil graphviz "dot" pour générer le fichier .png contenant le rapport.

Pour voir les messages d'information (comme la police) utilisez l'argument -v. Vous pouvez également générer d'autres formats d'image, par exemple, le format jpeg avec les informations de sortie :

dot -Tjpg -orapport.jpg rapport.dot -v

...

Activated plugin library: libgvplugin_pango.so.5
Using textlayout: textlayout:cairo
Activated plugin library: libgvplugin_dot_layout.so.5
Using layout: dot:dot_layout
Using render: cairo:cairo
Activated plugin library: libgvplugin_gd.so.5
Using device: jpg:cairo:gd
The plugin configuration file:	/usr/lib/graphviz/config4 was successfully loaded.
   render	:  cairo dot fig gd map ps svg vml vrml xdot
   layout	:  circo dot fdp neato nop nop1 nop2 twopi
   textlayout	:  textlayout
   device	:  canon cmap cmapx cmapx_np dia dot fig gd gd2 gif hpgl imap imap_np ismap jpe jpeg jpg mif mp pcl pdf pic plain plain-ext png ps ps2 svg svgz vml vmlz vrml vtx wbmp xdot xlib
   loadimage	:  (lib) gd gd2 gif jpe jpeg jpg png ps
dot: fontname "Times-Roman" resolved to: "Times New Roman, Normal" /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman.ttf
network simplex: 11 nodes 10 edges 0 iter 0.00 sec
mincross: pass 0 iter 0 trying 0 cur_cross 0 best_cross 0
mincross GRAMPS_graph: 0 crossings, 0.00 secs.
network simplex: 23 nodes 37 edges 7 iter 0.00 sec
routesplines: 10 edges, 30 boxes 0.00 sec
Using render: cairo:cairo
Using device: jpg:cairo:gd

...

Imprimer de grands graphiques

Méthode simple

Graphique au format A1
Découpé en 8 pages A4

Lancer le « Graphique de lignées familiales » (dans « Rapports > Diagrammes ») et le configurer. Par exemple :

  1. Options du papier :
    • Taille : A1
    • Orientation : 1. Paysage
    • Marges : toutes à 1 cm
  2. Individus recherchés :
    • Sélectionner tous les individus devant être utilisés comme base pour tracer l'arbre (permet d'inclure les lignés des parents et grand-parents par exemple)
  3. Couleur de la famille :
    • Donner une couleur aux noms principaux
  4. Mise en page GraphViz :
    • Taille de la police : 32
    • Orientation du graphique : Horizontal (←)
    • Nombre de pages horizontales et verticales : 1
  5. Options GraphViz :
    • Ratio d'aspect : Remplir la zone donnée
    • Résolution : 300
    • Espacement de nœud et rang : 0,50
    • Utiliser les sous-graphiques : Oui
  6. Format de sortie : PostScript

Enregistrer le fichier familylines_graph.ps et utiliser le logiciel poster (Ubuntu/Debian : apt-get install poster) pour le découper en plusieurs pages :

 poster -v -mA4 -pA1 familylines_graph.ps > familylines_graph-A1_A4.ps

Ensuite, avec ps2pdf, convertir ce fichier PostScript en PDF pour une utilisation plus simple :

 ps2pdf familylines_graph-A1_A4.ps

Il ne reste plus qu'à imprimer les pages et les assembler. L'auteur de Poster suggère de découper les marges de gauche et du bas (sauf sur les pages du bord gauche et celles du bas) et de les coller ensemble en commençant par celle en bas à gauche et ensuite de gauche à droite puis de bas en haut. Enfin, pour renforcer le poster, le retourner et mettre du ruban adhésif sur les jointures)

Autre méthode

Si vous souhaitez imprimer de grands graphiques (surtout avec des photos et autres détails) dans une qualité de lecture raisonnable, voici quelques étapes qui pourraient vous aider :

  1. Dans les options du document, choisissez le format de sortie SVG.
  2. Définissez le format de papier pour tenir dans une feuille (SVG ne peut pas gérer plus d'une feuille), donc choisissez A0 ou taille personnalisée.
  3. Utilisez Inkscape pour ouvrir votre graphique SVG.
  4. Menu Fichier/Propriétés du document, utilisez la fonction "Adapter la page à la sélection" (corrigez la taille d'après la taille du graphique).
  5. Menu Fichier/Enregistrer sous, choisissez le format PDF.

Vous avez maintenant un grand poster que vous pouvez imprimer. Inkscape ne donne pas de titre au fichier PDF pour imprimer de grands graphiques sur plusieurs feuilles A4/A3, vous devez donc utiliser un autre programme pour le faire. Sous GNU/Linux, l'outil en ligne de commande pdfposter peut diviser un grand fichier PDF en plusieurs au format A4/A3/Lettre/etc. Installez-le via le gestionnaire de paquets de votre distribution (Ubuntu/Debian : sudo apt-get install pdfposter). Par exemple, pour diviser un poster A0 en pages A4 (lisez la page de manuel : man pdfposter) :

 pdfposter -mA4 -pA0 posterA0.pdf posterA0_A4.pdf

Autres logiciels

  • Sous Linux, Windows et Mac, vous pouvez utiliser le programme PosterRazor, qui possède une interface simple à utiliser. Note : PosterRazor ne peut découper que des images, il faudra donc choisir d'enregistrer le graphique au format PNG dans Gramps.
  • Sous Windows, il y a également Govert's PDF Tiler (nécessite .NET 1.1)

Dépannage

  • Si vous rencontrez un problème avec les polices de caractère (caractères manquants) ou une taille de police inadaptée, voir l'exemple 3 sur comment définir manuellement la police.
  • Si vous avez une mauvaise résolution pour le fichier png, un texte illisible, c'est probablement la taille du papier qui est trop petite. Voir l'exemple 1-A: définir la taille du papier, et modifiez également les Options de la mise en page, dans le ratio d'aspect : utilisez automatiquement le nombre optimal de pages, ou taille minimale.
Gnome-important.png
Rapports et identifiants personnalisés

Après l'importation d'un GEDCOM, votre base de données peut contenir des identifiants non-normalisés (par ex. 123I ou 456U non définis dans Édition --> Préférences --> Identifiants ID). Si le rapport généré n'affiche pas correctement vos données, alors essayez l'outil Réorganiser les identifiants Gramps... (Outils --> Modification de la base de données -->Réorganiser les identifiants Gramps...).

D'autres possibilités

  • Vous pouvez générer des graphiques pour les descendants et les ajouter à la galerie d'image pour la personne. Le graphique est disponible pour sur un site internet.
  • un graphique relationnel en flash, permet de zoomer, se déplacer, ... au-dessus de vos données, ou mieux encore, utilisez le format SVG pour Firefox et Opera, voir DenominoViso.

Comment aider au développement ?

Si vous regardez les spécifications du format dot, vous noterez qu'il y a beaucoup de possibilités avec GraphViz. Si vous avez des connaissances en programmation vous pouvez ajouter des fonctionnalités :

  • plus/au moins de texte dans les boîtes : quel texte et comment les organiser ?
  • Les couleurs. Voir le rapport Lignées familiales : une couleur par famille, pour les relations spécifiques, pour la souche, ...

Lien vers le manuel

Par ailleurs, jettez un oeil sur le graphique relationnel.