Addon:Themes

From Gramps
Revision as of 05:16, 13 February 2019 by Sam888 (talk | contribs)
Jump to: navigation, search
Gramps-notes.png

Please use carefully on data that is backed up, and help make it better by reporting any comments or problems to the author, or issues to the bug tracker
Unless otherwise stated on this page, you can download this plugin by following these instructions
Please note that some Addons have prerequisites that need to be installed before they can be used.
This Addon/Plugin system is controlled by the Plugin Manager


Preferences-Themes-addon.png

The Themes addon adds a small set of configuration settings to the Preferences dialog. The original 'Colors' panel is renamed to 'Theme' and the new settings added at the top of the panel.

There are three settings;

Theme:Adwaita setting allows the user to select from the installed themes on their machine. A few of the themes will come standard with the system library Gtk. Others may be part of the Operating System, particularly in Linux based systems.

Note that not all themes are fully compatible with Gtk and Gramps; if the theme selected doesn't look right, with missing elements or other issues, select another theme.

Dark Variant: If the selected theme includes a dark version of the theme as a subset, then this will activate the dark version.

Font This brings up a selector which allows the user to pick a Font, and/or change the font size. The fonts presented are those found on the system.

Default This returns Gramps theme settings to their default values, as if no changes were made with these settings. Note that the graph colors below are independent, they have their own 'Default' button to return them to the Gramps defaults.

The remainder of the dialog is described in Gramps_5.0_Wiki_Manual_-_Settings#Colors.

Installing your own theme

Windows

It is possible to change the Gramps theme on the Windows AIO.

The Gramps AIO version 5.0.x uses Gtk 3.18 or higher, so a theme MUST be selected that supports that version (themes that are designed for a later version may not work). The current Gtk version is reported in the Addon:Prerequisites_Checker_Gramplet.

Suitable themes might be found in [1].

Download the theme file (often a tar.gz) and if necessary decompress it using 7-zip of similar.

The decompressed files should be stored in "C:\Users\you\.themes" (replacing 'you' with your user name) so that the final directory structure looks like:

C:\Users\you\.themes\YourThemeName

Linux

You should follow instructions for your distribution. Some other information that could help is provided GEPS_029:_GTK3-GObject_introspection_Conversion#GTK_3_theme.

See also