3.1.x Third-party Plugins

From Gramps
Revision as of 09:28, 27 March 2010 by Lcc (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Third-party plugins give you more tools to work with your genealogy data in GRAMPS. This page lists plugins written by users to work with the 3.1 series version of GRAMPS, released in March 2009. These plugins may not be officially part of GRAMPS. Feature requests and bugs with these plugins should be directed to the contact information below. Plugins for previous versions of GRAMPS can be found on the 3.0.x Third-party Plugins page, and Plugins for the next version of GRAMPS can be found on the 3.2 Third-party Plugins page.

Installing Plugins in GRAMPS

To install a GRAMPS Plugin:

  1. click on the download link below
  2. if the download is a file that ends in .py, save it in your GRAMPS User Directory, in the plugins folder
  3. if the download is a file that ends in .zip or .gz, save the contents of the file in your GRAMPS User Directory, in the plugins folder
  4. restart gramps, OR reload the plugins from the Help -> Plugin Status -> Reload button.

The Plugin Status window will show you which plugins failed to load, double click on such an entry shows you the error. You can mail this error to the plugin contact.

Plugin List

See Plugin List Legend for details of columns.

  1. REDIRECT Plugins4.1

See Writing a Plugin for information on developing your own plugin.