# Table of Contents

Gramps 5.1 Wiki Manual .......................... 7
   Abstract .................................................. 7

## Preface
   Why use Gramps? ....................................... 8
   Typographical conventions in the Gramps Wiki Manual .. 8

## What's new?
   Before you upgrade ................................... 10
   Visible changes to the core ......................... 10
   Under the hood changes .............................. 11
   Further information ................................. 12

Getting started ...................................... 13
   Overview of Gramps .................................. 13
   Start Gramps .......................................... 14
   Choosing a Family Tree .............................. 14
   Tell me how to start right now! .................... 15
   Obtaining Help ....................................... 15

Main Window .......................................... 16
   Main Window ......................................... 16
   Switching Navigator modes ......................... 22
   Switching Categories ................................ 23
   Switching Views ...................................... 23
   Filters .................................................. 24
   Troubleshooting a misbehaving interface .......... 25

Categories ........................................... 26
   Categories of the Navigator ....................... 26
   Dashboard Category .................................. 27
   People Category ...................................... 28
   Relationships Category ............................. 30
   Families Category ................................... 34
   Charts Category ...................................... 35
   Events Category ..................................... 42
   Places Category ..................................... 43
   Geography Category ................................ 47
   Sources Category .................................... 58
   Citations Category .................................. 59
   Repositories Category .............................. 60
   Media Category ...................................... 61
   Notes Category ...................................... 62

Manage Family Trees .................................. 64
   Starting a new Family Tree ....................... 64
   Opening a Family Tree ............................. 65
Entering and editing data: detailed - part 3

Name Editor 142
Attributes 143
Addresses 144
Merging records 145

Navigation 155
Using the People Category 155
Using the Relationships Category 155
Using the Families Category 155
Using the Charts Category 155
Using Gramplets 157
Setting the Home Person 157
Setting the Active Person 157
Finding records 159
Using the Clipboard 160
Main Menus 161
Toolbar 167

Plugin Manager 171
Plugin types 171
Registration and loading 171
Hide/Unhide 171
Actions 172
Detailed Info dialog 172

Gramplets 174
What is a Gramplet? 174
Summary of Gramplets 178
Gramplets 179

Reports 207
Introduction 207
Reports 207
Substitution Values 208
Books 208
Graphs 208
Graphical Reports 208
Text Reports 209
Web Pages 211
Quick Views 211

Reports - part 1 212
Generating Reports 212

Reports - part 2 213
Substitution Values 213

Reports - part 3 219
Books 219

Reports - part 4 224
This is the Wiki Manual for Gramps version 5.1. All users are encouraged to edit this manual to help improve its readability and usability.

Research, organize and share your family tree with Gramps.

Gramps is a free software project and community. We strive to produce a genealogy program that is both intuitive for hobbyists and feature-complete for professional genealogists. It is a community project, created, developed and governed by genealogists.

Abstract

This Gramps Wiki Manual for version 5.1 is the online user's guide, detailing most aspects of the Gramps application, a database for the collection of genealogical information. As of Saturday, 26 August 2023, the most current Gramps release is the 5.1.6 version. Both Gramps and the accompanying Wiki Manual have been translated into multiple languages.

For older Wiki Manuals, see the archival versions made for previous releases of Gramps. The last downloadable manual (for offline use) was in 2012 for the version 3.3.x of Gramps.

To explore other sources of information about using Gramps, see the Information Portal.
Gramps is software (packaged for several operating system computer environments and languages) designed for genealogical research. Although similar to other genealogical programs, Gramps offers some unique and features which we'll discuss below.

Gramps is Free and Open-Source Software (FOSS), which means you are free to make copies, to customize the code, and to distribute it to anyone you like. It is developed and maintained by a worldwide team of volunteers whose goal is to make Gramps powerful, yet easy to use.

Why use Gramps?

Most genealogy programs allow you to enter information about your ancestors and descendants. Typically, they can display family relationships through charts, graphs, or reports. Some allow you to include pictures or other media. Most let you include information about people even if those people are not related to the primary family you happen to be researching. And they may include features that let you exchange data with other programs and print different types of reports.

Gramps has all these capabilities and more. Notably, it allows you to integrate bits and pieces of data as they arise from your research and to put them in one place -- your computer. You can then use your computer to manipulate, correlate, and analyze your data, rather than messing with reams of paper.

Typographical conventions in the Gramps Wiki Manual

In this book, some words are marked with special typography:

- **Internal links** (aka: hotlinks, hyperlinks) mark terminology or procedures that are explained more completely elsewhere (on the same webpage or on another webpage) internally within the Gramps-Project wiki.
- **External links** mark terminology that is not specific to Gramps where well-defined explanations can be found on a website external to the Gramps-Project wiki.
- **Applications**
- **Commands you type at the command line**
- **Filenames or Filenames**
- **Replaceable text**
- **Labels** for buttons and other portions of the graphical interface. A trailing • and ▼ in a column header indicates the sort order for table column. • more headers or tabs ▼
- **[≡]** for hover or roll-over hints (aka Tooltips) that identify elements of the graphical interface
- **Menu selections look like this:** Menu -> Submenu -> Menu Item (Spaces should enclose the -> to make webpage auto-translation recognize menu words.) Gramplet pop-up menus are marked with a ▼ (Down Arrowhead button).
- **Buttons** you can click
- **Disclosure triangle** node ▼ expand or ▲ collapse disclosure triangular widget. All the nodes of the tree view mode can be simultaneously collapsed or expanded from the pop-up menu shown by right-clicking.
- **CTRL+D** Key combinations you can press on your Keyboard.
- **Anything you type in**
  - ☑ Checked - Checkbox that is selected
  - ☐ Unchecked - Checkbox that is deselected
  - ◇ Radio button that is selected
  - ◮ Radio button that is deselected
- **Abbreviated Latin notations:** e.g., etc., i.e., N.B., P.S., viz., vs,

The manual also provides assorted bits of additional information in tips and notes as follows:

---

**Example Tip**

Tips and bits of extra information will look like this.
Finally, there are **warnings**, notifying you where you should be careful:

**Example Warning**

⚠️ This is what a warning looks like. If there's a chance you'll run into trouble, you will be warned beforehand.
What's new?

This section gives an overview of changes since Gramps version 5.0. These changes are also detailed later in this manual. Users of Gramps upgrading from earlier versions are encouraged to review this section in older user manuals to be sure to take advantage of these new features when they start using version 5.1.

Before you upgrade

Prevent Data Loss During Upgrades

Creating an archive before upgrading might not be sufficient to safeguard your data.

In the unlikely event that Gramps 5.1 corrupts your database, it could also corrupt the archive. Making a backup of your data as outlined in this section is recommended.

Before you upgrade, make sure your family tree data is secure. The best way to do this is:

1. Start your existing version of Gramps (Gramps 3.4 or Gramps 4.2 or Gramps 5.0)
2. Open your family tree
3. Back up the family tree to the gramps xml format or the gramps xml package format (the gramps xml package includes your photographs and other media files associated with your family tree data). Backup your tree via menu Family Trees -> Make Backup...
4. Close this family tree and repeat the above steps for any other family trees you have
5. Keep the resulting file(s) in a safe place

For more information, please review Backing up a Family Tree. Note what will not be included during a backup.

After properly safeguarding your data, proceed to install Gramps 5.1 using your operating system's regular installation process. In most cases, this will ensure that the new Gramps 5.1 installation will not clash with your older version of Gramps. However, it may be safer to uninstall Gramps 3.4 before installing Gramps 5.1, or make sure you install Gramps 5.1 in a different location. This is always necessary if you are installing from the source code. For more information on installing Gramps 5.1, please see Downloading the latest Gramps.

After you install Gramps 5.1, you can open your existing family trees and continue working. In case of problems (e.g., after a complete system upgrade), import the backup file(s) created above to recreate your family tree(s).

Warning

Once you open a family tree in a newer version of Gramps or using a newer operating system, you generally should not try to open that database using an older version again. As always, the gramps xml format is the format to use for the interchange of your data in such cases. There are tools to repair broken databases, but they are for expert users, so avoid needing them by following the steps above before you upgrade your OS or Gramps.

Visible changes to the core

Changes visible after the migration: interface, data.

Data Model

Details of changes to the data model (if any):

1. No change

- A Family Tree cannot be opened in Gramps 3.4/4.0/4.1/4.2 and Gramps 5.1 without upgrade.
- A downgrade can only be accomplished by exporting XML and importing to the previous version.
- A Gramps XML file generated by Gramps 3.4/4.0/4.1 is not identical to one generated by Gramps 5.1.
- Gramps 5.1 is now python3 only

See detailed changes for more details on internal database.

Primary changes

- SQLite is now the default database backend rather than BSDDB. You can still choose to use alternative database backends. BSDDB remains available as a standard alternative. For power users, PostgreSQL and MongoDB are available as experimental third-party addons.

The developers believe that SQLite may have fewer database corruptions that prevent easy recovery.
• Options for automatic backup periodically and on exit. The Backup on exit is the default.
• Config. new database-backup-use-compression option

GUI

• New color schemes allow a light and dark choice.
• Additional color indications in graphs for Home person, Unknown Alive, Family, Family divorced.
• Add "within <n> km/miles/degree" filter
• Ability to be able to enter comma separated latitude/longitude pairs
• Sidebar resizes better, position is remembered
• Person SurName editor is more intuitive to use.
• View Buttons order no longer changes with different startup.
• Better progress indication for long running operations
• Windows remember size/position
• add FanChart2Way
• Add kmls for the geography places view.

Place

• ability to search alternate place names when selecting place

Reports, Tools, Gramplets

• new genealogy tree report
• Place format editor and option for many reports
• Date format Editor and option for many reports
• option how to report living people for many reports
• ReorderIDs tool has been upgraded; can now work around customized IDs (like GetGov IDs).
• Narrative web has additional options and appearance changes.
  ◆ Allows output in different language
  ◆ Date output option
  ◆ Statistics page
  ◆ Add option to Include all / unreferenced Media objects
  ◆ relationship to central person on individual pages
• Add thumbnail size option to family lines graph
• Enhance the Descendant Report and Detailed Descendant Report
• Complete Individual Report add options
  ◆ enable to include or exclude Person and Family Notes
  ◆ add option to include or exclude census data
  ◆ option to include relationship to center person
  ◆ options to include GrampsID, Tags, Attributes
• Include all place types in place report
• Relationship, Family Lines, Hourglass Graphs options how lines are drawn
• New: Clean input data Tool - Removes leading and trailing spaces.

Import/Export

• GEDCOM supports more non-standard 'tags' and additional standard tags
• GEDCOM 5.5.1 Support Custom Event on export
• XML export new compression option. (Feature request 9394 Allow Gramps to export a .gramps file, without compression Pull request 121 Add compression option on XML export)

New Addons

• Quilt Chart view: The view shows a quilt chart visualization of a family tree
• Plugin Manager Enhanced: An Addon/Plugin Manager with several additional capabilities
• Sandclock Tree: Sandclock tree using LaTeX genealogytree
• Import and Merge tool: Compares a Gramps XML database with the current one, and allows merging of the differences.
• Check Associations data: Will check the data on Association for people.

Under the hood changes

Technical changes.

• Numerous changes relating to support for other database backends (SQLite, PostgreSQL, MongoDB etc.).
• Alerts on certain database corruptions (handles to non-existent objects) that were previously suppressed are now regarded as errors. It may be necessary to run the Check and Repair tool to fix exceptions with a corrupted database.
• Fixes to prevent the user from closing or changing the database during long running operations.

Dependencies

• Support python3 only. (Python2 support dropped ahead of the Jan. 2020 EOL zero hour)
• Need GTK+ 3.10 and PyGObject 3.12 or greater versions
Further information

Miscellaneous

Localization

- Update translations: ca, cs, da, de, en_GB, eo, fr, fi, hu, is, it, lt, nb, nl, pt_BR, pt_PT, ru, sk, sl, uk, vi

Roadmap

- Explore the Release Notes for previous releases of Gramps
- See projected items related to Gramps next version.
- Gramps Enhancement Proposals (GEPS) - See Released column for new items implemented in Gramps 5.1
- 5.1 Roadmap - wiki

Changelog

- See items related to Gramps 5.1 on the Gramps issue tracker.
- See additional information see the changelogs for the maintenance releases of Gramps:
  - Gramps 5.1.0
  - Gramps 5.1.1
  - Gramps 5.1.2
  - Gramps 5.1.3
  - Gramps 5.1.4
  - Gramps 5.1.5

What Was Once New

The Previous Release page includes links to bullet lists of changes in major releases and maintenance releases over the years.

However, the What's New? pages in the superseded version of the wiki manual for each major releases can provide greater detail:

- Version 5.0
- Version 4.2
- Version 4.1
- Version 4.0
- Version 3.4
- Version 3.3
- Version 3.2

A compact overview of enhancements was first added to the manual in 2010. For the first 3 years of the wiki, it was necessary to review the entire manual.

- Version 3.1 - Full manual
- Version 3.0 - Full manual

The initial MediaWiki documentation was begun in 2006. Prior to the 2.9 edition of the manual, the documentation was distributed with the Gramps software. The downloadable manual was eliminated with the Gramps 3.0 version.

- Gramps 2.2 (manual version 2.9)
In this section, we'll begin with the basics. First, we'll describe the basic concepts in Gramps. Then, we'll show you how to start Gramps and how to get help when you need it.

**Overview of Gramps**

Gramps is a free, open source program that has been designed to be a flexible and powerful genealogy tool. It is a framework for collecting genealogical data, noting how each piece of data interrelates and presenting those relationships.

One can generally use Gramps any way one wishes. There is no single, correct method of working with or recording your data. However, if you wish to collaborate with other researchers or programs, it helps to conform to some common guidelines. Even if you are familiar with common genealogy research practices, you still need to understand how Gramps works. Then you can jump into how to use the Gramps program in a way that complements a particular genealogical research style.

Gramps separates all genealogical information into 9 primary categories of items:

- People
- Families
- Places
- Sources
- Citations
- Repositories
- Media
- Notes

Each of these is composed of stand-alone items. That means that you can enter into your family tree one item at a time, and in any order that you want. You can connect the items to one another or leave them disconnected (or even chaotically disorganized) but searchable. Or you can start with a Tree design in mind and fill it outwards, connecting new items as you go.

For example, you might want to enter each Person item first, and then connect them together by creating Family items later. Or, you can start with a Family, anchor the family by adding a new Person as a child or parent, then add relatives, events & source materials in the prepared slots of the Family framework. Or, you might start with Source items, and only create a Person item when your research includes a mention of someone. Or, you can mix these styles of entering data by adding some Note and Source items, then Family items, then later return to Notes and Sources. In short, you do your genealogical research however you wish.

If you have additional questions, Gramps has a community of users and developers. There is a FAQ (frequently asked question list); a mailing list; a bug, feature request, and issue tracker; and you can interact using on-line chat rooms or community forums.

**Connections**

These 9 primary items are connected in a number of ways. Some of these connections are maintained implicitly. For example, adding a Person item to a Family item as a parent, or child, automatically creates a special connection, called a Reference. You can see the Families a Person is connected to in the References tab on the main Person window. There are many other ways that these connections are also visualized in Gramps, including the Relationship View.

To keep from repeating information, Gramps allows you to reuse, or share, items. These are also special connections, called links. For example, a Person item can be linked to any number of Note items. If a note mentions two separate people, then it might make sense to share that single note with both of the person items.

Some links have information themselves. For example, you can link a person to another couple's marriage event, say, because the person was a witness at their wedding. However, the husband and wife are linked to the marriage event in a primary role, whereas a witness fills a different role, e.g. as a witness. This type of information is kept on the link itself, in the role property.

**Privacy**

Gramps supports two different methods to protect the privacy of sensitive data in your family tree. These methods are used when sharing your data with others, either through the creation of a report, exporting of data, or through the creation of a website.

The first method protects information on people who Gramps believes are alive. If you have not specifically indicated that a person is dead (by adding a Death Event to a Person item), then Gramps has a sophisticated, automatic function for determining if someone is alive. Living people have their sensitive data redacted when using this method. For example, a person named "Smith, John" could appear as "Smith, [Living]".

The second privacy method is an explicit "private" flag which you can set on each item. For example, you might have sensitive, personal information in a Note. If you mark such a note as private, then that note will not be shown in textual and narrative reports or exports. Also be aware that some links themselves can be marked private. This is useful when you want to mark the connection from, say, a person to an event as private, but still have the person and the event available in the report, export, or website.
In order to activate these two methods of privacy, you will need to indicate their use when creating some reports or exporting your data.

GEDCOM

Gramps derives its core structure of items from a standard called GEDCOM. However, Gramps extends this standard where it has been deemed necessary. If you plan on using your family data with another system which uses GEDCOM, then you probably will want to try to restrict your use of features that are Gramps-only extensions. On the other hand, if you are not limited by other genealogical software, then you can enter your data in whatever ways make sense to you.

You can read more details about this issue in the section on Gramps and GEDCOM.

Start Gramps

The best way to learn Gramps is by working with your data. Let's get started!

The way you start Gramps depends on the operating system you are using.

As well as starting Gramps using the normal graphical user interface (GUI) as described below, it is also possible to start Gramps using a command line interface (CLI). CLI use can produce reports that are not available via the GUI, it can be used to create reports, do conversions etc. without opening a window, and can provide extra information in the event of problems. For more information, see the Command Line appendix.

Linux

Only the Linux platform is officially supported as Gramps developers use and test the source code on that platform, fixing any problems that arise due to upgrades.

Assuming you have used the standard Package Manager (either through a CLI or a GUI) for your Linux distribution, you will start Gramps in the normal way for your distribution. For example in Ubuntu 18.04, an icon is placed in the launcher, or the program can be started from Dash. For other distributions, an entry may be created in the Application menu (normally in the Office section).

Starting Gramps through the CLI on Linux is covered here.

MS Windows

MS (Microsoft) Windows is a community supported platform. If you install the Windows AIO GrampsAIO32 or GrampsAIO64 executable, then this will place an icon on the desktop as well as a menu item in the 'Start' menu, and you click on that to start Gramps.

Starting Gramps through the CLI on MS Windows is covered here.

There are other ways to install Gramps for MS Windows, but these are much more complicated and are not covered here.

Mac OS X

Apple Mac OS X (MacOS) is a community supported platform. If you download the Mac OS X disk image (.dmg), then you simply drag the application to your application folder (or anywhere else you want to store it) and start Gramps by double clicking on the application in the normal way.

Starting Gramps through the CLI on Mac OS X is covered here.

There are other ways to install Gramps for Mac OS X, but these are much more complicated and are not covered here.

Choosing a Family Tree
If Gramps is started without a family tree selected, the initial screen will have little functionality. Most operations will not be available. To load a family tree (also referred to as a database), select in the menu Family Trees->Manage Family Trees to open the family tree manager, or click the Family Tree icon in the toolbar. Gramps keeps track of your recently opened Family Trees, and these can be selected by clicking on the arrow next to the Family Tree button and choosing from the drop down menu.

For more detailed information on the Family Tree manager and the Family Trees menu, see the chapter dedicated to this: Manage Family Trees.

Tell me how to start right now!

We advise everyone to read the manual to learn all about using Gramps. Genealogy takes time, so learning the tools is not wasted time.

However, if you really want the bare minimum to start, then read this:

- Gramps 5.1 Wiki Manual - Entering and editing data: brief
- How-To start with Genealogy using Gramps

Obtaining Help

Gramps has a Help menu that you can consult at any time.

- See the Help menu section.
Main Window

Elements of Gramps main window or A Visual Guide to the Gramps Interface.

Graphical User Interfaces (GUIs) are a way of arranging information on a computer screen that is easy to understand and use because it uses icons, menus, and a mouse rather than only text.

While a GUI is much more intuitive than memorizing keyboard commands, it is hard to learn from the feature documentation without knowing the feature’s name to lookup. Many elements are not labeled in Gramps to reduce clutter and maximize space for displaying Genealogical information.

There are even preference options to not show text labels for the buttons (icons) in the Category Navigator panel.

So this section of the Wiki Manual gives the standardized names of Gramps screen elements. Armed with the standard names, you can more efficiently use a search engine (like Google) to find pages in the online manual that discuss that element. As an example, to search for Gramps Wiki Manual pages on the "Navigator Mode" phrase, use following the Google search terms:

"navigator mode" site:gramps-project.org/wiki

This particular search even finds descriptively named illustrations of selecting the modes for the Navigator sidebar. Selecting one of those images shows a webpage about the illustration and where it is used in the documentation. Those illustrated pages tend to have greater introductory material.

If a particular screen element does not appear among the images below, look through the Gramps Screenshot Gallery. This page shows the Gramps thumbnail screenshots that are used throughout the documentation. Click the thumbnail image to show the full sized image and variants of that image, then scroll down to the "File usage" section to find Wiki pages that illustrate the features within that screenshot. Likewise, the Gramps Icon Gallery identifies the proper names of icons used throughout Gramps.

Once you are familiar with the screen elements, explore the keybindings or hotkeys to learn the shortcuts for features used so frequently that keyboard shortcuts have been created.

Main Window

When opening a (new or existing) Family Tree database, the introductory Gramps Dashboard window will be shown in the "Display Area" with the Sidebar and Bottombar hidden. Upon selecting the People Category from the Navigator, the Main Window layout will updated to show the "Person (List) View" in the "Display Area". See Fig. 3.1:

The main Gramps window contains the following elements:

Window Title Bar

- Window Title Bar shows the name of selected Family Tree, the name of the Category view, Gramps application name and buttons to minimize, maximize and close Gramps. The window can also be dragged from the Title Bar.

Menubar

- Menubar: The menubar (Main Menu) is located at the very top of the window (right below the window title) and provides access to all the
features of Gramps.

- Menus are contextual - the options shown depend on which category is active.
- Clicking a menu's header label opens that particular submenu. Submenu items may be dimmed (unavailable) if they are not usable with the active item.

**Typographically**, Menu selections will look like this in the wiki manual: **Menu -> Submenu -> Menu Item.**

![Visibility of elements](image)

Using the **View** menu, you can hide or unhide several elements of Main Window.

In addition, there are Preference option to hide or reveal aspects of the elements -- such as text labels, scrollbars and Close gadgets.

---

**Pull-down menus**

![Pull-down menu](image)

Outside the menubar, the occurrence of the unlabeled **Down Arrowhead** pull-down menu button indicates additional options are available for the interface item to its left.

**Pop-up menus**

![Pop-up menu](image)

The most invisible interface option might be the **contextual pop-up menu** (aka "context menu").

Right-clicking an interface item (or on a selected record row in a table) will reveal a pop-up menu of shortcuts to some frequently useful features for that item (or record).

Note that the right-clicking on row in a table other than the selected (high-lighted or 'active') row still reveals the pop-up menu related to the selected row. So, left-click the row first to select then right-click for the menu.
Right-clicking on objects is a familiar theme in GUIs. But right-clicking in the empty header space of any Object Editor is less obvious. However, this right-click will reveal another contextual pop-up menu with other shortcuts to useful reporting and navigation options.

**Toolbar**

- The **Toolbar** is located right below the menubar. Its buttons give faster access to the most frequently used functions for the active screen of Gramps.
- The assortment of toolbar buttons is context sensitive. Which Tools are shown depends on which category is active. And only the buttons for submodes of the currently selected view category are included in the toolbar.

- Configurable Options: most Category views have a ![Configure...] button as an alternative to choosing the View > Configure... from the View menu, or pressing the Configure active view keyboard keybinding. This option opens a dialog with choices for customizing the display records in the View. Basic customizations might include choice of sorting order and choice of whether to display specific details.
- Configuration customizations are persistent. They are carried over to future sessions using Gramps.
- Hovering over a toolbar icon shows a tip of its function

The Toolbar can be hidden or revealed by the option in menu View > Toolbar.
Installing a Third party Addon

allows Gramps to show toolbar text labels for each Toolbar button. The Themes addon augments the Preferences dialog with a Theme tab.

One of options of the Theme tab is a ☑ ToolBar Text checkbox. Selecting the checkbox causes the text labels to appear. This checkbox is deselected by default.

Fig. 3.6 Added Theme tab options for the Preferences dialog.

Navigator

- Navigator: The navigator is an optional sidebar located at the left of the window and allows selection of the different categories. See Categories of the Navigator

The Navigator is shown by default but this sidebar can be optionally hidden or revealed from the menu View -> Navigator or the keybinding `CTRL + M` ( `⌘ Cmd + M` on MacOS.)

Also see:

- Switching Navigator modes
- You can hide the text labels by deselecting the ☑ Show text label beside Navigator buttons option in the Edit -> Preferences Display tab.
- Navigator sidebar features (View categories, View Modes, and Navigator interface styles) can be added, removed, hidden or revealed using the Plugin Manager.

Display area

- Display area: The area in the center of the Gramps window is the display area. What it displays depends on the currently selected View category. We will discuss Views in detail below.

Status Bar and Progress Bar

- Status Bar and Progress Bar: These are located at the very bottom of the Gramps window.
  - The Progress Bar is located in the lower left corner of the Gramps window. It displays the progress of time consuming operations, such as opening and saving large Family Tree databases, importing and exporting to other formats, generating web sites, etc. When you are not doing these types of operations, the Progress Bar is not shown.
  - The Status Bar is located to the right of the Progress Bar. It displays information about current Gramps activity and contextual information about the selected items. (You can also edit the Display Preferences to show the Active Person's Relationship to the home person.)
  - The Status Bar may occasionally show a passing alert, warning of unusual conditions. An informative Warning button with a superficial summary (like the one below) will be displayed for three minutes at the left of the Status Bar. Clicking this lightbulb icon will show details of these minor alerts.
Bottombar and Sidebar

The **Gramplet Bar** is also known as the Bottombar and Sidebar.

- **Bottombar:** The bottombar is located below the display area.
- **Sidebar:** The sidebar is located to the right of the display area.

The Bottombar and Sidebar can be individually hidden or revealed by options in menu **View** or the relevant keybinding. If the Sidebar is hidden the **Search bar** will be displayed.

The Bottombar and the Sidebar allow **Gramplets** and **filters** to be displayed alongside a view.

Gramplet Bar Menu

You can also add / remove and restore the default Gramplets by clicking the **(Down Arrowhead button)** also known as the **Gramplet Bar Menu** at the far top right of the bars titles, and then using one of the options from the drop-down menu eg:

- **Gramplet Bar Menu**
  - **Add a gramplet** - Displays a list of Gramplets available for use on that **Gramplet Bar**
  - **Remove a gramplet** - Displays a list of Gramplets currently shown on the **Gramplet Bar** available for removal.
  - **Restore default gramplets** - Displays the **Restore to defaults?** confirmation dialog, that allows you to restores the **Gramplet Bar** to its default Gramplets.

**Restore to defaults? dialog**
The **Restore to defaults?** dialog allows you to restore the Gramplet Bar to its default Gramplets. This action cannot be undone. Select **OK** to confirm or select **Cancel**.

**Search Bar**

If the Sidebar is not displayed in a Category view with a list, then the **Search Bar** is displayed instead. Available search options vary depending on Category View you are in. But a visible sidebar makes the Search Bar Invisible.

A **Search Bar** is available for the following Views and the Select windows for the following Categories: People, Relationships, Families, Events, Places, Sources, Citations, Repositories, Media, Notes. *Not Available in the following Category Views: Dashboard, Relationships, Charts, Geography.*

Typing the characters into the **Search Bar** and clicking the **Find** button will display only lines that match the text.

Note that various **selectors** also have search bars:

- **Family Selector**
Switching Navigator modes

You can choose the `navigator` mode from the sidebar `Category` drop down list:

- **Category** (Default)
- **Expander**
- **Drop-Down**

When labels have been disabled for the Navigator in Preferences, this Category drop-down list control becomes the widest object. Its width limits how narrow the sidebar may be resized. The control can be made to disappear by using the Plugin Manager to hide (or remove) all but your single preferred Navigator sidebar mode. (When only one mode remains unhidden, there is no need for a menu and it will also become hidden.)

**Category navigator mode (default)**
Category Sidebar - A sidebar to allow the selection of view categories.

Expander navigator mode

![Expander Sidebar](image1)

Fig. 3.15 Expander navigator mode

Expander Sidebar - Selection of views from lists with expanders ▶ arrows.

Drop-Down navigator mode

![Drop-Down Sidebar](image2)

Fig. 3.16 Drop-Down navigator mode

Drop-down Sidebar - Selection of categories and views from drop-down lists.

Switching Categories

Gramps comes with number of different standard View categories built in, each of which has one or more standard View modes. The built-in categories are described in the introduction to the Categories of the Navigator.

Expanding the Views

You can download addon a 'Gramps View' in the General tab Preferences menu (or activate or remove previously downloaded Addon Views) via the Plugin Manager.

- If the view is a new mode (subcategory), the toolbar, menus and Navigator mode lists are modified to give access to the new layout.
- If it is a View of an existing category, then the layout is replaced for that category.
- If it is a new category of view, then an entire new visualization will be added with an additional icon appended to the navigator selections.

The way you change the currently displayed category depends on the navigator mode. Normally (for most navigator modes) you can select the category you want by clicking one of the navigator icons.

Alternatively you can use the keyboard shortcuts CTRL+<number> or Alt+<number> (on a Mac) go to the next or previous category respectively or use keyboard shortcuts CTRL+<number> (on a Mac) Shortcut are only available for the first 10 categories (e.g. Repositories/Media/Notes categories miss out on shortcuts.) If you have hidden the Navigator then shortcuts will be the only way to change categories until you turn the Navigator on again.

Switching Views

A View category can contain different ways of presenting the data, called a View mode. If there are several viewing modes, you can switch between modes interactively. The way you change between the modes depends on the Category View. The Configuration options for each mode are independently controlled.

In Views styled in tables of data with rows and columns, the modes are typically between a hierarchically grouped outline or a simple single-level sortable list. Table style view modes are configured with the Column Editor and have have sorting options.
In some graphical Category Views (like Charts and Geography) there may be a wide variety of viewing modes.

Fig. 3.17 Navigator sidebar in Expander mode

When there are multiple viewing modes, will be additional icon buttons on the toolbar to switch between those different viewing modes.

You can also switch via the View menu, or the View menu keybindings by pressing Ctrl + Alt + <number> (for Linux & Windows) or Cmd + Alt + <number> (for MacOS), where <number> corresponds to the order of viewing modes listed in the category's View menu.

Modes are also selectable from the Navigator sidebar when using the Drop-down or Expander arrangements. The Navigator sidebar defaults to the Category arrangement which has no mode selector. Using the Drop-Down or Expander mode makes the additional viewing modes available as Navigator icons.

Filters

Fig. 3.18 Filter Controls Displayed

Genealogical databases can contain information on many people, families, places, and objects. That means it is possible for a View to contain a list of data so long that is difficult to navigate. Beyond the basic seek-as-you-type Find box for precision navigation of the list, Gramps gives you two different means for filtering a list to a more manageable size.

These methods are Search and Filtering.

A search will search the text displayed in list, whereas filters display people whose data match the criteria of the filter.

Search is a simple but fast method of searching the columns displayed on the screen. When the sidebar is not displayed, the Search bar is displayed. Typing the characters into the Search bar, and clicking the Find button will display only lines that match the text.

Alternatively, you can enable a filter in either the bottombar or the sidebar. When the filter sidebar is displayed, the search bar is not displayed. The Filter allows you to interactively build a set of filter rules that can be applied to the display. The filter is applied based on the rules and the data, not on the screen display. Filters of the displayed category can also be constructed by clicking on the corresponding 'editor' button in the Edit menu.

Further details of how filters work is given in the Filters Chapter.
Searching vs. Filtering

Searching only searches for exact text matches. If the date displayed is "Jan 1, 2000", a search of "1/1/2000" will fail, but a filter of "1/1/2000" will match because it matches the date value rather than the formatted date.

When Gramps opens a Family Tree, no filtering is in effect. In People View, for example, all people in the Family Tree are listed by default.

Troubleshooting a misbehaving interface

If your Gramps GUI is behaving contrary to the manner described in this guide, you may have an installation or minor compatibility issue. It is likely that the behavior has been seen before and a solution has been identified.

Please review the Troubleshooting pages. If you are unable to discover the solution there, post a description of the problem to the general Gramps community on our user maillist. We help each other constantly there.
Genealogical information is very broad and can be extremely detailed. Displaying it poses a challenge that Gramps takes on by dividing and organizing the information into a series of Categories, each with their own Views. Each View displays a portion of the total information, selected according to a particular category. This will become clearer as we explore the different Categories.

Categories of the Navigator

The different Categories of the Navigator: The navigator is located at the left of the window and allows selection of the different categories.

By default, the Navigator is configured to select Views by main Category

New users may find that re-configuring to the Drop-Down option would make selecting the alternate View modes more intuitive. The Drop-down and Expander options create mode selectors in close proximity to the Category icon and those interface options will not change with context.

Fig. 4.1 Navigator mode selection drop down list

- **Dashboard**: Displays different general purpose Gramplets, small widgets that can help in your genealogical research.
- **People**: List of people in the family tree.
- **Relationships**: Displays the relationships between the Active Person and other people in a textual way. This includes the parents, siblings, spouses, and children of that person.
- **Families**: List of families in the family tree.
- **Charts**: Displays graphical trees for the selected person.
- **Events**: List of events in the family tree.
- **Places**: List of places in the family tree.
- **Geography**: Displays place data of your family tree on a map.
- **Sources**: List of sources in the family tree.
- **Citations**: List of citations in the family tree.
- **Repositories**: List of repositories in the family tree.
- **Media**: List of media objects in the family tree.
- **Notes**: List of notes in the family tree.

Fig. 4.2 Drop-Down navigator mode showing People Category view modes
The categories can contain several ways of presenting the data. Each specific way is called a View mode. For example:

- **People view category**
  - Grouped People default hierarchical list mode
  - People alternate flat list mode

For each category you have a variety of ways to switch between View modes:

1. by selecting the relevant icon from the toolbar
2. from the menu View > ...
3. from the Navigator bar when the Drop-down or Expander features are selected (See Switching Navigator modes)
4. Via the number-based **keybindings** (aka keyboard shortcuts) to Change the view mode to correspond to number key `0/1/2/...9` in this view category

The following sections provide a brief description of each category and the view modes within.

**Dashboard Category**

![Dashboard Category](image)

This contains the **Dashboard**, which shows a number of widgets, called Gramplets, that can help you in your research.

Two Gramplets are shown by default on start-up (the **Top Surname** and **Welcome to Gramps!** Gramplets) in two column configuration. (The number of columns can be changed with the Gramplet layout "Configure" controls provided in the toolbar and view menu.)

You can change the Gramplets on the Dashboard by using the context menu (right-clicking) on an empty area of the Dashboard View. This will show a pop-up menu to "Add a gramplet", populated with a list of the possible Gramplets you may add and use with this particular view. (Some Gramplets are only available in particular category views.) It is better to have a Family Tree open when changing out Gramplets. The added feedback of some tree data in the Gramplets will help make choices about configuring the layout.

- **Age on Date** Gramplet - list the people alive and their ages on a particular date
- **Age Stats** Gramplet - list age span statistics in a number of graphs
- **Calendar** Gramplet - see people's events on a particular date, or in a month in the past
- **FAQ** - Frequently asked questions about Gramps.
- **Given Name Cloud** Gramplet - most popular given names
- **Quick View** - run a Quick View on the current person
- **Records Gramplet** - see world's records of your data
- **Session Log** Gramplet - keep track of what you have done, and what records you have visited
- **SoundEx Gramplet** generates SoundEx codes for the names of people in the database.
- **Statistics** Gramplet - see stats on the database
- **Surname Cloud** Gramplet - most popular surnames as a "text cloud"
- **To Do** Gramplet - a notepad to keep tabs on your research
- **Top Surnames** Gramplet - top 10 most popular surnames (default)
- **Welcome** - a Gramps welcome message (default)
- **What's Next** Gramplet - what needs to be done next

In addition, there are a number of Third party Gramplets that you can easily install and use. These include:

- **Headline News Gramplet** - current, breaking news from Gramps
- **Data Entry Gramplet** - edit active person's name, birth date and place, death date and place, and add people
- **Python Gramplet** - a Python shell
- **Note Gramplet** - see and edit active person's primary Person Note

and many others. See Third-party Addons for more details.

For more detailed information on using the installed Gramplets, see Gramplets.

**Gramplet Layout**

Categories - Dashboard Category
You can change the Number of Columns: for the Dashboard on the Gramplet Layout tab or change the options for the other displayed Gramplets on the related tabs, click the button. Alternatively, you can choose Configure... from the View menu.

**People Category**

In the People Category, the People List view or Grouped People (default) views display a list of all people in the family tree without their connections. From this view, you may add, edit, remove, or merge people. Each view (List or Grouped) display several columns of information about each person.

By default, the view displays the Name, ID, Gender, Birth Date and Death Date columns for each Person. Additional columns for Birth Place, Death Place, Spouse, Number of Parents (in the topmost or Primary family), Number of Marriages, Number of Children, Number of To Do Notes, Private, Tags and Last Changed may be displayed. The People view also defaults to showing the Sidebar tabs and Bottombar.

The Column Editor dialog can be used to show, hide and change the order of the displayed columns. This editor can be accessed by selecting View ➡ Configure... from the menu or by clicking the button on the toolbar.

See also
- Using the People Category
- Editing information about people

---

**For Information displayed in the columns**

Some of the column selection types require that the event being shown has the Role type of Primary eg Birth and Death Dates. This is set via the Event Reference Editor dialog's General tab.

**Column counts for Number of xxxxxx**

For Number of Marriages only relationships of type Married are counted. For Number of Children only children with a Birth relationship are counted. However, for Number of Parents any parent in the Primary relationship (even those with a relationship of 'None') will be included in the parent count.

---

**Tree View - Grouped People**

People are grouped according to their family names. To the left of each family name is typically either an arrow (↑) or some other type of indicator (eg: +). Clicking it once will reveal the entire list of people sharing that name. Clicking the indicator again will "roll up" the list and show only the family name.

Additional options are available by selecting a person from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward

---

Categories - People Category
People List View

Tree View - People List View

List of all the people in the database, sorted by first column which by default is the *Name* column.

Additional options are available by selecting a person from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Home
- Set Home Person
- Add...
- Edit...
- Delete
- Merge...
- Quick View
  - All Events
  - Father Lineage
  - Mother Lineage
  - Person References
  - Relation to Home Person
  - Same Given Names
  - Same Surnames
  - Siblings

People Category Bottombar tabs

Both Tree Views (Grouped People/People List View) have the following *Bottombar* tabs. The configuration is independent between modes.

Details
Both Tree Views (Grouped People/People List View) have the following Sidebar tab by default. The configuration is independent between modes.

The Relationships Category shows the default view which displays all the relationships of the Active Person (the selected person). Specifically, it shows the parents, siblings, spouses, and children of that person.

The Relationships Category is designed to allow for quick navigation. You can quickly change the Active Person simply by clicking the name of any person listed on the page. Each name is actually a hypertext link, similar to a web page.

The name of the Active Person is in bold style. Other names are shown either with or without bold and italic emphasis depending on whether certain relationships exist for the named person. For a person listed as a parent or spouse of the Active Person, the name is emphasized if that person has a parent family. For a person listed as a sibling or child of the Active Person, the name is emphasized if that person has children.

Dates are normally in regular style, and in italic style if the displayed event is a fallback event, i.e., a substitute event for another missing event. That may be baptism event for birth event, burial event for death event, etc.
For the Relationships Category views via the menu or toolbar you may select:

- **Edit>Edit...** or the [Edit the active person] icon - opens the [Person Edit dialog](#).
- **Edit>Add New Parents...** or the [Add a new set of parents] icon - to create a new family with the Active Person listed as a child.
- **Edit>Add Existing Parents...** or the [Add person as child to and existing family] icon - which opens the [Select Family selector](#) allowing you to choose from a list of existing families, and then add the person as a child to that family.
- **Edit>Add Partner...** or the [Add a new family with person as parent] icon - to open the [Reorder Relationships dialog](#).

The following sections are available:

**Active Person**

- At the top of the screen, name, **ID**, **Birth**, and **Death** information, as well as the calculated age of the Active Person is displayed. You may highlight and copy the **Birth** and **Death** text fields.
- On the right hand side a photo of the person if available, will be shown. This photo shows the first image available in the [Gallery tab](#) of this person (if any exist). You can click on the photo to open it in the default picture viewer.
- Next to the person's name is a symbol indicating gender, and an [Edit button](#). Clicking the [Edit button](#) will allow you to edit all of the person's individual information in the [Edit Person dialog](#).
- See also: [Setting the Active Person](#)

**Parents**

The Parents section, displays the families in which the person is a child. Since it is possible for a person to have multiple sets of parents, it is possible to have several Parents sections.

You may edit an existing parents by selecting the [Edit button](#) next to the parents. If you select the [ ] button next to a set of parents, then the Active Person will be removed as a child from the parents. This button does not delete the parents' relationship.

See the [Configure Relationships section](#) to configure what details to show or hide etc...

---

### Warning

If you are not careful, it is possible to create multiple families with the same parents. This is rarely what the user wants to do. If you attempt to add a new family that has the same parents as an existing family, Gramps will issue a [Duplicate Family](#) warning dialog. If you get this dialog, you should probably Cancel the edit, and then use the [Select button](#) to select the existing family.

---

**Select Family selector**

The [Select Family](#) selector dialog allows you to link to an already existing Family.

The following columns are shown: **ID**(default sort for list), **Father**, **Mother**, **Last Change**.

You may use the [Find button](#) to filter the list based on one of the options from the drop down list:

- **ID contains** (default)
- **ID does not contain**
- **Father contains**
- **Father does not contain**
- **Mother contains**
- **Mother does not contain**
- **Last Change contains**
- **Last Change does not contain**

---

**Fig. 4.8 Select Family - selector dialog example**

---

**Categories - Relationships Category**
Siblings

The Sibling section shows brothers and sisters of the Active Person plus the Active Person themself.

Family

Similar to the Parents section is the Family section, which displays families where the Active Person is a parent. Because it is possible for a Person to have been a partner in multiple families, Gramps allows multiple Family sections to describe that. Each family section displays the spouse and any children. Children who were biological offspring of both partners in one Family might be a stepchild or adopted child for one partner of a subsequently formed family.

Spouse

We use the term spouse for sake of simplicity. However, please note that spouse may in fact be a domestic partner, a partner in a civil union, or various other similar relationships between two people. Spouse relationships are not required to be only between a male and female.

You may add a family by selecting the Add Spouse button in the toolbar. This will create a new family with the Active Person listed as a father or mother.

Selecting the Edit button next to the spouse will allow you to edit the displayed family. Clicking the - button will remove the person from the displayed family.

Removing a person from a family

Removing a person from a family does not delete the family. The person is removed as the father or mother, and any other relationships in the family continue to exist.

Note

We use the terms father and mother for the sake of simplicity. Even if there are no children in a family, the father and mother terminology is still used. In the case of male/male or female/female relationships, the father and mother labels should be considered to be convenience labels.

Reorder Relationships dialog

Select the Change order of parents families button to display the Reorder Relationships dialog that will allow you to reorder the families. The topmost family is considered the Primary family and is the family used for charts, graphs and summaries.

This option will only be enabled

if more than one set of parents or more than one set of spouses exists for the Active Person.
When more than one set of parents or more than one set of spouses exists for the Active Person.

Select one of the following:

- the menu Edit > Reorder
- or the Change order of parents and families toolbar icon button
- or the Reorder Parents icon near the Parents label
- or the Reorder Families icon near the Family label

to display the Reorder Relationships dialog that will allow you to reorder:

- the parents order in the top section Parent relationships using the up/down arrow buttons.
- or families order in the bottom section Family relationships using the up/down arrow buttons.

Children

The Active persons children.

Configuration

![Configure Relationships - Relationships - Gramps](image)

You can control how much information is displayed.

Use the View ➡ Configure... menu or click the Configure the active view button in the Toolbar.

The following options are available:

- On the **Content** tab
  - Show Details (checkbox checked by default) show or hide the birth and death information (All except the Active person)
  - Show Siblings (checkbox checked by default) show or hide siblings.

![Configure Relationships - Relationships - Gramps](image)

- On the **Layout** tab
  - Use shading (checkbox checked by default)
  - Display edit buttons (checkbox checked by default) - show or hide the Edit button shown next to each person.
  - View links as website links (checkbox unchecked by default)

Relationships Category Bottombar tabs

The Relationships Category view by default displays no Gramplets in the Bottombar tab. You may add them as required.

Relationships Category Sidebar tabs
The **Relationships Category view** by default displays no Gramplets in the **Sidebar** tab. You may add them as required.

### Families Category

Unlike the Relationships Category, clicking the **Remove** button in this view will remove the family from the database. All people will remain, but all relationships between the people in the family will be removed.

**Fig. 4.12 Families Category - (List) View**

In the **Families Category**, the **Families List view** displays a list of all families in the database (see Fig. 4.12). From this view, you may **Add a new Family**, **Edit the selected family**, **Delete the selected family**, **Merge the selected (2) families** from the list, or **Tag the selected rows**. The default display lists the ID, Father, Mother, Relationship and Marriage Date. If you configure the active view you can, hide existing columns, show additional columns like Private, Tags, Last Changed, or rearrange the column order.

Additional options are available by selecting a family from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Add...
- Edit...
- Delete
- Merge...
- Make Mother Active Person
- Make Father Active Person
- Quick View
  - All Family Events
  - Family References

See also

- Using the Families Category
- Editing information about relationships

**Children cannot be displayed on the screen in this list view.**

The children can be viewed in the associated **Children** tab in the bottombar or sidebar and **Family Editor's Children** tab.

### Families Category Bottombar tabs

The **Families Category** shows the following **Bottombar** tabs as default.

**Gallery**

See **Gallery** Gramplet

**Events**

See **Events** Gramplet

**Children**

See **Children** Gramplet
The Families Category shows the following Sidebar tabs as default.

Filter

See Filter Gramplet

Charts Category

The Charts Category shows several graphical representations of the ancestry or descendants of the active person.

By default Gramps shows the [Pedigree] View. With the [Fan Chart] View and [Descendant Fan] chart View and [2-Way Fan] chart view being selectable from the toolbar or menu via View > Name of Chart View

Want more Chart Views?

Installation of additional downloadable addons contain extra views. See Third-party Addons

Pedigree View

Fig. 4.13 Pedigree view 1 (Default) Tree direction: horizontal to right

The Pedigree View shows up to nine generations in the form of a chart, depending on the size of the window you may need to use the scroll bars to see parts of the chart.

Each person is indicated by a box labeled with his or her name, birth information (indicated by an asterisk * sign), death information (indicated by a plus + sign), a black stripe across the top left corner of the box is shown if the person is deceased (or determined by Gramps to be no longer alive) and optionally the primary image will be displayed if available.

Two lines branch from each person box. The top line leads to the person's father and the bottom line leads to the mother. Solid lines represent the biological birth type relationship, while dashed lines represent non-birth relationships such as adoption, step-parenthood, guardianship, etc.

The left arrow [Jump to child...] button beside the Active Person is a only selectable if the Active Person has children, clicking this button expands to show a list of the Active Person's children. Selecting one of the children makes that child the Active Person for the chart.

The appearance of the children's names in the menu differentiates the dead ends of the tree from the continuing branches.

Children who have children themselves appear in the menu in the boldface and italic type, while children without children (dead ends) appear in a regular font. If the Active Person has only one child, no menu will be displayed (since there is only one choice) and the child will become the
Active Person when the arrow button is clicked.

The right-hand side of the window shows two right arrow buttons. When the top button [Jump to father] is clicked, the Father of the Active Person becomes the Active Person. When the bottom button [Jump to mother] is clicked, the Mother of the Active Person becomes the Active Person.

![Image of Person context menu showing Children](image)

Right-clicking on any person's box in the Pedigree View will bring up the Person "context menu".

Among other useful items, the context menu has sub_menus listing [Spouses], [Siblings], [Children], [Parents] and [Related] of that person.

"Greyed-out" sub menus indicate the absence of the data in the appropriate category. Similar to the children menu above, Childrens' and Parents' menus distinguish continuing lines from dead ends.

**Configure the active view**

![Image of Configure Charts - Pedigree - Gramps dialog showing Defaults on Layout tab](image)

Use the **View ➡ Configure...** menu or click the [Configure the active view] button in the **Toolbar**.

The **Layout** tab has the following options available:

- **Show images** (checked by default)
- **Show marriage data** (checked by default)
- **Show unknown people** (checked by default)
- **Show tags** (unchecked by default)
- **Tree style**:
  - Standard (default)
  - Compact
  - Expanded
- **Tree direction**:
  - Vertical (↑) (default)
  - Vertical (↓)
  - Horizontal (→) (default)
  - Horizontal (←)
- **Tree size**: slider range 2 to 9 generations. Set to 5 (by default)
Fan Chart View

The Fan Chart view shows the active persons ancestry as a pie chart. Clicking on a name in the chart will double the section of the pie allocated to that person. A second click brings the chart back to the original form. Right click brings up a context menu like in the pedigree view, allowing to navigate to other people.

This view enables to see large ancestries in a more compact manner, and to see very quickly which parts of an ancestry need further research.

You can rotate the view by click and drag outside the fan chart. You can move the view by click and drag inside the inner (white) region.

1. The view can be a circle, a halfcircle or a quadrant of a circle. The latter are always attached to the bottom or side of the view
2. Children of the center person are shown within the ring at the center
3. Drag and drop people to the center to change the active person
4. Color options
   1. Colors of the boxes based on the age of the people
   2. Colors of the boxes depending on the time period the person lived in
   3. White, classic, gender based, and user defined colors
5. Filtering: use the person filter in the sidebar to quickly obtain insight in the people shown. For example: which people have birth events, who has the attribute blue eyes, … Filtered results have bold font, the ones that don’t satisfy the filter are shown transparent
6. Show up to 11 generations in the view.
7. Print the view from the toolbar. The view as you see it (after rotating, expanding, changing color) can via the print button be printed or saved as svg (to edit further in Inkscape and view in eg Firefox), pdf or ps.
8. The font used can be selected and automatically adjust to fit within the boxes. On a darker background, the font is white, and vice versa.
Use the View ➡ Configure... menu or click the Configure the active view button in the Toolbar.

- **Max generations**: 9 (default)
- **Text Font**: Sans (default)
- **Background**:
  - Gender colours
  - Generation based gradient (default)
  - Age (0-100) based gradient
  - Single main (filter) colour
  - Time period based gradient
  - White
  - Colour scheme classic report
  - Colour scheme classic view
- **Start gradient/Main colour**: #ef2929 (default)
- **End gradient/2nd colour**: #3d37e9 (default)
- **Fan chart type**:
  - Full Circle (default)
  - Half Circle
  - Quadrant
- **Show names on two lines**
- **Flip name on the left of the fan**
- **Show children ring**
- **Show gramps id**

See also

- Gramplets:
  - Fan Chart (ancestor)
  - 2-way Fan Chart (ancestor and descendant)
  - Descendant Fan Chart

- Charts category view modes:
  - Fan Chart (ancestor)
  - 2-way Fan (ancestor and descendant)
  - Descendant Fan

- Reports: Graphical reports:
  - Fan Chart... (ancestor)

**Descendant Fan View**
Fig. 4.21 Descendant Fan Chart View - full circle

View showing the active person's direct descendants as a fan chart.

Fig. 4.22 Charts Category - Descendant Fan Chart View - Configure the active view - dialog - showing Defaults on Layout tab

Use the View ➔ Configure... menu or click the Configure the active view button in the Toolbar.

- **Max generations**: 9 (default)
- **Text Font**: Sans (default)
- **Background**:
  - Gender colours
  - **Generation based gradient** (default)
  - Age (0-100) based gradient
  - Single main (filter) colour
  - Time period based gradient
  - White
  - Colour scheme classic report
  - Colour scheme classic view
- **Start gradient/Main colour**: #ef2929 (default)
- **End gradient/2nd colour**: #3d37e9 (default)
- **Fan chart type**:
- Full Circle (default)
- Half Circle
- Quadrant

[ Fan chart distributions: ]
- Homogeneous children distribution
- Size proportional to number of descendants (default)
- Show names on two lines
- Flip name on the left of the fan
- Show gramps id

See also

- Gramplets:
  - Fan Chart (ancestor)
  - 2-way Fan Chart (ancestor and descendant)
  - Descendant Fan Chart

- Charts category view modes:
  - Fan Chart (ancestor)
  - 2-way Fan (ancestor and descendant)
  - Descendant Fan

- Reports : Graphical reports:
  - Fan Chart... (ancestor)

2-Way Fan View

![2-Way Fan Chart View - 4 Generations of Ancestors (Top) / 4 Generations of Descendants (bottom)](image)

Chart consisting of both ascendants and descendants.

Configure the active view
Use the **View ➪ Configure...** menu or click the **Configure the active view** button in the **Toolbar**.

- **Max ancestor generations**: 4 (default)
- **Max descendant generations**: 4 (default)
- **Text Font**: Sans (default)
- **Background**:
  - Gender colours
  - Generation based gradient (default)
  - Age (0-100) based gradient
  - Single main (filter) colour
  - Time period based gradient
  - White
  - Colour scheme classic report
  - Colour scheme classic view
- **Add global background coloured gradient**
- **Start gradient/Main colour**: #ff2929 (default)
- **End gradient/2nd colour**: #3d37e9 (default)
- **Colour for duplicates**: #888a85 (default)
- **Fan chart distribution**:
  - Homogeneous children distribution
  - Size proportional to number of descendants (default)
- **Show names on two lines**
- **Flip name on the left of the fan**
- **Show gramps id**

See also

- Feature: Gep-030 FanChart2Way
- Gramplets:
  - Fan Chart (ancestor)
  - 2-way Fan Chart (ancestor and descendant)
  - Descendant Fan Chart
- Charts category view modes:
  - Fan Chart (ancestor)
  - 2-way Fan (ancestor and descendant)
  - Descendant Fan
- Reports: Graphical reports:
  - Fan Chart...

**Charts Category Bottombar tabs**

The **Charts Category** by default displays no Gramplets in the **Bottombar** tab. You may add them as required.

**Charts Category Sidebar tabs**

The **Charts Category** shows the following **Sidebar** tabs.

**Filter**

Only the **Fan Chart View** and **Descendant Fan View** have a Filter shown by default.

---

**Fig. 4.24 Charts Category - 2-Way Fan Chart View - Configure the active view - dialog - showing Defaults on Layout tab**
Events Category

The Events Category shows the Events View that lists all the events recorded in the Family Tree. Events can be shared between multiple people and multiple families.

See also:
- Editing information about events

Events View

Fig. 4.25 Events Category - Events (List) View - example

From the Events View list the following columns are available for display: Description, ID, Type, Main Participants, Date, Place and Last Changed.

The default view displays the Description, ID, Type, Date and Place of the event. The Column Editor dialog can be used to add, remove and rearrange the displayed columns. This can be accessed from the Configure View... button on the toolbar.

The list of Events can be sorted in the usual manner, by clicking on the column heading. Clicking once sorts in ascending order, clicking again sorts in descending order.

Additional options are available by selecting an event from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Add...
- Edit...
- Delete
- Merge...
- Quick View
  - Event References
  - On This Day

Use meaningful event descriptions

Because events can be shared, you should take the extra time to give each event a unique and meaningful description. This will help you find the correct event when you share events.

Configuration Options

As with most list style Views, you can control the layout (which columns will be displayed and their order of display) by clicking the Configure... button, choosing View ➡ Configure... from the View menu, or pressing the Configure active view keyboard keybinding.

The displayable columns include:

- Type
- Main Participants
- Date
- Place
- Description
Drag and drop columns to change their order in the Event list. The view will not be changed unless the **Apply** button is clicked. Clicking **Close** without first clicking **Apply** will abandon the changes.

**Events Category Bottombar tabs**

The **Events Category** shows the following **Bottombar** tabs.

- **Gallery**
  
  See [Gallery Gramplet](#)

- **Citations**
  
  See [Citations Gramplet](#)

- **Notes**
  
  See [Notes Gramplet](#)

- **Attributes**
  
  See [Attributes Gramplet](#)

- **References**
  
  See [References Gramplet](#)

**Events Category Sidebar tabs**

The **Events Category** shows the following **Sidebar** tabs.

- **Filter**
  
  See [Filter Gramplet](#)

**Places Category**

The **Places Category** holds two views that show places: either as grouped (hierarchically in a tree) or ungrouped (in a simple flat list). Each view lists the geographical places in which the events of the database took place. These could be places of birth, death, and marriages of people, as well as their home, employment, education addresses, or any other conceivable reference to the geographical location.

The Places View lists the places' **Name**, **Title**, **ID**, **Type**, **Code**, **Latitude**, **Longitude**, **Private**, **Tags**, and **Last Changed**. All of these columns can be used for sorting by clicking on a column heading.

**When giving a map co-ordinate, latitude always precedes longitude**

Latitude (north or south) parallels and longitude (east or west) meridians are divided in degrees (°), minutes (’) and seconds (”). There are 60 minutes to a degree and 60 seconds to a minute.

**Configuration Options**
You can control the layout (which columns will be displayed and their order of display) by clicking the `View ➔ Configure...` button, choosing `View ➔ Configure...` from the View menu, or pressing the `Configure active view` keyboard keybinding.

The `Column Editor` dialog may be used to add, remove and rearrange the displayed columns. Changes will only be enacted when the `Apply` button is clicked.

Once the View columns are shown, clicking once on the column header sorts in ascending order, clicking again sorts in descending order.

These Configuration options and the current filters also constrain the data exported via the `Family Trees ➔ Export View...`

**Places List View**
The Place List View shows all the places in one long list. Additional options are available by selecting a place from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Add...
- Edit...
- Delete
- Merge...
- Quick View ▶ Place References
- Look up with Map Service

Places Tree View

The Place Tree View groups the places in a hierarchy: country, county, ... etc

You can expand the listing using the ▶ arrows.

All the nodes of the tree view mode can be simultaneously collapsed or expanded from the context/pop-up menu shown by selecting a place and right-clicking:

- Expand this Entire Group
- Collapse this Entire Group
- Expand all Nodes
- Collapse all Nodes
- Add...
- Edit...
- Delete
- Merge...
- Quick View ▶ Place References
- Look up with Map Service
Map Service

This feature needs a set of coordinates (Longitude and Latitude) in Places

If the enclosed Place record does not yet have coordinates information, then Gramps will not request a map service marker for the Place associated with that person or event.

![Image of a map service pop-up window]

Fig. 4.31 Places Category - "Attempt to see selected locations with a Map Service (OpenstreetMap, Google Maps, ..." button - example

If a place has been highlighted, you may display the place in a web browser by selecting the "Attempt to see selected locations with a Map Service (OpenstreetMap, Google Maps, ..." button.

Your default web browser should open, attempting to use either the recorded coordinates (longitude and latitude) or the place name to display the location using the Maps provider web site. Different map services might have different requirements for the location description.

![Image of a map service selection window]

Fig. 4.32 Places Category - "Select a Map Service" button - showing list of options

From the "Select a Map Service" drop down list you can choose the map service you want to use from the following three options:

- **OpenStreetMap** (default) - Uses longitude and latitude coordinates if present, otherwise uses city and country, or uses description of the place.
- **EniroMaps** - Valid for places within Sweden and Denmark, only if longitude and latitude are available, otherwise uses city and country, or uses description of the place.
- **GoogleMaps** - Uses longitude and latitude coordinates if present, otherwise uses city and country, or uses description of the place.

See also:

- Map Services - Google Earth - addon allows you to use Google Earth.

Places Category Bottombar tabs

The **Places Category** shows the following **Bottombar** tabs.

Details

See Details Gramplet

Location

See Locations Gramplet

Gallery

See Gallery Gramplet

Events

Categories - Places Category
Places Category Sidebar tabs

The **Places Category** shows the following **Sidebar** tabs.

Filter

See **Filter** Gramplet

Geography Category

---

**Note**

The Geography category is only present if the prerequisite program [OsmGpsMap](#) is present that Gramps can use.

---

Fig. 4.33 "All known Places" GeoPlaces View - Geography Category - example using Openstreetmap - sidebar and bottombar hidden

The **Geography Category** shows place event data visually on a map. It contains many Geographic Views, which allows you to see the people and their events placed on a map via an internet map provider (OpenStreetMap, Google maps ...).

The following Geographic Views are available:

- Show all places in your family tree
- Show all places connected to the active person
- Show all places connected to the active family
- Show all places connected to all events
- Show all places connected to a filtered selection of events
- Show if two people have been able to meet
- Show if two families have been able to meet
- Show all displacements or moves for one person and their descendants

These views are accessible via the buttons on the toolbar. To filter on places or events, activate the filter sidebar via the menu **View->Filter Sidebar**

Prerequisites

If the Geography icon is not visible in the Navigator sidebar, you probably need to install the requisite [OsmGpsMap](#) program.

To have these Geographic views work correctly, you need:

- To have events related to places.
These places must have coordinates: latitude and longitude.
If one place has no coordinates, it will never appear on the map.
If you have an active internet connection, for all moves on the map, all zoom ... all tile maps are saved.

- When you are without an internet connection, all tile maps are cached from the previous session and can be used.
- So, the map can be used without an internet connection and all already visited places can be shown again.
- The only thing to do is for each place or area you want to use without an internet connection is to select them, zoom into these places. You'll be able to use them again without connection.

**BE CAREFUL**

The Geography Category views may use many Gigabytes of storage space on your computer. If you use several maps, you need to have this same gigabytes size multiply by the number of map used.

The different views

**All known places**

Fig. 4.34 "All known Places" GeoPlaces View - Geography Category - example using Openstreetmap - sidebar and bottombar hidden

This view show all places with coordinates in the database.

From Gramps 4.2.2, for performances reason, by default, the view show only the place related to the places history or the filtered places. If you really want to see all places, you need to select the popup menu from the context menu right button and select "show all places".

Fig. 4.35 The places marker color tab for the "All known Places" GeoPlaces View - Configure the active view

Configure the active view

The configuration menu tab for has the following options:

The All known Places view is the only Geography view that allows you to change the color used for the place type markers.

The colors are green for the following map renders:

- Openstreetmap
- Maps for free
- Opencyclemap and Public transport.

All other marker renders are red.
Click on the **Configure the active view** button on the toolbar.

Then click on the **The places marker color** tab.

For each type of place, you can select and choose a color. The default color is green "#008b00"

See also:
- Can we change the marker color?

**All known places for one Family**

![Image](image-url)

**Fig. 4.36 "All known places for one Family" GeoFamily View - Geography Category - example using Openstreetmap - sidebar and bottombar hidden**

This view show all places visited by all family members during their lives.

This view is not connected to filters. It only depend on the active family and the history.

Configure the active view **Specific parameters** tab

The configuration menu tab for this view has no additional options.

**Have they been able to meet ?**

![Image](image-url)

**Fig. 4.37 "Have they been able to meet ?" GeoClose View - Geography Category - example using Openstreetmap - sidebar and bottombar hidden**

Categories - Geography Category
This view is used to show if two persons were able to meet during their life.

You must select one reference person:

1. From the menu popup: Choose the reference person
2. From the toolbar

When the reference person is active, you'll see its life way. For each known place with coordinates, you'll see a circle or an oval depending on the longitude.

The circle radius can be tuned in the configuration view. This value is defined in tenth of degree.

Fig. 4.38 "The selection parameters" tab for the "Have they been able to meet?" GeoClose View - Configure the active view

Configure the active view

*The selection parameters* tab

See the configuration menu tab for additional options.

### All places related to Events

This view is used to show all places related to events. It can take some time to show when we have many events.

from Gramps 4.2.2, for performances reason, by default, the view show only the place related to the events history or the filtered events. If you really want to see all events, you need to select the popup menu from the context menu *right button* and select "show all events".

Configure the active view

*Specific parameters* tab
The configuration menu tab for this view has no additional options.

**All known places for one Person**

This view show all places visited by one person during that persons life.

This view is not connected to filters. It only depend on the active person and the history.

If you want to use the animate functionality, click on the right button of the mouse. You'll get a popup menu. From the menu popup, you can select 'animate' to see the life way of the current person:

If the active person has several related events, you can see a virtual move between those markers. The move is related to years or distance and can be modified in the person map preferences. If the distance between to markers is greater than a value in tenth of degree, we show moves depending on distance instead of years. In these case, the number of steps between these two markers can be modified. You can modify the animation speed between steps. The moves start at the first event year until the last event year.

**The animation parameters** tab

See the configuration menu tab for the following options you can change:

- A slider to set the Animation speed in milliseconds (big value means slower) (default: 100)
- A slider to set the How many steps between two markers when we are on large move? (default: 20)
- A slider to set the The minimum latitude/longitude to select large move. The value is in tenth of degree.
All known places for one person with graphical information (KML files)

Fig. 4.42 One person with 3 KML files

If KML files are added as Media objects in the Gallery tab for the various records, this Geography view will show one path or one surface for each KML file.

In the following example, you see 3 layered KML files rendered from different Gallery tabs referenced by this Person:

- a farm limits outline KML in the Birth Event.
- a path KML used to go to school in the Education Event.
- a parish (or municipality) limits outline KLM in the Place Gallery tab for the Baptism Event.

In the case of the Farm limits outline, the KLM was added to the Gallery tab of the Birth Event (rather than being applied to that of the re-useable 'Farm' type Place) because acreage was bought and sold over the years. This outline represented the Farm size at the date of birth.

See Adding places from KML files

What is a KML file?

See the article Keyhole Markup Language From Wikipedia, the free encyclopedia

Every residence or move for a person and any descendants

Fig. 4.43 "Every residence or move for a person and any descendants"
GeoMoves View - Geography Category - example using Openstreetmap - sidebar and bottombar hidden

This view is used to show all descendant's life ways.

They are displayed by generation. You can change the delay between the generation display in the view configuration.

This view is not connected to filters. It only depend on the active person and the history.
Configure the active view

**The parameters for moves** tab

See the configuration menu tab for the following options you can change:

- A slider to set *The maximum number of generations* to show. (default: 20)
- A slider to set the *Time in milliseconds between drawing two generations*. (default: 500)

**Have these two families been able to meet?**

This view is used to show if two families were able to meet during their life.

You must select one reference family:

- From the menu popup: Choose the reference family
- From the toolbar

When the reference family is active, you'll see all its member's life way. For each known place with coordinates, you'll see a circle or an oval depending on the longitude.

The circle radius can be tuned in the configuration view. This value is defined in tenth of degree.
Fig. 4.46 "The selection parameters" tab for the "Have these two families been able to meet ?" GeoFamClose View - Configure the active view

Configure the active view

**The selection parameters** tab

See the configuration menu tab for additional options.

**Usage**

The configuration

Via the toolbar **Configure View...** button (or via the menu **View**)

All views

Fig. 4.47 Configure Geography - "The map" tab

**The map** tab contains options common to all Geography views:

- **Where to save the tiles for offline mode:** (default is `$HOME/.gramps/maps`). If required you can change the directory where map tile files are stored on your computer. Be careful, it can take several gigabytes, and if on a metered internet connection may result in a monetary cost to you.
  - **Select tile cache directory for offline mode** button

- A slider for **zoom used when centering**: (default: 12). The zoom level for when we center the map or when we select one marker. Every time the Geographic View redraws the map, this zoom level will be used.

- A slider for **The maximum number of places to show**: (default: 5000). Reducing this number for faster map drawing but with less life ways.

  - **Use keypad for shortcuts**: Either we choose the + and - from the keypad if we select this or we use the characters from the keyboard. - checkbox selected by default.

**Specific views**

See the description of the view.

**Print or save the Map**
For each of the Geography Category views via the menu or toolbar you may select:

- Menu Edit > Print... or toolbar button Print or save the Map or keyboard shortcut Shift + Ctrl + P

How to zoom and move around the map?

Zoom in and Zoom out the map

To zoom, you can use:

- The +/- buttons on the top left of the map
- The scroll mouse.
- The “+” or “-” key on the keypad (default).

You can replace the numeric keypad by the alpha numeric keyboard in the configuration view.

Move around the map

To move around the map, you can:

- Click on the map, then drag it.
- Use the arrows.

The mouse actions on the map

The right button below is for one right handed person. This will be the left button for one left handed person.

button 1 (left button)

You have two usages for the button 1:

1. The marker selection.
2. Valid the region selection

button 2 (middle button)

The only usage for the center button is to draw a rectangular region on the map via click and drag.

1. when pressed: start the region selection
2. when released, end the region selection.

A left-click (button 1) will zoom-in the Geography view to fit the rectangle.

button 3 (right button)

Only one usage for this button.

- show the context menu popup.

The mouse over a marker

When the mouse is placed over one marker, we display the place name in the status bar.

The menu popup
From this context menu, you have the following functions available for views:

- hide or show the crosshair
- lock or unlock the zoom
- change the default map (provider)
- add a place and link a place at the mouse position
- add a place from kml file
- center the map at the mouse position.
- center the map depending on a place from sub menu.
- remove all tiles already uploaded for the current provider
- "show all places" or "show all events" for the "all known places" view or "all places related to events" view.

Click on a marker

We have two cases:

1. events: For each event, we can edit this event or center the map on this place.
2. places: For each place, we can edit this place or center the map on this place.

When centering the map, the zoom used is defined in the geography preferences.

We may have several markers in the click area depending on the zoom. In this case, We show for each marker all related events and/or places. We obtain a mix between the two cases described above.

Adding or Linking to a place

For this, click on the right button of the mouse, you'll get a popup menu. In this menu, you can select Add place or Link place.

When you add a place or try to link a place to the position of the mouse, you'll get a place selection in a region. You'll see on the map a circle in which you may choose markers place names. You can adjust the circle size with the cursor. Depending on the diameter of this circle, a list is created. If the place has already some filled fields, you'll see these values in a green color row. If you agree, you double click on this row. If you don't agree, you can choose another row.

Another way to set latitude and longitude:

- Download the Place completion tool via the Addons manager. If you download the data of your country, this tool can add latitude-longitude to all your places.

Adding places from KML files

For this, click on the right button of the mouse, you'll get a context popup menu.

In this menu, you can select Add place from KML.

You will get the Select a kml file used to add places file chooser dialog. Select the file you want to add.

If you have several places in the same KML file, you will get one place editor for each place. Be careful.

How to change the map provider?

Some maps are not free

Please read the map provider Terms of Service

OpenStreetMap
Several map providers are available in Gramps.

Click on the right button of the mouse, you'll get a popup menu.

In the bottom of this menu, you can select a new provider.

The following providers are available:

- **OpenStreetMap** (default): The advantage of OpenStreetMap is that it is a free project, so you can update the maps yourself with missing information via their website.
- Maps For Free
- OpenCycleMap
- Public Transport
- Google street
- Google sat
- Google hybrid
- Virtualearth street
- Virtualearth sat
- Virtualearth hybrid

Note that Virtualearth is now Bing maps

Can we change the marker's color?

Only the All known Places view supports changing the place type markers colors all the other views are hard coded in Gramps.

How to get/remove the crosshair?

It can be useful to have the crosshair visible to see the center of the map. This functionality is available with the right button of the mouse, you'll get a popup menu. Select Add or Remove cross hair. This is useful to add or link places to the correct latitude-longitude coordinates.

How to lock/unlock the map?

When we change the map (person to family, ...), the zoom is recalculated. It can be useful in some case to keep the same zoom and position when we change the map provider. For this, click on the right button of the mouse, you'll get a popup menu. In this menu, you can select lock or unlock zoom and position.

Prerequisites to see the geography view

For Gramps 5.x, you need to install osm2pgsql version 1.0 and above and the associated gir package.

For example on ubuntu, you must have: `gramps -v` from the command line may help you

Possible problems

- No view: do you have osm2pgsql installed? (gramps -v from the command line may help you)
- No tiles: do you have an internet connection active?
- No tiles for one provider: if other providers are OK, file a bug
- Missing tiles: you have no internet connection and it's the first time you try to show the current place.
- Missing tiles: this can be the same as no tiles for one provider if they modify the access rules (i.e user-agent)
Geography Category Bottombar tabs
The Geography Category by default displays no Gramplets in the Bottombar tab. You may add them as required.

Geography Category Sidebar tabs
The Geography Category shows the following Sidebar tabs.

Filter
The filter type may change depending on the view selected.
See Filter Gramplet

Sources Category
The Sources Category offers two view modes (Citation Tree View and Sources List View (default)) that list the sources of certain information stored in the family tree. The record selection, column configuration and Gramplet selections are independent for each view mode.

Sources can include various documents: birth, death, and marriage certificates; books; films; journals; private diaries - nearly anything that can be described as genealogical evidence. Gramps gives you the option to provide citations of sources for each (Event, Person, Place, Media, Note, et cetera) object you create.

By default, the Sources View mode lists the Title, ID, and Author of the source, as well as any Publication information that may be associated with it. The list of Sources can be re-sorted by clicking on a different column heading. Clicking the header the first time sorts the rows in ascending order based on that column. Clicking again reverses to descending order.

The Column Editor tab of the Configure Sources dialog can be used to add, remove and rearrange the displayed columns. Click the toolbar button or select Configure… from the Edit menu to open the dialog.

You can select the Add a new source toolbar button to create a new source or the Edit the selected source button to edit the sources selected in the list. Either action will invoke the Source Editor dialog.

See Editing information about sources

Citation Tree View

Fig. 4.49 Sources Category - Citation Tree - View

The Citation Tree View mode list will also show all the sources. In addition, it allows the user to see the Citations associated with each source by clicking on the disclosure triangle node to expand or collapse disclosure triangular widget.

All the nodes of the tree view mode can be simultaneously collapsed or expanded from the context/pop-up menu shown by right-clicking:
Sources List View

The default, **Sources View** mode only shows the Sources as a list and displays the **Title**, **ID**, and **Author** of the source, as well as any **Publication** information that may be associated with it. The list of Sources can be re-sorted by clicking on a different column heading. Clicking the header the first time sorts the rows in ascending order based on that column. Clicking again reverses to descending order.

Additional options are available by selecting a source from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Add...
- Edit...
- Delete
- Merge...
- Quick View ▶ Source References

Sources Category Bottombar tabs

The **Sources Category** shows the following **Bottombar** tabs.

**Gallery**

See [Gallery](#) Gramplet

**Notes**

See [Notes](#) Gramplet

**References**

See [References](#) Gramplet

Sources Category Sidebar tabs

The **Sources Category** shows the following **Sidebar** tabs.

**Filter**

See [Filter](#) Gramplet

Citations Category

The **Citations Category** shows the Citation list View that show the citations for certain information stored in the family tree.

Citations specify which parts of a source are relevant to the information in the database. For example, a Source may be a book, and the citation may be a particular page in the book. Gramps gives you the option to provide a citation for each event you record (births, deaths, marriages, etc.).

Citations List View

---

**Categories - Citations Category** 59
The Citations List View shows the Volume/Page, ID, and Date of the citation, as well as any Confidence in the evidence.

The list of Citations can be sorted by clicking on a column heading. Clicking once sorts in ascending order, clicking again sorts in descending order. The Column Editor dialog can be used to add, remove and rearrange the displayed columns.

Additional options are available by selecting a citation from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Add...
- Edit...
- Delete
- Merge...
- Quick View ▶ Citation References

Citations Category Bottombar tabs

The Citations Category shows the following Bottombar tabs.

Gallery

See Gallery Gramplet

Notes

See Notes Gramplet

References

See References Gramplet

Citations Category Sidebar tabs

The Citations Category shows the following Sidebar tabs.

Filter

See Filter Gramplet

Repositories Category

The Repositories Category shows the Repository List View. A repository can be thought of as a collection of sources. Each source in the family tree may be a reference to a repository (such as a library) in which it belongs.

Repository List View
This view shows a list of all recorded repositories. Additional options are available by selecting a repository from the list and using the context/pop-up menu shown by right-clicking:

- Back
- Forward
- Add…
- Edit…
- Delete
- Merge…
- Quick View
- Repository References

**Repository Category Bottombar tabs**

The Repository Category shows the following Bottombar tabs.

- Details
  See Details Gramplet

- Notes
  See Notes Gramplet

- References
  See References Gramplet

**Repository Category Sidebar tabs**

The Repository Category shows the following Sidebar tabs.

- Filter
  See Filter Gramplet

**Media Category**

The Media Category shows the Media List View, which list the Media Objects stored in the family tree. Media Objects are technically any files that relate somehow to the stored genealogical data. Most frequently, these are images, audio files, animation files, etc.

**Media List View**
The Media List View shows the following columns for the list: Name, ID, Type, Path and Date of the Media Object.

The Column Editor dialog may be used to rearrange the displayed columns, which obey usual sorting rules.

Selecting a media item from the list and using the context menu (right-clicking) offers the following options:

- Back
- Forward
- View - show the media item using an external program.
- Open Containing Folder - which opens to the folder containing the media item.
- Add...
- Edit...
- Delete
- Merge...
- Quick View
  - Media References

**Media Category Bottombar tabs**

The Media Category shows the following Bottombar tabs.

**Preview**

In the "Preview" tab you can double click on the media/photo to open it in the default picture viewer.

See Media Preview Gramplet

**Citations**

See Citations Gramplet

**Notes**

See Notes Gramplet

**Attributes**

See Attributes Gramplet

**Image Metadata**

See Image Metadata Gramplet

**References**

See References Gramplet

**Media Category Sidebar tabs**

The Media Category shows the following Sidebar tabs.

**Filter**

See Filter Gramplet

**Notes Category**

Categories - Notes Category
The Notes Category View shows a List mode, which inventories the text notes (either pure text or pre-formatted) that can be referenced by the other objects.

See also:

- Using the Note Editor to make new annotations or editing information about existing notes

### Notes List View

![Notes List View](image)

The Notes List View shows a list of text notes.

The functionality of the notes View is similar to the other views. The view lists all Notes stored in the Family Tree.

Using the menu View -> Configure View... you open the Column Editor and you can change the displayed columns. The possibilities are Preview, ID, Type, Private, Tags and Last Changed.

The Type can be (amongst others): Event Note, Address Note, Source text, Place Note. (In version 5.1, the built-in Type list includes: Citation, General, HTML code, Link, Report, Research, Source text, To Do, Transcript, Unknown)

Selecting a Note item from the list and using the context menu (right-clicking) offers the following options

- Back
- Forward
- Add...
- Edit...
- Delete
- Merge...
- Quick View
  - Link References
  - Note References

Double-clicking on a Note item in the list will bring up the Note editor window where you can edit the Note. You can change fonts, font color and background color. A spelling checker is available for English and your local language.

### Notes Category Bottombar tabs

The Notes Category shows the following Bottombar tabs.

### References

See References Gramplet

### Notes Category Sidebar tabs

The Notes Category shows the following Sidebar tabs.

### Filter

See Filter Gramplet
A detailed exploration of the day-to-day use of Gramps. In this Chapter we give a detailed overview of how you can manage your family trees, as well as share your data with other genealogists.

**Starting a new Family Tree**

To start a new Family Tree, choose the menu Family Trees -> Manage Family Trees... or select the toolbar button or use the keybinding `CTRL+O`. This will open the **Family Trees** manager window.

Select the button and to add a new Family Tree entry to the list of Family Trees. To change its name from the default *Family Tree 1*, select the name and press the **Rename** button then type in a new name.

To open the new, empty Family Tree select the Family Tree and either double click or press the **Load Family Tree** button to load.

**Family Trees manager window**

Family Trees are what Gramps calls the database structure used to store and organize genealogical data. You need to create a Family Tree before any genealogical data can be entered, restored from a backup archive or imported from other software.

Family Trees can be renamed, converted to other database backends, repaired or deleted. A 'mistake' here won't be unrecoverable. (The biggest potential mistake, an accidental Deletion, requires a confirmation.)
Fig. 5.4 "Family Trees" manager window

Clicking the [Family Tree Manager] button brings up the [Family Trees] manager windows this allows you to work with and manage the Family Trees found within the specific Gramps [Family Tree Database path] directory.

The Family Tree Manager window allows the you to create a new Family tree, rename an existing Family tree, delete a Family tree, or load a Family tree or check information) about the Family tree. All the names of your Family trees appear in the list. If a Family tree is open, an icon will appear next to the name in the status column. The Database Type as well an indication of the date and time your family tree was [*Last accessed*] is shown.

- **New** creates a new Family tree.
- **Info** shows information about the selected Family tree.
- **(Delete)** the selected Family tree, this will show a warning with a final confirmation for you to select.
- **(Rename)** the selected existing Family tree.
- **(Close)** the selected existing Family tree.
- **(Convert)** the selected family tree. This option only when the database of tree is different than the . See: Converting a legacy BSDDB Family Tree to SQLite (BSDDB)
- **(Repair)** the selected existing Family tree, only available if Gramps detects an issue.
- **(Archive)** option is only present if GNU Revision Control System (RCS) is installed.
- **(Extract)** used with the [Archive] button and the option is only present if GNU Revision Control System (RCS) is installed.
- **(Help)** - opens the default browser window showing this section of the online manual.
- **(Close Window)** - dismisses the [Family Tree] manager windows
- **(Load Family Tree)** opens selected existing Family tree into working memory and locks the database file so other users cannot commit conflicting edits.

**Opening a Family Tree**

To open a Family Tree, either choose the menu [Family Trees ->Manage Family Trees...], or click the Toolbar [Family Trees] button. The [Family Tree Manager] will appear and you will see a list of all the Family Trees known to Gramps. In the [Status] column an icon (looks like an open folder) will display beside any Family Tree that is currently open. Select the tree you want to open, and open it by selecting the [Load Family Tree] button. Alternatively you can double-click on the desired Family Tree.

To open a recently accessed Family Tree, choose either the menu [Family Trees ->Open Recent] or the down arrow next to the Toolbar [Family Trees] button and select the Family Tree from the list.

**Read Only Mode**

![Read Only Mode]

If you do not have "write permissions" for the selected Family Tree, it will be opened in a Read Only mode. In this mode, the data may be viewed, but no changes will be made to the Family Tree. To indicate this mode, the title of the main window will be appended with (Read Only) text.

The Tools menu will not be available.

**Saving changes to your Family Tree**

Gramps saves your changes as soon as you apply them. This means, for example, that any time you click [OK] when using Gramps, your changes are immediately recorded and saved. There is no separate "save" command.

You can undo changes you have made by selecting the menu [Edit ->Undo]. If you select this command repeatedly, your most recent changes will be undone one at a time. To roll back multiple commands at a time, you can use the menu [Edit] dialog.

If you want to return your Family Tree to the way it was when you opened it, select the menu [Family Trees ->Abandon Changes and Quit] (This is just like quitting without saving in other programs.)

If you would like to save a copy of your Family Tree under a different name, you will need to export it and then import into a new Family Tree. The *Gramps XML* database format is recommended for this purpose.

**Opening a GEDCOM or XML database**

*Manage Family Trees - Opening a Family Tree*
Gramps allows you to open certain databases that have not been saved in Gramps own file format from the command line, see [Command line references](#). These include XML and GEDCOM databases. But you should be aware that if the XML or GEDCOM database is relatively large, you will encounter performance problems, and in the event of a crash your data can be corrupted. Hence, it is normally better to create a new Gramps family tree (database) and import your XML/GEDCOM data into it.

### Opening databases

XML and GEDCOM databases require all data to be held in memory and don't contain indexes. Gramps native format is a database that only reads the data needed. Thus, for a large family tree the data can be accessed quicker and more efficiently by not using XML or GEDCOM.

### GEDCOM Editing

Please keep in mind that some information in a GEDCOM file may be lost during import into Gramps as well as export back to GEDCOM. Simply opening and viewing the file will not change it. However, if any changes were made and they were not abandoned upon exit, exiting Gramps will save the data, with possible data loss.

### Deleting a Family Tree

Select the family tree you want removed, and click the **Delete** button. This will completely remove the tree, with no possibility to retrieve the data. Consider taking a backup of your data by exporting to the GRAMPS XML format, and storing that file.

### Renaming a Family Tree

You can rename a Family Tree (or an archive of it) by selecting the tree you want to rename and clicking **Rename**. You can also click on the name in the list of trees.

In either case, you just type in the new name to have it take effect.

### Family Tree name Limitations

There are some characters that are not allowed within a Family Tree name. They will be automatically replaced with the underscore character "_".

The comma, double quote and vertical bar characters and these: ":/<>[]\+*?" are also invalid.

### Backing up a Family Tree

The safest way to backup your Gramps Family Tree is to export without privacy options and filters to Gramps XML format (or Gramps XML Package) to include items from your Gallery and copy the resultant file to a safe place, preferably in a different building.

### Backup dialog

From the menu select **Family Trees > Make Backup...**

The **Gramps XML Backup** window will appear.

You can enter the **Path:** where the backup should be stored manually or using the **path selector** button to bring up the **Select backup directory** dialog.

You can enter a **File:** name manually or use the automatically generated file name.

You can either choose **Include** or **Exclude**(default) the **Media:**.

---

Manage Family Trees - Deleting a Family Tree
You can use the Archive feature (see next section) to store snapshots of your Family Tree. These snapshots can be used as simple backups, very useful if you want to try something that you might later want to undo. However this method should not be used for standard backups, as it will not survive a hard disk crash or most of the other disasters that can befall a computer.

For advanced users: each database is stored in its own subdirectory under ~/.gramps. Although a manual backup can be made by backing up this directory, it is not recommended. It is strongly recommended that you please use a Gramps XML backup instead.

Backup on exit

In preferences Family Tree tab, Gramps can be set to create a backup when Gramps exits. Note that this only creates a backup for the open family tree. If the tree is closed before exiting Gramps, no backup is created.

Settings Family Tree

Automatic backup

In preferences Family Tree tab, Gramps can be set to create a backup every 15, 30 or 60 minutes.

See also:

- Settings Family Tree
- Advanced backup filename setting - Where you can also define the naming pattern for the backup filename.
- Backup omissions - what is not included during a backup

Archiving a Family Tree

To make an archive:

1. load your Family Tree.
2. click on the Toolbar (Family Trees) button (it displays Connect to a recent database when you hover over it).
3. click on the family tree you have just loaded: the (Archive) button should appear.
4. click on Archive and you will be able to enter in the Revision comment dialog a Version description for your archive.

After archiving, the list of family trees will now show your original family tree with a right-pointing triangle on its left.

- Click on the triangle to display the archive name. (Click again to collapse the archive list).

Archives can be (Deleted), (Rename) and (Extracted).

Extracting a Family Tree Archive
To retrieve a version of a previously archived family tree in the "Family Tree" manager highlight the archive you want to restore, and select the [Extract] button.

The archive will then be restored into a new Family Tree and be listed in the family tree manager.

The Family Tree name is based on the original name and the archive name eg: <name of original tree>:<name of archive> (see also Archiving a Family Tree).

This can be a useful way of preserving an archive, because archives disappear if the originating tree is deleted; and *they are not incorporated into a Gramps XML export of the family tree.*

**Unlocking a Family Tree**

Gramps is a single-user database application and identifies Tree database files as busy with a "lock" when in use. As Gramps opens a tree, it drops a lock file (which lists the username and domain) in the tree's subfolder in the grampsdb folder of the User Directory. Gramps refuses to let you (or anyone else) open that Tree at the same time. A second instance of Gramps will be able to open another family tree, but any tree that is already open will appear with the lock icon in the Status column of the Manage Family Trees dialog. Closing the tree in the first copy of Gramps deletes the lock file and will make the tree available to be opened in the second instance.

If you *could* open the same Family Tree in two instances of Gramps at once, it is likely your data would be damaged as the two overwrite each other's work.

**See also:**
- Command Line:Force unlock option
- Be careful Breaking Locks!

Only do this if you are sure no other copy of Gramps is using the selected Family Tree.

Break the lock on the "Family Tree name" database? dialog
In the unlikely event that Gramps crashes, the family tree will be left in a locked state (indicated by a lock icon in the Status column next to the Family Tree name).

To unlock the Family Tree during startup

- If the Family Tree Preferences have been set to open a tree automatically on startup, then you will see the Error parsing arguments dialog which remarks that the Database is locked. Click on the Close button then choose Manage Family trees... from the Family Trees menu.
- Otherwise, the Family Tree Manager will appear automatically as Gramps starts.

Choose the locked family tree and then click the Load Family Tree button. The Break the lock on the 'Family Tree name' database? dialog will be shown.

Click the Break lock button and the Family Trees (Manager) window should show that the lock icon has gone.

Choose the previously locked family tree and then click the Load Family Tree button to continue your work.

Should your Family Tree become damaged or corrupted in some way, Gramps Family Tree Manager will display a red Error icon in the Status column.

To have Gramps attempt to repair the damage, select the Family Tree and then click the Repair button.

This will attempt to rebuild your Family Tree from the backup files that are automatically created on exit.

See also:
- Recover corrupted family tree

Converting a BSDDB Family Tree to SQLite

From Gramps 5.1.x the default database is SQLite.

Before following the conversion advice in this section, take the time to backup your family trees.
If you have an older legacy BSDDB format Database Type shown for any of your family tree's in the Family Trees (Manager) - Dialog, then selecting a family tree in the Family Trees (Manager) - Dialog will show the [Convert] button as available.

**It is highly recommended that before doing the following you back up the family trees to be converted.**

When ready select the [Convert] button and the Convert the 'Family Tree Name' database? dialog will be shown with the message Do you wish to convert this family tree into a SQLite database? you can select [Cancel] to stop or [Convert] to start the process, once completed the Family Trees (Manager) - Dialog will show a new entry for the converted copy of your Family tree but with the Database Type of SQLite, you should then open and backup the converted family tree.

You may then rename the original BSDDB family tree with the word OLD or you can Delete it to avoid confusion, then you can rename the new SQLite database.

This article's content is incomplete or a placeholder stub. Please update or expand this section.

**Importing data**

Please recognize that importing a Family Tree is different from opening a Family Tree. When you import, you are actually bringing data from another Family Tree into a Gramps Family Tree. When you open a file, you are editing your original file.

Importing allows you to transfer data from other genealogy programs into a Gramps Family Tree. Gramps can import data from the following formats:

- Gramps XML (.gramps file extension) Gramps native data exchange format in uncompressed text and gzip compressed
- Gramps XML Package (.gpkg file extension) Gramps .tar.gz archive compressed backup format
- GRAMPS V2.x database (.grdb file extension)
- CSV Spreadsheet - comma separated values (.csv file extension)
- GEDCOM (.ged file extension) de facto standard file format for data interchange between genealogy programs
- GeneWeb (.gw file extension) - GeneWeb is genealogy software with a web interface.
- Pro-Gen (.def file extension) - Pro-Gen has been very popular in the Netherlands and North-West Germany. It is often used by people who started collecting and storing data as early as 1989. This was a DOS based program which has been patched to work with Win 10.
- vCard (.vcf file extension) - Virtual Contact File is a file format standard for electronic business cards.
- JSON Import (.json file extension) - JavaScript Object Notation is a lightweight data-interchange format.
- SQLite Import (.sql file extension) - SQLite database format

**Import Family Tree dialog**

Note that data can only be imported into a prepared Family Tree (database)

So, if migrating from another program, it is necessary to first create a new empty Family Tree before importing the unauthenticated data into it. Once the data is imported, clean up any corruptions or incompatibilities.

If the intent is use the import for merging outside data into an existing Gramps Tree, it is less complex to import data from a pre-cleaned and validated Tree already in Gramps format.

Importing is a risky task, always make a backup of your Tree before importing.
First create a **new and empty Family Tree**. Then select the menu **Family Trees -> Import** or use the **keybinding** `CTRL+I` to import data or restore a previously saved Gramps Family Tree (from an older version of Gramps or the current version) the **Import Family Tree** dialog will open, asking you to specify the file you wish to import.

**Fig. 5.15 Import warning dialog**

As you attempt to import into a Family Tree that is **not empty**, the **Undo history warning** dialog will open. This reminds you make a backup before importing. Create a new Family Tree instead, unless you are knowingly attempting to merge data.

Gramps uses a **GTK File Chooser** for selecting the data file to be exported. The basic options for navigating to a file are familiar and obvious.

The default display option for the filepath is to show each folder level as clickable **breadcrumb navigation**. The path can be typed in an editable text box by pressing the `CTRL+L` keybinding.

The file type extension will normally allow the **Automatically detected** option to expect a particular pattern of data to be converted to the native database format. You can override this by choosing a different **Select file type** options. The list of files may be filtered by changing from the **All files** option.

When planning to use the import repeatedly (for ongoing updates or including genealogy research), you can **customize the dialog** by adding buttons for bookmarked folder paths. Right-click on a folder name and choose **Add to bookmarks** from the pop-up menu.

---

**Data loss with some formats**

It is important to note that there is no direct one-to-one correspondence between all the features of Gramps and those supported in the basic **GEDCOM** generic genealogy file format or data files of programs like GeneWeb or Pro-Gen. Therefore, unrecognized data chunks may be lost when importing from any of these formats. Details of data at greatest risk of being lost from GEDCOM is **outlined below**.

**Reorder Events generated by other programs**

Some programs from which you have imported data may not order the events by date as you expect. They will be in the order they were exported by the other program. Gramps provides help for reordering events according to your preference. See the **Sort Events** tool.

**GRAMPS V2.x database import**

**GRAMPS V2.x database (.grdb):** Prior to Gramps Version 3.0, this native Gramps database format was a specific form of the Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).

Import from the GRAMPS V2.x database format is only supported by Gramps version 3.0.x. Import of V2.x into Gramps V3.0.x will not lose any data.
Import from the Gramps V2.x format is not supported by Gramps 5.1.

If you have an old V2.x database, then you must import it into Gramps V3.0.x, export it from there to Gramps XML (or Gramps XML Package), and then import it into Gramps 5.1.

Moving a Gramps 2.2 databases to Gramps 3.x

To move your Gramps data from version 2.x to version 5.1.x you must import the v2.x database into an earlier Gramps v3.0.x program and then either save the database and import it into Gramps 5.1.x, or export the database in XML format from the earlier Gramps version and import it into Gramps 5.1.x.

Please refer to the User Manual for earlier versions of Gramps for instructions on the import of v2.x databases into Gramps v3.x.

Gramps XML and XML Package import

The Gramps XML and Gramps XML Package database are the native Gramps formats. There is no risk of information loss when importing (restore) from or exporting to these formats.

- Gramps XML (.gramps): The Gramps XML file is the standard Gramps data-exchange and backups format, and was also the default working-database format for older (pre 2.x) versions of Gramps. Unlike the GRAMPS V2.x grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable (for full portability including media objects in the Gramps XML package (.gpkg) should be used). The Gramps XML database is created by exporting (Menu Family Trees ->Export...) to that format.

- Gramps XML package (.gpkg): The Gramps XML package is a compressed archive containing the Gramps XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The Gramps XML package is created by exporting ( Menu Family Trees ->Export...) data in that format.

If you import information from another Gramps database or Gramps XML database, you will see the progress of the operation in the progress bar of Gramps main window. When the import finishes, a feedback window shows the number of imported objects. If the imported data originates from the very family tree in which you import the data, the import feedback gives suggestions about what could be merged; the merge is not done automatically for you. If you want to merge basic genealogy data automatically, consider CSV Spreadsheet Export/Import.

Gramps CSV import

- The Gramps CSV Spreadsheet format allows importing and exporting of a subset of your Gramps data in a simple spreadsheet format. See CSV Import and Export for more information.

GEDCOM import

First create a new empty Family Tree. Then select the menu Family Trees ->Import or the keybinding CTRL + 1 then use the Import Family Tree dialog to select the GEDCOM file you want to import, depending on the the type of GEDCOM you may then see the GEDCOM Encoding dialog.

When you import information from GEDCOM, Gramps main window will show you a progress bar. When the GEDCOM import finishes, the Import Statistics window and the GEDCOM import report windows show any results or warnings.

GEDCOM Encoding dialog

![GEDCOM Encoding dialog](image)

Fig. 5.16 GEDCOM Encoding dialog

The GEDCOM Encoding dialog will be shown when the GEDCOM file you are importing has identified itself as using the ANSEL encoding format. Sometimes, this is in error. If after the GEDCOM is imported you notice that your data contains unusual characters, undo the import, and override the character set by selecting a different encoding from the available list.

- default
- ANSEL
- ANSI (iso-8859-1)
- ASCII
- UTF8
Import Statistics dialog

![Import Statistics - dialog]

Fig. 5.17 Import Statistics - dialog
Shows details of the import statistics.

GEDCOM import report dialog

![GEDCOM import report - example results]

Fig. 5.18 GEDCOM import report - example results.

The GEDCOM import report details most of the GEDCOM lines that were either ignored or could not be understood. These are most likely because they are not part of the GEDCOM 5.5.1 standard. (See Addon:GEDCOM Extensions.) The contents of the GEDCOM line (or lines where there are continuation lines) are also shown. In some cases, the lines may not be exactly what is contained in the input GEDCOM file, because the line is reconstructed following some processing.

Reading the report
Fig. 5.19 GEDCOM import note indicating omitted data attached to "Source> Note" (data from "GEDitCOM" - "GEDCOM 5.5 Torture Test Files")

Gramps uses a more advanced 'data model' than GEDCOM, therefore some data in GEDCOM cannot be imported into Gramps. (See Gramps and GEDCOM.) The main exceptions are:

- Some GEDCOM attribute structures are treated as Gramps Attributes and therefore many of the GEDCOM Primitive Elements cannot be stored.
- The DATA elements of a SOURCE_RECORD (indicating the events recorded and responsible agency) are ignored.
- Any source citations on notes are ignored.
- Many GEDCOM Primitive Elements do not have exactly corresponding data elements in Gramps, and they are therefore stored as Attributes with appropriate names, normally the GEDCOM tag. This applies particularly to the header, submitter and submission GEDCOM records and particular fields like REFN, RFN, RIN and AFN.

Where data is listed as 'ignored', its omission is reported in the feedback at the end of import, and it is included in a Note attached to a relevant object with a custom type of GEDCOM import. See, for example, the Source object in the example screenshot.

Where data is listed as 'silently ignored', it is not reported and not included in a note. At present this may be regarded as something that has been missed by Gramps and should be raised as an issue.

GEDCOM import limitations

This section describes any GEDCOM data that cannot be directly represented in Gramps, and how it is handled. For additional information on the limits of GEDCOM imports (and exports), please read the section on Gramps and GEDCOM.

HEADER, SUBMITter and SUBmission

Gramps has no direct representation of this data, and hence all information there has to be stored in other objects. Depending on a General preferences setting, a 'default source' object may be created. If this is created, then much of the data is stored in that Source, or in Repositories attached to that source.

HEADER=

n HEAD
+1 SOUR <APPROVED_SYSTEM_ID> [0:1] (Data item of the 'default source')
+2 VERS <VERSION_NUMBER>  [0:1] (Data item of the 'default source')
+2 NAME <NAME_OF_PRODUCT> [0:1] (Repository of the 'default source')
+2 CORP <NAME_OF_BUSINESS> [0:1] (Repository of the 'default source')
+3 <<ADDRESS_STRUCTURE>> [0:1] (Repository of the 'default source')
+2 DATA <NAME_OF_SOURCE_DATA> [0:1] (Data item of the 'default source')
+3 DATE <PUBLICATION_DATE> [0:1] (Data item of the 'default source')
+3 COPR <COPYRIGHT_SOURCE_DATA> [0:1] (Data item of the 'default source')
+1 DEST <RECEIVING_SYSTEM_NAME> [0:1*] (Data item of the 'default source')
+1 DATE <TRANSMISSION_DATE> [0:1] (Data item of the 'default source')
+2 TIME <TIME_VALUE> [0:1] (Data item of the 'default source')
+1 SUBM @<XREF:SUBM>@ [1:1] (Data item of the 'default source')
+1 FILE <FILE_NAME> [0:1] (Data item of the 'default source')
+1 COPR <COPYRIGHT_GEDCOM_FILE> [0:1] (stored as the Publication information of the 'default source')
+1 GEDC [1:1] (Data item of the 'default source')
+2 VERS <VERSION_NUMBER> [0:1] (Data item of the 'default source')
+2 FORM <GEDCOM_FORM> [0:1] (Data item of the 'default source')
+1 CHAN <CHARACTER_SET> [1:1] (Data item of the 'default source')
+2 VERS <VERSION_NUMBER> [0:1] (Data item of the 'default source')
+1 LANG <LANGUAGE_OF_TEXT> [0:1] (Data item of the 'default source')
+1 PLAC [1:1] (see below)
+1 NOTE <GEDCOM_CONTENT_DESCRIPTION> [0:1] (note attached to the 'default source')
NOTE: Submissions to the Family History Department for Ancestral File submission or for clearing temple ordinances must use a DESTination of ANSTFILE or TempleReady.

The PLAC FORM is stored internally and used to govern the interpretation of places (in accordance with the GEDCOM specification).

SUBMISSION

The SUBMISSION_RECORD (there should be only one, but this is not checked) is stored as a Data item of the 'default source'.

SUBMISSION_RECORD:=
  n @<XREF:SUBN>@ SUBN                            {1:1}
  +1 SUBM @<XREF:SUBM>@                         {0:1}
  +1 FAMF <NAME_OF_FAMILY_FILE>                 {0:1}
  +1 TEMP <TEMPLE_CODE>                         {0:1}
  +1 ANCE <GENERATIONS_OF_ANCESTORS>            {0:1}
  +1 DESC <GENERATIONS_OF_DESCENDANTS>          {0:1}
  +1 ORDI <ORDINANCE_PROCESS_FLAG>              {0:1}
  +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}

SUBmitter

SUBMITTER_RECORDs (there may be more than one) are stored as Repository records attached to the 'default source' except as indicated in bold below. The SUBMITTER_RECORD that corresponds with the SUBM record in the HEADER is used to set the database owner and can be copied to the Researcher Information tab if required.

SUBMITTER_RECORD:=
  n @<XREF:SUBM>@   SUBM                          {1:1}
  +1 NAME <SUBMITTER_NAME>                      {1:1}
  +1 <<ADDRESS_STRUCTURE>>                      {0:1}
  +1 LANG <LANGUAGE_PREFERENCE>                 {0:3}
  +1 RFN <SUBMITTER_REGISTERED_RFN>             {0:1}
  +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
  +1 <<CHANGE_DATE>>                            {0:1}

  * Multimedia link is ignored
  * LANG is ignored
  * RFN and RIN are ignored

INDIVIDUAL

The INDIVIDUAL_RECORD is stored as a Gramps Person record, except as indicated in bold below.

INDIVIDUAL_RECORD:=
  n @<XREF:INDI>@  INDI                           {1:1}
  +1 RESN <RESTRICTION_NOTICE>                  {0:1}
  +1 <<ADDRESS_STRUCTURE>>                      {0:1}
  +1 SEX <SEX_VALUE>                            {0:1}
  +1 <<INDIVIDUAL_EVENT_STRUCTURE>>             {0:M}
  +1 <<INDIVIDUAL_ATTRIBUTE_STRUCTURE>>         {0:M}
  +1 <<LDS_INDIVIDUAL_ORDINANCE>>               {0:M}
  +1 <<CHILD_TO_FAMILY_LINK>>                   {0:M}
  +1 <<SPOUSE_TO_FAMILY_LINK>>                  {0:M}
  +1 SUBM @<XREF:SUBM>@                         {0:M}
  +1 <<ASSOCIATION_STRUCTURE>>                  {0:M}
  +1 ALIA @<XREF:INDI>@                         {0:M}
  +1 ANCI @<XREF:SUBM>@                         {0:M}
  +1 DESI @<XREF:SUBM>@                         {0:M}
  +1 <<SOURCE_CITATION>>                        {0:M}
  +1 <<MULTIMEDIA_LINK>>                        {0:M}
  +1 <<NOTE_STRUCTURE>>                         {0:M}
  +1 RFN <PERMANENT_RECORD_FILE_NUMBER>         {0:1}
  +1 AFN <ANCESTRAL_FILE_NUMBER>                {0:1}
  +1 REFN <USER_REFERENCE_NUMBER>               {0:M}
  +2 TYPE <USER_REFERENCE_TYPE>                 {0:1}
  +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
  +1 <<CHANGE_DATE>>                            {0:1}

  * Link to submitter, ancestor interest and descendent interest indicators are silently ignored.
  * The alias indicator ("An indicator to link different record descriptions of a person who may be the same person") is stored as an Association called 'Alias'.
  * The REFN and REFN:TYPE are stored as Attributes of the Person, but if there is more than one REFN, it may not be clear which TYPE is associated with which REFN.

Handling of the INDIVIDUAL_ATTRIBUTE_STRUCTURE is rather complicated. The following tags:

- EDUC (Scholastic achievement),
- NMR (Count of marriages),
- OCCU (Occupation),
- PROP (Possessions),
- RELI (Religious affiliation),
- RESI and
- TITL (Nobility title)

are all treated as Gramps Event's and the associated information is stored in the event structure. The details following the main tag (shown in brackets in the list above) are stored as the Description of the Event. The <EVENT_DESCRIPTOR> following the TYPE tag will overwrite the Description if the <EVENT_DESCRIPTOR>-<> is not the attribute name.

The following tags:

- Manage Family Trees - Importing data
• CAST (Caste name),
• DSCR (Physical description),
• INDO (National ID Number),
• NATI (National or tribal origin),
• NCHI (Count of Children) and
• SSN (Social Security Number)

are all treated as Gramps Attributes and most of the fields except the details following the main tag (shown in brackets in the list above), the source citation and the note structure are ignored, as indicated in bold below.

INDIVIDUAL_ATTRIBUTE_STRUCTURE: =
  n CAST <CASTE_NAME>                            {1:1}
  +1 <<EVENT_DETAIL>>                           {0:1}
  etc.

EVENT_DETAIL: =
  n TYPE <EVENT_DESCRIPTOR>                      {0:1}
  n DATE <DATE_VALUE>                            {0:1}
  n <<PLACE_STRUCTURE>>                          {0:1}
  n AGE <AGE_AT_EVENT>                           {0:1}
  n AGNC <RESPONSIBLE_AGENCY>                    {0:1}
  n CAUS <CAUSE_OF_EVENT>                        {0:1}
  n <<SOURCE_CITATION>>                          {0:M}
  +1 <<NOTE_STRUCTURE>>                         {0:M}
  +1 <<MULTIMEDIA_LINK>>                        {0:M}
  n <<MULTIMEDIA_LINK>>                          {0:M}

Individual attribute structure, type, date, place structure, address structure, age, agency, cause and multimedia link are all ignored.

FAM_RECORD

The FAM_RECORD is stored as a Gramps Family record.

FAM_RECORD:=
  n @<XREF:FAM>@ FAM                            {1:1}
  +1 <<FAMILY_EVENT_STRUCTURE>>                 {0:M}
  +1 HUSB @<XREF:INDI>@                         {0:1}
  +1 WIFE @<XREF:INDI>@                         {0:1}
  +1 CHIL @<XREF:INDI>@                         {0:M}
  +1 NCHI <COUNT_OF_CHILDREN>                   {0:1}
  +1 SUBM @<XREF:SUBM>@                         {0:M}
  +1 <<LDS_SPOUSE_SEALING>>                     {0:M}
  +1 <<SOURCE_CITATION>>                        {0:M}
  +1 <<MULTIMEDIA_LINK>>                        {0:M}
  +1 <<NOTE_STRUCTURE>>                         {0:M}
  +1 REFN <USER_REFERENCE_NUMBER>               {0:M}
  +2 TYPE <USER_REFERENCE_TYPE>               {0:1}
  +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
  +1 <<CHANGE_DATE>>                            {0:1}

• The link to submitter is silently ignored.
• The REFN and REFN:TYPE are stored as Attributes of the Family, but if there is more than one REFN, it may not be clear which TYPE is associated with which REFN.

SOURCE_RECORD

The SOURCE_RECORD is stored as a Gramps Source record, except as indicated in bold below.

SOURCE_RECORD:=
  n @<XREF:SOUR>@ SOUR                           {1:1}
  +1 DATA                                       {0:1}
  +2 EVEN <EVENTS_RECORDED>                    {0:M}
  +3 DATE <DATE_PERIOD>                       {0:1}
  +3 PLAC <SOURCE_JURISDICTION_PLACE>       {0:1}
  +2 AGNC <RESPONSIBLE_AGENCY>                 {0:1}
  +2 <<NOTE_STRUCTURE>>                        {0:M}
  +1 AUTH <SOURCE_ORIGINATOR>                  {0:1}
  +2 [CONT|CONC] <SOURCE_ORIGINATOR>          {0:M}
  +1 TITL <SOURCE_DESCRIPTIVE_TITLE>          {0:1}
  +2 [CONT|CONC] <SOURCE_DESCRIPTIVE_TITLE>    {0:M}
  +1 ABBR <SOURCE_FILED_BY_ENTRY>             {0:1}
  +1 PUBL <SOURCE_PUBLICATION_FACTS>          {0:1}
  +2 [CONT|CONC] <SOURCE_PUBLICATION_FACTS>   {0:M}
  +1 TEXT <TEXT_FROM_SOURCE>                  {0:1}
  +2 [CONT|CONC] <TEXT_FROM_SOURCE>            {0:M}
  +1 <<SOURCE_REPOSITORY_CITATION>>           {0:1}
  +1 <<MULTIMEDIA_LINK>>                       {0:M}
  +1 <<NOTE_STRUCTURE>>                        {0:M}
  +1 REFN <USER_REFERENCE_NUMBER>              {0:M}
  +2 TYPE <USER_REFERENCE_TYPE>               {0:1}
  +1 RIN <AUTOMATED_RECORD_ID>                 {0:1}
  +1 <<CHANGE_DATE>>                            {0:1}

• DATA and its subsidiary records are ignored

REPOSITORY_RECORD

The REPOSITORY_RECORD is stored as a Gramps Repository record, except as indicated in bold below.

REPOSITORY_RECORD: =
  n @<XREF:REPO>@ REPO                          {1:1}
  +1 NAME <NAME_OF_REPOSITORY>                 {0:1}
  +1 <<ADDRESS_STRUCTURE>>                     {0:1}

Manage Family Trees - Importing data 76
REFN, REFN:TYPE and RIN are ignored

MULTIMEDIA_RECORD

The MULTIMEDIA_RECORD is stored as a Gramps Media record, except as indicated in bold below.

MULTIMEDIA_RECORD:=
n @<XREF:OBJE>@ OBJE (1:1)
+1 FORM <MULTIMEDIA_FORMAT> (1:1)
+1 TITL <DESCRIPTIVE_TITLE> (0:1)
+1 <<NOTE_STRUCTURE>> (0:M)
+1 <<SOURCE_CITATION>> (0:M)
+1 BLOB (1:1)
+2 CONT <ENCODED_MULTIMEDIA_LINE> /* Chain to continued object */ (0:1)
+1 OBJE @<XREF:OBJE>@ /* chain to continued object */ (0:1)
+1 REFN <USER_REFERENCE_NUMBER> (0:M)
+2 TYPE <USER_REFERENCE_TYPE> (0:1)
+1 RIN <AUTOMATED_RECORD_ID> (0:1)

- It is expected that there will be a 'FILE' tag to indicate the file holding the multimedia object. This usage is taken from GEDCOM 5.5.1, but the ability in GEDCOM 5.5.1 to have more than one <MULTIMEDIA_FILE_REFN> and having the FORM, TYPE and TITL subsidiary to the FILE gedcom_line is not supported (a later FILE may overwrite an earlier one - there is no error checking).
- BLOB is ignored
- REFN, REFN:TYPE and RIN are ignored

NOTE_RECORD

The NOTE_RECORD is stored as a Gramps Note record, except as indicated in bold below.

NOTE_RECORD:=
n @<XREF:NOTE>@ NOTE <SUBMITTER_TEXT> (1:1)
+1 [ CONC | CONT] <SUBMITTER_TEXT> (0:M)
+1 <<SOURCE_CITATION>> (0:M)
+1 REFN <USER_REFERENCE_NUMBER> (0:M)
+2 TYPE <USER_REFERENCE_TYPE> (0:1)
+1 RIN <AUTOMATED_RECORD_ID> (0:1)
+1 <<CHANGE_DATE>> (0:1)

- source citation ignored
- REFN, REFN:TYPE and RIN are ignored

Exporting data

Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your Gramps window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

To export data, choose Menu Family Trees -> Export... or the keybinding Ctrl+E or Command ⌘+E on Apple Mac's. This will bring up the Export Assistant dialog.

Exporting allows you to share any portion of your Gramps Family Tree(database) with other researchers as well as to enable you to transfer your data to another computer.

Gramps can export data to the following file formats:

- Comma Separated Values Spreadsheet (CSV)
- GEDCOM
- GeneWeb
- Gramps XML (family tree)
- Gramps XML Package (family tree and media)
- Web Family Tree
- vCalendar
- vCard

Export Assistant dialog
The Export Assistant pages will guide you through the output file format selection, and then the export options specific to that file format. After the Final confirmation page, the export will be performed according to the choices you have made. At any time, you can click the Back button and revise any selection, and then go forward to redo the export.

Saving your data

General information about exporting from Gramps.

Select the Next button to continue.

Choose the output format

Select the file format to export your data to:

- Comma Separated Values Spreadsheet (CSV)
- GEDCOM
- GeneWeb
- Gramps XML (family tree) (default)
- Gramps XML Package (family tree and media)
- Web Family Tree
- vCalendar
- vCard

Then select the Next button to continue.

Export options
After you have adjusted your options in the two sections.

- Top unlabeled section: Filters and privacy
- Bottom unlabeled section: File format specific options

Select the [Next] button to continue.

Filters and privacy

Gramps allows you to export your selected Family tree into common file formats.

The following filters provide options that allow you to fine tune your export.

Filters allow you to export a limited amount of data, based on the criteria you select.

Privacy Filter:

[✓] Do not include records marked private: Check this box to prevent private records from being included in the exported file. (Checkbox checked by default)

Living Filter:

These option restrict data and help limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported file. For example, you can choose to substitute the word Living for the first name (see your settings); you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. Gramps uses an advanced algorithm to try to determine if a person could still be alive. Remember, Gramps is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

Select from the following options:

- Include all selected people (default)
- Replace given names of living people
- Replace complete name of living people
- Do not include living people

Person Filter:

Select from the following options:

- Include all selected people (default)
- Descendants of [Active Person]
- Descendant Families of [Active Person]
- Ancestors of [Active Person]
- People with common ancestor with [Active Person]
- Create a custom filter by selecting the Edit icon to show the Define filter dialog.

Note Filter:

Select from the following options:

- Include all selected notes (default)
- Create a custom filter by selecting the Edit icon to show the Define filter dialog.

Reference Filter:

Select from the following options:
This article's content is incomplete or a placeholder stub. Please update or expand this section.

**Select save file**

Fig. 5.23 Export Assistant - Select save file - wizard dialog - example

Enter a export file **Name:** Untitled_1.<file format extension> (default) and choose the folder location to save the export file to (normally your **Documents** folder.

Then select the **Next** button to continue.

If you don't have permission to save the file to that location you will see the **Could not create <file location and export file name>** warning dialog and then the Export Assistants **Saving failed** wizard dialog, select the **Close** button and start the export again this time choosing a suitable folder.

**Final confirmation**

Fig. 5.24 Export Assistant - Final confirmation - wizard dialog - example

The Export Assistants **Final confirmation** wizard dialog allows you to check the summarized details (Format/Name/Folder) of the export file to be created.

At this point you can press **Back** to revisit your options or **Cancel** to abort. Or select the **Apply** button to continue.
Summary

The Export Assistants Summary wizard dialog shows the Filename: and confirms that you export data has been saved successfully. Select the Close button to exit the Export Assistant.

Comma Separated Values Spreadsheet(CSV) export

Comma Separated Values Spreadsheet(CSV): Allows exporting (and importing) a subset of your Gramps data in a simple spreadsheet format. See CSV Import and Export for additional information and examples.

Comma Separated Values Spreadsheet(CSV) has the following file format specific export options:

- Include people -
- Include marriages -
- Include children -
- Include places -
- Translate headers -

Also, see Export (List) View as Spreadsheet.

GEDCOM export

Gramps supports the GEDCOM 5.5.1 version last updated 15 November 2019.

GEDCOM export has no file format specific export options but you can change the following:

- Make sure you add your Researcher information to create a valid GEDCOM file, this can be also be done with the Edit Database Owner Information tool.
- In the General Gramps settings section of the General tab in preferences you can also choose to Add default source on GEDCOM import and also Add tag on import both can significantly slow down the importing of your data.
If you have installed the third party addon **Addon:GEDCOM Extensions (.GED2)**

it will have its own specific file format specific export options.

For more information on the GEDCOM format see:

- [https://www.familysearch.org/developers/docs/guides/gedcom](https://www.familysearch.org/developers/docs/guides/gedcom)
- [https://www.familysearch.org/developers/docs/gedcom/](https://www.familysearch.org/developers/docs/gedcom/)

See [Gramps and GEDCOM](https://www.familysearch.org/developers/docs/gedcom/) for details of data which is not exported when exporting to GEDCOM (Use Gramps XML for a full family tree export/backup).

#### GeneWeb export

GeneWeb export will save a copy of your data to the GeneWeb genealogy format.

To find out more about GeneWeb and its format, visit:

- [http://www.geneweb.org](http://www.geneweb.org)

GeneWeb has no file format specific export options.

#### Gramps XML (family tree) export

- **Privacy Filters**

  It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for Gramps XML backups.

Fig. 5.27 Export Assistant - Export Options - wizard (showing defaults for "Gramps XML (family tree)") with highlight Bottom section for File format specific options

Gramps XML (family tree) export (.gramps): This format is the standard format for data-exchange and backups (see the related .gpkg format below for full portability including media objects). Exporting into Gramps XML format will produce a portable database. As XML is a text-based human-readable format, you may also use it to take a look at your data. Gramps guarantees you can open XML output of older versions of Gramps in newer version of Gramps (not the other way around though!).

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Gramps XML (family tree) has the following file format specific export options:

- **Use Compression**: option to allow Gramps to export a .gramps file, without compressing the file. (Checkbox is selected by default)

**What's not included:**

The Gramps Package backup only contains your family tree and (when the 'include media' backup option is selected) your media.

The following settings in Gramps are not transferred:

- Any changes you have manually made to `gramp.ini`
- Any custom settings for `reports/report_options.xml` you have made.
- Any custom `Books`(`books.xml`) you have created.
- Any custom `holiday sets or country calendars`(`holidays.xml`) you have created.
- Any changes you have made to the dictionary for spell checking e.g.: new or excluded words.
- Gramps exports objects in the Tree. So any added Tags or custom types that have not been applied to at least one record, the Tag or Type will have no place to be included in the backup.
- Any custom `filters`(`custom filters.xml`) you have created.

Manage Family Trees - Exporting data
Custom Filter migration

Keep your collection of custom filters through a minor updates to patch Gramps (e.g., from version 5.1.0 to 5.1.2) by manually copying your custom_filter.xml from Gramps User Directory to the corresponding directory in new gramps_version_number.

Even minor upgrades with feature changes (e.g., from a 5.0.x to a 5.1.x version) may include XML format changes since the recent innovation of addon rules are causing rapid evolution in Filters. So porting filters in this manner requires verification that the XML definitions haven't changed. Also, Addon rules may have to be installed in the new upgrade before copied custom filters will work safely.

You can keep your custom settings by manually copying each of the *.xml files from the Gramps User Directory to the corresponding directory in the new gramps_version_number directory. Be aware that (due to changes in different versions of Gramps) the settings may no longer work. So be diligent that you test.

Gramps XML Package (family tree and media) export

Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for Gramps XML backups.

Gramps XML Package (family tree and media) export (.gpkg): Exporting to the Gramps package format will create a compressed file that contains the Gramps XML database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Gramps XML Package (family tree and media) has no file format specific export options.

What's not included:

The Gramps Package backup only contains your family tree and (when the 'include media' backup option is selected) your media.

The following settings in Gramps are not transferred:

- Any changes you have manually made to gramp.ini
- Any custom settings for reports (report_options.xml) you have made.
- Any custom Books (books.xml) you have created.
- Any custom holiday sets or country calendars (holidays.xml) you have created.
- Any changes you have made to the dictionary for spell checking e.g.: new or excluded words.
- Gramps exports objects in the Tree. So any added Tags or custom types that have not been applied to at least one record, the Tag or Type will have no place to be included in the backup.
- Any custom filters (custom_filters.xml) you have created.

Custom Filter migration

Keep your collection of custom filters through a minor updates to patch Gramps (e.g., from version 5.1.0 to 5.1.2) by manually copying your custom_filter.xml from Gramps User Directory to the corresponding directory in new gramps_version_number.

Even minor upgrades with feature changes (e.g., from a 5.0.x to a 5.1.x version) may include XML format changes since the recent innovation of addon rules are causing rapid evolution in Filters. So porting filters in this manner requires verification that the XML definitions haven't changed. Also, Addon rules may have to be installed in the new upgrade before copied custom filters will work safely.

You can keep your custom settings by manually copying each of the *.xml files from the Gramps User Directory to the corresponding directory in the new gramps_version_number directory. Be aware that (due to changes in different versions of Gramps) the settings may no longer work. So be diligent that you test.

Web Family Tree export

Web Family Tree export creates a text file that can be used by the Web Family Tree program.

To find out more about Web Family Tree and its format, visit
Web Family Tree has no file format specific export options

vCalendar export

vCalendar export saves information in the format used in many calendaring applications, sometimes called PIM for Personal Information Manager.

For more information on the vCalendar format see:

- https://en.wikipedia.org/wiki/iCalendar#vCalendar_1.0

vCalendar has no file format specific export options

vCard export

vCard export saves information in a format used in many addressbook applications, sometimes called PIM for Personal Information Manager.

For more information on the vCard format see:


vCard has no file format specific export options
Manage Family Trees: CSV Import and Export

This section relates to using Gramps with the **Comma Separated Values Spreadsheet (CSV)** format.

- **Gramps CSV import**
- **Comma Separated Values Spreadsheet (CSV) export**

You can also **Export** the current list view to a Spreadsheet (*.ODT) or CSV file.

**Gramps Spreadsheet Import/Export**

This format allows you to import/export a spreadsheet of data all at once. The spreadsheet must be in the Comma Separated Value (CSV) format. Most spreadsheet programs can read and write this format. It is also easy to write by hand. This is the only Gramps import format which allows for merging with existing data.

**This spreadsheet format does not allow for 100% export of Gramps data.**

It only exports (and imports) a subset of data, namely: people (names, gender, birth, baptism, death, and burial dates/places/sources); marriages (dates/places/sources); relationships (parents and children); and places (title, name, type, latitude, longitude, code, enclosed by, and enclosed date). Notes are not exported, but new notes are appended onto the end of existing notes.

**The CSV import and export both use the Edit/Preferences/Display/Place Format setting for places. For most uses, the 'Full' setting for Place Formats should be used. If the place format setting doesn't match the CSV file for import, you may get the same place created more than once.**

There are three main uses for this format:

1. You can export your core Gramps data into a spreadsheet format, edit it with a text or spreadsheet program, and import the changes and additions back into Gramps. This is handy for sending to others to fill in, or for taking on the road when you don't have your full Gramps application.
2. You can import new data into your Gramps database. For example, if you have a set of new people to add to your database, but don't want to hunt and peck your way to finding where they go, you might find it easier to type them into a spreadsheet, and then quickly bring all of them in at once. This is handy if you have a large amount of data that you are cutting and pasting from another application or the web. An example of this is **restoring your Gramps database** by loading the Narrative Website into a spreadsheet.
3. You can also import a set of corrections and additions. Say that you have printed out a report, and you are going through it marking corrections. If you make each correction a section of a spreadsheet, you can "script the edits" and then execute them all at once.

**Export**

![Fig. 6.1 Export Assistant - Export Options - wizard dialog (showing defaults for "Comma Separated Values Spreadsheet (CSV)") with highlight Bottom section for File format specific options](image)

To export your database:

1. Start Gramps
2. Load the Family Tree to be exported
3. Select from the menu **Family Trees -> Export...**
4. Select **Next** on the **Saving your data** window.
5. Select **Comma Separated Values Spreadsheet (CSV)** on the **Choose the output format** window
6. On the **Export options** window:
   1. In the top section, select which filters to apply to your family tree
   2. From the checkboxes, select which items to include in the export (people, marriages, children, places) and whether to Translate headers
into the language currently being used.

7. On the **Select Save file** window, select the destination filename and path
8. On the **Final confirmation** window, verify the setting and click the Apply button to begin the actual export.

A subset of fields containing your genealogy data will be saved to a .csv file in the format described below. The people and families are annotated in such a way that allows the data to be edited and overwrite the outdated information as they are Imported back in. The annotations allow updating the Tree database via Import.

There are some columns that will be blank, specifically note and source columns. These are listed in the spreadsheet so that you can make notes for the import, but notes are never exported with this tool.

Your data is broken up into four sections representing places, individuals, marriages, and children. The exported fields and column names are:

**Places**
- Place, Title, Name, Type, Latitude, Longitude, Code, Enclosed_by, Date

**Individuals**
- Person, Lastname, Firstname, Callname, Suffix, Prefix, Title, Gender, Birthdate, Birthplace (or Birthplaceid), Birthsource, Baptismdate, Baptismplace (or Baptismplaceid), Baptismsource, Deathdate, Deathplace (or Deathplaceid), Deathsource, Burialdate, Burialplace (or Burialplaceid), Burialsoure, Note

**Marriages**
- Marriage, Husband, Wife, Date, Place (or Placeid), Source, Note

**Families**
- Family, Child

The first column in each area is the Gramps ID. That is what will connect your edits back to the appropriate data, so do not alter those IDs. Load this file into your favorite spreadsheet using comma separated, double-quote text delimited, and Text format (any encoding for now). Then you can add or correct data, and save it back out, keeping the same format. You can then import the data back on top of your old data and it will be corrected.

**LibreOffice allows auto-formatting to be turned off when opening the CSV file.**

Auto-formatting may cause LibreOffice to interpret the dates incorrectly. Change the type of the column to 'Text' rather than 'Standard'. If your spreadsheet program doesn't allow formatting the fields before imported the data into columns, it will be necessary to change the date display format in Gramps before exporting. This is done with **Edit -> Preferences -> Display -> Date Format**

**Excel allows formatting columns as 'text' while opening the CSV file.**

If not overridden, Excel may interpret the dates incorrectly. Change the type of the column to 'Text' rather than 'General'. Open the CSV from the file menu (select 'Text files' as the type in the file open dialog box). This brings up the 'Text Import Wizard' which allows selecting 'Delimited' by commas, and selecting 'Text' for all the columns. (To Select all columns, click the first column, scroll to last and shift-click it.)

**Excel cannot directly save proper Unicode CSV files.**

To save a CSV in Unicode, save to "Unicode Text (*.txt)" , then open the file in Notepad++. Using Notepad++ 'Search' and replace menu, change all the tabs ('\t') to commas (','). Using Notepad++ 'Encoding' menu convert to "UTF-8-BOM" and save the file to CSV (*.csv).

**Import**

To import your data:

1. Use the file from above, or create a spreadsheet (described below) with genealogical data
2. Start Gramps
3. Create a new Family Tree
4. Select from the menu **Family Trees -> Import...**
5. Select the **Comma Separated Values Spreadsheet (CSV)** file and then select the **Import** button

The merge part of this code will only add or update information to your database, and it always assume that the spreadsheet data is the correct version.

If you load this spreadsheet into LibreOffice, make sure you select each column as type **Text** rather than **Standard**. Standard will reformat your
dates and numbers. Also, if you use Excel, you will probably want to select all cells once opened, and change the format of the cells to **Text**.

The spreadsheet is data made up of columns. Each column should have at the top of it the name of what type of data is in the column. The first column in each area is the Gramps ID reference. You must use special names for the columns. They are:

### Place

- **place**: a reference to this place
- **title**: title of place
- **name**: name of place
- **type**: type of place (eg, City, County, State, etc.)
- **latitude**: latitude of place
- **longitude**: longitude of place
- **code**: postal code, etc.

**enclosed_by**: the reference to another place that encloses this one

**date**: date that the enclosed_by place was in effect

### People

- **person**: a reference to be used for families (marriages, and children)
- **grampsid**: to assign a Gramps id to the person
- **firstname**/**first_name**/**given**/**given_name**: a person’s first name
- **surname**/**lastname**/**last_name**: a person’s last name
- **callname**/**call_name**/**call**: a common name (nickname) for the person
- **prefix**: surname prefix (von, de, etc)
- **suffix**: a suffix of a person’s name (Jr., Sr.)
- **title**: a person’s title (Dr., Mr.)
- **gender**: male or female (you should use the translation for your language)
- **source**: source title for person
- **note**: a note for the person’s record

**birthdate**: date of birth

**birthplace**: place of birth

**birthsource**: source title for birth

**baptismdate**: date of baptism

**baptismplace**: place of baptism

**baptismsource**: source title of baptism

**deathdate**: date of death

**deathplace**: place of death

**deathsource**: source title for death

**deathcause**: cause of death

**burialdate**: date of burial

**burialplace**: place of burial

**burialsource**: source title of burial

**occupationdate**: date of occupation

**occupationplace**: place of occupation

**occupationsource**: source title of occupation

**occupationdescr**: description of occupation

**residedate**: date of residence

**residenceplace**: place of residence

**residencesource**: source title of residence

**attributetype**: type of attribute

**attributevalue**: value of attribute

**attributesource**: source title of attribute

### Marriage

- **marriage**: if you want to reference this from a family, you'll need a matching name here
- **husband/father/parent1**: the reference of the person above who is the husband (for female parent1, you'll need to put gender in the person area, or edit it later in gramps)
- **wife/mother/parent2**: the reference of the person above who is the wife (for male parent2, you'll need to put gender in the person area, or edit it later in gramps)
- **date**: the date of the marriage

### Family

- **family**: a reference to tie this to a marriage above (required)
- **child**: the reference of the person above who is a child
- **gender**: male or female (you should use the translation for your language)
- **note**: a note about the family

### Details

Column names are not case-sensitive. You may use any combination of the columns, in any order. (Actually, you have to at least have a surname and a given name when defining a person, you have to have a marriage and child columns when defining children, and places need a place reference, but that is it.) The column names are the English names given (for now) but the data should be in your language (including the words “male” and “female”).
Top-to-bottom order is important in that if you want to reference something in one area to another, the definition MUST come first. For example, if you want to define families of people, the individuals must be defined before the families. The same applies to places. So it is usually best to put the Places data first, people next, then marriages and families.

Each of these can go in its own area in a spreadsheet. There is no limit to the number of areas in a sheet, and each area can have any number of rows. Leave a blank row between "areas". Just make sure that areas are not next to each other; they must be above and below one another.

You can have multiple areas of each kind on a spreadsheet. The only limitation is that if you refer to a person, you must do that in a row lower than where that person is described. Likewise, if you refer to a marriage, you must do that in a row lower than where the marriage is described. References to enclosed by places must already exist in the database, or be defined in rows above in the spreadsheet.

If you use the 'grampsid' as a way to assign specific ids, be very careful when importing to a current database. Any data you enter will overwrite the data assigned to that grampsid. If you use ids in the place, person, marriage, or family columns that are surrounded by brackets (for example '[I0001]'), the values you use will be interpreted as grampsids as well. If you are adding new items, you are encouraged to avoid use of the bracket format or grampsid columns, so as to avoid accidentally overwriting your data. If you are mixing the bracket (or grampsid) methods with plain references (no brackets), put the plain referenced data after the bracket referenced data.

If you are entering the data in a text file, and if you wish to have a comma inside one of the values, like "Clinton, Co., MO" then you need place the entire value in double-quotes and put the first double-quote right after the preceding comma. For example:

```
m1, p1, p2,"Clinton, Co., MO"
m2, p3, p4,"Havertown, PA"
```

A spreadsheet program will do this automatically for you.

Here is an example spreadsheet in LibreOffice, but any spreadsheet program should work.

![Spreadsheet](image)

Notice that the data need not begin in the first column, nor in the first row.

And here is the resulting data in Gramps:

![Gramps](image)
Example CSV with multiple areas

Here is an example of a CSV text spreadsheet with multiple areas:

<table>
<thead>
<tr>
<th>Place, Title, Name, Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>[P0001], Michigan, Michigan, State</td>
</tr>
<tr>
<td>L1, USA, USA, Country</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Firstname, Surname, Birthdate, Birth place id</th>
</tr>
</thead>
<tbody>
<tr>
<td>John, Tester, 11/11/1965, L1</td>
</tr>
<tr>
<td>Sally, Tester, 01/26/1973, L1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Person, Firstname, Surname, Birthdate, Birth place id</th>
</tr>
</thead>
<tbody>
<tr>
<td>p1, Tom, Smith, 22 Jan 1970, [P0001]</td>
</tr>
<tr>
<td>p2, Mary, Jones</td>
</tr>
<tr>
<td>p3, Jonnie, Smith</td>
</tr>
<tr>
<td>p5, James, Loucher</td>
</tr>
<tr>
<td>p6, Penny, Armbruster</td>
</tr>
<tr>
<td>[P0002], Tim, Sparklet</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Marriage, Husband, Wife</th>
</tr>
</thead>
<tbody>
<tr>
<td>m1, p1, p2</td>
</tr>
<tr>
<td>m2, p5, p6</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Family, Child</th>
</tr>
</thead>
<tbody>
<tr>
<td>m1, p3</td>
</tr>
<tr>
<td>m1, p6</td>
</tr>
<tr>
<td>m2, [P0002]</td>
</tr>
</tbody>
</table>

If you cut and paste that into a file (or use the Addon:Import Gramplet), you can import it directly.

A date can be any valid Gramps date, including dates formats like "26 JAN 1973" or "26.1.1973".

If you make your references be Gramps IDs inside square brackets, then you can refer to people already in the database, like this:

<table>
<thead>
<tr>
<th>Person, Firstname, Lastname</th>
</tr>
</thead>
<tbody>
<tr>
<td>joe's boy, Harry, Smith</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Family, Child</th>
</tr>
</thead>
<tbody>
<tr>
<td>[F1524], joe's boy</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Husband, Wife</th>
</tr>
</thead>
<tbody>
<tr>
<td>[I0123], [I0562]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>firstname, surname</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timothy, Jones</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>place, enclosed_by</th>
</tr>
</thead>
<tbody>
<tr>
<td>[P0001], [P0002]</td>
</tr>
</tbody>
</table>

This example would create and add Harry Smith to the previously existing family in Gramps, family F1524.

Also, this example would marry two previously existing people, I0123, and I0562.

This also creates a person named Timothy Jones who is not related to anyone.

Finally, this also make place P0001 be enclosed by place P0002.

Example CSV from Spreadsheet
Fig. 6.4

Using Gramps `Example.gramps` for this example. The children already exist in the Family Tree. So you can enter an entire generation (8 names with marriage dates) into LibreOffice Calc.

Notice that you can use numbers or strings as the reference names between areas. In the person area, I used the numbers 1 through 8. That made it easy to refer to them in the second area of marriages. The marriages are labeled with the letters A through D.

Also note that in the spreadsheet the children in the third area are existing people in Gramps as indicated by the brackets around the Gramps IDs.

Saving as CSV and importing into Gramps produces the far right-hand column in the tree.

Fig. 6.5 Saving as CSV and importing into Gramps produces the far right-hand column in the tree. (Highlighted in yellow)

Contents of CSV file `gen4-test.csv`

```
"Person","Firstname","Lastname",
1,"Peter","Blank",
2,"Anna Maria","Kiefer",
3,"Georg","Schmidt",
4,"Barbara","Goering",
5,"Johann","Kiefer",
6,"Fidee","Federer",
7,"Sebastian","Scheibl",
8,"Magdalena","Schlegel"
```
<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>Johann</td>
<td>Kiefer</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Fides</td>
<td>Federer</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Sebastian</td>
<td>Schelli</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Magdelena</td>
<td>Schlegel</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Marriage**, **Husband**, **Wife**, **Date**
  - "A",1,2,"28 Jan 1712"
  - "B",3,4,"4 May 1732"
  - "C",5,6,"28 Jan 1730"
  - "D",7,8,"17 Aug 1927"

- **Family**, **Child**, **   **
  - "A","[I0104]"
  - "B","[I0105]"
  - "C","[I0972]"
  - "D","[I0973]"

See also

- Addon: Import (text) Gramplet 3rd party addon by Doug Blank - an interactive version of the CSV Import
- Python CSV library docs - **dialects and formatting parameters**

Examples of customizing the CSV import code to support additional records:

- **PR #139**: Add CSV Import support for AFN and REFN attributes
- **PR #810**: Add occupation & residence events + attributes in the CSV persons importer
The living status of the people in a Gramps database is important when you need to share your data with others, but want to protect the details of those that are alive. It is also employed in some reports. For these reasons, Gramps has some tools to help you determine if someone is alive.

**How does Gramps determine if someone is alive?**

A simple way to tell if someone is alive is to see if they have a death event, or a death-related event (such as a burial). However, it is probably true that many people in your database don't have such events, as you may not know any details of their death. If you know someone is dead, it might be a good idea to create a death event. You can also go back and add useful details (such as date and place of death) once that is known. Adding events for people known dead, even if they contain no exact details, is somewhat useful. However, Gramps can also add events with estimated dates (or not) for you (described below).

Requiring a user to manually add a death event to a person (so that they would not be considered alive) would be very tedious --- one would have to enter details on many people. Recall that if someone is considered alive, then their details should be prevented from being shared when exported.

Therefore, Gramps has a function that can compute whether someone is probably alive based on their event dates, or their relations with people who may have event dates. For example, if a person doesn't have any evidence of death (such as a death or burial event), then Gramps will check this person's parents, children, siblings, continuously until some evidence is found---or it runs out of connections to check. Using information on typical age and event spans (such as typical age differences among siblings, typical ages of mothers at time of birth, etc.) Gramps can make guesses as to whether a person is alive or dead. As you can imagine, this can be a time-expensive function to execute, but can be quite useful. The values for the typical ages at birth, between generations, etc., can be set in [Menu -> Edit -> Preferences -> Dates](#).

The probably alive function can check to see if a person was alive on any specific date, or during a time span. This is used in the [Age on Date Gramplet](#). Normally, the system will estimate birth and death events, and see if a date falls between those two.

However, there is one special case: if you are looking for people probably alive *today* and they have a death event, then they are considered dead no matter what (even if the event doesn't have a date). Therefore, you will get different results if you see who was probably alive yesterday (or last year) as compared to who is considered alive today. The reason for this is that if you have a death event, you know that a person died in the past, but you don't know when. If you look to see if a person was alive in the past (yesterday and prior) then you can not say for certain if they were dead then without knowing a death date.

If you want to know the details of why Gramps has determined an individual is alive or dead, you can use the [Calculate Estimated Dates Tool addon](#) to get an explanation. This will show the estimate birth and death dates, and the relationship to someone who has an event date on which these are based.

**Probably Alive Proxy**

The first tool is the "Probably Alive" proxy. This is used automatically whenever you export your data to a format that supports the ability to restrict details on living people. The proxy wraps the database in a layer that prevents access to sensitive details of living people, such as their given name, and their events.

**Probably Alive Filter**

Today's date is treated specially in the instances of events with no dates, and checking alive status in the past. For example, if a person has a death event with no date, then we know that the person is dead as of today, and always in the future. However, for those functions for which you can check to see if a person was alive on a date in the past, we cannot say if they were alive or dead on that date. So, if you have a death event with no date, and check to see if they were alive just yesterday, Gramps will be unable to determine the alive/dead status.

See: *Probably Alive - How does Gramps determine if someone is alive?*
• People probably alive filter

Calendar Gramplet
See Calendar gramplet.

Editing Dates
See Editing dates.
This section is provides the basic knowledge necessary to start entering your genealogical information into Gramps. It will explain how to enter people into your family tree (also called a database) and how to specify their family relationships. (A more detailed explanation will follow in the next chapter: Gramps 5.1 Wiki Manual - Entering and editing data: detailed.)

First, let us identify the types of information you can enter into your family tree using Gramps. These include:

- Personal information about an individual (names, addresses, birth and death dates, etc.)
- Information about an individual's relationships (marriages, divorces, civil unions, etc.)
- Information about an individual's parents and children
- Sources that document your research

### Keybindings (Keyboard Shortcuts or Hotkeys)

In addition to interacting with Gramps through menu items and buttons, you can use its extensive set of "keybindings." For more information, see Appendix B: Keybindings reference.

Now let us explore how you can enter and edit these various types of genealogical information.

## To add or edit a person

The **Add** menu for each **Category View** includes the option to add a **Person**. A **keybinding** for adding a Person is also supported in all categories views.

There are multiple ways to add a new person to your family tree. Many have an implied context which saves a step in grafting the Person into a Tree. (e.g., adding a Person from within the Family context of the Relationships or Charts views automatically inserts the new Person into the Family. You don't have to create the Person as a separate action, then subsequently find and drag the new Person into that Family.) We will cover some of the different workflows as we proceed.

### Add a new person

![Fig. 8.1 People Category - Tree View - Grouped People](image)

The most obvious way to insert a person in your tree is to add them from the **People** View. While you are in the **People** View, click the Toolbar button.

![Fig. 8.2 Edit Person - window - New empty editor](image)

The **Edit Person** dialog will be shown and you can enter any data you know about this person then select **OK** to save the new person.
Edit an existing person

Fig. 8.3 Edit Person - window - Existing person example

To edit information about a person already present in the family tree, select the person from the People View and click the Toolbar Edit button.

Alternate ways of adding or editing a person from the People View

You can also use the Menu Edit->Add... and other items available under Edit. Or you can right-click on the person and select Add... or Edit... from the context menu that pops up.

People can also be added to the family tree in the Relationships View, Edit Family dialog, and other places where it makes sense.

To specify a relationship

There are two primary ways to specify relationships between people:

1. By family:
   a. using the Relationships View. The Relationships View is usually used to build multiple relationships around a single person.
   b. using the Edit Family dialog from the Family List View. The Family List is usually used to build all the Relationships within a single family at a time.

1. By Association
   a. using the Associations tab of the Edit Person dialog. Adding a Person and specifying the type of Association (godparent, coworker, pallbearer, childhood friend, etc.) identifies an interpersonal relationship.
   b. using the Link Editor feature of the Edit Note dialog. Cross-referencing a person via a Person link in a Note will associate that linked person to the person where the note is attached.
   c. Persons who share a reference (sources, notes, colocated in the same places, etc.) have an indirect or proximal relationship.

Specifying a relationship using the Relationship View

Fig. 8.4

To specify a new relationship to the Active Person, switch to the Relationships View and you will see this individual indicated as the "Active Person". Next to the Family label is a Add button (typically represented by a + sign).
Clicking the + button will display the **Edit Family** dialog with the Active Person set as either the father or the mother.

Now a question ?: Does the person who will form the relationship with the Active Person already exist in the family tree? If yes, click the **Select** button to the other person. You will then be able to browse through the list of people in the family tree to select the one you want. If not, click the + button. This will allow you to add a new person to the family tree and to specify the relationship this person has to the Active Person.

**Filtering**

By default, Gramps filters the displayed list to show only those people who could theoretically have a relationship with the Active Person. That is, Gramps only shows those people whose birth dates and death dates fit within the lifetime of the Active Person. If you wish, you can add a person to the list by clicking the + button. To completely override the filter and display all people from the family tree, check the Show all box.

To search a person on dialog selector

Remember that you can get an entry on the list by typing the first letter on your keyboard. (see Finding records)

To edit an existing relationship from the **Relationships** View, click on the Edit button next to corresponding Family entry. If there is more than one relationship in the list, you can select the spouse or partner you want by clicking the corresponding Edit button next to the relationship.

**Specifying a relationship using the Family List View**

To specify a new relationship in the **Family List** View, click on the + button on the toolbar, and an empty Edit Family dialog will open. At this point, you can add people to the family.

**To specify parents**

You can specify the Active Person's parents in the **Relationship** View (See **Select Family** - selector). A little care is required to prevent the creation of duplicate families. If you wish to add the Active Person to an already existing family, you should click the **Select** button. If the family including the parents does not already exist, you should click the + button.
If you click on the **Select** button, you are presented with the **Select Family** dialog. This will allow you to select the existing family, and then the Active Person will be added as a child to the family.

If you click on the **+** button, a new **Edit Family** dialog is presented with the Active Person listed as a child of the new family. You can add the parents to the family by either adding new people as the parents or selecting existing people as the parents.

You can also specify the parents of a person in the **Family List** View. If the family already exists, click on the Toolbar **Edit** button and add the person as a child when the **Edit Family** dialog is displayed. If the family does not already exist, click the **+** button to create a new family, and add the appropriate parents and children.

**Duplicate Family Warning**

If you create a new family and select parents that are already in an existing family, Gramps will issue the **Duplicate Family** warning message. If you proceed by saving the new family, you will have a duplicate family.

**To specify children**

Adding children to a relationship is done through a similar procedure. From the **Relationships** View or the **Family List** View, select the existing family or create a new family. Children can be added by selecting the **+** button or **Select** button to the right of the child list.

Clicking the **+** button will display the **Edit Person** dialog, allowing you to enter a new person. Clicking on the **Select** button, will allow you to select an existing person from a list. By default, the child is added with the relationship type of **birth** to both parents.

**Adding photos and other media objects**
You can add photos and other media objects to individual people, events, sources, and places. You can also add images that might not be limited to a single person or event (for example, group family photos).

Note

The first image in the Gallery will be the default *(displayed)* image.

If you want to add an image to a single person, switch to the **People** View (mainwin-fig), select a person, and then click the icon on the toolbar. This will bring up the **Edit Person** dialog (edit-pers-fig). Next, select the **Gallery** tab, and click the button to call up the **Select a media object** dialog. Type a filename or browse to find the image file you want and then provide a title for that image. Keep adding images until you are done.

To add images related to a relationship (for example, a marriage), switch to the **Family** View (family-fig) and double-click on the Spouse box. This calls up the **Marriage/Relationship editor** dialog. Select the **Gallery** tab and click the button to add an image.
To add images related to a source or a place, first switch to the Source View (sources-fig) or Place View (places-fig). Select the source or place you want and then either double-click on it or click the Edit icon on the toolbar. Select the Gallery tab and click the + button to add an image.

Finally, to add images that you want to include in the family tree, but are not limited to any particular person, relationship, source or place, switch to the Media View (media-fig). Then click the icon on the toolbar to add an image. If you have already added any images to any individual galleries, you will also find them listed in the Media View.

**Alternate way of adding images to galleries**

An image can always be added to any gallery by using drag-and-drop. Items can be dragged from the Media View, any gallery, the desktop, the file manager or a web browser and dropped on the target gallery, adding the image to the gallery.

In any gallery, you can also use the button to edit image information and the button and to remove the image reference from that gallery.

**Removing an image from a gallery**

Removing a media object from a gallery does not remove the image from the family tree. To completely remove the image from the family tree, delete it from Media View by first selecting it and then clicking the Remove icon on the toolbar.

**To edit events, citations/sources, places, and repositories**
To add an event, a citation/source, a place, or a repository to the family tree, switch to the appropriate view, and then click the + icon on the toolbar to add the corresponding object. Enter the information into the Event Editor (or Source Editor, Citation Editor, Place Editor, or Repository Editor) dialog.

To edit information about events, sources, places, and repositories already present in the family tree, switch to the appropriate view, select an entry you would like to view/modify, and then click the Edit icon on the toolbar. Alternatively, you may double-click on the entry to edit it.
The previous section offered you a brief overview of how to enter and edit data in Gramps. This section continues that discussion in much greater detail.

As we have been shown, Gramps offers you a series of Views. Each of these Views gives you opportunities to enter and edit information. In fact, you can often get to the same information from different Views.

In Gramps, information is entered and edited through what we call Edit dialogs. Since we use that term frequently, we should define what we mean by it:

An Edit dialog is a pop-up window that provides one or more forms for entering and editing data that fits a certain category. Examples in Gramps include the Edit Person dialog and the Family Editor dialog, among many others.

An Edit dialog often includes a series of "notebook tabs" that group the information into subcategories. For example, the Edit Person dialog has notebook tabs for subcategories such as Events, Attributes, Addresses, and Notes, among others.

Add, Remove, and Edit buttons

In most cases, Gramps uses a + to correspond to Add, a - correspond to Remove, and an icon of a pen on a sheet of paper to denote Edit. We will continue referring to the latter as the Edit+ button, while using + and - to denote the two former buttons.

Let's continue with a deeper dive into Entering and editing data of specific types:

- **Part 1**: How to add persons, dates, families and relationships to Gramps
- **Part 2**: How to add the other core objects in Gramps: events, media, sources and citations, places, repositories and notes
- **Part 3**: How names, attributes and addresses work, as well as how you can merge data.
The section expands on the brief overview of how to enter and edit data in Gramps. Gramps offers you a series of Views. Each of these Views gives you opportunities to enter and edit information. In fact, you can often get to the same information from different Views.

In Gramps, information is entered and edited through what we call dialogs. Since we use that term frequently, we should define what we mean by it: A dialog is a pop-up window that provides one or more forms for entering and editing data that fits a certain category. Examples in Gramps include the Edit Person dialog and the Family Editor dialog, among many others.

A dialog often includes a series of "notebook tabs" that group the information into subcategories. For example, the Edit Person dialog has notebook tabs for subcategories such as Events, Attributes, Addresses, and Notes, among others.

Add, Remove, and Edit buttons

In most cases, Gramps uses a + to correspond to Add+, a - to correspond to Remove-, and an icon of a pen on a sheet of paper to denote Edit. We will continue referring to the latter as the Edit button, while using + and - to denote the two former buttons.

Editing information about people

Information about people is entered and edited through the Edit Person dialog. This dialog can be invoked from different Views in the following ways:

- From the People Category:
  - Double-click the name of the person whose data you would like to edit
  - Select the name by single click and then click the Edit button on the toolbar.
  - Select the name and then press Enter.
  - Select Edit... from the Edit menu of Gramps
  - Select Edit from the context menu that appears upon right-click on the name.

- From the Relationships Category: To edit the Active Person's data, click on the Edit button next to the Active Person's name.

- From the Charts Category: Double-click in the box having the name of the person whose data you want to edit.

Any of these methods will prompt you with the Edit Person dialog.

Edit Person dialog

The Edit Person dialog is where you either add a new person's information or edit an existing person.

The top of the window has two parts: The basic information about the Preferred name of the person, and a section General with the privacy button (to set the record as private), the gender selector, an ID you can give this record, and a marker you can assign to the person indicating the state of the record (complete, TODO, uncertain, ...) which will give this record a specific color in the person view.
By using the context menu (right clicking) from a blank area in the top section of the window eg: near the "Preferred Name" field, you will be present with a context menu for three options:

- Make Active Person
- Make Home Person
- Quick View reports are available.

Below this top section, there are several "tabs" containing different categories of available information. Click any tab to view and edit its contents.

Clicking the OK button at the bottom will apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button will close the window without applying any changes.

If any data in any tabs were modified, an Save Changes? alert window will appear, prompting you to choose from the following options:

- Close the without saving - changes.
- Cancel (default) - the initial cancel request.
- Save - the changes.

as well as a checkbox to indicate Do not ask again. Also can be disabled from Suppress warning when cancelling with changed data option in the Preferences > Warnings dialog.

Clicking OK will immediately save changes to the database. There is no need for a Save operation, since all changes are immediate.

The preferred or default name is the name that will be used in Gramps for the 'name' of the person. You can set in the Gramps Preferences how a name is displayed, and generally you will only the need to put data in fields shown in the preferred name section.

Only detailed reports (textual and Narrative Web site generator) show also the alternate names. Note however that searching on a name will search in all names attached to a person, not only the preferred name.

The preferred name section contains the typical name information you will edit upon creation of a person. To reduce clutter, the less frequently
needed fields (for Multiple Surnames and Alternate Names) are hidden by default. To expand the section for Multiple Surnames, click the Add button or use its keybinding. To see the full range of data you can store about a name, click the Edit button in the lower right corner the Preferred name section or use its keybinding. This will show the Name Editor.

The name fields of the preferred name in the Person Editor are:

- **Type** of the name. Predefined types include: Also Known As, Birth Name (default), Married Name, Unknown. You can also type over in this entry field to create your own Custom Types (eg nick name, short name, etc.).

It is advisable that the preferred name be a registered birth name or other name with legal standing. Those are names that will be found most often on citable documents. You may choose to store other name types in the Name tab of the Person Editor.

- **Given name**, the person's given name(s)
- **Surname**, the part of a person's name indicating the family to which the person belongs.
  - Selecting the Use Multiple Surnames Add button, will show the Multiple Surnames section entry box, allowing you to enter compound surnames (for example for patronymics, or compound matrilineal-patrilineal names)
- **Surname prefix**, an optional prefix for the family name that is not used in sorting, such as de or van
- **Origin**, the origin type of the name identifies the cultural naming system that specifies how a particular surname was elected. This is meta information about the surname which can be important in genealogical research.
- **Title**, which is a title (typically in abbreviated form) used to refer to the person such as Dr. or Rev., selector,
- **Nick Name**, is a descriptive name given in place of or in addition to the official given name. If a Nick name is a full name construct, use a specific name type Also known as instead of the Nick field.
- **Call name**, officially this is the part of the given name that is the normally used name. Eg, a person can have 3 given names as in Jean Baptiste Jules, where in reality only Baptiste is used. In Germany and some other places, it was customary to underline the calname among the different given names, see also here. Some people will try to use this field also for nickname, or changes to the Given name (like Cristy for Cristina), but this is not the intended use. A call name is a proper legal name. For nick names, or short name variants, you should create an alternative name with a different type.

On the Name Editor an extra field is available: Family Nickname. This is an unofficial name given to a family splinter group to distinguish them from people with the same family surname. Often referred to as Farm name and typically references a location where the splinter group resides or originates. (aka sect, sect, camp)

The Origin and Type fields provide an "autocompletion" feature: as you type in these fields, a menu appears below the field containing database entries that match your partial input. This gives you a shortcut by letting you select an entry that already exists in the database rather than having to type it all out. You can select the entry using your mouse or using your arrow and Enter keys.

This article's content is incomplete or a placeholder stub.
Please update or expand this section.

Multiple Surnames

Fig. 9.1.6 "Multiple Surnames" section (Highlighted in Blue) of the "Edit Person" - dialog - example

When the add (Use Multiple Surnames) button has been pressed at the far right of the Surname: row in the Edit Person: window, a new Multiple Surnames section entry box will be shown, allowing compound surnames to be entered. Alternately, the Add button's Editor keybinding can be used.

The height of the multiple surname box can be customized in the Display tab of the Edit Preferences dialog.

The Multiple Surnames feature might be used for patronymics or compound matrilineal-patrilineal names. Another variation would be a Scandinavian name like ‘Syver Ericksen Skotterud’ where the full name is composed of a forename (Syver), a reference to his father (Ericksen or son of Erick) together with a village or locality name. In such a case, you can add 'Ericksen' with an Origin of "Patronymic" and expand to a Multiple Surnames by adding 'Skotterud' with an Origin of "Location".

If you do not add any information in this section then, on the next open of the Edit Person dialog, it will be hidden. Any empty rows will not be saved.
The Gender menu offers the choice of person's gender:
- male
- female
- unknown (Default)

The ID field displays the Gramps ID number which identifies the user in the Family tree uniquely. This value helps you distinguish between people who have the same name. You may enter any unique value you want. If you do not provide a value, Gramps will automatically select a value for you.

The Tags area show the your custom assigned tags that specify some basic information on the status of your research.

- The Edit the tag list button brings up the Tag selection dialog list that lets you remove or assign existing custom tags.
- The Privacy button lets you mark whether or not the person's record is considered private.

Preferred image

If any images exist the person editor will show an additional area in the top left region (otherwise it is hidden). This Image area shows the first image available in the Gallery of this person.

Edit Person tab pages

The tabs reflect the following categories of personal data:

Events

The Events tab lets you view and edit any events relevant to the person. The bottom part of the window lists all such events stored in the database and displays the following columns: Type, Description, Date, Place, Main Participants, Private (lock icon), Role, ID, Age. The top part shows the details of the currently selected event in the list (if any). The buttons +, Edit, and - allow you to add, modify, and remove an event record from the database. Note that the Edit and - buttons become available only when an event is selected from the list.

When you use the Share an existing event button the Select Event selector dialog is shown allowing you to select an already existing event and edit it in the Event Reference Editor dialog.

When you add a new event or edit an existing event, the Event Reference Editor dialog is invoked. The Event Reference Editor dialog is described in the Event Reference section.
The Select Event selector dialog allows you to link to an already existing event and once selected it will be opened in the Event Reference Editor dialog.

The following columns are shown: Type (default sort for list), Main Participants, Date, Place, Description, ID, Last Change.

You may use the Find button to filter the list based on one of the options from the drop down list:

- Type contains (default)
- Type does not contain
- Main Participants contains
- Main Participants does not contain
- Date contains
- Date does not contain
- Place contains
- Place does not contain
- Description contains
- Description does not contain
- ID contains
- ID does not contain
- Last Change contains
- Last Change does not contain

Names

The Names tab lets you view and edit any alternative names the person may have. The name shown in the top of the Edit Person dialog is the Preferred name and is usually (but not necessarily) the Birth Name. Alternative names might be other Name Types for aliases ('Also Known As' name type) for adopted names, pen names, stage names or legal name changes. (Because it is so common, there is a separate alias Name type for "Married Name"). If alternative names exist, date ranges can be set for each. So a "Birth Name" may use one range (before the date of adoption) and a "Also known as" will have another range (after the date of adoption). Alternative names can also be spelling variants, including anglicized versions of the birth name and common misspellings.

The bottom part of the window lists all alternate names for the person stored in the database. The top part shows the details of the currently selected name in the list (if any). The buttons (add), (edit), and (remove) allow the addition, modification, and removal of an alternate name from the database. Double-clicking a row is the same as selecting and clicking the (edit) button. Note that the and buttons become available only when an alternate name is selected from the list.

Any row in the Alternative names may be set to the Preferred name from the context menu. Right-click the Alternative name and choose the menu choice. That Alternative names row will be swapped into the Preferred name section and the previous Preferred name will be demoted to the bottom of the Alternative names list.

When adding a new name or editing an existing name, the Name Editor dialog is invoked. This Names dialog is described in the Name Editor section.

Source Citations

The Source Citations tab allows you to view and document the source citations for the information you collect.

These might be general sources that do not describe a specific event, but which nevertheless yield information about the person. For example, if Aunt Martha's memoirs mention her great-grandson Paul, the researcher may assume that this Paul actually existed and cite Aunt Martha's memoirs as the source that justifies this assumption.
Tip
Sources which document specific events are best recorded as sources of the event (under the **Events** tab) instead of as a source of the person. The person's **Citations** tab is best used for any sources not specifically connected to any other data.

The central part displays the list of all source references stored in the database in relation to the person. The buttons [+], [Edit], and [-] allow you to correspondingly add, modify, and remove a source reference to this person. Note that the [Edit], and [-] buttons become available only when a source reference is selected from the list.

On edit you can change the data in the citation (unique to this person), as well as the shared source object, see [Editing Citations](#).

**Attributes**

Fig. 9.1.13 "Attributes" tab from "Edit Person" - dialog - example

The **Attributes** tab lets you view and assign attributes to the person. You have complete freedom to define and use attributes. For example, attributes might be assigned to describe the person's physical characteristics or personality traits.

Note that each attribute listed in the **Attribute** dialog consists of two parts: the Attribute itself and a Value associated with that Attribute. This so-called "Parameter-Value" pairing can help you organize and systematize your research. For example, if you define "Hair color" as an Attribute for a person, "Hair Color" will become a selectable Attribute for all other people. The Value of Hair Color for person A might be red, and brown for person B. In similar fashion, you might define an Attribute like "Generosity" and use the Value of "Enormous" to describe a particularly generous person.

The bottom part of the dialog window displays the list of all Attributes stored in the database. The top part shows the details of the currently selected attribute in the list (if any). The buttons [+], [Edit], and [-] let you add, modify, and remove an attribute record from the database. Note that the **Edit** and - buttons become available only when an attribute is selected from the list.

If you edit an attribute the **Attribute Editor** opens.

---

**GEDCOM**

Several predefined attributes refer to values present in the GEDCOM standard. See: [Reading the GEDCOM report](#)

**Addresses**

Fig. 9.1.14 "Addresses" tab from "Edit Person" - dialog - example

The **Addresses** tab lets you view and record the various mailing addresses of the person. You are advised to use a residence event to store information of residency of a person. The address tab is offered mainly for compatibility with the GEDCOM standard where the rationale of addresses is mailing only.

The bottom part of the window lists addresses stored for that person in the database. The top part shows the details of the currently selected address in the list (if any). The buttons [+], [Edit], and [-] allow you to correspondingly add, modify, and remove an address record from the database. Note that the [Edit] and [-] buttons become available only when an address is selected from the list.

If you edit an address the **Address Editor** opens.

Some reports allow you to restrict data on living people. In particular, that option will omit their addresses.

---

**Notes**

---

Entering and editing data: detailed - part 1 - Editing information about people

107
The **Notes** tab provides a place to record various items about the person that do not fit neatly into other categories, as well as text excerpts you want to add to the family tree. You can share notes between different records in Gramps. The iconbar in this tabpage offers the usual buttons: create and add a new note, add an existing note, edit the selected note, remove the existing note, and reorder buttons to change the order of the notes.

If you edit a note, you obtain the **Note Editor**.

### Select Note selector

The **Select Note** selector dialog allows you to link to an already existing note.

The following columns are shown: Preview (default sort for list), ID, Type, Tags, Last Change.

You may use the **Find** button to filter the list based on one of the options from the drop down list:

- Preview contains (default)
- Preview does not contain
- ID contains
- ID does not contain
- Type contains
- Type does not contain
- Tags contains
- Tags does not contain
- Last Change contains
- Last Change does not contain

### Gallery

The **Gallery** tab lets you view and store photos, videos, and other media objects that are associated with the person. The central part of the window lists all such media objects. Any object in the form of a valid image file will result in the display of a thumbnail view of the image. For other objects such as audio files, movie files, etc., a corresponding file type icon is displayed instead.

The following options are available:

- ![+](image) - allows you to add a new media object from the **Media reference editor**.
- ![share](image) - brings up the **Select Media Object** selector dialog allowing you to link to an already existing media object.
- ![edit](image) - allows you to modify the select media object in the **Media reference editor**. This button only becomes available when a media object is selected from the list.
- ![remove](image) - remove the selected media object from the person's gallery. This button only becomes available when a media object is selected from the list.

You can change the order of the primary (active) image by selecting the image and dragging it to the first position.
If you select a media object a context menu (right-click) is available with the following options:

- View
- Open Containing_folder
- Make Active Media
- Add
- Share
- Edit
- Remove

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Removing a media object from a person's gallery does not remove it from the database. It only removes the reference to that object from this person's record.</td>
</tr>
</tbody>
</table>

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Select Media Object selector

![Select Media Object](image)

The *Select Media Object* selector dialog allows you to link to an already existing media object and once the image is selected it will be opened in the [Media reference editor](#) dialog.

Once you select a media object from the list a preview will be shown if possible in the top section.

The following columns are shown: Title (default sort for list), ID, Type, Last Change.

You may use the [Find](#) button to filter the list based on one of the options from the drop down list:

- Title Contains (default)
- Title does not contain
- ID contains
- ID does not contain
- Type contains
- Type does not contain
- Last Change contains
- Last Change does not contains

See also Select a media object selector

Internet

![Internet](image)

The *Internet* tab displays Internet addresses relevant to the person. A descriptive caption of the Internet location you are storing. Type of internet address as needed to navigate to it, eg. [http://gramps-project.org](http://gramps-project.org), E-mail, Web Page, ...

The bottom part lists all such Internet addresses and accompanying descriptions. The top part shows the details of the currently selected
addresses in the list (if any). The buttons [+ Create and add a new web address] (Edit the selected web address) opens the Internet Address Editor dialog to add or edit and the [-] removes the selected Internet address. The "Jump to" button opens your web browser and takes you directly to the highlighted page.

Note that the [Edit the selected web address] and [- Remove the existing web address] buttons become available only when an web address is selected from the list.

**Internet Address Editor**

![Internet Address Editor - Gramps](image)

The Internet Address Editor dialog allows you to add a new Internet address or modify selected Internet address.

- **Type**: Type of internet address:
  - E-mail
  - Unknown (default)
  - FTP
  - Web Home
  - Web Search

- [Record is public/private] toggle the privacy status of the record.

- **Web address**: The internet address as needed to navigate to it eg: [https://gramps-project.org](https://gramps-project.org)

- [Jump to] open the web address in the default browser

- **Description**: A descriptive caption of the Internet location you are storing.

See also:
- Link Editor
- Note Link Report

**Associations**

![Associations tab from "Edit Person" - dialog - example](image)

The Associations tab lets you view and edit relationship role information about two persons explicitly associated in the database.

The associations tend to be roles that cannot be inferred from being connected in normal (or blended) family structure or through shared event roles. For instance, cousin or sibling relationships are apparent through how marriages connect the people. Relationships such as Godparents (a participant in a Christening), an organ donor (participant in a medical procedure), pall bearer (participant in a Burial), and Guardian (participant in a Probate or mentioned in a will) may be Roles created by sharing an event created for the Primary role person.

So Association roles are less obvious. They might be family friends, an eponym (the person honored by a namesake), a coworker, a penpal, or any other type of associations you may wish to record. If the closest relation is 'Godparent', then this would indicate that the Godparent of the person (being edited) is the person whose name is shown in the Associations tab.

The Associates (ASSO) tag in the GEDCOM standard says that "a person's relation or association is the person being pointed to." You might choose to put a reciprocal Association in that other person's Associations tab.

In the association shown from example.gramps, Lewis Garner's Godfather is Anderson Garner. Use Events instead for relations connected to specific time frames or occasions. Events can be shared between people, each indicating their role in the event.

The button [+ Create and add a new association] opens the Person Reference Editor dialog to add. The [Edit the selected association] button allows you to edit and the [- Remove the existing association] removes the selected association. The other buttons [Move the selected association upwards] or [Move the selected association downwards] move the selected entry position in the list only.

See also:
- Roles, Relationships & Associations
- Add a godfather-godmother

---

**Entering and editing data: detailed - part 1 - Editing information about people** 110
The **Person Reference Editor** lets you add and edit Association entries. You can access it from the **Edit Person**'s dialog **Associations** tab.

- **Person:**
  - A **Select a person that has an association to the edited person** button brings up the **Select Person** selector dialog.
- **Association:**
  - **Godfather** (Default) you can over type the default entry with anything you choose.
  - **Privacy lock** record is public (Default)
- Source Citations tab
- Notes tab

**Select Person selector**

- **Select Person - Gramps**

**LDS**

The **LDS** (Latter Days Saints) tab lets you view and edit information about LDS ordinances of the person. This information is inherited from GEDCOM specification.

These are LDS Baptism, Endowment, and Sealed to Parents ordinances, as labeled inside the tab. Each ordinance is described by its date, LDS temple, and Place where it happened.

An additional pop-up menu, "Parents," is available for the Sealed to Parents ordinance. Each ordinance can be further described through the selections available in the Status pop-up menu. It can also be include notes and references to sources through the corresponding **Sources...** and **Note** buttons.

See: [Family Editor dialog > Tab > LDS](#)
Fig. 9.1.25 "LDS Ordinance Editor" - dialog - default

Use the Create and add a new LDS ordinance or Edit selected LDS ordinance buttons to bring up the LDS Ordinance Editor dialog where you can add or edit existing LDS ordinances of the person.

- See Ordinance (Latter Day Saints) on Wikipedia.

Fig. 9.1.26 "References" tab from "Edit Person" - dialog - example

The References tab

- See Ordinance (Latter Day Saints) on Wikipedia.

Editing information about relationships

Information about relationships is entered and edited through the Family Editor dialog.

This dialog may be invoked in a number of ways:

- From Relationships Category: click on an Edit button in the family that you want to edit.
- From Families Category: select the family in the list and then click the Edit button on the Toolbar, or double-click on the family.
- From Charts Category: point your mouse over the black line connecting the spouses, right-click and select Edit from the context menu, or double-click on the black line.

Any of these methods will prompt you with the Family Editor dialog.
Family Editor dialog

Fig. 9.1.27 Family Editor dialog

The top section of the window shows the names of the people whose relationship is being edited, as well as their birth and death information.

+ [Father/partner1]
+ [Mother/partner2]

Quick View reports are available by using the context menu (right clicking) from a blank area in the top section of the window.

The **Relationship Information** section displays three fields and a number of notebook tabs representing different categories of information about the relationship. Click any tab to view or edit the information it contains. The bottom part has OK and Cancel buttons. Clicking the OK button at any time will apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button at any time will close the window without applying any changes. If any of the data in any tab is modified, an alert window will appear that will prompt you choose between closing the dialog without saving changes, canceling the initial cancel request, or saving the changes.

The **Relationship Information** section fields have the basic description of the relationship. The **ID** field displays the ID number which labels this relationship in the database, leave this field empty to have Gramps generate a unique ID number. You can choose from the drop-down list the available types of family relationships such as Civil Union, Married, Unknown (default), Unmarried, etc.

See also:

- How do I represent a divorce?

**Tags:** displays shows the tags you have created to show some basic information on the status of your research. You can add additional tags by selecting the [Edit the tag list] button.

**Note**

Clicking OK will immediately save changes to the database. Gramps does not have a separate saving function, all changes are immediate.

Select Father selector

This article's content is incomplete or a placeholder stub.
Please update or expand this section.

Fig. 9.1.28 Select Father - selector

The **Select Father** selector dialog allows you to link to an already existing Father.

Select Mother selector

This article's content is incomplete or a placeholder stub.
Please update or expand this section.
The Select Mother selector dialog allows you to link to an already existing Mother.

**Family Editor tab pages**

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>If a tab label is in <strong>boldface</strong> type, this means it contains data. If not, it has no data.</td>
</tr>
</tbody>
</table>

The tabs provide the following information categories of relationship data:

**Children**

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Removing a child from the list does not delete that child from the database. It only removes the child from this relationship.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use arrows (up/down) or <em>drag and drop</em> for setting children order into the family.</td>
</tr>
</tbody>
</table>

**How do I change the order of children? Use:**

- This Children tab in the Family Editor to change the order of children in the family.
- The third party addon **Birth Order Tool** which allows bulk updates of the children order.

**Select Child selector**

[Image of Select Child selector]
The **Select Child** selector dialog allows you to link to an already existing child and once selected will be opened in the **Child Reference Editor**.

The following columns are shown: Name (default sort for list), ID, Gender, Birth Date, Birth Place, Death Date, Death Place, Spouse, Last Change.

Children Reference Editor

![Child Reference Editor](image)

Fig. 9.1.32 Child reference editor

The **Child Reference Editor** dialog allows editing of the relationship between the selected child and the parents in a Family. The dialog appears when initially committing a Person as offspring in a Family. The final step of using the ![Share button](image) button or using "drag and drop" to add someone to the family is to confirm the relationship.

The Relationships may also be edited for existing children of shown in the Edit Family dialog. Double-clicking on an existing child in a Family or selecting the **Edit relationships** context menu item will open the Child Reference Editor for the selected child. (Selecting the **Edit child** context menu item will open the Edit Person dialog instead.)

While a Person will only have a Birth relationship to both parents in a traditional Birth family, they might also be part of multiple blended families. In those families, a birth parent re-marries and the other spouse can have a more complex relationship with the children of a previous marriage. But it they are part of the household, those children should be added to the new Family with the appropriate relationship.

The following options are available:

- **Name Child**: The name of the child
  - ![Open person editor of this child button](image)
- **Relationship to the Father**: Select from the drop down list of possible relationship types:
  - Adopted
  - Birth (default)
  - Foster
  - None
  - Sponsored
  - Stepchild
  - Unknown
- **Relationship to the Mother**: Select from the drop down list of possible relationship types:
  - Adopted
  - Birth (default)
  - Foster
  - None
  - Sponsored
  - Stepchild
  - Unknown
- **Record is Public/Private** privacy toggle for this relationship.

Also the following tabs are available.

**Source Citations** tab

**Notes** tab

**Events**

The **Events** tab lets you view and edit the list of events relevant to the relationship. The buttons ![Add](image), ![Edit](image), and ![Remove](image) let you add, modify, or remove an event record from the database. Note that the ![Edit](image) and ![Remove](image) buttons become available only when an event is selected from the list.
Note

Removing an event from the list does not delete that event from the database. It simply removes the event reference from this relationship.

Source Citations

The Source Citations tab lets you view and edit a list of references to the sources that provide evidence for the relationship. These might be documents that refer to the relationship, but which do not necessarily document it officially. For example, if Aunt Martha's memoirs mention that her great-grandson Paul was married, the researcher may take this as evidence of the relationship between Paul and his wife existed and cite the memoirs as the source for this assumption.

Tip

Sources that document specific events such as marriages or divorces are better filed in relation to those events, under the Events tab.

The buttons [+], [Edit], and [-] allow you to add, modify, and remove a source reference to this relationship. Note that the [Edit] and [-] buttons become available only when a source reference is selected from the list.

Note

Removing an entry from the list does not delete that source from the database. It simply removes the source reference from this relationship.

Attributes

The Attributes tab lets you view and edit particular information about the relationship that can be expressed as attributes. The buttons [+], [Edit], and [-] let you add, modify, or remove an attribute. Note that the [Edit] and [-] buttons become available only when an attribute is selected from the list.

Notes

The Notes tab lets you view and edit any Note associated with the relationship. These could be any comments which do not naturally fit into the "Parameter-Value" pairs available to Attributes. To add a note or modify existing notes simply edit the text in the text entry field.

The Format option lets you set the way the note will appear in reports and web pages. If you select Flowed, the text generated will have single spaces put in place of all multiple spaces, tabs, and single end-of-line characters. A blank line inserted between two blocks of text will signal a new paragraph; additional inserted lines will be ignored.

If you select the Preformatted option, the text in reports and web pages will appear exactly as you enter it in the Notes dialog.

Gallery

The Gallery tab lets you store and display photos and other media objects associated with the relationship. The central part of the window lists all such objects and gives you a thumbnail preview of image files. Other objects such as audio files, movie files, etc., are represented by a generic Gramps icon. The buttons [+], [Select], [Edit], and [-] let you add a new image, add a reference to an existing image, modify an existing image, and remove a media object's link to the relationship. Note that the [Edit] and [-] buttons become available only when a media object is selected from the list.

LDS
Fig. 9.1.33 Sealed to Spouse ordinance editor of "Edit Family" - dialog - example

The LDS (Latter Days Saints) tab of the Family Editor only displays information about the LDS Sealed to Spouse Ordinance. (The ordinances related to individuals can be recorded in LDS tab of the Person Editor.)

The data can also include LDS temple, Status, date, and Place.

Each ordinance record can also be annotated in the corresponding Sources and Note tabs. The status of the ordinance can be described through the options available in the Status pop-up menu.

The status states for the Sealed to Spouse ordinance are:

- <No Status> (default)
- Canceled
- Cleared
- Completed
- Do not seal
- Pre-1970
- Qualified
- Do not seal/Cancel
- Submitted
- Uncleared

To edit Source or Note annotation data, switch to the corresponding LDS Ordination Editor tab and select the desired entry in the list of records. Double-click that entry or click the Edit icon on the toolbar to invoke the following Source Editor dialog:

The main part of the Family Editor’s LDS tab displays a table of the five different kids of data in a each record. Click a column header to row or double-click a row to edit its contents. The bottom part of the window has OK and Cancel buttons. Clicking OK will apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button will close the window without applying any changes.

Note

Clicking OK will immediately commit changes to the database (write on disk). All changes are immediate.

Tip

If a tab label is in boldface type and has an icon to the left of the label, this means it contains data records. If not, that tab has no data of that kind records.

Editing dates

This section describes how to enter and modify dates. Since dates are so important in genealogical research, Gramps takes special care to preserve and use any date information available.

Information can be entered into a date field by directly typing it or by invoking the Date selection dialog by clicking the Date editor button next to any Date entry field.

See also:
- Gramps 5.1 Wiki Manual - Probably Alive
- Menu -> Edit -> Preferences -> Dates - To change the default values for the typical ages at birth, between generations, etc.

Date selection dialog
While the above parsing rules provide a guide for you to type in most common dates, you can also use the **Date selection** dialog. The dialog is particularly useful for building a complex date or for simply insuring that your information is entered in a way Gramps will understand.

- **Calendar**: Choose alternate calendar type.
  - Gregorian (default)
  - Julian (including Mixed/Dual dates)
  - Hebrew
  - French Republican
  - Persian
  - Islamic
  - Swedish
- **Dual dated**: This field is select-able with the matching **New Year begins** field if the alternate **Calendar** supports dual dating. (checkbox unchecked by default)
- **New Year begins**: (Empty text field by default)
- **Quality**: Set the date quality.
  - Regular (default)
  - Estimated
  - Calculated
- **Type**: Set the interval precision or time frame date type.
  - Regular (default) - the interval spanning a specific day, month or year (without regard to time zone)
  - Before
  - After
  - About
  - Range
  - Span
  - Text only
- **Date**: Select the **Year**, **Month**, and the **Day**.
- **Second date**: If your date **Type** is Range or Span, this option will be available to set a date.
- **Text comment**: text entry field allows storing an arbitrary text string along with the date.

**Important comment about a date**

If you have an important annotation regarding a date, it is better to do so in a Note or the Description that corresponds to the event, instead of in the Text comment field of the **Date selection** dialog. This is recommended for the following reason: If you enter a date by typing it directly into the date field (that is, not via the **Date selector** dialog), your entry will be copied and stored as the text comment string when Gramps parses the entered text. Thus, any comment that may have been there prior to the parsing will be overwritten.

**Date validity indicators**

Gramps uses a date validator.
While partial dates do not uniquely define the day, they allow at least for some type of comparisons between the dates.

The date field will highlight in red and display a red symbol (such as a stop sign or cross) to indicate the entered date is not recognized as a valid and recognized format for a date.

Examples of common date references that are not recognizable Gramps formats might be "Christmas week of’61", "Fall 1782", or "the summer when I had surgery". In such a case, the date will be stored as string and marked as Text only type. Any dates of this Type will not be compared to other dates. Wherever possible, it is preferable to avoid such Text Only date entries. It might be better, for example, to enter a date of "December 1961" and then to add the Description annotation "Christmas week of’61." It would be more precise to check a calendar for December 1961 then key in the actual date span... but still include the annotation. The annotation is needed because you cannot assume that 'Christmas week' means the same span of days to you as to your source. There could be culture bias to color the interpretation. It could mean the calendar row containing Christmas day. But American & European calendar rows start on different days of the week. Or, it could mean the 7 days starting with Christmas or even the 7 days leading up to Christmas. So the span allows searches and comparisons but the annotation shows that actual interval is subject to interpretation.

In the various views (such as the Person View), unrecognized dates will be displayed in bold by default. The text markup (formatting style) for unrecognized dates can be modified by changing the Markup for invalid date formats option in the Dates tab of Preferences.

When a Birth or Death date is missing for a Person, the dates of existing fallback Events in the same category may be shown (and indicated with italics with an abbreviated title) rather leaving the display blank. So, a Burial or Cremation date will be shown if a Death date has not yet been recorded.

Date Quality

- Regular: A "regular" date is one with an explicit day, month, or year.
- Estimated: An "estimated" date is one based on average interval assumptions offset from a known reference date. (Such as the average number of years between generations, maximum lifespan, or length of sea voyage.)
- Calculated: A "calculated" date is one based on a known interval from a reference date but without a source explicitly mentioning the date. (Such as a gravestone engraved with both a date of death and a precise age at death.)

Census data is unusual in that it seems to a candidate for a Calculated date but is not. The census often explicitly defines the interval (age) and the reference date (census polling date) but that age is often estimated or rounded.

Date Type

To the right of the Quality should appear the Type pop-up menu.

Dates in Gramps are classified according to the following types of precision (scale) of interval or time frame:

- Regular: A "regular" date is one which includes an interval spanning a specific day, month, or year. It can be complete (or 'fully qualified' for a 24 hour interval like June 6, 1990) or partial (like omitting the day for a 1 month interval like July 1977 or omitting the day and month for a 1 year interval).
- Before: A "before" date is one that can only be identified as occurring (in a preferences-defined long interval) prior to a certain day, month, or year. (By default, the interval is 50 years.)
- After: An "after" date is one that occurs (in a 2nd preferences-defined long interval) following a certain day, month, or year. (By default, the interval is 50 years.)
- About: An "about" (circa) date is one that occurs (in yet another preferences-defined +years interval) before or after a certain day, month, or year. (By default, the interval is ±50 years.)
- Range: A "range" describes a time period during in which the event occurred. It could be recurrent event during the interval or a single instance believed to have occurred between known boundary dates.
- For example, "between January 1932 and March 1932."
- Span: A "span" describes an inclusive time period during which a condition continually existed.
- For example, "from May 12, 2000 to February 2, 2002."

Date formats and parsing rules

The Date Selection dialog just helps layout a date in the standard format that Gramps knows how to parse. It is useful while you're unfamiliar with the options, need to use an alternative calendar or specify a New Year begins date.

Gramps recognizes dates entered in a variety of formats. The default numeric format is that which is conventional for the environment is which Gramps is operating; that is, DD.MM.YYYY for most European countries, MM/DD/YYYY for the U.S., and so on. A way to avoid this ambiguity is to always choose a d mmmnbsp;yyyy or mmmnbsp;d yyyy format.

Besides exact dates, Gramps recognizes many date types that are not regular: before, after, about, ranges and spans. It also understands the quality: estimated or calculated. Finally, it supports partial dates and many alternative calendars. Below is the list of date entry rules to allow precise date parsing.
Regular single dates can be entered just as you would write them. And typing a slash after the year followed by a value 1 year later creates a Julian dual dated entry.


Partial dates are entered simply by omitting unknown information.


Dates that are not Regular should start with the keywords of Estimated or Calculated, if applicable.

Example: est. 1961, or calc 2005. (Note that a quality does not need to be specified for regular dates.)

The menu options can also be set to Before, After, or About by simply typing "before", "after" or "about" before a single date in the Event Editing dialog.

If the desired is a range, write "between DATE and DATE", and if the is a span, write "from DATE to DATE".


Here are a couple examples to try:

Captain John Smith has been stationed in the 1st Grenadier regiment between 1888-5-13 and 1902-10-24 according to his military record (words "between" and "and" intentionally used as this is the way we talk in day-to-day life); Then date should be coded "from … to …" because this is the duration of his duty.

Captain John Smith's regiment was posted to the Escaut river at Valenciennes the week before the Armistice. Then this can be recorded as a "Military Service" Event type with a date of "between Nov 4 1918 and 11 Nov 1918" (Gramps will convert to a standard date format despite 2 formats being used for entry) at River Escaut, Valenciennes, Noord department, France... because the actual date for this "instantaneous" event is not known in the source.

Calendars

Alternate calendars are calendars other than the Gregorian calendar. Currently, Gramps supports Hebrew, French Republican, Julian, Islamic, Persian, and Swedish alternate calendars. To specify the calendar other than the default Gregorian, append the name of the calendar to the date string, e.g. "January 9, 1905 (julian)" or use the drop down menu.

Swedish calendar

The Swedish king, Karl XII, decided that Sweden should start using the Gregorian calendar. However, it was planned to take place gradually by skipping 11 leap days starting 1700-02-29 and end by 1744. So 1700-02-28 was followed by 1700-03-01. This took place during the Great Nordic War and the leap days were kept 1704 and 1708. In January 1711 the same king decided that Sweden should return to the Julian Calendar by 1712-03-01. In order to be in phase, an extra day was inserted on 1712-02-30. And that was the end of the Swedish Calendar. Sweden converted to Gregorian in 1753-03-01, by skipping dates between 1752-02-18 and 1753-02-28. In Gramps you can only enter valid dates for the Swedish Calendar from 1700-03-01 to 1712-02-30. All other dates are flagged as not valid and has to be corrected.

Dual-dated dates

Dual-dated dates (also called "double dating", "slash dates", and sometimes "Old Style/New Style" dates) appear like "Jan 23, 1735/6". Often mistaken as a year uncertainty, this actually has a specific historic meaning. The dual dated date represents a time when an area was in a transition between moving to January 1 as the beginning of the new year. Thus Jan 23, 1735/6 is an indication to make it clear what date is being referred to. In this example, "Jan 23, 1736" might have occurred after "Jun 23, 1736".

England and the American colonies didn't officially accept the "Jan 1" as the new year date until 1752. Before 1752, the English government still officially observed March 25 as the first of the year, whereas most of the English population observed January 1 as the first of the year. Many people therefore wrote dates falling between January 1 and March 25 in the dual-dated format.

Sometimes, a dual date may appear as a fraction, as in this grave stone (170 and 3/4, which means 1703 and 1704):

Fig. 9.1.36 Gravestone showing dual date as a fraction
Marking a date as dual dated can be done by simply putting a slash between the years. For example:

- 1721/2
- 1719/20
- 1799/800

These slash-years can appear anywhere in a date that a regular year can appear.

Dual-dated dates are currently represented in the Julian calendar so their month and day will be the same as that in the textual representation.

Alternate new year day

With dual-dated dates (and other dates) you may know that the new year was celebrated on a day other than January 1. To indicate this in Gramps, put the month/day code in parentheses, after the calendar (if one). For example:

- Jan 20, 1865 (Mar25)
- Jan 20, 1750 (Julian,Mar1)
- Feb 23, 1710/1 (Mar25)

To indicate the beginning of a year that is different from that of January 1, you use the following codes:

- Jan1
- Mar1
- Mar25
- Sep1

You can put that as the only item in parenthesis, or right after a calendar name (comma, and no space).

Note that if new year's day is not Jan 1, then January will come after December that year. Dates with new year day codes will be sorted appropriately.
The previous section offered you a detailed overview of how to enter and edit data for people, relationships and dates. This section continues with other objects you encounter in Gramps.

**Editing information about events**

Adding an Event to a person allows you to record information you have found.

When adding an event to the *Events Category*, the *New Event* dialog appears.

To add or edit event data, switch to the *Event Category View* and select the desired entry in the list of events. Double-click on that entry or click *Edit* on the toolbar to invoke the following *New Event* dialog.

**New Event dialog**

Events are edited through the *Event Editor* dialog. This dialog can be accessed by: double-clicking a row in the Event category view, or in the *Events* tab of the *Edit Person* dialog, or the *Events_2* tab of the *Family Editor* dialog.

The top part lets you view and edit basic information about the event:

- **Event type**: can be selected from the available types listed in the Event type drop-down menu. e.g., *Birth* (default), Baptism, Death, Burial, etc. Gramps.
- You can enter your own Event *Custom Types* by typing directly into this entry field.
- **Date**: of the event can be an exact date, a range (*from ... to ..., between ...*), or an inexact date (*about ...*).
- *Invoke date editor* button starts the *Date selection* dialog.
- **Description**: field gives you the opportunity to give a longer description what this event is.
- *Record is Public* - Toggle the Privacy lock to mark the event record as private which allows it to be omitted from reports.
- **Place**: can be selected from a list of previously entered place using the *Select an existing place* button or entered anew using the *Add a new place* button. Additionally, you can drag and drop a place entry into this field.
- **ID**: is a unique identifier for the event. Leave this field blank to allow Gramps to generate this value automatically for new events.
- **Tags**: allow you to select an existing tag using the *Edit the tag list* button.

**New Event tab pages**

The central part of the window displays tabs containing different categories of information. Click on a tab to view or edit its contents. The tabs
provide the following information categories of the event data:

**Source Citations**

The **Source Citations** tab lets you view and edit sources relevant to an event. The central part of the window lists all such source references stored in the database. The buttons **[ + ]**, **[Edit]**, and **[ - ]** let you add, modify, and remove a source reference associated with an event. Note that the **[Edit]** and **[ - ]** buttons become available only when a source reference is selected from the list.

**Notes**

The **Notes** tab provides a place to record notes or comments about the event. To add a note or modify existing notes simply edit the text in the text entry field.

**Gallery**

The **Gallery** tab

**Attributes**

The **Attributes** tab

**References**

The **References** tab

The bottom part of the window has **[OK]** and **[Cancel]** buttons. Clicking **[OK]** will apply all the changes made in all tabs and close the dialog window. Clicking the **[Cancel]** button will close the window without applying any changes. Pressing **[Help]** will provide help if available.

**Tip**

If a tab label is in **boldface** type, this means it contains data. If not, it has no data.

**Editing event references**

Event references connect a Event to a person and allow you to provide additional information about the event.

When adding event references to a **Edit Person's Events** tab, the **Event Reference Editor** dialog appears.

**Event Reference Editor dialog**

<table>
<thead>
<tr>
<th><strong>Reference versus Shared Information Tip</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>References Information</strong> in the top of this dialog is specific to the particular reference from a Primary Object. A single object (such as an Event) can be referenced many times, and all such references will have in common the Shared Information.</td>
</tr>
</tbody>
</table>

This expanded object editor dialog lets you provide both the reference-specific data (such as relevant role), attribute to further specify and document the reference.

Accessing the reference object editor.
The New Citation dialog includes two sections, Reference Information and Shared Information.

- The Reference Information section indicates the details associated with the particular reference to this Event: General, Notes, Attributes.
- The Shared Information displays: General, Source Citations, Attributes, Notes, Gallery, References.

Reference Information

Reference Information tab pages

General

For the Role of the person in this event, use the Primary (default during an Add Event) option for the main beneficiary. Use a descriptive Event Role (e.g., Aide, Bride, Celebrant, Clergy, Family, Groom, Informant, Witness) for a Events where the Person is not the Primary participant.

Events added to a Person via the Share or by drag'n'drop will be assigned the Unknown Event Role by default. If the Person holds an equal Role, set their Role to Primary as well.

If none of the pre-defined Roles are appropriate, add a Role Custom Types by keyboarding in the new Role name rather than selecting one from among those of the Role Pull-Down menu. Any added Role custom types will remain available in that expanded menu... unless the Tree is exported & re-imported or cleaned via a 3rd party addon Utility like Type Cleanup.

Notes

Attributes

Shared Information

Note

Any changes in the shared event information will be reflected in the event itself, for all participants in the event.
Editing information about media objects

To add or edit media data, switch to the Media Category View and select the desired entry in the list of media. Double-click on that entry or click [Edit] on the toolbar to invoke the following New Media editor dialog.

New Media dialog

Fig. 9.2.4 New Media Editor - dialog - example showing Media properties

The top section presents a thumbnail preview of the media object if available, along with a summary of its properties (ID, Date, Path and object type) that you can view and edit. You can type this information directly into the corresponding fields. For the Date, you can also enter information by clicking the [Invoke date editor] button to invoke the [Date selection] dialog.

- A descriptive Title: for this media object.
- The ID: is an unique record to identify the media object, leave blank to have it generated by Gramps.
- Privacy toggle for this media object [Record is public] (default) or [Record is private]
- A date associated with the media object eg: for a picture it could be the date it was taken.
- [Invoke date editor] button to invoke the [Date selection] dialog.
- Path: of the media object on your computer. Gramps does not store the media internally, it only stores the path! Set the Relative Path in the Preferences > General tab's Base path for relative media paths: entry to avoid retyping the common base directory where all your media is stored. The Media Manager tool can help managing paths of a collection of media objects.
- [Open File Browser to select a media file on your computer] button.
- [Edit the Tag list] button.

The bottom section of the window displays four notebook tabs containing different categories of information. Click a tab to view or edit its contents. The bottom part of the window has [Help], [Cancel] and [OK] buttons. Clicking [OK] will apply all the changes made in all tabs and close the dialog window. Clicking the [Cancel] button will close the window without applying any changes. Pressing the [Help] button will bring you here.

**Note**

Every media object is referred to by its Path. The user is responsible for keeping track of the object files. Gramps will only reference and display the contents, not manage the files themselves.
New Media tab pages

Tip

If a tab label is in **boldface** type, this means it contains data. If not, it has no data.

The tabs represent the following categories of media data:

**Source Citations**

The **Attributes** tab lets you view and edit particular information about the media object that can be expressed as Attributes. The bottom part displays the list of all such attributes stored in the database. The top part shows the details of the currently selected attribute in the list (if any). The buttons +, **Edit**, and - let you add, modify, or remove an attribute. Note that the **Edit** and - buttons become available only when an attribute is selected from the list.

**Notes**

The **Notes** tab provides a place to record various information about the source that does not fit neatly into other categories. This area is particularly useful for recording information that does not naturally fit into the "Parameter/Value" pairs available to Attributes. To add a note or modify existing notes simply edit the text in the text entry field.

**References**

The **References** tab indicates any database records that refer to a given media object. The list can be ordered according to any of its column headings: **Type**, ID, or **Name**. Double-clicking an entry allows you to view and edit the corresponding record.

Only primary objects can be shown in the **References** tab: Person, Family, Event, Source, or Place. The secondary objects such as Names and Attributes, although able to refer the media object, will only show up through their primary objects to which they belong.

Editing media object references

When Media Object references connect a Media Object to an other object on a **Edit Person's Gallery** tab, the **Share** button will bring up the **Select Media Object selector** and once you select a Media Object the **Media Reference Editor** dialog appears.

Select a media object selector
The *Select a media object* file selector allow you to preview and select a media file you want to attach, and at the same time you may edit the shown *Title*: (Defaults to the filename without the file extension).

- Convert to a relative path (checkbox unchecked by default until checked for the first time and remembered for each subsequent image selection.)

- See also: Select Media Object selector

**Media Reference Editor dialog**

The *Media Reference Editor* dialog.

See also How to create image reference regions

This article's content is incomplete or a placeholder stub.
Please update or expand this section.
Fig. 9.2.7 Media Reference Editor - dialog - "Shared Information" section expanded example

You may also expand the **Shared Information** section.

---

**Top section**

---

**Top section tab pages**

**General**

- Region corners: x1, x2, y1, y2.

The **region** part allows to select a specific region on the Media Object. You can use the mouse cursor on the picture to select a region, or use these spinbuttons to set the top left, and bottom right corner of the referenced region. Point (0,0) is the top left corner of the picture, and (100,100) the bottom right corner.

- Privacy

The **Privacy** button lets you mark whether or not the record is considered private. Check the **Private** record box to mark this record as **private**.

See also the **Narrated Web Site** Gallery tab supports output of these referenced regions.

---

**Source Citations**

---

**Attributes**
Editing information about places

To edit information about places, switch to the **Places** Category and select the desired entry from the list of places. Double-click that entry or click the **Edit** button on the toolbar to bring up the **Place Editor** dialog:

The following fields are available:

- **Title area at top** displays the description of this place to be used in reports. Gramps will construct this for you. See [Preferences > Display](#) > Enable automatic place title generation
- **Name**: the name of this place.
  - **Invoke place name editor** button opens the **Place Name Editor** dialog where you can add/edit additional information.
- **Type**: the place type. All [Custom Types](#) are shown at the bottom of the list. Choose from the following default available **Types**:
  - Building
  - Borough
  - Country
  - County
  - City
  - Department
  - District
  - Farm
Place editor tab pages

Tip

If a tab label is in boldface type and displays an icon, this means it contains data. If not, it has no data.

The tabs represent the following categories of place data:

Enclosed By

Places in Gramps are stored in a hierarchy. The Enclosed By tab allows you to link this place to other places, higher in the hierarchy, which enclose it. Each link consists of a place and an optional date range.

To enclose with an existing place, use the Share button to choose a Place from the Place Selector. Alternately, drag a place (from the Clipboard, Places Category view, or an Event Editor) into bottom of the Enclosed By tab.

Editing a hierarchy of Enclosing Places spawns a hierarchy of dialogs

Sharing, adding or Editing an enclosure spawns an additional Place Editor dialog. It looks just like the parent dialog but is focused on the enclosing Place. This allows further qualification of that place's enclosing characteristics. e.g., the enclosure date range -- for shifting borders.

The buttons add, edit, and remove let you add a new Place as an enclosing hierarchical level, modify the selected enclosing Place, and remove a selected link to an enclosing Place.

Note that the Edit and Remove and re-ordering (up, down) buttons become available only when a link exists and is selected from the list. In general, a country will be a top level place, and will not be linked to any other place.

See also:

- Enclosed By Gramplet
- Using the clipboard

Select Place selector
The `Select Place` selector dialog allows you to link to an already existing place and一旦 selected it will be opened in the `Place Reference Editor`.

You may use the `Find` button to filter the list based on one of the options from the drop down list:

- **Name contains** (default)

The second part of the window displays seven notebook tabs containing different categories of information. Click a tab to view or edit its contents. The bottom part of the window has `OK` and `Cancel` buttons. Clicking `OK` will apply all the changes made in all tabs and close the dialog window. Clicking the `Cancel` button will close the window without applying any changes.

**Note**

Clicking `OK` will immediately save changes to the database. All changes are immediate.

**Alternative Names**

The `Alternative Names` tab lets you view and edit other names by which the place might be known. The tab lists all other names of the place stored in the database. The buttons `+`, `Edit`, and `-` let you add, modify, and remove a name record. Note that the `Edit` and `-` buttons become available only when a name is selected from the list.
Note

Seeing a question mark means that you may have a problem in the naming variants of that place. There may be some places which have different names for the same date range and language. Overlapping date ranges are valid. The place displayer will use the first matching name.

Source Citations

The Source Citations tab lets you view and edit sources relevant to a place. The central part of the window lists all such source references stored in the database. The buttons [ ], [ Edit ], and [ ] let you add, modify, and remove a source reference associated with a place. Note that the [ Edit ] and [ ] buttons become available only when a source reference is selected from the list.

Notes

The Notes tab displays any comments or notes concerning the place. To add a note or modify existing notes simply edit the text in the text entry field.

Gallery

The Gallery tab lets you store and display photos and other media objects associated with a given place. The central part of the window lists all such media objects and gives you a thumbnail preview of image files. Other objects such as audio files, movie files, etc., are represented by a generic Gramps icon. The buttons [ ], [ Select ], [ Edit ], and [ ] let you add a new image, add a reference to an existing image, modify an existing image, and remove a media object's link to the place. Note that the [ Edit ] and [ ] buttons become available only when a media object is selected from the list.

Internet

The Internet tab contains Internet addresses relevant to the place. The bottom part of the window lists all such Internet addresses stored in the database. The top part shows the details of the currently selected address in the list (if any). The buttons [ ], [ Edit ], and [ Go ] let you add, modify, and remove an Internet address. The [ Go ] button (represented by an icon with a green arrow and yellow circle) opens your browser and takes you to the web page corresponding to the highlighted Internet address. Note that the [ Edit ], [ ], and [ Go ] buttons become available only when an address is selected from the list.

References

The References tab indicates any database records (events or LDS ordinances) that refer to a place. This information cannot be modified from the Place Editor dialog. Instead, the corresponding database record (e.g., a birth event) has to be brought up and its place reference edited.

Place Name Editor dialog

![Place Name Editor - Gramps](image)

You can access the Place Name Editor dialog from the Place Editor dialogs [Invoke place name editor] button.

The Place Name Editor dialog allows you to add/edit the following information:

- **Name**: the name of the place
- **Date**: Date range in which the place is valid
  - [Invoke the date editor] button
- **Language**: Language in which the name is written. Valid values are two character ISO codes for example: en, fr, de, nl. See Wikipedia for the full list of valid ISO 639-1 codes.

Supported longitude/latitude formats

When you create/modify a place, the possible formats used for longitude/latitude are:

**Longitude & Latitude Formats**

Entering and editing data: detailed - part 2 - Editing information about places
degree notation, 4 decimals

D.D4
eg +12.0154 , -124.3647

4 decimals of longitude precision allows an 11.132 meter (36.5223097 foot) approximation at the equator.

degree notation, 8 decimals (precision like ISO-DMS)

D.D8
eg +12.01543265 , -124.36473268

degree, minutes, seconds notation

eg 50°52'21.92"N , 124°52'21.92"E (° symbol has UTF-8 code c2b00a)
or N50°52'21.92", E124°52'21.92" (° symbol has UTF-8 code c2ba0a)
The character for seconds can be either one double quote " or two single quote ‘
The letters N/S/W/E can be placed before or after the digits.

degree, minutes, seconds notation with :

DEG-

ISO 6709 degree notation

ISO-D
i.e. ±DD.DDDD±DDD.DDDD

ISO 6709 degree, minutes notation

ISO-DM
i.e. ±DDMM.MMM±DDDMM.MMM

ISO 6709 degree, minutes, seconds notation

ISO-DMS
i.e. ±DDMMSS.SS±DDDMMSS.SS

Editing information about sources

From either of the Sources category views you can select or create a new source, or if you had chosen the or buttons, then the New Source editor dialog appears.

New Source dialog

For the New Source editor dialog the general information in the top section of the window lets you define basic information about the source: its Title, Author, Abbreviation, and Publication information. You can type this information directly into the adjacent fields.

- Title: Title of the source.
- Authors: Authors of the source.
- Pub. info.: Publication Information, such as city and year of publication, name of publisher, ...
- Abbreviation: Provide a short title used for sorting, filing, and retrieving source records.
- Record is public/private: Lock icon toggle.
- ID: an unique record to identify the source. Leave generated by Gramps.
- Tags: Edit the tag list

New Source tab pages

The tabs provide the following information categories of source data:

Notes
The **Notes** tab provides a place to record notes or comments about the source. To add a note or modify existing notes simply edit the text in the text entry field. Only primary objects can be shown in the **References** tab: Person, Family, Event, Place, or Media object. Secondary objects such as Names and Attributes can only be accessed through the primary objects to which they belong.

**Gallery**

The **Gallery** tab lets you store and display photos and other media objects associated with a given source (for example, a photo of a birth certificate). The central part of the window lists all such objects and gives you a thumbnail preview of image files. Other objects such as audio files, movie files, etc., are represented by a generic Gramps icon. The buttons [+] (select), [edit], and [-] let you add a new image, add a reference to an existing image, modify an existing image, and remove a media object's link to the relationship. Note that the [edit] and [delete] buttons become available only when a media object is selected from the list.

**Attributes**

The **Attributes** tab displays "Key/Value" pairs that may be associated with the source. These are similar to the "Attributes" used for other types of Gramps records. The difference between these Key/Value pairs and Attributes is that Attributes may have source references and notes, while Key/Value data may not.

The central part of the window lists all existing Key/Value pairs. The buttons [+] and [-] let you add and remove pairs. To modify the text of Key or Value, first select the desired entry. Then click in either the Key or Value cell of that entry and type your text. When you are done, click outside the cell to exit editing mode.

**Repositories**

![Repositories Tab](image)

The **Repositories** tab displays the references to the repositories in which the source is contained. The list can be ordered by any of its column headings: ID, Title, Call Number, and Type. Double-clicking an entry allows you to view and edit the record. You may also edit the reference. The buttons on the side of the tab allow you to add a new repository, link to (or share) an existing repository, edit the reference to the repository, or remove the reference.

![Select Repository Dialog](image)

The **Select Repository** selector dialog allows you to link to an already existing repositories and once selected it will be opened in the

You may use the **Find** button to filter the list based on one of the options from the drop down list:

- **Title contains** (default)
- **Title not contain**
- **ID contains**
- **ID does not contain**
- **Last Change contains**
- **Last Change does not contain**
References

The References tab lists all the database records that refer to this source, if any. The list can be ordered by any of its column headings: Type, ID, or Name. Double-clicking an entry allows you to view and edit the record.

Editing source citations

Citations connect a Source to another object and allow you to provide additional information about the source. Citations can be attached to a large number of objects,

- People and various information about people (such as their name, address etc),
- Relationships (Families) and various information about relationships,
- Events and various information about events,
- Media objects and attributes of media objects,
- Places and various information about places,
- Addresses of repositories.

For each object, a common set of buttons are provided:

- + (Create and add a new citation and a new source). This brings up an empty Citation dialog.
- * (Add an existing citation or source). This brings up the Source or Citation selection dialog box.
- Edit (Edit the selected citation). This brings up the Citation dialog pre-populated with the Citation and source information.
- - (Remove the existing citation). This removes the citation from the object. It does not delete the citation itself, which could then be connected to another object.

Note that the Edit and - buttons become available only when a citation has been selected.

Select Source or Citation selector

![Select Source or Citation selector](image)

Fig. 9.2.16 Select Source or Citation - Selector Dialog - example

When * Add adding an existing citation or source, the Select Source or Citation dialog appears

This allows either an existing source or an existing citation (along with its associated source) to be selected. Click on the disclosure triangle alongside a source to see the citations associated with that source. For example, if one of your sources were a book, then the citations would normally refer to a page (or pages) within the book. If you already have a citation that refer to the particular page of the book, then you could select that citation which would then be shared. On the other hand, if this object needs to refer to a new page, then you would select the source and in the subsequent dialog enter the new page.

You may use the Find button to filter the list based on one of the options from the drop down list:

- Source: Title or Citation: Volume/Page contains (default)
- Source: Title or Citation: Volume/Page does not contain
- ID contains
- ID does not contain
- Last Change contains
- Last Change does not contain

New Citation dialog
Once you have selected a citation or a source, or if you had chosen the + or Edit buttons, then the New Citation dialog appears.

The New Citation dialog includes one section called Citation information.

Citation information

The Citation information section indicates the details associated with the particular reference to this Source: [Confidence].

- **Date**: Date associated with this source reference. Typically used to store the date that the data was entered into the original source document (not the date when the event occurred).
- **ID**: Specific location within the information referenced. For a published work, this could include the volume of a multi-volume work and the page number(s). For a periodical, it could include volume, issue, and page numbers. For a newspaper, it could include a column number and page number. For an unpublished source, this could be a sheet number, page number, frame number, etc. A census record might have a line number or dwelling and family numbers in addition to the page number.
- **Confidence**: Conveys the submitter's quantitative evaluation of the credibility of a piece of information, based upon its supporting evidence. It is not intended to eliminate the receiver's need to evaluate the evidence for themselves.
  - Very Low = Unreliable evidence or estimated data.
  - Low = Questionable reliability of evidence (interviews, census, oral genealogies, or potential for bias for example, an autobiography).
  - Normal = ?
  - High = Secondary evidence, data officially recorded sometime after event.
  - Very High = Direct and primary evidence used, or by dominance of the evidence.

A warning icon is displayed if the citation is shared.

**Tip**

Information in a citation may be shared. A single citation can be referenced many times and all such references will have in common the overall citation information. Changing the citation information will change it for all of the shared uses.
The **Select Source** selector dialog allows you to link to an already existing source.

You may use the **Find** button to filter the list based on one of the options from the drop down list:

- **Title contains** (default)
- **Title not contain**
- **Author contains**
- **Author does not contain**
- **ID contains**
- **ID does not contain**
- **Last Change contains**
- **Last Change does not contain**

Citation information section tab pages

The tabs provide the following information categories of citation data:

**Note**

The **Note** tab provides a place to record notes or comments about the citation. The central part of the window lists all notes for this citation, and gives you a preview of the beginning of the note. The buttons <+>, Add, <edit>, −, Up and Down let you add a new note, share the selected note, edit the selected note, remove the selected note and move the selected note up or down the list of notes. Note that the <edit> and − buttons become available only when a media object is selected from the list. Removing a note only removes the note from this citation, it does not delete the note itself. Please refer to details on editing notes.

**Gallery**

The **Gallery** tab lets you store and display photos and other media objects associated with a given citation (for example, a photo of a page of a book or a page of a census). The central part of the window lists all such objects and gives you a thumbnail preview of image files. Other objects such as audio files, movie files, etc., are represented by a generic Gramps icon. The buttons <+>, Add, <edit> and − let you add a new image, add a reference to an existing image, modify an existing image, and remove a media object's link to the citation. Note that the <edit> and − buttons become available only when a media object is selected from the list. Please refer to details on editing media references.

**Attributes**

The **Attributes** tab displays "Key/Value" pairs that may be associated with the citation. These are similar to the "Attributes" used for other types of Gramps records. The difference between these Key/Value pairs and Attributes is that Attributes may have source citations and notes, while Key/Value data may not.

The central part of the window lists all existing Key/Value pairs. The buttons <+>, + and − let you add and remove pairs. To modify the text of Key or Value, first select the desired entry. Then press the <edit> button to select the Key, or click in either the Key or Value cell of that entry and type your text. When you are done, click outside the cell to exit editing mode.

**References**

The **References** tab lists all the database records that refer to this source, if any. The list can be ordered by any of its column headings: **Type**, **ID**, or **Name**. Double-clicking an entry allows you to view and edit the record.

**Editing information about repositories**

Once you have selected a source, or if you had chosen the <+> or <edit> buttons, then the **New Repository** dialog appears.

**New Repository dialog**

Fig. 9.2.19 New Repository - editor dialog - example

The following fields are shown:

- **Name**: of the repository (where sources are stored).
- **Type**: of repository can be physical or virtual structures where genealogical and family history sources are stored:
  - Album
  - Archive

Entering and editing data: detailed - part 2 - Editing information about repositories
New Repository tab pages

The tabs represent the following categories of repository data:

Addresses

The Addresses tab lets you view and record the various addresses of the repository.

The bottom part of the window lists all addresses stored in the database. The top part shows the details of the currently selected address in the list (if any). The buttons \( + \), \( \text{Edit} \), and \( - \) allow you to correspondingly add, modify, and remove an address record from the database. Note that the \( \text{Edit} \) and \( - \) buttons become available only when an address is selected from the list.

Internet

The Internet tab displays Internet addresses relevant to the repository. The bottom part lists all such Internet addresses and accompanying descriptions. The top part shows the details of the currently selected addresses in the list (if any). The buttons \( + \), \( \text{Edit} \), and \( - \) let you add, modify, and remove an Internet address. The "Go" button (represented by an icon having a green arrow and yellow circle) opens your web browser and takes you directly to the highlighted page. Note that the \( \text{Edit} \) and \( - \) buttons become available only when an address is selected from the list.

Notes

The Notes tab provides a place to record notes or comments about the repository. To add a note or modify existing notes simply edit the text in the text entry field.

References

The References tab indicates any database records that refer to a given repository. The list can be ordered according to any of its column headings: Type, ID, or Name. Double-clicking an entry allows you to view and edit the corresponding record.

Editing information about notes

See also:

- Notes Category

Note editor dialog

![Fig. 9.2.20 New Note - editor dialog - example](image)

When creating a new note, or when editing an existing note, the Note Editor dialog appears. There are two tabs, the Note tab, and the References tab.

Note tab

The Note tab is the space where text is added. The text can be formatted using many standard text editing tools.
A toolbar to apply styles to your notes. You can select and apply one of the toolbuttons, or set the values as you want and start typing.

- Italic: common function known from text editors
- Bold: common function known from text editors
- Underline: common function known from text editors
- Font selection drop down list: a basic font selector showing all fonts installed on your operating system.
- Font size: select the size of the font to use for your text.
- Undo: Undoes last action.
- Redo: Re-applies last action.
- Font color: Select the color of your font.
- Background color: Adds a background color to the text you enter.
- Link: Opens the Link Editor, allowing you to create an internal link to an item in Gramps, such as a Person, Family, Event, Note, etc. External URL links can also be created.
- Clear Markup: Return selected text to plain text. Removes any links made.

A context menu on the textview.

The most important entry in this context menu is the spell selection. You are offered a selection of installed languages on your system with spell checking enabled.

Some properties of your note

- **Preformatted** checkbox: Notes in Gramps are considered reflowable to allow the content to conform to the report's page size and formatting for the most harmonious presentation. In the default setting, newlines (linefeeds & carriage returns) and white spaces will be automatically ignored so as to form complete paragraphs, which are defined by an empty line between two textblocks.
  When **Preformatted** is checked, Gramps will assume the whitespaces and newlines you keyed into the notes are important. Use **Preformatted** for tables, literal transcripts, and so forth. Using a monospace font will help keep preformatting column widths & margins predictable.
  Try not to use preformatted unless absolutely necessary, the reports create will flow more naturally.
- **Make public/private** Privacy is the same as on the other objects. With one easy click, you can indicate a note should be considered private so Gramps can remove this note from all output created.
- **ID**: a unique ID for the note. If left blank, an automatic ID will be generated according to the settings in the preferences.
- **Type**: (general default) The note type. You can add your own custom Type by keyboarding it in directly. Adding a Note will automatically set the Type to match the object to which it is being added. (e.g. A note added to the Notes tab of the Person Editor will default to Person Note Type.)

<table>
<thead>
<tr>
<th>Type</th>
<th>Recognized for features in</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;primary object&gt; Note</td>
<td>Note</td>
</tr>
<tr>
<td>&lt;secondary object&gt;</td>
<td></td>
</tr>
<tr>
<td>Note</td>
<td></td>
</tr>
<tr>
<td>Citation</td>
<td></td>
</tr>
<tr>
<td>General</td>
<td>(default)</td>
</tr>
<tr>
<td>Html code</td>
<td>Narrated Web Site</td>
</tr>
<tr>
<td>Link</td>
<td>report inclusions; export to GEDCOM</td>
</tr>
<tr>
<td>Report</td>
<td></td>
</tr>
<tr>
<td>Research</td>
<td></td>
</tr>
<tr>
<td>Source text</td>
<td></td>
</tr>
<tr>
<td>To Do</td>
<td>To Do Gramplet, ToDo Notes Gramplet Addon. Not to be confused with ToDo tag-based reports.</td>
</tr>
<tr>
<td>Transcript</td>
<td></td>
</tr>
<tr>
<td>Unknown</td>
<td></td>
</tr>
</tbody>
</table>

- **Tags**: Select a Tag for the note: Complete, Todo etc... You can add your own Tags by typing it. Reports based on tags include: Tag Report, Todo report

References tab

The **References** tab indicates any objects that refer to a given note. The list can be ordered according to any of its column headings: Type, ID, or Name. Double-clicking an entry allows you to view and edit the corresponding record.

Link Editor

A block of Note text must be highlighted for the Link Editor to be active. There is no visual indicator when the button is inactive.
The **Link Editor** has the following options:

- **Link Type**: specifies the type of link
  - Internet Address (URL)
  - or an item in Gramps, such as an Event, Family, Media, Note, Person, Place, Repository, Source, or Citation.

- **Select Item** button: opens the selector dialog for existing items in the category specified in the Link Type. Not applicable for Internet Address selection.

- **New** button: opens a window to create a new item of the specified Gramps item. Successful creation of a new item will autofill the Gramps item box and the Internet Address box with the appropriate data.

- **Gramps item**: This box is Auto generated by the selection of the Select Item button, New button, Edit button.

- **Edit** button: opens the editor dialog for the specified Gramps item. The selected item will autofill the Gramps item box and the Internet Address box with the appropriate data.

- **Internet Address**: For Link type = Internet Address delete any data left by Gramps and enter the full Internet Address.

### HTML links

Links created in the note will turn blue and underlined when you hover your mouse over the text. While working within Gramps, right-click allows the edit window for the selected object to open or to open the URL link in your default browser.

Their true power comes when a [Narrated Web Site](#) or [Dynamic Web](#) is created. Links created become true navigation links to other pages within the web report.

See also:

- **Internet Address Editor**
- **Note Link Report**

### Note markup and preformat in reports

Markup like **bold**, color, underline, ... can be added to notes. A note can be preformatted or not. It depends on the output type how this markup will appear. Here an overview is given of what you can expect.

- **PDF** and **direct print** (to printer or to file) fully support the markup and the preformatted setting
- **ascii** print removes all markup from the notes for obvious reasons
- **LaTeX** supports the preformatted setting and partially supports font emphasis stylings and size markup; output does not support font family or colors markup at the moment.
- **Narrative Web**. Many people use the Narrative Web report as an easy way to work with their data. This report is trying to respect markup in the notes. This is an interpreted translation, it is not one-to-one.
- **ODF** output does not support markup at the moment.
- **RTF** output does not support markup at the moment.
html output does not support markup at the moment.

Note markup and preformat in reports

Use markup in notes only in those cases it adds to the information stored. Gramps is not a text editor.
The previous section offered you a detailed overview of how to enter and edit the main objects you see in Gramps. This section continues with other objects you encounter in Gramps.

**Name Editor**

Names are edited through the [Name Editor](#) dialog, available from the [Names tab](#) of the [Edit Person](#) dialog.

**Name Editor dialog**

![Name Editor dialog](#)

The top of the window allows entry of the type of name (e.g., Birth Name, Married Name, etc) from a dropdown list. Next are elements of the personal name most commonly grouped as Given Name elements. Following the Given Name section is the Family Names section. At the bottom are elements allowing for customization of name sorting, dates for names, name sources, and notes for names.

**Type**

- **[Type](#)** (birth name default) The Name type dropdown list allows you to select the type of name being entered. You may also directly key in a [Custom Type](#) into this field.
- **[Record is public/private](#)** toggle the icon in the top right corner to mark this name record as private. This will give you a chance to omit this name from being included in reports if you choose so among the report generation options.

**Given Name(s) Section**

The [Given Name(s)](#) Section contains all parts of a personal name you can store with Gramps:

- **[Given](#)** The person's given names should all be entered here.
- **[Call Name](#)** The person's proper legal name that was used most commonly by the person should be entered here. For example, someone named John Raymond Smith who uses the name Raymond should have Raymond entered here. If this person uses Ray commonly, this should be entered as a nickname since Ray is not the proper legal name (see following). In Germany and some other places, it was customary to underline the call name among the different given names (see also [here](#)).
- **[Title](#)** The person's title, such as Doctor (or Dr.) can be entered here.
- **[Suffix](#)** The person's name suffix, such as Junior (Jr.) or III, should be entered here.
- **[Nick Name](#)** The person's nickname should be entered here. Nicknames include shortenings of proper legal names such as Greg for Gregory (cf. Call Name above).

**Family Names Section**

The [Family Names](#) Section contains the person's family name elements. Gramps allows for multiple family names as well as multiple kinds of
family names.

- Toolbar - + / Edit / Remove / Move up in list / Move down in list

The following columns are shown:

- **Prefix**: A prefix for the family name that is not used in sorting (such as "de" or "van").
- **Surname**: For the main portion of one's family name.
- **Connector**: Often used in matronymic or patronymic naming schemes, such as dotter.
- **Origin**: Indicating the type of family name this is and its derivation.
- **Primary**: Radiobox indicating if the family name is the primary one.

The following field is shown:

- **Family Nick Name**: For families commonly referred to using a more vernacular nickname.

See also: Names in Gramps - wiki article.

**Name Editor tab pages**

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>The tab labels reflect the presence of corresponding information: if the tab contains any data, its label appears <em>boldface</em>; if the tab has no data then its label appears regular (not bold).</td>
</tr>
</tbody>
</table>

**General**

Options allowing you to adjust specific grouping, sorting, and displaying properties of this name, as well as to provide the date corresponding to the name:

- The **Group as**: field provides an alternative grouping node for a name in the person view, overriding the default grouping based on the family name. This may be necessary with similar family names that need to be grouped -- for example Russian names Ivanov and Ivanova are considered the same, but the difference in gender is reflected in different spelling. See Grouping Surnames.

  - Override Check this checkbox to enable typing into this field. (Checkbox unchecked by default)

People are displayed according to the name format given in the Preferences (the default). Here you can make sure this person is displayed according to a custom name format. *(More name formats can be selected in the Edit - >Preferences… Display tab or customized using the Display_Name_Editor.)*

- The **Sort as** and **Display as**: determine how the name appears in the People View and the reports. The sort allows you to override the name pattern set in the Gramps preferences in the sorting of the name. For example, you suddenly have a branch of Swedish names with given and patronymic, but the rest of your database sorts names on Family name, Given. You can indicate here to sort this name always as Patronymic, Given.

  Here you can make sure this person is sorted according to a custom name format. *(More name formats can be selected in the Edit - >Preferences… Display tab or customized using the Display_Name_Editor.)*

  - The **Display as** allows you to say how the name is listed. You might, for example, want to sort a name in based on a person's given or surname, but still have the display show an honorific title before that name. *(More name formats can be selected in the Edit - >Preferences… Display tab or customized using the Display_Name_Editor.)*

The Person Tree view groups people under the primary surname. You can override this by setting here a group value. You will be asked if you want to group this person only or all people with this specific primary surname.

- The **Date** can provide information on the validity of this name -- use date spans as necessary. The edit date icon opens the Date Editor. Eg. for a Married Name, enter the date that the name is first used or the marriage date.

**Source Citations**

The **Source Citations** tab displays information about sources and citations relevant to this name and controls allowing its modification. The central part displays the list of all such citations and sources stored in the database. The buttons (+), (Edit), and (-) allow you to correspondingly add, modify, and remove a citation to this name. Note that the (Edit) and (-) buttons become available only when a source reference is selected from the list.

More info: Citations editor

**Notes**

The **Note** tab displays any notes concerning the name. To add a note or modify existing notes simply edit the text in the text entry field.

More info: Note Editor

**Attributes**

When you add or edit an Attributes from the Edit Person dialogs Attributes tab the Attribute Editor dialog will be shown.
Attribute Editor dialog

Fig. 9.3.2 Attribute Editor - Dialog - default

The top of the window shows the dialog title including the name of the person whose attribute is being edited. The central part of the window displays three notebook tabs containing different categories of available information. You can bring any tab to the top for viewing or editing by clicking on the appropriate tab heading. The bottom part has [OK] and [Cancel] buttons. Clicking the [OK] button at any time will apply all the changes made in all tabs and close the dialog window. Clicking the [Cancel] button at any time will close the window without applying any changes.

The top section allows editing of the most general information about the attribute:

- **Attribute**: (Identification Number [default]) The name of an attribute you want to use. For example: *Height* (for a person), *Weather on this Day* (for an event), ... Use this to store snippets of information you collect and want to correctly link to sources. Attributes can be used for people, families, events, and media. The information can be typed in the appropriate text entry fields. The attribute name can also be selected from available choices (if any) listed in the **Attribute** drop-down menu.
- **Record is public/private** Toggle this to mark this attribute record as private or public. This will give you a chance to omit this attribute from being included in the reports if you choose so among the report generation options.
- **Value**: Plain text description entry of the attribute. Eg. *1.8m, Sunny, or Blue eyes.*

Attribute Editor tab pages

**Tip**

The tab labels reflect the presence of corresponding information: if the tab contains any data, its label appears **boldface**; if the tab has no data then its label appears regular (not bold).

**Source Citations**

The **Source Citations** tab displays information about citations and sources relevant to this attribute and controls allowing its modification. The central part displays the list of all such sources and citations references stored in the database. The buttons [+], [Edit], and [-] allow you to correspondingly add, modify, and remove a source reference to this attribute. Note that the [Edit] and [-] buttons become available only when a citation/source reference is selected from the list.

**Notes**

The **Note** tab displays any notes concerning the attribute. To add a note or modify existing notes simply edit the text in the text entry field.

**Addresses**

 Use the Residence Event for historical genealogical address data.

See also Why residence event and not Address?
When you add or edit an address from the Edit Person dialogs Addresses tab the Address Editor dialog will be shown.

**Address Editor dialog**

![Address Editor dialog](image)

The Address Editor dialog allows you to record a current address by recording the information in the appropriate text entry fields. The top section of the dialog allows editing and entry of information about the address:

- **Date**: Date at which the address is valid.
- **Street**: The street of the address.
- **Record is public/private** button. Toggle this button to mark this address record as private or public. This will give you a chance to omit this address from being included in reports if you choose so among the report generation options.
- **Locality**: The locality name of the address.
- **State/County**: The state or county of the address in case a mail address must contain this.
- **City**: The village or city of the address.
- **Country**: Country of the address.
- **ZIP/Postal code**: Postal code.
- **Phone**: Phone number linked to the address.

The bottom of the dialog has Help, Cancel and OK buttons. Clicking the OK button at any time will apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button at any time will close the window without applying any changes.

**Address Editor tab pages**

The following tabs contain different categories of available information. You can bring any tab to the top for viewing or editing by clicking on the appropriate tab heading.

**Source Citations**

The Source Citations tab displays information about sources relevant to this address and controls allowing its modification. The central part displays the list of all such sources and citations references stored in the database. The buttons ![add button], ![edit button], and ![delete button] allow you to correspondingly add, modify, and remove a citation/source reference to this address. Note that the ![edit button] and ![delete button] buttons become available only when a source reference is selected from the list.

**Notes**

The Notes tab displays any notes concerning the address. To add a note or modify existing notes simply edit the text in the text entry field.

**Merging records**
Sometimes several records in your family tree turn out to be describing the same object: same person, same place, or same citation/source. It could happen either when the data is entered twice by mistake, or when new information reveals that the two entries refer to the same person. It can also happen after importing a GEDCOM obtained from a relative, whose database overlaps with your existing data.

Whenever you detect duplicate records, merging them is a useful way of correcting the situation.

To make a merge, **exactly two records have to be selected** in the appropriate view (People View, Sources View, or Places View). This is accomplished by selecting one entry and then selecting another person while holding down the **Ctrl** key. You will see the **Cannot merge object** warning dialog if you attempt to merge anything other than two(2) records.

### Merge People

**Merging people** does not discard any information.

The decisions you make during the merge only affect which data parts will become primary and which will become secondary for the resulting merged record.
When exactly two people are selected, choose Edit -> Merge... to invoke the Merge People dialog.

The dialog allows you to decide on whether or not the selected records should be merged. If you decide that the records should not be merged, despite similar names, you may click Cancel button to close the dialog without making any changes.

Expanding the Detailed Selection and the Context Information fields on the bottom left shows more information about the people to be merged.

If you decide to proceed with merging, select the appropriate Select radio button to specify the record to be used as the source of primary data, then click OK. The data from the other record will be kept as alternate data.

Specifically, all names from the other record will become alternate names of the merged record. Similarly, parents, spouses, and children of the other record will become alternate parents, spouses, and children of the merged record, and so on.
Merge Families

When exactly two families are selected, choose Edit -> Merge... to invoke Merge Families dialog.

The dialog allows you to decide on whether or not the selected records should be merged. If you decide that the records should not be merged, despite being similar, you may click Cancel to close the dialog without making any changes.

You can either choose one of the two families to be the source of the primary data for the new family, or by expanding the Detailed Selection field you can individually choose which father is the source of the primary data, which mother is the source of the primary data, and which family (selected by Gramps ID) is the source of the other primary data.

If you decide to proceed with merging, choose the appropriate Select radio button(s) to specify the source(s) of the primary data to be used for the merged family record, and then click OK. The children from both marriages are merged into the new family. The two fathers are merged and the events from the secondary father are attached to the primary father. The names from the secondary father become alternate names for the primary father. The events related to the secondary family (e.g., marriage and any divorce) are transferred to the primary family. The secondary family and the person record for the secondary father and mother are deleted from the database.

Merge Events

When exactly two events are selected, choose Edit -> Merge... to invoke Merge Events dialog.

The dialog allows you to decide on whether or not the selected records should be merged.

By expanding the Detailed Selection field you can see additional information about the merge.

If you decide that the records should not be merged, despite similar titles, you may click Cancel to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:
to be used for the merged record, then click **OK**.

---

**Merge Events**

![Merge Events dialog](image)

Fig. 9.3.10 Merge Events - "Detailed Selection" section expanded - dialog - example

**Merge Places**

![Merge Places dialog](image)

Fig. 9.3.11 Merge Places - dialog - default example

When exactly two places are selected, choose Edit -> Merge... to invoke **Merge Places** dialog.

By expanding the **Detailed Selection** field you can see additional information about the merge.

The dialog allows you to decide on whether or not the selected records should be merged.

If you decide that the records should not be merged, despite similar titles, you may click **Cancel** to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:

- Title
- Latitude
- Longitude
- Location
- ID

to be used for the merged record, then click **OK**.
When exactly two sources are selected, choose Edit -> Merge... to invoke the Merge Sources dialog.

By expanding the Detailed Selection field you can see additional information about the merge.

The dialog allows you to decide on whether or not the selected records should be merged.

If you decide that the records should not be merged, despite similar titles, you may click Cancel to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:

- Title
- Author
- Abbreviated title
- Publication information
- ID

To be used for the merged record, then click OK.
When exactly two citations are selected, choose Edit -> Merge... to invoke Merge Citations dialog.

By expanding the ▶ Detailed Selection field you can see additional information about the merge.

The dialog allows you to decide on whether or not the selected records should be merged.

If you decide that the records should not be merged, despite similar titles, you may click Cancel to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:

- Volume/Page
- Date
- Confidence
- Gramps ID

to be used for the merged record, then click OK.

See also the Merge Citations... Tool.
**Merge Repositories**

When exactly two repositories are selected, choose **Edit -> Merge** to invoke the **Merge Repositories** dialog.

By expanding the **Detailed Selection** field you can see additional information about the merge.

The dialog allows you to decide on whether or not the selected records should be merged.

If you decide that the records should not be merged, despite similar titles, you may click **Cancel** to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:

- Name
- Type
- Gramps ID

...to be used for the merged record, then click **OK**.

**Merge Media Objects**

When exactly two Media Objects are selected, choose **Edit -> Merge** to invoke the **Merge Media Objects** dialog.

By expanding the **Detailed Selection** field you can see additional information about the merge.

The dialog allows you to decide on whether or not the selected records should be merged.

If you decide that the records should not be merged, despite similar titles, you may click **Cancel** to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:
to be used for the merged record, then click **OK**.

![Merge Media Objects dialog](image1)

**Fig. 9.3.20 Merge Media Objects - "Detailed Selection" section expanded - dialog - example**

**Merge Notes**

![Merge Notes dialog](image2)

**Fig. 9.3.21 Merge Notes - dialog - default example**

When exactly two notes are selected, choose **Edit -> Merge...** to invoke **Merge Notes** dialog.

By expanding the **Detailed Selection** field you can see additional information about the merge.

The dialog allows you to decide on whether or not the selected records should be merged.

If you decide that the records should not be merged, despite similar titles, you may click **Cancel** to close the dialog without making any changes.

If you decide to proceed with merging, choose the appropriate radio button to specify:

- **Text**
- **Type**
- **Format**
- **Gramps ID**

...to be used for the merged record, then click **OK**
Fig. 9.3.22 Merge Notes - "Detailed Selection" section expanded - dialog - example
As long as any Family Tree database is open, Gramps is focused on a single person usually referred to as an Active Person. This allows you to view or modify the data concerning this person, his or her immediate family, etc. Navigating in the Family Tree database (i.e. moving from person to person) is in fact nothing else but changing the Active Person.

This section describes many alternative ways to navigate through the database using both the complex and the convenient interfaces Gramps provides. All these ways fundamentally accomplish the same result, but some methods of navigating will be more convenient than others... depending on what you are doing in Gramps at the moment.

Using the People Category

The most intuitive way to select an Active Person is to use the People Category. When in the People Category, just select the name of the desired person from the list by clicking that list entry. The person you have selected becomes active. The statusbar updates to reflect the change of the active person.

See also
- Editing information about people

Using the Relationships Category

When in the Relationships Category, you can easily navigate between the members of the displayed family as follows:

Click on the underlined name of the person you want to go to and this person will be the new active person of the Relationships Category.

The name of the currently active person is not underlined.

In addition to this, Gramps provides an extensive set of keyboard navigation options. The detailed reference to the key bindings is found in the Appendix B: Keybindings reference.

Using the Families Category

When in the Families Category, you can easily navigate between the displayed families.

The Families can be used to visually compare a series of families for possible duplicates and missing data. Sorting on the different columns allows putting similarly named Partners in close proximity allowing Spouses to be compared. You can match by Given name or Nickname by temporarily changing "Name format" in the Display tab of Edit ▶ Preferences... dialog. As an example, a name format of "Given Surname Suffix" would makes the column sort on the nickname name.

Merging two families will not only combine the Family secondary objects, but also simultaneously merge the two fathers and two mothers.

The Family view's Filter Gramplet allows searching for Persons in different family roles. So you might look for Families with a father named "John", a mother named "Mary" and a child named "Thomas".

Using the Charts Category
Gramps relies heavily on form-based layouts of linked list items. These imply relationships between records in your family Tree. The Charts Category provides an alternative, more visual, way of representing those relationships. The positions, shapes, and colors of containers along with their connecting lines & arrows can show an extra depth of interrelation with different factors. Containers can be simple color filled boxes, arcs, ribbons, or many other shapes.

But the Charts Category also provides an alternative way to navigate through the family tree. The benefit of this method is that you can see more than one generation of the family tree. So you can jump directly from a great-grandson to a great-grandfather without going through the intermediate generations.

Note that after changing the Active Person in the Charts Category, the Chart View is re-adjusted to the newly selected Active Person focus. When in the Charts Category, you can easily navigate between the members of the displayed family tree as follows:

To make any displayed person the Active Person focus, left-click their corresponding container. Right-clicking the container will invoke a context menu with options appropriate to contents.

The a context menu for a Person container may contain sub-menus listing all spouses, siblings, children, and parents of the corresponding Person. The first entry in the context menu will usually be the name of the Person in that container. (It could alternately be an Edit option.) Selecting the Person name will shift focus in the same way as left-clicking the container. You can also change the Active Person focus to any of the spouses, siblings, children, or parents of any displayed person.

Some charts views have an obvious navigational correlation. Moving through generations intuitively matches moving to the left, right, upwards or downwards in the chart. These may have custom directional navigation buttons to allow navigation by clicking rather than dragging.

As an example, to change the focus of the Pedigree View to a child (if any exists) of the current Active Person, click the (Left Arrowhead) button to the left of the Active Person’s chart box. If there is only one child, the focus changes immediately. If the Active Person has more than one child, the (Left Arrowhead) button expands with a pop-up menu with a selectable list of the children. (For this particular (Left Arrowhead) button, the pop-up menu list of Children is sorted by that Parent’s Marriage order, sub-sorted by Birth order. These orders can be changed globally in the Relationships category.)

Like containers, buttons may have alternate features accessed by right-clicking and choosing from a contextual pop-up menu.

Other buttons are less obvious aids to navigating to not People but features of Gramps. Using the Pedigree View example again, rolling over the lines between boxes shows a hint with any known basic details about the relationship and double-clicking those lines opens the editor for that Family. And double-clicking the Active Person box opens the editor for that Person. It is well worth reading the detailed documentation on each Chart View to discover these hidden shortcuts to favorite features.

The built-in Views of the Chart Category are introduced in the Categories reference section. Some are described in greater depth in articles listed at the bottom of the View’s introductory section.

The collection of Views in the Charts Category can be expanded with 3rd Party Addons using the Plug-in Manager feature of Gramps. The available 3rd Party Addon plug-ins can be found under the View column of the list of Addons table. The maintenance of a few 3rd Party Addon Views has been adopted by the Gramps volunteer team over the years. These became 'built-in' after being vetted and then included in the main Gramps distributions. Articles about using each Addon View are linked to the label Plugin/Documentation column. The quality of documentation varies dramatically for these articles.
Using Gramplets

On the Sidebar and bottombar, you can add Gramplets to expand your navigation options beyond a single generation's distance. Some examples are:

- Relatives
- Descendants
- Pedigree
- Fan Chart

These examples provide the ability to navigate the Active Person focus with the perspective of familial relationship... to nearby relatives, descendants or ancestors. Future Gramplets might allow navigating by geographical proximity, DNA matching or some other connection we haven't yet considered.

The text based Gramplets tend to have names hotlinked for navigation while the graphical ones may use contextual menus.

Setting the Home Person

One (and only one) person in the Family Tree database can be designated as the Home Person. Once the Home Person is designated, returning the Active Person focus to that person becomes a matter of a single click, regardless of which Category is being used at the moment.

To set the Home Person, first navigate to that person using any method you like. Then choose the People category and select the menu Edit -> Set Home Person. Once this is done, you can move to the Home Person from anywhere in the database by simply clicking the Toolbar Home icon. You can also choose the menu Go -> Home or select Home item from any context menu available on the right click or use the keyboard shortcut Alt + Home.

- Settings/Setting Home Person
- On the Edit Person dialog you can select "Make Home Person" from the context menu.

Setting the Active Person

The Active Person is expected to be the contextual focus of actions, reports and edits. They are the selected item in the Person view or at top of the Relationship view.

The Active Person focus may be selected directly or "navigated" to indirectly. Methods include:

- clicking on a person's listing in the Person view
- selecting the person from the Bookmarks menu
- Using history-based Navigation
- hotlink navigation
- Context menus
- Notes as Navigational Shortcuts

There is a selection highlight as a visual cue of the Active Person in the People View. In the Relationship View, the Active Person is shown in a separate section at the top. All other persons shown below have an immediate (parent, sibling, spouse, child) relationship with the Active Person. Optionally, the Status Bar may set to list the focus Object for the View Category. (The Active Person is the focus for several View Categories.)

Hotlink Navigation

Normally, simply clicking on the hotlinked name of a Person will select that person and shift this Active Person contextual focus.
Fig. 10.3 Relationships Category view

Each Person’s name in the Person and Relationship category views is a hotlink. Changing the Active Person focus in Person view appears to merely change which record is highlighted. But this also causes Gramplets contents to be updated and the Relationship, Charts & Geography views to be re-focused on the new Active Person.

Selecting a different hotlinked name in the Relationship category view causes a less subtle change. The perspective of how the family data is represented changes towards that focus. Their details move to the top section and their immediate family are re-arranged below.

Contextual Menu Navigation

However, hotlinked names in the References tab and Notes (and in some Gramplets) will merely open the Person Editor window without navigating the Active Person focus to that Person. (These links behave as though you had clicked an Edit button instead of a hotlinked name.) This facilitates quickly editing Persons around the Active Person without the disorientation of a shifting focus.

Fig. 10.4 Context menu on the Person editor

The Active Person focus can be set while in the Edit Person dialog by using the context menu (right-clicking) in the empty space of the header area. The Make Active Person option in that context menu changes the Active Person focus to the Person being edited.

Using history-based Navigation

Gramps also features a powerful set of history-based navigation tools. These tools are similar to those commonly used in web browsers.

They include Back and Forward items available from the Go menu, context menus (available in People, Family, and Pedigree Categories), and the toolbar buttons. They also include the list of the recent selections available under the Go menu that allows you to jump directly to any of the recent selections. Finally, right-clicking on the Next Selection and Previous Selection toolbar buttons invokes the popup menu with corresponding portion of the history. Select any item from the menu to jump directly to it.
**Bookmark Navigation**

The Home button on the toolbar is a special case bookmark. It shifts the Active Person focus to the Person currently designated as the **Home Person**. This is so frequently useful that this feature also has a **keybinding**.

Similar to setting the Home Person, you can bookmark other people from the database to simplify further navigation. To bookmark a person, first navigate to that person, then choose the menu **Bookmarks -> Add Bookmark**. To move to that person elsewhere in the database, choose the menu **Bookmarks -> Person's name** from the list of bookmarked names shown. The other categories have their own list of Bookmarks.

![Organize Bookmarks](image)

**Fig. 10.6 Organize Bookmarks**

You can manage your bookmarks by choosing the menu **Bookmarks -> Organize bookmarks...** or **keybinding**: Shift + CTRL + D. This opens the **Organize Bookmarks** dialog with the list of bookmarks and the controls to modify this list.

Use the **Up** and **Down** buttons to change the list sequence. Use the **Remove** button to remove a Bookmark. The **Help** button will bring you to this page, and you close the **Organize Bookmarks** window with the **Close** button.

The list of Bookmarked People can be selected through the People Category, as explained above, but is also shared with the Relationships and Charts Categories.

On a similar basis, separate lists of Bookmarks are maintained in each of the following Categories: Families, Events, Places, Sources, Citations, Repositories, Media, and Notes.

**Notes as Navigational Shortcuts**

![Notes Editor - Linking text](image)

**Fig. 10.7 Notes Editor - Linking text**

There are separate Bookmarks lists in several categories. But they are still just simple lists. Long lists of bookmarks quickly become unwieldy.

Persistent Links can be created in **Notes**. Use the **Link Editor** in Notes to organize navigation links to different types of Gramps records following to your own organization methods. Once a Note has linked text, that linked record can be used like a Bookmark. In Note Gramplets where editing is not active, clicking on the Link open the Object Editor for that link. (It requires an extra modifier in the Noted Editor: navigate to that record by holding the **CTRL** key and clicking on the Linked Text.) One note be used as a Linked Index to other Notes with different sets of Links.

An example of a linked note might include an obituary where all the Persons, Places or even the Events are Linked. This makes it easier to navigate to the indirectly related (or even unrelated) pallbearers, funeral **officiators**, or attendees.

Another note might be the transcribed bibliography for the published original research of another genealogist. As you collect digital copies of those originally cited references, the linked bibliography can be used as a Source acquisition checklist. When completely Linked, the Bibliography can be use to navigate through Sources for each citation while searching for unsupported conclusions, inaccuracies or omissions.

**Finding records**
Finding People

You may want to first apply search filters to reduce the size of the list. The search bar can be used for single term searches when the gramplets sidebar is not enabled. For more complex searches, gain access to the multiple term filter controls by enabling the gramplets sidebar (by choosing the View -> Sidebar menu) and choosing the Filter gramplet tab. Select the desired filter and click Find. For details, see Filters.

Fig. 10.8 Find people list view using Interactive search type ahead - example

To find a record in one of the category list views, first switch to the appropriate category that provides the list of the desired records: People, Sources, Places, or Media. Select a line in the list to gain focus and then start typing the name of a person or the title of a Source, Place, or Media object that you are looking for, respectively.

Alternatively, select a line in the list to gain focus and then you may press CTRL + F to turn on the search mode textbox. However, simply starting to type is also enough to both open the box and start entering the search term.

As you type, the first matching record in the sort column of the list will scroll to the center of the list and be selected. As you type more characters, the match will be refined. As long as the search mode text box is visible, pressing the ↓ down arrow cursor key will move to the next match while pressing the ↑ up arrow cursor control key will move to the previous match. The box disappears after it is idle. (When there have been no keystrokes for between 5 and 15 seconds.) Without the Find box active, the cursor control keys revert to moving the records selection up and down the list.

Changing the sort column (by clicking on the header) also changes the column being matched. Finding in a different sort column works best in Flat List view modes. (People or Place category view modes with hierarchical grouped are less responsive than Flat List view that are already sorted alphabetically.)

Using the Clipboard

Not your ordinary Clipboard

Note, that the Gramps Clipboard doesn't work anything like a standard computer clipboard. It works like a real clipboard in that you drag things onto it, and drag-copy them off.

Warning

Clipboard: storage is persistent within a single Gramps session. Closing the Clipboard window will not lose the stored records. However, exiting Gramps will.

If you do need to save items between sessions there is a Third-party Addon Collections Clipboard Gramplet that does.
For an application like Gramps the **Clipboard** is very important as it will help reduce repetitive data entry.

The **Clipboard** tool provides a temporary notepad to store database records for easy reuse during a single Gramps session eg: until you exit Gramps. In short, this is a sort of the copy-and-paste functionality extended from textual objects to other types of records used in Gramps. Clipboard makes extensive use of the *drag and drop* technique.

To invoke the **Clipboard**, either choose the menu `Edit->Clipboard` or click the Toolbar **Clipboard** button or use the Keyboard shortcut (accelerator key) **CTRL+E**.

**Clipboard** supports addresses, attributes (both personal and family), events (both personal and family), names, media objects references, citations, URLs, and of course textual information of notes and comments. To store any type of these records, simply drag the existing record on to the **Clipboard** Pad from the corresponding editor dialog. To reuse the record, drag it from the Clipboard on to the corresponding place in the editor, e.g. Address tab, Attribute tab, etc.

### Tip

Some objects show a link icon in the left column and say 'ref' in the label. This indicates that dragging such selection will produce a reference to a shared object, not link the object itself. All the shared attributes will be replicated. For example, the media object file will not be duplicated. Instead, the reference will be made to an existing media object, which will result in the local gallery entry.

**Clipboard context menu**

Selecting a record using the the context menu (right click) will show the following three options for each record type:

- **See the [RECORD TYPE] details**
- **Make the [RECORD TYPE] active**
- **Create Filter from the [RECORD TYPE] selected**

One example

You find a birth certificate of a person. In this certificate also the witnesses are mentioned. And the birth certificate also determines a source where the information was stored. The best way is to open the clipboard and drag the source you want to work with there. Then use drag and drop to use it in new items you use.

Now you can finalize the information on the person editor screen. Drag that info also to the Clipboard.

Now you add two new persons for the witnesses (assuming you do not have them already in your database). Simply drag and drop the birth info to the witness event screen. You are then presented with the screen where you can change the role of the witness to witness for this birth event. You do the same with the other witness.

This saves you a lot of typing and possible errors.

**Main Menus**
The MenuBar shows the available Gramps Menu options.

Very abbreviated menus will be available before a Tree is loaded. They allow managing Trees; quitting Gramps; editing application-wide Preferences; enabling and disabling sections of the Graphical User Interface (GUI); and Help options.

**"Import" is a Family Tree menu option that only appears when a Tree has been loaded**

Gramps needs to have a prepared place to import genealogical data. Create and load a new, blank Tree to in order to import data exported from another Genealogy tool. (Such as a GEDCOM file.) Data can also be directly imported into a Tree that already has data. *But make a backup first!*

---

Fig. 10.11 Menubar - Main Menu Overview - Family Tree Loaded

Fig. 10.12 Menubar - Main Menu Overview - Family Tree Loaded showing "Active" and "Windows" menu entries in use

After a Tree is loaded, the Family Trees, Reports, Tools and Help menus will always have consistent options. But the availability of options of the other menus is context aware. Options in the Add, Edit and View menus change depending on the active Category and some menu items appear 'dimmed' when the selection objects in the view do not permit the action.

The Go and Bookmarks menus are specifically built of navigation links within each view.

A Windows menu appears when there are any spawned windows or dialogs to be listed.

### Family Trees

![Example Family Tree - Gramps](image)

- **Manage Family Trees...** - open the Family Tree Manager Window
- **Open Recent** - a shortcut to opening a recently worked on Family Tree
- **Close** - backup and close the current Tree

- **Import...** - Bring in data from other formats. Make a Backup before importing! There are import Preferences to mark imported data with timestamped Tag and/or Source attributes. These options dramatically slow the Import process but are helpful for the ensuing data cleanup.
- **Export...** - Exporting data allows you to share any portion of your Gramps Family Tree with other researchers as well as to enable you to transfer your data to another computer.

- **Export View...** - Menu only appears on most Views, if the displayed data can be exported. Gramps will export data on screen according your choice: CSV or Open Document spreadsheet format.

- **Make Backup...** - Allows you to make a Full Gramps XML backup of your currently opened Family Tree. Note some configuration and Media items are omitted from XML backups.

- **Abandon Changes and Quit...** -
- **Quit...** -

---

**Navigation - Main Menus**

162
Add

- Add - a new object
  also see keybindings.

- Person - adds a Person (prim.obj)
- Family - adds a Family (prim.obj) - Brings up the Family Editor dialog
- Event - adds an Event (prim.obj)
- Place - adds a Place (prim.obj)
- Source - adds a Source (prim.obj)
- Citation - adds a Citation (prim.obj)
- Repository - adds a Repository (prim.obj)
- Media - adds a Media (prim.obj)
- Note - adds a Note (prim.obj)

Edit

- Undo -
- Redo -
- Undo History... - Open the Undo History dialog

Additional menu options dependent on Category view will appear here.

- Tag - See Tagging

- Clipboard - The Clipboard tool provides a temporary notepad to store database records for easy reuse.

- Preferences... - Shows the Preferences dialog. That allows you to change most settings in Gramps.
  Additional menu options dependent on Category view will appear here.

View
Go

- **Configure** - Allows you to configure the active view. Provides options to hide, reveal & re-arrange elements.
- **Navigator** - The Navigator is a sidebar container for the Navigator Category icons. When selected (default), the sidebar is shown on the left of the active View. Deselecting hides the Navigator sidebar. If all the Category icons cannot fit in the available vertical space, a hidden scrollbar will be created on the right of the sidebar and be revealed when rolled (hovered) over. Text labels for the icons can be hidden via an option in the Display tab of Preferences. Display modes can be selected from the pop-up menu at the bottom of the Navigator sidebar.
- **Toolbar** - show (or hide) a split screen container for (frequently used) action icons above the Category View. The selection of action icons varies to suit the Category view. A Third party Addon can be installed to supplement the Preferences with a Theme tab providing an option to show Text labels for each Toolbar button.
- **Sidebar** - Show (or hide) a split screen container for Gramplets to the right of the Category View.
- **Bottombar** - Show (or hide) a split screen container for Gramplets at the bottom of the window, just above the Status Bar.
- **Full Screen** - Expand window to use all available screen space while disabling the window dragging & resizing controls. Deselecting restores to previous size while re-enabling the window dragging & resizing controls.

- Dependent on which view is active, other option menu items will appear here that can modify how the View organizes data.

**Go**

- **Back** - navigates the selection of the current View backwards to the previous item in your Navigation history
- **Forward** - navigates the selection of the current View forward to the next item in your Navigation history

- **Home** - navigates the Active Person focus to the individual set as the Home Person

- Dynamic list of the most recent 10 records (People, Families, et cetera) selected, the List is dependent on the Category view being viewed.

Known bug patch for Gramps version 5.1.1(Fixed in Version 5.1.2)

Fixes 'Go' menu selection scramble caused by recent UIManager upgrade
addresses Bug Report: **11341** on 24 Sept 2019

You can use the third party RestoreHist addon

So that a portion of the Go menu can be made to persist between restarts of Gramps. If installed then you can manually clear the stored state by finding and deleting /gramps51/plugins/RestoreHist/hist_save.ini file from the user folder (the ~.gramps folder or %Appdata% folder in Windows).
Fig. 10.18 Menubar - Bookmarks Overview

- **Add Bookmark** - Create a bookmark from the currently selected item e.g. Person, Family etc..
- **Organize Bookmarks...** - Opens the Organize Bookmarks window.
- Dynamic section where the bookmarks appear

**Reports**

Fig. 10.19 Menubar - Reports Overview

- **Books...** - The Books Report allows you to create a custom genealogy book containing a collection of Gramps textual and graphical reports in a single document (i.e. a Book)

- **Graphs...** -
  - Family Lines Graph...
  - Hourglass Graph...
  - Relationship Graph...
- **Graphical Reports...** -
  - Ancestor Tree...
  - Calendar...
  - Descendant Tree...
  - Family Descendant Tree...
  - Fan Chart...
  - Statistics Charts...
  - Timeline Chart...
- **Text Reports...** -
  - Ahnentafel Report...
  - Birthday and Anniversary Report...
  - Complete Individual Report...
  - Database Summary Report...
  - Descendant Report...
  - Detailed Ancestral Report...
  - Detailed Descendant Report...
  - End of Line Report...
  - Family Group Report...
  - Kinship Report...
  - Note Link Report...
  - Number of Ancestors Report...
  - Places Report...
  - Records Report...
  - Tag Report...
- **Web Pages...** -
  - Narrated Web Site...
  - Web Calendar...

**Tools**

Fig. 10.20 "Tool..." Menubar - Tools Overview
Analysis and Exploration -
- Compare Individual Events...
- Interactive Descendant Browser...

Debug -
- Check Localized Date Display and Parser...
- Dump Gender Statistics...
- Generate Testcases for Persons and Families...
- Populate Sources and Citations...
- Python Evaluation Window...
- Show Uncollected Objects...

Family Tree Processing -
- Edit Database Owner Information...
- Extract Event Descriptions...
- Extract Information from Names...
- Extract Place Data from Place Title...
- Find Possible Duplicate People...
- Fix Capitalization of Family Names...
- Merge Citations...
- Rename Event Types...
- Reorder Gramps IDs...
- Sorts events...

Family Tree Repair -
- Check and Repair Database...
- Rebuild Gender Statistics...
- Rebuild Reference Maps...
- Rebuild Secondary Indices...
- Remove Unused Objects...

Utilities
- Media Manager...
- Not Related...
- Relationship Calculator...
- Verify the Data...

Windows

![Windows menu](image)

Fig. 10.21 Menubar - "Windows" - overview example

- **Windows** - This menu provides quick access to opened windows you are working on.

Help

![Help menu](image)

Fig. 10.22 Menubar - "Help" - overview example

- **User Manual** - Direct link to the online Gramps User manual you are viewing right now. Yes, you need an internet connection to consult the Gramps User Manual.
- **FAQ** - A link to the Frequently Asked Questions about Gramps.
- **Key Bindings** - A link to the Keybindings reference for Gramps. Also known as Keyboard shortcuts.
- **Tip of the Day** - Displays a dialog with a random hint about using the Gramps software.
- **Plugin Manager** - From this menu you can manage the built in plugins as well as any Third-Party Addons you may have installed.
- **Gramps Home Page** - This item opens your web browser and connects to the Gramps project web site.
- **Gramps Mailing List** - This item opens your web browser to the Gramps mailing list page. On this page, you can browse the mailing list
archives and join the gramps-users mailing list so you can share your experiences with other Gramps user's.

- **Report a Bug** - Choose this item to file a bug report in the Gramps bug tracking system. (This requires you to have a registered account on the Gramps bug reporting system) (Remember, Gramps is a living project. We want to know about any problems you encounter so we can work to solve them for you and everyone else benefits.)
- **Extra Reports/Tools** - A link to Installing Third-Party Addons in Gramps.
- **About** - This item displays a dialog with general information about the Gramps version you are running.

**Toolbar**

![Image](image.png)  
Fig. 10.23 Tip for the Tools button of the Dashboard category toolbar

The **Toolbar** is a horizontal set of button controls located right below the menubar. It gives you access to the most frequently used functions of Gramps.

- The assortment of Tool buttons is "contextual" -- the icons shown depends on which Category **view** and **view mode** is active
- Hovering over a toolbar icon shows a tip of its function
- The Toolbar can be hidden or revealed by the option in menu **View -> Toolbar**.

**Toolbar enhancement in the Themes Third party Addon**

Installing this **Third party Addon** allows Gramps to show toolbar text labels for each Toolbar button. The **Themes** addon augments the **Preferences** dialog with a **Theme** tab.

One of options of the Theme tab is a [Toolbar Text] checkbox. Selecting the checkbox causes the text labels to appear. This checkbox is deselected by default.

![Image](image.png)  
Fig. 10.24 Added Theme tab options for the Preferences dialog.

**Common Toolbar buttons**

- [Manage Databases](image.png)

![Image](image.png)  
Fig. 10.25 Manage databases - icon and tooltip on toolbar.
The button is the same as the Family Trees ▶ Manage Family Trees... menu option. The resulting dialog allow switching between Trees (genealogical databases).

▼ Connect to a recent database

![Connect to a recent database]

Fig. 10.26 "Connect to a recent database" toolbar button

This ▼ button opens Family Trees ▶ Open Recent... drop-down menu from the toolbar.

Go to the previous object in the history

The ▸ toolbar button is an alternative to the Go ▶ Back menu option, or pressing the Back keyboard keybinding. It uses the history based Navigation to shift the active object focus to the previously selected object in this category.

Go to the next object in the history

The ▹ toolbar button is an alternative to the Go ▶ Forward menu option, or pressing the Forward keyboard keybinding. It uses the history based Navigation to restore the active object focus shifted with the Go ▶ Back feature.

This button is only available after using the Go ▶ Back feature.

Go to the home person

The;base64,MTQ=

The toolbar button is an alternative to the Go ▶ Home menu option, or pressing the Home keyboard keybinding. It shifts the Active Person focus to match the Home Person.

This button is only functional if the Home Person has been set.

Add a new...

The ▶ toolbar button is an alternative to the Edit ▶ Add.. menu option, or pressing the Add keyboard keybinding. It opens a blank Object Editor matching the object category of the current view.

Edit the selected...

The button is an alternative to the Edit ▶ Edit... menu option, or pressing the Edit keyboard keybinding. It opens an Object Editor for each selected object in the category view.

Delete the selected...

The ▼ toolbar button is an alternative to the Edit ▶ Delete menu option, or pressing the Delete keyboard keybinding. It opens a Delete confirmation dialog.

The item that is about to be deleted is identified. If multiple items were selected, a dialog appears for each. A checkbox option offers to "Use this answer for the rest of the items".

Merge the selected...

This toolbar button is an alternative to the Edit ▶ Merge... menu option. It opens the Merge dialog for that particular category of records.
Successful use of the Merge button is only possible if two (and only 2) records are selected in the view.

Tag the selected rows

This toolbar button is an alternative to the Edit ▶ Tag submenu.

The button reveals a pop-up menu with the following Tag options:

- New tag...
- Organize tags...

Followed by a list of currently available tags that can be applied to the selected objects in the view.

Tags are used for color coding rows in list views, marker swatches on some charts, and persistent markers for filtering and organization.

Open the Clipboard dialog

This toolbar button is an alternative to the Edit ▶ Clipboard menu option, or pressing the Clipboard keyboard keybinding. It opens the Clipboard dialog without adding the selected object to its collection.

Configure the active view

This toolbar button is an alternative to choosing the View ▶ Configure... menu option, or pressing the Configure active view keyboard keybinding.

Most Category views have Configurable Options. Clicking this button opens the dialog with the controls for adjusting those options.

This option opens a dialog with choices for displaying records in the View. (The dialog will also have tabs for any Gramplets which have configurable options that are active in the view.)

Open the reports dialog

This is a persistent alternative to using the Reports submenus.
By presenting the available Reports in a floating dialog, room is available for describing each Report, its status and contributing developer information. The dialog also allows exploration of Reports to be more structured.

**Open the tools dialog**

![Tool Selection - dialog](image)

Fig. 10.29 Tool Selection - dialog

This is a persistent alternative to using the **Tools** submenus.

By presenting the available Tools in a floating dialog, room is available for describing each Tool, its status and contributing developer information. The dialog also allows exploration of Tools to be more structured.
The Plugin Manager is available from the menu Help -> Plugin Manager. Many of the features of the Plugin Manager are intended for developers, and the dialogues described below are those seen by developers. The features for normal users are noted below where they are different.

Gramps detects whether it is being run in User mode or Developer mode by the 'optimise' Python option flag:

- `python -O gramps.py`

See Debugging Gramps.

Gramps consists of a core plus many plugins. When Gramps starts, the core is loaded and only a limited number of plugins are loaded. This decreases the startup time and memory requirements of Gramps. Subsequently, many plugins are automatically loaded by Gramps as they are needed, so that many users will not need to be aware of the existence of plugins, or their delayed loading.

The Plugin Manager allows you to control how Gramps manages plugins.

You may also replace the built-in Plugin Manager with the experimental third party Plugin Manager Enhanced Addon that provides a single unified view that combines the Registered and Loaded views with all the available 3rd party plugins

### Plugin types

There are two main categories of plugins in Gramps: "user plugins" and "system plugins". User plugins are those that you use and control to provide different functionality for you. The system plugins are used by Gramps.

The following types of User Plugins are present in Gramps:

1. doc creators: Backends for which Gramps can write reports (pdf, odf, ascii text, ...)
2. exporters: export formats you can export your data too via menu Family Trees -> Export...
3. gramplets: small programs you can embed in the Dashboard View, or detach and use as a normal window
4. gramps views: the views visible in the main window of Gramps
5. importers: import formats from which Gramps can import data via menu Family Trees -> Import...
6. map service: targets that can be used on the place view to go to an internet map service (Go toolbar button)
7. quickreport: known as Quick Views they are small reports that are available in the context menu on the listviews, or via the Quick View gramplet
8. reports: Textual or graphical reports Gramps can produce
9. tools: Tools you can start via the menu Tools

The following types of System Plugins are present in Gramps:

1. database: Backends that allow Gramps to support alternate database types.
2. plugin libs: libraries that are present giving extra functionality.
3. relationships: relationship calculators for different languages
4. Rule (Introduced Gramps 5.1.x and greater)

There are many plugins that come with Gramps. However, anyone can also write a plugin and share it. These third-party plugins are called "addons". We highly encourage users and developers to share their creations with other Gramps users.

### Registration and loading

Plugins are either held locally on the computer and are known about by Gramps, when they are said to be Registered, or they are held on a remote computer and Gramps only knows their name, type and description, when they are said to be Addons.

When Gramps starts, information is automatically read about the local plugins, so that they become registered. The Plugin Manager can be used to download remote Addons so that they too become registered.

Registered (i.e. local) plugins are loaded by Gramps in the following situations:

1. they are automatically loaded at startup. Some plugin types are loaded at startup (e.g., non hidden views), some plugins can have a flag that forces load on startup,
2. they are automatically loaded by virtue of the user clicking on a view or requesting a report,
3. they are loaded by the user explicitly requesting load in the plugin manager,
4. remote plugins are loaded at the same time as they are registered by using Install Addons in the General tab of Edit > Preferences...

### Hide/Unhide

The plugin Manager can be used to hide or unhide plugins. Some menus will not display hidden addons, so that the addon cannot be selected. For...
example, if a Gramplet is hidden, then it will not appear in the "Add a gramplet" context menu which appear when right clicking the background of the Gramplets main tab. However, hiding some addons (such as Relationships or Gramps Views) has no effect and may not even be allowed.

Actions

There are two tabs for the Plugin Manager:

- Registered Plugins
- Loaded Plugins

Registered Plugins

Fig. 11.1 Registered plugins

Here you see a list of all plugins that Gramps has found. These are the plugins which are part of Gramps, as well as the plugins found in the gramps51/plugins directory within the Gramps User Directory. The type of plugin is shown in the first column.

You can show or hide a plugin by selecting a row and pressing the Hide/Unhide button. This is only useful for the User Plugins.

By selecting a row and double clicking or pressing the Info button you will be shown the Detailed Info dialog.

Loaded Plugins

Fig. 11.2 Loaded plugins

Here you see a list of all plugins that have been attempted to be loaded. Normally, all views (such as the Relationship View) will be loaded, and all gramplets/reports/tools you have used will be loaded automatically.

If there was an error during the loading of a plugin, then the Status column will be shown in this tab. Double clicking a row showing a failure opens the Detailed Info dialog showing the error in detail. You can use this to contact the plugin author or the Gramps bug list.

Later if you decide that you do not like an Addon, you can mark it "hidden" and it will no longer show.

You can show or hide a plugin by selecting a row and pressing the Hide/Unhide button. This is only useful for the User Plugins.

By selecting a row and pressing the Info button you will be shown the Detailed Info dialog.

Detailed Info dialog
The **Detailed Info** dialog will display information about the selected plugin/Addon. You can use this to contact the plugin author or the Gramps bug list.

- Plugin name:
- Description:
- Version:
- Authors:
- Email:
- Filename:
- Location:
Gramplets

This page details the functionality of the Gramplets that come with Gramps.

For more Gramplets that you can extend your Gramps functionality with, see Third-party Addons. For technical details about creating your own Gramplet, please see Gramplets for Developers.

What is a Gramplet?

A Gramplet is an expansion to the Gramps program that ideally works seamlessly as if it was a core feature. They actually become embedded as part of Gramps. But while the core features of a view are needed almost constantly, the bundled Gramplets extend the view in ways that are only needed occasionally. Gramplets provide a supplemental perspective of the Tree data which either: changes dynamically during the navigation of the Gramps Tree, or; provides interactivity to your genealogical data.

Gramplets are the division of plug-ins (also called widgets, plugins, addons, auxiliary components) that can be found in the Dashboard Category ... or the Sidebars and Bottombars in other Navigator View Categories. They provide all kinds of functionality that can be useful for the researcher.

A selection of built-in plugins are bundled and pre-installed with Gramps. The Gramps project hosts a selection of add-on plugins that might only be of interest to certain audiences.

There are also third-parties, such as The Taapeli Project in Finland, who hosts their own selection of Isotammi group add-on plug-ins developed to tune Gramps for their needs. Members of the Gramps community also share special purpose addons privately or via GitHub repositories. And, of course, users are invited to develop their own addons.

Performance Drain

Gramplets can slow down Gramps and can use a lot of memory. Close any docked Gramplets that will not be of immediate use. (It is not necessary to uninstall them with the Plugin Manager.) Closed Gramplets can be re-added to a Gramplet Bar or the Dashboard as needed.

Aren’t all Plugins also Gramplets?

What is the difference between Gramplets, reports, quick views, and tools?

All of these are plugin types. But Gramplets are subtype of plugins with more emphasis on the user interface. Gramplets add a capability or a different perspective to the View. They can be used to improve the workflow of a View.

The other plugins tend to interrupt the normal workflow to do another task. They also tend to be used more intermittently. A plugin might generate a static (even when hot-linked) snapshot of the data, be a way of doing mass change, or provide an alternative import/export/output system.

Some common Plugin types are:

- Reports - provide a static output format of your data, typically for presentation
- Quick Views - provides a typically short, interactive listing derived from your data
- Tools - provide a method of processing your data
- Gramplets - provide a dynamic view and interface to your data.

Gramplets - What is a Gramplet?
A deeper understanding of the different types of plugins can be gained by sorting the Addon List by Type and exploring the contrasting Descriptions.

Some of the more static types of plugins can be extended to work dynamically as a Gramplet.

Several plugins have evolved into multiple types. Some plugins are shells which layer extra capabilities around other plugins. The Quick View Gramplet is not a type of Quick View plugin. Instead, it is a dockable shell that shows a Quick View plugin and pushes the plugin to refresh as the context changes.

Tip: Configure the Quick View Gramplet

Use the Configure button to change which Quick View plugin will be displayed from the any of the various Navigator categories.

Starting with Gramplets

When you first start the Dashboard Category you will see two default Gramplets; the Welcome to Gramps! Gramplet and the Top Surnames Gramplet.

Since Gramps 4.2 extended some Dashboard features to other Navigator Categories, we have common and specific Gramplets.

- Common Gramplets are applicable to any View ... and the data viewpoint is with respect to the Context of the Active Person and/or the Home Person. They can be docked on any Navigator Category View without making the View unambiguous.
- Specific Gramplets need the context of particular Views to give context to their perspective of the data. The list of Add Gramplets menu will differ according active Category view and Gramplets installed.

This list is leftover from an earlier revision of the wiki. It is unclear where the items fit in this discussion.

- Back references Gramplets - provide immediate visibility to data that tends be viewed occasionally and is buried in the interface... like the references tab on object Editor.
- Filter Gramplet is like the previous filter sidebar
- Common models for Notes, Gallery, Sources, Citations, Events
- Children Gramplet on Person views (also charts category and relationships category), families view

General Usage and Configuration

Fig. 12.2 Dashboard Welcome Gramplet
The container controls for Gramplets are arranged a little differently in the Dashboard category View as opposed to the Sidebar and Bottombar. Being aware of how these Gramplet containers differ (and are similar) will let you focus on getting the high speed performance instead of wondering why it spun out of control.

Originally added in version 3, Gramplets in Dashboard category View are arranged in a configurable number of columns. The Sidebar and Bottombar split panes were selected from among later innovations proposed in GEPS 19. They were built on the Filter Sidebar of the 3.3 version. The Filter was converted to a Gramplet and pre-docked in the Sidebar.

![Fig. 12.3 Detached Sidebar Welcome Gramplet](image)

The split panes provide limited screenspace for docking Gramplets in the other Navigator categories. But, unlike the many columns of the Dashboard View, each new split pane is a single column, filled with a single Gramplet. (The pane still supports holding multiple Gramplets, it just uses Tabs to display them one at a time.)

The split pane approach reduces the need for flipping between Category Views... and that lightens the demands on the database.

![Fig. 12.4 Detached Gramplet in the Dashboard View](image)

However, Gramplets can be undocked (detached, torn off) to float free from any of the three containers. When detached, an additional Help button in the lower left will open the Gramplet's page on this website. Clicking the X button in the upper right corner will re-docks a detached Gramplet. Clicking the similar X button of a docked Gramplet will remove it from the pane.

The Dashboard Category View

In the Dashboard, you can drag the Properties button (top left) of each Gramplet to reposition it in the Dashboard View area. You can click the Properties button to detach (or ‘undock’) the Gramplet from Dashboard View and place it in its own window. The window will stay open regardless of page (relationships, charts, etc). Closing the detached view will put it back onto the Dashboard view. If you quit Gramps with an open Gramplet, when you start gramps again, it will open automatically.

When one or more Gramplets are undocked from the Dashboard View, they remain visible as you change to a different View (such as the People or Charts View). In this way, you can use these Gramplets to supplement a particular View with additional details and functionality provided by the Gramplet.

You can add new Gramplets by right-clicking on an open space on Dashboard view. Click the X button above the Gramplet to remove it from the Dashboard.

Configurable Options
Fig. 12.5 View menu

You can also change the number of columns by changing a Gramplets Layout tab setting in Configure Dashboard window. To open the window, click the Configure... button, choose View ➪ Configure... from the View menu, or press the Configure active view keyboard keybinding.

Fig. 12.6 Gramplet Configuration tabs

Each Gramplet docked in the Dashboard will also have a Configuration tab added. (But the same Gramplet may not have any Configuration options or tab when docked in the Sidebar or Bottombar.) The Dashboard provides extra options for each Gramplet to allow it be renamed, set to a fixed vertical size, or be maximized vertically in its column. The Configuration tab for Gramplets in docked in the Dashboard reflect at least these minimum options.

Double-clicking the title of a Gramplet docked in the Dashboard Category allows you to change the display title.

The split-screen Sidebar & Bottombar

Fig. 12.7 Gramplet split-screens showing Gramplet Bar Menu with the unlabeled Down Arrowhead pull-down menu button

Each of these split screen panes is a container of stacked Gramplet tabs. Like Windows with a tabbed section, each can show only a single tab at a time. But tabs can be added, re-ordered, undocked or disabled in a similar fashion to the Dashboard. However, instead of a Contextual Menu, each split-pane Gramplet Bar Menu has a Down Arrowhead pull-down menu button to show the same pop-up list of options.

To add a Gramplet to the stacked tabs, select it from the Gramplet Bar Menu Add a gramplet submenu.

To undock a tab, grab the tab title and drag out of the split-pane. To re-dock, click the Close button or the 'X' button.

To remove the Gramplet from the stack tabs, select it from the Gramplet Bar Menu Remove a gramplet submenu. (Alternatively, the Close button will be accessible if the 'Show close button in gramplet tabs' checkbox in the Display tab of Preferences is selected.)

Curiously, the same Gramplets might be tabs in the different split-screen section of a View but be configured to show information differently. It is important to be aware that each Gramplet (whether stacked as a Tab or floating undocked) bogs down performance of Gramps. Use fewer Gramplets to make Gramps more responsive.
The lists of Gramplets that can be added to the stack of tabs in a split pane are filtered by those appropriate to that category.

Configurable Options

- Gramps

Want Additional Gramplets

<table>
<thead>
<tr>
<th>Gramplet</th>
<th>Dashboard</th>
<th>People</th>
<th>Relationships</th>
<th>Families</th>
<th>Charts</th>
<th>Events</th>
<th>Places</th>
<th>Geography</th>
<th>Sources</th>
<th>Citations</th>
<th>Repositories</th>
<th>Media</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>2-Way Fan Chart</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Age Stats</td>
<td>✦</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Age on Date</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Ancestors</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Attributes</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Calendar</td>
<td>✦</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Children</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Citations</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Descendant Fan</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Descendants</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Details</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Encloses</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Enclosed By</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Events</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Events Coordinates</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>FAQ</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Fan Chart</td>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
</tbody>
</table>

In addition, there are a number of Third party Gramplets that you can easily install and use. These include:

- Headline News Gramplet - current, breaking news from Gramps
- Data Entry Gramplet - edit active person's name, birth date and place, death date and place, and add people
- Python Gramplet - a Python shell
- FAQ Gramplet - frequently asked questions
- Note Gramplet - see and edit active person's primary Person Note

and many others. See Third-party Addons for more details.

Summary of Gramplets

Summary of all default built-in Gramplets and the view categories in which each gramplet can be used.

Independently for each Category view mode container, the Gramplets can be added or removed using the following controls:

- In the Dashboard Category, via the right-click context menu.
- In all other Categories, via the drop-down Gramplet selection menus (Down Arrowhead button) on either the Bottombar or Sidebar.

*There are no Menu options to add a Gramplet. This is because it would be ambiguous whether the Gramplet was to be added to that view mode's sidebar or bottombar.*

**Gramplet List**

Click a Category header (twice) to sort the list and show that category's menu of available built-in Gramplet choices. (The actual menu will also include installed 3rd-party add-on Gramplets.)
For more detailed information on using the installed Gramplets, see [Gramplets](#).

### Gramplets

This following sections describe each Gramplet and its basic functionality.

For more detailed information on using the installed Gramplets, see Gramplets.

**2-Way Fan Chart**

![2-Way Fan Chart](image)

Fig. 12.9 2-Way Fan Gramplet

**See also:**

- Gramplets:
  - [Fan Chart](#) (ancestor)
  - 2-way Fan Chart (ancestor and descendant)
  - Descendant Fan Chart

- Charts category view modes:
  - Fan Chart (ancestor)
  - 2-way Fan (ancestor and descendant)
  - Descendant Fan
### Age on Date

![Age on Date Gramplet](image)

The **Age on Date** Gramplet allows you to enter a *Calendar date* in the **Date** entry field. If you select the **Run** button, the Gramplet will compute the ages for everyone in your Family Tree living on that Date and will show the results in a separate Quick View report dialog. The date must be entered in a calendar format that Gramps accepts e.g: `YYYY-MM-DD`.

- No configuration options are available for this gramplet.

![Quick View - Age on Date](image)

From the resulting Quick View report dialog you can sort by the Person, Age or Status columns. Right clicking the row opens a context menu that allows you to *Copy all rows* to the clipboard; or to *See the person details* in the Person Editor, or *Make the person active*.

- You can also drag a date to from **Calendar Gramplet** to the **Age on Date** Gramplets **Date** entry field to enter that date.
- See also the **Third-party Addon Date Calculator Gramplet** which allows you to do date math.

### Age Stats
The Age Stats Gramplet shows statistics in the form of three text graphs grouped in 5 years age span breakdowns (use the vertical scroll bar to see the other two graphs):

- **Lifespan Age Distribution** - for all people having valid birth and death dates.
- **Father - Child Age Diff Distribution** - shows the age difference between child and father where both individuals have valid birth dates.
- **Mother - Child Age Diff Distribution** - shows the age difference between child and mother where both individuals have valid birth dates.

Rolling over a chart row will display a hint with the count of offspring matching the row's range.

Double-clicking a row in any of the statistics graphs opens a Quick Report of the offspring categorized by that row. You can sort the Quick Report by the Name, Birth Date and Name Type columns.

Right-clicking the Quick View report row displays a context menu for copying the list, opening the Person Editor or activating the person.

### Configurable Options

Adjustable graph scaling limits

- Maximum Age 1-150; *(110 default)*
- Maximum Age of mother at birth: 1-150; *(40 default)*
- Maximum Age of father at birth: 1-150; *(60 default)*
- Chart Width: 1-150; *(60 default)*

In the Dashboard View, the Gramplet may be detached by clicking the **Configure active view** button.

### See also

- An upgrade has been developed for the 5.2 version of Gramps. See the screen capture.
Ancestors

Fig. 12.14 Ancestors Gramplet - detached example

Gramplet showing active person's ancestors.

Attributes

Fig. 12.15 Attributes Gramplet

The Attributes Gramplet shows all of the attributes for the current, active person. Double click on the name of the attribute, and you will run a Quick View that shows all of the people that have that attribute, and the values for it. You can sort the Quick View by the attribute value by clicking on the column name.

Fig. 12.16 Attributes Gramplet - Quick View example result

In the Quick View, highlight the entry to change the active person (which will then change the Attributes Gramplet), and double-click the Quick View entry to bring up the Edit Person dialog window.

Person Attributes

See Attributes

Family Attributes

See Attributes

Event Attributes

See Attributes

Source Attributes

See Attributes

Citation Attributes

See Attributes
The **Calendar Gramplet** shows a monthly calendar.

Surrounding the **month** label at the top left corner, the `<` **previous** and `>` **next** buttons can be used to change the month.

Surrounding the **year** label at the top right corner, the `<` **previous** and `>` **next** buttons can be used to change the year.

Double-click a **day** to run the **On This Day** Quick View. The Quick View window shows up to 3 table sections, the events (if any exist) of: the exact date, other events on the same month/day in history, and events in that year.

You can also drag a day from the Calendar to the date fields (such as for the Event Editor or the Age on Date Gramplet) to enter that date. Similarly, a calendar day may also be dragged to the Clipboard where it will be stored in a plain text format.

### Localized Day of the week headers

The customary first day of the week can be shown on calendar and which vary culturally. The calendar adapts to the language setting.

The feature will be included in the 5.2 release but can patched manually. See the [Discourse forum discussion on the Calendar Gramplet](https://discourse.example.com/t/calendar-gramplet-discussion/1).

---

**Children**

Gramplet showing the active persons children.

How do I change the order of children? Use:

- The Family Editor **Children** tab to change the order of children in the family.
- The third party addon **Birth Order Tool** which allows bulk updates of the children order.

---

**Person Children**

See **Children**

Also shows the childs spouse if present.

**Family Children**

See **Children**
Citations

Fig. 12.19 Citation Gramplet - detached example
Gramplet showing the active persons citations.

Person Citations

See Citations

Family Citations

See Citations

Event Citations

See Citations

Place Citations

See Citations

Media Citations

See Citations

Descendant Fan Chart

Fig. 12.20 Descendant Fan (chart) Gramplet - detached example
Gramplet showing active person's direct descendants as a fan chart.

See also:

- Gramplets:
  - Fan Chart (ancestor)
  - 2-way Fan Chart (ancestor and descendant)
  - Descendant Fan Chart

- Charts category view modes:
  - Fan Chart (ancestor)
  - 2-way Fan (ancestor and descendant)
  - Descendant Fan

- Reports: Graphical reports:
  - Fan Chart... (ancestor)
Descendants

Fig. 12.21 Descendants Gramplet - detached example

The Descendants Gramplet shows the direct descendants of the active person.

The order of the spouses and children is that given in the Gramps editor. To change the order of spouses, click on Order on the Relationship view. To change the order of children, drag and drop them in the correct order in the Family edit window.

This Gramplet is based on the Descendant Report, available from the Textual Reports.

The Descendants Gramplet will update when you change the active person, or change family trees. It does not update automatically for edits or additions because this report is time-consuming to run.

Minimizing a Gramplet will prevent it from updating.

Moving the mouse over a person will show a tooltip summary which includes the death date.

Details

Fig. 12.22 Details Gramplet - detached example

Gramplet showing details of the active person.

Provides a brief non editable summary of the selected person for example:

- **Name**: of person
- **Also Known As**:
- **Other Name**:
- **Father**:
- **Mother**:
- **Birth**:
- **Death**:
- **Burial**:

- **Image**: If available the primary image will be shown to the right of the details, otherwise a cross will indicate the image is missing, you may double click the image to open it in an external viewer. To change the primary active image see: Edit Person Editors - Gallery tab

You may highlight and copy the individual text fields.

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Person Details

See Details

Place Details

See Details
Encloses

Fig. 12.23 Encloses Gramplet - detached example
Gramplet showing the locations of a place it encloses over time.

- See also Enclosed By tab

Encloses Place Locations

See Enclosed By

Enclosed By

Fig. 12.24 Enclosed By Gramplet - detached example
Gramplet showing the locations enclosed by a place over time.

- See also Enclosed By tab

Enclosed By Place Locations

See Encloses

Events

Fig. 12.25 Events Gramplet - detached example
Gramplet showing the events for the active person.
Double click a row to edit the event.
Person Events

See Events

Family Events

See Events

Events Coordinates

Fig. 12.26 Events Coordinates Gramplet - detached example

Gramplet showing the events coordinates for the active person.

Double click a row to edit the event.

Fan Chart

Fig. 12.27 Fan Chart Gramplet

The Fan Chart Gramplet shows the direct ancestors of the active person in a circular format. It is similar to the Pedigree View, but shown around the center/active person, and further generations spiralling out.

Click on a parent in the chart and they will expand or contract above their child. Right-click on a person and you can:

- select that person to be the active person
- edit the person which allows through Person Editor add children to person's families
- select from among the person's relatives to be the active person
- add partners (families) to person
- copy name, birth and death of person into clipboard

Clicking in an open area (non-person) and dragging the mouse will allow you to rotate the chart about the center. You may also left-click and drag in the center to reposition the fan chart.

A black edge on the outer radius of the chart indicates more parents for that person. A black circle in the center indicates that the center person has children.

The Fan Chart Gramplet will update when you change the active person, or change family trees.

Minimizing a Gramplet will prevent it from updating.

See also:

- Gramlets:  
  - Fan Chart (ancestor)  
  - 2-way Fan Chart (ancestor and descendant)  
  - Descendant Fan Chart

- Charts category view modes:  
  - Fan Chart (ancestor)  
  - 2-way Fan (ancestor and descendant)  
  - Descendant Fan

- Reports : Graphical reports:  
  - Fan Chart... (ancestor)
FAQ

The FAQ Gramplet (Frequently Asked Questions) shows a list of common questions, and links to their answers from the Gramps Wiki (requires an internet connection).

This gramplet shows a manually curated list of Frequently Asked Questions hyperlinked to answers in articles of the Gramps wiki. The list is collated from new user postings to the Gramps User maillist that must be answered repeatedly.

The idea is to make the answers to the most common question easier to find, the primary objective is to let new users start using Gramps more quickly.

See Also

- Bug Report 11742: Dashboard FAQ links are obsolete (resolved)
- Bug Report 11997: how to add/update FAQs

Filter

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Gramplet providing a filter specific to the Category.

See also Which filters in which Category?

Person Filter
This article's content is incomplete or a placeholder stub. Please update or expand this section.

See Filter

Family Filter

See Filter

Event Filter
This article's content is incomplete or a placeholder stub. Please update or expand this section.

See Filter

**Place Filter**

![Filter Gramplet](image)

Fig. 12.32 Place - Filter Gramplet - detached - default

This article's content is incomplete or a placeholder stub. Please update or expand this section.

See Filter

**Source Filter**
Fig. 12.33 Source - Filter Gramplet - detached - default

This article's content is incomplete or a placeholder stub.
Please update or expand this section.

See Filter

Citation Filter

Fig. 12.34 Citation - Filter Gramplet - detached - default

This article's content is incomplete or a placeholder stub.
Please update or expand this section.

See Filter

Repository Filter
This article's content is incomplete or a placeholder stub.
Please update or expand this section.

See Filter

Media Filter

See Filter

Notes Filter
Fig. 12.37 Notes - Filter Gramplet - detached - default

This article's content is incomplete or a placeholder stub.
Please update or expand this section.

See Filter

Gallery

Fig. 12.38 Gallery Gramplet - detached example
Gramplet showing media objects. The first image is the primary active media object that is used in reports and the Edit Person dialog.

This article's content is incomplete or a placeholder stub.
Please update or expand this section.

See also Gallery tab for Edit Person dialog where you can change which image is the primary active media object for reports etc...

Person Gallery
See Gallery

Family Gallery
See Gallery

Event Gallery
See Gallery

Place Gallery
See Gallery

Source Gallery
See Gallery

Citation Gallery

Gramplets - Gramplets
Given Name Cloud

Like the Surname Cloud Gramplet, the Given Name Cloud Gramplet shows the top most popular given names in your family tree. The size of the name indicates how popular it is. Mouse over the name to see the exact count, and the percent of people in the family tree that have that name.

The Gramplet splits up given names into words (broken up by spaces). For example "Sarah Elizabeth" would appear under both "Sarah" and "Elizabeth".

Double-click on the given name to bring up a Quick View of all of the matching people.

Image Metadata

The Image Metadata Gramplet offers an interface to look at Image Exif Metadata from your images (*.jpg, *.png, *.tiff, *.exv, *.nef, *.psd, *.pgf). See also the third party:

- Addon: Edit Image Exif Metadata

Prerequisites

Special Note

Before being able to use this Gramplet/Addon, you will need to download and install gexiv2 or install gexiv2 from your local Linux repository. MS-Windows users, this is depends on which installer you used. Ubuntu, use the Universe repository to find gexiv2. Also see GExiv2 for Image metadata

Once you have installed gexiv2, see above for directions to download and install this addon...

Pyexiv2 can be used from the command line interface (cli) as well, and from within a python script:
1. import the pyexiv2 library
   
   from pyexiv2 import ImageMetadata, ExifTag

2. specify your image
   
   image = ImageMetadata("/home/user/image.jpg")

3. read the image
   
   image.read()

Exif, IPTC, XMP metadata reference tags can be found [here](#).

Example:

```python
image["Exif.Image.Artist"] # Artist
Smith and Johnson's Photography Studio

image["Exif.Image.DateTime"] # DateTime
1826 Apr 12 14:00:00

image["Exif.Image.DateTime"] = datetime.datetime.now() # Add DateTime

image.write() # write the Metadata
```

Usage scenario

The preferred way to use this addon is:

1. install pyexiv2
2. Install this addon
3. Restart Gramps
4. Click Views from the Menu bar, and select Media Views
5. Open the Side Bar
6. Slide the available empty right view to about half the screen.
7. Right click text to the Side Bar tab, and select Add a Gramplet
8. Select Image Metadata Gramplet
9. Select an image from the left hand MediaView

Media Preview

![Media Preview Gramplet](#)

Fig. 12.41 Media Preview Gramplet - detached example

Gramplet shows a preview of a single media object. See Media Category

Notes
Fig. 12.42 Notes Gramplet - detached example

Gramplet showing the active persons notes.

See also:
- [Note Gramplet - Third party Addon](#)

**Person Notes**

See [Notes](#)

**Family Notes**

See [Notes](#)

**Event Notes**

See [Notes](#)

**Place Notes**

See [Notes](#)

**Source Notes**

See [Notes](#)

**Citation Notes**

See [Notes](#)

**Repository Notes**

See [Notes](#)

**Media Notes**

See [Notes](#)

**Pedigree**

Fig. 12.43 Pedigree Gramplet - detached example

The Pedigree Gramplet shows a compressed view of the active person's direct ancestors. It defaults to going back 100 generations. The names can be clicked to change the active person, right-click to edit the person. At the bottom of the Gramplet the number of people per generation is listed. Birth and death dates are shown next to each person's name. Double-click the Generation number to see the matching individuals.
Using the content of the Pedigree in another program requires a bit of effort. Open a contextual pop-up menu by right-clicking anywhere in the gramplet except a hotlink. Or, you can begin a drag selection from the same inert areas. Copy the highlighted text to the OS clipboard from that same context menu. (The keybinding for 'Copy' will not work.) When you paste the text into another text editing program, you may need change the font to a non-proportional font to preserve the indentation. Some online services collapse leading spaces when you post a chunk of text. Preserving the indentation for such services may require replacing doubled spaces with doubled placeholder characters... like periods/full stops.

**Configurable Options**

- Maximum generations: 1 to 100 limit; (default: **100**)
- Show Dates checkbox; (default: deselected)
- Line Type menu: UTF, ASCII; (default: **UTF**)

**Quick View**

![Quick View Gramplet - detached example](image)

Fig. 12.44 Quick View Gramplet - detached example

The Quick View Gramplet allows Quick View reports to update dynamically. Instead of a window with a static report, the gramplet updates different active record is selected within the target Category. (When this Gramplet was introduced, it only offered choosing Quick View Reports from the People category. A Configuration pop-up menu to select View categories has since been added.)

You can run any of the built-in Quick Views or add-on QuickView reports.

![Quick View Gramplet - Configuration tab shown](image)

Fig. 12.45 Quick View Gramplet - Configuration tab shown

You can change the options by clicking the Option button (top, left hand button of the Gramplet) which will detach the Gramplet and bring it up an a window. Select **Options** on the top row, and a list of options will appear. Press **Save** to apply the changes to the Quick View. You may then close the window to reattach the Gramplet.

See the following developer information if you are interested in creating your own:

- [Making your own Quick view](#)

**Records**
The Records Gramplet shows a number of interesting facts about the records (mostly age related) from your database. The list shows the top three for each element.

- **Person Records:**
  - Youngest living person
  - Oldest living person
  - Person died at youngest age
  - Person died at oldest age
  - Person married at youngest age
  - Person married at oldest age
  - Person divorced at youngest age
  - Person divorced at oldest age
  - Youngest father
  - Youngest mother
  - Oldest father
  - Oldest mother

- **Family Records**
  - Couple with most children
  - Living couple married most recently
  - Living couple married most long ago
  - Shortest past marriage
  - Longest past marriage

The list is not only interesting on its own, it is also a good sanity check of the data. For some items you have to fill in some additional information.

This following example shows that there was a marriage event (thus calculation of the offset) but none of the persons had a death event. Even if the date is not known, just enter a death event for one of the partners and the list will be corrected.

**Living couple married most long ago**

1. van Dosselaere, Egidius and Rechters, Petronella (382 years, 1 month)
2. de Richter, Petrus and Asscericx, Catharina (379 years, 9 months)

An identical [Records Report](#) is also available.

**References**

Grammar showing the active persons References.
This Gramplet shows all direct relatives of the active person. It's intended use is as a navigation help, an alternative way to move through your family tree in Gramps. If you detach the Gramplet, and place it next to Gramps, it will allow you to use it to easily change the content of the current "Person view".

If you are working in the charts category Pedigree view, the active person is the left-most person. By clicking a name in the relatives Gramplet, you can easily change the active person, and all person view in the other window will update. As the relatives Gramplet shows all spouses, all children and all parents, this offers an alternative way of navigating your data.

The names in this Gramplet also allow you to call up the person editor directly, by right-clicking on any of the names.
The Relatives Gramplet can be added to the following categories:

- People Category
- Relationships Category
- Charts Category
- Geography Category (selected views only)

**Residence**

![Residence Gramplet - Gramps](image)

**Fig. 12.49 Person - Residence Gramplet - detached - example**

Gramplet showing residence events for the active person

**Person Residence**

![Person Residence Gramplet - Gramps](image)

See [Residence](#)

**Session Log**

![Session Log Gramplet - Gramps](image)

**Fig. 12.50 Session Log Gramplet - detached example**

The session log keeps track of activity in this session. It lists selected and edited objects.

Click a name once to make this person the active person. Double-click on a name or family brings up the edit page for that object. In addition, if you want to edit a person, but don't want to change the active person, you can right-click on the person's name.

This Gramplet is handy because you can very quickly change the active person, or edit the object, from the session list.

**SoundEx**
This Gramplet generates SoundEx codes for the names of people in the database.

From the **SoundEx Gramplet** window you can either choose a Name: from the pop-up menu shown by selecting the down ▼ arrowhead, (triangle) or you can type a name into the text field.

The name you type in can be any name... even a name not present in your Family Tree.

The result is shown automatically eg: The SoundEx code for **Simpson** is S512

A **Help** button is available which brings you to this page. With the **Close** button (or using the keyboard shortcut Alt + C) you dismiss the **SoundEx Gramplet** window.

### Soundex what is this?

Soundex is the most widely known of all [phonetic algorithms](https://en.wikipedia.org/wiki/Phonetic_algorithm) which allow indexing of words by their sound, as pronounced in English. Soundex support is included with searching via a Soundex match of People with the <name> Custom Filter rule, a **Soundex Gramplet**, and as a quality control for matching in the Find Possible Duplicate People tool.

The Soundex equivalent is a coded surname (last name) index based on the way a surname sounds rather than the way it is spelled. Surnames that sound the same, but are spelled differently, like SMITH and SMYTH, have the same code and are filed together. The Soundex coding system was developed so that surnames may be found even when recorded under variant spellings.

First applied to the 1880 US Census, Soundex is a "sound index", not a strictly alphabetical one. The key feature is that it codes surnames (last names) based on the way a name sounds rather than on how it is spelled. The Soundex phonetic coding system pre-dates computers and was to help researchers find a surname quickly even though it may have received different spellings.

Those doing census lookups must use the same method to encode and tabulate surnames as the census workers did when they generated the database.

To search for a particular surname, you must first work out its encoding equivalent.

#### Basic Soundex Coding Rule:

Every Soundex code consists of a letter and three numbers, such as W-252. The letter is always the first letter of the surname. The numbers are assigned to the remaining letters of the surname according to the Soundex guide shown below. Zeros are added at the end if necessary to produce a four-character code. Additional letters are disregarded. Examples: Washington is coded W-252 (W, 2 for the S, 5 for the N, 2 for the G, remaining letters disregarded). Lee is coded L-000 (L, 000 added).

| Number Represents the Letters | 1 | B, F, P, V |
|                             | 2 | C, G, J, K, Q, S, X, Z |
|                             | 3 | D, T |
|                             | 4 | L |
|                             | 5 | M, N |
|                             | 6 | R |

Disregard the letters A, E, I, O, U, H, W, and Y.

#### Additional Soundex Coding Rules:

- **Names With Double Letters**: If the surname has any double letters, they should be treated as one letter. For example:
  - Gutierrez is coded G-362 (G, 3 for the T, 6 for the first R, second R ignored, 2 for the Z).
- **Names with Letters Side-by-Side that have the Same Soundex Code Number**: If the surname has different letters side-by-side that have the same number in the Soundex coding guide, they should be treated as one letter. Examples:
  - Pfister is coded as P-236 (P, F ignored, 2 for the S, 3 for the T, 6 for the R).
  - Jackson is coded as J-250 (J, 2 for the C, K ignored, S ignored, 5 for the N, 0 added).
  - Tymczak is coded as T-522 (T, 5 for the M, 2 for the C, Z ignored, 2 for the K). Since the vowel "A" separates the Z and K, the K is coded.
- **Names with Prefixes**: If a surname has a prefix, such as Van, Con, De, Di, La, or Le, code both with and without the prefix because the surname might be listed under either code. Note, however, that Mc and Mac are not considered prefixes. For example, VanDeusen might be coded two ways: V-532 (V, 5 for N, 3 for D, 2 for S) or D-250 (D, 2 for the S, 5 for the N, 0 added).
- **Consonant Separators**: If a vowel (A, E, I, O, U) separates two consonants that have the same Soundex code, the consonant to the right of the vowel is coded. Example: Tymczak is coded as T-522 (T, 5 for the M, 2 for the C, Z ignored (see "Side-by-Side" rule above), 2 for the K). Since the vowel "A" separates the Z and K, the K is coded. If "H" or "W" separate two consonants that have the same Soundex code, the consonant to the right of the vowel is not coded. Example: Ashcraft is coded A-261 (A, 2 for the S, C ignored, 6 for
the R, 1 for the F). It is not coded A-226.

Please visit the [NARA Soundex Indexing page](#) to learn more about Soundex Indexing System.

**Statistics**

![Statistics Gramplet](image)

Fig. 12.52 Statistics Gramplet - detached example

The Statistics Gramplet runs a Statistics report. Double-click the phrases to bring up the matching items.

Following information is provided to you in this Gramplet:

- **Individuals**
  - Number of individuals
  - Males
  - Females
  - Individuals with unknown gender
  - Incomplete names
  - Individuals with missing birth dates
  - Disconnected individuals

- **Family information**
  - Number of families
  - Unique surnames

- **Media objects**
  - Individuals with media objects
  - Total numbers of media object references
  - Number of unique media objects
  - Total size of media objects
  - Missing Media Objects

As with all Gramplets if you click on the left hand side Tool button you detach the window and if you add persons to your family tree, you will see the amount of individuals change dynamically.

The information given in this Gramplet is the same as in the [Database Summary Report](#)

**Surname Cloud**

![Surname Cloud Gramplet](image)
The Surname Cloud Gramplet shows the top 100 (by default) used surnames. The name font size is proportional to the amount of people with the same name.

Double-click a surname to run the **Same Surnames Quick View**. This will open the **Quick View** window where you can find all people with a matching or alternate name. Person, birth date and name type are given.

If you mouse over the name you see the percentage of occurrence and total counts.

You can change the number of names displayed by configuring the view for this gramplet.

### To Do

The **To Do Gramplet** displays a free form text area showing the contents of Note objects of the "To Do" type.

You can use this area to put some notes, remarks, things you should to get your research going. There are several other To Do programs (e.g. Tomboy e.a.) but these Gramplets are useful as the information stays within the Gramps database.

To Do Gramplets allow you to create notes and attach them to Gramps objects. For example, you can add a Person To Do Gramplet to the sidebar of the Person View. Notes added using this Gramplet will be attached to the currently active person. There is a To Do Gramplet for each Gramps primary object type.

See also the experimental **Third-party Addon**:

- **ToDo Notes Gramplet** available for the Dashboard that lists all To Do notes in the database, together with the object to which they are attached.

### Person To Do

See **To Do**

### Family To Do

See **To Do**
The Top Surnames Gramplet shows the top 10 (by default) used surnames. The top ten is presented as follows:

- **Surname**
- **percentage**
- **occurrences**

The list gives you also the Total unique surnames in the database as well as the total number of people in your database.

Double-click a surname to run the *Same Surnames Quick View*. This opens the *Quick View* window, which gives the people with the surname you double-clicked.

A table is presented which shows all people with a matching name or alternate name. Person's name, ID, birth date and name type is given.

**Advanced:**

- Change the number of names displayed by editing this section in `~/.gramps/gramps50/gramplets.ini`

**Uncollected Objects**
Diagnostic Tool

This option is only available when Gramps has been started using developer mode switch. It is not intended for general use and has limited safeguards.

Fig 12.57 Uncollected Objects Gramplet - detached example

The Uncollected Objects Gramplet is intended to list the low-level Python objects that are left around in memory and cannot be (easily) automatically deleted when they are no longer in use. Developers use it to try to identify the source of memory 'leaks', which cause Gramps to continually use more and more memory, the longer it is used.

Because the tool is trying to display objects that might still be getting deleted, it sometimes has some trouble.

Welcome

Fig. 12.58 Welcome Gramplet - detached example

The Welcome to Gramps! Gramplet gives an introductory message to new users, and some basic instructions.

The welcome message describes what Gramps is, that the program is Open Source Software and how you start a Family Tree.

What's Next

Fig. 12.59 What's Next? Gramplet - detached example

The What's Next Gramplet displays a list of the "most urgent" information gaps in your family tree. It is based on the following assumptions:
- The Home Person defines the focus
- Searches for gaps begin with the Home Person's descendants and work up the tree
- The tree is expected to contain the given name, surname, birth date and place, and death date and place of each person
- You want to know parents, their marriage date and place, and - if divorced - divorce date and place of each family with married parents
- You want to know at least the mother of each family with unmarried parents
- The closer the relationship to the Home Person, the more "urgent" the information gap is.
- The closer the common ancestor is from the main person, the more "urgent" the information is (e.g. nephews are considered more "urgent" than uncles, even though both have a distance of 3 generations, because for nephews the common ancestor is father/mother, while for uncles, the common ancestor is grandfather/grandmother)
- Marriage data and personal data of the spouse is slightly less "urgent" than personal data of the directly related person
- Half-siblings are less "urgent" than siblings

You may copy the text from inside of this Gramplet by selecting it and pasting into an empty document.

![Fig. 12.60 What's Next? Gramplet - Configuration tab shown](image.png)

The Gramplet can ignore previously verified events by making use of some custom Tags. The tags are selected in the Gramplets configuration. For example you can tag the following to be ignored:

- that a person is complete
- that a family is complete
- that a person or family should be ignored for shortening lists
Reports

This section describes all the different reports available in Gramps.

Gramps comes with a large number of available reports. The different subsections describe the various possibilities and options:

### Additional Reports

Gramps has even more reports available to install, made by volunteers just like you they are called Addons and you check the growing list of available reports [here](#). This system is controlled by the Plugin Manager.

### Introduction

**Generating Reports:** This first subsection gives you some general remarks.

### Reports

The reports can be accessed by choosing the menu Reports -> Report Section -> Particular Report.

Alternatively, you can browse the complete selection of available reports along with their brief descriptions in a Report Selection dialog invoked by clicking the Open the reports dialog icon on the toolbar from any of the categories.

### Report Selection dialog

The Report Selection dialog allows you to browse the complete selection of available reports along with their brief descriptions when invoked by clicking the Open the reports dialog icon on the toolbar from any of the categories and using the ▶ arrows to expand the listings.
Substitution Values

Substitution Values: you can use some handy values in your reports. (Selected reports only)

Books

The Books Report allows you to create a custom genealogy book containing a collection of Gramps textual and graphical reports in a single document (i.e. a Book).

Available items selections

Alphabetical Index

Alphabetical Index - This item produces page(s) with an alphabetical index of people noted into selected textual reports.

Custom Text

Custom Text - This item produces a page with three paragraphs, each containing custom text: Initial Text, Middle Text and Final Text. The text input fields are expandable so you can really put all the text you want in there.

Table Of Contents

Table Of Contents - A Table of contents (TOC) is generated for book as a list of the parts of a book or document organized in the order in which the parts appear.

Title Page

Title Page - A title page for your book.

Graphs

Graphs reports are created in Graphviz format and then converted into graphical output running it through the Graphviz dot tool behind the scene.

Family Lines Graph

The Family Lines Graph creates an easy-to-follow graph.

Hourglass Graph

The Hourglass Graph generate an hourglass graph.

Relationship Graph

The Relationship Graph creates a complex relationship graph.

Graphical Reports

Graphical reports represent information in forms of charts and graphs.

Ancestor Tree

The Ancestor Tree report generates the chart of people who are ancestors of the Active Person.

Calendar

The Calendar report produces a calendar with birthdays and anniversaries on a page by month.

Descendant Tree
The **Descendant Tree report** generates a graph of people who are descendants of the Active Person.

**Descendants Lines**

Addon:DescendantsLines - 3rd Party Addon.

**Family Descendant Tree**

The **Family Descendant Tree** generates a graph of people who are descendants of the Active Family.

**Family Tree**

Addon:FamilyTree - 3rd Party Addon.

**Fan Chart**

The **Fan Chart report** produces a chart resembling a fan, with Active Person in the center, parents the semicircle next to it, and so on, for a total of five generations.

See also

- Gramplets:
  - Fan Chart (ancestor)
  - 2-way Fan Chart (ancestor and descendant)
  - Descendant Fan Chart

- Charts category view modes:
  - Fan Chart (ancestor)
  - 2-way Fan (ancestor and descendant)
  - Descendant Fan

- Reports : Graphical reports:
  - Fan Chart... (ancestor)

**Pedigree Chart**

Addon:PedigreeChart - 3rd Party Addon.

**Statistics Charts**

The **Statistics Charts report** can collect and display a wealth of statistical data about your database.

**Timeline Chart**

The **Timeline Chart report** outputs the list of people with their lifetimes represented by intervals on a common chronological scale.

**Text Reports**

Text reports output information as formatted text.

**Ahnentafel Report**

The **Ahnentafel Report** lists the Active Person and his or her ancestors along with their vital data. The people are numbered in an establish standard called 'Ahnentafel'.

**Ancestor fill Report**


**Birthday and Anniversary Report**

The **Birthday and Anniversary Report** gives the same information as a calendar but in text format.

**Complete Individual Report**

The **Complete Individual Report** provides individual summaries similar to that of the Individual Summary Report.

**Database Differences Report**


**Database Summary Report**

The **Database Summary Report** displays the overall statistics concerning number of individuals of each gender, various incomplete entries statistics,
as well as family and media statistics.

**Descendant Book**

Addon:Descendant and Detailed Descendant Book Reports - 3rd Party Addon.

**Descendant Report**

The Descendant Report presents the descendants of the Active Person with a brief description in intended style.

**Detailed Ancestral Report**

The Detailed Ancestral Report covers in detail the ancestors of the Active Person, including a range of vital data as well as marriages.

**Detailed Descendant Book**

Addon:Descendant and Detailed Descendant Book Reports - 3rd Party Addon.

**Detailed Descendant Report**

The Detailed Descendant Report covers in detail the descendants of the Active Person by generation, following the genealogical tradition of textual descendant reports by generation. It aims to provide all important features expected to be found in these classic descendency formats and has received influence from various sources.

**Detailed Descendant Report with all Images**


**Double Cousins**


**End of Line Report**

The End of Line Report provides a list of the person's last known ancestors with the pedigree line, ordered by generations.

**Family Group Report**

The Family Group Report creates a family group report, showing information on a set of parents and their children.

**Family Sheet Report**


**Kinship Report**

Kinship Report provides the kinship of selected person according to level search (height, down generations) set by the user.

**Last Change Report**

Addon:LastChange - 3rd Party Addon.

**Lines of Descendancy Report**


**Media Report**


**Note Link Report**

The Note Link Report checks the status of internal Gramps links in notes.

**Number of Ancestors Report**

The Number of Ancestors Report displays the number of ancestors of the Active Person. The form is - generation x has y individuals (z %).

**PersonEverything Report**


**Place Report**

The Place Report produces a report according to places selected by the user. It will list related person and event to the selected place.
Records Report
Records Report shows a number of interesting records (mostly age related) in your database, like oldest living person, youngest mother, etc.

Repositories Report
Repositories Report - 3rd Party Addon.

Repositories Options Report
Repositories Options Report - 3rd Party Addon.

Sandclock Tree Report
Sandclock Tree Report - 3rd Party Addon.

Sources and Citations Report
Sources and Citations Report - 3rd Party Addon.

Tag Report
The Tag Report lists primary objects - persons, families, and notes - who match the selected tag.

TinyTafel Report
TinyTafel Report - 3rd Party Addon.

ToDo Report
ToDo Report - 3rd Party Addon.

Web Pages
Web Pages for use on your personal website or to give away as a standalone report.

Narrated Web Site
One of the reports in this category is the Narrated Web Site report. It generates a web site (that is, a set of linked web pages), for a set of selected individuals.

Web Calendar
The Web Calendar is a Report that creates webpages showing events for the selected individuals as a set of monthly calendars.

Dynamic Web Report
The Dynamic Web Report Addon creates interactive web pages of the family tree database with options allowing a wide range of customization.
This addon is based on the Narrative Web Report native Gramps report.

This section is a placeholder.
Addons don't belong in this part of the manual. This section was created to compensate for an incorrect address used by the Help button in the addon and has been corrected as of the 0.0.82 version released 3 Jan 2020. The new version links to the actual webpage for the Dynamic Web Report.

See Also
- Web Solutions for Gramps

Quick Views
Quick Views are reports that are available in the context menus of person, family, ... They may be created by users, even with limited programming knowledge.
Generating Reports

Reports are the most common form of the output produced by genealogical research. The majority of genealogical software puts a lot of emphasis on developing nice looking reports. Gramps is no exception in this regard, offering a choice of a variety of reports. Gramps can generate reports in a multitude of open formats, both text based and graphical. Gramps can also produce screen based reports that are convenient for viewing a summary of your database. Finally, Gramps can generate a web site suitable for immediate posting on the Internet.

All reports can be accessed by choosing the menu Reports -> Report Type -> Particular Report. Alternatively, you can browse the complete selection of available reports along with their brief descriptions in a Report Selection dialog invoked by clicking the Reports icon on the toolbar.

Report Settings

The settings chosen when generating a report is stored in the users profile in .gramps/report_options.xml, and will be used as default settings when generating the next report.

If there is a need to revert to the default report options for any reason, the file report_options.xml can be deleted.

Report Format Style

All of the reports are very flexible. If you wish to modify or extend the default format of Gramps reports, you can design and choose the style for each of your reports. Gramps provides an advanced interface for customizing practically every aspect of report-styles, e.g. for fonts: type face, size, color and style; for paragraphs: alignment, background color, indentation, spacing, and borders.

See:
- Customize report output formats
This section describes the substitution values that can be used in the different reports available in Gramps.

**Substitution Values**

Many of the graphical reports allow you to customize the information that is displayed on the reports. Variable substitution is the method that is used to substitute a particular symbol (key) for specific information about the person in the database.

For example:

<table>
<thead>
<tr>
<th>Substitution Keys</th>
<th>Will show as: (the person is alive)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line 1 $n</td>
<td>Line 1 Smith, Edwin Michael</td>
</tr>
<tr>
<td>Line 2 b. $b{ at $B}</td>
<td>Line 2 b. 1961-05-24 at San Jose, Santa Clara Co., CA</td>
</tr>
<tr>
<td>Line 3 d. $d&lt; at &gt;$D</td>
<td>Line 3 d.</td>
</tr>
</tbody>
</table>

In the next section a list of all available variables (The Substitution Keys) follows.

- If you wish to display names, date, or place information differently, you may use Format Strings to accomplish this.
- There are also Control Variables to display special characters (like the dollar sign).
- You can also use Grouping to optionally display information. In the example above Line 2, uses grouping to display ‘at’ only when the birth place is known.
- Along with Events you can print almost anything.
- Finally, Separators, to make your life complete. In the example above Line 3, uses this to display ‘at’ only when both the birth date and place is known.

### The Substitution Keys

<table>
<thead>
<tr>
<th>Personal variables</th>
<th>Marital variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>$n</td>
<td>Displays the person's name</td>
</tr>
<tr>
<td>$s</td>
<td>Displays the name of the person's spouse</td>
</tr>
<tr>
<td>$i</td>
<td>Displays the Gramps ID for the person.</td>
</tr>
<tr>
<td>$j</td>
<td>Displays the Gramps ID for the marriage.</td>
</tr>
<tr>
<td>$b</td>
<td>Displays the person's date of birth</td>
</tr>
<tr>
<td>$m</td>
<td>Displays the marriage date of the person and the spouse.</td>
</tr>
<tr>
<td>$Sb</td>
<td>Displays the person's place of birth</td>
</tr>
<tr>
<td>$Sm</td>
<td>Displays the place of the marriage of the person and the spouse.</td>
</tr>
<tr>
<td>$sd</td>
<td>Displays the person's date of death</td>
</tr>
<tr>
<td>$Md</td>
<td>Displays the place of the divorce of the person and the spouse.</td>
</tr>
<tr>
<td>$d</td>
<td>Displays the person's date of death</td>
</tr>
<tr>
<td>$v</td>
<td>Displays the divorce date of the person and the spouse.</td>
</tr>
<tr>
<td>$D</td>
<td>Displays an attribute about the person.</td>
</tr>
<tr>
<td>$V</td>
<td>Displays an attribute about the marriage.</td>
</tr>
<tr>
<td>$a</td>
<td>Displays event information about the person.</td>
</tr>
<tr>
<td>$u</td>
<td>Displays event information about the marriage.</td>
</tr>
<tr>
<td>$e</td>
<td>Displays event information about the person.</td>
</tr>
<tr>
<td>$t</td>
<td>Displays the description by default</td>
</tr>
</tbody>
</table>

All of the Marital variables are defined by the person's preferred spouse in Gramps. If the person has never been married, then these variables will not display anything.

### Other Substitution Keys

- $T Displays Todays date.

### Default displayed formats

<table>
<thead>
<tr>
<th>Variables</th>
<th>Display format</th>
</tr>
</thead>
<tbody>
<tr>
<td>$n $s</td>
<td>Names will be displayed as set in 'Name format:' on the Display tab in Gramps preferences</td>
</tr>
<tr>
<td>$b $d $Sb $M $d</td>
<td>Places will display the Place title by default</td>
</tr>
<tr>
<td>$b $d $Sm $s ST</td>
<td>Dates will be displayed as set in 'Date format:' on the Display tab in Gramps preferences</td>
</tr>
<tr>
<td>$e $t</td>
<td>Events will display the description by default</td>
</tr>
</tbody>
</table>

### Deprecated variables

Some of the old variables were deprecated because Format Strings have replaced them. So here is a list of those variables and how to achieve their results:

<table>
<thead>
<tr>
<th>Old Variable How to display it now</th>
<th>What is displayed</th>
</tr>
</thead>
</table>
Format Strings

Format strings are used to display names and dates differently than those assigned under Gramps Preferences. Here is the syntax for a format string:

$ key (format string)

where: key is one of the following characters: 'n$sijbmBMdvDVauet'

A format string is any text, separators or format codes (defined below) to display information about the person.

Formatting names

For names ($n $s) you may use the following formatting codes to display the name differently.

- t Title
- f Given name
- x Common name. Call name if existing, otherwise first first name
- c Call name
- n Nick name
- s Suffix
- l Surname
- g Family nickname

These codes can be upper-cased to uppercase the result.

For example:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>Displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>$n(L, f) ($n(c)), $n(L, f){ ($n(c))}</td>
<td>SMITH, Edwin Michael (), SMITH, Edwin Michael Janice Ann Adams</td>
</tr>
</tbody>
</table>

Note:

If you want to print a character 'c' within the format string (or any one of the other format codes), you will need to first add a \` in front of it. See Control Variables for more.

Note:

The curly brackets { } are used to hide information. Here it is used around \` ($n(c))` to not display \` ()` if the person does not have a call name. See Grouping for more.

Formatting Dates

For all of the date variables ($b $d $m $v) you may use the following formatting codes:

- yyyy The year as a four digit number
- yy The year, from 00 to 99
- mmmm The full name of the month
- mmm The abbreviated name of the month
- MMMM The full name IN CAPS
- MMM The abbreviated name IN CAPS
- mm The month, from 00 to 12
- dd The day, from 00 to 31
- o The date type (modifier)

For example:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>$b(yyyy)</td>
<td>Date of birth, year only</td>
</tr>
<tr>
<td>$d(yyyy)</td>
<td>Date of death, year only</td>
</tr>
<tr>
<td>$m(yyyy)</td>
<td>Date of preferred marriage, year only</td>
</tr>
<tr>
<td>$f(yyyy)</td>
<td>Preferred spouse's name as by Gramps name display under Preferences</td>
</tr>
<tr>
<td>$g(yyyy)</td>
<td>Preferred spouse's name - LastName, FirstName</td>
</tr>
<tr>
<td>$g(f, g)</td>
<td>Preferred spouse's name - LastName in UPPER case, FirstName</td>
</tr>
<tr>
<td>$s(yyyy)</td>
<td>Preferred spouse's name as by Gramps name display under Preferences</td>
</tr>
<tr>
<td>$s(f, g)</td>
<td>Preferred spouse's name - LastName, FirstName</td>
</tr>
<tr>
<td>$s(g, f)</td>
<td>Preferred spouse's name - LastName in UPPER case, FirstName</td>
</tr>
<tr>
<td>$s(f, g)</td>
<td>Preferred spouse's name - LastName, FirstName</td>
</tr>
<tr>
<td>$s(g, f)</td>
<td>Preferred spouse's name - LastName in UPPER case, FirstName</td>
</tr>
<tr>
<td>$s(f l s)</td>
<td>Janice Ann Adams</td>
</tr>
<tr>
<td>$s(f l s)</td>
<td>Smith, Edwin Michael ()</td>
</tr>
</tbody>
</table>

Reports - part 2 - Substitution Values
For date types (modifier)

Only "Before", "After", and "About" are supported at this time. all others will not display anything. And for date span and date ranges, only the starting (first) date is displayed.

Formatting Places

For all of the place variables ($B $D $M $V) you may use the following formatting codes:

- $e Street
- $l Locality
- $c City
- $u County
- $s State
- $p Postal Code
- $n Country
- $t Title
- $x Longitude
- $y Latitude

These codes can be upper-cased to uppercase the result.

For example:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>$B</td>
<td>St Judes Hospital</td>
</tr>
<tr>
<td>$B(c, s, N)</td>
<td>Carmel, IN, USA</td>
</tr>
</tbody>
</table>

Rules for format strings

- Anything will print inside a format string
- You need to use Control Variables to display things like `)` and format codes
- Separators can be within format strings.
- At least ONE format code has to display something for the ENTIRE format string to display

For examples:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>$n(f l)</td>
<td>Edwin Michael Smith</td>
</tr>
<tr>
<td>b. $B {at $B {d. $d $D</td>
<td>b. 1961-05-24 at San Jose, Santa Clara Co., CA</td>
</tr>
<tr>
<td></td>
<td>The person is still alive (or has no information present) so the line was removed.</td>
</tr>
</tbody>
</table>

Control Variables

Control variables allow you to print characters that are special to Substitution values within a display.

For example the dollar character '$' is used to note the start of a variable. If you wish to print a dollar character you would use a control character like '\$'

<table>
<thead>
<tr>
<th>Control Variables</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$</td>
<td>Displays a single '§'</td>
</tr>
<tr>
<td>\</td>
<td>Displays a single ''</td>
</tr>
<tr>
<td>(</td>
<td>Displays a single '('</td>
</tr>
<tr>
<td>)</td>
<td>Displays a single ')'</td>
</tr>
<tr>
<td>{</td>
<td>Displays a single '{'</td>
</tr>
<tr>
<td>}</td>
<td>Displays a single '}'</td>
</tr>
<tr>
<td>&lt;</td>
<td>Displays a single '&lt;'</td>
</tr>
<tr>
<td>&gt;</td>
<td>Displays a single '&gt;'</td>
</tr>
</tbody>
</table>

Basically anything that comes after a `\` will be printed.

Note:

When you are inside a format string, you may need to use this to display a character that would normally be a format code.
**Grouping**

There are instances where you do not want certain text to be displayed.

Take the example:

```
Formatting Code     Only date is known     Only place is known
died on $d at $D died on 1975-06-26 at died on at Reno, Washoe Co., NV
```

Neither of these displayed results are very acceptable.

But with groups (denoted by `{}`), you can optionally print information if a variable within contains information.

```
Formatting Code     Only date is known     Only place is known
died{ on $d}{ at $D} died on 1975-06-26 died at Reno, Washoe Co., NV
```

Which is a more preferable displayed result than in the first example.

**Rules for groups**

A group will only display if there is at least one variable that displays something. So if a group only has text and/or variables where the information is not known, the entire group will not print.

Groups can also be nested. If this happens (like below), the outer group will only display if there is at least one variable that displays something within the outer group or any of the sub groups.

Groups can also be used to remove text. If you wish to not display the entire line, `-' at the start of a line will remove the entire line from the display if the above rule is true.

If you do not wish to have the display code above (for death information) displayed (the person is alive, or you do not yet know the information), modify the code to look like:

```
- {died{ on $d}{ at $D}
```

**Examples**

This will hide `(' or ')' if the divorce information is not known (or still married).

```
• m. $m $M {- ($v(yyyy))}
```

Only display some spouse information if married or remove the entire line if never married:

```
• {($s $m(yyyy) {- $v(\(yyyy\)))}}
```

**Attributes**

Attributes do not have a format string. Instead the attribute name is placed inside `{}`. Here is the syntax for an attribute:

```
$ key [attribute name]
```

where: `key` is one of the following characters: 'au'

For example:

```
Formatting code     displays
}$[Profession]              Programmer
}$[Social Security Number] 7A3-29-F1C6
}$[Total \$ bequeathed]     3.00USD
```

**Events**

Events have the same starting structure as attributes, $e or $t and the event name in `{}` but events have an extra format string after the name to display the description, date, place, id, and attributes associated with it. Each of these items can be displayed with a , a 'n', 'd', 'D', 't', and 'a' respectively in the format string. Here is the syntax for an event:

```
$ key [attribute name][format string]
```

where: `key` is one of the following characters: 'et'
The Event format string is used to display information about the event. Here are the format codes to display parts of the event:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>displays</th>
<th>Formatting code</th>
<th>displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>n</td>
<td>Description</td>
<td>i</td>
<td>Event ID</td>
</tr>
<tr>
<td>d</td>
<td>Event Date*</td>
<td>D</td>
<td>Event Place*</td>
</tr>
<tr>
<td>a</td>
<td>An attributes for the event**</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*These variables can themselves have format strings. Date and a place can be formatted with format string as defined in Format strings.

**Attribute needs to have the attribute name in [] and are formatted as above.

For example:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>displays</th>
</tr>
</thead>
</table>
| $e[First Communion](d/yyyy-mm-dd)] 2009-11-6 | 2009-11-6
| $e[Bar Mitzvah](n< at > D] Jerry's Bar Mitzvah at Opas house | Jerry's Bar Mitzvah at Opas house
| $e[Birth](d/yyyy mm/dd) D) 2007 05/23 Grandmothers house | 2007 05/23 Grandmothers house

And:

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>$b(yyyy-Mmm-dd)</td>
<td>$M is the same as $e<a href="d/yyyy-Mmm-dd">Birth</a>)</td>
</tr>
<tr>
<td>$t<a href="D">Marriage</a></td>
<td></td>
</tr>
</tbody>
</table>

Notes for attributes and events

Attribute and event names are mandatory. ' $a' or ' $a[ ]' will not display anything.

Attributes and event names may have special characters within them. Most notably ' ' and '}'. If this is the case, you will need to use Control Variables.

Separators

Separators are special 'text only' groups inside '<' and '>' that conditionally display a separator (like ', ' or ' - ') between two groups, variables, format codes or text.

Separators are displayed conditionally depending on these rules:

- A variable that does not display anything will remove itself and a separator that is to the left of it from the display line only.
- If there is not a separator to the left, the same variable will remove itself and a separator that is to the right of it from the displayed line.
- If there are two separators together, the left one will be removed from the display line and the right is kept.
- Separators at the start or end of the display line (or format strings) are removed.

Take this example formatting code:

$e[First Communion](d/yyyy-mm-dd)] 2009-11-6
$e[Bar Mitzvah](n< at > D] Jerry's Bar Mitzvah at Opas house
$e[Birth](d/yyyy mm/dd) D) 2007 05/23 Grandmothers house

Here are some things that may happen:

<table>
<thead>
<tr>
<th>Possibility</th>
<th>Outcome</th>
</tr>
</thead>
<tbody>
<tr>
<td>If none of the variables are known</td>
<td>None of the separators will display</td>
</tr>
<tr>
<td>If only one variable is known</td>
<td>Only that variable will print. No separators will print.</td>
</tr>
<tr>
<td>If only the spouse's name is not known</td>
<td>The first separator will not display</td>
</tr>
<tr>
<td>If only the marriage date is not known</td>
<td>The first separator does not display. We will be left with:</td>
</tr>
<tr>
<td>If only the divorce date is not known</td>
<td>Jane Doe&lt; - &gt;</td>
</tr>
<tr>
<td>Separators can be inside format strings:</td>
<td>the second separator will not display</td>
</tr>
</tbody>
</table>

$e[First Communion](d/yyyy-mm-dd)] 2009-11-6
$e[Bar Mitzvah](n< at > D] Jerry's Bar Mitzvah at Opas house
$e[Birth](d/yyyy mm/dd) D) 2007 05/23 Grandmothers house

Unlike groups, separators can not cross over/out of format strings. So the separator < > will NEVER display. No matter what is on the left hand side of the variable.

Here is a useful example:

* ((b. $b)<, >(d. $d))

This will:
Only print the outside () if either the birth or death date displays

Only displays the center separator if both dates are known.
So here are some thing that could display

(b. 1970-4-8) (d. 2012-3-9) (b. 1970-4-8, d. 2012-3-9) or the line does not print at all.

We will not see things like:

{} {} (b.) (b.,) (d.)
{} {} (b. 1970-4-8, 2012-3-9) (b.,  d. 2012-3-9)

Back to Index of Reports.
This section describes the Book report available in Gramps.

**Books**

The Books Report allows you to create a custom *genealogy book* containing a collection of Gramps textual and graphical reports in a single document (i.e., a Book).

The only report available under this report is the Books Report.

When you select Reports-->Books... from the menu, the main **Book** dialog appears.

**Manage Books dialog**

To start the creation of your custom genealogy book click the OK button once all selections of the reports to be included have been made, and possibly configured (or reconfigured) or to just accept the defaults; this will present the **Generate Book** dialog.

**Book name**

The **Book name** (New Book default) text entry field shows the name of the current book. Change it and save your custom book (a set of configured selections) for future use, in which case you may first alter the field to contain whatever name you want. If you load a saved-away book (see below) it will show that book's name -- which may then be changed if you want to save a slightly-different configuration.

**Book name toolbar**

The top horizontal set of set of toolbar icons near the **Book name** text entry field operate on the whole book and allow the following functions:

- The Clear the book icon button clears all previously selected *Available items* items from the **Current book** section.
- The Save current set of configured selections icon button to save the current book (under the name previously typed in the **Book name** text entry field) for future use, if the book name already exists you will be asked if you wanted to Proceed to save over it
or you can [Cancel] and provide another name. **Saving the book also saves the configuration for each of the Available items you setup.**

![Available Books - dialog](image1)

**Fig. 13.3.3** "Open previously created book" icon and resulting "Available Books" - dialog

- Select the [Open previously created book] icon button to open the **Available Books** window which shows all your previously-saved books. In that box either double-click on a particular book name or first select it and then hit **OK** to then load the book.

![Available Books - dialog](image2)

**Fig. 13.3.4** "Manage previously created books" icon and resulting "Available Books" - dialog

- You can also select the [Manage previously created books] icon button to open a slightly different **Available Books** window which shows your list of available books, and by using the [Delete] button you can removed the selected book.

### Available items

The middle section **Available items** lists the items available for inclusion in the book.

### Available items selections

Almost all items available for inclusion in the book are textual or graphical reports, and are therefore available in the form of standalone reports (see **Index of Reports** for their individual documentation). The exceptions are the following items which are only available as book items, in a book report:

**Alphabetical Index**
This item produces page(s) with an alphabetical index of people noted into selected textual reports.

On the Report Options tab you may choose the Translation language from the drop down list.

The Custom Text item produces a page with three paragraphs, each containing custom text:

- Initial Text:
- Middle Text:
- Final Text:

The text input fields are expandable so you can really put all the text you want in there.

The lower window part shows some Document Options: here you can choose the Style. You can choose the default style or click on the Style Editor button. This brings up a Style Editor window where you can add and remove Styles. For more details see also style editor. This item was meant to be used for epigraphs, dedications, explanations, notes, and so forth.

A Table of contents (TOC) is generated for book as a list of the parts of a book or document organized in the order in which the parts appear.

On the Report Options tab you may choose the Translation language from the drop down list.

For Open Document Text(ODT) file output

the Table of Contents and Index are inserted into the document but not generated by Gramps. Right click in them in LibreOffice and then click on "Update Index or Table of Contents" in the context menu to generate the entries.
If you selected the **Title Page** item and clicked the [Add] button to put this item in your book and you click the [Preferences] button (Configure currently selected item) you will get a **Title Page** window.

On the **Report Options** tab you have three text input fields available where you can change the **Title**, the **Subtitle** and a **Footer** from the example text provided.

An **Image** can be optionally placed between the subtitle and the footer, by selecting the [Select an existing media object] button which will show the **Select Media Object** selector dialog where you can select the existing image you want.

You can also change the **Image Size** from the default.

The lower window part shows some **Document Options**: here you can choose the **Style**. You can choose the default style or click on the **Style Editor** button. This brings up a **Style Editor** window where you can add and remove Styles. For more details see also **style editor**.

Because you can configure the various elements, this item can be used to create title pages for the whole book, its chapter, or even a single item.

**Current book**

The bottom section **Current book** lists the currently selected items in the order they will appear in the book.

**Current book toolbar**

The bottom right vertical set of toolbar icons beside the **Current book** section table operate on the sections and allow the following functions:

- Use the [Add an item to the book] icon button to add the selected item from the top **Available items** section list to the **Current book** section list below. Double-clicking the (top list's) selected item will also add it.
- Use the [Remove currently selected item from the book] icon button to remove an item from the bottom **Current book** section list.
- Use the [Up arrow Move current selection one step up in the book] icon button to change the order of the selected item in the **Current book**.
- Use the [Down arrow Move current selection one step down in the book] icon button to change the order of the selected item in the **Current book**.
- With the [Configure currently selected item] icon button you can configure the options of the selected **item** of the **Current book** -- but you must select the item first. Double-clicking an item will also start a configuration dialog. The configuration dialog invoked by **Configure currently selected item** icon button are item-specific. If you choose not to configure the item, some defaults will be used for all needed options. The common option for almost all book items is the center person: the person on whom the item is centered. Thanks to this option, you can create a book with items centered on different people (e.g. your mom's and dad's ancestors as separate chapters). By default, the center person is set to the **Active Person**.

**Generate Book dialog**
Fig. 13.3.9 Generate Book - dialog

You will see the **Generate Book** dialog once you have selected the **Manage Books** dialogs [OK] button to accept the defaults and start the creation of your custom genealogy book.

There are two sections **Paper Options** and **Document Options**:

**Paper Options**

Where you can change the Size and Orientation for the Paper Format, and all Margins. A Checkbox is available to use metric values instead.

**Document Options**

The **Document Options** section allows you to change the:

- **Output Format**: use the drop down menu to change output format:
  - PDF document
  - PostScript
  - OpenDocument Text
  - Print...

  [Open with default viewer] if checked allow you to open in the default viewer eg: **LibreOffice** Word Processor. (Checkbox unchecked by default)

- **Filename**: enter your filename, note the filename extension changes depending on the output format eg: For PDF documents the default value is /yourhomedir/<Family Tree name>_book.pdf and OpenDocument Text the default value is /yourhomedir/<Family Tree name>_book.odt, etcetera.

**See also**

- Add a table contents or an index to a Book of Reports

---

Back to **Index of Reports**
This section describes the different Graphical Reports available in Gramps.

**Graphical Reports**

Graphical reports represent information in forms of charts and graphs. Most of the options are common among graphical reports, therefore they will be described only once, at the end of this section. The few options which are specific to a given report will be described directly in that report's entry. See also substitution values.

The following graphical reports are available in Gramps:

**Common options**

Common options for text reports are the filename of the output, the format of the output, selected style, page size and orientation. For HTML reports, there is no page information. Instead, HTML options include the choice of the HTML template, either available in Gramps or a custom template defined by you. Optionally, the reports can be immediately opened with the default application.

Tip

The options used in reports are persistent. Each report remembers the options previously used.

The options which are specific to a given report will be described directly in that report's entry and on Command line references.

For each report there is a screen with on the top part tabs (like Paper Options...) and on the bottom part the Document Options. The number of tabs varies with the report.

**Paper Options**

With the Paper Options tab you can change:

- **Paper format**
  - **Size**: Letter (default)
  - **Width**: 8.50 in. (default)
  - **Height**: 11.00 in. (default)
  - **Orientation**: Portrait (default)

- **Margins**
  - **Left**: 1.00 in. (default)

Fig. 13.4.2 Paper Options - tab for Graphical Reports
• **Right**: (1.00 in. default)
• **Top**: (1.00 in. default)
• **Bottom**: (1.00 in. default)

**Metric**: whether to use metric values or not (in. or cm.). (checkbox unchecked by default)

See also **Report could not be created** dialog which may occur if your custom page size is too large.

### Document Options

Options below will change slightly depending on the output format selected.

![SVG document output selected](image)

- **Output Format**: choose the output format:
  - **SVG document**: (Scalable Vector Graphics) for display with a web browser or editing with a suitable graphics editor.
  - **PostScript**
  - **OpenDocument Text** (if you want to edit the report with Libreoffice/Openoffice)
  - **PDF document**
  - **Print...**

  - **Open with default viewer**: you can indicate to open the made document your default viewer, will open the created report using whatever program is defined on your system for handling the format selected.(checkbox unchecked by default)
  - **Filename**: default value is `/home/<username>/<Family Tree Name><Report Name><output format extension>`. by default the filename is the same as the report type, and it will be placed in your home directory. (In Windows it defaults to one level up from "My documents").
  - **Style**: (default is `default`). With the **Style Editor...** button you can add Document Styles.
  - **SVG Background color**: (transparent background default)

### Select a person for the report selector

The **Select a person for the report** selector allows you to select an already existing person for the report and once selected they will be placed in **Tree Options** as the Centre Person.

![Select a person for the report](image)

It defaults to the current active person.

You may check the

- **Show all** box to show the entire list of persons in the tree (checkbox unchecked by default).

### Scale and Resize options

The tree is first made on a canvas that can fit a tree of any size. From that canvas the following options can change how it is finally displayed on a page.

**Scale tree to fit**:

This option will scale up/down the size of the report on the canvas to fit the size of the page (set in Paper Options) that you wish to print on. Currently you can:

- **Do not scale tree** (Default)
- **Scale tree to fit page width only**
- **Scale tree to fit the size of the page** (both width and height)
Note

For the last option, the report will scale to the lesser scale amount. If the report can be scaled up to fit the width, but needs to be scaled down further to fit the height, it will be scaled down leaving lots of room (empty white space) width-wise. Or if the report needs to be scaled down just a little for height and scaled down more for width, the report will be scaled down the most (width) leaving a gap (empty white space) at the bottom.

Without the Check box: Resize Page to Fit Tree size. option checked, the following occurs for the Scale tree to fit selections:

- Do not scale the tree may give you a report that spans multiple pages horizontally and/or vertically
- Scale tree to fit page width only may still give you a report that spans multiple pages vertically. No pages to the sides of others. Only one on top of another.
- Scale tree to fit the size of the page will give you a one page only report. The report will print on a page the size set in Paper Options.

Resize Page to Fit Tree size

This option tells how big/small to resize the page we will print on. With this option unchecked, the page size that is set in Paper Option. With this option checked the following happens based upon the three choices in Scale tree to fit:

Overrides options in the 'Paper Option' tab

This option will create irregular page sizes.

This overrides/ignores what is set on Paper Options and print on a page the same dimensions that the tree uses on the canvas. So taking the three options above, in scale tree to fit, this is what will happen if you select the 'Resize Page to Fit Tree size' option:

- With Do not scale the tree, this option will completely ignore what is set in Paper Options and print on a page that is large enough to display the entire tree
- With Scale tree to fit page width only, this option will ignore Paper Height that is set in Paper Options only. The tree has already been scaled up/down to fit the page width, so it is set. Only the page Height is set upon the height of the tree we are printing.
- With Scale tree to fit the size of the page, the tree has already been scaled to the size of the page. But as noted above, either the width or height will (more than likely) have a gap (empty white space) in it. The Resize Page to Fit Tree size will narrow down this gap on the page to remove that gap.

inter-box Y scale factor

Make the inter-box Y bigger or smaller

box shadow scale factor

Make the box shadow bigger or smaller

Know what you want to print on

Scaling a tree is an advanced function. The Document Options → Style sets the size of text that you can print. Scaling down is not very desirable as the text becomes more difficult to read. Scaling up is better but may have the some issues. So here are some pointers to make nice printed documents.

First thing first. What paper sizes can you print on? Ask around and see what page sizes you can print on easily. Just knowing what paper sizes you can print on helps a lot. At Kinkos (in the U.S.A) there is a 3 foot wide printer with paper that is on a roll (any length). So we could use 'Scale report to fit page width only' and 'One page report' for this.

It is also noteworthy to first make your report using Scale tree to fit's Do not scale the report option and Resize Page to Fit Tree size to know what the reports full dimensions (width and height) are. This will help you know how to better put this report on the pages you can print on. Here are some other quick things to take into account.

- A report that is very high and not too wide may print better with only the Scale report to fit page width only option.
- With the reports normal width, which will print better? Landscape or Portrait?
- Since every boxes width is set by the widest box, can you use the Descendant reports → Replace option to abbreviate or remove very long parts that are not needed?
- The size of the title. If there is room, you may want to make the title larger. And if it is too large, it will set the width of the report.

Ancestor Tree
This report generates the chart of people who are ancestors of the Active Person.

You can choose the Ancestor Tree report with Reports -> Graphical Reports -> Ancestor Tree...

See also common options

**Tree Options**

**Fig. 13.4.6 Ancestor Tree - Graphical Reports - Tree Options - tab**

The **Center Person** is chosen here. The Active person will be the default.

- [ ] Include siblings of the center person

With the input field **Generations**, you can change the number of generations considered.

**Display unknown generations** will allow you to select how many generations of empty boxes to display when the tree is not completely full.

Here is also the check box **Compress tree**.

**Report Options**

**Fig. 13.4.7 Ancestor Tree - Graphical Reports - Report Options - tab**

This tab gives you the option to include other items on the report.

**Report title** allows you to choose a title for the report.

- Do not print a title
- Include Report Title
And this tab also includes check boxes for Include a border, Include page numbers, and Include blank pages.

Scale tree to fit will make the tree larger or smaller to fit the page as desired. The options are:

- Do not Scale the tree
- Scale tree to fit page width only
- Scale tree to fit the size of the page

where Resize page to fit tree will make the page larger or smaller to fit the tree.

If both are selected, the options happen in that order; scale the tree first, then the page.

These two options are better described in common options with tips for making nicer reports.

Report Options (2)

![Image]

Fig. 13.4.8 Ancestor Tree - Graphical Reports - Report Options (2) - tab default options

- **Name Format**: Select the format to display the names. Choose from
  - Surname, Given Suffix (default)
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)

- **Living people**: Select to include or not living persons in the report. Choose from
  - Include, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included

- **Years from death to consider living**: Select the number of years since death to consider persons for the report. Allows for the inclusion or exclusion of recently-dead persons in the report. Default value is 0 years.

- **Translation**: The translation to be used for the report.
  - Language selector

- **Date Format**: Select the format to display dates. Choose from YYYY-MM-DD (ISO) (2018-04-08) (default) / Numerical (8/4/2018) / Month Day, Year (April 8, 2018) / Mon Day, Year (Apr 8, 2018) / Day Month Year (8 April 2018) / Day Mon Year (8 Apr 2018)

Display

![Image]

Fig. 13.4.9 Ancestor Tree - Graphical Reports - Display - tab default options

This tab allows you to determine the **Father Display Format** to be used for the report. All fathers, grandfathers, etc. will use this format.

The **Mother Display Format** to be used for all mothers, grandmothers, etc. will use this format.

The {} around the death information line states that the text ‘d.’ will display ONLY when there is death information. See Substitution Values for more information, including how to include places and attributes, and format names and dates and places.

Center person uses which format allows you to specify if the center person uses the father display format or the mother display format found on the Display tab.
Include Marriage box specifies to display an extra box between a father and mother that contains marriage information. The Marriage Display Format specifies what will print in this box.

Advanced

Fig. 13.4.10 Ancestor Tree - Graphical Reports - Advanced - tab default options

- **Replace Display Format** 'Replace this'/'With this': This allows you to put in pairs of strings separated by '/' that specify text you want to replace with other text. For example,
  
  United States of America/USA

- **Include a note**: You may check the Include a note box to add a note (checkbox unchecked by default). The Note specifies text the note will contain.

- **Note location**: Specify where on the page to place the note (default is bottom left).

“$T” within the note will display the day that the report was made. Regular date formatting (see Substitution Values) applies. Currently a note will be attached to a corner. If a person box writes over it, the note box will not move. Select another corner to see the note tab if this happens.

- **Inter-box scale factor**: Make the inter-box bigger or smaller (default is 1.00 in.).
- **Box shadow scale factor**: Make the box shadow bigger or smaller (default is 1.00 in.).

These two options are better described in Size options with tips for making nicer reports.

Calendar

Fig. 13.4.11 Calendar - Graphical Reports - example output overview

This report produces a calendar with birthdays and anniversaries on a page by month.

You can choose the Calendar report with Reports -> Graphical Reports -> Calendar...

You can print the same information but in text format by using the Birthday and Anniversary Report.

See Calendar tools holidays for an explanation of how to add or change the holidays appearing on the output of this calendar.

See also common options

Report Options
Fig. 13.4.12 Calendar - Graphical Reports - Report Options - tab default options

- **Filter**: choose between
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
- **Center Person**: The center person for the report usually the active person unless you use the **Select a different person** button to use **select a person for the report** selector dialog.
- **Text Area 1**: (My Calendar default) First line of text at bottom of calendar.
- **Text Area 2**: (Produced by Gramps default) Second line of text at bottom of calendar.
- **Text Area 3**: (http://gramps-project.org/ default) Third line of text at bottom of calendar.

Fig. 13.4.13 Calendar - Graphical Reports - Report Options (2) - tab default options

- **Name Format**: Select the format to display the names. Choose from
  - Surname, Given Suffix (default)
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
    - Include data marked private (checkbox checked by default)
    - Include only living people (checkbox checked by default)
- **Translation**: The translation to be used for the report.
  - Language selector

Fig. 13.4.14 Calendar - Graphical Reports - Content - tab default options

- **Year of report**: fill in the year. Defaults to current Year.
- **Country for holidays**: Select the country to see associated holidays.
- **First day of week**: (Default: Monday) Select the first day of the week for the report.
- **Birthday surname**: Select married women's displayed surname.
  - Wives use their own surname (Default)
  - Wives use husband's surname (from first family listed)
  - Wives use husband's surname (from last family listed)
  - Include birthdays: include or not birthdays in the calendar (checkbox checked by default)
Include anniversaries: include or not anniversaries in the calendar (checkbox checked by default)

Descendant Tree

This report generates a chart of people who are descendants of the starting person. Alternatively it may generate a chart of descendants of the parents of the starting person.

You can choose the Descendant Tree report with Reports -> Graphical Reports -> Descendant Tree...

See also common options

Tree Options

Fig. 13.4.16 Descendant Tree - Graphical Reports - Tree Options - tab

default options

Report for: selects the starting person for the report. It defaults to the current active person.

Generations (10 default). The number of generations to show on the chart (including the starting person). If Start with the parent(s) of the selected first is selected, the chart will include one more generation. (Example 1 was run with Generations =3, Example 2 with Generations =2.)

Level of spouses specifies how deep to display spouses.

Start with the parent(s) of the selected first will draw a descendancy chart from the parents of the starting person, if they are in the database. The Example is based on the same family as the first example and shows the result of starting with "Child 2 Davies" and ticking this box.

Example 1 was obtained by selecting Allan Davies as the starting person and then running the report without this box ticked, with all other options the same except Generations. The differences between the two examples are:

- The format of the first generation is changed. Because the parents of the starting person must be adjacent, spouses in the first generation may be shown out of order.
- For the purpose of the Level of spouses setting, both parents are considered direct descendants, rather than spouses. (Although the mother uses the Spousal display format on the Display tab.)

This means that other spouses (if any) of both of them will be shown to the number of levels specified by Level of spouses. In example 2, Mike Morris is shown even though Level of spouses is set to 1.

- The title of the report (if selected on the Include tab) is changed to include both parents of the starting person. Only two people are shown in the title. In example 2, Mike Morris is not listed in the title even though his descendants are shown.
For the example:

- Abe is a direct descendant
  - Abe has/had married Barbra and had two children
  - Abe also married Bridget and had one child
    - Bridget has/had married Carl.
    - Carl and Denise had a child.

Given the above example, this is what will be displayed for the first three Level of spouses options.

- 0 means that only direct descendants will be shown. Nothing on the Secondary tab will be shown (Spousal information or Marriage information). For the example above, only Abe will be shown with three children directly under him.
- 1 means that only spouses of the direct descendants will be shown. For the example above, Abe will be shown with two pieces of marriage information. Under the first will be two children and one child under the second.
- 2 means that spouses of spouses are shown. Same as 1 but Bridget will also show her other marriage. If they had any children, they would be shown too.
- 3 means that everyone in the example above will be displayed.

Any option above 1 is very hard to read on the report without the Indent Spouses option on the Display tab.

And last but not least is the Compress Tree option which tries to move everyone up as far as they can go (compress) and still have a readable report. If Start with the parent(s) of the selected first is ticked, Compress Tree does not have any affect on the first generation.

**Report Options**

![Descendant Tree](image)

**Report title**: allows you to choose a title for the report. Options are:

- Do not include a title
- Descendant Chart for [selected person(s)]
- Include a border
- Include Page Numbers

If "Start with Parents of Selected" is ticked on the "Tree Options" tab, both parents of the selected person are shown. Only two people will be listed in the title. If "level of spouses" is two or more, descendants of "spouses of spouses" are included on the chart, but are not listed in the title.

**Scale tree to fit**: Scale tree to fit will make the tree larger or smaller to fit the page as desired. The options are:

- Do not scale the tree (Default)
- Scale tree to fit page width only
- Scale tree to fit the size of the page
- Resize page to fit tree: Resize page to fit tree (unchecked by default) will make the page larger or smaller to fit the tree. If selected with the "Scale tree to fit", the options happen in that order; scale the tree first, then the page. There is a combined effect with each option:
  - With "Do not scale the tree", both the page width and height is resized to fit the tree.
  - With "Scale tree to fit page width only", the page height is resized to fit the tree height.
  - With "Scale tree to fit the size of the page", the page is resized to remove any gap in both height and width.

These two options are better described in common options with tips for making nicer reports. This tab also includes check boxes to Include a border, Include page numbers, and Include blank pages.

**Report Options (2)**
Descendant Display Format: sets the display for all descendants in the tree. The default is:

\[
\text{\$n} \\
\text{\$b} \\
\{d. \text{\$d}\}
\]

which displays the name, birth date and death date on consecutive lines in the formats set on the Display tab in Gramps preferences. The \{d. \} on the third line states that the text ‘d.’ will display ONLY when \$d has a value, i.e. there is something in the death date field of the database for this person. See Substitution Values for more information, including how to include places and attributes, and select different formats for names and dates and places.

The check box **Bold direct descendants** causes the names and other information about direct descendants to be in the bold font selected in the style editor.

Spousal Display format: specifies what is displayed for each spouse. The default is the same as for descendants. If you do not wish to have a separate box for marriage information, it can be displayed in the spouse box, for example by adding a line with

\[
\text{m. } \text{\$m}
\]

Which displays the date of the marriage.

Indent spouses: will indent the spouse and marriage boxes from the descendant boxes. In the Family descendant Chart, it does not affect the starting family or the parents of the starting family, but it does affect any other spouses of those three couples.

Include marriage box: will display a separate box on the tree for each marriage. The display format is set in **Marriage Display format**: The default is
which displays the date of the marriage. If this box is not ticked, marriage information will not be displayed unless you specify it in the spousal display format as described above.

**Advanced**

![Descendant Tree - Graphical Reports - Advanced]

Pairs of strings separated by a slash ‘/’ specify what you want to replace and what you want to replace it with.

**Example:**

- The United States of America/USA
- United Kingdom of Great Britain and Northern Ireland/UK
- Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch/Llanfairpwll

Each column width is defined by the widest box in the report. So if one box happens to be a lot wider than the rest, a lot of space will be wasted. The replace string option allows you to remove, or abbreviate, parts of the string that is not needed, or that can be cut down, so the amount of space wasted is minimal.

In this tab you can also **Include a note** in one of the corners of the report.

For example, adding the “$T” variable in the note box will display the day the report was created. Regular date formatting (see Substitution Values) applies.

**Examples**

This article's content is incomplete or a placeholder stub. Please update or expand this section.
Fig. 13.4.21 Descendant Tree Report, Example 1. Allan Davies had three spouses.

Fig. 13.4.22 Descendant Tree Report, Example 2.

Example 1 was obtained by selecting Allan Davies as the starting person and then running the report without this box ticked, with all other options the same except **Generations**. The differences between the two examples are:

- The format of the first generation is changed. Because the parents of the starting person must be adjacent, spouses in the first generation may be shown out of order.
- For the purpose of the **Level of spouses** setting, both parents are considered direct descendants, rather than spouses. (Although the mother uses the **Spousal display format** on the Display tab.)

This means that other spouses (if any) of both of them will be shown to the number of levels specified by **Level of spouses**. In example 2,
Mike Morris is shown even though Level of spouses is set to 1.

- The title of the report (if selected on the Include tab) is changed to include both parents of the starting person. Only two people are shown in the title. In example 2, Mike Morris is not listed in the title even though his descendants are shown.

Generations: The number of generations to show on the report (including the starting person). If Start with the parent(s) of the selected first is selected, the chart will include one more generation. (Example 1 was run with Generations = 3, Example 2 with Generations = 2.)

Level of spouses specifies how deep to display spouses.

For the example:

- Abe is a direct descendant
  - Abe has/had married Barbra and had two children
  - Abe also married Bridget and had one child
    - Bridget has/had married Carl.
    - Carl and Denise had a child.

Given the above example, this is what will be displayed for the first three Level of spouses options.

- 0 means that only direct descendants will be shown. Nothing on the Secondary tab will be shown (Spousal information or Marriage information). For the example above, only Abe will be shown with three children directly under him
- 1 means that only spouses of the direct descendants will be shown. For the example above, Abe will be shown with two pieces of marriage information. Under the first will be two children and one child under the second.
- 2 means that spouses of spouses are shown. Same as 1 but Bridget will also show her other marriage. If they had any children, they would be shown too.
- 3 means that everyone in the example above will be displayed.

Any option above 1 is very hard to read on the report without the Indent Spouses option on the Display tab.

And last but not least is the Compress Tree option which tries to move everyone up as far as they can go (compress) and still have a readable report. If Start with the parent(s) of the selected first is ticked, Compress Tree does not have any affect on the first generation.

**Family Descendant Tree**

Shared options with the Descendant Tree report

This report has the same options as the 'Descendant Tree' report, except that there are more options for the report title on the Include tab. Also, some of the options have a different effect.
Options are only described here if they differ between the two reports.

Fig. 13.4.23 Family Descendant Tree - Graphical Reports - example output overview

This report generates a chart of people who are descendants of the Active Family.

You can choose the Family Descendant Tree report with Reports -> Graphical Reports -> Family Descendant Tree...
See also common options

Tree Options
Fig. 13.4.24 Family Descendant Tree - Graphical Reports - Tree Options - tab default options

Report for: will select the starting family (Father and Mother) for this report. It defaults to the currently active family.

Generations (10 default). The number of generations to show on the chart (including the starting person). If Start with the parent(s) of the selected first is selected, the chart will include one more generation. (Example 1 was run with Generations = 3, Example 2 with Generations = 2.)

Level of spouses specifies how deep to display spouses.

Start with the parent(s) of the selected first If this box is ticked, the report shows both parents of the starting father and mother (if they are in the database), and all descendants of both sets of parents for the selected number of generations. The total number of generations in the chart is therefore 1 more than the number selected in the generations box. (The example chart above was made with generations=2.)

The starting father and mother have to be in the center of the chart. They will therefore not be shown in birth order with their siblings - instead they will be shown as the last and first child of their parents respectively. This is shown in the Examples chart, where the children in both families have been named Child 1,2,3 in their birth order. Furthermore, if the starting father or mother have other spouses they will be shown twice. This also applies to the parents of the starting father or mother.

If this box is not ticked, the report is the same as the descendant tree report, except that the number of generations is increased by one, the format of the first generation is different, and you get extra options for the chart title.

Report Options

Report Options - tab default options

Report title allows you to choose a title for the report. Options are:

- Do not include a title
- Descendant Chart for [selected person(s)]

If “Start with Parents of Selected” is ticked on the “Tree Options” tab, both parents of the selected person are shown. Only two people will be listed in the title. If “level of spouses” is two or more, descendants of “spouses of spouses” are included on the chart, but are not listed in the title.

Scale tree to fit Scale tree to fit will make the tree larger or smaller to fit the page as desired. The options are:

- Do not scale the tree (Default)
- Scale tree to fit page width only
- Scale tree to fit the size of the page
- Resize page to fit tree: Resize page to fit tree (unchecked by default) will make the page larger or smaller to fit the tree. If selected with the “Scale tree to fit”, the options happen in that order; scale the tree first, then the page. There is a combined effect with each option:
  - With "Do not scale the tree", both the page width and height is resized to fit the tree.
  - With "Scale tree to fit page width only", the page height is resized to fit the tree height.
  - With "Scale tree to fit the size of the page", the page is resized to remove any gap in both height and width.

Overrides options in the Paper Option tab.

Overides options in the Paper Option.
These two options are better described in common options with tips for making nicer reports. This tab also includes check boxes to Include a border, Include page numbers, and Include blank pages.

Report Options (2)

- **Name Format:** Select the format to display the names. Choose from
  - Surname, Given Suffix (default)
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
- **Include data marked private** (checkbox checked by default)
- **Living people:** Select to include or not living persons in the report. Choose from
  - Include, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living:** Select the number of years since death to consider persons for the report. Allows for the inclusion or exclusion of recently-dead persons in the report. Default value is 0 years.
- **Translation:** The translation to be used for the report.
- **Language selector**
- **Date Format:** Select the format to display dates. Choose from YYYY-MM-DD (ISO) (default) / Numerical (8/4/2018) / Month Day, Year (April 8, 2018) / Mon Day, Year (Apr 8, 2018) / Day Month Year (8 April 2018) / Day Mon Year (8 Apr 2018)

Display

- **Descendant Display Format:** sets the display for all descendants in the tree. The default is:

  \[
  \$n
  \]
  
  \[
  \text{b. } \$b
  \]
  
  \[
  \{d. } \$d
  \]

  which displays the name, birth date and death date on consecutive lines in the formats set on the Display tab in Gramps preferences. The \{\} on the third line states that the text \d. will display ONLY when \$d has a value, i.e. there is something in the death date field of the database for this person. See Substitution Values for more information, including how to include places and attributes, and select different formats for names and dates and places.

- **Spousal Display format** specifies what is displayed for each spouse. The default is the same as for descendants. If you do not wish to have a separate box for marriage information, it can be displayed in the spouse box, for example by adding a line with

  \[
  \text{m. } \$m
  \]

  Which displays the date of the marriage.

Reports - part 4 - Graphical Reports
Indent spouses will indent the spouse and marriage boxes from the descendant boxes. In the Family Descendant Chart, it does not affect the starting family or the parents of the starting family, but it does affect any other spouses of those three couples.

Include marriage box will display a separate box on the tree for each marriage. The display format is set in Marriage Display format. The default is $m$

which displays the date of the marriage. If this box is not ticked, marriage information will not be displayed unless you specify it in the spousal display format as described above.

Advanced

Fig. 13.4.28 Family Descendant Tree - Graphical Reports - Advanced - tab default options

- Replace Display Format: 'Replace this'/'With this': This allows you to put in pairs of strings separated by '/' that specify text you want to replace with other text. For example,

  United States of America/USA

  replaces the United States of America with USA.

- Include a note: You may check the Include a note box to add a note (checkbox unchecked by default). The Note specifies the note will contain.

- Note location: Specify where on the page to place the note (default is bottom left).

- Inter-box scale factor: Make the inter-box bigger or smaller (default is 1.00 in.).

- Box shadow scale factor: Make the box shadow bigger or smaller (default is 1.00 in.).

These two options are better described in common options with tips for making nicer reports.

Fan Chart

5 Generation Fan Chart for Lewis Anderson Garner von Zieliński, Sr

Fig. 13.4.29 Fan Chart - Graphical Reports - example output overview

This report produces a chart resembling a fan, with Active person in the center, parents the semicircle next to it, grandparents in the next semicircle, and so on, for a total of five generations.

You can choose the Fan Chart report with Reports -> Graphical Reports -> Fan Chart...

See also common options

Report Options
'CAVEAT'
A "Person ____ is not in the Database" error will appear if the Center Person is Private or Living while the filtering Report Options (2) settings do not allow Private or Living Persons.

- **Center Person**: The center person for the report.

- **Generations**: (5 default) The number of generations to include in the report.
- **Type of graph**: The form of the graph.
  - full circle
  - half circle (Default)
  - quarter circle
- **Background color**: Background color is either white or generation dependent (Default).
- **Orientation of radial texts**: Print radial text upright (Default) or roundabout.
- **Draw empty boxes**: Draw the background although there is no information (checkbox checked by default)
- **Use one font style for all generations**: You can customize font and color for each generation in the style editor (checkbox checked by default)

Report Options (2)

- **Include data marked private** (checkbox checked by default)
- **Living people**: Select to include or not living persons in the report. Choose from
  - Include, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living**: Select the number of years since death to consider persons for the report. Allows for the inclusion or exclusion of recently-dead persons in the report. Default value is 0 years.
- **Translation**: The translation to be used for the report.
  - Language selector

Statistics Charts
This report displays statistical data about your Family Tree.

- Statistics Charts - Graphical Reports - example output overview (Gramps 5.1.0; Microsoft Windows 10; data from example.gramps)
You can choose the Statistics Charts report with Reports -> Graphical Reports -> Statistics Charts...

Specific options include filter, sorting methods, and additional birth- and gender-based limit for inclusion into statistics. You can also set the minimum number of items to qualify for the bar chart, so that the charts with fewer items will generate a pie chart instead. The Charts 1, Charts 2, and Charts 3 tabs allows you to select which additional information to include on each individual chart in your report. See also common options

Report Options

- **Filter**: choose between
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person

- **Filter Person**: The center person for the report.

- **Sort chart items by**: Select how the statistical data is sorted:
  - Item count (default)
  - Item name
  - Sort in reverse order (checkbox unchecked by default)

- **People born after**: (1700 default) Birth year from which to include people: fill in a year to start from

- **People born before**: (Current year default) Birth year until which to include people: fill in a year

- **Include people without known birth years** (checkbox unchecked by default)

- **Genders included**: Select which genders are included into statistics.
  - Both (Default)
  - Men
  - Women

- **Max. items for a pie**: (8 default) With fewer items pie chart and legend will be used instead of a bar chart.
Fig. 13.4.36 Statistics Charts - Graphical Reports - Report Options (2)
- tab default options

- **Name Format:** Select the format to display the names. Choose from
  - Surname, Given Suffix (default)
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
  - Include data marked private (checkbox checked by default)

- **Living people:** Select to include or not living persons in the report. Choose from
  - Include, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included

- **Years from death to consider living:** Select the number of years since death to consider persons for the report. Allows for the inclusion or exclusion of recently-dead persons in the report. Default value is 0 years.

- **Translation:** The translation to be used for the report.
  - Language selector

Charts 1

Fig. 13.4.37 Statistics Charts - Graphical Reports - Charts 1 - tab default options

Displays **Birth Month** statistics by default and you can include any of the following indicated data on a chart:

- **Age** (checkbox unchecked by default)
- **Age at death** (checkbox unchecked by default)
- **Age at marriage** (checkbox unchecked by default)
- **Age when first child born** (checkbox unchecked by default)
- **Age when last child born** (checkbox unchecked by default)
- **Birth month** (checkbox checked by default)

Charts 2
Displays **Number of children** statistics by default and you can include any of the following the indicated data on a chart:

- Birth place (checkbox unchecked by default)
- Birth year (checkbox unchecked by default)
- Death month (checkbox unchecked by default)
- Death place (checkbox unchecked by default)
- Death year (checkbox unchecked by default)
- Event type (checkbox unchecked by default)

**Charts 3**

Displays **Gender** statistics by default and you can include any of the following the indicated data on a chart:

- Forename (checkbox unchecked by default)
- Gender (checkbox checked by default)
- Marriage place (checkbox unchecked by default)
- Number of children (checkbox checked by default)
- Number of relationships (checkbox unchecked by default)
- Surname (checkbox unchecked by default)
- Title (checkbox unchecked by default)

**Timeline Chart**

Fig. 13.4.38 Statistics Charts - Graphical Reports - Charts 2 - tab default options

Fig. 13.4.39 Statistics Charts - Graphical Reports - Charts 3 - tab default options

Fig. 13.4.40 Timeline Chart - Graphical Reports - example output
overview

This report outputs the list of people with their lifetimes represented by intervals on a common chronological scale.

You can choose the Timeline Chart report with Reports -> Graphical Reports -> Timeline Chart...
See also common options

Report Options

![Timeline Chart](image)

Fig. 13.4.41 Timeline Chart - Graphical Reports - Report Options - tab default options

- **Filter**: choose between
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
- **Filter Person**: The center person for the report.
- **Sort by**: Sorting method to use.
  - Birth Date (Default)
  - Name

Report Options (2)

![Timeline Chart](image)

Fig. 13.4.42 Timeline Chart - Graphical Reports - Report Options (2) - tab default options

- **Name Format**: Select the format to display the names. Choose from
  - Surname, Given Suffix (default)
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
- **Include data marked private** (checkbox checked by default)
- **Living people**: Select to include or not living persons in the report. Choose from
  - Include, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living**: Select the number of years since death to consider persons for the report. Allows for the inclusion or exclusion of recently-dead persons in the report. Default value is 0 years.
- **Translation**: The translation to be used for the report.
  - Language selector

Back to [Index of Reports](Index of Reports).
Reports - part 5

Graphs

These reports are created using the GraphViz program. Therefore, it is important that the Graphviz program is installed on your computer.

Reports and custom IDs

After a GEDCOM import, your database can use some non-standard IDs (ie. 123I or 456U not set on Edit - Preferences on the ID Formats tab). If generated reports do not properly display data, then try Reorder Gramps IDs tool Tools-->Family Tree Processing-->Reorder Gramps IDs...

All three graph reports: Family Lines, Hourglass, and Relationship Graphs share common options: Graphviz Layout, Graphviz Options, and Note.

Also they share common options with the other reports common options: Paper Options and Document Options.

Common Options

There are also several GraphViz specific options related to pagination, color, and details of the graph.

This plugin uses the Graphviz graph visualization software. Graphviz takes the generated .gv files and creates the final files, such as .gif, .png, .pdf, .ps, etc.

Graphviz Layout

* **Font family**: Choose the font family. If international characters don't show, use FreeSans font. FreeSans is available from the NonGNU org.
  * Default
  * PostScript/ Helvetica
  * True Type/ FreeSans

* **Font size**: (14 default) The font size, in points.

* **Graph Direction**: Whether the graph goes from top to bottom or left to right
  * Vertical (top to bottom) (Default)
  * Vertical (bottom to top)
  * Horizontal (left to right)
  * Horizontal (right to left)

* **Number of Horizontal Pages**: (1 default) Graphviz can create very large graphs by spreading the graph across a rectangular array of pages. This controls the number of pages in the array horizontally. Only valid for dot and pdf via Ghostscript.
- **Number of Vertical Pages**: (1 default) Graphviz can create very large graphs by spreading the graph across a rectangular array of pages. This controls the number of pages in the array vertically. **Only valid for dot and pdf via Ghostscript**.

- **Paging Direction**: (Bottom, left default) The order in which the graph pages are output. This option only applies if the horizontal pages or vertical pages are greater than 1.

- **Connecting lines**: - How the lines between objects will be drawn. Choose from:
  - Straight
  - Curved (Default)
  - Orthogonal

**Graphviz Options**

![Graphviz Options](image)

**Fig. 13.5.3 Family Lines Graph - Graphs - Graphviz Options - tab default options**

- **Aspect Ratio**: Affects greatly how the graph is laid out on the page. Specifically node spacing and scaling of the graph (see *Advice 1:*).
  - Compress to minimal minimal size
  - Fill the given area (default)
  - Expand uniformly

**Advice 1:**

If the graph is smaller than the print area:

- **Compress to minimal minimal size** will not change the node spacing.
- **Fill the given area** will increase the node spacing to fit the print area in both width and height.
- **Expand uniformly** will increase the node spacing uniformly to preserve the aspect ratio.

If the graph is larger than the print area:

- **Compress to minimal minimal size** will shrink the graph to achieve tight packing at the expense of symmetry.
- **Fill the given area** will shrink the graph to fit the print area after first increasing the node spacing.
- **Expand uniformly** will shrink the graph uniformly to fit the print area.

- **DPI**: (72 default) dots-per-inch. When creating PostScript or PDF, use 72 DPI. Typically between 75 and 120 if generating .png or .gif files, but 300 or 600 if generating files to be printed. When creating images such as .gif or .png files for the web, try numbers such as 100 or 300 DPI.

- **Node Spacing**: (0.20 default) The minimum amount of free space, in inches, between individual nodes. For vertical graphs, this corresponds to spacing between columns. For horizontal graphs, this corresponds to spacing between rows.

- **Rank Spacing**: (0.20 default) The minimum amount of free space, in inches, between ranks. For vertical graphs, this corresponds to spacing between rows. For horizontal graphs, this corresponds to spacing between columns.

  - **Use subgraphs** (checkbox checked by default) Subgraphs can help Graphviz position spouses together, but with non-trivial graphs will result in longer lines and larger graphs.

**Note**

![Note](image)

**Fig. 13.5.4 Family Lines Graph - Graphs - Note - tab default options**

- **Note to add to the graph**: (Empty by default) This text will be added to the graph
- **Note location**: - Whether the note will appear on top or bottom of the page.
  - **Top** (default)
  - **Bottom**

- **Note size**: (12 default) The size of note text, in points.

**Family Lines Graph**
That Family Lines Graph does not display all of the people in the Family Tree.

Instead, this Graph report generates smaller family trees, with many options to try and restrict the number of people included.

Generate a Family Lines Graph using the GraphViz generator.

A typical use of this report is to generate simplified graphs to be printed on large format printing plotters.

To create a Family Lines Graph: from the menu select Reports -> Graphs -> Family Lines Graph, and then from the People of Interest tab select at least one person from the Select Person selector dialog and the report will suggest if possible a second related person via the Select Person - Also include <Person Name> warning dialog select Yes or No depending on what you decide and then select OK to generate the report.

See also common options

Report Options

- **Follow parents to determine "Family lines"** Parents and their ancestors will be considered when determining "Family Lines" (checkbox checked by default)
- **Follow children to determine "Family lines"** (checkbox checked by default)
- **Try to remove extra people and families** People and families not directly related to people of interest will be removed when determining "family lines" (checkbox checked by default)

**Arrowhead direction**: Choose the direction that the arrows point:
- Descendants <- Ancestors (default) - arrows point to the to the Descendants.
- Descendants -> Ancestors - arrows point to the to the Ancestors.
- Descendants <-> Ancestors - arrows point to both.

**Graph colouring**: - Males will be shown with blue, females with red, unless otherwise set above for filled. If the sex of an individual is unknown it will be shown with gray.
- B&W outline - Black and white outline
- Coloured outline
- Colour fill (default)
- Use rounded corners: to differentiate between women and men (checkbox unchecked by default)

**Gramps IDs**: whether to include Gramps IDs.
- Do not include default
- Include

Report Options (2)
Fig. 13.5.7 Family Lines Graph - Graphs - Report Options (2) - tab default options

- **Name Format**: Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format. Or to override that setting for the report choose from:
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)

- **Include data marked private** (checkbox checked by default) - Whether to include private data.

- **Living People**: How to handle (information about) living people
  - Included, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included

- **Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.

- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

- **Date format**: The format and language for dates, with examples
  - Default - Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO)(2018-03-14) (default for report)
  - Numerical(14/3/2018)
  - Month Day, Year(March 14, 2018)
  - DAY MON YEAR(14 Mar 2018)

Fig. 13.5.8 Family Lines Graph - Graphs - People of Interest - tab default options

The graph works by starting with a list of "people of interest". This initial list of people is then used to find both ancestors and descendants.

- **People of interest**: click on and to add/remove people of interest. When in doubt, try adding your grandparents as a starting point.

- **Limit the number of ancestors** (checkbox unchecked by default)
  - 50 default. The maximum number of ancestors to include. The maximum is for the total number of people, not generations to be displayed on the chart.

- **Limit the number of descendants** (checkbox unchecked by default)
  - 50 default. The maximum number of descendants to include. The maximum is for the total number of people, not generations to be displayed on the chart.
Fig. 13.5.9 Family Lines Graph - Graphs - Include - tab default options

- Include dates: date of birth, date of death, and marriage dates will be included in the graph when this is selected. (checkbox checked by default)
- Limit dates to years only: from the above only show the years. (checkbox unchecked by default)
- Include places: place of birth, place of death, and place of marriage will be included in the graph when this is selected. (checkbox checked by default)
- Include the number of children: marriage text will include the total number of children when this is selected. (checkbox unchecked by default)
- Include thumbnail images of people: (checkbox checked by default)
  - Thumbnail location:
    - Above the name (default)
    - Beside the name
  - Thumbnail size:
    - Normal (default)
    - Large

Family Colours

Fig. 13.5.10 Family Lines Graph - Graphs - Family Colours - tab default options

- Family colours: Select the color to use for people with a specific surname. Two columns are available: Surname and Color. Click on + or - to add a surname from the select surname window, select a surname and press [OK]. To edit the surname color double-click on a surname and from the Select color for [Surname Selected] window choose from the shown colors and then select [Select].

Individuals

Fig. 13.5.11 Family Lines Graph - Graphs - Individuals - tab default options

You can select a color for each of the following from the Pick a Color window and then select the Select button.

- **Males**: the colour to use for males.
- **Females**: the colour to use for females.
- **Unknown**: the colour to use when gender is unknown (and for people whose surname doesn't match any of the names on the "Family Colours" tab.).
- **Families**: the colour to use for families (weddings).
**Hourglass Graph**

Fig. 13.5.12 Hourglass Graph - Graphs - example output overview

Generate an hourglass graph using the GraphViz generator. Go to Reports -> Graph -> Hourglass Graph...

See also common options

**Report Options**

![Hourglass Graph - Graphs - Report Options - tab default options]

- **Center Person**: the center person for the report, defaults to the current active person.
- **Max Descendant Generations**: default 10
- **Max Ancestor Generations**: default 10
- **Arrowhead direction**: Choose the direction that the arrows point:
  - Descendants <- Ancestors (default) - arrows point to the to the Descendants.
  - Descendants -> Ancestors - arrows point to the to the Ancestors.
  - Descendants <-> Ancestors - arrows point to both.
- **Graph colouring**: - Males will be shown with blue, females with red, unless otherwise set above for filled. If the sex of an individual is unknown it will be shown with gray.
  - B&W outline - Black and white outline
  - Coloured outline
  - Colour fill (default)
- **Use rounded corner**: to differentiate between women and men (checkbox unchecked by default)
- **Gramps IDs**: whether to include Gramps IDs.
  - Do not include default
  - include
Report Options (2)

Fig. 13.5.14 Hourglass Graph - Graphs - Report Options (2) - tab default options

- **Name Format**: Select the format to display the names. This choice is normally taken from the default setting in Edit > Display tab for Name format. Or to override that setting for the report choose from:
  - **Default**: (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
- **Include data marked private**: (checkbox checked by default) - Whether to include private data.
- **Living People**: How to handle (information about) living people
  - **Included, and all data**: (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.
- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.
- **Date format**: The format and language for dates, with examples
  - **Default**: Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO)(2018-03-14) (default for report)
  - Numerical(14/3/2018)
  - Month Day, Year(March 14, 2018)
  - MON DAY, YEAR(Mar 14, 2018)
  - Day Month Year(14 March 2018)
  - DAY MON YEAR(14 Mar 2018)

Graph Style

Fig. 13.5.15 Hourglass Graph - Graphs - Graph Style - tab default options

You can select a color for each of the following from the Pick a Color window and then select the Select button.

- **Males**: the colour to use for males.
- **Females**: the colour to use for females.
- **Unknown**: the colour to used when gender is unknown (and for people whose surname doesn't match any of the names on the "Family Colours" tab.)
- **Families**: the colour to use for families (weddings).

- **Force Ahnentafel order**
- **Ahnentafel number visible**

Relationship Graph

Reports - part 5 - Graphs
The Relationship Graph creates a complex relationship graph in GraphViz format.

Via the menu: Reports-> Graphs-> Relationship Graph... You will be presented with a Relationship Graph window where you can change all the settings.

See also common options

Report Options

- **Filter**: Select the filter to be applied to the report. Choose from:
  - **Entire Database** (Default) *(Not recommended!)*
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
  - *Any custom made filter you have created will be listed below the other choices.*
  
- **Filter Person**: The center person for the filter. Defaults to the Active Person. If you use a custom filter, no Person can be chosen.
  - *[Select a different person]* button. - Change the filter person.

- **Arrowhead direction**: Choose the direction that the arrows point:
  - **Descendants <-> Ancestors** (default) - arrows point to the to the Descendants.
  - **Descendants -> Ancestors** - arrows point to the to the Ancestors.
  - **Descendants <-> Ancestors** - arrows point to both.

- **Graph colouring**: Males will be shown with blue, females with red, unless otherwise set above for filled. If the sex of an individual is unknown it will be shown with gray.
  - **B&W outline** - Black and white outline
  - **Coloured outline**
  - **Colour fill** (default)
  
- **Use rounded corners** - Use rounded corners to differentiate between women and men (checkbox unchecked by default)

- **Gramps ID**: Whether to include Gramps IDs.
  - **Do not include** default
  - include

Report Options (2)
**Name Format:** - Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format. Or to override that setting for the report choose from:
- **Default** - (in a new Family Tree this is normally Surname, Given Suffix)
- Surname, Given Suffix
- Given Surname Suffix
- Given
- Main Surnames, Given Patronymic Suffix
- SURNAME, Given (Common)

**Include data marked private** (checkbox checked by default) - Whether to include private data.

**Living People:** - How to handle (information about) living people
- **Included, and all data** (default)
- Full names, but data removed
- Given names replaced, and data removed
- Complete names replaced, and data removed
- Not included

**Years from death to consider living:** (default) - Whether to restrict data on recently dead people.

**Translation:** - The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

**Date format:** - The format and language for dates, with examples
- **Default** - Choose this option to use the default set in Edit > Display tab for Date format option.
- **YYYY-MM-DD(ISO)(2018-03-14)** (default for report)
- **Numerical(14/3/2018)**
- **Month Day, Year(March 14, 2018)**
- **MON DAY, YEAR(Mar 14, 2018)**
- **Day Month Year(14 March 2018)**
- **DAY MON YEAR(14 Mar 2018)**

### Include

**Dates and/or Places:** - Whether to include dates and/or places
- **Do not include any dates or places** (default)
- Include (birth, marriage, death) dates, but no places
- Include (birth, marriage, death) dates, and place
- Include (birth, marriage, death) dates, and place if no dates
- Include (birth, marriage, death) years, but no places
- Include (birth, marriage, death) years, and places
- Include (birth, marriage, death) places, but no dates
- Include (birth, marriage, death) dates and places on same line

**Include URLs** (checkbox unchecked by default)

**Include relationship to center person** (checkbox unchecked by default)

**Include thumbnail images of people** (checkbox unchecked by default)

**Thumbnail location:** - Where the thumbnail image should appear relative to the name
- **Above the name** (Default)
- Beside the name

**Include occupation:** - Whether to include the last occupation
- **Do not include any occupation** (default)
- Include description of most recent occupation
- Include date, description and place of all occupations
Graph Style

You can select a color for each of the following from the Pick a Color window and then select the Select button.

- **Males**: the colour to use for males.
- **Females**: the colour to use for females.
- **Unknown**: the colour to use when gender is unknown (and for people whose surname doesn't match any of the names on the "Family Colours" tab.)
- **Families**: the colour to use for families (weddings).
- **Indicate non-birth relationships with dotted lines** (checkbox checked by default) - Shows adopted relationships.
- **Show family nodes** (checkbox checked by default)

Example

![Relationship Graph](image)

Let us make a simple example. We want a relationship graph with the Descendant Families of a certain person.

1. First check that this person is the active person. (You change this later but this is handier)
2. Go via the menu Reports->Graphs->Relationship Graph...
3. Papersize : A4 metric landscape: we know there will be not too many people on the graph, so this is ok
4. Report Options: filter: Descendant Families of... Color fill, Use rounded corners
5. Graph Style : Show Family Nodes
7. Graphviz Options: Fill given area dpi 133
8. Note : we add title on the top size: 18 pts

The results are similar to the image shown to the right of here.

See also:

- A detailed tutorial How to make a relationship chart

Back to Index of Reports.
This section describes the different Text Reports available in Gramps.

Text Reports

Text reports represent the desired information as formatted text. Most of the options are common among text reports, therefore they will be described here under Common options.

Common options

Common options for text reports are the filename of the output, the format of the output, selected style, page size and orientation. For HTML reports, there is no page information. Instead, HTML options include the choice of the HTML template, either available in Gramps or a custom template defined by you. Optionally, the reports can be immediately opened with the default application.

Tip

The options used in reports are persistent: eg: each report remembers the options previously used.

The options which are specific to a given report will be described directly in that report's entry and on Command line references.

For each report there is a screen with on the top part tabs (like Paper Options...) and on the bottom part the Document Options. The number of tabs varies with the report.

Paper Options

With the Paper Options tab you can change:

- Paper format
- Size Letter(default)
Ahnentafel Report

Ahnentafel Report for Robinson, Hugh Martin

**Generation 1**
1. Robinson, Hugh Martin.

**Generation 2**
2. Robinson, Clarence. He was buried in Sterling, Whiteside, IL, USA.
3. Garner, Bertha P. Bertha P. was born on 1888-03-13 in Hagerstown, MD, USA. She died on 1918-04-05 in Columbus, Bartholomew, IN, USA. She was buried in 1918-04-06 in Sterling, Whiteside, IL, USA.

**Generation 3**
6. Garner von Zietlinski, Lewis Anderson Sr. Lewis Anderson was born on 1855-06-21 in Great Falls, MT, USA. He died on 1911-06-28 in Twin Falls, Twin Falls, ID, USA. He was buried on 1911-07-01 in Twin Falls, Twin Falls, ID, USA.
7. Martel, Luella Jacques. Luella Jacques was born on 1852-01-23 in Eureka, Humboldt, CA, USA. She died on 1921-04-28 in Myrtle Beach, SC, USA. She was buried on 1921-04-30 in Myrtle Beach, SC, USA.

**Generation 4**
14. Martel, Henry. Henry was born on 1805-10-27 in Wauchula, Hardee, FL, USA. He died on 1902-01-18 in Helena, MT, USA. He was buried in 1902 in Helena, MT, USA.
15. Hébert, Ruth Ann. Ruth Ann was born in Ardmore, OK, USA. She died in 1843.

Fig. 13.6.4 Ahnentafel Report - Text Reports - example output overview

This report lists the Active Person and his or her ancestors along with their vital data.

You can choose the Ahnentafel Report with Reports -> Text Reports -> Ahnentafel Report...

The people are numbered in a special way which is an established standard Genealogical Numbering System called Ahnentafel. This report has some Ahnentafel specific Style options in the Style Editor accessible via the [Style Editor...] button.
The Active Person is given number 1. His or her father and mother have numbers 2 and 3, respectively.

This rule holds for every person while going back in generations: father's parents are numbered 4 and 5, and mother's parents are numbered 6 and 7, fathers always numbered with even and mothers with odd numbers.

Therefore, for any person having number N in this tree, the numbers of father and mother are 2N and 2N+1, respectively.

\[
\begin{align*}
\text{person} &= n \\
\text{father} &= 2n \\
\text{mother} &= 2n+1 \\
\end{align*}
\]

Each entry will consist of a single paragraph, and should contain the following contents:

- Person number.
- Person's name.
- Birth Information, if available.
- Death Information, if available.
- Burial Information, if available.

See also common options

Report Options

Fig. 13.6.5 Ahnentafel Report - Text Reports - Report Options - tab default options

- **Center Person:** the center person for the report, defaults to the current active person.
  - Select a different person button. - Change the center person.
- **Generations:** (10 default) The number of generations to include in the report.
- **Gramps IDs:** whether to include Gramps IDs.
  - Do not include default
  - Include
- **Page break between generations** Whether to start a new page after each generation.(checkbox unchecked by default)
- **Add linebreak after each name** Indicates if a line break should follow the name.(checkbox unchecked by default)

Report Options (2)

Fig. 13.6.6 Ahnentafel Report - Text Reports - Report Options (2) - tab default options

- **Name Format:** - Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format:
  - Default - (in a new Family Tree this is normally Surname, Given Suffix )
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
  - Include data marked private (checkbox checked by default) - Whether to include private data.
- **Living People:** - How to handle (information about) living people
  - Included, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living:** 0(default) - Whether to restrict data on recently dead people.
- **Translation:** The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.
Date format:

- Default - Choose this option to use the default set in Edit > Display tab for Date format option.
- YYY-MM-DD (ISO) (2018-03-14) (default for report)
- Numerical (14/3/2018)
- Month Day, Year (March 14, 2018)
- MON DAY, YEAR (Mar 14, 2018)
- Day Month Year (14 March 2018)
- DAY MON YEAR (14 Mar 2018)

Birthday and Anniversary Report

Birthday and Anniversary Report: 2018

My Birthday Report
Produced with Gramps
http://gramps-project.org/

January
1
Warner, Martha Ellen and French, Jimmy Michael, 46
2
Garner, Francis William, 73
4
Mortensen, Robert Alan, 38
Boucher, Roger Joseph, 78
Wheeler, Jason Earl, 41
6
Walsh, Penelope, 63
George, Elizabeth and Garner, Gerard Stephen, 39
8
Rees, Kathleen Louise and Beach, Robert William, 71

Fig. 13.6.7 Birthday and Anniversary Report - Text Reports - example output overview

This report produces a list of birthdays and anniversaries on a page by month. It produces the same information as a Calendar report but in text format instead of a calendar table.

You can choose the Birthday and Anniversary Report with Reports ➔ Text Reports ➔ Birthday and Anniversary Report.

See also common options.

Report Options

Fig. 13.6.8 Birthday and Anniversary Report - Text Reports - Report Options - tab default options

- [Filter Person]: Select the filter to be applied to the report. Choose from:
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
  - Any custom made filter you have created will be listed below the other choices.
- [Filter Person]: The center person for the filter. Defaults to the Active Person.
  - Select a different person button. - Change the filter person.
- Title Text: Birthday an Anniversary Report (default) - Title of report
- Text Area 1: My Birthday Report (default) - First line of text at bottom of report
- Text Area 2: Produced with Gramps (default) - Second line of text at bottom of report
- Text Area 3: http://gramps-project.org/ (default) - Third line of text at bottom of report

Report Options (2)
**Name Format:** Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format:.
- Default - (in a new Family Tree this is normally Surname, Given Suffix)
- Surname, Given Suffix
- Given Surname Suffix
- Given
- Main Surnames, Given Patronymic Suffix
- SURNAME, Given (Common)
- Include data marked private
- Include only living people
- Translation: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

**Year of report:** Fill in the year. Defaults to current Year.
**Country for holidays:** Select the country to see associated holidays. None are shown by default.
**Birthday surname:** Select married women's displayed surname.
- Wives use their own surname (Default)
- Wives use husband's surname (from first family listed)
- Wives use husband's surname (from last family listed)
- Include birthdays: Whether to include birthdays in the calendar (checkbox checked by default)
- Include anniversaries: Whether to include anniversaries in the calendar (checkbox checked by default)
- Include relationships to center person: Whether to include relationships to the filter person (Note: Slower to create report) (checkbox unchecked by default)

**Complete Individual Report**
This report provides individual summaries.

You can choose the Complete Individual Report with Reports -> Text Reports -> Complete Individual Report...

See also common options

Report Options

The advantage of this report is the specific filter option. Depending on the filter choice (Active Person only, his or her descendants, his or her ancestors, or entire database), the report may contain from one to many individual summaries. Another option for this report is the inclusion of source information when listing events.

- **Filter**: choose between
  - **Entire Database** (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person

- **Filter Person**: The center person for the report.
  - List events chronologically (checkbox checked by default)
  - Page break before end notes (checkbox unchecked by default)

Report Options (2)

- **Name Format**: Select the format to display the names. Choose from **Surname, Given Suffix** (default) / **Given Surname Suffix** / **Given**
Main Summaries, Given Patronymic Suffix / SURNAME, Given (Common)

- Include data marked private (checkbox checked by default)
- Living People: - How to handle (information about) living people
  - Included, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- Years from death to consider living: 0 (default) - Whether to restrict data on recently dead people.
- Translation: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.
- Date format: The format and language for dates, with examples
  - Default - Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO)(2018-03-14) (default for report)
  - Numerical(14/3/2018)
  - Month Day, Year(March 14, 2018)
  - MON DAY, YEAR(Mar 14, 2018)
  - Day Month Year(14 March 2018)
  - DAY MON YEAR(14 Mar 2018)

Include

Fig. 13.6.14 Complete Individual Report - Text Reports - Include - tab default options

- Include Notes (checkbox checked by default)
- Include Source Information (checkbox checked by default)
- Include source notes (checkbox unchecked by default)
- Include Photo/Images from Gallery (checkbox checked by default)

Include (2)

Fig. 13.6.15 Complete Individual Report - Text Reports - Include (2) - tab default options

- Gramps ID: whether to include Gramps IDs.
  - Do not include default
    - include
  - Include Tags (checkbox checked by default)
  - Include Attributes (checkbox checked by default)
  - Include Census Events (checkbox checked by default)
  - Include relationships to center person Whether to include relationships to the filter person (Note: Slower to create report) (checkbox unchecked by default)

Sections
Used if separate section is required.

- **Event groups:**
  - Family (Checkbox checked by default)
  - Religious (Checkbox checked by default)
  - Vocational (Checkbox checked by default)
  - Academic (Checkbox checked by default)
  - Travel (Checkbox checked by default)
  - Legal (Checkbox checked by default)
  - Residence (Checkbox checked by default)
  - Other (Checkbox checked by default)
  - Custom (Checkbox checked by default)

---

**Database Summary Report**

**Individuals**
Number of individuals: 2157
Males: 1184
Females: 953
Individuals with unknown gender: 20
Incomplete names: 81
Individuals missing birth dates: 1010
Disconnected individuals: 73
Unique surnames: 616
Individuals with media objects: 5

**Family Information**
Number of families: 762

**Media Objects**
Number of unique media objects: 7
Total size of media objects: less than 1 MB

This report displays the overall statistics concerning number of individuals of each gender, various incomplete entries statistics, as well as family and media statistics.

You can choose the Database Summary Report with Reports -> Text Reports -> Database Summary Report...

The report shows a break down of the following information for the open Family tree

The numbers in the different categories are shown

- **Individuals:**
  - Number of individuals:
  - Males:
  - Females:
  - Individuals with unknown gender:
  - Incomplete names:
  - Individuals missing birth dates:
  - Disconnected individuals:
  - Unique surnames:
  - Individuals with media objects:

- **Family information:**
  - Number of families:

- **Media Objects:**
  - Number of unique media objects:
  - Total size of media objects: in MB(megabytes)

- Missing Media Objects: this will show the file names of any missing media object.
The information given in this report is the same as in the Statistics Gramplet.

See also common options.

**Report Options**

**Descendant Report**

Descendants of Garner von Zieliński, Lewis Anderson Sr

1. Garner von Zieliński, Lewis Anderson Sr (b. 1855-06-21 - Great Falls, MT, USA, d. 1911-06-28 - Twin Falls, Twin Falls, ID, USA)
   sp. Martin, Lolland Jacobs (b. 1852-01-23 - Erie, Humboldt, CA, USA, d. 1921-04-28 - Myrtle Beach, SC, USA)
2. Garner, Eugene Stanley (b. 1895-12-01 - Portsmouth, OH, USA, d. 1964-03-01 - Twin Falls, Twin Falls, ID, USA)
   sp. Ried, Frances Lucille (Raflo) (b. 1902-07-06 - Worthington, MN, USA, d. 1985-08-09 - Worthington, MN, USA)
3. Garner, Howard Lane (b. 1928-07-09 - LeGrange, GA, USA)
   sp. Minn, Mary Anne (b. 1927-01-13 - Worthington, MN, USA)
4. Garner, Rita Marie (b. 1952-09-07 - Worthington, MN, USA)
   sp. Warner, Allen Carl 6a (b. 1952-02-01 - Worthington, MN, USA)
5. Warner, Sarah Suzanne (b. 1987-08-29 - Gainesville, Texas, USA)
6. Warner, Donnie Jeffrey (b. 1988-05-01 - Conroe, TX, USA)

This report presents the descendants of the Active Person with a brief description in indented style.

You can choose the Descendant Report with Reports -> Text Reports -> Descendant Report...

See also common options.

**Report Options**

The only specific option concerns the number of forward generations to consider.

- **Center Person:** the center person for the report, defaults to the current active person.
  - Select a different person button: Change the center person.
  
- **Numbering system:** The numbering system to be used.
  - Simple numbering (default)
  - d’Aboville numbering
  - Henry numbering
  - Modified Henry numbering
- de Villiers/Pama numbering
- Meurgey de Tupigny numbering

- Generations: (10 default) The number of generations to include in the report.
- Show marriage info Whether to show marriage information in the report. (checkbox unchecked by default)
- Show divorce info Whether to show divorce information in the report. (checkbox unchecked by default)
- Show duplicate trees Whether to show duplicate Family Trees information in the report. (checkbox checked by default)

Report Options (2)

**Name Format:** Select the format to display the names. This choice is normally taken from the default setting in Edit ➔ Display tab for Name format. Or to override that setting for the report choose from:
- Default (in a new Family Tree this is normally Surname, Given Suffix)
- Surname, Given Suffix
- Given Surname Suffix
- Given
- Main Surnames, Given Patronymic Suffix
- SURNAME, Given (Common)

- Include data marked private (checkbox checked by default) - Whether to include private data.

- Living People: How to handle (information about) living people
- Included, and all data (default)
- Full names, but data removed
- Given names replaced, and data removed
- Complete names replaced, and data removed
- Not included

- Years from death to consider living: 0 (default) - Whether to restrict data on recently dead people.

- Translation: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

**Date format:** The format and language for dates, with examples
- Default - Choose this option to use the default set in Edit ➔ Display tab for Date format option.
- YYYY-MM-DD(ISO)(2018-03-14) (default for report)
- Numerical(14/3/2018)
- Month Day, Year(March 14, 2018)
- DAY MONTH YEAR(Mar 14, 2018)
- DAY MON YEAR(Mar 2018)

**Detailed Ancestral Report**

Ancestral Report for Garner von Ziełiński, Lewis Anderson
Sr

Generation 1

1. Garner von Ziełiński, Lewis Anderson Sr. Lewis Anderson was born on 1803-06-21 in Great Falls, MT, USA. He died on 1911-06-28 in Twin Falls, Twin Falls, ID, USA at the age of 56 years, 7 days. He was buried on 1911-07-01 in Twin Falls, Twin Falls, ID, USA. He was the son of Garner, Robert W. and Ziełiński, Phoebe Emily. He married Martel, Luella Jacques on 1875-04-01 in Paragould, Greene, AR, USA.

   Spouse: Martel, Luella Jacques.

   Luella Jacques was born on 1852-01-23 in Kuna, Humboldt, CA, USA. She died on 1921-04-28 in Myrtle Beach, SC, USA at the age of 17 years, 0 days.

Fig. 13.6.22 Detailed Ancestral Report - Text Reports - example output overview

This report covers in detail the ancestors of the active person, including a range of vital data as well as marriages, following Sosa-Stradonitz/Ahnentafel numbering. It shares many of its properties with the Detailed Descendant Report (see below).

You can choose the Detailed Ancestral Report with Reports ➔ Text Reports ➔ Detailed Ancestral Report...

See also common options.

Reports - part 6 - Text Reports 264
The report is structured with the Ahnentafel standard numbering.

- **Center Person**: the center person for the report, defaults to the current active person.
  - Select a different person button - Change the center person.
- **Sosa-Stradonitz number** (1 default) The Sosa-Stradonitz number of the central person.
- **Generations**: (10 default) The number of generations to include in the report.
- **Gramps IDs**: whether to include Gramps IDs.
  - Do not include default
  - include
- **Page break between generations**: Whether to start a new page after each generation. (checkbox unchecked by default)
- **Page break before end notes**: whether to start a new page before end notes (checkbox unchecked by default)

**Report Options (2)**

- **Name Format**:
  - Select the format to display the names. This choice is normally taken from the default setting in Edit > Display tab for Name format.
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
  - Include data marked private (checkbox checked by default) - Whether to include private data.
- **Living People**: How to handle (information about) living people
  - Included, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.
- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.
- **Date format**: The format and language for dates, with examples
  - Default - Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO)(2018-03-14) (default for report)
  - Numerical(14/3/2018)
  - Month Day, Year (March 14, 2018)
  - MON DAY, YEAR (Mar 14, 2018)
  - Day Month Year (14 March 2018)
  - DAY MON YEAR (14 Mar 2018)
Fig. 13.6.25 Detailed Ancestral Report - Text Reports - Content - tab default options

- **Use Complete Sentences**: whether to use complete sentences or succinct language (checkbox checked by default)
- **Use full dates instead of only the year**: whether to use full dates instead of year (checkbox checked by default)
- **Compute death age**: whether to compute a person's age at death (checkbox checked by default)
- **Omit duplicate ancestors**: whether to omit duplicate ancestors (checkbox checked by default)
- **Use callname for common name**: whether to use the call name as the first name (checkbox unchecked by default)

**Include**

Fig. 13.6.26 Detailed Ancestral Report - Text Reports - Include - tab default options

- **Include children**: whether to list children (checkbox checked by default)
- **Include spouses of children**: whether to list the spouses of the children (checkbox checked by default)
- **Include events**: whether to include events (checkbox unchecked by default)
- **Include other events**: whether to include other events people participated in (checkbox unchecked by default)
- **Include descendant reference in child list**: whether to add descendant references in child list (checkbox checked by default)
- **Include Photo/Images from Gallery**: (checkbox unchecked by default)

**Include (2)**

Fig. 13.6.27 Detailed Ancestral Report - Text Reports - Include (2) - tab default options

- **Include notes**: (checkbox checked by default)
- **Include sources**: (checkbox checked by default)
- **Include source notes**: (checkbox unchecked by default)
- **Include attributes**: (checkbox checked by default)
- **Include addresses**: (checkbox checked by default)
- **Include alternative names**: (checkbox unchecked by default)

**Missing information**
Detailed Ancestral Report

- Replace missing places with ___
- Replace missing dates with ___

Replace missing places with ___: Whether to replace missing Places with blank spaces. (checkbox unchecked by default)
Replace missing dates with ___: Whether to replace missing Dates with blank spaces. (checkbox unchecked by default)

Detailed Descendant Report

Descendant Report for Garner von Zieliński, Lewis Anderson Sr

Generation 1


Lewis Anderson was born on 1855-06-21 in Great Falls, MT, USA. He died on 1911-06-28 in Twin Falls, Twin Falls, ID, USA at the age of 56 years, 7 days. He was buried on 1911-07-01 in Twin Falls, Twin Falls, ID, USA. He was the son of Garner, Robert W. and Zieliński, Rhea Emily. He married Martel, Luella Jacques on 1875-04-01 in Paragould, Greene, AR, USA.

Notes for Garner von Zieliński, Lewis Anderson Sr

This report covers in detail the descendants of the active person by generation, following the genealogical tradition of textual descendant reports by generation. It aims to provide all important features expected to be found in these classic descendency formats and has received influence from various sources. The Gramps team considers as one of its objectives the viability of this report's adoption by professional genealogical institutions worldwide. As a consequence this is a highly customizable report.

The report includes a range of vital information, marriages and (optionally) notes and spouses' information. Among the numerous options are the number of forward generations to consider, whether to compute ages, the text-style between complete-sentenced and succinct, and whether to include images. The report utilizes Henry-style numbering by default, and offers d'Aboville-style numbering and Register-style numbering as options.

You can choose the Detailed Descendant Report with Reports -> Text Reports -> Detailed Descendant Report...
See also common options

Report Options

- Center Person: the center person for the report, defaults to the current active person.
- Numbering system: the numbering system to be used.
  - Henry numbering (default)
  - d'Aboville numbering
  - Record (Modified Register) numbering
- Report structure: How people are organized in the report
  - show people by generations (default)
  - show people by lineage
- Generations: (10 default) The number of generations to include in the report.
- Gramps ID: whether to include Gramps IDs.
• Do not include default

• Include

Page break between generations: Whether to start a new page after each generation. (checkbox unchecked by default)
Page break before end notes: whether to start a new page before end notes (checkbox unchecked by default)

Report Options (2)

Fig. 13.6.31 Detailed Descendant Report - Text Reports - Report Options (2) - tab default options

• Name format: - Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format.
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)

Include data marked private (checkbox checked by default) - Whether to include private data.

• Living People: - How to handle (information about) living people
  - Included, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included

• Years from death to consider living: 0 (default) - Whether to restrict data on recently dead people.

Translation: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

• Date format: The format and language for dates, with examples
  - Default - Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO)(2018-03-14) (default for report)
  - Numerical(14/3/2018)
  - Month Day, Year(March 14, 2018)
  - Day Month Year(14 March 2018)
  - DAY MON YEAR(14 Mar 2018)

Content

Fig. 13.6.32 Detailed Descendant Report - Text Reports - Content - tab default options

• Use complete sentences: whether to use complete sentences or succinct language.(checkbox checked by default)
• Use full dates instead of only the year: whether to use full dates instead of year.(checkbox checked by default)
• Use callname for common name: whether to use the call name as the first name. (checkbox unchecked by default)

Include
Fig. 13.6.33 Detailed Descendant Report - Text Reports - Include - tab default options

- **Include children**: whether to list children. (checkbox checked by default)
- **Include spouses of children**: whether to list spouses of children. (checkbox unchecked by default)
- **Include spouses**: (checkbox unchecked by default)
- **Include spouse reference**: (checkbox unchecked by default)
- **Include descendant reference in child list**: whether to include descendant references in child list. (checkbox checked by default)
- **Include Photo/Images from Gallery**: (checkbox unchecked by default)

Include (2)

Fig. 13.6.34 Detailed Descendant Report - Text Reports - Include (2) - tab default options

- **Include notes**: (checkbox checked by default)
- **Include sources**: (checkbox unchecked by default)
- **Include sources notes**: (checkbox unchecked by default)
- **Include attributes**: (checkbox unchecked by default)
- **Include addresses**: (checkbox unchecked by default)
- **Include alternative names**: (checkbox unchecked by default)
- **Include sign of succession ('+') in child-list**: (checkbox checked by default)
- **Include path to start-person**: (checkbox unchecked by default)

Missing Information

Fig. 13.6.35 Detailed Descendant Report - Text Reports - Missing Information - tab default options

- **Replace missing places with ____**: Whether to replace missing Places with blank spaces. (checkbox unchecked by default)
- **Replace missing dates with ____**: Whether to replace missing Dates with blank spaces. (checkbox unchecked by default)

**End of Line Report**
This provides a list of a person's last known ancestors with the pedigree line, ordered by generations.

You can choose the End of Line Report with Reports -> Text Reports -> End of Line Report...

See also common options

**Report Options**

- **Center Person**: the center person for the report, defaults to the current active person.
  - [Select a different person] button. - Change the center person.
- **Name Format**: Select the format to display the names. This choice is normally taken from the default setting in **Edit > Display** tab for Name format. Or to override that setting for the report choose from:
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
- **Include data marked private** (checkbox checked by default) - Whether to include private data.
- **Living People**: How to handle (information about) living people
  - **Included, and all data** (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- **Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.
- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.
- **Date format**: The format and language for dates, with examples
  - Default - Choose this option to use the default set in **Edit > Display** tab for Date format option.
  - YYYY-MM-DD (ISO)(2018-03-14) (default for report)
  - Numerical (14/3/2018)
  - Month Day, Year (March 14, 2018)
  - MON DAY, YEAR (Mar 14, 2018)
  - Day Month Year (14 March 2018)
  - DAY MON YEAR (14 Mar 2018)

**Family Group Report**
This creates a family group report, showing information on a set of parents and their children.

You can choose the Family Group Report with Reports -> Text Reports -> Family Group Report...

See also common options.

**Report Options**

- (Filter): Select the filter to be applied to the report. Choose from:
  - Default: Defaults to the Active family for the current active Person.
  - Every family
  - Descendant families - of the active family
  - Ancestors families - of active family
- Center Family: The center family for the filter. Defaults to the Active family for the current active Person.
  - [Select a different family] button - Change the filter family.
- Recursive (down): Create reports for all descendants of this family (checkbox unchecked by default)

---

**Fig. 13.6.38 Family Group Report - Text Reports - example output overview**

**Fig. 13.6.39 Family Group Report - Text Reports - Report Options - tab default options**

---

Reports - part 6 - Text Reports
Name Format: Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format. Or to override that setting for the report choose from:
- Default - (in a new Family Tree this is normally Surname, Given Suffix )
- Surname, Given Suffix
- Given Surname Suffix
- Given
- Main Surnames, Given Patronymic Suffix
- SURNAME, Given (Common)

Include data marked private (checkbox checked by default) - Whether to include private data.

Living People: How to handle (information about) living people
- Included, and all data (default)
- Full names, but data removed
- Given names replaced, and data removed
- Complete names replaced, and data removed
- Not included

Years from death to consider living: 0 (default) - Whether to restrict data on recently dead people.

Translation: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

Date format: The format and language for dates, with examples
- YYYY-MM-DD(ISO)(2018-03-14) (default for report)
- Numerical(14/3/2018)
- Month Day, Year(March 14, 2018)
- MON DAY, YEAR(Mar 14, 2018)
- Day Month Year(14 March 2018)
- DAY MON YEAR(14 Mar 2018)

Include

Parent Marriage: Whether to include marriage information for parent. (checkbox checked by default)

Parent Events: Whether to include events for parents. (checkbox unchecked by default)

Parent Addresses: Whether to include addresses for parents. (checkbox unchecked by default)

Parent Notes: Whether to include notes for parents. (checkbox unchecked by default)

Alternate Parent Names: Whether to include alternate name. (checkbox unchecked by default)

Include (2)

Gramps ID: whether to include Gramps IDs.
Do not include default
include

- **Family Notes**: Whether to include notes for families. (checkbox unchecked by default)
- **Dates of Relatives**: Whether to include dates for relatives. (checkbox unchecked by default)
- **Children Marriages**: Whether to include marriage information for children. (checkbox checked by default)
- **Generation numbers (recursive only)**: Whether to include the generation on each. (checkbox unchecked by default)
- **Print fields for missing**: Whether to include fields for missing information. (checkbox checked by default)

**Kinship Report**

**Kinship Report for Garner von Zieliński, Lewis Anderson Sr**

![Spouses (1)]
- Martel, Lucile (1852-01-23 - 1921-04-28)

**Children (8)**
- Garner, Eugene Stanley (1895-12-01 - 1964-03-01)
- Garner, Jose V. (1876-08-18 - 1929-01-21)
- Garner, Raymond E. (1876-09-16 - 1921-05-30)
- Garner, Bessie S. (1880-09-11 - 1964-06-20)
- Garner, Walter E. (1902-02-17 - 1946-10-23)
- Garner, Daniel Webster (1883-09-30 - 1968-03-02)
- Garner, Bertha P. (1888-03-13 - 1918-04-05)
- Garner, Elizabeth (1883+)

**Spouses of children (6)**
- Reed, Frances Lucile (Baba) (1902-07-06 - 1988-06-02)
- Taylor, Viola
- Rieves, George
- Gouge, Maudie
- Jackson, Cora Ellen
- Robinson, Elvira

**Grandchildren (14)**
- Garner, Howard Lane (1925-07-09+)
- Garner, Eugene Stanley Jr. (1926-10-09+)

![Spouses of grandchildren (6)]
- Garner, Dorothy (1929+)

![Fig. 13.6.43 Kinship Report - Text Reports - example output overview](Text Reports - example output overview)

This provides the kinship of selected person according to level search (height, down generations) set by user.

You can choose the Kinship Report with **Reports -> Text Reports -> Kinship Report...**

See also:

- **common options**
- **Relationship Calculator Localization** - create meaningful relation descriptions in your region.

**Report Options**

![Fig. 13.6.44 Kinship Report - Text Reports - Report Options - tab default options](Text Reports - Report Options - tab default options)

- **Center Person**: the center person for the report, defaults to the current active person.
- **Max Descendant Generations**: (2 default) The maximum number of descendant generations. If needed you can type a larger number.
- **Max Ancestor Generations**: (2 default) The maximum number of ancestor generations. If needed you can type a larger number.
- **Include spouses**: Whether to include spouses. (checkbox checked by default)
- **Include cousins**: Whether to include cousins. (checkbox checked by default)
- **Include aunts/uncles/nephews/nieces**: Whether to include aunts/uncles/nephews/nieces. (checkbox checked by default)
Fig. 13.6.45 Kinship Report - Text Reports - Report Options (2) - tab default options

- **Name Format**: - Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format. Or to override that setting for the report choose from:
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given
  - Main Surnames, Given Surname Suffix
  - SURNAME, Given (Common)

- **Include data marked private** (checkbox checked by default) - Whether to include private data.

- **Living People**: - How to handle (information about) living people
  - Included, and all data (default)
  - All names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included

- **Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.

- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

- **Date format**: The format and language for dates, with examples
  - Default - Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO) (default for report)
  - Numerical (14/3/2018)
  - Month Day, Year (March 14, 2018)
  - MON DAY, YEAR (Mar 14, 2018)
  - Day Month Year (14 March 2018)
  - DAY MON YEAR (14 Mar 2018)

**Note Link Report**

New Report in Gramps 4.2.0

Check Links in Notes are valid

<table>
<thead>
<tr>
<th>Note ID</th>
<th>Link Type</th>
<th>Links To</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>N0001 Person</td>
<td>Garner von Zieleniski, Lewis Anderson Sr</td>
<td>[0044]</td>
<td>Ok</td>
</tr>
<tr>
<td>N0009 Place</td>
<td>Great Falls, MT, USA</td>
<td>[P1435]</td>
<td>Ok</td>
</tr>
<tr>
<td>custo Internet m3</td>
<td>relative/relative.archive.zip</td>
<td></td>
<td></td>
</tr>
<tr>
<td>custo Media m3</td>
<td>1897_expeditionsmannschaft_flo_a</td>
<td>[00010]</td>
<td>Ok</td>
</tr>
<tr>
<td>custo Media m1</td>
<td>1897_expeditionsmannschaft_flo_a</td>
<td>[00010]</td>
<td>Ok</td>
</tr>
<tr>
<td>custo Family</td>
<td>Garner, Rita Marie Warner, Allen Carl</td>
<td>[P0001]</td>
<td>Ok</td>
</tr>
</tbody>
</table>

Fig. 13.6.46 Note Link Report - Text Reports - example output overview

This report displays and checks the status of the internal link consistency in Gramps notes created with the Link Editor and only list external internet addresses created using the Internet Address Editor without checking them.

You can choose the Note Link Report with Reports ->Text Reports ->Note Link Report...

No options are available for this report.[1]

See also:
- common options
- Link Editor
- Internet Address Editor.

Reports - part 6 - Text Reports
Number of Ancestors Report

Number of Ancestors for Garner von Zieliński, Lewis Anderson Sr

Generation 1 has 1 individual. (100.00%)  
Generation 2 has 2 individuals. (100.00%)  
Generation 3 has 4 individuals. (100.00%)  
Total ancestors in generations 2 to 3 is 6. (100.00%)  

Fig. 13.6.47 Number Of Ancestors Report - Text Reports - example output overview

This report displays the number of ancestors of the active person.

You can choose the Number of Ancestors Report with Reports -> Text Reports -> Number of Ancestors Report...

The report shows the following details:

- generation 1 has 1 individual : 100% : this is the person you started with
- generation 2 has 2 individuals : 100% : both parents are known
- generation 8 has 35 individuals : 27.34% this means from the \(2^{*8}\) 128 possible ancestors in generation 8 - 27% are known.

Total ancestors in generation 2 to .. is also given in numbers and percentages.

See also common options

Report Options

Fig. 13.6.48 Number of Ancestors Report - Text Reports - Report Options - tab default options

- **Center Person:** the center person for the report, defaults to the current active person.
- **Name Format:** - Select the format to display the names. This choice is normally taken from the default setting in Edit -> Display tab for Name format.
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)
- **Include data marked private** (checkbox checked by default) - Whether to include private data.
- **Translation:** The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

Place Report

Fig. 13.6.49 Place Report - Text Reports - example output overview

Produces a report according to places selected by the user.

It will list related person and event to the selected place.
You can choose the Place Report with [Reports -> Text Reports -> Place Report...](#).

See also [common options](#).

### Report Options

![Place Report](#)

- **Select using filter**: Select places using a custom filter you created earlier.
- **Select places individually**: List of places to report on.
  - **+** button - Brings up the **Select Place** selector dialog so you can choose a place.
  - **-** button - Select place in list then press this to remove place.
- **Center on**: If report is event or person centered.
  - **Event** (default)
  - **Person**

### Report Options (2)

![Place Report (2)](#)

- **Name format**: Select the format to display the names. This choice is normally taken from the default setting in [Edit > Display](#) tab for **Name format**. Or to override that setting for the report choose from:
  - **Default** - (in a new Family Tree this is normally **Surname, Given Suffix**)  
  - Surname, Given Suffix  
  - Given Surname Suffix  
  - Given  
  - Main Surnames, Given Patronymic Suffix  
  - SURNAME, Given (Common)
- **Place format**: Select the format to display places. This choice is normally taken from the default setting in [Edit > Display](#) tab for **Place format**. Or to override that setting for the report choose from:
  - **Default**  
  - **Full**

- **Include data marked private** (checkbox checked by default) - Whether to include private data.
- **Living People**: How to handle (information about) living people
  - **Included, and all data** (default)  
  - Full names, but data removed  
  - Given names replaced, and data removed  
  - Complete names replaced, and data removed  
  - Not included
- **Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.
- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

- **Date format**: The format and language for dates, with examples
  - **Default** - Choose this option to use the default set in [Edit > Display](#) tab for **Date format** option.
  - YYYY-MM-DD(ISO) (2018-03-14) (default for report)  
  - Numerical (14/3/2018)  
  - Month Day, Year (March 14, 2018)  
  - MON DAY, YEAR (Mar 14, 2018)  
  - Day Month Year (14 March 2018)  
  - DAY MON YEAR (14 Mar 2018)
Records Report

Youngest living person
1. Gomer, Andrew Joseph (48 years, 8 months)
2. Osborne, Madeline Kathleen (39 years, 3 months)
3. Warner, Noah Stuart (19 years, 6 months)

Oldest living person
1. Gomer, Helen Bernice (118 years, 2 months)
2. Gomer, Bernice Ellen (105 years, 2 months)
3. Leachman, Helen (105 years, 2 months)

Person died at oldest age
1. Bianco, Rufus (1846 years, 10 months)
2. Merri, Cyrus (1832 years, 7 months)
3. Cunningham, William Philip (116 years, 23 days)

Person married at youngest age
1. Norton, Christine (0 days)
2. Barrett, Aline (about 5 years, 16 months)
3. Harmon, Martha (10 years)

Person married at oldest age
1. Bianco, Rufus (1816 years, 6 days)

Fig. 13.6.52 Records Report - Text Reports - example output overview

The Records report shows a number of interesting records (mostly age related) in your database, like oldest living person, youngest mother, etc.

You can choose the Records Report with Reports -> Text Reports -> Records Report...

An identical Records Gramplet is also available.

See also common options

Report Options

Fig. 13.6.53 Records Report - Text Reports - Report Options - tab
default options

Selection of the records to print is possible, and a reasonable list of "positive records" is preselected (most people would regard, for example, a long marriage as a positive record, while an early divorce would rather be seen as a negative record).

- **Filter**: Select the filter to be applied to the report. Choose from:
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
  - Any custom made filter you have created will be listed below the other choices.
- **Filter Person**: The center person for the filter. Defaults to the Active Person.
  - Select a different person button.
  - Change the filter person.
- **Number of ranks to display**: 3 (default)
- **Use call name**: Don't use call name (default)
  - Replace first names with call name - (See Caveats)
  - Underline call name in first names / add call name to first name
- **Footer text**: default = empty field

**Caveats**

If the option to underline the call name is selected, the report uses `<u>...</u>` to achieve this. This only works with CairoDoc based output (direct printing, PDF export) and HTML output.

Report Options (2)
Name format: Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format:.
- Default - (in a new Family Tree this is normally Surname, Given Suffix)
- Surname, Given Suffix
- Given Surname Suffix
- Given
- Main Surnames, Given Patronymic Suffix
- SURNAME, Given (Common)
- Include data marked private (checkbox checked by default) - Whether to include private data.
- Living People: - How to handle (information about) living people
  - Included, and all data (default)
  - Full names, but data removed
  - Given names replaced, and data removed
  - Complete names replaced, and data removed
  - Not included
- Years from death to consider living: 0 (default) - Whether to restrict data on recently dead people.
- Translation: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

Person 1

Youngest living person (checkbox checked by default)
Oldest living person (checkbox checked by default)
Person died at youngest age (checkbox unchecked by default)
Person died at oldest age (checkbox checked by default)
Person married at youngest age (checkbox checked by default)
Person married at oldest age (checkbox checked by default)
Person divorced at youngest age (checkbox unchecked by default)
Person divorced at oldest age (checkbox unchecked by default)

Person 2

Youngest father
Youngest mother
Oldest father
Oldest mother
Father with most children
Father with most grandchildren
Mother with most children
Mother with most grandchildren
Family

Fig. 13.6.57 Records Report - Text Reports - Family - tab default options

Tag Report

Tag Report for complete Items

People

<table>
<thead>
<tr>
<th>Id</th>
<th>Name</th>
<th>Birth</th>
<th>Death</th>
</tr>
</thead>
<tbody>
<tr>
<td>I0623</td>
<td>Garner, Jesse V.</td>
<td>1876-06-18</td>
<td>1929-01-21</td>
</tr>
</tbody>
</table>

Fig. 13.6.58 Tag Report - Text Reports - example output overview

This lists primary objects (person, family, notes) who match the selected Tag.

You can choose the Tag Report with Reports -> Text Reports -> Tag Report...

This report was previously called the "marker report" in Gramps 3.2.

See also common options

Report Options

Fig. 13.6.59 Tag Report - Text Reports - Report Options - tab default options

- **Tag**: Select the Tag to use for the report.
- **Name Format**: Select the format to display the names. This choice is normally taken from the default setting in Edit > Display tab for Name format: Or to override that setting for the report choose from:
  - **Default** - (in a new Family Tree this is normally Surname, Given Suffix )
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
Main Surnames, Given Patronymic Suffix
SURNAME, Given (Common)

**Place format**: Select the format to display places. This choice in normally taken from the default setting in Edit > Display tab for Place format. Or to override that setting for the report choose from:
- Default
- Full

[ ] **Include data marked private** (checkbox checked by default) - Whether to include private data.

**Living People**: - How to handle (information about) living people
- Included, and all data (default)
- Full names, but data removed
- Given names replaced, and data removed
- Complete names replaced, and data removed
- Not included

**Years from death to consider living**: 0 (default) - Whether to restrict data on recently dead people.

**Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

**Date format**: The format and language for dates, with examples
- YYYY-MM-DD(ISO)(2018-03-14) (default for report)
- Month Day, Year(March 14, 2018)
- Day Month Year(14 March 2018)
- DAY MON YEAR(14 Mar 2018)

Back to Index of Reports.
This section describes the **Web Pages** reports, Narrated Web Site and Web Calendar as part of the different reports available in Gramps.

### Web Pages

#### Narrated Web Site

**Do you really want to use the entire Family Tree database**

Be aware that if you select the **Entire Database** filter option for your Family Tree database that a large number of files will be generated (depending on the size of your Family Tree database). It is recommended to start with a smaller filter (for example: ancestors of a certain person) to simplify the output while you learn about the Narrated Web Site Report.

The Narrated Web Site report generates a web site (that is, a set of linked web pages), for a set of selected individuals and provides the user with options that allow a wide range of customization. You can run this report via the menu **Reports-->Web Pages-->Narrated Web Site...**

The Narrated Web Site report creates pages that closely follow the World Wide Web Consortium’s Recommendations for XHTML 1.0 Strict and CSS 1. These recommendations include a separation of content from presentation. Due to this practice, the style and appearance of the new web pages can be completely controlled from one CSS stylesheet without altering individual pages.

Introduction pages can be added to provide additional information, such as a family history.

Genealogy records can generate a lot of files. Many web servers have a difficult time with a large number of files in a single directory. The Narrated Web report strives to keep the number of files per directory to a manageable level. To do this, a hierarchy of directories is created. The generated file names are not intuitive, but are unique for each person. Subsequent runs will generate identical file names, making it easy to update specific files.

**HTML Code type Notes**

*In this subsection, the word tag does not refer to Gramps marker tags but instead refer to HTML formatting tags!*

Notes set to the **HTML Code type** will be inserted under the object to which they are attached. This allows special

The HTML chunks must be well-formed, with all tags properly closed, to avoid conflicts with the rest of the webpage generated by the report. Only insert tags in a **HTML Code-type** Note that would normally be contained within the body of a HTML document.
Generating Pages...

When you select the OK button, the generation of the web pages will start. So first check all options on the each of the dialog tabs.

Dialog tabs

The Narrated Web Site report dialog has the following tabs:

Report Options

- Store web pages in .tar.gz archive (Checkbox unchecked by default) If you have trouble transferring the files to an external web host, you can create a single gzip’d tar file to more easily upload the data. The large number of files and directories in this web output may make it difficult to transfer the files to an external web host. Gramps has the capability of saving all of your Narrative Web files in one compressed archive using the gzip and tar formats (casually known as a ‘tarball’). This single file can quickly be transferred to your server and uncompressed on the website host. Unfortunately not all web servers support saving web files in this way, so contact your hosting provider for more information.
- Destination: (~‘/yourhomedirectory/’<Family Tree Name>’NAVWEB default) The destination directory for the web files.
- Web site title: (My Family Tree default) The title of the web site. You can enter a custom site title in this option. Strongly suggested you change this from the default
- Filter: (Any person matching this filter who is not excluded due to the privacy rules, will be included in the output.) choose between
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
- Filter Person: The center person for the report. (defaults to Active person)
  - Show the relationship between the current person and the active person (Checkbox unchecked by default) - For each person page.

Please note that compliance with privacy laws and individuals’ privacy concerns is your responsibility as the researcher.

The Gramps project cannot be held responsible for privacy law compliance or other privacy issues. Privacy of personal information is an important issue.

Gramps provides tools and settings that give some control over the privacy of your data... but these controls were built to meet the regional considerations for that tool's programmer. You are responsible for verifying compliance before publication.
baptism/christening dates, death dates of ancestors and birth dates of ancestors. The algorithm assumes that each individual is possibly still alive unless the cross-referenced dates make the individual’s possibility of being alive unlikely.

- **Exclude** – (Default) Excludes all information of all individuals who are possibly still alive
- **Include Last Name Only**
- **Include Full Name Only**
- **Include** – Include all information of all individuals even if they are possibly still alive

**Years from death to consider living:** (30 default) This option is inactive if the "Living People" option is set to Include.

---

**Privacy requirements can extend after Death. Laws vary regionally**

Some countries have laws that specify a certain number of years after death before an individual's information can be published. Here you can comply with such laws by specifying the number of years after death to continue to apply Privacy redactions.

- **Include data marked private:** Whether to include private objects. If your intention is to provide a complete record of your research, checking this box will include all entries marked private along with the rest of your database. (checkbox unchecked by default)

**Html options**

![Fig. 13.7.4 Narrated Web Site - Web Pages - Html options - tab default options](image)

- **File extension:** The extension to be used for the web files.
  - .html (Default)
  - .htm
  - .shtml
  - .php
  - .php3
  - .cgi
- **Copyright:** (Standard copyright default) When creating a public web site it is important to specify the copyright conditions under which you are publishing your data. International copyright law reserves all rights of your data to your discretion. You own the data and individuals must have your permission if they wish to reuse that data. In genealogical research sharing data with other researchers is a common practice. Other options include the Creative Commons licenses, offering a wide range of use restrictions or none at all. Learn more about the Creative Commons at [http://creativecommons.org/](http://creativecommons.org/)

- **Stylesheet:** Gramps provides seven built in style sheets for you to choose from to determine the appearance or your web pages. Choose between Basic (Ash, Blue, Cypress, Lilac, Peach or Spruce color schemes), Mainz, or Nebraska styles. There is also the option of not including a stylesheet (No style sheet). Regardless of the style you choose, the style sheet can be found in css/narrative-screen.css. You may edit this file to further customize the appearance of your web pages. If you make modifications to your style sheet be aware that regenerating your pages with the same output destination will overwrite your custom style sheet. To preserve your custom style sheet through subsequent web page updates select No style sheet. If you want your own stylesheet, you can copy one of the existing stylesheets in $HOME/gramps/css/. This directory doesn't exist. You must create it before copying your future stylesheets. Change its name. If you ask for a new report, this new stylesheet will be added to the list of preexisting stylesheets.

- **Navigation Menu Layout:** Choose which layout for the Navigation Menus. (Only available for selected Stylesheets)
  - Horizontal -- Default
  - Vertical -- Left Side
  - Fade -- Webkit Browsers Only
  - Drop-Down -- Webkit Browsers Only

- **Citation Referents Layout:** Determine the default layout for the Source Page's Citation Referents section
  - Normal Outline Style (Default)
  - Drop-Down -- Webkit Browsers Only

- **Include ancestor’s tree** - Checking this box will include an ancestor graph on each individual’s detail page if they have defined ancestors in your database. (checkbox checked by default) (Note: Narrated Website Ancestry Tree Design Notes discusses creating a compact Ancestry trees using the Buchheim/Walker algorithm.)
  - You can change the number of generations shown from the Display tabs Graph generations option.

- **Add previous/next** (checkbox unchecked by default) - adds links to the navigation bar.

- **This is a secure site (https)** (checkbox unchecked by default)
**Name Format:** Select the format to display the names. Choose from Surname, Given Suffix / Given Surname Suffix / Given / Main Surnames, Given Patronymic Suffix / SURNAME, Given (Common)

**Date format:** - The format and language for dates, with examples.

**Gramps ID:** - Option determines whether to hide or show the Gramps ID of objects in your web page output.
  - Do not include (default)
  - Include

- **Sort all children in birth order** (checkbox unchecked by default) - Whether to display children in birth order or in entry order?
- **Do we display coordinates in the places list?** (checkbox unchecked by default) - Whether to display latitude/longitude in the places list?
- **Sort places references either by date or by name** (checkbox unchecked by default) - Sort the places references by date or by name. Not set means by date.

**Graph generations:** This option is inactive if the Include ancestor graph option on the Html options tab is not checked. The default number of generations shown in the ancestor graphs is 4 with options of 2, 3, 4 or 5. The individuals represented in the ancestor graphs are the same individuals whose information is provided elsewhere in your web pages.

- **Include narrative notes just after name, gender** (checkbox checked by default) - Unchecked will show them just before attributes.

---

**Page Generation**

The Page Generation tab provides options for creation of commonly expected supplemental webpages & annotations common to all webpages throughout the generated website.

The first options are used to control generation of three supplemental pages: Home (Home webpage), Introduction (FAQ or About Us webpage) and Publisher Contact (Contact Us webpage).

Each of supplemental pages may be assigned a specific Media or Note item. By default, no content (neither media nor text from a Note) is assigned to these pages.

Content for these pages must originate as Media or Notes items that have been created before running the report. Once the desired items have been added to your Tree, you will be able to choose them from a list of Notes or Media Objects.
Planning for sustainability

These special-purpose items do not need to have References associated with any other record in the Tree. However, you might find it helpful to add a Source your generated Website as a distinct Source (marked as Private) to your Tree. This private Source could use the References as a special-purpose item checklist... with an added Note to document the options used to generate the Narrated Website.

Add another note documenting any idiosyncrasies encountered when publishing the site. Such internal documentation makes reproducing the same appearance easier when generating website updates in the future.

Privacy & Spam Exposure Risk

Please use the Publisher contact page with caution if you will be publishing your web pages on a publicly accessible web server. Consider using a single-use (disposable) eMailbox or secure form mail system.

Extra pages

Extra page name: (blank) - Your extra page name like it is shown in the menubar.

Your extra page path: (blank) - Your extra page path without extension.

Image Generation

Fig. 13.7.8 Narrated Web Site - Web Pages - Image Generation - tab default options
Include images and media objects: This option determines whether to include/exclude a gallery of media objects on your website. (Checkbox checked by default)

Include unused images and media objects: This option determines whether to include/exclude a gallery of unused media objects on your website. (Checkbox checked by default)

Create and only use thumbnail-sized images: This option allows you to create only thumbnail images instead of full-sized images on the Media Page. This will allow you to have a much smaller total upload size to your web hosting site. (Checkbox unchecked by default)

- **Max width of initial image:** (800 default) This allows you to set the maximum width of the image (in pixels) shown on the media page.
- **Max height of initial image:** (600 default) This is no more used and will disappear in 5.2.

### Considerations for choosing image height/width

The height & width options need further expansion but discussions on the MailLists provide some added insight.

See also:
[Gramps-devel] NarrativeWeb and large images - Mk II

Some idiosyncratic browser support for images on iPad has been reported:
[Gramps-users] Narrated website images don’t appear on iPad [SOLVED]

If the image contains regions, the size will be resized to max_width. If the width of an image is less than max_width, no resizing will occurs.

---

Fig. 13.7.9 Example of **image reference regions** - Media tab of HTML output for "Narrative Web" Report

Note that **image reference regions** are also displayed in the Narrative Web HTML pages created with Gramps. There are no special options necessary for this feature, other than the existence of reference regions for 1 or more images. Narrative Web displays reference regions for people and place objects only.

---

Download

Fig. 13.7.10 Narrated Web Site - Web Pages - Download - tab default options

- **Include download page:** Whether to include a database download option. (Checkbox unchecked by default)
- **Download Filename:** Select the file to be used for downloading of database.
- **Description for download:** (Smith Family Tree default) Give a description for this file.
- **Download Filename:** Select the file to be used for downloading of database.
Advanced Options

These settings address the amount of information displayed on the Surname detail and Individual index web pages.

- **Character set encoding:** The encoding to be used for the web files.
  - Unicode UTF-8 (recommended) (Default)
  - ISO-8859-2
  - ISO-8859-3
  - ISO-8859-4
  - ISO-8859-5
  - ISO-8859-6
  - ISO-8859-7
  - ISO-8859-8
  - ISO-8859-9
  - ISO-8859-10
  - ISO-8859-13
  - ISO-8859-14
  - ISO-8859-15
  - koi8_r - Kod Obmena Informatsiey, 8 bit ("Code for Information Exchange - 8 bit")

- **Include link to active person on every page:** (If they have a webpage) (checkbox unchecked by default)
- **Include a column for birth dates on the index pages:** (checkbox checked by default)
- **Include a column for death dates on the index pages:** (checkbox unchecked by default)
- **Include a column for partners on the index pages:** (checkbox unchecked by default)
- **Include a column for parents on the index pages:** (checkbox unchecked by default)
- **Include half and/or step-siblings on the individual pages:** (checkbox unchecked by default)
- **Include family pages:** (checkbox unchecked by default)
- **Include event pages:** (checkbox unchecked by default)
- **Include places pages:** (checkbox unchecked by default)
- **Include sources pages:** (checkbox unchecked by default)
- **Include repository pages:** (checkbox unchecked by default)
- **Include GENDEX file (/gendex.txt):** This option creates a GENDEX file placed at the top of the website. You can see sites which support this format and read more about it at the GENDEX Wikipedia article (checkbox unchecked by default)
- **Include address book pages:** (checkbox unchecked by default)
- **Include the statistics page:** (checkbox unchecked by default)
Place Map Options

**Fig. 13.7.13Narrated Web Site - Web Pages - Place Map Options - tab default options**

- **Map Service**: Choose your choice of map service for creating the Place Map Pages
  - **OpenStreetMap** (default)
  - **Google**: For this option to work requires a Google maps API key to be entered. To apply for one goto the Google maps platform ([https://cloud.google.com/maps-platform/](https://cloud.google.com/maps-platform/)) and select "Get Started" (top right corner) and follow the instructions (may involve a credit card) and then select the "Credentials" option on the "API Manager" menu. Then click on the "Create Credentials" button on the "Credentials" window. Click on "API Key " on the next pop-up window. Copy the generated API key to your clipboard and paste in to Gramps "Google maps API key:" field. I strongly suggest that after generating and placing your report online that you go back to the google maps platform and click the "Restrict key" button on the API key created window and add your domain (this will stop other website hijacking your api key and making you pay)! These new Google Maps API changes came into affect from the 11th of June 2018. see the pricing table [https://cloud.google.com/maps-platform/pricing/sheet/](https://cloud.google.com/maps-platform/pricing/sheet/) "You also get a recurring $200 credit on your billing account each month to offset your usage costs, and you can set usage limits to protect against unexpected cost increases"

- **Include Place map on Place Pages**: Whether to include a place map on the Place Pages, where Latitude/ Longitude are available. (checkbox unchecked by default)
- **Include Family Map Pages with all places shown on the map**: Whether or not to add an individual page map showing all the places on this page. This will allow you to see how your family traveled around the country. (checkbox unchecked by default)
- **Google/ FamilyMap Option**: Select which option that you would like to have for the Google Maps Family map pages...
  - **Family Links** (default)
  - **Drop**
  - **Markers**
- **Google maps API key**: To get a "Google maps API key:":
  - visit [https://cloud.google.com/maps-platform/pricing/sheet/](https://cloud.google.com/maps-platform/pricing/sheet/) as a cost may be involved as well as the use of a credit card

Other inclusion (CMS, Web Calendar, Php)

**Fig. 13.7.14Narrated Web Site - Web Pages - Other inclusion (CMS, Web Calendar, Php) - tab default options**

- **Do we include these pages in a cms web?** (Checkbox unchecked by default)
  - **URI:** /NAVWEB (default) - Where do you place your website ?

- **Do we include the web calendar?** (Checkbox unchecked by default)
  - **URI:** /WEBCAL (default) - Where do you place your website ?

See also:

- [Howto: Make a genealogy website with Gramps#Integration of NarrativeWeb in a CMS or MVS](#)
Example Web Site output

The following sections show the default appearance of web pages the Narrative Website web page report.

Home
(optional page)

Introduction
(optional page)

Individuals
(default page)

Surnames
(default page)

Families
(optional page)

Events
(optional page)

Places
(default page)

Sources
(default page)

Repositories
(optional page)

Media
(default page)

Thumbnails
(default page)

Download
(optional page)

Address Book
(optional page)

Contact
(optional page)

Web Calendar

Note

The Narrated Web Site Report does not currently hyperlink back into the Web Calendar Report.
Fig. 13.7.15 Web Calendar Report - Web Pages - default Calendar for December 2018 - HTML output

The Web Calendar shows events for the selected individuals on a set of monthly calendars. You can run this report via the menu Reports-->Web Pages-->Web Calendar...

There are options to filter the individuals, to choose which years to include (by default, only the current year is included); whether to include only living people and whether to include birthdays or anniversaries or both; notes can be included on monthly pages and abbreviated pages can be included.

The report is designed to work with the Narrative Web Site Report. There is a 'Home' link on each page to the home page of the Narrative Web Site Report. There is also an option to include links from the individuals on the calendar to the same individual on the Narrated Web Site.

Working with the Narrated Web Site Report requires that the two reports have been constructed in a compatible way by the user. There is no automated check that the two are compatible. If the pages are not compatible, then the user will likely get a 'Page not found' error.

Compatibility depends on:

1. Including the same individuals in the two reports,
2. Storing the pages in compatible directories.

In order to include the same individuals in the two reports, the same filters should be used, and similar options with regard to including living individuals (the Web Calendar does not have an option to remove 'private' information).

By default, the Narrated Web Site Report is stored in the directory "~/<Family Tree Name>+NAVWEB", and by default the Web Calendar is stored in the directory "~/<Family Tree Name>+WEBCAL". If these defaults are retained, then the various links should work properly. If the directories have been changed, then the 'Home link' under the 'Content Options' and the 'Link prefix' under the 'Advanced Options' will need to be changed accordingly.

If the Web Calendar is to be used without an associated Narrative Web Site, then the text in the 'Home link' under the 'Content Options' should be deleted to ensure that no 'Home' link is generated.

Dialog tabs

The Web Calendar report dialog window Web Calendar has five tabs each are reviewed below.

Report Options
Fig. 13.7.16 Web Calendar - Web Pages - Report Options - tab default options

- **Destination:** /~yourhomedirectory/<Family Tree Name>+WEBCAL The destination directory for the web files.
- **Calendar Title:** (My Family Calendar default) The title of the calendar.
- **Filter:** choose between
  - Entire Database (Default)
  - Descendants of active person
  - Descendant families of active person
  - Ancestors of active person
  - People with common ancestor with active person
- **Filter Person:** The center person for the filter. (Default: Active person)
- **File extension:** The extension to be used for the web files.
  - .html (Default)
  - .htm
  - .shtml
  - .php
  - .php3
  - .cgi
- **Copyright:** The copyright to be used for the web files.
  - Standard copyright (Default)
  - Creative Commons - By attribution
  - Creative Commons - By attribution, No derivations
  - Creative Commons - By attribution, Share-alike
  - Creative Commons - By attribution, Non-Commercial
  - Creative Commons - By attribution, Non-Commercial, No derivations
  - Creative Commons - By attribution, Non-Commercial, Share-alike
  - No copyright notice
- **StyleSheet:** The stylesheet to be used for the web pages.
  - Basic-Ash (Default)
  - Basic-Blue
  - Basic-Cypress
  - Basic-Lilac
  - Basic-Peach
  - Basic-Spruce
  - Mainz
  - Nebraska
  - No style sheet
  - Visually Impaired

Report Options (2)

Fig. 13.7.17 Web Calendar - Web Pages - Report Options (2) - tab
default options

- **Name Format**: - Select the format to display the names. This choice in normally taken from the default setting in Edit > Display tab for Name format.
  - Default - (in a new Family Tree this is normally Surname, Given Suffix)
  - Surname, Given Suffix
  - Given Surname Suffix
  - Given
  - Main Surnames, Given Patronymic Suffix
  - SURNAME, Given (Common)

- **Include data marked private** (checkbox unchecked by default)
- **Include only living people** (checkbox checked by default) - eliminates ancestors for webcalendars being used as reminder tools instead of historical tools.

- **Translation**: The translation to be used for the report. Language selector showing all languages supported by Gramps. Defaults to the language you are using Gramps in.

- **Date format**: The format and language for dates, with examples
  - Default - Choose this option to use the default set in Edit > Display tab for Date format option.
  - YYYY-MM-DD(ISO)(2018-03-14) (default for report)
  - Numerical(14/3/2018)
  - Month Day, Year(March 14, 2018)
  - MON DAY, YEAR(Mar 14, 2018)
  - Day Month Year(14 March 2018)
  - DAY MON YEAR(14 Mar 2018)

**Content Options**

![Web Calendar - Web Pages - Content Options - tab](image)

- **Create multiple year calendars** (checkbox unchecked by default)
  - **Start Year for the Calendar(s)** (Defaults to current year)
  - **End Year for the Calendar(s)** (Defaults to current year)
- **Country for holidays** - Select the country to see associated holidays. (Defaults to blank)
- **First day of week** - Select the first day of the week for the calendar. (Default: Sunday)
- **Birthday surname**: Select married women's displayed surname.
  - Wives use their own surname (Default)
  - Wives use husband's surname (from first family listed)
  - Wives use husband's surname (from last family listed)
- **Home link**: (../../../Family Tree 1_NAVWEB/index.html default) The link to be included to direct the user to main page of the web site.

**Jan - Jun Notes**
Select an existing note for the month.

- **January Note:**
- **February Note:**
- **March Note:**
- **April Note:**
- **May Note:**
- **June Note:**

Jul - Dec Notes

Select an existing note for the month:

- **July Note:**
- **August Note:**
- **September Note:**
- **October Note:**
- **November Note:**
- **December Note:**
Fig. 13.7.21 Web Calendar - Web Pages - Advanced Options - tab
default options

- **Character set encoding**: The encoding to be used for the web files
  - Unicode UTF-8 (recommended) (Default)
  - ISO-8859-1
  - ISO-8859-2
  - ISO-8859-3
  - ISO-8859-4
  - ISO-8859-5
  - ISO-8859-6
  - ISO-8859-7
  - ISO-8859-8
  - ISO-8859-9
  - ISO-8859-10
  - ISO-8859-13
  - ISO-8859-14
  - ISO-8859-15
  - koi8_r

- **Create one day event pages for Year At A Glance Calendar** (checkbox unchecked by default)
- **Include birthdays** (checkbox checked by default)
- **Include anniversaries** (checkbox checked by default)
- **Link to Narrated Web Report** (checkbox unchecked by default)

- **Link prefix**: /../Family Tree 1_NAVWEB/ A Prefix on the links to take you to Narrated Web Report.

Example Web Site output

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Back to [Index of Reports](#)
This section describes the Quick Views as part of the different reports available in Gramps.

Quick Views are report windows available via the context menu of the most of the category views and some of the edit dialogs.

These quick views are generate reports based on the first selected record and have no options to confuse the process. However, like the main views, the user defined formats selected in the Display tab of the Preferences will carry through in these reports.
Quick View reports are static. The contents of these floating windows will not update as the object focus changes nor when the record data is edited. If you want a more dynamic version of the Report, a QuickView Gramplet can be added to the sidebar or bottombar. The report will be regenerated as the object focus shifts. The Configure toolbar tool (or View menu "Configure... option) will have a Quick View tab to select the Object type and report being displayed.

**Clipboarding Quick View data**

Use the context menu (Right-click) option for **Select All** to highlight QuickView content that is not contained in a formatted table. Then use the context menu again to **Copy** the selected content to the OS Clipboard.

For Quick Views that have lists of records in tabular format, copy QuickView Table row data to the OS Clipboard by using the Context menu (Right-click) option within a table row to choose the **Copy all** menu option. If the QuickView has multiple tables, they must be copied individually.

**Location**

The following built-in Quick view reports are available per category:

- **Dashboard view** - Not available
  - Note that you can use the Quick View Gramplet

- **People view** and **Edit Person** dialog
  - All Events
  - Father lineage
  - Mother lineage
  - Person References
  - Relation to Home Person
  - Same Given Names
  - Same Surnames
  - Siblings

- **Relationships view** - Not available

- **Families view** and **Edit Family** dialog
  - All Family Events
  - Family References

- **Charts view** - Not available

- **Events view**
  - Event References
  - On This Day

- **Places view**
  - Place References

- **Geography view** - Not available

- **Sources view**
  - Source References

- **Citations view**
  - Citation References

- **Repositories view**
  - Repository References

- **Media view**
  - Media References

- **Notes view**
  - Link References
  - Note References

**QuickView Add-ons**

Sort the **Add-ons list table** on the **Type** column and scroll to the **Quickview** grouping.

As of 2022, the available add-on Quickviews (in the People category view) include:

- All Names of All People
- Biography
- Descendant Count (simple totals)
- Number of ancestors (by generation)
- Number of descendants (by generation)
- Timeline (events of immediate family)
### All Events

Example "All Events" quick view report from the People view:

**Sorted events of Big Louie (Big Louie) Garner von Zieliński Sr**

<table>
<thead>
<tr>
<th><strong>Event</strong></th>
<th><strong>Type</strong></th>
<th><strong>Date</strong></th>
<th><strong>Place</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Birth</td>
<td>[E0001656]</td>
<td>Jun 21, 1855</td>
<td>Great Falls, MT, USA</td>
</tr>
<tr>
<td>Marriage</td>
<td>[E0002815]</td>
<td>Apr 1, 1875</td>
<td>Paragould, Greene, AR, USA</td>
</tr>
<tr>
<td>Death</td>
<td>[E0001657]</td>
<td>Jun 28, 1911</td>
<td>Twin Falls, Twin Falls, ID, USA</td>
</tr>
<tr>
<td>Burial</td>
<td>[E0001658]</td>
<td>Jul 1, 1911</td>
<td>Twin Falls, Twin Falls, ID, USA</td>
</tr>
</tbody>
</table>

### All Family Events

Example "All Family Events" quick view report from the Families view:

**Sorted events of family**

**Big Louie (Big Louie) Garner von Zieliński Sr - Luella Martel**

<table>
<thead>
<tr>
<th><strong>Family Members</strong></th>
<th><strong>Event</strong></th>
<th><strong>Type</strong></th>
<th><strong>Date</strong></th>
<th><strong>Place</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Luella Martel [I0000045]</td>
<td>Birth</td>
<td>Jan 23, 1852</td>
<td>Eureka, Humboldt, CA, USA</td>
<td></td>
</tr>
<tr>
<td>Big Louie (Big Louie) Garner von Zieliński Sr [I0000044]</td>
<td>Birth</td>
<td>Jun 21, 1855</td>
<td>Great Falls, MT, USA, 2398756</td>
<td></td>
</tr>
<tr>
<td>Family</td>
<td>Marriage</td>
<td>Apr 1, 1875</td>
<td>Paragould, Greene, AR, USA</td>
<td></td>
</tr>
<tr>
<td>Big Louie (Big Louie) Garner von Zieliński Sr [I0000044]</td>
<td>Death</td>
<td>Jun 28, 1911</td>
<td>Twin Falls, Twin Falls, ID, USA</td>
<td></td>
</tr>
<tr>
<td>Big Louie (Big Louie) Garner von Zieliński Sr [I0000044]</td>
<td>Burial</td>
<td>Jul 1, 1911</td>
<td>Twin Falls, Twin Falls, ID, USA</td>
<td></td>
</tr>
<tr>
<td>Luella Martel [I0000045]</td>
<td>Death</td>
<td>Apr 28, 1921</td>
<td>Myrtle Beach, SC, USA</td>
<td></td>
</tr>
<tr>
<td>Luella Martel [I0000045]</td>
<td>Burial</td>
<td>Apr 30, 1921</td>
<td>Myrtle Beach, SC, USA</td>
<td></td>
</tr>
</tbody>
</table>

**Personal events of the children**

<table>
<thead>
<tr>
<th><strong>Family Members</strong></th>
<th><strong>Event</strong></th>
<th><strong>Type</strong></th>
<th><strong>Date</strong></th>
<th><strong>Place</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Jesse Garner [I0000623]</td>
<td>Birth</td>
<td>Jun 18, 1876</td>
<td>Paragould, Greene, AR</td>
<td></td>
</tr>
<tr>
<td>Raymond Garner [I0000624]</td>
<td>Birth</td>
<td>Sep 16, 1878</td>
<td>Paragould, Greene, AR</td>
<td></td>
</tr>
<tr>
<td>Jennie Garner [I0000625]</td>
<td>Birth</td>
<td>Sep 11, 1880</td>
<td>Paragould, Greene, AR</td>
<td></td>
</tr>
<tr>
<td>Walter Garner [I0000626]</td>
<td>Birth</td>
<td>Feb 17, 1882</td>
<td>Paragould, Greene, AR</td>
<td></td>
</tr>
<tr>
<td>Elizabeth Garner [I0000629]</td>
<td>Birth</td>
<td>1883</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Daniel Garner [I0000627]</td>
<td>Birth</td>
<td>Sep 30, 1883</td>
<td>Hood River, OR, USA</td>
<td></td>
</tr>
<tr>
<td>Bertha Garner [I0000628]</td>
<td>Birth</td>
<td>Mar 13, 1888</td>
<td>Hagerstown, MD, USA</td>
<td></td>
</tr>
<tr>
<td>Eugene Garner [I0000046]</td>
<td>Birth</td>
<td>Dec 1, 1895</td>
<td>Portsmouth, OH</td>
<td></td>
</tr>
<tr>
<td>Raymond Garner [I0000624]</td>
<td>Birth</td>
<td>Jul 12, 1911</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bertha Garner [I0000628]</td>
<td>Burial</td>
<td>Apr 1918</td>
<td>Sterling, Whiteside, IL, USA</td>
<td></td>
</tr>
<tr>
<td>Jesse Garner [I0000623]</td>
<td>Burial</td>
<td>1929</td>
<td>Sterling, Whiteside, IL, USA</td>
<td></td>
</tr>
<tr>
<td>Daniel Garner [I0000627]</td>
<td>Burial</td>
<td>Mar 4, 1936</td>
<td>Sterling, Whiteside, IL, USA</td>
<td></td>
</tr>
<tr>
<td>Walter Garner [I0000626]</td>
<td>Burial</td>
<td>Oct 1946</td>
<td>Sterling, Whiteside, IL, USA</td>
<td></td>
</tr>
<tr>
<td>Jennie Garner [I0000625]</td>
<td>Burial</td>
<td>Jun 1964</td>
<td>Sterling, Whiteside, IL, USA</td>
<td></td>
</tr>
<tr>
<td>Bertha Garner [I0000628]</td>
<td>Death</td>
<td>Apr 5, 1918</td>
<td>Columbus, Bartholomew, IN, USA</td>
<td></td>
</tr>
<tr>
<td>Raymond Garner [I0000624]</td>
<td>Death</td>
<td>May 2, 1921</td>
<td>Astoria, OR, USA</td>
<td></td>
</tr>
<tr>
<td>Jesse Garner [I0000623]</td>
<td>Death</td>
<td>Jan 21, 1929</td>
<td>Cedar City, UT, USA</td>
<td></td>
</tr>
<tr>
<td>Daniel Garner [I0000627]</td>
<td>Death</td>
<td>Mar 2, 1936</td>
<td>Gary, Lake, IN, USA</td>
<td></td>
</tr>
<tr>
<td>Walter Garner [I0000626]</td>
<td>Death</td>
<td>Oct 23, 1946</td>
<td>Battle Creek, MI, USA</td>
<td></td>
</tr>
<tr>
<td>Jennie Garner [I0000625]</td>
<td>Death</td>
<td>Jun 20, 1964</td>
<td>Columbus, Bartholomew, IN, USA</td>
<td></td>
</tr>
<tr>
<td>Eugene Garner [I0000046]</td>
<td>Death</td>
<td>Mar 1, 1984</td>
<td>Twin Falls, Twin Falls, ID, USA</td>
<td></td>
</tr>
</tbody>
</table>

**On This Day**

Reports - part 8 - Quick Views 297
Right-click on a selected record in the Event view to select from the context menu or, Double-click a day in the Calendar Gramplet to run the On This Day QuickView. The Quick View window shows the Events of the selected day: Events on this exact date and Other events on this Month/day in history as well as Other events in that year.

The information is presented in a table showing:

- Date
- Type
- Place
- Reference

The text in the QuickView is editable. You can also drag a reference to the Clipboard.

Father lineage

Example "Father lineage" quick view report from the People view:

**Father lineage for Big Louie (Big Louie) Garner von Zieliński Sr**

<table>
<thead>
<tr>
<th>Name</th>
<th>Father</th>
<th>Birth Date</th>
<th>Death Date</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Joseph Garner [00000104]</td>
<td>Apr 24, 1826/7 (Julian)</td>
<td>Feb 3, 1916</td>
<td></td>
</tr>
</tbody>
</table>

**Direct line male descendants**

- Eugene Garner (Dec 1, 1895 - Mar 1, 1984)
  - Howard Garner (Jul 9, 1928 - )
    - Barry Garner (Dec 14, 1948 - )
    | Andrew Garner (Apr 11, 1999 - )
    | Gerard Garner (Jul 31, 1955 - )
    | Stephen Garner (Oct 5, 1983 - )
    | Daniel Garner (Feb 11, 1985 - )
    | David Garner (Dec 21, 1956 - )
    | Thomas Garner (Dec 10, 1965 - )
  - Eugene Garner ( - )
    | Francis Garner (Jan 3, 1945 - )
    | Richard Garner (Feb 28, 1947 - )
    | Jason Garner (Oct 20, 1975 - )
    | Michael Garner (Jun 12, 1948 - )
    | Michael Garner (Jun 1, 1975 - )
    | Peter Garner (Aug 5, 1954 - )
    | Mark Garner (Oct 16, 1962 - )
    | John Garner (Aug 15, 1961 - )
    | John Garner (Oct 29, 1925 - )
  - Jesse Garner (Jun 18, 1876 - Jan 21, 1929)
    | Victor Garner ( - )
  - Raymond Garner (Sep 16, 1878 - May 2, 1921)
  - Walter Garner (Feb 17, 1882 - Oct 23, 1946)
  - Daniel Garner (Sep 30, 1893 - Mar 2, 1936)
Mother lineage

Siblings

Relation to Home Person

Fig. 13.8.5 Relationship to Home Person QuickView

Example "Relation to Home Person" quick view report from the People view:

Same Given Names

Same Surnames

Person References

- Person References built-in Quick View : Display showing the backlink references for the active person

Family References

- Family References built-in Quick View : Display showing the backlink references for a family

Event References

- Event References built-in Quick View : Display showing the backlink references for an event

Place References

- Place References built-in Quick View : Display showing the backlink references for a place

Source References

- Source References built-in Quick View : Display backlink references for a Source
- Source or Citation References built-in Quick View : Display backlink references for a Source or Citation

Citation References

- Citation References built-in QuickReport : Display backlink references for a Source or Citation

Repository References

Fig 13.8.6 Repository References Quick View

Repository References built-in Quick View : Display the repository backlink references for sources related to the active repository

Reports - part 8 - Quick Views
• See Repositories Report addon

Media References

• Media References built-in Quick View: Display showing the backlink references for a media object

Link References

Note References

• Note References built-in Quick View: Display showing the backlink references for a note

Quick View Gramplet

Configurable to show the Quick View you want to see.
Available for use from the Dashboard and each of the category view sidebars and bottombars.
See: Gramplets > Quick View

Making your own Quick view

You can create your own Quick view, even with limited programming/coding knowledge.

Many users want to produce a view quickly for their specific needs, but are hindered by the fact they do not want to learn python fully, nor the intricacies of a complicated program like Gramps.

These views are short textual reports that the user can register with Gramps, so they automatically appear in the context menu's.

Accompanying this, the simple database access and simple document interface's have been constructed, so as to hide as much complexity as possible.

See the Quick Views Coding page to make your own.

Back to Index of Reports.
This chapter describes the various *Tools* available in Gramps.

Gramps tools allow you to perform various types of analysis of your genealogical data. Typically, the tools do not produce output in form of printouts or files. Instead, they produce screen output immediately available for the researcher. However, when appropriate, you can save the results of running a tool into a file.

### Tools

The tools can be accessed by choosing the menu **Tools -> Tool Section -> Particular Tool**.

Alternatively, you can browse the complete selection of available tools along with their brief descriptions in a *Tool Selection* dialog invoked by clicking the **Open the tools dialog** icon on the toolbar from any of the categories.

#### Additional Tools

Gramps allows you to install even more tools. This system is controlled by the **Plugin Manager**. For additional tools see **Addons**.

### Tool Selection dialog

The **Tool Selection** dialog allows you to browse the complete selection of available tools along with their brief descriptions when invoked by clicking the **Open the tools dialog** icon on the toolbar from any of the categories and use the ▶ arrows to expand the listings.

### Analysis and Exploration

This section contains tools which analyze and explore the database, but do not alter it. The following analysis and exploration tools are currently available in Gramps:

- **Compare Individual Events**
This tool compares events across the selected group of people.

You can use this tool via menu `Tools->Analysis and Exploration > Compare Individual Events...` which will open the `Event comparison filter selection` dialog.

The people for this comparison can be chosen from previously created custom filters by selecting the `Filter` drop down list, which defaults to the *Entire Database*. Or by selecting the *Custom Filter Editor* button, to create custom filters in the *Person Filters* editor. To run the report select *Apply* and the results will be displayed in the *Event Comparison Results* dialog.

From the *Event Comparison Results* dialog you can view the results or *Save as* the resulting table as a spreadsheet (ODS format). Select *Close* to exit the report.

**Family Tree Processing**

This section contains tools which may modify your database. The tools from this section are used mostly for finding and correcting errors in the data. The following Family Tree Processing tools are currently available in Gramps:

- **Edit Database Owner Information**
This tool modifies any existing Researcher Information.

Select the menu Tools->Family Tree Processing->Edit Database Owner Information... This brings up the Database Owner Editor window, where you can fill in the needed info.

- Name:
- Street:
- Locality:
- City:
- State/County:
- Country:
- ZIP/Postal Code:
- Phone:
- Email:

This information is family tree specific and will be used when exporting your data in GEDCOM format.

Two choices are available from the context menu(right click):

- Copy from DB to Preferences
- Copy from Preferences to DB

Extract Event Description

Note

The name format in the Event's Description field depends on the defined name format in Edit- >Preferences->Display->Name format
Fig. 14.7 Extract Event Description's - Modifications Made - window - example result

Extracts event descriptions from the event data by using a model:

(event type) of (Surname), (Given name)

If event description is missing, then tool will use this event description field model.

You can access this tool via the menu Tools->Family Tree Processing->Extract Event Description...

The Undo history warning will be shown and you can either Stop or Proceed with the tool.

Once you proceed with the tool this tool will scan and modify your Family Tree and present you with the Modifications made result window listing the total number of event descriptions that have been added.

Extract Information from Names

This tool searches the entire database and attempts to extract titles and nicknames that may be embedded in a person's Given name field. If any information could be extracted, the candidates for fixing will be presented in the table. You may then decide which to repair as suggested and which not to.

You can access this tool via the menu Tools->Family Tree Processing->Extract Information from Names....

The Undo history warning dialog will be shown and you can either Stop or Proceed with the tool.

Fig. 14.8 "Default prefix and connector settings" - dialog for the "Extract Information from Names" Tool

The Default prefix and connector settings dialog will be shown and you can modify each of the options as required:

- Prefixes to search for: de, van, von, di, le, du, dela, della, des, vande, ten, da, af, den, das, dello, del, en, ein, elet, les, lo, los, un, um, una, uno, der, ter, te, die (default)
- Connectors splitting surnames: e, y (default)
- Connectors not splitting surnames: de, van (default)

Once you have finished select OK to start the tool.
Once the report finishes the **Name and title extraction tool** dialog results window will be shown.

---

**Extract Place Data from a Place Title**

This tool has been moved to **third party addons**!

When the Place Hierarchy was first added to Gramps, every user needed a tool to **Addon:Extract Place Data from a Place Title**. Now that that a Hierarchy of Places is well established, the tool is needed infrequently. So installation has been made optional.

---

**Find Possible Duplicate People**

The **Find Possible Duplicate People** tool searches the entire Tree database, looking for the entries that may represent the same person.

You can access this tool via the menu Tool -> Family Tree Processing -> Find Possible Duplicate People...

The **Find Possible Duplicate People** dialog will be shown and you can adjust the following options:

- **Match Threshold**: choose between Low (default), Medium and High from the drop down menu.
How is the quality of match measured?

This calculates the chances (or 'odds') of matching on a quality scale labeled as low, medium and high.

For each piece of information that corresponds, the quality of the match is considered to be marginally increased. The closer the particular pieces of data correlate, the larger the increase. When the chance is greater than the selected **Match Threshold** then a match will reported. The thresholds are Low=0.25, Medium=1.0 and High=2.0. So, with the filtering threshold set to High, fewer matches are expected.

Options

- **Use soundex codes**: for matching possible duplicate people. (checkbox checked by default)

The following buttons are present: [Help] brings you to this page, [Cancel] to stop processing and an [OK] button to start processing the data.

Select [OK] to start the tool and the data will be processed in two passes.

- Pass 1: Building preliminary lists
- Pass 2: Calculating potential matches.

A progress bar will be shown and depending the speed of your computer and the amount of people in the database this can take some time.

Fig. 14.11 "Potential Merges" result dialog window for "Find Possible Duplicate People" - dialog - example

Once the report finishes a **Potential Merges** result list window is presented with the following columns shown:

- **Rating**: this gives you an idea of the resemblance between the two people. The higher the ranking, the higher the chance that the people are duplicates.
- **First Person**
- **Second Person**

You can either double-click on the selected row or select the [Compare] button to check the details.

Three buttons are present: [Help] brings you to this page, a [Close] to close the window which returns you to the **Find Possible Duplicate People** window and a [Compare] button to which brings up the **Merge People** window which was explained in detail in the **Merge People** Dialog. Here you can select with the radio buttons one of the persons and eventually use the [OK] button to merge the data if you find the two persons are duplicates.

Selecting the [Cancel] button brings you back to the **Potential Merges** result list window.

**Fix Capitalization of Family Names**

This tool searches the entire database and attempts to fix the capitalization of family names.

The aim is to have conventional capitalization: capital first letter and lower case for the rest of the family name. If deviations from this rule are detected, the candidates for fixing will be presented in the table.

You may then decide which to repair as suggested and which not to.

You can use this tool via menu **Tools->Family Tree Processing->Fix Capitalization of Family Names...**

**Undo history**

- Proceeding with this tool will erase the undo history for this session. In particular, you will not be able to revert the changes made by this tool or any changes made prior to it. It is recommended that you please stop here and backup your database; so that you can revert the process of running this tool.
The **Undo history warning** will be shown and you can either [Stop] or [Proceed with the tool].

![Fig. 14.12 "Capitalization changes" - dialog - results example for "Fix Capitalization of Family Names" tool](image1)

If there were changes to the capitalization of any names you will be presented with the **Capitalization changes** results window. The window shows a list of the family names that Gramps can convert to (according to Gramps) correct capitalization (please check that it is correct for you.). In the **Capitalization changes** results window list the following columns are available:

- **Select** - Check or uncheck these on a "by name" basis if you choose not to accept the recommendation (checkbox checked by default)
- **Original Name** - The name as currently recorded.
- **Capitalization Change** - The name with change if applied.

Select the names you want to be changed, then select the [Accept changes and close] button. Or use the [Cancel] button to abort changes.

You can also install the "Addon: Fix Capitalization of Given Names" tool Addon that once installed works almost identically to this tool but works for "Given Names"

**Merge citations**

 ![The Merge Citations tool](image2)

You can select this via menu **Tools > Family Tree Processing > Merge Citations...** .

**Undo history**

Proceeding with this tool will erase the undo history for this session. In particular, you will not be able to revert the changes made by this tool or any changes made prior to it. It is recommended that you please stop here and backup your database; so that you can revert the process of running this tool.

The **Undo history warning** will be shown and you can either [Stop] or [Proceed with the tool].

![Fig. 14.13 "Merge Citations" - dialog - default](image3)

Then the **Merge Citations** dialog (Title of dialog shows: *Notes, media objects and data-items of matching citations will be combined.*) will be
The following options are available:

- **Match Threshold**: drop down list:
  - Match on Page/Volume, Date and Confidence
  - Ignore Date (default)
  - Ignore Confidence
  - Ignore Date and Confidence
- **Options**: [Don't merge if citation has notes](checkbox unchecked by default)

![Number of merges done](image)

Fig. 14.14 "Number of merges done" result dialog for "Merge Citations" - dialog - Tool - example

Select [OK](select button) to run the tool and once complete it will report back the total with the **Number of merges done** result dialog. See also the [Merge Citations](Merge citations) option available from the Citations Category list view.

**Rename Event Types**

This tool will rename all events of one type to a different type.

You can access this tool via the menu **Tools->Family Tree Processing->Rename Event Types...**

The **Undo history warning** will be shown and you can either [Stop](select button) or [Proceed with the tool](select button).

The undo history warning will be shown and you can either [Stop](select button) or [Proceed with the tool](select button).

![Change Event Types](image)

Fig. 14.15 "Change Event Types" - dialog - example for "Rename Event Types" Tool

The [Change Event Types](Change event types) dialog is presented.

- **Original event type**: fill in the text field or use the drop down menu and select an original event type
- **New event type**: fill in the text field (you can create a complete new type here) or use the drop down menu and select a new type

The example shows a renaming of the **Birth** event to a **Baptism** event.

<table>
<thead>
<tr>
<th>Custom types</th>
</tr>
</thead>
<tbody>
<tr>
<td>While the custom types do not show in the drop down list, you can over type or paste into either of the selection boxes and convert from one to another.</td>
</tr>
</tbody>
</table>
Finally use the [Cancel] to exit or select [OK] to run the tool and once complete it will report back the total events modified with the [Change types] result dialog.

Renaming events

Once completed, this cannot be undone by the regular [Undo] function.

See also:
- Editing information about events

Reorder Gramps ID

This tool can be used to Reorder your Gramps IDs. Several options are available.

Custom IDs'

If you customized your IDs', all those can be replaced by this tool. So take care before you use this tool!

Reorder Gramps IDs

You can use this tool via menu [Tools]->[Family Tree Processing]->[Reorder Gramps IDs]...

The 'Object' column lists the type of ID. Immediately to the left of this column are checkboxes that allow the enabling of changes to individual object types. When checked, the type can be reordered. The 'Object' label is actually a button that can be used to toggle all of the check boxes at once.

The 'Actual' column shows an example of the current ID. The 'Quantity' column show the number of objects.

The 'Format' column can be used to change the ID format for each object type. Note that the format consists of a prefix, the '%04d' and suffix. There
The Events tool has been designed specifically for this purpose, re-sorting all events in the database or just those associated with a targeted selection of people chosen by using a filter. The 'Change' column contains checkboxes for each object type. If this is checked, the IDs for that object will be replaced with new IDs of the format style, unless 'Keep' is also checked. If there is no check, the ID formats are NOT updated, but the number field within the format is renumbered. The 'Change' label is actually a button that can be used to toggle all of the check boxes at once.

The 'Start' field indicates the starting number used during the renumber operation. The 'Start' label is actually a button that can be used to toggle between start at 0, and start after last current number.

The 'Step' field indicates the interval between numbers during the renumber, '1' is a simple increment, '2' will increment by 2 etc. The 'Step' label is actually a button that can be used to toggle between '1', '2', '5', and '10'.

The 'Keep' column contains checkboxes for each object type. If this and 'Change' is checked, the ID formats for that object will be retained, and the number field within the format is renumbered. The 'Keep' label is actually a button that can be used to toggle all of the check boxes at once.

The undo history warning will be shown and you can either stop or proceed with the tool.

When you click 'OK', the tool will show a progress bar.

In different stages the following IDs are reordered: Reordering People IDs, Reordering Family IDs, Reordering Event IDs, Reordering Media Object IDs, Reordering Source IDs, Reordering Citation IDs, Reordering Place IDs, Reordering Repository IDs and finally Reordering Note IDs.

In a next step unused IDs are searched for and assigned.

During this process the tool will examine each ID to see if it looks like it has been 'customized', if it doesn't look like the previous ID format or the default ID format. This might be the case if the user had entered his own text in the ID field for the object when editing it. It might also occur if the third party GetGOV Addon or GeoName Addon has been used, as that tool stores the GOV ID in the ID field. If a 'customized' ID is found, it will ask the user if he really wants to replace the ID. The dialog also allows the user to use the same answer for other customized IDs found.

Sort Events

Events appearing on the Event tab on a Person or Family Editor are not sorted in any particular order other than the order that the events were added. The reason for not enforcing any particular ordering, particularly ordering by date, is to allow for the situation where an event was known to have happened but the exact chronology is not. Importing or merging data from an external source can lead to extra events being added to, but out of sequence with, the existing set of events of a person or family.

Events can be manually re-ordered by drag & drop or by use of the re-order buttons on the Events tab. Either way, an event can be moved up or down in the list of events and Gramps will remember the new order when the changes are saved. The new ordering will be used wherever events are shown elsewhere in Gramps, such as on a report.

The order of all events on a tab can also be changed by clicking a column title. For example, clicking the 'Date' column header will sort all the events in date order. However this way of sorting events is temporary and changes to the event order are not preserved when the window is closed.

The drag and drop approach to sorting events is fine for moving a small number of events but is not practical for large scale changes. The Sort Events tool has been designed specifically for this purpose, re-sorting all events in the database or just those associated with a targeted selection of people chosen by using a filter.

You can use this tool via menu Tools->Family Tree Processing->Sort events...

The undo history warning will be shown and you can either stop or proceed with the tool.
The first option on the **Sort Events** dialog window is used to define the range of people whose events are to be sorted. The first choice in the list is to apply the sorting to all people in the database. Alternative choices are to apply sorting to ancestors and descendants of a chosen person or to a range of people selected by a custom built person filter. After choosing who the sort should apply to, the next thing to consider is how the events should be sorted. The first option is to sort by date. This is probably the most likely choice, but other event attributes can be chosen too. The final choices are whether to make the events sorted ascending or descending and whether to apply the sort to family events that the selected people belong to as well.

### Family Tree Repair

**Check and Repair Database**

This tool checks the database for integrity problems, fixing the problems it can. Specifically, the tool is checking for:

- **Broken family links.** These are the cases when a person's record refers to a family while the family's record does not refer to that person, and vice versa.
- **Missing media objects.** The missing media object is the object whose file is referenced in the database but does not exist. This can happen when the file is accidentally deleted, renamed, or moved to another location.
- **Empty families.** These are the family entries which have no reference to any person as their member.
- **Parent relationship.** This checks all families to ensure that father and mother are not mixed up. The check is also made that parents have different gender. If they have common gender then their relationship is renamed to "Partners".

You can use this tool via menu **Tools->Family Tree Repair->Check and Repair Database...**

### Undo history

Proceeding with this tool will erase the undo history for this session. In particular, you will not be able to revert the changes made by this tool or any changes made prior to it. It is recommended that you please stop here and backup your database; so that you can revert the process of running this tool.

The **Undo history warning** will be shown and you can either [Stop] or [Proceed with the tool].
Any issues found are automatically fixed and the Integrity Check Results dialog will be shown with a summary actions taken. Otherwise you will see the No errors were found dialog stating that The database has passed internal checks.

Gramps had a problem the last time it was run - dialog

Starting in Gramps 5.1.x after Gramps crashes on restart, Gramps will offer to run Check & Repair tool.

Rebuild Gender Statistics

Rebuilds gender statistics for name gender guessing based on the accumulated statistics of genders for given names within the tree. If a gender is common to more than half the in the Tree with a particular first word in their Given name, then Gramps will guess that Gender for that name will be the same.

The statistics can also be cleared (if the Tools ➪ Debug menu has been enabled) with the Dump Gender Statistics Tool.

You can use this tool via menu Tools ➪ Family Tree Repair ➪ Rebuild Gender Statistics...

Once completed the Gender statistics rebuilt result dialog will be shown.

Rebuild Reference Maps

This tool rebuilds reference map tables. This drives the list of References items in editors.

You can use this tool via menu Tools ➪ Family Tree Repair ➪ Rebuild Reference Maps...

Once completed the Reference maps rebuilt result dialog will be shown.

See also

- This rebuild is also performed as part of the Tools ➪ Family Tree Repair ➪ Check and repair database...
Rebuild Secondary Indexes

This tool rebuilds secondary indices.

You can use this tool via menu **Tools ➪ Family Tree Repair ➪ Rebuild Secondary Indexes**... Once completed the **Secondary indexes rebuilt** result dialog will be shown.

The **Rebuild Secondary indexes...** re-constructs the secondary tables in the Tree db. These tables include things like gender statistics (Given Name versus gender) to allow guessing the gender of names as they are entered, surnames (for faster lookup of possible surname and to make the person tree view work), the various IDs for objects (to facilitate lookup by ID), place enclosure tables, to make the place tree view work, and a few others.

In theory, these tables are kept constantly up-to-date when anything changes. So rebuilding the Reference Maps and Secondary Indices should not be necessary. But, especially early on in the Gramps history, bugs sometimes interfered with updates completing correctly. So the tools remain available... 'just in case'.

See also

- This rebuild is also performed as part of the **Tools ➪ Family Tree Repair ➪ Check and repair database**...

Remove Unused Objects

This tool will search your database for pieces of information which are not connected to anything else, and then allow you to edit and attach the information or remove them.

You can use this tool via menu **Tools ➪ Family Tree Repair ➪ Remove Unused Objects**...

The **Unused Objects** dialog is presented.

You can choose from the search option you want to use from the top section of the **Unused Objects** dialog:
Select the Find button to run the report, and once completed the results if any will show in the bottom section of the Unused Objects dialog with the following columns shown:

- **Mark**: Select the row if you want to delete the object (unchecked by default)
- **Type**: Icon representing the type of object.
- **ID**: Gramps internal name for the object.
- **Name**: - of the object.

To examine the object you must double-click on the row and it will show the appropriate editor for the object allowing you to edit if required.

**Mark** the objects you want to delete either using the individual checkboxes or using the associated buttons:

- Mark all
- Unmark all
- Invert marks

Once your deletion choices have been made select the Delete button to delete the objects.

When finished you may then use the Close button to exit the tool.

**Utilities**

This section contains tools allowing you to perform a simple operation on a portion of data. The results can be saved in your database, but they will not modify your existing data. The following utilities are currently available in Gramps:

- **Find database loop**
- **Media Manager**
- **Not Related**
- **Relationship Calculator**
- **Verify the Data**

**Clean input data**

**Remove leading and trailing spaces**

![Clean input data - Gramps](image)

Fig. 14.25 Clean input data

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Tool to suppress leading and trailing spaces. The tool searches for place names with leading or/and trailing spaces. It also looks in the first name and surname.

You can access it from the menu **Tools > Utilities > Clean input data**.

See also:

- **New tool to suppress leading and trailing spaces** - (added in Gramps 5.1.0)
Find database loop

The **Find database loop** utility allows you to verify if you have ancestral loops in the database.

Select this via the menu **Tools->Utilities->Find database loop...** you will get a **Find database loop** window. The window has five tabs; **Gramps_ID, Parent, Gramps_ID, Child, Family_ID**.

1. First Gramps_ID is a reference to the Parent.
2. Parent (Ancestor on the image) is the person we are looking for a loop.
3. Second Gramps_ID is a reference to the Child.
4. Child (Descendant) is the origin of the loop.
5. Family_ID is a reference to the associated family.

In the following complex example, we have multiple ancestral loops:

If we look at the second line, we have :

1. First Gramps_ID : I0002
2. Parent is : Father, Child2
3. Second Gramps_ID : I0001
4. Child is : Father, Father
5. Family_ID is : F0000

To understand what happens :

1. we start at [I0002] Father, Child2.
2. We continue with his son [I0003] Father3.
3. We continue with his son : [I0000] Child, Child.
4. We continue with his son : [I0001] Father, Father.
5. We continue with his son : [I0002] Father, Child2 ===> **HERE, we have a ancestral loop.**

To read more about ancestral loops see:

- Finding Ancestral Loops : Modern Software Experience
- Ancestral Loops : Louis Kessler's Behold Blog

**Media Manager**
The Gramps Media Manager is a group of four separate tools accessed via a wizard dialog that you can access via the menu Tools⇒Utilities⇒Media Manager..., which will show the first Introduction dialog page with the following information on the tool's abilities.

**Introduction**

This tool allows **batch operations** on media objects stored in Gramps. An important distinction must be made between a Gramps media object and its file.

The Gramps media object is a collection of data about the media object file: its filename and/or path, its description, its ID, notes, source references, etc. **These data do not include the file itself.**

The files containing image, sound, video, etc. exist separately on your hard drive. These files are not managed by Gramps and are not included in the Gramps database. The Gramps database only stores the path and file names.

This tool allows you to only modify the records within your Gramps database. If you want to move or rename the files then you need to do it on your own, outside of Gramps. Then you can adjust the paths using this tool so that the media objects store the correct file locations.

From the Introduction page selecting the Next button (or using the keyboard shortcut Alt + N) you will be shown the Selection page window.
From the **Selection** page window select from one the four options the actions you want to take and then select the **Next** button:

- **Replace substrings in the path** (default)
- **Convert paths from relative to absolute**
- **Convert paths from absolute to relative**
- **Add images not included in database**

Replace substrings in the path

This tool allows replacing specified substring in the path of media objects with another substring. This can be useful when you move your media files from one directory to another.

Selecting this radio button will bring up a **Replace substring settings** window where you can type in any string in the **Replace** text field and the **With** text field. At any time you can click on the **Cancel** button or the **Back** button. Clicking the **Forward** button will bring up the **Final confirmation** window.

Convert paths from relative to absolute
This tool allows converting relative media paths to the absolute ones. It does this by prepending the **Base path for relative media paths** as given in the Edit > Preferences > General tab, or if that is not set, it prepends the default User's Directory.

- **Absolute and relative paths**, From Wikipedia.
- **Absolute, relative, UNC, and URL paths** ArcMap help.

### Convert paths from absolute to relative

This tool allows converting absolute media paths to a relative path. The relative path is relative to the given base path in the setting **Base path for relative media paths** as from the Edit > Preferences > General tab, or if that is not set, the user's directory is used. A relative path allows to tie the file location to a base path that can change to your needs.

- **Absolute and relative paths**, From Wikipedia.
- **Absolute, relative, UNC, and URL paths** ArcMap help.

Add images not included in database
Check directories for images not included in database, this tool adds images in directories that are referenced by existing images in the database. You will have to import one media item from each sub directory manually. Media Manager does not include sub-directories automatically. All the directory paths shown in the tool will be searched through.

**Not Related**

This tool will list people who are not connected to the selected active person. Connections may include linked in a chain of references or linkages created with the link editor in Notes.

You can use this tool via menu Tools->Utilities->Not Related...

You will get a **Not related to '...'** results dialog which shows a list of all the people that are NOT related to the selected person.

This list gives you:

- **Name**
- **ID**
- **Parents**
- **Tags**

From the **Name** column you can use the (right arrow) button and (down arrow) buttons to collapse or expand the grouped **Name** list. Double clicking on a person will bring up the **person edit** dialog or **family edit** dialog.

If you select a person, you can use the **tag** text field (you can fill in whatever custom tag name you want to use) or use the drop down list to choose an existing tag eg TODO, NotRelated. Use the **Apply** to add the selected tag to the person(s). This tag will then show up in the **Tags** column.

**Relationship Calculator**
You can use this tool via menu Tools->Utilities->Relationship Calculator....

Selecting the Relationship Calculator tool will open a list filtered to all people connected, but not necessarily related, to the Active Person. To calculate relationship to different person, close the window, make that person Active and select the tool from the menu again.

Select the individual from the filtered list to report if a relationship exists. The exact relationship will be shown in the lower panel along with the common ancestors of that's reported relationship. Only blood relationships will display (except for husband-wife relationships). Note "in-law" relationships are not displayed.

The filtered list will grouped and alphabetically sorted by surname. (Regardless of whether the View menu setting of the Person category has been set to Grouped.) The list columns cannot be re-sorted.

The degree of separation (generation distance) that will be recognized is controlled by the the Max generations for relationships value in the General tab under the Edit->Preferences... menu. (The default of 15 generations will report a 12th great-grandparent relationship but not their parents. The active person is counted as one of the generations.)

Essentially, any two people are directly related by blood if they have an ancestor in common. One of these individuals may actually be an ancestor of the other - such as a great grandparent. Even in the cases of aunts and uncles, you still can calculate the relationship by searching for the common ancestor. In this case, the father or mother of the aunt or uncle will be a grandparent to the nephew or niece.

The most basic blood relationship through common ancestors is that of siblings (brothers and sisters) who are only one generation down from the common ancestor. Another special relationship is that of one of those siblings to the descendants of the other siblings. If the Active Person is a grandchild of the common ancestor, the sibling would be an aunt or uncle. Beyond that generation of descendants, there are two equivalent ways of describing the relationship. The daughter of great grandparents might be called either a granddaughter or a great aunt. (The Relationship Calculator uses the 'grand' variant.) That person is a great grandaunt to the second great grandchildren, who are four generations distant from the common ancestor. (She may also be called a second great aunt.) The reverse relationship of an aunt or uncle is a nephew or niece.

Cousins (also called "first" cousins) are two generations down from the common ancestor through different siblings. "Second" cousins are thus, three generations down from the common ancestor - and so on.

After that, everyone is considered a "cousin", but to indicate that they are not in the same generation we use the word "removed" to indicate the number of generations different between the two. For example, my father's "first" cousin is also my "first" cousin but "once removed" (one generation difference between us). My fathers "first" cousin is my own child's "first cousin twice removed" - two generations different.

If multiple blood relationships exist due to pedigree Collapse, all will be reported.

A full text list of all blood relations and their spouses can be viewed using a Kinship Report.

See also:
- The Relationship to home person Display Preferences option for the Status bar
- Relation to Home Person quick view.
- The Deep Connections gramplet: If this third party addon is installed, it will list the intervening generations through the sibling offspring of a common ancestor. (But it does not list the common ancestor or if both person a connected through the same spouse.) The Gramplet also details the indirect relationships.
- Relationship Calculator Localization - create meaningful relation descriptions in your region.

Verify the Data
This utility allows you to verify the database based on the set of criteria specified by you.

For example, you may want to make sure that nobody in your database had children at the age of 98. Based on common sense, such a record would indicate an error. However, it is not a consistency error in the database. Besides, someone might have a child at the age of 98 (although this rarely happens). The Verify tool will display everything that violates your criteria so that you can check whether the record is erroneous or not. The ultimate decision is yours.

Select this via the menu Tools->Utilities->Verify the Data... you will get a Data Verify Tool window. The window has four tabs; General, Women, Men, Families. Those tabs show a list with criteria and a input field where you can alter the criteria value. In the lists below I show some workable values.

### General

- **Maximum age**: 90
- **Minimum age to marry**: 17
- **Maximum age to marry**: 50
- **Maximum number of spouses for a person**: 3
- **Maximum number of consecutive years of widowhood before next marriage**: 30
- **Maximum age for an unmarried person**: 99

The first check box: Estimate missing or inexact dates causes the tool to accept a baptism date if a birth date is not known, and to accept a burial date if a death date is not known. It also causes the tool to accept "inexact" dates (i.e., any "legal" Gramps date which is not a fully-specified one (with an explicit day and month and year)).

The second check box: Identify invalid dates will check if the dates are invalid.

### Women

- **Minimum age to bear a child**: 17
- **Maximum age to bear a child**: 48
- **Maximum number of children**: 12

### Men

- **Minimum age to father a child**: 18
- **Maximum age to father a child**: 65
- **Maximum number of children**: 15

### Families

- **Maximum husband-wife age difference**: 30
- **Maximum number of years between children**: 8
- **Maximum span of years for all children**: 25
Data Verification Results window

Fig. 14.37 Data Verification Results window.

After you run the tool you will be presented with the Data Verification Results window.

On the bottom of the window four buttons are available to make a selection easier. Those are Mark all, Unmark all, Invert marks, and Hide marked.

Double-clicking on a row will give you a possibility to view and or edit the data.

With the Close button (or select the keyboard shortcut Alt + C) you close the Results window.

Examples

Two examples from using real data with this tool:

- The warning showed 'female husband': checking the data I found a family with father: Anna Roelants. Luckily in the Description I read: The marriage of Adam Roelants and Cornelia Crabbe. It was clearly a typo: Anna is o. Adam. Without this Tool it would be very hard to find.

- The warning showed 'late marriage': checking the data: male person °1738 female person °1756 : marriage X 1804 [Gregorian Calendar]: Everything seemed to be OK: so they (re)married at the age of 66 and 48 years! The warning showed up because the General criteria was set to 60.

![Difference between Verify the Data tool and the Check and Repair Database tool](image)

The Check and Repair Database tool detects inconsistencies in the database structure. The Verify the Data tool, however, is detecting the records that do not satisfy your particular criteria.

Debug

![Warning do not use the Debug tools on your working Family Tree](image)

Always create a new empty Family Tree or a copy of your existing Family Tree for testing. The tools available in this advanced menu are used for testing only.

Fig. 14.38 "Tools >Debug>..." Menubar - Tools - Debug menu

Overview

When the python -o optimise flag is not turned on, an additional Debug entry appears in the Tools menu.

See Command Line: Python options

Check Localized Date Display and Parser
This test tool will create many people showing all different date variants as birth. The death date is created by parsing the result of the date displayer for the birth date. This way you can ensure that dates printed can be parsed back in correctly.

### Dump Gender Statistics

![Fig. 14.40 "Gender Statistics tool" dialog results example - for "Dump Gender Statistics" - Tool](image)

Will dump the statistics for the gender guessing from the first name.

### Generate Testcases for Persons and Families
The testcase generator will generate some persons and families that have broken links in the database or data that is in conflict to a relation. The *Undo history warning* dialog will be shown and you can either *Stop* or *Proceed with the tool*.

**Populate Sources and Citations**

This tool generates sources and citations for each source in order to populate the database for testing with significant numbers of sources and citations.
This section deals with various settings you can manage within Gramps.

Preferences

Most of the settings affecting the entire Gramps program are configured in the Preferences dialog. To invoke it, select the menu Edit ➪ Preferences...

There are overrides that can be set before running Gramps (such setting the Language shown in the interfaces or for reports) that can be set temporarily or permanently from the command line interface.

For configuration options that are limited to the current view or Gramplet set, choose via the menu View ➪ Configure View..., click on Configure View... toolbar button or press the Configure active view keyboard keybinding.

The tabs on the top display the available option categories as follows:

- General
- Family Tree
- Display
- Text
- ID Formats
- Dates
- Researcher
- Warnings
- Colors
- Genealogical Symbols

Also other additional tabs maybe shown from any addons you may have installed.

General

This tab contains two sections containing preferences relevant to the general operation of the program. Sections and options are:

General Gramps settings

- Add default source on GEDCOM import: This checkbox option affects the importing of GEDCOM data. If this is set, each item that is imported will contain a Source reference to the imported file. Note - Adding a default source can significantly slow down the importing of your GEDCOM data.
- Add tag on import: Checkbox (Default: Imported %Y/%m/%d %H:%M:%S) Note - Adding a Tag on import can significantly slow down the importing of your data. Specified tag will be added on import. Clear to set default value.
- Enable spelling checker: This checkbox option controls the enabling and disabling of the spelling checker for notes. The gtkspell package must be loaded for this to have an effect. (See Troubleshoot Spellcheck)
- Display Tip of the Day: This checkbox option controls the enabling and disabling of the Tip of the Day dialog at startup.
- Show useful information about using Gramps on startup: Enabling will bring you to the view where you stopped the program the last time. (See Troubleshoot Spellcheck)
- Max generations for relationships: You can enter the number of generations used to determine relationships. The default value...
is 15.

- **Base path for relative media paths**: Here you can fill in a base path for the media objects. Selecting the **Directory** button gives you a **Select media directory** editor where you can fill in the required path.

**Third party addons management**

- **Check for addon updates**: Select the frequency that Gramps checks for updates to **Addons**. Default: **Never**
- **What to check**: Default: **New addons only**
- **Where to check** (Gramps compatible Addon servers)
  - Default - Gramps project: [https://raw.githubusercontent.com/gramps-project/addons/master/gramps51](https://raw.githubusercontent.com/gramps-project/addons/master/gramps51)
  - Isotammi project: [https://raw.githubusercontent.com/Taapeli/isotammi-addons/master/addons/gramps](https://raw.githubusercontent.com/Taapeli/isotammi-addons/master/addons/gramps)
  - **Do not ask about previously notified addons**: Checkbox selected by default
  - **(Check for updated addons now)** Button to force a check for Addons, if Addons are available you will then be presented the **Available Gramps Updates for Addons** window where you choose and install them from.

**Available Gramps Updates for Addons**

![Available Gramps Updates for Addons](image)

**Fig. 15.3** "Available Gramps Updates for Addons" window showing example listing output for Gramps 5.1

The **Available Gramps Updates for Addons** window will be shown a list broken down by **Type** that you can view by selecting the "Select" column expand out each "Type".

- You can then select the check box of those Addons you want to install.
- Then select the **Install Selected Addons** button to download those Addons from the **Internet**.
- Once downloaded from the **Done downloading and installing addons** dialog select the **Close** button.
- From the **Preferences** dialog select **Close** button.
- To use the Addons you need to **Family Trees>Quit** and restart Gramps.

**Tip of the Day dialog**

![Tip of the Day](image)

**Fig. 15.4** Tip of the Day dialog

When enabled in **Edit > Preferences** **General** tab the **Tip of the Day** dialog shows helpful hints.

The following options are available:

- **Display on startup** (check box checked by default - once enabled) - uncheck to stop further tips appearing.
Family Tree

This tab contains preferences relevant to the Family Tree Database settings and Backup management.

- **Database backend**: 
  - BSDDB - Legacy Database backend. Superseded in the Gramps 5.1 version.
  - SQLite (default) - the DB-API Database Backend
  - If other database backends addons are installed, they will be added to the list e.g.: [Addon:PostgreSQL]PostgreSQL] backend

- **Host**: Server address or other computer IP address for the location of the database.
- **Port**: Port number to access the Host database

- **Family Tree Database path**: Unless you have a definite reason to change this, stay with the default path. This path will be within the User Directory of the local machine's Operating Systems.
  The default path where the Databases are stored is:
  
  - `/home/<username>/gramps/grampsdb` (Linux and macOS)
  - `C:\Users\<~username>\AppData\Roaming\gramps\grampsdb` (Windows)

- **Automatically load last family tree**: Selecting this checkbox option causes the last used database to load upon start. It bypasses the Manage Family Trees dialog.

- **Backup path**: Location in which to save your Gramps backup archive files.

- **Backup on exit**: Selecting this option will Backup Your family tree upon choosing to exit Gramps. The file be saved to the Backup path specified above. The filename of the backup will match the Family Tree appended with a date and time.

- **Autobackup**: timer interval for triggering full backups during Gramps editing sessions.
  - Never (default)
  - Every 15 minutes
  - Every 30 minutes
  - Every hour

See also:

- **Backing up a family tree** - more information on backups
- **Backup omissions** - what is not included during a backup
- **Addon PostgreSQL** - this adds support for PostgreSQL databases.

Display
The **Display** tab contains preferences relevant to the display of data and names, **Appearance and format settings**. Options are:

- **Name format**: This option controls the display of names in the current database (the setting is saved in the database and is not system wide). In Gramps there are two type of name display formats: the predefined formats, and the user defined custom formats. Several different predefined name formats are available: Given - Prefix Patronymic, Suffix Given - Prefix Surname, Given Patronymic Suffix etc.
  - Clicking on the right hand side **Edit...** button will bring up a **Display Name Editor** window where the available list of options is shown. The format is given as well as an example. When predefined formats are not suitable one can define one's own format. You can use the **Add** button to add a Name format to the list. Clicking once will give you a SURNAME,Given Suffix(call) format and as example : SMITH, Edwin Jose Sr (Ed). If you added new name formats to the list the **Remove** and **Edit** buttons become available to change the name format list.
  - **Consider single pa/matronymic as surname** Checkbox unselected by default. If selected enables Gramps to consider patronymic and matronymic names as surnames.

- **Date format**: This option controls the display of dates. It is a global setting, requiring a restart of Gramps to take effect, and applies to the display of dates in all databases loaded within Gramps until such time as the date display format is changed again. Several different formats are available, which may be dependent on your locale. Please note once changed it is necessary to restart Gramps to view the new date display format
  - **YYYY-MM-DD** (ISO) (Default) - Example 2020-09-30 - Displays the date using the international standard ISO 8601 Data elements and interchange formats – Information interchange particularly useful when sharing data between countries with different conventions for writing numeric dates and times.
  - **Numerical**
  - **Month Day, Year**
  - **MON DAY, YEAR**
  - **DAY MON YEAR**

- **Place format (auto place title)**: This option controls the display of places. Enables automatic place title generation using specified format.
  - **Full** (Default)
  - Selecting the **Edit...** button will show the **Place format editor**.

- **Age display precision (requires restart)**: 
  - **Years** (default)
  - **Years, Months**
  - **Years, Months, Days**

---

**Reported Bug in version 5.1.1 Fixed in version 5.1.2**

Changes made in the "Age Display Precision" in the Preferences Display tab cannot be saved in this version of Gramps.


- **Calendar on reports**: **Gregorian** (default). This option controls the display of calendar on reports, tools, gramplets, views. Several different calendars are available (see *Date Edition*). Two dates with two different calendars will not properly display timeline or period, (e.g. Using the Gregorian calendar as the default displayed calendar, users will have a better coherency for displaying dates on period).

- **Surname Guessing**: This option affects the initial family name of a child when they are added to the family tree. The default **Father’s surname** will use the family name of the father. Selecting **None** means that no surname guessing will be attempted. Selecting **Combination of mother’s and father’s surname** will use the father's name followed by the mother's name. Finally, **Icelandic**
**Style**: will use the father's given name followed by the "sson" suffix (e.g. the son of Edwin will be guessed as Edwinsson).

**Tip**

The **Surname Guessing** option only affects the initial family name guessed by Gramps when the **Edit Person** dialog is launched from a **Family Editor** window. You can modify that name any way you see fit. Set this Preferences **Display tab** option to the value that you will most frequently use, as it will save you a lot of typing.

See:

- feature request to support other local variations for surname guessing
- Category: Names by culture, From Wikipedia, the free encyclopedia

- **Default family relationship**: Unknown (default), Married, Unmarried, Civil Union
- **Height multiple surname box (pixels)**: Default: 150
- **Status bar**: This option controls the information displayed in the status bar. This can be either the **Active person's name and ID** (default) or **Relationship to home person**.

**Show text label beside Navigator buttons (requires restart)** checked (default) This checkbox controls whether or not a text description is displayed next to the icon in the **Navigator** in the **Main Window**. This option takes effect after the program has been restarted. **Show or hide text beside Navigator buttons (People, Families, Events...)** : Requires Gramps restart to apply.

**Show close button in gramplet bar tabs** unchecked (default) This checkbox controls whether or not a close button is displayed to simplify removing gramplets from bars.

**Display Name Editor**

**Note**

Custom name display formats are stored in the Family Trees, thus before loading any Family Tree the **Custom format details** expander is disabled.

![Display Name Editor](image)

**Fig. 15.7** Display Name Editor - dialog (example) from Menu: "Edit->Preferences..." -> "Display" - tab

The following keywords are replaced with the appropriate name parts:

- **Given** - given name (first name)
- **Title** - title (Dr., Mrs.)
- **Call** - call name
- **Initials** - first letters of Given
- **Primary, Primary[pre] or [sur] or [con]** - full primary surname, prefix, surname only, connector
- **Patronymic, or [pre] or [sur] or [con]** - full paternal surname, prefix, surname only, connector
- **Familynick** - family nick name
- **Rest** - non primary surnames
- **Rawsurnames** - surnames (no prefixes and connectors)
- **Surname** - surnames (with prefix and connectors)
- **Suffix** - suffix (Jr., Sr.)
- **Nickname** - nick name
- **Common** - nick name, otherwise first of Given
- **Prefix** - all prefixes (von, de)
- Not patronymic - all surnames, except pa/matronymic & primary

**UPPERCASE versions of these keywords forces uppercase to be displayed.** Extra parentheses, commas are removed. Other text appears literally.

![Fig. 15.8 Display Name Editor - reference person](image)


All the fields in the Example except the Family Nickname can be added in the standard Person Editor dialog. Double-click the Preferred name in Names tab of the Person Editor to access additional fields including: the Family Nick Name, Grouping controls, exception Sorting & Display controls, Date range controls for using a particular name.

![This article's content is incomplete or a placeholder stub. Please update or expand this section.](image)

**Place Format Editor**

![Feature - introduced in Gramps 4.1](image)

**Hierarchical Place Structure**

![Fig. 15.9 Place Format Editor - dialog (example) from Menu: "Edit>Preferences..." - "Display" - tab](image)
This tab contains preferences relevant to how Places should be shown.

- **Name:** A unique name for the place format.
- **Levels:** The place names to be displayed.

Each level in the hierarchy is represented by a positive integer, starting with 0 for the selected place and increasing by 1 for each level up the hierarchy. The levels can also be represented by negative integers, starting with -1 for the top level (usually a country) and decreasing by 1 for each level lower in the hierarchy. In addition, the populated place (city, town, village or hamlet) is represented by the letter p; this can be used with an offset (e.g. p+1 or p-2).

The names to be displayed are defined as a comma-separated list of ranges. A range can either be a single level, or a start level and an end level separated by a colon. The start level must be less than the end level in a range. The start and end levels default to 0 and -1 if missing.

- **Street format:** "None" (Default), "Number Street" or "Street Number". Option to concatenate the number and street in order to suppress the comma. For this option to work, the street must have the Type Street and house number must have the Type Number.
- **Language:** (Empty by Default) A two-digit language code.
  - **Reverse display order** (checkbox unchecked by default)

See also:

- Place Editor dialog
- Place Name Editor dialog

**Text**

![Fig. 15.10 Menu: "Edit>Preferences..." - "Text" - tab - defaults](image)

This tab contains preferences relevant to how missing and private names and records should be shown.

- **[Missing surname]** in the input field you can determine how a missing surname should be displayed. Default value is [Missing Surname]. You can change this to [--] or whatever is most convenient for you.
- **[Missing given name]** in the input field you can determine how a missing given name should be displayed. Default value is [Missing Given Name]. You can change this to whatever you want.
- **[Missing record]** Default: [Missing Record]
- **[Private surname]** Default: [Living]
- **[Private given name]** Default: [Living]
- **[Private record]** Default: [Private Record]

**ID Formats**

<table>
<thead>
<tr>
<th>ID Prefixes</th>
</tr>
</thead>
<tbody>
<tr>
<td>The ID prefixes use formatting conventions common for C, Python, and other programming languages. For example, the %04d expands to an integer, prepended with zeros to have the total width of four digits. If you would like IDs to be 1, 2, 3, etc., simply set the formatting parameter to %d, the 'd' specifies Decimal Integer, outputting the number in base 10.</td>
</tr>
</tbody>
</table>

See: Python ([String]) Format Specification Mini-Language
This tab contains preferences relevant to the automatic generation of Gramps IDs.

- **Person**: Provides the template for generating IDs for a Person. Default value: I%04d
- **Family**: Provides the template for generating IDs for a Family. Default value: F%04d
- **Place**: Provides the template for generating IDs for a Place. Default value: P%04d
- **Source**: Provides the template for generating IDs for a Source. Default value: S%04d
- **Citation**: Provides the template for generating IDs for a Citation. Default value: C%04d
- **Media Object**: Provides the template for generating IDs for a Media Object. Default value: O%04d
- **Event**: Provides the template for generating IDs for an Event. Default value: E%04d
- **Repository**: Provides the template for generating IDs for a Repository. Default value: R%04d
- **Note**: Provides the template for generating IDs for a Note. Default value: N%04d

You can use the Reorder Gramps ID tool to change the format.

### Dates

Date settings used for calculation operations.

- **Markup for invalid date format**: Default: <b>%s</b>
  - Convenience markups are:
    - <b>Bold</b> (Default)
    - <big>Makes font relatively larger</big>
    - <i>Italic</i>
    - <s>Strikethrough</s>
    - <sub>Subscript</sub>
    - <sup>Superscript</sup>
    - <tt>Monospace font</tt>
    - <u>Underline</u>
  - For example: <u><b>%s</b></u> will display Underlined bold date.

- **Date about range**: Default: 50
  - Defines the number of years +/- of the event date "about <date>" that the event will return as valid for a filter.
  - Used in the calculation of the person's age.

- **Date after range**: Default: 50
  - Defines the number of years after the event date "after <date>" that the event will return as valid for a filter.
  - Used in the calculation of the person's age.
• **Date before range**: Default: 50
  - Defines the number of years before the event date "before <date>" that the event will return as valid for a filter.
  - Used in the calculation of the person's age.
• **Maximum age probably alive**: Default: 110
  - Absent a Death event, the age by which Gramps will consider the person is no longer alive.
• **Maximum sibling age difference**: Default: 20
• **Minimum years between generations**: Default: 13
• **Average years between generations**: Default: 20

See also:

- [Gramps 5.1 Wiki Manual - Probably Alive](#)
- Editing dates
- Setting the date approximation.ini manually

### Researcher

**Researcher Information**

This contact information is independent of the family trees you create.

Most exports and reports will be filtered to protect the privacy of living people of the Tree... including yourself. This information feeds into the authoring and citation features of any publication (or archival) options.

![Fig. 15.13 Menu: "Edit>Preferences..." - "Researcher" - tab - defaults](#)

Allows you to **Enter your information so people can contact you when you distribute your Family Tree** in the corresponding text entry fields. Although Gramps requests information about you, this information is used only so that Gramps can create valid GEDCOM output files. A valid GEDCOM file requires information about the file's creator. If you choose, you may leave the information empty, however none of your exported GEDCOM files will be valid.

The available text entry fields are (all blank by default):

- **Name**:
- **Address**:
- **Locality**:
- **City**:
- **State/County**:
- **Country**:
- **ZIP/Postal Code**:
- **Phone**:
- **Email**:

The information entered under this preference acts as default value for family tree specific values that can be adjusted with the Edit Database Owner Information tool.

### Warnings
This tab controls the display of warning dialogs, allowing the re-enabling of dialogs that have been disabled.

- Suppress warning when adding parents to a child. Checkbox checked by Default (See Dialog)
- Suppress warning when cancelling with changed data. Checkbox unchecked by Default (See Dialog)
- Suppress warning about missing researcher when exporting to GEDCOM. Checkbox unchecked by Default (See Dialog)
- Show plugin status dialog on plugin load error. Checkbox unchecked by Default (See Dialog)

See the Error and Warning Reference page for examples.

Colors

This tab allows you to set the colors used for boxes in the graphical views.

You can select the

- **Colour scheme**: Light colours (default) or Dark colours
- **(Restore to default)** - restores themes default colors.
- Colors for Male persons
- Colors for Female persons
- Colors for Unknown persons
- Colors for Family nodes
- Other colors

Pick a Color selector
Fig. 15.16 "Pick a Color" - selector dialog

Select a color from the color pallet area, or select the [Custom] button to create your own color either via direct 'color Hex color code'; the slider or mouse click.

**Genealogical Symbols**

---

**Prerequisites exist for this feature**

The Genealogical Symbols tab can only be used if the prerequisite program `python-fontconfig` is present that Gramps can use.

---

Fig. 15.17 "Genealogical Symbols" - Preferences tab - activated defaults

Allows you to use Genealogical symbols instead of text abbreviations in reports, charts and the Gramps interface.

This tab gives you the possibility to use one font which is able to show all genealogical symbols. (Once configured see: [Prerequisite to use Genealogical Symbols](#))

If you select the "use symbols" checkbox, Gramps will use the selected font if it exists.

This can be useful if you want to add phonetic in a note to show how to pronounce a name or if you mix multiple languages like Greek and Russian.

You can only configure the death symbol from this tab.

List of Genealogical Symbols shown (listed in order shown at bottom screenshot):

- Female
- Male
- Asexuality, sexless, genderless
- Lesbianism
- Male homosexuality
- Heterosexuality
- Transgender, hermaphrodite (in entomology)
- Transgender
- Neuter
- Illegitimate
- Birth

---

Settings - Preferences
- Baptism/Christening
- Engaged
- Marriage
- Divorce
- Unmarried partnership
- Buried
- Cremated/Funeral urn
- Killed in action
- Extinct
- Death

<table>
<thead>
<tr>
<th>meaning</th>
<th>symbol</th>
<th>Unicode code point(s)</th>
<th>name</th>
</tr>
</thead>
<tbody>
<tr>
<td>male</td>
<td>♂</td>
<td>U+2642</td>
<td>Male Sign</td>
</tr>
<tr>
<td>female</td>
<td>♀</td>
<td>U+2640</td>
<td>Female Sign</td>
</tr>
<tr>
<td>unknown</td>
<td>⚬</td>
<td>U+26AA</td>
<td>Medium White Circle</td>
</tr>
<tr>
<td>hermaphrodite</td>
<td>♂♀</td>
<td>U+26A5</td>
<td>Interlocked Male and Female Sign</td>
</tr>
<tr>
<td>neuter</td>
<td>♀♂</td>
<td>U+26B2</td>
<td>Neuter</td>
</tr>
<tr>
<td>birth</td>
<td>⚫</td>
<td>U+002A</td>
<td>Asterisk</td>
</tr>
<tr>
<td>baptism, christening</td>
<td>⚫</td>
<td>U+007E</td>
<td>Tilde</td>
</tr>
<tr>
<td>death</td>
<td>†</td>
<td>U+271D</td>
<td>Latin Cross</td>
</tr>
<tr>
<td>burial</td>
<td>⚰</td>
<td>U+26B0</td>
<td>Coffin</td>
</tr>
<tr>
<td>cremation</td>
<td>⚲</td>
<td>U+26B1</td>
<td>Funeral Urn</td>
</tr>
<tr>
<td>stillborn</td>
<td>⚫</td>
<td>U+0086 U+002A</td>
<td>Latin Cross, Asterisk</td>
</tr>
<tr>
<td>born illegitimately</td>
<td>⚫</td>
<td>U+002A U+20DD</td>
<td>Circled Asterisk</td>
</tr>
<tr>
<td>born illegitimately</td>
<td>⚫</td>
<td>U+229B</td>
<td>Circled Asterisk Operator</td>
</tr>
<tr>
<td>killed in action</td>
<td>⚫</td>
<td>U+2694</td>
<td>Crossed Swords</td>
</tr>
<tr>
<td>this line extinct</td>
<td>‡</td>
<td>U+2021</td>
<td>Double Dagger</td>
</tr>
<tr>
<td>approximate(ly)</td>
<td>±</td>
<td>U+00B1</td>
<td>Plus-Minus</td>
</tr>
<tr>
<td>before</td>
<td>&lt;</td>
<td>U+003C</td>
<td>Less-Than Symbol</td>
</tr>
<tr>
<td>after</td>
<td>&gt;</td>
<td>U+003E</td>
<td>Greater-Than Symbol</td>
</tr>
<tr>
<td>engaged</td>
<td>⚪</td>
<td>U+26AC</td>
<td>Medium Small White Circle</td>
</tr>
<tr>
<td>married</td>
<td>⚪</td>
<td>U+26AD</td>
<td>Marriage Symbol</td>
</tr>
<tr>
<td>divorced</td>
<td>⚪</td>
<td>U+26AE</td>
<td>Divorce Symbol</td>
</tr>
<tr>
<td>unmarried</td>
<td>⚪</td>
<td>U+26AF</td>
<td>Unmarried Partnership Symbol</td>
</tr>
</tbody>
</table>

**Prerequisite to use Genealogical Symbols**

![Genealogical Symbols preferences tab](Fig. 15.18 "Genealogical Symbols" - Preferences tab - defaults)

**Initial setup**

If the fontconfig prerequisite has been installed, then on the Genealogical Symbols tab select the Try to find button, Gramps will attempt to detect any suitable unicode text fonts that can be used.
When the search has completed select one of the fonts from the Choose font list and then select the checkbox:

- Use symbols

**Prerequisite**

**Prerequisite:** python-fontconfig: Python bindings of fontconfig and its dependencies are required for displaying genealogical symbols

Use the Prerequisites Checker

Do you have python-fontconfig installed? Run the Prerequisites Checker Addon and look for something similar to the following line:

* python-fontconfig 0.5.0 (Success version 0.5.x is installed.)

See also:

- Tamura Jones expounds on Genealogical Symbols (the 'Unicode' section is particularly relevant)
- GEPS 039: Genealogical symbols in gramps
- Feature request: 9098 Gramps should be able to use genealogy symbols everywhere.
- Customize the Genealogical Symbols lookup table located in the Gramps user directory at: gramps/gen/utils/symbols.py

**Other settings**

Besides Preferences dialog, there are other settings available in Gramps. For various reasons they have been made more readily accessible, as listed below.

**Column Editor**

The Column Editor is available and works in the same way for all list views. Specifically, it is available for People View, Family View (children list), Sources View, Citations View, Places View, Media View, Repositories View and the Notes View.
The columns of the list views may be added, removed, or reordered in a Column Editor dialog.

To use the Column Editor dialog for the current view, choose via the menu View ➪ Configure View..., click on Configure View... toolbar button or press the Configure active view keyboard keybinding.

Only columns with a selected checkbox will be shown in the view. You can also change the position of a column in the View by clicking and dragging it to a new position in the Editor (drag and drop). Once you have made the changes you want click Apply, then click OK to exit the Editor and see your changes in the View.

By default, the View List, displays several columns of information about the respective category. You can add or remove columns to and from the display.

The default sort key for the view [always ascending] is the left-most field [i.e. at the top in the Column Editor], so changing which field is in that position affects default sorting.

The Column Editor dialog will have a different selection of columns for each category of View that displays a simple table.
Changes will only be enacted when the **Apply** button is clicked.

Once the View columns changes have been applied, clicking once on the column header sorts in ascending order, clicking again sorts in descending order.

The subset of columns and the current filters will also constrain the data exported via the **Family Trees ➪ Export View...** operation. Hidden columns and records will not be exported.

**Sorting columns**

By default, each Category View presenting data in a columnated table layout will sort the rows in ascending order based on the data in the first (left-most) column. If the table has grouped rows, the grouped data will be sub-sorted. *(Tables in tabbed subsets of data, Editors and Selectors will work similarly.)*

Click once on a different column header to sort on the data of that column in ascending order. Click the header again to sort in reverse order.

The **Column Editor** dialog can be used to add, remove and rearrange the displayed columns. Choosing a different first column will make that the new default sorting column of the view [though always ascending].

**Setting Home person**

To set (designate) the **Home person**, select the People Category and select the desired person to make them into the **Active Person** and then choose **Edit ➪ Set Home Person** via the menus.

Alternately, when editing any Person, right-clicking on inactive areas (areas without a text-entry box) of the top section displays a pop-up menu which includes an option to **Make Home Person** of that profile.

The Home person is the persistently designated person who becomes the **Active Person** when one of the following occurs:

- By default, when the Family tree database is opened
  *(The **General** setting in **Preferences** can modify this default behavior. The "Remember last view displayed" will return to the last **Active Person** of the previous session.)*
- As the toolbar **Home** button is clicked
- When the Home menu item is selected from either the **Go** menu or the right-click context menu in selected views
- As the **keybinding** **ALT+Home** is pressed to return to the **Home Person**.

The toolbar **Home** button is available in the People Category, Relationships Category, and Pedigree Category.

**See also**
• Setting the Home Person

Adjusting viewing controls

Whether the toolbar, the sidebar, or the filter (not available on Pedigree and Relationships Views) are displayed in the main window is adjusted through the View menu.

In the different views clicking the View menu will shows for boxes you can click:

- Navigator
- Toolbar
- Sidebar
- Bottombar
- Full Screen F11

Additionally, depending on the view you are in, other options will be available on Configure:

- Gramplets:
  - Set Columns to 1
  - Set Columns to 2
  - Set Columns to 3
- Relationships:
  - Show Siblings
  - Show Details
- Geography:
  - Time period
  - Layout

All other Views: the column editor.

Export View

On most Category List Views, displayed data maybe be exported, choose via the Family Trees -> Export View... menu command.

This Menu command only appears if the displayed data can be exported. Gramps will export data on screen according your choice: CSV or Open Document spreadsheet format.

Note that the current configuration of the View's columns will control what data will be exported. The export will contain only the displayed column data (in the same order) and be limited to records matching any filters you have applied.

Export View as Spreadsheet dialog

Fig. 15.25 Menubar - "Family Trees" - overview example showing "Export View" menu entry

Fig. 15.26 "Export View as Spreadsheet" CSV (default) file-dialog - example
Gramps will then display the *Export View as Spreadsheet* dialog where after choosing a file location to save to and a name for your file; export data on from the Category List View in one of two spreadsheet formats:

- CSV (default)
- OpenDocument Spreadsheet - ODS format.

![Example ODS Spreadsheet](Fig. 15.27 Example ODS Spreadsheet - Displayed in LibreOffice Calc)

The example screenshot shows an export to the OpenDocument Spreadsheet (ODS format) displayed as a Spreadsheet in Libreoffice Calc.

**Modularity and plugins**

Gramps has been designed for expansion. The Plugin (a.k.a. Plug-in, addon, extension) framework provides a path for 3rd party development outside the normal Gramps release distributions.

The documentation for each addon is maintained outside the flow of these main wiki chapters. The interface & functionality of the software & documentation may not conform with the styles seen throughout the rest of Gramps... although we encourage Developers to try to make their additions as seamless as possible.

A brief description & screenshot of each addon can be found in the Addon List section of the wiki manual. The separately maintained documentation page for the addon is linked from the 1st column of that list.

See Plugin Manager and Third-Party Addons.

**Customize report output formats**

![Document Options](Fig. 15.28 Document Options - tab defaults for Text Reports (Plain Text - output selected) example)

What kind of output customization is available? This dialog allows you to change the fonts, font sizes, font color, background color of the text and alignment of paragraphs on the report.

For most report dialogs, in the top part are option tabs specifically related that particular report. The lower part will have more broadly reusable features and is called the *Document Options* section.

From the **Style** drop down list you can choose an existing custom style. Or to make your own **Style** select the **Style Editor...** button to show the **Document Styles** dialog and then select the **Add a new style** button to show the **Style editor** dialog.

![This article's content is incomplete or a placeholder stub. Please update or expand this section.](Settings - Other settings)
The Document Styles dialog, list the default style and any custom styles for that report and allows you to edit or delete any custom styles you have created. Select the (Add a new style) button to show the Style editor dialog.

Style editor dialog

The Style editor dialog allow you to customize the document style specific to each report.

Change the Style sheet name: (New Style default) field to a unique name as it will appear in Document Options Style drop down list.

Once changes for your custom style have been finalized select the OK button to save the changes or Cancel to exit.

Style editor dialog tabs

On the left hand side you will see the Style column that list the paragraph options specific to that report that you may modify. For example the Ahnentafel Report shows the style options for AHN-Entry, AHN-Generation and AHN-Title.

On the right hand side are three tabs associated with each style listed in the left hand column:

- **Description**: The description describes what each paragraph is all about. For example shown here is the style used for the Ahnentafel Report (AHN-Entry).

Font options
Font options:
Here you can set the **Type face** Roman or Swiss, the **Size** of the font in pt., the **Color** of the font and some **Options** like Bold, Italic or Underline.

Paragraph options:
Here you set the **Alignment**, the **Background color**, **Indentation**, **Spacing** and **Borders** of your style.

Context menu

Used in various places in Gramps; how you access the context menu is dependent on your operating systems:

- On Microsoft windows, you generally use the right button of your mouse to show the context menu or use the keyboard shortcut **Shift** + F10. see Using Context Menus - Microsoft Docs.
- On Apple macOS, you generally press **cmd** while clicking the button of your mouse to show the context menu. see: Contextual Menus - Menus - macOS - Human Interface Guidelines - Apple Developer

See also:

Settings - Other settings
Customizing

Here are some ways that you can customize Gramps.

Preferences

The Display tab of the Preferences allows selection of the Name format used by default throughout Gramps. The Edit button for the Name format opens the Display Name Editor, allowing the creation of user-defined (custom) stylings beyond the pre-defined (built-in) name format choices.

See Preferences

The Edit button for a person's preferred and alternative names opens the Name Editor, allowing the selection of a name format exceptions that will override the format chosen in the Display tab of Preferences for the entire Tree.

The name format, grouping and sorting can be overridden for selected individuals and surnames. The Edit Person dialogs have two Edit buttons to access this feature. The button for Preferred name is to the right of the Suffix field. However, for any selected Name (Preferred or Alternative) in the Names tab which opens the Name Editor. The built-in and custom Display Name formats can be selected exceptions to "Group as:" and "Sort as:" options that default to the Name format selected in Preferences.

File Chooser

Fig. 15.33 Linux GTK File Chooser: highlighting breadcrumbs and bookmarking

Fig. 15.34 macOS GTK File Chooser: highlighting breadcrumbs and bookmarking

Fig. 15.35 Windows GTK File Chooser: highlighting breadcrumbs and bookmarking

The Open and Save dialogs (File Chooser) for Gramps are based on the GTK File Chooser. Each operating system has expected behaviors for clicks, double-clicks, sorting, keybindings, environmental variables, and standard file locations that are characteristic of File Chooser dialogs native.
to the operating system. A few of these can be customized via the user interface to feel more similar to the OS native File Choosers.

The `GtkFileChooser` allows for adding quick navigation hotlinks to commonly used places of the filesystem. In the default implementation, these are displayed in the left sidebar navigation pane. It may be a bit unclear at first that these shortcuts come from various sources and in various flavors, so let’s explain the terminology here:

- **Bookmarks**: are created by the user, by dragging folders from the right pane to the left pane, or by using the “Add”. Bookmarks can be renamed and deleted by the user.
- **Shortcuts**: can be provided by the Gramps application. For example, program may want to add a shortcut for a Downloads or Documents folder. Shortcuts cannot be added or removed by the user. The ‘Rename...’ context menu option allows them to be relabeled.
- **Volumes**: are provided by the underlying filesystem abstraction. They are the “roots” of the filesystem. The Home and Downloads hotlinks are common "roots". Volumes cannot be modified by the user.

**Context Menu options**

Right-click on any file or folder in the current directory to open context pop-up menu with the following options:

- Open With File Manager
- Copy Location
- Add to Bookmarks
- Show Hidden Files
- Show Size Column
- Show Type Column
- Show Time
- Show Folders before Files

Right-click in the navigation sidebar to open context pop-up menu with the following options:

- Open
- Remove
- Rename...

**Breadcrumbs and text-entry address bar**

By default, the file folder navigation in the File Chooser is by browsing. There are also some shortcuts on the left and breadcrumbs (highlighted in green in the dialog illustration) for quick navigation up and down the path.

Optionally, a text-entry address bar can be used to directly key-in or paste a path. Toggle between displaying breadcrumbs and the text-entry address bar with the `CTRL + L` keybinding.

**Bookmarking file folders**

File folder bookmarks can be user defined to make finding standard locations easier. These bookmarks are remembered between sessions and regardless of which Family Tree has been loaded.

With any Open or Save dialog open, navigate to the file location containing the folder to be bookmarked. Create the bookmark by either: dragging the folder icon to the navigation column on the left; or, right-clicking that folder to use the Add to Bookmarks context menu option.

Right-clicking an existing Bookmark allows renaming that bookmark or removing it.

**File Formats**

Support for several file formats are built into the standard distribution of Gramps. Import plugin and Export Plugin Addons can be installed via the Plugin Manager or Preferences to expand the options.

See the [Output Format](#) article for list of file formats.

**See also**

- [How to Show Text-Entry Address Bar or “Breadcrumbs” (Navigation Buttons)](#) in Nautilus After Ubuntu 10.04 Upgrade
- Discourse discussions about the GTK File Chooser:
  - [Documenting the File Chooser in the wiki](#)
  - [Illustrating the File Chooser in the Wiki](#)
  - [File Chooser: Sorting files and folders](#)

**Language**

Gramps has been translated into a number of languages. Usually Gramps automatically starts in your local language, as chosen for other applications, but sometimes this may not be right for you. And in other cases, a module or addon will not yet have been translated and a warning dialog will appear saying something like “Warning: plugin XYZ has no translation for any of your configured languages, using US English instead”. (Note that the US dialect of English is the default rather than British.) This can become annoying or intrusive.

The most idealistic situation is that you are as facile in US English as the language selected for the operating system GUI on your computer. And that you would take the opportunity to translate that Gramps feature for users who are non-English speakers.

If your system is configured to show a language other then English, you can override this for Gramps.
As an example, assume that a computer in the Netherlands is configured to default to Unicode 8 Dutch: "LANG: nl_NL.UTF-8". You could either reset the OS language.

In Windows, use the SET command to rest the LAN env variable to "en_GB.UTF-8" for British English. You can do this from the command line interface or create a startup shortcut with the following Target: `c:\Windows\System32\cmd.exe /c "SET LANG=en_GB.UTF-8 & & START /D "C:\Program Files\GrampsAIO64-5.1.3" gramps.exe"`

Linux

If you want to choose a locale 'variant' for sorting that is not the default variant, then you can start Gramps from the terminal (or console) with a different LC_COLLATE environment. For example, the default sorting (collation) variant for Swedish is "reformed", but you can instead choose "standard" by typing:

```
export LC_COLLATE="sv_SE.UTF-8@collation=standard"
python Gramps.py
```

Mac OS X

For Mac OS X see Advanced setup for details on how the language is normally chosen, and how to choose a special, non-default setting for the language, the sorting order or the format of such things as day and month names and number separators.

MS Windows

![Fig. 15.36 Microsoft Window Gramps AIO Installer Choose Components-Selection window.](image)

If you want to run Gramps in another language other than English using the Gramps AIO installer, then you must select it during installation process.

Otherwise it will not be available.

More information can be found at Download#MS_Windows page.

**Add Windows OS Menu Item**

**Settings - Customizing**
To make Gramps work in your selected language (See table below for your language code), complete the following:

- Using your mouse right button click on the "GrampsAIOxx 5.x.x" icon on Desktop and from menu choose: Copy.
- Right click anywhere on Desktop and from menu choose: Paste shortcut
- New icon will be created with name: "GrampsAIOxx 5.x.x (2)"
- Right click on that and from menu choose: Properties
- A new window will open, click on first tab called General and change text from "GrampsAIOxx 5.x.x (2)" to something more descriptive like: "GrampsAIO Danish"
- Click on second tab called Shortcut, change text in first entry called Target from (note path will vary depending on Gramps version used):
  - 'C:\Program Files(xxx)\GrampsAIOxx-5.x.x\grampsw.exe" 50:
  - %comspec% /c set LANG=da_DK.UTF-8 && start grampsw.exe"
- Click OK and now when you click on that icon Gramps will start in Danish.

Change the windows LANG variables

Another option if you want Gramps to always load in say:French Canadian language, you can go to Windows > System Properties, and add the LANG variable in the user section of the environment variables dialog with the appropriate Value.

The value to add is:

Name: LANG
Value: fr_CA.UTF-8

Language codes

Select from the following table of languages Gramps has been translated into:

<table>
<thead>
<tr>
<th>Language</th>
<th>ISO code</th>
<th>Example Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dutch</td>
<td>nl_BE.UTF-8</td>
<td></td>
</tr>
<tr>
<td>English (British)</td>
<td>en_GB.UTF-8</td>
<td></td>
</tr>
<tr>
<td>Finnish</td>
<td>fi-UTF-8</td>
<td></td>
</tr>
<tr>
<td>French Canadian</td>
<td>fr_CA.UTF-8</td>
<td></td>
</tr>
<tr>
<td>Russian</td>
<td>ru_RU.UTF-8</td>
<td></td>
</tr>
</tbody>
</table>

- The language codes are two-letter lowercase ISO language codes (such as "da") as defined by ISO 639-1.
- The country codes are two-letter uppercase ISO country codes (such as "BE") as defined by ISO 3166-1.

Advanced manipulation of settings

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Warning ** Make sure you have closed Gramps **

The contents of this section is outside the scope of interest of a general user of Gramps. If you proceed with tweaking the options on the low level you may damage your Gramps installation. Be careful. YOU HAVE BEEN WARNED!

Besides the settings available in Preferences, you may also wish to explore the advanced settings.

Gramps uses INI keys and INI sections for managing user preferences and program settings these are stored in the text file gramps.ini under the .gramps/gramps[XX] folder in your home or user directory.

The gramps.ini file has following sections:

- [behavior] : typical Key names are: betawarn, enable-autobackup, use-tips...
- [colors] :
- [database] : related to database settings for the Family Tree.
- [export] : export and import folders/directories
- [interface] : a lot of keys regarding height and width of the different Views: e.g. event-height: 450, event-ref-height: 585, event-ref-width: 728, event-width: 712...
- [paths] : keys related to recent imported files and folders/directories
- [plugin] :
- [preferences] : keys related to preferences: all the common prefixes , todo -colors..
- [researcher] : all information regarding the researcher
- [utf8] :

Example gramps.ini file

Settings - Customizing 347
Example contents of the gramps.ini file:

```
[behavior]
;addmedia-image-dir=''
;addmedia-relative-path=0
;addons-url='https://raw.githubusercontent.com/gramps-project/addons/master/gramps51'
;autoload=0
;avg-generation-gap=20
;beta-warn=0
;check-for-addon-update-types=['new']
;check-for-addon-updates=0
;date-about-range=50
;date-after-range=50
;date-before-range=50
;do-not-show-previously-seen-addon-updates=1
;generation-depth=15
;last-check-for-addon-updates='1970/01/01'
:max-age-prob-alive=110
:max-sib-age-diff=20
:min-generation-years=13
;owner-warn=0
;pop-plugin-status=0
;previously-seen-addon-updates=[]
;recent-export-type=3
;runcheck=0
;spellcheck=0
;startup=0
;surname-guessing=0
;translator-needed=0
;use-tips=0
;web-search-url='http://google.com/#&q=%(text)s'
;welcome=100

[colors]
;border-family=['#cccccc', '#252525']
;border-family-divorced=['#ff7373', '#720b0b']
;border-family-dead=['#000000', '#000000']
;border-male-alive=['#1f4986', '#171d26']
;border-male-dead=['#000000', '#000000']
;border-unknown-alive=['#8e5801', '#8e5801']
;border-unknown-dead=['#000000', '#000000']
;

[interface]
;dbmanager-height=350
;dbmanager-horiz-position=12
;dbmanager-vert-position=85
;dbmanager-width=780
;dont-ask=0
;filter=0
;fullscreen=0
;grampletbar-close=0
;ignore-gexiv2=0
;ignore-osmgpsmap=0
;ignore-pil=0
;main-window-height=500
;main-window-horiz-position=15
;main-window-vert-position=10
;main-window-width=775
;mapservice='OpenStreetMap'
;open-with-default-viewer=0
;pedview-layout=0
;pedview-show-images=1
;pedview-show-marriage=0
;pedview-show-unknown-people=0
;pedview-tree-direction=2
;pedview-tree-size=5
```

Settings - Customizing
Advanced backup filename setting

You can also define the naming pattern for the backup filename by setting the `paths.quick-backup-filename` in the `~/.gramps/gramps51/gramps.ini` key file like the following:

```
[paths]
;quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%{extension}s'
```

by removing the two semicolons(;) from the front of INI key line and using use any of the following keywords for the filename pattern:

- `filename`
- `year`
- `month`
- `day`
- `hour`
- `minutes`
- `seconds`
- `extension`: `.gpkg`(default) if you include media.
Use the appropriate ~/.gramps/gramps{XX}/gramps.ini key file.

- Gramps version 5.1:
  ~/.gramps/gramps51/gramps.ini

See also:

- Gramps 5.1 Wiki Manual - Manage Family Trees#Backup dialog
- Gramps 5.1 Wiki Manual - Command Line#Configuration .28config.29 option
- Install_latest BSDDB#Make Gramps use bsddb3
- Customize the Genealogical Symbols lookup table#Genealogy symbols preferences

Theme

The look of Gramps can be changed.

- Addon:Themes
- Windows_AIO_themes
- GTK 3 theme - GEPS 029: GTK3-GObject introspection Conversion
- Overrule Gramps Icons - for older Gramps versions.
- UI style

Some reports can also be changed:

- Website report Themes
Filters allow Gramps to limit operations to a smaller part of a family Tree. The filtered part of the Trees shares a certain characteristic in common. (e.g., females born in France between the years 1550 and 1575.) The filter specifies which characteristics are important and allows choosing values for which to look. (In the example, the Filter looks for People of a particular sex who have an Event in specific Place during a small timespan.)

Database queries can be a challenge to compose without errors in syntax. So Filters provide structured and pre-tested database queries that hide most of the syntax complexity while providing some safety nets to avoid routine mistakes. Common characteristics used for filtering are normally presented as "parameter" fields in a form. Then the form composes a properly written query around the parameter. Forms with multiple parameter fields will compound complex queries.

Lists of all the filtering query rules currently defined in Gramps. Each of these rules is available for use when creating custom filters.

The rules are listed by their categories.

**Filter vs. Search**

There are two primary ways to find data in Gramps: Search and Filter.

- Search uses the Search Bar above a listing View (such as People, Families, etc).
  - The Search Bar only appears when the entire sidebar is closed. You can show or hide the Gramplet bars through changing the selection of the View ➡ Sidebar or View ➡ Bottombar menus.
  - Custom Filters are selected from pop-up menus in the Filter Gramplet, export option and in some reports. They can be used in combination with Search, or stand-alone in the sidebar/bottombar Gramplets.
- Custom Filters are created or edited from the filter Gramplet or Edit ➡ Filter Editor menu.

(There is also a basic seek-as-you-type Find box for navigating the active record focus within list view and object selector lists.)

Name filtering behavior has **changed for Gramps 5.1**

In prior versions of Gramps, the name portion of the Filter Gramplet would try to match on any single name field (given, surname, prefix, etc) of all names (primary and alternate) but only field per name — you couldn't match the given field and surname field in the same name. You could match surname, but simultaneously matching surname and given in the same query wasn't possible. For example, if you Filter on "John", you would get matches of people with firstname "John" but also those with surname "Johnson". More complex search required use of the regular expressions pattern matching options or custom filters.

This constraint has been removed and simultaneous search of multiple terms is now the default behavior.

Search and Filter work completely differently and it is useful to understand these differences:

- **Search** - the Search Bar looks through the database as it appears in the rows and columns on the screen. The Search functionality is probably
the one you want to use most of the time, as it is fast and most straightforward. But speed and simplicity imposes some limitations (see below).

For example, if you have the Name Display in Preferences set to show "Surname, Given" then you can match names such as "Smith, J" and all of the correct rows will match. If you change the way that names are displayed (in Preferences) then you can match that format (for example, "John Smith").

For example, if you have the Name Display in Preferences set to show "Surname, Given" then you can match names such as "Smith, J" and all of the correct rows will match. If you change the way that names are displayed (in Preferences) then you can match that format (for example, "John Smith").

Fig. 16.2 Gramps Main Window showing Search Bar

- Filter - Filters use a more elaborate system. It is not limited to what you see on the screen, but looks at the actual data in all name fields, rather than just what is showing in the View. Entering multiple words does phrase matching for most text fields. However, the Name filter line is far more powerful. Each word in the Name search is handled separately as though it was a sub-search on the records found with the previous search word. And it simultaneously searches all the Name fields.

e.g. a name search of "geo r." in the example tree database finds 5 people: with a variety 'Jr.' & 'Sr.' as the suffix and 'George's as first & middle names. Or searching "garn ski ph" finds Phoebe Emily who has a birth surname of Zielinski and alternate married surname of Garner.

Fig. 16.3 Gramps Filter SideBar for People view - Tag pop-up menu example

Filters can be created and controlled from the menu Edit ➔ Filter Editor, or from a special sidebar/bottombar Gramplet. The Filter Gramplets allow for some quick filters that are similar to the Search Bar, but all Filters follow the distinction outlined here.

Some additional points:

- The Filter will search alternative & multiple names too; the Search Bar only looks in the primary name... the one showing in the People view. That is why doing a Filter on "Smith" might list people that superficially don't appear to match. But if you drill down into that person's details with the Name Editor, you might see that they have an alternate name containing "smith".
- The Filter allows "regular expressions". So you can find all of the names that start with "B" and end in "ship": "B.*ship". You can't do that...
with the Search Bar.
* The Search will only match what is visible. If a name or text is too big to see in listing below Search Bar, then you won't find it. This is something to keep in mind when Searching through Notes. Best to use Filter for notes and other long text fields.
* All Filters default to use case-insensitive matching; "Ship" will match "ship", "SHIP", or "ShIp". As explained below under Regular Expressions, using Regular Expressions does not currently give a means of changing from the default.

See also
- Filter - a definition
- Filters introduction in the Gramps Manual
- Which filters in which Category?
- Filter
- Example filters - Multi-stage filters
- Rules - a definition
- Addon list - Rules
- Expanding the Filter rulebook with Addons
- Category: Filters
- Custom Filter migration - backing up a Gramps Tree does not include any filter customizations

Regular Expressions

Regular Expressions (aka reger, regexp, or sometimes rational expression) are a condensed, precise and powerful way to describe text that matches a pattern.

Designing an effective search pattern can be formulaic. Like math formulas, a search pattern can be quickly composed which finds a subset of records but does so very crudely and slowly. Elegant and efficient RegEx phrases are collected by optimization experts in data manipulations. There are many resources (books, websites, professional training) for RegEx design and strategy.

Gramps uses RegEx as a matching option that may be enabled for Custom Filters and in the Filter Gramplets of each Category view.

RegEx pattern matching is an advanced feature and so its checkbox is not selected by default. For Custom Filters, each individual Rule has a

- Use regular expressions option check box in its Edit Rule dialog. The Filter Gramplets also have

- Use regular expressions option check boxes to allow regexp expression to be used directly for matching strings in their text boxes.

For example, if you were looking for a surname that started with a "B", and ended with "ship" then you could use regular expressions to describe that pattern. That would be "B.*ship:

- The "B" indicates text that starts with B
- The . indicates any single character (letter, number, or anything)
- The * indicates zero or more of the previous (in this case, any single character)
- The ship matches the exact letters s, h, i, p in that order.

Regular expressions are quite powerful, and there are many options. We use the Python Regular Expression system, and we will document that here. In addition, you can use any Python Regular Expression resource.

Gramps is currently implemented to make all string matching case-insensitive (which is the opposite of the usual default in Python). There is no easy way at present to override this behaviour for the relatively uncommon purpose of matching strings that have been entered into the database in a particular case format. Regular expressions in Gramps currently give identical results regardless of whether the target string is entered in upper case, title case, lower case or some mixture.

whitespace - The term "whitespace" is used below to mean one or more character that you don't see. For example, whitespace includes tabs, spaces, and newlines.

There are some characters that have special meaning with regular expressions. They are:

- ^ $ * + ? { } [ ] \ | ( )
  decimal point (full stop), caret, dollar sign, asterisk, plus sign, question mark, left and right curly braces, left and right square brackets, backslash, vertical bar (pipe), left and right parentheses

They can be used as described:

- . matches any character (letter, number, or other)
- " matches beginning of text
- " matches end of text
- * matches zero or more of the previous item
- + matches one or more of the previous item
- ? matches zero or one of the previous item (makes it optional)
- {n} - defines a number of matches
- {n,} - ends number of matches
- [ ] - beginning of set
- [ ] - end of set
- [ ] - next character is special sequence
- | or
- | - beginning of a group
- | - ending of a group
Some of the special sequences beginning with ‘\’ represent predefined sets of characters that are often useful, such as the set of digits, the set of letters, or the set of anything that isn’t whitespace. The following predefined special sequences are a subset of those available.

- \d Matches any decimal digit; this is equivalent to the class [0-9].
- \D Matches any non-digit character; this is equivalent to the class [^0-9].
- \s Matches any whitespace character; this is equivalent to the class [ \t\n\r\f\v].
- \S Matches any non-whitespace character; this is equivalent to the class [^ \t\n\r\f\v].
- \w Matches any alphanumeric character; this is equivalent to the class [a-zA-Z0-9_].
- \W Matches any non-alphanumeric character; this is equivalent to the class [^a-zA-Z0-9_].

The most complicated repeated qualifier is \{m,n\}, where m and n are decimal integers. This qualifier means there must be at least m repetitions, and at most n.

Find all defined values or blanks

To find all values, (.|\s)* will match: any character or any whitespace character; and zero or more repetitions of those.

To find empty (blank or null) strings, ^\.{0}$ looks from the start of the match ^ for any character (except newline) . occurring precisely zero times \s before the end of the match $.

Groups and Sets

Groups are marked by the "('', ')" metacharacters. '(' and ')' have much the same meaning as they do in mathematical expressions; they group together the expressions contained inside them, and you can repeat the contents of a group with a repeating qualifier, such as *, +, ?, or \{m,n\}. For example, (ab)* will match zero or more repetitions of ab.

Sets are marked by the "['', ']'" metacharacters.

You can think of groups as a list of alternatives separated by the "'|" metacharacter, where each alternative consists of one, several or zero characters and sets as a list of alternatives where each alternative is a single character.

Examples

- `B.*ship` - matches all text that starts with a 'B', followed by anything, ending with 'ship'.
  - matches: Blankenship, Blueship, Beeship
  - does not match: Blankenships
- `B.*ship` - matches all text that starts with a 'B', followed by anything, followed by 'ship'(could be followed by more).
  - matches: Blankenship, Blankenships, Blueship, Blueshipman, Beeship, Beeshipness
  - does not match: Blankenships

Common variations of a surname

Example 1
Using the expression Eri(ch|ck|k|c)(ss|s)on the following are matched:

- Erikson
- Eriksson
- Ericson
- Erickson
- Ericksson
- Erickson
- Erickson
- Erickson

Explanation: Because of the following

- Eri = Eri
- (ch|ck|k|c) = group matching ch, ck, k or c. It tries to make the longest match first
- (ss|s) = group matching ss or s. It tries to make the longest match first
- on = on

Example 2
Using the expression Ba(in|yn|m|n)bri(dge|cke|g(g|e|)) the following are matched:

- Bainbricke
- Bainbridge
- Bainbrig
- Bainbrigg
- Bainbridge
- Bainbridge
- Bainbridge
- Bainbridge

Explanation: Because of the following

- Ba = Ba
- (in|yn|m|n) = group matching in, yn, m or n. It tries to make the longest match first.
- bri = bri
- (dge|cke|g(g|e|)) = group matching dge, cke or (g with g, g with e or g with nothing)

Example 3
Using the expression n(es|oua|o[ia]i|oua[iy]|a[iy])r(r|)((e|)au(x|t|d|l|t|)) the following are matched:
Explanation: Because of the following

- \( n = n \)
- \((es|oua|oai|set1|set2) = \) group matching es, oua, oai, set1 or set2
- \( set1 \) is \((iys) = \) set matching i, y, or a. In other words oi, oy or oa
- \( set2 \) is \((i|y) = \) set matching a AND i or y. In other words ai or ay
- \( r = r \)
- \((e|) = \) group matching r or nothing
- \( (on|subgroup1) = \) group matching on or subgroup1.
- \( subgroup1 \) is group matching (subgroup2 au subgroup3)
- \( subgroup2 \) is \((e) = \) group matching e or nothing
- \( au = au \)
- \( subgroup3 \) is \((x|t|d|lt) = \) group matching x, t, d or lt

Testing regular expressions

Regular Expression testers can be found online through Google. [https://www.regexr.com/](https://www.regexr.com/) is simple and convenient

Regular Expression 'dialect' noted and Repaired

In Gramps 5.1, the sidebar filter inappropriately evaluated parameters containing spaces... attempting to re-interpret a single Regular Expression as a sequence of separate expressions. The Gramps 5.1.1 resolution for Bug [0011321](https://www.regexr.com/) handles Regular Expressions more literally.

See Also

Regular expressions have been in wide use across the computer industry since the 1950s. But they are "expert tools" designed for power and efficiency rather than intuitiveness. As a result, many resources have been developed on the web.

Some of these resources have excellent tutorials. Some have cheat sheets. Some have “sand boxes” where regular expressions can be explored in real-time.

A sampling of RegEx reference websites:
- [rexegg.com](https://www.rexegg.com) (tutorials)
- [RegexBuddy](http://regexbuddy.com)
- [regex101.com](https://www.regex101.com) (sandbox with feedback)

Custom Filters

Custom Filter migration

Keep your collection of custom filters through a minor updates of Gramps (e.g., from version 5.0.x to 5.1.x) by manually copying your custom_filter.xml from [Gramps User Directory](https://www.gramps-project.org) to the corresponding directory in new gramps_version_number.

Even minor upgrades (e.g., from a 5.0.x to a 5.1.x version) may include format changes since the recent innovation of addon rules are causing rapid evolution in Filters. So porting filters in this manner requires verification that the XML definitions haven't changed. Also, Addon rules may have to be installed in the new upgrade before copied custom filters will work safely.

You can carry out a considerable amount of selection of persons, events, places, etc., just using the Filter Sidebar in Person, Event, Place, etc. Views; but note, however, that the 'Use regular expressions' option only works with particular fields in each View.

If the Filter Sidebar is inadequate for your purpose, you will need to build custom filters.
Building a quick Custom Filter for an object

The clipboard has a Custom Filter generation shortcut. Copy any View object to the Clipboard (by drag'n'drop or by selecting and pressing the \texttt{Ctrl} + 	exttt{C} keybinding), then select the object on the Clipboard and right-click to reveal the \textit{Clipboard's contextual pop-up menu}. The bottom menu item will offer to create a Filter for the selected object.

CategoryName Filters dialog

\textbf{Note:Changes on filters}

The changes made to the filters only take effect after you use the \texttt{Close} button from this window.

![Person Filters - Gramps](image)

Fig. 16.4 Person Filters - dialog - example

To create new or show previously created custom filters use the \textit{CategoryName Filters} dialog list where the \textit{CategoryName} changes based on the category you are in eg:

- Person Filters
- Family Filters
- Event Filters
- Place Filters
- Source Filters
- Citation Filters
- Repository Filters
- Media Filters
- Note Filters

When in the \textit{CategoryName Filters} dialog you have the following options from the right hand side icons:

- \textbf{Add a new filter:}
  shows the \textit{Define filter} dialog and adds a new (as yet unnamed) custom filter framework.

- \textbf{Edit the selected filter:}
  opens the \textit{Define filter} dialog and loads your existing custom filter for editing.

- \textbf{Clone the selected filter:}
  makes an exact copy of the selected filter

- \textbf{Test the selected filter:}
  brings up the \textit{Filter Test} results dialog containing a list of matches following a successful test. If the filter test is invalid, an error may be shown instead.

- \textbf{Delete the selected filter:}
  removes the selected filter from the Gramps collection of custom filters.

Filter Test dialog
The results list of a successful Filter Test dialog might be empty, a valid custom filter might not match any records.

**Define Filter dialog**

Add-on rules for custom filters are available

Filter rules can be expanded through the add-ons interface starting with the Gramps 5.1.0 version. See: Example filters and Add-on rules

The **Define filter** dialog allows you to build custom filters that can be used to select people included in reports, exports, and other tools and utilities. This is in fact a very powerful tool in genealogical analysis.

To list all the filters (if any) previously defined by you, access the Define filter dialog from:

- The Sidebar/Bottombar Filters
- In most categories via the menu **Edit > CategoryName Filter Editor** which will bring up the **CategoryName Filters** dialog where you can select the **+ (Add another rule to filter)** button or **Edit the selected filter** button.

In the **Definition** section type the **Name** for your new filter and add a **Comment** that would help you identify this filter in the future. Add as many rules to the **Rule list** as you would like to your filter using **+** button.

If the filter has more than one rule, select one of the **Options** from the drop down list which allows you to choose whether

- All rules must apply (default)
- At least one rule must apply
- Exactly one rule must apply
in order for the filter to generate a match. If your filter has only one rule, this selection has no effect.

- Select **Return values that do not match the filter rules** to invert the filter rule. For example, inverting "has a common ancestor with I1" rule will match everyone who does not have a common ancestor with that person. (Check box unchecked by default)

### Add Rule dialog

A filter you have already designed may be used as a rule parameter for another filter.

This gives you nearly infinite flexibility in custom-tailoring your selection criteria that can be later used in most of the exports, reports, and some of the tools (such as comparing individual events).

See: Example filters and Addon Rules

Fig. 16.7 Add Rule - selector dialog - available for Person filters - example

To define a new filter click the **Add another rule to filter** button from the **Define filter** dialog as this invokes the **Add Rule** dialog.

The pane on the left-hand side displays available filter rules arranged by their categories in an expandable tree.

For detailed filter rule reference you can either, use the search box to find the rule, or:

- Click on the ▶ arrows to fold/unfold the appropriate category.
- Select the rule from the tree by clicking on its name. The right-hand side displays the name, the description, and the values for the currently selected rule.

#### Finding a rule

It can be hard to remember which filter grouping contains a rule. And, since the "addon rule" is a recent innovation, there can be too many rules to peruse easily. So you can narrow down the rule list -- based on keywords from the rule titles.

Type a keyword by using the search box (box with the magnifying glass) and only the groupings with matches will be expanded.

Once you are satisfied with your rule selection and its values, click **OK** to add this rule to the rule list of the currently edited filter. Clicking **Cancel** will abort adding the rule to the filter.

See also Which filters in which Category?

### Which filter rules in which Category?

Depending on the used Category, you will get a different set of filter rules. Also see Summary of Gramplets.

- Dashboard Category
Ancestral filters

This rule category includes the following rules that match people based on their ancestral relations to other people:

**Ancestor of <filter> match**

This rule matches people who are ancestors of someone who is matched by the specified filter. The specified filter name should be selected from the menu.

**Ancestor of <person>**

This rule matches people who are ancestors of the specified person. The Inclusive option determines whether the specified person should be considered his/her own ancestor (useful for building reports). You can either enter the ID into a text entry field, or select a person from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

**Ancestor of <person> at least <N> generations away**

This rule matches people who are ancestors of the specified person and are at least N generations away from that person in their lineage. For example, using this rule with the value of 2 for the number of generations will match grandparents, great-grandparents, etc., but not the parents of the specified person.

**Ancestor of <person> not more than <N> generations away**

This rule matches people who are ancestors of the specified person and are no more than N generations away from that person in their lineage. For example, using this rule with the value of 2 for the number of generations will match parents and grandparents, but not great-grandparents, etc., of the specified person.

**Ancestor of bookmarked people not more than <N> generations away**

**Ancestor of the default person not more than <N> generations away**

The "default person" is the individual that has been defined as the "Home Person". (The "default" is a legacy term in Gramps that caused minor confusion she nice the word is used in so many different parts of the wiki to describe different things.)

**Duplicate ancestors of <person>**

Matches people that are ancestors twice or more of a specified person
People with a common ancestor with <filter> match

This rule matches people who have common ancestors with someone who is matched by the specified filter. The specified filter name should be selected from the menu.

People with a common ancestor with <person>

This rule matches people who have common ancestors with the specified person.

Child filters

This rule category finds families having children that match the rule:

Families having child with id containing <text>

Matches families where child has a specified Gramps ID

Families with child with the <name>

Matches families where child has a specified (partial) name

Families with twins

Matches families with two (or more) children having a 'Birth' role for the Relationship to the Mother and the same birthdate.

Citation/source filters

These filter rules are view dependent

- People-, and Relationships Category
- Families Category
- Events Category
- Places Category
- Media Category

People-, and Relationships Category

This category includes the following citation and source rules:

People with <count> source

Matches people with a certain number of items in the source. Values: Number of instances -- Number must be greater than/lesser/equal to

People with the <citation>

Matches people with a citation of a particular value

People with the <source>

Matches people who have a particular source. values: Source ID

Person with at least one direct source >= <confidence level>

Families Category

This category includes the following citation and source rules:

Families with <count> sources

Matches families with a certain number of items in the source. Values: Number of instances -- Number must be greater than/lesser/equal to

Families with at least one direct source >= <confidence level>

Matches families with at least one direct source with confidence level(s)

Families with the <citation>
Matches families with a citation of a particular value

**Families with the `<source>`**

Matches families who have a particular source. values: Source ID

**Events Category**

This category includes the following citation and source rules:

**Events with `<count>` source**

Matches events with a certain number of items in the source. Values: Number of instances -- Number must be greater than/lesser/equal to

**Events with at least one direct source >= `<confidence level>`**

Matches events with at least one direct source with confidence level(s)

**Events with source matching the `<source filter>`**

**Places Category**

This category includes the following citation and source rules:

**Place with `<count>` sources**

Matches places with a certain number of items in the source. Values: Number of instances -- Number must be greater than/lesser/equal to

**Place with a direct source >= `<confidence level>`**

Matches places with at least one direct source with confidence level(s)

**Place with the `<citation>`**

Matches places with a citation of a particular value

**Places with the `<source>`**

Matches places who have a particular source. values: Source ID

**Media Category**

This category includes the following citation and source rules:

**Media with `<count>` sources**

Matches media with a certain number of items in the source. Values: Number of instances -- Number must be greater than/lesser/equal to

**Media with a direct source >= `<confidence level>`**

Matches media with at least one direct source with confidence level(s)

**Media with the `<citation>`**

Matches media with a citation of a particular value

**Media with the `<source>`**

Matches media who have a particular source. values: Source ID

**Descendant filters**
This descendant filters category include the following rules that match people based on their descendant relations to other people:

**Descendant family member of <filter> match**

Matches people that are descendants or the spouse of anybody matched by a filter

**Descendant family member of <person>**

This rule not only matches people who are descendants of the specified person, but also those descendants' spouses.

**Descendant of <filter> match**

This rule matches people who are descendants of someone who is matched by the specified filter. The specified filter name should be selected from the menu.

**Descendant of <person>**

This rule matches people who are descendants of the specified person. The Inclusive option determines whether the specified person should be considered his/her own descendant (useful for building reports). You can either enter the ID into a text entry field, or select a person from the list by clicking the Select... button. In the latter case, the ID will appear in the text field after the selection was made.

**Descendant of <person> at least <N> generations away**

This rule matches people who are descendants of the specified person and are at least N generations away from that person in their lineage. For example, using this rule with the value of 2 for the number of generations will match grandchildren, great-grandchildren, etc., but not the children of the specified person.

**Descendant of <person> not more than <N> generations away**

This rule matches people who are descendants of the specified person and are no more than N generations away from that person in their lineage. For example, using this rule with the value of 2 for the number of generations will match children and grandchildren, but not great-grandchildren, etc., of the specified person.

**Event filters**

These filter rules are view dependent

- People-, and Relationships Category
- Families Category

**People-, and Relationships Category**

This category includes the following rules that match people based on their recorded events:

**Families with incomplete events**

This rule matches people missing date or place in any family event of any of their families.

**People with incomplete events**

This rule matches people missing date or place in any personal event.

**People with the <birth data>**

This rule matches people whose birth event matches specified values for Date, Place, and Description. The rule returns a match even if the person's birth event matches the value partially. The matching rules are case-insensitive. For example, anyone born in Sweden will be matched by the rule using the value "sw" for the Place. The rule returns a match if, and only if, all non-empty values are (partially) matched by a person's birth. To use just one value, leave the other values empty.

**People with the <death data>**

This rule matches people whose death event matches specified values for Date, Place, and Description. The rule returns a match even if the person's death event matches the value partially. The matching rules are case-insensitive. For example, anyone who died in Sweden will be matched by the rule using the value "sw" for the Place. The rule returns a match if, and only if, all non-empty values are (partially) matched by a person's death. To use just one value, leave the other values empty.

**People with the family <event>**

This rule matches people that have a family event matching specified values for the Event type, Date, Place, and Description. The rule returns a match even if the person's event matches the value partially. The matching rules are case-insensitive. For example, anyone who was married in Sweden will be matched by the rule using the Marriage event and the value "sw" for the Place. The family events should be selected from a pull-down menu. The rule returns a match if, and only if, all non-empty values are (partially) matched by the personal event. To use just one value, leave the other values empty.

**People with the personal <event>**
This rule matches people that have a personal event matching specified values for the Event type, Date, Place, and Description. The rule returns a match even if the person's event matches the value partially. The matching rules are case-insensitive. For example, anyone who graduated in Sweden will be matched by the rule using the Graduation event and the value "sw" for the Place. The personal events should be selected from a pull-down menu. The rule returns a match if, and only if, all non-empty values are (partially) matched by the personal event. To use just one value, leave the other values empty.

**Persons with events matching the <event filter>**

Matches persons who have events that match a certain event filter. Values: Event filter name.

**Witnesses**

This rule matches people who are present as a witness in the event. If the personal or family event type is specified, only the events of this type will be searched.

**Families Category**

This category includes the following rules that match families based on their recorded events:

**Families with the <event>**

This rule matches families that have a event matching specified values for the Event type, Date, Place, and Description. The rule returns a match even if the person's event matches the value partially. The matching rules are case-insensitive. For example, anyone who was married in Sweden will be matched by the rule using the Marriage event and the value "sw" for the Place. The family events should be selected from a pull-down menu. The rule returns a match if, and only if, all non-empty values are (partially) matched by the personal event. To use just one value, leave the other values empty.

**Family filters**

This category includes the following rules that match people based on their family relationships:

**Adopted people**

This rule matches adopted people.

**Children of <filter> match**

This rule matches people for whom either parent is matched by the specified filter. The specified filter name should be selected from the menu.

**Parents of <filter> match**

This rule matches people whose child is matched by the specified filter. The specified filter name should be selected from the menu.

**People missing parents**

Matches people that are children in a family with less than two parents or are not children in any family.

**People with children**

This rule matches people with children.

**People with multiple marriage records**

This rule matches people with more than one spouse.

**People with no marriage records**

This rule matches people with no spouses.

**People with the <relationships>**

This rule matches people with a particular relationship. The relationship must match the type selected from the menu. Optionally, the number of relationships and the number of children can be specified. The rule returns a match if, and only if, all non-empty values are (partially) matched by a person's relationship. To use just one value, leave the other values empty.

**Siblings of <filter> match**

This rule matches people whose sibling is matched by the specified filter. The specified filter name should be selected from the menu.

**Spouses of <filter> match**

This rule matches people married to someone who is matched by the specified filter. The specified filter name should be selected from the menu.

**Father filters**
This rule category finds families having fathers that match the rule:

**Families having father with Id containing <text>**
Matches families whose father has a specified Gramps ID

**Families with father with the <name>**
Matches families whose father has a specified (partial) name

### General filters

These filter rules are view dependent

- People-, and Relationships Category
- Families Category
- Events Category
- Places Category
- Sources Category
- Citations Category
- Repositories Category
- Media Category
- Notes Category

### People-, and Relationships Category

This category includes the following general rules:

- **Bookmarked people**
  Matches the people on the bookmark list.

- **Home person**
  Matches the [Home Person](#).

- **Disconnected People**
  Matches people that have no family relationships to any other person in the database.

- **Everyone**
  Matches everyone in the family tree database.

- **Females**
  Matches all females.

- **Males**
  Matches all males.

- **People having <count> notes**
  Matches people having a certain number of notes: Values: Number of instances -- Number must be greater than/lesser/equal to

- **People having notes containing <text>**
  Matches people whose notes contain text matching a regular expression

- **People marked private**
  Matches people that are indicated as private.

- **People matching the <filter>**
  Matches people matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

- **People not marked private**
  Matches people that are not indicated as private

- **People probably alive**
Matches people without indications of death that are not too old. Values: On Date

- **Probably Alive Filter**

**People with <count> LDS events**
Matches people with a certain number of LDS events. Values: Number of instances -- Number must be greater than/lesser/equal to

**People with <count> addresses**
Matches people with a certain number of personal addresses. Values: Number of instances -- Number must be greater than/lesser/equal to

**People with <count> associations**
Matches people with a certain number of associations. Values: Number of instances -- Number must be greater than/lesser/equal to

**People with <count> media**
Matches people with a certain number of items in the gallery. Values: Number of instances -- Number must be greater than/lesser/equal to

**People with id containing <text>**
Matches people whose Gramps ID matches the regular expression

**People with a nickname**
Matches people with a nickname

**People with an alternate name**
Matches people with an alternate name

**People with incomplete names**
Matches people with first-name or last-name missing.

**People with records containing <substring>**
Matches people whose records contain text matching a substring. Values: Substring -- Case Sensitive or not -- Regular-Expression matching or not

**People with the <Name type>**
Matches people with a type of name

**People with the <Surname origin type>**
Matches people with a surname origin

**People with the <name>**
Matches people with a specified (partial) name. Values: Given Name -- Family Name -- Suffix -- Title -- Prefix -- Patronymic -- Call Name

**People with <tag>**
Matches people with a tag of a particular value. Values: Tag name.

**People with the family <attribute>**
Matches people with the family attribute of a particular value. Use RegEx pattern matching to search for all values or attributes that have been left blank. Values: Family Attribute: Identification Number -- Age ...

**People with the personal <attribute>**
Matches people with the personal attribute of a particular value. Use RegEx pattern matching to search for all values or attributes that have been left blank. Values: Personal Attribute: Identification Number -- Age ...
People with unknown gender

Matches all people with unknown gender.

People without a known birth date

This General filter in the People category will matches people without a known birth date.

This rule includes both Persons without any birth-type event and Persons with undated Birth-type events.

People without a known death date

Matches people without a known death date.

People with <id>

Matches people with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

People changed after <date time>

Matches person records changed during a particular time period. Used to identify records that were imported or modified during particular work-sessions.

Filtering based on specified date and timestamp being after a particular timestamp in the format yyyy-mm-dd hh:mm:ss. This filter rules will look for records modified within a date range, if a second date-time is given.

Values:

- Changed after:
- but before:

Values must be after January 1st, 1970 at UTC. Future dates until 3001-01-01 01:59:59 are valid.

The People changed after <date time> filter rules are available in the General filters section for custom rules in the People, Relationships, Charts, and Geography views.

Equivalent rules exist for records of the corresponding category type in People, Families, Events, Places, Sources, Citations, Repositories, Media, and Notes category views.

Soundex match of People with the <name>

Soundex Match of people with a specified name. First name, Surname, Call name, and Nickname are searched in primary and alternate names.

This rule compares names of People against a phonetic pattern. It uses the Soundex phonetic algorithm for indexing names by sound, as pronounced in English.

Match criteria can be a Soundex code (which can be found with the Soundex Gramplet) consisting of of a letter followed by three numerical digits: the letter is the first letter of the name, and the digits encode the remaining consonants. But if the match criteria is not a valid Soundex code, the filter will simply generate Soundex code for the word entered.

All name fields (and the separate words within those fields) are searched individually against the Soundex code.

Families Category

This category includes the following general rules:

Ancestor families of <family>

Bookmarked families

Matches the families on the bookmark list.

Descendant families of <family>
Every family

Matches every family in the database.

Families changed after <date time>

Matches families records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:

Families having <count> notes

Matches families having a certain number of notes: Values: Number of instances -- Number must be greater than/less/equal to

Families having notes containing <text>

Matches families whose notes contain text matching a regular expression

Families marked private

Matches families that are indicated as private.

Families matching the <filter>

Matches families matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

Families with <count> LDS events

Matches families with a certain number of LDS events. Values: Number of instances -- Number must be greater than/less/equal to

Families with <count> media

Matches families with a certain number of items in the gallery. Values: Number of instances -- Number must be greater than/less/equal to

Families with id containing <text>

Matches families whose Gramps ID matches the regular expression

Families with a reference count of <count>

Matches families with a certain number of references. Values: Number of references -- Number must be greater than/less/equal to

Families with the <tag>

Matches families with a tag of a particular value. Values: Tag name.

Families with the family <attribute>

Matches families with the family attribute of a particular value. Values: Family Attribute: Identification Number -- Age ...

Families with the relationship type

Matches families with the relationship type of a particular value

Families with <id>

Matches families with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

Events Category

This category includes the following general rules:

Event with <id>

Matches events with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.
Events changed after <date time>
Matches events records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:

Events having <count> notes
Matches events having a certain number of notes: Values: Number of instances -- Number must be greater than/lesser/equal to

Events having notes containing <text>
Matches events whose notes contain text matching a regular expression

Events marked private
Matches events that are indicated as private.

Events matching the <filter>
Matches events matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

Events occurring on a particular day of the week
Matches events occurring on a particular day of the week

Events of persons matching the <person filter>
Matches events of person matched by the specified person filter name

Events of places matching the <place filter>
Matches events that occurred at places that match the specified place filter name

Events with <count> media
Matches events with a certain number of items in the gallery. Values: Number of instances -- Number must be greater than/lesser/equal to

Events with
Matches events with data of a particular value

Events with Id containing <text>
Matches events whose Gramps ID matches the regular expression

Events with a reference count of <count>
Matches events with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

Events with the <tag>
Matches events with a tag of a particular value. Values: Tag name.

Events with the attribute <attribute>
Matches events with the attribute of a particular value. Values: Family Attribute: Identification Number -- Age ...

Events with the particular type
Matches events with the particular type

Every event
Matches every event in the database.

Places Category
This category includes the following general rules:

Every place
Matches every place in the database.
Place with <Id>

Matches places with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

Places changed after <date time>

Matches places records changed after a specified date-time (yyyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:.

Places enclosed by another place

Places having <count> notes

Matches places having a certain number of notes: Values: Number of instances -- Number must be greater than/lesser/equal to

Places having notes containing <text>

Matches places whose notes contain text matching a regular expression

Places marked private

Matches places that are indicated as private.

Places matching a title

Matches places with a particular title

Places matching parameters

Matches places with particular parameters

Places matching the <filter>

Matches places matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

Places of events matching the <event filter>

Matches places where events happened that match the specified event filter name

Places with <count> media

Matches places with a certain number of items in the gallery. Values: Number of instances -- Number must be greater than/lesser/equal to

Places with Id containing <text>

Matches places whose Gramps ID matches the regular expression

Places with a reference count of <count>

Matches places with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

Places with the <tag>

Matches places with a tag of a particular value. Values: Tag name.

Sources Category

This category includes the following general rules:

Every source

Matches every source in the database.

Source with <Id>
Matches sources with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking (Select...) button. In the latter case, the ID will appear in the text field after the selection was made.

**Sources changed after <date time>**

Matches sources records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:.

**Sources having <count> notes**

Matches sources having a certain number of notes: Values: Number of instances -- Number must be greater than/lesser/equal to

**Sources having notes containing <text>**

Matches sources whose notes contain a regular expression

**Sources marked private**

Matches sources that are indicated as private.

**Sources matching the <filter>**

Matches sources matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

**Sources with <count> Repository references**

Matches sources with a certain number of repository references

**Sources with <count> media**

Matches sources with a certain number of items in the gallery. Values: Number of instances -- Number must be greater than/lesser/equal to

**Sources with Id containing <text>**

Matches sources whose Gramps ID matches the regular expression

**Sources with a reference count of <count>**

Matches sources with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

**Sources with repository reference containing <text> in "Call Number"**

Matches sources with a repository reference containing a substring in 'Call Number'

**Sources with repository reference matching the <repository filter>**

Matches sources with a repository reference that match a certain repository filter

**Sources with the <tag>**

Matches sources with a tag of a particular value. Values: Tag name.

**Sources with title containing <text>**

Matches sources whose title contains a certain substring

**Citations Category**

This category includes the following general rules:

**Citation with <Id>**

Matches citations with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking (Select...) button. In the latter case, the ID will appear in the text field after the selection was made.

**Citations changed after <date time>**

Matches citations records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:.

**Citations having <count> notes**

Matches citations having a certain number of notes: Values: Number of instances -- Number must be greater than/lesser/equal to
Citations having notes containing text
Matches citations whose notes contain text matching a regular expression

Citations marked private
Matches citations that are indicated as private.

Citations matching parameters
Matches citations with particular parameters

Citations matching the filter
Matches citations matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

Citations with count media
Matches citations with a certain number of items in the gallery. Values: Number of instances -- Number must be greater than/lesser/equal to

Citations with Id containing text
Matches citations whose Gramps ID matches the regular expression

Citations with Volume/Page containing text
Matches citations whose Volume/Page contains a certain substring

Citations with a reference count of count
Matches citations with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

Citations with a source with a repository reference matching the repository filter
Matches citations with a source with a repository reference that match a certain repository filter

Citations with source matching the source filter
Matches citations with sources that match the specified source filter name

Citations with the tag
Matches citations with a tag of a particular value. Values: Tag name.

Every citation
Matches every citation in the database.

Repositories Category
This category includes the following general rules:

Every repository
Matches every repository in the database.

Repositories changed after date time
Matches repository records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:.

Repositories having notes containing text
Matches repositories whose notes contain text matching a regular expression

Repositories marked private
Matches repositories that are indicated as private.

Repositories matching the filter
Matches repositories matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.
Repositories with Id containing <text>
Matches repositories whose Gramps ID matches the regular expression

Repositories with a reference count of <count>
Matches repositories with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

Repositories with name containing <text>
Matches repositories whose name contains substring

Repositories with the <tag>
Matches repositories with a tag of a particular value. Values: Tag name.

Repository with <Id>
Matches repositories with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

Media Category
This category includes the following general rules:

Every media object
Matches every media object in the database.

Media object with <Id>
Matches media objects with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

Media objects changed after <date time>
Matches media object records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given. Values: Changed after: -- but before:

Media objects having notes containing <text>
Matches media objects whose notes contain text matching a regular expression

Media objects marked private
Matches media objects that are indicated as private.

Media objects matching parameters

Media objects matching the <filter>
Matches media objects matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

Media objects with Id containing <text>
Matches media objects whose Gramps ID matches the regular expression

Media objects with a reference count of <count>
Matches media objects with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

Media objects with the <tag>
Matches media objects with a tag of a particular value. Values: Tag name.
Media objects with the attribute <attribute>
Matches media objects with the attribute of a particular value

Notes Category
This category includes the following general rules:

Every note
Matches every note in the database.

Note with <Id>
Matches notes with Gramps ID. The rule returns a match only if the ID is matched exactly. You can either enter the ID into a text entry field, or select an object from the list by clicking [Select...] button. In the latter case, the ID will appear in the text field after the selection was made.

Notes changed after <date time>
Matches notes records changed after a specified date-time (yyy-mm-dd hh:mm:ss) or in the range, if a second date-time is given: Values: Changed after: -- but before:.

Notes containing <text>
Matches notes contain text matching a regular expression

Notes marked private
Matches notes that are indicated as private.

Notes matching parameters
Matches notes with particular parameters

Notes matching the <filter>
Matches notes matched by the specified filter name. Values: Filter name. The specified filter name should be selected from the menu.

Notes with Id containing <text>
Matches notes whose Gramps ID matches the regular expression

Notes with a reference count of <count>
Matches notes with a certain number of references. Values: Number of references -- Number must be greater than/lesser/equal to

Notes with the <tag>
Matches notes with a tag of a particular value. Values: Tag name.

Notes with the particular type
Matches notes with the particular type

Mother filters
This rule category finds families having mothers that match the rule:

Families having mother with Id containing <text>
Matches families whose mother has a specified Gramps ID

Families with mother with the <name>
Matches families whose mother has a specified (partial) name

Position filters
This rule category finds Places by their Global Positioning System coordinates proximity:

Places in neighborhood of given position
Matches places with latitude or longitude position in a rectangle of given height and width (in degrees), and with middle point the given latitude and
longitude.

**Places with no latitude or longitude given**

Matches places with empty latitude or longitude

**Places within an area**

---

**Source filters**

This rule category finds Citations that match the rule:

**Citation with Source <id>**

Matches a citation with a source with a specified Gramps ID

**Citations having source notes containing <text>**

Matches citations whose source notes contain a substring or match a regular expression

**Citations with Source Id containing <text>**

Matches citations whose source has a Gramps ID that matches the regular expression

**Sources matching parameters**

Matches citations with a source of a particular value

**Relationship filters**

This category includes the following rules that match people based on their mutual relationship:

**People related to <Person>**

Matches people related to a specified person

**Relationship path between <person> and people matching <filter>**

Searches over the database starting from a specified person and returns everyone between that person and a set of target people specified with a filter. This produces a set of relationship paths (including by marriage) between the specified person and the target people. Each path is not necessarily the shortest path.

**Relationship path between <persons>**

This rule matches all ancestors of both people back to their common ancestors (if exist). This produces the "relationship path" between these two people, through their common ancestors. You can either enter the ID of each person into the appropriate text entry fields, or select people from the list by clicking their **select...** buttons. In the latter case, the ID will appear in the text field after the selection was made.

**Relationship path between bookmarked persons**

Matches the ancestors of bookmarked individuals back to common ancestors, producing the relationship path(s) between bookmarked persons.

**Tagging**

The concept of tagging for most people using *gmail* or *thunderbird*, the Tag feature will seem quite familiar. Instead of classifying emails into folders like in *Outlook* (Windows) or *Evolution* (Linux), emails are classified by assigning tags to them. So instead of having a disjoint N:1 classification (a email can be in one and only one folder, and a folder can contain many emails), in *gmail* or *thunderbird* there is a N:M classification (where a email can have several tags, and a tag can be applied to several emails)
Likewise, when you have a big tree, you might want to make subsets of the tree, and these subsets might be overlapping. For example, the subsets of your fathers family and your mothers family, some subset of your family that emigrated to Australia.

The idea is to assign a different tag to each subset: *Paternal, Maternal, Australia* and *ToDo* for example.

The differences with Gramps previous *Markers* are like the folders for emails. A person can be given at most one marker. Tags are thus are like multiple-valued markers.

Go to the Menu Edit -> Tag.

See also *Tag Report*

**New Tag dialog**

You are able to add a new tag either a single or multiple list entries from any of the list views, by making the selection and then using the New Tag dialog.
Tagging a selection of objects

Due to the static nature of tags, it might be useful to add a tag to a selection of objects. For example, one should be able to select a number of people in the Person View, and add them a new tag or an existing one.

Organize Tags Window

![Organize Tags](image1)

Fig. 16.11 Organize Tags - dialog - example

The order in the Organize Tags dialog defines the priority for coloring rows in the category views.

Tag selection dialog

![Tag selection](image2)

Fig. 16.12 Tag selection in the Person Editor

When you use the Edit the tag list button from any of the Editor dialogs like Person Edit, the Tag selection dialog list is shown that lets you remove or assign existing custom tags. The tags are shown in alphabetical order.

Usage of tags

Here are some ideas of operations that can be done with tags

Filtering
The most obvious use is that of filtering.

- Tags and filters both create subsets of the tree. However they have practical differences in usage.

Specifying your father's family using filters is an easy thing; there are already filters based on some logic's that do it. On the other hand, specifying the people that emigrated to the USA is harder, while for the famous people in your family it is simply impossible as there is no logical rule. Tags are much more practical here.

However filters have the advantage of being **dynamical**. If you add an ancestor of your father in the database, it will be automatically added to the filter.

On the other hand, tags are **static**. When adding a famous person in the tree, you have to explicitly tag them as **FAMOUS**.

- The most immediate object that comes to mind are the individuals, and that is also the most useful. However, other objects could be tagged:
  - Places: For example "places to visit",
  - Source: For example "sources in german",
  - Notes: For example "notes in progress", or "notes in german",
  - Media: For example "Picture belonging to Uncle Alfred".

Tags are available to use with all primary objects.

**Tags Column**

To easily see your tags, you can use the **Column Editor** to add the **Tags** column to the list views of objects. The content is then displayed as a comma-separated list of the tags of the objects.

**Tags Usage Report**

The **Tag Usage Report** lists primary objects (person, family, notes) having the selected Tag.

**See also**

- **Tags in Gramps** - an introduction
- Automatic Import timestamp Tags
- filtered Add/Remove Tag Tool (Third party addon for Gramps)
This appendix contains the list of Frequently Asked Questions (FAQ) that repeatedly come up in mailing lists and discussion forums. This list is by no means complete. If you would like to add questions/answers to this list, please join and email your suggestions to the [email protected] mailing list.

Also consider having a look at the following Categories on the Gramps wiki:

- How do I...
- Gramps Tutorials

You may find it useful to review

- Gramps Glossary - gives an overview of terms that appear in Gramps
- Genealogy Glossary - genealogical terms and meanings.

General

What is Gramps?

Gramps is the Genealogical Research and Analysis Management Program System. In other words, it is a personal genealogy program letting you store, edit, and research genealogical data using the powers of your computer, see About.

Where do I get it and how much does it cost?

Gramps can be installed at no charge. Gramps is an Open Source project covered by the GNU General Public License. You have full access to the source code and are allowed to distribute the program and source code freely.

Do I need to register as a user to use Gramps, I am not a programmer?

No, registering is only needed if you want to file a bug (or feature request) report or edit/write a wiki page.

No programming skill needed for that.

Does Gramps exist in other languages?

Yes, at the release of Gramps 5.1 it has been translated into 28 languages, see Gramps translations.

How do I keep backups?

Automatic backup is a default feature that protects your genealogical data in Gramps. (It became automated in 2018 with the release of the 5.1 version.) The interval, backup file path and option to backup when exiting Gramps settings are in the Edit -> Preferences... menu. Additionally, a backup can be manually selected from the Family Trees > Make Backup... window.

It is extremely important to keep backups of your data, and keep them in a safe place. Gramps has a specific portable file format which is small, and human readable, denoted by .gramps. See the "backup up a Family Tree" section of the manual. It is also important to be aware of what is omitted from a Gramps backup.

You can copy this backup file from time to time to a safe location (e.g., a USB stick). [Note: The .gramps files are compressed by default. Clicking them will open Gramps. To see the XML, select the .gramps file and open it with a decompress utility (like ark, gunzip, 7-zip), after which you can extract the XML text file which is human readable, see details.]

Gramps does a quick hidden binary backup to allow restore if an error is noted. If the correct package is installed, you can use a revision system.

Another method is to backup the .gramps hidden directory. This subdirectory is situated in your User Directory. Backing up this directory will backup your databases and revisions. (On Windows 10 it is /Users/<your username>/AppData/Roaming/gramps)

Do not keep backups in GEDCOM format. Not all information Gramps stores can be written in the GEDCOM. Hence, an export/import operation from Gramps exported into GEDCOM and re-imported into Gramps, will mean you lose data. Use the .gramps file format for backups!

Do not keep backups in GRDB format. GRDB is a database, which might be computer dependent (read, not working on a different PC). Small damage to a GRDB file can also not be repaired. Use the .gramps file format for backups!

Does Gramps support Unicode fonts?

In particular, does it support non-Roman Unicode fonts? Yes. Gramps works internally with Unicode (UTF-8), so all alphabets can be used on all entry fields.

There is no special assistance for entering Unicode symbols (glyphs) that are not directly labeled on your keyboard. Finding aids for precomposed characters (aka composite characters or decomposable characters) with diacritical marks are available outside the program. You may find the various language-specific multilingual virtual keyboards on the Lexilogos website useful.
All reports fully support Unicode, although for PDF/PS, you need to work with gnome-print or LibreOffice.

Installation

What is needed to install Gramps under Linux, Solaris, or FreeBSD?

Gramps is a GTK application. Gramps needs to have the PyGObject libraries installed on the system. As long as these libraries are installed, Gramps should function. It will operate under the GNOME desktop, KDE desktop, or any other desktop. If the GNOME bindings for Python are installed on the system, Gramps will have additional functionality. Please check that it meets the Gramps project recommendations regarding the GTK version to use.

Does Gramps work on Windows?

Yes, Windows is a community supported platform for Gramps.

You can download the All In One Gramps Software Bundle for Windows (GrampsAIO).

We will do our best to solve any reported Windows-related problems. See here.

Does Gramps work on the Mac?

Yes, macOS is a community supported platform for Gramps.

You can download the macOS version.

We will do our best to solve any reported Apple macOS related problems. See here.

See here.

Does Gramps work on my mobile device?

Short answer is no, Gramps cannot be installed on your Mobile Phone or tablet (Google Android or Apple iOS).

More technical answer is 'yes' but not as a native application. Using Gramps would require either:

1. install a version of Linux Operating systems on the mobile device along with all the support packages, or
2. set up a local or online server with a fork of Gramps designed for collaboration (such as Gramps Web) and then work with Gramps via browsing

Does Gramps work on my Google Chromebook?

You can but with a few issues install Gramps on your Chromebook see #11058.

What are the Minimum Specs to run Gramps?

We would recommend at least an 1920x1080 video display. The early memory requirements for Gramps, have been reduced, and Gramps were quite high. Beginning with Gramps 3.0, the software could run quite efficiently on a 256MB system, holding considerably more people. A system with 512MB should be able to hold around 200,000 people. However, disk disk space requirements for databases are however considerably larger, with a typical database being several megabytes in size. For 120,000 people you must consider already 530MB for the database. Pictures are stored on disk separately, so a large harddisk is necessary.

How do I upgrade Gramps?

Upgrades begin with making backups of ALL your Trees. But in addition to that, look at the list Backup Omission to determine additions items you may want to archive. (The most important items are noting the database path, backup path, and relative media path in Preferences. If you can't find your data after an upgrade, you will be very unhappy.)

Once backups are safely stored, the most safest approach to upgrading is: downloading the newest installer, un-installing the existing Gramps and re-installing from the installer.

Start Gramps (the first load will be slow as it re-compiles and caches the Python source code files) In the "Edit -> Preferences...", enter your Media path on the General tab, database path on the Family Tree tab, backup on the Family Tree tab. Try loading your Tree via the Family Trees menu.

If this was a 'minor' update (containing only bug fixes), the update should find your configuration and add-ons with no further effort. If it was an upgrade, you wil need to reset all your configuration customizations and download the compatible add-ons.

Preferences

Can I change the dates in reports to 'day month year'?

Yes, in the preferences (Edit -> Preferences Display tab) change the Date format: setting for Gramps to the required format (eg YYYY-MM-DD or day month year), and make the report. Your global date preferences will be used.
Is Gramps compatible with other genealogical software?

Gramps makes every effort to maintain compatibility with GEDCOM, the general standard of recording genealogical information. We have import and export filters that enable Gramps to read and write GEDCOM files.

It is important to understand that the GEDCOM standard is poorly implemented -- virtually every genealogical software has its own "flavor" of GEDCOM. As we learn about new flavor, the import/export filters can be created very quickly. However, finding out about the unknown flavors requires user feedback. Please feel free to inform us about any GEDCOM flavor not supported by Gramps, and we will do our best to support it!

There is a specific article of this wiki which discusses Gramps and GEDCOM. There is also an article about the know idiosyncracies of GEDCOM dialects when importing from another program.

Can Gramps read files created by other genealogy programs?

Yes can read GEDCOM files created by other genealogy programs.

- See above.

Can Gramps write files readable by other genealogy programs?

Yes can write GEDCOM files to be read by other genealogy programs.

- See above.

What standards does Gramps support?

The nice thing about standards is that there never is a shortage of them. Gramps is tested to support the following flavors of GEDCOM 5.5.1, Brother's Keeper, Family Origins, Family Tree Maker, Free, GeneWeb, Legacy, Personal Ancestral File, Pro-Gen, Reunion, and Visual Genealogie.

How do I import data from another genealogy program into Gramps?

The best way is to create a new family tree, and select the import option in the file menu. Here you select the GEDCOM you generated with the other program, and import it.

Can I install Gramps on a Linux Web Server and use it via a web browser?

This would enable my relations worldwide to access and update it.

While Gramps can generate web sites, it does not provide a web interface that allows for editing. If this is a requirement, then GeneWeb or webtrees are programs more likely to meet your needs. Also have a look at experimental gramps-online. However, you may wish to ask yourself the following questions:

1. Do I really want relatives or other people to directly edit my genealogy database?
2. Do I implicitly trust, without verification, any data that people may enter?
3. Do these people have the same understanding of good genealogy practice that I have?

A better approach may be to provide a web form interface that allows others to enter data that is then held for your examination. You can then decide if the information should be entered into your database.

You may also want to consider the effects of possible downtime of your site if you cannot afford yourself a premium webhosting service.

<table>
<thead>
<tr>
<th>New web server option in 2022</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can also now try Gramps Web. Since the project is in an early stage, remember to frequently generate backups when you use this on your genealogical data.</td>
</tr>
<tr>
<td>See Also: Web Solutions for Gramps</td>
</tr>
</tbody>
</table>

Reports

Can Gramps print a genealogical tree for my family?

Yes. Different people have different ideas of what a genealogical tree is. Some think of it as a chart going from the distant ancestor and listing all his/her descendants and their families. Others think it should be a chart going from the person back in time, listing the ancestors and their families. Yet other people think of a table, text report, etc.

Gramps can produce any of the above, and many more different charts and reports. Moreover, the plugin architecture enables users (you) to create their own plugins which could be new reports, charts, or research tools.

How can the relationship between people on the tree be determined?

Some users are interested in only showing direct ancestor or descendant genetic relationships. Other users are also interested in collateral (cousins!) lines or immediate in-laws. And yet other users are interested in how the most indirect connections influence a community.
So Gramps offers a continually expanding variety of tools, reports and methods to determine how people are connected within a Tree's database. Following a discussion on the Gramps-User Maillist, the posted suggestions have been collated and expounded upon in the "How to find the relationship between people" article in the "How do I..." wiki category.

In what formats can Gramps output its reports?

Text reports are available in HTML, PDF, ODT, LaTeX, and RTF formats. Graphical reports (charts and diagrams) are available in PostScript, PDF, SVG, ODS, and GraphViz formats.

How can I change the default language in reports?

The reports are in the language of your installation. Most reports allow you to select the Language to output to look for the Translation option to select the translation to be used for the report. You can change it by installing extra language packs, see Howto: Change the language of reports.

Is Gramps compatible with the Internet?

Yes, in a variety of ways. There are features for referencing hot-linked external data, archiving tools to collecting them to internal storage, and while Gramps is designed to be a local application, a rich set of tools have been created for publishing some or all of your research to the web.

Gramps can store web addresses and direct your browser to them. It can import data that you download from the Internet. It can export data that you could send over the Internet. Gramps is familiar with the standard file formats widely used on the Internet (e.g. JPEG, PNG, and GIF images, MP3, OGG, and WAV sound files, QuickTime, MPEG, and AVI movie files, etc). If your browser is configured to access other file types, Gramps will inherit that ability.

There are addon Finding Aid tools to assist searching for records in online sources. The is an increasing variety of other Web Solutions for Gramps.

The Reports can optionally generate content in formats suitable for publication as webpages or even as entire websites. And there are development forks that extend Gramps into online genealogical content management systems. Some are dynamic presentation systems for publishing research, others offer limited collaborative editing.

See Also

- Web Solutions for Gramps

Can I create custom reports/filters/whatever?

Yes. There are many levels of customization. One is creating or modifying the templates used for the reports. This gives you some control over the fonts, colors, and some layout of the reports. You can also use Gramps controls in the report dialogs to tell what contents should be used for a particular report. In addition to this, you have an ability to create your own filters -- this is useful in selecting people based on criteria set by you. You can combine these filters to create new, more complex filters. Finally, you have an option to create your own plugins. These may be new reports, research tools, import/export filters, etc. This assumes some knowledge of programming in Python.

Why are non-Latin characters displayed as garbage in PDF/PS reports?

This is a limitation of the built-in fonts of PS and PDF formats. To print non-Latin text, use the Print... in the format selection menu of the report dialog. This will use the gnome-print backend, which supports PS and PDF creation, as well as direct printing. (Note: you might need to install gnome-print separately as it is not required for Gramps).

If you only have Latin text, the PDF option will produce a smaller PDF compared to that created by gnome-print, simply because no font information will be embedded.

I would like to contribute to Gramps by writing my favorite report. How do I do that?

The easiest way to contribute to reports, filters, tools, etc. is to copy an existing Gramps report, filter, or tool. If you can create what you want by modifying existing code -- great! If your idea does not fit into the logic of any existing Gramps tool, you will need to write your own plugin from scratch. Help is available on the Developers Portal, or on the Developers mailing list: [email protected].

To test your work in progress, you may save your plugin under $HOME/.gramps/plugins directory and it should be found and imported on startup. The correctly written addon/plugin will register itself with Gramps, create menu item, and so on.

If you are happy with your addon/plugin and would like to contribute your code back to the Gramps project, you are very welcome to do so by joining and contacting us at [email protected] mailing list.

Database - Gramps file formats

The default file format is Gramps XML, it is used for exports, backups, and imports and preserves your entered genealogical data with no data loss as compared to the GEDCOM format.

What is the maximum database size (bytes) Gramps can handle?

Gramps has no hard limits on the size of a database that it can handle. Starting with 2.0.0 release, Gramps no longer loads all data into memory, which allows it to work with a much larger database than before. In reality, however, there are practical limits. The main limiting factors are the available memory on the system and the cache size used for BSDDB database access. With common memory sizes these days, Gramps should have no problem using databases with Millions of people.

How many people can Gramps database handle?
My database is really big. Is there a way around loading all the data into memory?

Starting with 2.0.0 release, Gramps no longer loads all data into memory, which allows it to work with a much larger database than before. The fileformat used is .grdb which means Gramps database.

Can I run Gramps from a database on a NFS share?

Yes you can run a Gramps database from a NFS(NetworkFile System) share.

What does "portable" mean?

A Gramps 3 database (and any .grdb file) is very dependent on the software versions that created it. For example, you can't just move your Gramps data in these formats to a different operating system (or even a different version of an operating system) and expect that you will be able to read your data. The data is not "portable". Therefore, you can't just rely on backups of these formats, but you should also occasionally export into a format that is portable. There are two possible portable formats: GEDCOM and Gramps XML (.gramps or .gpkg). But only Gramps XML is recommended, as it faithfully saves all of your data.

Why is the database format (GRDB) not portable?

The biggest issue with Gramps portability lies with 'transactions'. With Gramps 2.2, we added support for atomic transactions to protect data. With atomic transactions, multiple changes are committed as a single unit. Either all the changes make it, or none of the changes make it. You are never left in a situation with a partial set of changes. A side benefit of using transactions is that database access (reads and writes) are faster.

The problem with transactions (at least using BSDDB) is that it does not allow all the data to be stored in a single file. Logging files are needed to keep track of things. These logging files are kept in a DB Environment directory. We need a separate directory for each file, otherwise the log files can interfere with each other.

In 2.2, we keep the log files under the ~/.gramps/ directory, creating a unique directory for each database. The problem is that your GRDB file needs the log files, which are in a different directory.

Copying the GRDB file is only copying a portion of the database.

Does Gramps have an Example Tree?

Yes, it does. Several example family tree databases are included with most installations of Gramps and can be imported for working through tutorials and for safely exploring tools or features.

The example family tree database (example.gramps file) attempts the ideal of having at least one example of even the obscure things that Gramps does. You can import the example into a blank Tree then safely make destructive exploratory mistakes on a disposable working database. And when you suspect that you have discovered an issue (aka 'bug') in Gramps, you can first try the same operation with the example family tree then file a bug report.

- The Example.gramps wiki article describes where to find the example Family Tree archival file, how to use it and suggests some alternative files.

Bugs and requests

What do I do if I have found a bug?

You can submit a bug report.

A good bug report would include:

1. Version of Gramps you were using when you encountered the bug (available through Help → About menu item).
2. Language under which Gramps was run (available by executing echo $LANG in your terminal).
3. Symptoms indicating that this is indeed a bug.
4. Any Traceback messages, error messages, warnings, etc, that showed up in your terminal or a in separate traceback window.

Most problems can be fixed quickly provided there is enough information. To ensure this, please follow up on your bug reports. Then we will have a way of contacting you should we need more information.

Requests

- Gramps should be a .... type of application

It is obvious that Gramps absolutely needs to become a (client-server/web-based/PHP/weblog/Javascript/C++/distributed/KDE/Motif/Tcl/Win32/C#/You-name-it) application. When is this going to happen?

The surest way to see it happen is to get it done by yourself. Since Gramps is free/open source, nobody prevents you from taking all of the code and continuing its development in whatever direction you see fit. In doing so, you may consider giving your new project another name to avoid confusion with the continuing Gramps development. If you would like the Gramps project to provide advice, expertise, filters, etc., we will gladly cooperate with your new project, to ensure compatibility or import/export options to your new format of a project.

If, however, you would like the Gramps project to adopt your strategy, you would need to convince Gramps developers that your strategy is good
for Gramps and superior to the present development strategy.

**Adding to and editing my database**

**What is the difference between a residence and an address?**

A residence is a place where someone lived for a period of time. An address is the name of a residence formatted in the way expected by the postal system. Therefore each residence can also have an address if that is useful. See also: Why residence event and not Address?

**How do I change the order of children?**

Children can be moved in the Family Editor's Children tab by dragging and dropping or using the **up** and **down** buttons.

**How do I change the order of spouses?**

Spouses can be reordered from the Relationships Category by selecting the **Reorder** button in the toolbar.

**How do I add an additional spouse?**

See Add a spouse

**How do I remove a spouse?**

Removing a Spouse (without deleting the Person profile from the tree) requires just a single click in the Edit Family dialog. Simply click the "Remove person as the mother/father" (-) button just above the name of the Spouse.

_The Name, Birth & Death will be cleared and the "Add a new person as the mother/father" (+) and "Shared person selection" buttons will replace the (-) and "Edit" buttons._

To remove the Spouse from the Tree entirely, select the Person in the Person view and click the "Delete the selected person" (-) toolbar button. A confirmation dialog will appear. Confirm by clicking the "Delete Person" button.

_The Person will be removed from all families where they are a Spouse or a Child. The attached Events, Citations, Notes and Media will be orphaned. The other secondary objects will be deleted along with their Person._

**How do you add photos to an item?**

See Adding photos and other media objects

**How do you find unused media?**

Media that have not been associated with any objects may be found by creating a Custom Filter in the Media Category view. Use the Media objects with a reference count of <count> rule to find media with fewer than 1 reference.

**How can I publish a genealogy web site with Gramps?**

Gramps has multiple options in the Reports menu for creating Web Pages based on your Tree data.

The Howto: Make a genealogy website with Gramps tutorial describes using the Narrated Web Site (a.k.a. NarrativeWeb) report. In it, you will learn to generate a website around a set of people in your Family Tree.

Once generated, you can upload the web files to a hosting service. You can also distribute them on a portable thumbdrive or other media.

See Also

Web Solutions for Gramps

You can also install third party addon reports to create other styles of web content. See the Addons List.
Keybindings

This appendix lists keybindings (also known as Keyboard shortcuts or hotkeys) that can be used in the Gramps dialogs as an alternative to using the mouse.

Some keybindings require the user to press a single key or a sequence of keys one after the other. Other keybindings require pressing and holding several keys simultaneously.

### Keyboards are not all the same!

Keybindings may depend on the keyboard layout (localization) and on your computer’s Operating System.

The following keybindings are available in all category views.

### List Views

#### Common keybindings

<table>
<thead>
<tr>
<th>Action/Function</th>
<th>Microsoft Windows</th>
<th>macOS</th>
<th>KDE/GNOME</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage family trees</td>
<td>Ctrl + O</td>
<td>⌘Cmd + O</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Import family tree</td>
<td>Ctrl + I</td>
<td>⌘Cmd + I</td>
<td>Ctrl + I</td>
</tr>
<tr>
<td>Export family tree</td>
<td>Ctrl + E</td>
<td>⌘Cmd + E</td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>Changes to the next Category</td>
<td>Ctrl + N</td>
<td>⌘Cmd + N</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Changes to the previous Category</td>
<td>Ctrl + P</td>
<td>⌘Cmd + P</td>
<td>Ctrl + P</td>
</tr>
<tr>
<td>Change Category to Category number 0/1/2/.../9</td>
<td>Ctrl + 1 ...</td>
<td>⌘Cmd + 1 ...</td>
<td>Ctrl + 1 ...</td>
</tr>
<tr>
<td>Within the Category changes the view to view mode number 0/1/2/.../9</td>
<td>Ctrl + Alt + 1 ...</td>
<td>⌘Cmd + Opt + 1 ...</td>
<td>Ctrl + Alt + 1 ...</td>
</tr>
<tr>
<td>Open the Clipboard</td>
<td>Ctrl + B</td>
<td>⌘Cmd + B</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Add the selected item as a bookmark</td>
<td>Ctrl + D</td>
<td>⌘Cmd + D</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Organize the bookmarks</td>
<td>⌃Shift + Ctrl + D</td>
<td>⌃Shift + ⌘Cmd + D</td>
<td>⌃Shift + Ctrl + D</td>
</tr>
<tr>
<td>Open the Undo History dialog</td>
<td>Ctrl + H</td>
<td>⌃Shift + ⌘Cmd + H</td>
<td>Ctrl + H</td>
</tr>
<tr>
<td>Jump to a Gramps ID in the Current View</td>
<td>Ctrl + J</td>
<td>⌘Cmd + J</td>
<td>Ctrl + J</td>
</tr>
<tr>
<td>Move to previous item in history</td>
<td>Alt + ⌃ (Left arrow)</td>
<td>⌘Opt + ⌃ (Left arrow)</td>
<td>Alt + ⌃ (Left arrow)</td>
</tr>
<tr>
<td>Move to next item in history</td>
<td>Alt + ⌃ (Right arrow)</td>
<td>⌘Opt + ⌃ (Right arrow)</td>
<td>Alt + ⌃ (Right arrow)</td>
</tr>
<tr>
<td>Go to the Home Person</td>
<td>Alt + Home</td>
<td>Alt + Home</td>
<td>Alt + Home</td>
</tr>
<tr>
<td>Same action as the Configure active view button</td>
<td>⌃Shift + Ctrl + C</td>
<td>⌃Shift + ⌘Cmd + C</td>
<td>⌃Shift + Ctrl + C</td>
</tr>
<tr>
<td>Toggle the left splitter (Navigator panel)</td>
<td>⌃Shift + Ctrl + M</td>
<td>⌘Cmd + M</td>
<td>Ctrl + M</td>
</tr>
<tr>
<td>Toggle the right granplet splitter (Sidebar)</td>
<td>⌃Shift + Ctrl + R</td>
<td>⌘Cmd + R</td>
<td>⌃Shift + Ctrl + R</td>
</tr>
<tr>
<td>Toggle the bottom granplet splitter (Bottombar)</td>
<td>⌃Shift + Ctrl + B</td>
<td>⌘Cmd + B</td>
<td>⌃Shift + Ctrl + B</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>⌘Cmd + Z</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Do again</td>
<td>⌃Shift + Ctrl + Z</td>
<td>⌘Cmd + Z</td>
<td>⌃Shift + Ctrl + Z</td>
</tr>
<tr>
<td>Quit Gramps</td>
<td>Ctrl + Q</td>
<td>⌘Cmd + Q</td>
<td>Ctrl + Q</td>
</tr>
</tbody>
</table>

Add/Create a new object (Opens the related Editor)

- **Person**: ⌃Shift + Alt + P
- **Family**: ⌃Shift + Alt + F
- **Event**: ⌃Shift + Alt + E
- **Place**: ⌃Shift + Alt + L
- **Source**: ⌃Shift + Alt + S
- **Citation**: ⌃Shift + Alt + C
- **Repository**: ⌃Shift + Alt + R
- **Media**: ⌃Shift + Alt + M
- **Note**: ⌃Shift + Alt + N

### All List Views bindings

**Keybindings - List Views**
The following bindings are available in all list views: People, Families, Events, Places, Sources, Citations, Repositories, Media and Notes View.

<table>
<thead>
<tr>
<th>Action/Function</th>
<th>Microsoft Windows</th>
<th>Mac OS</th>
<th>KDE/GNOME</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edits the selected list item</td>
<td>Ctrl+P</td>
<td>⌘ cmd+A</td>
<td>Ctrl+P</td>
<td></td>
</tr>
<tr>
<td>Adds a new item to the database</td>
<td>Ctrl+ Insert</td>
<td>⌘ cmd+A</td>
<td>Ctrl+ Insert</td>
<td></td>
</tr>
<tr>
<td>Deletes the selected list item</td>
<td>Ctrl+ Delete</td>
<td>⌘ cmd+D</td>
<td>Ctrl+ Delete</td>
<td></td>
</tr>
<tr>
<td>Activate the [Find] field</td>
<td>Ctrl+F</td>
<td>⌘ cmd+F</td>
<td>Ctrl+F</td>
<td>List view interactive search ahead / Quick search</td>
</tr>
<tr>
<td>Expands and collapses entries of the selected entry in Group mode</td>
<td>⌘ Shift + ⏎ (expand)</td>
<td>⌘ Shift + ⏎ (expand)</td>
<td>⌘ Enter</td>
<td></td>
</tr>
<tr>
<td>Expands and contracts selected entry in Group mode</td>
<td>⌘ Shift + ⏎ (Up arrow)</td>
<td>⌘ Shift + ⏎ (Up arrow)</td>
<td>⌘ Enter</td>
<td></td>
</tr>
</tbody>
</table>

### Editors

#### Editor Tab bindings

These bindings work on the tab pages of the editors (so not on the labels of the tabs!), press tab on label to move to tabpage content.

<table>
<thead>
<tr>
<th>Action/Function</th>
<th>Microsoft Windows</th>
<th>Mac OS</th>
<th>KDE/GNOME</th>
<th>Mouse Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same action as the [button when that button is present</td>
<td>⌘ Enter</td>
<td>Return or ⌘ Enter</td>
<td>⌘ Enter</td>
<td></td>
</tr>
<tr>
<td>Same action as the button when that button is present</td>
<td>Insert</td>
<td>Insert</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Same action as the button when that button is present</td>
<td>Delete</td>
<td>Delete</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change tabpage to the tabpage to the left</td>
<td>Alt+← (Left arrow)</td>
<td>Ctrl+← (Left arrow)</td>
<td>Alt+← (Left arrow)</td>
<td>Right-click</td>
</tr>
<tr>
<td>Change tabpage to the tabpage to the right</td>
<td>Alt+→ (Right arrow)</td>
<td>Ctrl+→ (Right arrow)</td>
<td>Alt+→ (Right arrow)</td>
<td>Double-click</td>
</tr>
</tbody>
</table>

#### Editor bindings

These bindings work on Editors by activating focus or by changing state of toggle buttons (Accessibility).

<table>
<thead>
<tr>
<th>Action/Function</th>
<th>Microsoft Windows</th>
<th>Mac OS</th>
<th>KDE/GNOME</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the privacy status.</td>
<td>Ctrl+P</td>
<td>⌘ cmd+P</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Call the Date editor (if present).</td>
<td>Ctrl+D</td>
<td>⌘ cmd+D</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Activate the Add button (if present).</td>
<td>Ctrl+A</td>
<td>⌘ cmd+A</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Activate the Edit button (if present).</td>
<td>Ctrl+E</td>
<td>⌘ cmd+E</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Activate the Select button (if present).</td>
<td>Ctrl+S</td>
<td>⌘ cmd+S</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Activate the Delete button (if present).</td>
<td>Ctrl+M</td>
<td>⌘ cmd+M</td>
<td>Ctrl+M</td>
</tr>
</tbody>
</table>

### Handy Shortcuts

<table>
<thead>
<tr>
<th>Action/Function</th>
<th>Microsoft Windows</th>
<th>Mac OS</th>
<th>KDE/GNOME</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full screen</td>
<td>F1</td>
<td>⌘ cmd+F</td>
<td>F1</td>
<td>Maximizes Gramps to use the Full screen</td>
</tr>
<tr>
<td>Show this user manual</td>
<td>F1</td>
<td>F1</td>
<td>F1</td>
<td></td>
</tr>
<tr>
<td>Select the delete button</td>
<td>Alt+O</td>
<td>⌘ cmd+O</td>
<td>⌘ cmd+O</td>
<td>Handy for use with low resolution screens</td>
</tr>
<tr>
<td>Dismiss (Select the [Cancel] button)</td>
<td>Esc</td>
<td>Esc</td>
<td>Esc</td>
<td>Handy for use with low resolution screens</td>
</tr>
<tr>
<td>Toggle Open/Save dialog</td>
<td>Ctrl+L</td>
<td>Ctrl+L</td>
<td>Ctrl+L</td>
<td>Handy for pasting filepaths</td>
</tr>
<tr>
<td>between breadcrumbs and filepaths</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Context menu

A context pop-up menu shows limited number of choice related to the currently selected item in a Graphical User Interface. The menu appears with right-click on an item in operating systems with a 2 or 3 button mouse. In the one button mouse macOS, a ⌘ cmd-click will bring up the Contextual Menus.

Keybindings:

- In Windows, the **Menu Key** (aka application key) will show the context menu for the active field. Alternately, the ⌘ cmd+shift+F10 keyboard shortcut, or sometimes ⌘ cmd+shift+F10
In macOS, users will need to enable the Universal Access settings in the System Preferences.

### Quick navigation to an object

The clipboard has a navigation shortcut. Copy any object to the Clipboard (by drag'n'drop or by selecting and pressing the `Ctrl+C` keybinding), then select the object on the Clipboard and right-click to reveal the Clipboard's contextual pop-up menu. The bottom menu item will offer to make the selected object active. The View will not navigate to the object's category.

See [Context Menu](#)

### See also

- [Table of keyboard shortcuts](#) - for major operating systems.
- Discourse forum thread: "[Can I disable a hotkey/keybinding](#)" (aka: hacking keybindings)
This appendix provides the reference to the command line capabilities available when launching Gramps from the terminal.

Start Gramps through the Command Line

Normally Gramps is started through the graphical user interface (GUI) on your platform. It is also possible to start Gramps using a command line interface (CLI). CLI use can

- produce reports that are not available via the GUI,
- create reports, do conversions etc. without opening a window and
- can provide extra information in the event of problems.

This section of the user manual describes how to start Gramps through the CLI, and the features that are available.

The way you start Gramps through the CLI depends on the operating system you are using.

For simplicity of description, the examples of use below are written from the point of view of running Gramps on Linux. The examples would need to be changed for other platforms.

**Linux**

Only the Linux platform is officially supported as Gramps developers use and test the source code on that platform, fixing any problems that arise due to upgrades.

Assuming you have used the standard Package Manager (either through a CLI or a GUI) for your Linux distribution, you start Gramps through the CLI by typing

```
gramps
```

**MS Windows**

MS Windows is a community supported platform. If you install the Windows Alo bundle, then this will place an icon on the desktop as well as a menu item in the 'Start' menu. However, the Gramps installation directory is not added to the system path and to run gramps via CLI, we need to know the path to that directory. To find the installation folder, refer to Alo bundle's installation folder section.

To find the path using a shortcut icon instead,

- Right-click on the GrampsAIO64 5.1.6-console application, or the corresponding item in the Start menu.
- Note down the file location (its 'Start in' directory).
- Select the full path and copy (Ctrl+c) it.

To run Gramps from the command line, you'll need to start a console window:

- From the Start menu, start cmd.exe.
- Change directory to the installation directory you located.
- Type in or paste the path, surrounding it in quotes if there are spaces.
- Press Enter.

For example, this might be:

```
cd "C:\Program Files\GrampsAIO64-5.1.6"
gramps
```

You may use any of the command-line options along with this. For example, to get a detailed listing of all of the Family Tree databases in your default Family Tree folder, you would append -L

```
cd "C:\Program Files\GrampsAIO64-5.1.6"
gramps -L
```

See example usage https://github.com/gramps-project/addons-source/pull/121

**MacOS**

MacOS is a community supported platform. If you download the MacOS disk image (.dmg), then you simply drag the application to your application folder (or anywhere else you want to store it) and start Gramps by double clicking on the application in the normal way. The Homebrew package manager[1] also allows for installation of the application in the usual Applications folder.

To run from the command line, you'll need to start Terminal, found in the Utilities folder of the main Applications folder (/Applications/Utilities). Once you have a terminal window open, at the prompt type

```
/path/to/Gramps.app/Contents/MacOS/Gramps
```

If you installed Gramps in Applications along with most of your other apps, as suggested above, that would be

```
/Applications/Gramps.app/Contents/MacOS/Gramps
```
You may use any of the command-line options along with this. For example, to get a detailed listing of all of the Family Tree databases in your default Family Tree folder, you would use

```
/Applications/Gramps.app/Contents/MacOS/Gramps -L
```

There are other ways to install Gramps for MacOS, but these are much more complicated and are not covered here.

**Python options**

In the examples of different platforms above, and also in commands in various files you may see some options after the 'python' command, for example '-EO' in

```
"python3 -EO ..\share\gramps\gramps.py -L
```

It is important to distinguish between the **python options** in this case:

- `-EO`
  and the **Gramps options**, in this case

- `-L`

The **python options** that you may come across are:

- `-e` Ignore all PYTHON* environment variables, e.g. PYTHONPATH and PYTHONHOME, that might be set.
- `-o` Turn on basic optimizations. This changes the filename extension for compiled (bytecode) files from .pyc to .pyo. See also PYTHONOPTIMIZE.

The -o optimise flag has a number of effects in Gramps:

- If it is not turned on, an additional Debug entry appears in the Tools menu.
- If it is not turned on, info logging messages are output.
- If it is not turned on, debug statements may be activated.
- If it is not turned on, additional features are available in the Plugin Manager.

The **Gramps options** are described below.

**Available Gramps options**

This section provides the reference list of all command line options available in Gramps. If you want to know more than just a list of options, see next sections: **Operation** and **Examples**. The summary below is printed by

```
gramps -h
```

or

```
gramps --help
```

**Usage:**

```
gramps.py [OPTION...]   --load-modules=MODULE1,MODULE2,...
```

**Help options**

```
--load-modules=MODULE1,MODULE2,...
```

**Dynamic modules to load**

**Help options**

```
-?, --help                             Show this help message
--usage                                Display brief usage message
```

**Application options**

```
-o, --open=FAMILY_TREE                 Open Family Tree
-u, --username=USERNAME                Database username
-p, --password=PASSWORD                Database password
-c, --create=FAMILY_TREE               Create on open if new Family Tree
-i, --import=FILENAME                  Import file
-e, --export=FILENAME                  Export file
-r, --remove=FAMILY_TREE_PATTERN       Remove matching Family Tree(s) (use regular expressions)
-f, --format=FORMAT                    Specify Family Tree format
-a, --action=ACTION                    Specify action
-o, --options=OPTIONS_STRING           Specify options
-d, --debug=LOGGER_NAME                Enable debug logs
-l [FAMILY_TREE_PATTERN,...]           List Family Trees
-t [FAMILY_TREE_PATTERN,...]           List Family Trees, tab delimited
-f, --force-unlock                     Force unlock of Family Tree
-s, --show                              Show config settings
-c, --config=[config.setting[:value]]  Set config setting(s) and start Gramps
-y, --yes                               Don’t ask to confirm dangerous actions (non-GUI mode only)
-q, --quiet                             Suppress progress indication output (non-GUI mode only)
-v, --version                           Show versions
-s, --safe                              Start Gramps in 'Safe mode'
                                      (temporarily use default settings)
-D, --default=[APXFE]                   Reset settings to default;
                                      A = addons are cleared
                                      P = Preferences to default
                                      X = Books are cleared, reports and tool settings to default
                                      F = filters are cleared
                                      E = Everything is set to default or cleared
```

The usage message is as follows:

```
gramps --usage
```

**Example of usage of Gramps command line interface**

1. To import four databases (whose formats can be determined from their names) and then check the resulting database for errors, one may type:

```
```

**Command Line - Python options**
2. To explicitly specify the formats in the above example, append filenames with appropriate -f options:

3. To record the database resulting from all imports, supply -e flag
   (use -f if the filename does not allow Gramps to guess the format):
   gramps -i file1.ged -i file2.gpkg -e ~/new-package -f gramps-pkg

4. To save any error messages of the above example into files outfile and errfile, run:
   gramps -i file1.ged -i file2.gpkg -e ~/new-package -f gramps-pkg >outfile 2>errfile

5. To import three databases and start interactive Gramps session with the result:
   gramps -i file1.ged -i file2.gpkg -i ~/db3.gramps

6. To open a database and, based on that data, generate timeline report in PDF format
   putting the output into the my_timeline.pdf file:
   gramps -O 'Family Tree 1' -a report -p name=timeline,off=pdf,of=my_timeline.pdf

7. To generate a summary of a database:
   gramps -O 'Family Tree 1' -a report -p name=summary

8. Listing report options
   Use the name=timeline,show=all to find out about all available options for the timeline report.
   To find out details of a particular option, use show=option_name , e.g. name=timeline,show=off string.
   To learn about available report names, use name=show string.

9. To convert a Family Tree on the fly to a .gramps xml file:
   gramps -O 'Family Tree 1' -e output.gramps -f gramps-xml

10. To generate a web site into an other locale (in German):
    LANGUAGE=de_DE; LANG=de_DE.UTF-8 gramps -O 'Family Tree 1' -a report -p name=navwebpage,target=./..de

11. Finally, to start normal interactive session type:
    gramps

Note: These examples are for bash shell. Syntax may be different for other shells and for Windows.

List options

Print a list of known family trees:

Sparse
   -1, List Family Trees
   gramps -l
   List of known Family Trees in your database path
   /home/<~username>/.gramps/grampsdb/5a46c1c3 with name "Example Family Tree"

Detailed
   -L, List Family Trees in Detail
   gramps -L
   Gramps Family Trees:
   Family Tree "Example Family Tree":
   Database: SQLite
   Database module location: /usr/lib/python3.6/sqlite3/__init__.py
   Database module version: 2.6.0
   Database version: 3.21.0
   Last accessed: 30/12/17 09:29:37
   Locked?: False
   Number of citations: 2854
   Number of events: 3432
   Number of families: 762
   Number of media: 7
   Number of notes: 19
   Number of people: 2157
   Number of places: 1294
   Number of repositories: 3
   Number of sources: 4
   Number of tags: 2
   Path: /home/<~username>/.gramps/grampsdb/5a46c1c3
   Schema version: 18.0.0

Note that dates are shown in the default LOCALE format.
You change that at the system level. For example, on POSIX-based systems you could use:
   LC_TIME=en_AU.UTF-8 gramps -L

Version options

   -v or --version prints version of Gramps and dependencies,
   information about environment settings and python and system paths
   gramps -v
   Gramps Settings:
   ----------------
   python    : 3.7.5

Command Line - Python options
Environment settings:
-------------------------------
LANG      : en_GB.UTF-8
LANGUAGE  : en_GB:en
GRAMPSI18N: not set
GRAMPSHOME: not set
GRAMPSDIR : not set
PYTHONPATH:
/usr/lib/python3/dist-packages/gramps
/usr/bin
/usr/lib/python37.zip
/usr/lib/python3.7
/usr/lib/python3.7/lib-dynload
/usr/local/lib/python3.7/dist-packages
/usr/lib/python3/dist-packages

Non-python dependencies:
-------------------------------
Graphviz  : 2.40
Ghostscr. : 9.27

System PATH env variable:
-------------------------------
/usr/local/sbin
/usr/local/bin
/usr/sbin
/usr/bin
/sbin
/bin
/usr/games
/usr/local/games
/snap/bin

Databases:
-------------------------------
bsddb     :
version    : 6.2.6
db version : 5.3.28
location   : /usr/lib/python3/dist-packages/bsddb3/__init__.py

sqlite3   :
version    : 3.29.0
py version : 2.6.0
location   : /usr/lib/python3.7/sqlite3/__init__.py

Format options

The format of any file destined for opening, importing, or exporting can be specified with the
-f format
option. The acceptable format values are listed below.

Full family tree support

These formats contain all your data that is present in a family tree.

- gramps - Gramps XML format: This format is available for import, and export. When not specified, it can be guessed if the filename ends with .gramps
- gpkg - Gramps package XML format: This format is available for import and export. When not specified, it can be guessed if the filename ends with .gpkg. This creates a zip package with your data as xml, and all your media files included
- grdb - pre Gramps 3.x database: This format is available for import to support the old file format of Gramps. Everything in the grdb file is imported. When not specified, it can be guessed if the filename ends with .grdb
- burn - GNOME iso burning: export, only available on GNOME where burn protocol exists

Reduced family tree support

These formats contain most, but not all data that can be created in Gramps

- ged - GEDCOM format: This format is available for import, and export. When not specified, it can be guessed if the filename ends with .ged
- gw - GeneWeb file: This format is available for import and export. When not specified, it can be guessed if the filename ends with .gw

Subset of your data

These formats contain a specific subset of your data

- csv - Comma Separated Value: This format is available for import and export. Be careful however, import must be as values created by the export function. Only a part of your data is contained in the output.
- vcf - VCard 3.0 format: import and export
- vcs - VCalendar format: export
- def - old Pro-Gen format: import
• wft - Web Family Tree: This format is available for export only. When not specified, it can be guessed if the filename ends with .wft

Opening options

You can open a family tree, or you can open a file by importing it in an empty family tree.

To let Gramps handle this automatically, just supply the family tree or filename you want to open:

```python
python gramps.py 'My Fam Tree'
python gramps.py JohnDoe.ged
```

The first opens a family tree, the second imports a GEDCOM into an empty family tree.

Additionally, you can pass Gramps the name of the family tree to be opened:

• use this option: `-O famtree` or `--open=famtree`

`-o`, Open of a family tree. This can be done also by just typing the name (name or database dir)

Examples:

```python
python gramps.py 'Family Tree 1'
python gramps.py /home/cristina/.gramps/grampsdb/47320f3d
python gramps.py -O 'Family Tree 1'
python gramps.py -O /home/cristina/.gramps/grampsdb/47320f3d
```

Tip

If no option is given, just a name, Gramps will ignore the rest of the command line arguments. Use the `-o` flag to open, `-i` to import, and do something with the data.

Tip

Only family trees can be opened directly. For other formats, you will need to use the import option which will set up the empty database and then import data into it.

Tip

Only a single family tree can be opened. If you need to combine data from several sources, you will need to use the import option.

Import options

The files destined for import can be specified with the `-i` filename or `--import=filename` option. The format can be specified with the `-f` format or `--format=format` option, immediately following the `filename`. If not specified, the guess will be attempted based on the `filename`

Example:

```python
python gramps.py -i 'Family Tree 1' -i 'Family Tree 2'
python gramps.py -i test.grdb -i data.gramps
```

Tip

More than one file can be imported in one command. If this is the case, Gramps will incorporate the data from the next file into the database available at the moment.

When more than one input file is given, each has to be preceded by `-i` flag. The files are imported in the specified order, i.e. `-i file1 -i file2` and `-i file2 -i file1` might produce different Gramps IDs in the resulting database.

Export options

The files destined for export can be specified with the `-e` filename or `--export=filename` option. The format can be specified with the `-f` option immediately following the `filename`. If not specified, the guess will be attempted based on the `filename`. For iso format, the `filename` is actually the name of directory the Gramps database will be written into. For gramps-xml, gpkg, gedcom, wft, geneweb, and gramps-pkg, the `filename` is the
name of the resulting file.
-e, export a family tree in required format. It is not possible to export to a family tree.

Example:
```
python gramps.py -I 'Family Tree 1' -i test.grdb -f grdb -e mergedDB.gramps
```
Note that above does not change 'Family Tree 1' as everything happens via a temporary database, whereas:
```
python gramps.py -0 'Family Tree 1' -i test.grdb -f grdb -e mergedDB.gramps
```
will import test.grdb into Family Tree 1, and then export to a file!

---

### Exporting more files

More than one file can be exported in one command. If this is the case, Gramps will attempt to write several files using the data from the database available at the moment.

---

When more than one output file is given, each has to be preceded by -e flag. The files are written one by one, in the specified order.

### Action options

The action to perform on the imported data can be specified with the `-a action` or `--action=action` option. This is done after all imports are successfully completed.

The following actions remain the same:

- **report**: This action allows producing reports from the command line.
- **tool**: This action allows to run a tool from the command line.

Reports and tools generally have many options of their own, so these actions should be followed by the report/tool option string. The string is given using the `-p option_string` or `--options=option_string` option.

The actions available in older versions of Gramps which were relocated in Gramps 3.3 are:

- **summary**: This action was the same as Reports -> View -> Summary. In Gramps 3.3 it was replaced by (or renamed to) `-a report -p name=summary`.
- **check**: This action was the same as Tools -> Database Processing -> Check and Repair. In Gramps 3.3 it was replaced by (or renamed to) `-a tool -p name=check`.

### report action option

You can generate most reports from the command line using the report action.

An example:
```
gramps -O "Family Tree 1" -a report -p "name=family_group,style=default,off=html,of=test.html"
```

You can provide the css style to use here with the css option:
```
gramps -O "Family Tree 1" -a report -p "name=family_group,style=default,off=html,of=test.html,css=Web_Nebraska.css"
```
or without css in the html output:
```
gramps -O "Family Tree 1" -a report -p "name=family_group,style=default,off=html,of=test.html,css="
```

---

### Report option string

The report option string should satisfy the following conditions:
- It must not contain any spaces (due to the general nature of the command line interface). If some arguments need to include spaces, the string should be enclosed with quotation marks.
- Option string must list pairs of option names and values. Within a pair, option name and value must be separated by the equal sign.
- Different pairs must be separated by commas.

Most of the report options are specific for every report. However, there are some common options.

- **name=report_name**: This mandatory option determines which report will be generated.
Report names

If the supplied report_name does not correspond to any available report, an error message will be printed followed by this list of available reports.

Available names are:

- ancestor_chart - Ancestor Tree
- ancestor_report - Ahnentafel Report
- AncestorFill - Ancestor Fill
- birthday_report - Birthday and Anniversary Report
- calendar - Calendar
- d3-ancestralcollapsibletree - Ancestral Collapsible Tree
- d3-ancestralfanchart - Ancestral Fan Chart
- d3-descendantindentedtree - Descendant Indented Tree
- database-differences-report - Database Differences Report
- denominoviso - Denominoviso
- descend_chart - Descendant Tree
- descend_report - Descendant Report
- DescendantBook - Descendant Book
- DescendantsLines - Descendants Lines
- det_ancestor_report - Detailed Ancestral Report
- det_descendant_report - Detailed Descendant Report
- DetailedDescendantBook - Detailed Descendant Book
- double_cousins - Double Cousins
- DynamicWeb - Dynamic Web Report
- endofline_report - End of Line Report
- family_descend_chart - Family Descendant Tree
- family_group - Family Group Report
- familines_graph - Family Lines Graph
- FamilySheet - Family Sheet
- FamilyTree - Family Tree
- fan_chart - Fan Chart
- gt_ancestor - Ancestor Tree
- gt_descendant - Descendant Tree
- gt_grandparent - Grandparent Tree
- gt_sandclock - Sandclock Tree
- gt_sandclock_family - Sandclock Tree for a Family
- Heatmap - Heatmap
- hourglass_graph - Hourglass Graph
- indiv_complete - Complete Individual Report
- kinship_report - Kinship Report
- LastChangeReport - Last Change Report
- LinesOfDescendency - Lines of Descendency Report
- ListeEclair - Tiny Tafel
- MediaReport - Media Report
- navwebpage - Narrated Web Site
- networkchart - Network Chart
- notelinkreport - Note Link Report
- number_of_ancestors - Number of Ancestors Report
- PedigreeChart - Pedigree Chart
- PersonEverythingReport - Person Everything Report
- place_report - Place Report
- records - Records Report
- rel_graph - Relationship Graph
- Repositories Report - Repositories Report
- SourcesCitationsReport - Sources and Citations Report
- statistics_chart - Statistics Charts
- summary - Database Summary Report
- tag_report - Tag Report
- timeline - Timeline Chart
- TimePedigreeHTML - Time Pedigree Report
- TodoReport - Todo Report
- WebCal - Web Calendar

- of=<output filename and optional destination folder/directory eg: of="C:\Users\<username>\Desktop\FamilyTree.odt">
- off=<output format. These are the extension an output format makes available, eg, pdf, html, doc, ...>
- style= for text reports, the stylesheet to use. Defaults to 'default'.
- show=all: This will produce the list of names for all options available for a given report.
- show=option_name: This will print the description of the functionality supplied by the option_name, as well as what are the acceptable types and values for this option.

So, to learn to use a report, do for example:

```
gramps -O "Family Tree 1" -a report -p "name=family_group,show=all"
```

Tip

If an option is not supplied, the last used value will be used. If this report has never been generated before, then the value from last generated report will be used when applicable. Otherwise, the default value will be used.

When more than one output action is given, each has to be preceded by -a flag. The actions are performed one by one, in the specified order.

lists

Some reports have options or arguments which are interpreted (by the report) to be on multiple lines. For instance some reports allow you to format how the information will be shown, perhaps with a name on one line and the person's birth date on the next line. Such multiple-line options or arguments are called "lists" by Gramps.
On the command line such lists must always start with a left square bracket [ and must always end with a right square bracket ] but since such square brackets are usually "special" to the "shell" (they mean something to the command interpreter you are typing the command to), you must "escape" them so that they are ignored by your shell.

The details vary with each shell but (in Linux/UNIX) usually you can precede such a square bracket with a backslash \ or put quotation marks around the square bracket, usually either "single" or "double" ones.

The Hourglass Graph report allows you to put a "note" at the top of the report and such a "note" is an example of a "list" option. Here is an example:

```
gramps -O "Family Tree 1" -a report -p name=hourglass_graph,note='[line one,line two]'```

which shows that inside such a list different lines are separated by commas, and that spaces are acceptable since the quotation marks are already there for the square brackets.

But if you want to have a comma inside your report you have to somehow tell Gramps that comma is not one which separates lines. You do that by enclosing the line with the comma in quotation marks (either single or double).

But if you are already using a set of quotation marks (to enclose your square brackets) you have to use the other type to enclose the line with your comma. Here is an example:

```
gramps -O "Family Tree 1" -a report -p name=hourglass_graph,note="['line one, also line one','line two, also line two']"
```

It is possible to include any character in a list but the details are beyond the scope of this command-line introduction to Gramps.

You will need to know the precise methods available in your particular command shell interpreter to include a character which is "special" to your shell or "special" to Gramps (like the comma in the example above) but in general you will have to "escape" it twice, once to your shell and once again to Gramps, since you don't want your shell to think it is some instruction it should pay attention to and you don't want Gramps to think that either.

tool action option

You can run most tools from the command line using the 'tool' action. To see which ones, say:

```
gramps -O "Family Tree 1" -a tool -p show=all```

To see a tool's available options, for instance the "verify" tool:

```
gramps -O "Family Tree 1" -a tool -p name=verify,show=all```

To run a tool, for instance the "verify" tool:

```
gramps -O "Family Tree 1" -a tool -p name=verify```

book action option

You can run books from the command line using the 'book' action. To see which ones, say:

```
gramps -O "Family Tree 1" -a book```

To see a book's available options, for instance a book called "mybook":

```
gramps -O "Family Tree 1" -a book -p name=mybook,show=all```

To run a book, for instance a book called "mybook":

```
gramps -O "Family Tree 1" -a book -p name=mybook```

Command Line - Python options
**Book names**

If the supplied book name does not correspond to any available Book, an error message will be printed followed by this list of available Books. eg: Example listing only as the Books will be whatever you have named them.

Available names are:
- Granny Jones
- Grampa John
- Smith Family History

---

**Force unlock option**

- `--u` you can extend the `-o` flag with `-u` to force a locked family to be unlocked. This allows you to recover from a crash that leaves the family tree (database) locked, from the command line.

An example (to unlock the "Family Tree 1" database):

```
gramps -O "Family Tree 1" -a report -u > /dev/null
```

---

**Note**

It is not possible to open family trees that need repair from the command line.

See also:

- [Manage Family Trees: Unlocking a Family Tree](#)

**Configuration (config) option**

When all configuration variable(s) are set Gramps will start with these new values.

These options can take three forms:

---

**Note**

Except for examples 1 and 3.2, All the following examples, use `behavior.database-path` as the configuration variable to change.

1) See all config values
   - `--s` or `--show`

   For example:
   ```
gramps --show
   Gramps config settings from /home/<~username>/gramps/gramps50/gramps.ini:
   export.proxy-order=[['privacy', 0], ['living', 0], ['person', 0], ['note', 0], ['reference', 0]]
   database.compress-backup=True
database.backend='bsddb'
database.backup-path='/home/<~username>'
database.port=''
database.autobackup=0
database.path='/home/<~username>/.gramps/grampsdb'
database.host=''
database.backup-on-exit=True
geography.lock=False
....
```

2) See a single config value
   - `--config=database.path` or `-c database.path`

   For example:
   ```
gramps --config=database.path
   Current Gramps config setting: database.path:'/home/<~username>/.gramps/grampsdb'
   ```

3) Set a value:
   - `--config=behavior.database-path: /media/mydb` or `--c behavior.database-path: '/media/mydb'`

   For example:
   ```
   3.1) Set a value to its default: --config=behavior.database-path:DEFAULT or --c behavior.database-path:DEFAULT
   3.2) Set more than one value: --config=behavior.use-tips:False --config=behavior.autoload:True or --c behavior.use-tips:False --c behavior.autoload:True
   ```

---

**Command Line - Python options**

396
behavior.autoload:True

For example:

**Safe mode**

gramps -S or gramps --safe

This CLI command starts Gramps as if it had never been installed before. In this mode, any previous family trees can still be loaded, as long as they were stored in the default folder. All other settings, filters, books, addons etc. are either cleared or returned to their default values. Other CLI commands can be used, or, if none, Gramps will start the GUI. Nothing except the actual family tree data is saved.

Note that this is typically used to see if Gramps behaves better when it is running as if with a totally 'clean' install. It is NOT permanent (if you want that see **Defaults** below), if you start Gramps normally after using this command all of your previous settings etc. are still there.

This actually works by setting the folder that Gramps uses to store its user data (except for family trees) to a temporary directory, which is deleted when Gramps closes.

**Defaults**

gramps -D E or gramps --default=E

This CLI command causes Gramps to clear out or return to defaults the desired settings. The family tree databases are NOT cleared out or removed. The sub-commands (replace the 'E' from the example command line above with one or more of the subcommand characters) are:

- A Addons are cleared. Any installed addons are removed, along with their settings.
- F Filters are cleared. Any custom filters are removed.
- P Preferences are returned to their default values.
- X Books are cleared, Reports and Tools settings are returned to their default values.
- Z Old '.zip' files from family tree version upgrades are deleted.
- E Everything except the actual family tree data is returned to default settings. This does all of the above as well as a few more items; deletes thumbnails, maps, and the user CSS (used in web reports).

For example:

gramps -D AP

will cause Gramps to remove all the Addons and to reset Preferences to their default values.

**Operation**

If the first argument on the command line does not start with a dash (i.e. no flag), Gramps will attempt to open the file with the name given by the first argument and start an interactive session, ignoring the rest of the command line arguments.

If the -O flag is given, then Gramps will try opening the supplied file name and then work with that data, as instructed by the further command line parameters.

---

**Note**

Only one file can be opened in a single invocation of Gramps. If you need to get data from multiple sources, use the importing options by using -i flag.

With or without the -O flag, there could be multiple imports, exports, and actions specified further on the command line by using -i , -e , and -a flags.

The order of -i , -e , or -a options with respect to each does not matter. The actual execution order always is: all imports (if any) -> all exports (if any) -> all actions (if any).

---

**Note**

But opening must always be first!

If no -O or -i option is given, Gramps will launch its main window and start the usual interactive session with the empty database, since there is no data to process, anyway. (Unless you have already expressed a "preference" that it start with the last database it used.)

If no -e or -a options are given, Gramps will launch its main window and start the usual interactive session with the database resulted from opening and all imports (if any). This database resides in a directory under the ~/.gramps/grampsdb/ directory.

Any errors encountered during import, export, or action, will be either dumped to stdout (if these are exceptions handled by Gramps) or to stderr (if these are not handled). Use usual shell redirections of stdout and stderr to save messages and errors in files.

**Examples**

- To import four databases (whose formats can be determined from their names) and then check the resulting database for errors, one may type:

  gramps -i file1.ged -i file2.gpkg -i ~/db3.gramps -i file4.wft -a check

---

Command Line - Operation
To explicitly specify the formats in the above example, append filenames with appropriate -f options:
```
```
To record the database resulting from all imports, supply -e flag (use -f if the filename does not allow Gramps to guess the format):
```
gramps -i file1.ged -i file2.gpkg -e ~/new-package -f gramps-pkg
```
To save any error messages of the above example into files outfile and errfile, run:
```
gramps -i file1.ged -i file2.gpkg -e ~/new-package -f gramps-pkg >outfile 2>errfile
```
To import three databases and start interactive Gramps session with the result:
```
gramps -i file1.ged -i file2.gpkg -i ~/db3.gramps
```
To open a database and, based on that data, generate timeline report in PDF format putting the output into the my_timeline.pdf file:
```
gramps -O 'Family Tree 1' -a report -p name=timeline,off=pdf,of=my_timeline.pdf
```
### Listing report options

Use the `name=timeline,show=all` to find out about all available options for the timeline report. To find out details of a particular option, use `show=option_name`, e.g. `name=timeline,show=off` string. To learn about available report names, use `name=show` string.

To convert the bsddb database on the fly to a .gramps xml file:
```
gramps -O 'Family Tree 1' -e output.gramps -f gramps-xml
```
To generate a web site into another locale (in German):
```
LANGUAGE=de_DE; LANG=de_DE.UTF-8 gramps -O 'Family Tree 1' -a report -p name=navwebpage,target=/../de
```
Finally, to start normal interactive session type:
```
gramps
```

### Environment variables

**Warning**

Gramps can take advantage of the following environment variables

(Only change them if you know what are you doing.)

**GRAMPSHOME**

- if set, override default path to profile allowing user to use an external network drive to store data and all settings. For technically advanced users who run multiple versions of Gramps, setting a different GRAMPSHOME is a way to avoid interference between the different versions in the Gramps User Directory. It can also be used to configure Gramps to run from a portable drive or to prepare for a manual installation. The path can also be used to configure the path to a separate test Tree or development Tree.

For example
```
GRAMPSHOME=$HOME/familytrees/paternal
```

### LANG, LANGUAGE, LC_MESSAGE, LC_TIME

- LANG, LANGUAGE, LC_MESSAGES, and LC_TIME - are used by Gramps to determine which language file(s) should be loaded. See `locale()` for a general discussion of LANG, LC_MESSAGES, and LC_TIME. Note that in addition to setting date formats (which are overridden in Gramps with Preferences settings) LC_TIME also sets the language used for words in dates like month and day names and in the context of dates words like about, between, and before. LANGUAGE is a comma-separated list of language codes (not locales, though certain languages like pt, BR or en TW are regional variants) that sets a preference-ordered list of desired translations. It will override LANG but not LC_MESSAGES or LC_TIME.

**MacOSX**

Because of the way launching with Finder works, the environment variables for the Gramps.app bundle are hard-coded in Gramps.app/Contents/Resources/gramps_launcher.py. If for some reason you need to change them, edit the file with TextEdit; be sure to save it back as plain text. See as well setting locale for an alternative to using the LANG and LANGUAGE environment variables.
GRAMPSI18N

- **SGRAMPSI18N (for your locale)** - The LANG assumes the Gramps translations are installed globally. If this is not the case, you need to [give Gramps the directory](#) where the translations will be found. This can be used to temporarily [change the language for Reports](#) being generated.

A translation is called `gramps.mo`, you can find it in Linux with the locate command. For example, if you have Swedish in directory `/home/me/gramps/mo/sv/gramps.mo`, you can direct Gramps there using:

```
GRAMPSI18N=/home/me/gramps/mo LC_ALL=C.UTF-8 LANG="sv" python3 gramps
```

**GRAMPSDIR**

- The environment variable GRAMPSDIR is the path to your Gramps directory.

**GRAMPS_RESOURCES**

- The environment variable GRAMPS_RESOURCES is the path to Gramps built-in resources files. You should only change this if you are using Gramps from source code or a custom environment. An indicator that you need to set this variable is if you receive one of the following errors:
  - `Encoding error while parsing resource path`
  - `Failed to open resource file`
  - `Resource Path {invalid/path/to/resources} is invalid`
  - `Unable to determine resource path`

Example usage:

```
GRAMPS_RESOURCES=/home/username/gramps/branches/maintenance/gramps51/build/lib.linux-x86_64-2.7/ PYTHONPATH=$GRAMPS_RESOURCES:$PYTHONPATH ./gramps
```
This appendix provides the reference for finding the location of the **Gramps User Directory**. The folder/directory is stored at different locations due to the requirements of Gramps forks for various operating systems or special purposes.

The location of your Gramps user directory can depend on the operating system you are using and how you have logged into your computer.

Where `<username>` is shown below it should be replaced by the name you use to log in to your computer.

### POSIX - style systems

The default user directory location for Gramps in a POSIX-style environment is:

```
/HOME/<username>/.gramps
```

which can also be entered as

```
<username>/.gramps
```

This is true for BSD, Linux, Solaris, Unix and Mac OS-X when using Mac OS X Build from source.

Alternatively, you can leverage the `HOME` Home directory equivalent to avoid dealing the complications of active user names. Although Gramps will not recognize directory equivalents for paths internally, you can use them within Linux to find Gramps user files. The Gramps user directory path above is simplified to either:

```
$HOME/.gramps
```

or

```
~/.gramps
```

Or if using MS Windows the following syntax is used

```
$HOME\.gramps
```

or

```
~\.gramps
```

### MacOS

On Apple Macs filenames starting with "." do not show up in Finder. To simplify access to the Gramps user directory, open a terminal window using the Terminal application and type:

```
ln -s ~/.gramps ~/Documents/Gramps
```

which will make Finder show the directory as a folder in your Documents folder named "Gramps". (You can replace "Gramps" with whatever name you wish, but use a / before any spaces.) Alternatively you can simply click on Go -> 'Go to Folder...' in the Finder, and type

```
~/.gramps
```

in the resulting macOS Go to the Folder dialog box.

### MacOS Application Package

The Mac OS X: Application package uses a different, more MacOS-standard default location for the directory:

```
/Users/<username>/Library/Application Support/gramps
```

### MS Windows
On Microsoft Windows, filenames and folder for programs and userdata are hidden in the File Explorer. To make access to the Gramps user directory easy follow the following advice from Microsoft:

- **Show hidden files - Windows Help**

The default **User Directory** location for any Gramps user data on a Windows 7 (and newer) system is

C:\Users\<~username>\AppData\Roaming\gramps

The `<~username>` in the above filepath is a placeholder for the particular user name chosen when logging into Windows.

Alternately, you can leverage the `%AppData%` environment variable to avoid dealing the complications of active user names. Although Gramps will not recognize Environment Variables for paths internally, you can use them within Windows to find Gramps user files. The **Gramps user directory** path above is simplified to:

`%AppData%\gramps`

Like the **User Directory**, the location for programs/applications is also hidden from browsing with Windows Explorer.

The default location for an installation on a Windows 7 (and newer) system is

C:\Program Files\GrampsAIO64-5.X.X

or

C:\Program Files (x86)\GrampsAIO32-5.X.X

See Also

- **Command Line** Configuration (config) option with Environment Variables
- Switching from Breadcrumbs to a location text box using `Ctrl+L` in GTK file dialogs
- Discourse forum thread: [how to use Environment Variables in Gramps](https://discourse.gramps.org/t/how-to-use-environment-variables-in-gramps/401)
This section explains what to do when something unexpected happens.

**When something goes wrong**

Sometimes something goes wrong, either because you have asked to do something that Gramps doesn't know how to do, or because something has happened that the developers of Gramps did not anticipate, or because there is a mistake in the coding of Gramps.

<table>
<thead>
<tr>
<th>Warning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sometimes all the errors do not appear on the screen. If something unexpected happens, you may need to see all the error messages.</td>
</tr>
</tbody>
</table>

**Alerts**

An alert is a dialog that appears when Gramps needs to give you an important message about an error condition or warn you about potentially hazardous situations or consequences.

Most alerts are self-explanatory, and the same type of alerts that you might get with any application. These are not discussed further here.

However, some alerts require more complicated actions, so they are described below.

**Are you sure you want to upgrade this Family Tree?**

![Fig. E.1 "Are you sure you want to upgrade this Family Tree?" dialog - Db Upgrade Required - example](image1)

![Fig. E.2 "Are you sure you want to upgrade this Family Tree?" dialog - Bsdv Upgrade Required Error - example](image2)

![Fig. E.3 "Are you sure you want to downgrade this Family Tree?" dialog - Bsdv Downgrade Required Error - example](image3)
These dialogs appear for the listed reasons:

- "Db Upgrade Required" - If you try to open a Db(Sqlite3) Family Tree created with a previous older version of Gramps with a newer version of Gramps.
- "Bsdwb Upgrade Required Error" - If you try to open a Bsdwb Family Tree created with a previous older version of Gramps with a newer version of Gramps.
- "Bsdwb Downgrade Required Error" - If you try to open a Bsdwb Family Tree created with a previous older version of Bsdwb with a newer version of Bsdwb.
- "Python Upgrade Required Error" - If you try to open a Bsdwb Family Tree created with a previous older version of Gramps using Python 2 with a newer version of Gramps that uses Python 3.

For each of these reasons you may follow the same general advice; if you still have the older version of Gramps available, then you should:

- Cancel this dialogue, and exit Gramps
- Open the Family Tree with the previous version of Gramps (Reinstall the old version of Gramps),
- Export your family tree in Gramps XML (family tree) export format or Gramps XML Package (family tree and media) format,
- Exit the old version of Gramps and Start the new version of Gramps,
- Open the Family Tree in the new version of Gramps and click I have made a backup, please upgrade my Family Tree in this dialogue

**Error parsing arguments**

The Family Tree database is locked while in use by another user or because Gramps exited abnormally during previous use.

See [Unlocking a Family Tree](#)

**Database is locked. cannot open it!**

The Family Tree database is locked while in use by another user or because Gramps exited abnormally during previous use.

See [Unlocking a Family Tree](#)

**Cannot open database**
As explained in the dialogue, the Family Tree was probably created with an old version of the Berkeley database program. This is not quite the same thing as an old version of the Gramps program, because the version of the Gramps program and the version of the Berkeley database are independent. However, the effect is somewhat the same. As suggested in the dialogue, if you have the old version of Gramps and its support software, then you should:

- cancel this dialogue,
- open the Family Tree with the previous version of Gramps,
- export your family tree in Gramps XML database export format or Gramps package export format (see Export into Gramps formats),
- start the new version of Gramps,
- open the 'Manage Family Tree' dialogue,
- click on 'new' and create a new Family Tree,
- load the new Family Tree
- Import the Gramps XML or Gramps package.

Alternatively, it may be possible to use the recovery tools. See 'obtain the bsddb recovery tools' under Recover corrupted family tree

**Low level database corruption detected**

This dialogue appears when a problem is detected with the underlying database that supports Family Trees.

- close the dialogue,
- click on the Family Tree Manager,
- select the Family Tree you were trying to open,
- the 'REPAIR' button should be available; click on it,
- once the Family Tree has been repaired it should be possible to open it in the normal way.

If this does not work, try 'obtain the bsddb recovery tools' under Recover corrupted family tree

**Error detected in database**
Carry out suggested action.

**Warnings**

If Gramps detects a minor error, or wishes to notify you about an occurrence within the program, then Gramps may display a [Warning] button on the status bar, as shown below. This button is only displayed for 180 seconds, so if you see it you should immediately click on it if you want to see the messages.

If you click the [Warning] button, then a [Gramps Warnings] dialog box appears showing the last 20 messages received. [More details]
Some of the warnings that may appear are described below:

**Locale warnings**

Sometimes there is a problem with the language you have chosen.

If you have installed Gramps using your platform's standard installation method (Package manager/AIO installer/Application package) and are using your platform's built-in mechanism (System Setting/Control Panel/System Preferences) to choose the language/sort order/formats you are running in, then these errors should not occur, and may mean there is a problem in Gramps.

However, if you have set the language/sort order/formats manually by setting the 'environment' see [languages](#), particularly if you are running Gramps from the command line, then there may be a problem with what you have typed in. The message (only part of which is shown below) should help you to understand where the error is.

- "Date parser for %s not available, using default"
- "Date displayer for %s not available, using default"
- "Family relationship translator not available for language %s. Using 'english' instead."
- "Unable to determine your Locale, using English"
- "Localization library libintl not on %PATH%, localization will be incomplete"
- "No translations for %s were found, setting localization to U.S. English"
- "Unable to create collator: %s"
- "No language provided, using US English"
- "No usable languages found in list, using US English"
- "None of the requested languages (%s) were available, using %s instead"

**Module not loaded warnings**

The Gramps application contains many different 'modules'. Some of these modules are required for Gramps to run at all; some are 'strongly recommend', and some are optional.

If you have installed Gramps using your platform's standard installation method (Package manager/AIO installer/Application package) then the builder of that package will have decided which modules are present. He must include all the required modules, because otherwise Gramps will not run, but he can choose which of the recommended and optional packages he includes. Consult the documentation for your package to determine which modules are included.

If you try to do something that needs a module that is not included, then you will get a warning like the ones below (only the first part of the message is included). What you can do about it depends on your platform:

**Linux** You should be able to install the package using your distribution's standard Package Manager or the GUI interface to the Package Manager. However, in some cases you will need to build the module from source.

**MS Windows and Mac OS X** The MS Windows AIO installer and the Max OS X Application bundle come with certain modules built in. It is not possible for the normal user to add further modules. Therefore, if you find a module that you particularly feel should be included you should post on the Gramps [mailing list](#) (probably the devel list) explaining why you feel its omission is a mistake.

- "WARNING: PIL module not loaded."
- "ICU not loaded because %s. Localization will be impaired."
- "OsmGpsMap module not loaded."
- "GExiv2 module not loaded."
- "Webkit module not loaded."

---

Error and Warning Reference - Warnings
This article's content is incomplete or a placeholder stub. Please update or expand this section.

**Show plugin status dialog on plugin load error.**

Can be disabled from `show plugin status dialog on plugin load error` option in the **Preferences > Warnings** dialog.

This article's content is incomplete or a placeholder stub. Please update or expand this section.

### Configuration warnings

This article's content is incomplete or a placeholder stub. Please update or expand this section.

Sometimes it is worth just deleting the old configuration files.

- "Importing old key file 'keys.ini'..."
- "Done importing old key file 'keys.ini'"
- "Can't find filter %s in the defined custom filters"
- "Number of arguments does not match number of " + 
- "Value '%(val)s' not found for option '%(opt)s'"
- "Unable to open recent file %s because %s",
- "WARNING: ignoring old key %s"
- "WARNING: ignoring key with wrong type "
- "Failed to parse doc options"
- "Skipped a line in the addon listing: "
- "Failed to load gramplets from %s because %s"

### Other warnings

This article's content is incomplete or a placeholder stub. Please update or expand this section.

### Cannot save person

![Cannot save person - Gramps](image)

**Fig. E.12 Cannot save person (Warning window)**

Attempting to save a person without any data from the Person editor displays this warning popup. You need at least one letter for the first name.

**Cannot save person**

No data exist for this person. Please enter data or cancel the edit.

Close

This article's content is incomplete or a placeholder stub. Please update or expand this section.
Attempting to merge anything other than two(2) of one type of record displays this warning popup dialog.

For example:

**Cannot merge people**

Exactly two people must be selected to perform a merge. A second person can be selected by holding down the control key while clicking on the desired person.

Close

---

**Duplicate Family warning dialog**

If you create a new family and select parents that are already in an existing family, Gramps will issue the duplicate family warning message. If you proceed by saving the new family, you will have a duplicate family.

---

**Suppress warning when adding parents to a child**

Can be enabled from Suppress warning when adding parents to a child option in the Preferences > Warnings dialog.

---

**Adding parents to a person dialog**
This article's content is incomplete or a placeholder stub. Please update or expand this section.

Suppress warning when cancelling with changed data

Can be disabled from Suppress warning when cancelling with changed data, option in the Preferences > Warnings dialog. Used by the Edit Person dialog.

Save Changes? dialog

Suppress warning about missing researcher when exporting to GEDCOM

Can be disabled from Suppress warning about missing researcher when exporting to GEDCOM, option in the Preferences > Warnings dialog.
**Undo history warning**

The *Undo history warning* dialog will be shown and you can either [Stop] or [Proceed with the tool/import]. It is recommended that you stop and backup your database; so that you can revert the process of running the tool (or import) if required.

![Undo history warning dialog](image)

**Errors**

More serious problems cause an *Error Report* dialog to be shown which will describe the actions you should take.

**Error Report**

The *Error Report* dialogue appears whenever something has happened in the Gramps application that the programmers did not expect. Have a read of the *How to create a good bug report* article. If you believe you know how the Gramps developers might reproduce the bug or not, then select the [Report] button to start the *Error Reporting Assistant* dialog, and you can then follow the instructions.

![Error Report Assistant dialog](image)
Error Reporting Assistant dialog

Allows you an opportunity to compile a report about an error and then submit it manually to the Gramps bug reporting system (This requires you to have a registered account on the Gramps bug reporting system)

- Using the bug tracker

The Error Reporting Assistant is also known as the Bug Reporting Assistant.

Report a bug page

This is the Bug Reporting Assistant. It helps to make a bug report to the Gramps developers that will be as detailed as possible.

The assistant asks a few questions and gathers some information about the error that just occurred and the operating environment.

At the end of the assistant process, you will be asked to file a bug report through the Gramps bug tracking system.

The assistant will copy the bug report to the Operating System clipboard. This allows you to paste it into the form on the Gramps bug tracking and review exactly what information you want to include.

Error Details page
If you can see that there is any personal information included in the error please remove it.

This is the detailed Gramps error information, don't worry if you do not understand it. You will have the opportunity to add further detail about the error in the following pages of the assistant.

System Information page

This is the information about your system that will help the developers to fix the bug.

Further Information page
Please provide as much information as you can about what you were doing when the error occurred.

This is your opportunity to describe what you were doing when the error occurred.

Bug Report Summary page

This is the completed bug report. The next page of the assistant will help you to file a bug on the Gramps bug tracking system website.

Send Bug Report page
Use the two buttons below to first copy the bug report to the clipboard and then open a web browser to file a bug report at https://gramps-project.org/bugs/login_select_proj_page.php?ref=bug_report_page.php

- **Send Bug Report** - This is the final step. Use the buttons on this page to start a web browser and file a bug report on the Gramps bug tracking system (This assumes you already have an user account on the bug tracker, if not signup for one first.)
  - **File bug report** - Use this button to start a web browser and file a bug report on the Gramps bug tracking system.
  - **Copy to clipboard** - Use this button to copy the bug report onto the clipboard. Then go to the bug tracking website by using the button below, paste the report and click submit report

Gramps is an Open Source project. Its success depends on its users. User feedback is important. Thank you for taking the time to submit a bug report.

**Other Errors**

Report could not be created

File: Xxxx.png
Fig. E.29 Report could not be created dialog

The **Report could not be created** dialog can occur for various reasons, eg: one reason is that the custom paper size you have chosen for the report is too large for PDF format that is being used.
PDF size limits

Each Adobe PDF Version format specification has a maximum page size limit, for:

- PDF Version 1.4 (Acrobat 5.0) and PDF Version 1.5 (Acrobat 6.0) the maximum PDF page size is 200” x 200” inches (508cm x 508cm)
- PDF Version 1.6 (Acrobat 7.0) and newer the theoretical PDF page size is 15,000,000” x 15,000,000” inches (38,100,000cm x 38,100,000cm) but in reality most programs do not properly support any sizes above 200” x 200” inches (508cm x 508cm).

See PDF From Wikipedia.

Seeing all the error messages

Sometimes, not all the information needed to understand what has gone wrong will appear on the screen. For example, if you start Gramps with an invalid language setting (and some missing components) then the message that appears in the **Warnings** dialog is:

![Fig. E.30 Dialogue showing limited warnings](image)

However, the full set of warning messages is:

(process:10929): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
2013-03-13 18:49:04.376: WARNING: __init___.py: line 69: Date parser for 'xx_XX.UTF-8' not available, using default
2013-03-13 18:49:04.547: WARNING: __init___.py: line 85: Date displayer for 'xx_XX.UTF-8' not available, using default
2013-03-13 18:49:05.949: WARNING: spell.py: line 74: Spelling checker is not installed

Sometimes Gramps just doesn't start and nothing appears on the screen, or Gramps suddenly quits so you don't see anything on the screen. In all these cases you may need to do something special to see all the errors.

Linux

You can start Gramps from the Command Line, as described in the note here. You will then see all the diagnostic information on the terminal.

MS Windows

You can start Gramps from the Command Line, as described in the note here. You will then see all the diagnostic information on the terminal.

Mac OS X

Starting Gramps through the CLI on Mac OS X is covered here.

Console application

You can also look at log messages from Gramps using Apple's **Console application**. The Console application is located in your Mac's Utilities folder, which is found in the Applications folder. (A shortcut on recent versions of Mac OS X is to press Command and the space bar to start a Spotlight search. In the resulting pop up window, enter the first few characters of the word "Console" and then select the Console application.)

For example, one of the early alpha releases of Gramps just would not start and displayed nothing on the screen. However by opening the Console application, and typing Gramps in the filter at the top right hand corner some diagnostic information appeared. (Actually we typed "gramps[" because there were some other messages that were not relevant, but it wouldn't matter if they were included as well).

![Fig. E.31 Console output](image)
By shift clicking to select all the relevant messages and copying them we get:

01/03/2013 00:08:02 [0x0-0x88088].org.gramps-project.gramps[1867] 2939: ERROR: importer.py: line 51: Could not find any typ
01/03/2013 00:08:05 [0x0-0x88088].org.gramps-project.gramps[1867] Gtk typelib not installed. Install Gnome Introspection,
01/03/2013 00:08:05 [0x0-0x88088].org.gramps-project.gramps[1867] Gramps will terminate now.

In this particular case, this was enough to help the developer discover the problem.
About

To find more information about Gramps, please visit the Gramps Project Web page:

- [https://gramps-project.org](https://gramps-project.org)

Original author

Gramps was written by Donald N. Allingham ([email protected]).

Contributors

The somewhat incomplete list of contributors includes (in first name alphabetical order):

- Alexander Bogdashevsky
- Alexander Roitman
- Alexandre Duret-Lutz
- Alexandre Prokoudine
- Anton Huber
- Arkadiusz Lipiec
- Arpad Horvath
- Artaras Steinius
- Baruch Even
- Benny Malengier
- Bernd Felsche
- Bernd Schandl
- Billy C. Earney
- Brian Matherly
- Bruce J. DeGrasse
- Daniel Durand

Fig F.1 About Gramps notice dialog
If you know of somebody else who should be listed here, please let us know.

**Have an issue or idea?**

To report a bug or make a suggestion regarding this application or this manual, use the Help > Report a Bug menu in Gramps, or follow the directions on this site.

**License**

This program is distributed under the terms of the GNU General Public license as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. A copy of this license can be found at this link, or in the file COPYING included with the source code of this program.
Gramps Glossary

This glossary gives an overview of terms that appear in Gramps, with a short description, and a link to relevant articles. (Since knowing a feature's name is necessary for finding the corresponding glossary term, also refer to the Visual Guide to the Gramps Interface.)

For a glossary of genealogical terms, see Genealogy Glossary and Latin words and expressions.

A

Active Person

(aka add-on)

The person designated (or 'selected') as the momentary center of focus in the open Gramps database. The perspective of this person defines the context for actions and for displaying all the surrounding information. Changing this focus is done by navigating the Active Person selection to another person.

The Active Person's relationship to the Home Person defines the scope of the perspective. N.B.: There is always an Active Person selection, even when the primary object (aka record) selected in the current view is not a 'Person' object.

address

(aka add-on)

an optional third-party expansion to Gramps that leverages Gramps plugin customization framework to add a specific feature. Addons may not conform to design or code quality standards. Use at your own risk!

Optional parts built into the core project (but which can be enabling or disabled leveraging this framework) are called by the more generic name: plugins.

administrative division

a unit of a layered system subdividing a geopolitical (geographic or political) region. Such divisions are recorded as Place Types in Gramps.

Meanwhile the structure of a Place Tree is built by layering via the Enclosed by tab in the Place Editor. The subdivisions are sometimes categorized as an entity, locality, area, or region. The terms of subnational entity, constituent unit, or country subdivision tend to imply divisions that are more related to political representation than administrative.

See wikipedia's Administrative division for a conceptional definition or List of administrative divisions by country for specific countries.

Aide

(event role)

A term to refer to the role of an assistant.

anglicisation

process of making something English. If an immigrant (or their descendant) adopts a naturalized variation of their birth name, that preferred alias can be added with an Also Known As name type in the Names tab. All aliases can be categorized by type and surname variants may be grouped with the in the Name Editor.

Association

(aka add-on)

The roles in Associations are to explicitly define the how one person relates to another.

Association roles are used when the relationship falls outside the implicit roles of a family relationship or the explicit roles in shared events. These custom roles convey relationships that might not readily apparent... such as a penpal or the eponymous person honored by a namesake. Association roles may also be used as placeholder when the actual genetic connection has not yet been discovered.

Association roles are created and edited with the Person Reference Editor, which includes no pre-defined roles. This feature starts with a blank list of custom types and the default "Godfather" role is only shown as a hint.

attribute

(aka add-on)

Attributes are for something permanent, or at least somewhat permanent: eye color, blood type, etc. Usually you would have not more than one of each attribute type for a Person/Family/etc. Attributes are managed from an Attributes tab in each primary Object Editor. There are no built-in Attributes, only custom types.

B

Books Report

A Reports menu feature of Gramps that allows the design or generation of a repeatable custom genealogy Book. A Book consists of an ordered collation of Gramps textual and graphical reports in a single document. The individual report configuration options are also stored with the Book but the Book's document pagesize and print destination configuration options override.
Bride  
**event role**  A term to refer to the woman a marriage ceremony who will have the role of **wife** in the marriage. See also: **mother**.

BSDDB  
**database backend engine**  The **Berkeley Software Distribution database** (also known as BSDDB) was the first default database engine used by the 2.0 through the 5.0 versions of Gramps. Originally, Gramps **XML** was used directly rather than as a Backup and data exchange format. The default db engine changed to **SQLite** in the 5.1 version via the DB-API Database Backend. (Manual updates to the BSDDB engine for the 5.1.3 version may be advisable.)

C  
**Category**  
**core concept**  Gramps divides and organizes the information about each **Primary Object** into a series of different descriptive schemas called Categories, each with their own **View**. Each Category is a smaller, more digestible portion of the total information that comprises a Genealogical Tree. The View categories are: **Dashboard**, **People**, **Relationships**, **Families**, **Charts**, **Events**, **Places**, **Geography**, **Sources**, **Citations**, **Repositories**, **Media**, **Notes**

Celebrant  
**event role**  A term describing a role of the person who performs a rite, especially referring to a priest at the Eucharist.

Citation  
**prim, obj** - Contains the information that enables you or others to locate your source document. An isolated **Citation can be created** without first creating separate **Source** object. But, should the same source be referenced repeatedly in a Tree, a separate Source simplifies the Citation and eliminates redundant information that must be harmonized.

Clergy  
**event role**  A term applied to a religious person regardless of religion. For example, a monk or priest. See also: **celebrant**.  
Religious terminology is often subject to dispute, see the **Merriam-Webster** for an independent definition.

Clipboard  
**graphical user interface terminology** - The **Gramps Clipboard** is a shortcut system for **sharing** a **secondary** object, navigation, and custom **filter** creation.  
**Usage:** The Clipboard can be opened from a icon on the **Toolbar**, the Clipboard choice in the Edit menu or a **keybinding**. A floating clipboard dialog that has become buried can be brought to the top of the stack by selecting **Clipboard...** from the Windows menu.  
The Clipboard can greatly improve data entry efficiency, see the **How to use the Gramps Clipboard** article for more information.

custom types  
This indicates a user-defined classification, as opposed to classifications that came pre-defined in Gramps. (i.e.: 'Birth' and 'Marriage' are 2 of the pre-defined 'types' of Events.)  
When none of the pre-defined Types are suitable, add a new **custom** Type by typewriting directly into the selector combo box. If the value doesn't precisely match any of the existing menu items, a new custom Type will be created when the **OK** button is clicked.  
Any added custom Type will remain available in that expanded menu... unless the Tree is exported & re-imported or removed via a **3rd party addon** Utility like **Type Cleanup**.

custom Types can be defined for: Event Attributes, Family Attributes, media Attributes, Person Attributes, Event Roles, Event types, Family Relation types, Child Reference Types, Name Origin Types, Names Types, Note Types, Place Types, Repository Types, Source Attributes, source Media Types, URL Types.

D  
**date**  
**sec, obj** - Dates in Gramps are much more complex than just a month, day, and year. Dates are always in a particular **calendar**, can span a time frame, the **Date Quality** can be approximate, and have support for many other subtleties specific to genealogy data.

DNA  
1. acronym: **deoxyribonucleic acid**  
2. a **nucleic acid** that carries genetic information.

DTD  
**acronym:** Document **Type Definition**. A document that defines the tagging structure which identifies the individual components of an **SGML** or **XML** document.  
See the **reference documentation for the versions** of Gramps **RELAX NG (RE)gular LAnguage for XML Next Generation)**, **rng** schema **XML** and **DTD**

E  
**Event**  
**prim, obj** - Contains the information related to an happening. **Adding an Event record** provides the context of an interaction of the roles of People/Families, dates & places in activities.  
An Event is a defining moment in a person's life. See **events** for the use in genealogy, for predefined events in Gramps and suggested naming for **common events**.
event role
The role a Person plays in an Event. In Gramps, an Event can be linked to as many participants as desired. Each Person may participate in different roles but more than one Person might play the same role. The Event Role captures this. Some common Roles are pre-defined but the user can add other custom Roles by just typing in an appropriate new Role Type in the Event Reference Editor.

Pre-defined Types of Event Role: Aid, Bride, Celebrant, Clergy, Family, Groom, Informant, Primary, Witness, Unknown, custom

event type
The general denominator to which an event belongs, e.g., a christian, civil, tibetan, ... marriage, are all denoted by the event type marriage. See events in Gramps for an overview.

F

Fallback events
Certain event types are definitive bookends marking the beginning or end of a life (Birth/Death) or relationship (Marriage/Divorce). Those bookend events are key factors in any kind of timeline analysis.

If the definitive event types are missing, Gramps will look for similar event types to calculate a 'fallback' approximation. When dates are shown in italics, it indicates that the preferred bookend event was not found and one of the pre-defined Fallback events had to be used.

Family

1. Family (prim.obj) - Contains the information specific to relationships between people. The information may be edited directly using the Edit Family dialog.

   This traditionally contains one or two parents and zero or more children. A family unit is created in Gramps by adding Parents to an individual, by adding a partner/spouse to an individual, or by adding a family first then adding the people.

   The Family relationship is a core concept in Gramps. It depicts the basic relations between people. Commonly this will contain a father, a mother and some children, however, it can also contain only parts of this (e.g., two brothers, a mother and child). People can be part of several families (adoption, remarried, ...)

2. Family (event role) An event can be coupled to a family, denoting that both partners were equally involved in the event. Typically, the Marriage event will be coupled to a family with event role family. Family is the default role when adding a new Event in the Edit Family dialog.

File formats

File formats repackgage the Tree database information for archiving, data exchange with other software or display.

Import formats: GRAMPS v2.x database (obsolete), .gedb, Comma Separated Values .csv, GEDCOM (Genealogical Data Communication) .ged, GeneWeb .gw, Pro-Gen .def, vCard (virtual contact card) .vcf, JSON (JavaScript Object Notation) .json, SQLite .sql

Export formats: Gramps native XML format (compressed & uncompressed variants) .gramps, Gramps Package (Gramps XML plus media) .gpkg, GEDCOM (Genealogical Data Communication) .ged, GeneWeb .gw, Web Family Tree (a GEDCOM variant) .ged, vCalendar .ics, vCard (virtual contact card) .vcf


Filter

A filter in a database finds (or hides by 'filtering out') records, displaying only those records that match certain criteria. The criteria are comparison rules describing some attribute of a record.) Layers of criteria can be applied but each layer requires additional processing and slows performance of the interface.

The basic Search is a single criteria filter. The search value is compares only one attribute of a record that has been selected from a pop-up menu.

The Filter Gramplets will compare several predefined common attributes simultaneously with simplified access to changing the search value.

The default is for exact matching but Regular Expressions (RegEx) can be used for pattern matching. A Custom Filter may be also layered in. A Custom Filter adds richly complex Rules-based comparison with layers of intersection options for those rules. Custom Filters allow repeatable filters to be created with pre-defined rules and values to be matched. Beyond interactively hiding (or revealing) records in views, Custom Filters are used to set limits for exporting, setting scopes for reports, and targeting tool actions.

In addition to the built-in rules for filtering, addon rules are available for Custom Filters.

G

GEDCOM

1. acronym: Genealogy Data Communication

2. a format for importing and exporting genealogical data. The open specification for the GEDCOM format was developed by The Church of Jesus Christ of Latter-day Saints (LDS Church) as an aid to genealogical research. The long standing standard release was version 5.5.5 proposed in 2019. (Belatedly, the 'draft' label was officially removed in the annotated 2019 release. After 20 years as the de facto standard format, it remained unimproved excepting for 2 tags and the copyright.) As an Open Standard, there are extensive and constantly changing incompatibilities between implementations and data loss when transferring GEDCOM formatted data between competing software tools is common.

GEDCOM X proposed in 2012 and 5.5.5 proposed in 2019 are improvements that have not gained the approval of the copyright holder. As of June 2021, these proposals have been superseded by the GEDCOM 7.0.1 version.
Gramps is an open-source genealogy program, a free software project and community. The GRAMPS in all capital letters and the "Genealogical Research and Analysis Management Programming System" backronym were both invented around 2001 by Don Allingham's father but were phased out around March 2010 in favor of Gramps as the official name of the software. All upper-case acronym-based names have become unfashionable for software.

**Gramplet**
a Gramplet is a plug-in (aka widget) that can be docked in the sidebar or bottombar of a standard view to extend the functionality of that view. Gramplets dynamically update as the different records are selected in the main display area of a view. Gramplets typically create an alternate interface to your Family Tree data. Collections of built-in and 3rd party addon grammels are available for installation and download with the Plugin-Manager. The Plugin-Manager also regulates a wide variety of other built-in and add-ons which can expand functionality unrelated to the interface.

See the [Gramplets for Python Developers](https://www.gramps-project.org/developer/gramplets.html) for independent development information.

**Graphical User Interface (GUI)**
a visual way of indicating interactive features of a computer operating system or application/program. Gramps uses a "windows, icons, menus, pointer" (WIMP) based GUI with post-WIMP elements like hyperlinked redirection and custom interface objects. The appearance and interaction may vary by conventions dictated by the Operating System (OS), installation option (such as language localization support or addon/plug-in), theme (at the OS or internal levels), and/or user preferences customization.

The specific interface elements are identified by customary name, general appearance & behavior in the Visual Guide to Gramps. Expansion interface elements are described in the user documentation for each specific addon.

**Groom**
(event role) A term to refer to the man at a marriage who will be referred to as husband after the marriage. See also: father.

**GUI**
An acronym. see [Graphical User Interface](https://www.gramps-project.org/developer/gui.html)

**H**

**Home Person**
(core concept) - The persistently designated Home Person is the foundational Person in the Tree (the currently open Gramps database). This Person is the central target of genealogical research and references extend from this center. Ideally, every person, event and source in the Tree will (however directly or indirectly) relate back to the Home Person.

By default, the database reports describe everything else in contextual relation to this person. The Status Bar, the Quick View, called "Relation to Home Person", and the Third party addon Gramplet called "Deep Connections" all describe different aspects of the relationship of the Active Person to the Home Person.

You (or your client) are customarily designated (set) as the Home Person. And this Home designation serves as a persistent point of reference for the rest of the the Tree in Reports generally and for the Active Person in detail. But a different Home Person might be temporarily set when generating reports or when researching a complex biography or obituary.

Fascinating tidbits often lure Gramps researchers into wandering off-course. When the Active Person has become lost, the bearings can be instantly regained by navigating the Active Person selection back to the Home Person.

Navigate to Home Person - keyboard shortcut [Alt+Home] or press the toolbar button.

The custom filter rule for finding the Home Person is in a People category filter under the General filters and was named 'Default person' until the 5.1 version.

**I**

**Informant**
(event role) A term to refer to the Role of Person who reports an Event.

**J**

**K**

**L**

**M**

matronym
(origin Name attrib.) - personal name based on the name of one's mother

**Media**
(prin. obj.) - Contains the information related to a media object. Media objects include images, videos, audio recordings, documents, webpages or any other type of related files.

When new Media objects are edited from the Gallery tabs of Object Editors or from the Media category view, the New Media editor allows the metadata to be modified.

**Mode**
see View mode

**N**

Gramps Glossary - H
Name Origin
An optional attribute (characteristic) identifying how a name was derived for a Person. Pre-defined items of the origin selection menu include: inherited, patrilineal, matrilineal, given, taken, patronymic, matronymic, feudal, pseudonym, occupation. The Name Origin of Multiple surnames and Alternative names can be added from the Edit Person dialog.

Available as a standard attribute of Names in Gramps

Note
(prim. obj) - Contains the information representing a textual brief record of facts and how it references other objects in the Tree. Notes can be added to any object at any level of the Tree and are often used to detail the context of that record in the Tree. Records in the Note Category contain free-form text with basic formatting and linking features. Notes can be categorized by Tag and Type in addition to the object to which it is attached. That information is created and modified using the Notes Editor.

O

Object Editor (aka Edit Object dialogs)
(core concept) The object editor dialogs show the basic info of the Primary Object in the structured form of the header area where it can be directly edited. And the bottom tabbed section allows the editing of interrelationships with secondary objects and provides access to the Object Editors for those secondary objects.

Click the following links for instructions of how to open and use each type of Edit Object dialog.

The available categories of object editor dialogs are: Edit Person, Edit Family, Edit Event, Edit Place, Edit Source, Edit Citation, Edit Repository, Edit Media, Edit Note

The available categories of object reference editor dialogs for shared objects are: Person Reference Editor (see Associations), Child Reference Editor, Event Reference Editor, Place Reference Editor, Repository Reference Editor, Media Reference Editor

Officiator
(event role) A term to refer to the role of a person authorized to conduct an official duty or function. (Such as performing a marriage or funeral ceremony or conferring a vocational degree.) Jurisdiction may be derived from a from holding a position of civil or religious authority. Use 'OFFICILATOR' rather than 'Officiant' for GEDCOM Roles compatibility.

P

patronym
(origin Name attrib.) - personal name based on the name of one's father.

Person
(prim. obj) - Contains the information specific to an individual person in the People category. The information may be edited directly using the Edit Person dialog.

Place
(prim. obj) - The Gramps concept of a Place is a particular location independent of time. Over time, the same Place may have different address information due to changing borders and political situation. For example, Leningrad and St. Petersburg represent the same place, but with different names. Places in Gramps are stored in a hierarchy and are direct accessed via the Places category view. A Place consists of:

- Descriptive Title
- Name
- Type (administrative divisions such as country, state, county ...)
- Longitude/Latitude
- Code (such as a country code or postal code)
- A list of alternative names for the place
- A list of regions which enclose the place

plugin
(aka plug-in)

- a type of expansion framework that allows Gramps customization by providing interface hooks to recognize and use external code.
- customized module of code built to provide a specific feature or functionality that is not part of the core program.

The various types of Gramps plugin code modules can be enabled or disabled via a plugin manager. Plugin types include: Database, Exporter, Gramplet, Gramps View (Category or mode), Importer, Map Service, Plugin lib, Quickreport/Quickview, Report, Rule, Tool

Plugins can be built-in (included with the normal distribution of Gramps) or an add-on (installed via the Third party add-ons management in Preferences).

POSIX
Portable Operating System Interface; a family of OS standards specified by the IEEE Computer Society for maintaining compatibility with variants of Unix (such as Linux) and other operating systems. Although the MacOS is "POSIX-certified", the term is used in this manual to generically refer to just the "Mostly POSIX-compliant" Linux and BSD distributions with verified Gramps downloads and which use the POSIX-style environment.

Preferences
The Preferences is an option in the Edit main menu that allows global customization of the appearance, defaults and behavior of Gramps.
Gramps Glossary - Q

The customizations are categorized into the following tabs: General, Family Tree, Display, Text, ID Formats, Dates, Researcher, Warnings, Colors, Genealogical Symbols. A Themes tab is available as an addon.

(see also Configure... option in the View main menu is an option. Those customizations are limited to the currently active view and its Gramplets. The feature may also be accessed by the [configure...] toolbar icon.)

Primary object

Primary objects are the data structures at the top level of a hierarchical collection of records. Beside the main structure of data, they can contain a hierarchy of secondary objects, and can be referenced by other primary or secondary objects. In the Gramps database, primary objects and the secondary objects that they contain are stored as separate records. Each primary object type is stored in a separate table. See Using database API, Primary Objects (see also secondary object)

The primary objects are:

- Citation
- Event
- Family
- Media
- Note
- Person
- Place
- Repository
- Source
- Tag

Primary role

(event role) A term to refer to the role of the focal participant of an Event. Primary is the default role when adding a new Event in the Edit Person dialog.

Private flag or tag

The Private option identifies sensitive information that should be redacted when sharing data or printing reports. (This marker should not be confused with the generic user-definable Tags used for custom filters and color highlighting.) Records are shown with: a unlocked padlock when private; and, an unlocked padlock when public. Clicking the padlock icon toggles between Private & Public flags. This manual override supplements the automated Probably Alive and custom Filter features which help Gramps to respect Personal Privacy.

Gramps is a single user database and omits the typical security features of a multi-user system. So even "Private" data will be accessible from within Gramps. However, generating reports and exporting data default to redacting information flagged as Private.

Public tag or flag

The Public option identifies information that should be included when sharing data or printing reports. Records are shown with: a unlocked padlock when public; and, an locked padlock when private. Clicking the padlock icon toggles between Public & Private flags. By default, all records are created as Public.

Q

R

Reference

the basic a system of linking relationships between objects in Gramps. When when an object is added in the Editor for record, a Reference (link) is created in the object that was added.

References tab

a system of linking between objects in Gramps. When objects of Gramps are linked, the References tab lists the objects to link toward it.

Repository

_prim. obj._ - Contains the information related to a physical or virtual structure where genealogical and family history sources are stored. Once a Repository is added to a Gramps Tree, it can used to organize Sources.

role

function performed or part played by a person (or other Gramps object) in a particular situation. When objects of Gramps are linked, a Reference is created where the implicit Role disambiguates the relative nature of the reference. For explicitly defined roles, see event role and association role.

romanization

linguistic representation of a word in the Roman (Latin) alphabet

S

secondary object

Secondary objects are contained within other objects, and cannot be referenced directly. They can contain other secondary objects. Examples include: Name, Date and Address. See Using database API, Secondary Objects (see also primary object)

Shared objects

Sharing allows an Object to be linked at multiple places in the tree. Doing so establishes a relationship or maintains single set of attributes (or secondary objects) that they hold in common.

Object Reference Editors allow updates to a shared object to be reflected in all instances mentioning (referencing) that shared object.

Redundantly creating object with the same information should be avoided. (So, refining a Transcription Note shared by multiple Citations will show the updated transcription in all the Citations.)

Object descriptions are grouped in two distinct sections:
• The **Reference Information** section contains information unique to one instance.
• The **Shared Information** of an object will be seen in all instances that are linked to it.

**Source**

*(prim. obj.)* - Sources can be a person (family, friend, another researcher), thing (book, magazine, newspaper, census), or place (courthouse, church, library, genealogical/historical society... although places might be better handled as Repositories) from which information comes, arises, or is obtained. After *adding a Source* with the *new source dialog* to the *Sources category* of a Gramps Tree, the Source can be referenced when adding a *Citations* and organized within *Repositories*. The same Source may exist in multiple Repositories and may have different Media Types (such as book, microfilm, or electronic) and Call numbers in each Repository.

**SQLite**

*(database backend engine)* The **SQLite** project's *in-process library* (also known simply as SQLite) is the *default database engine* used since the **5.1** version of Gramps. The support was extended from **BSDDB** in the **5.0** version via the **DB-API Database Backend**.

**T**

**Tag**

*(prim. obj.)* - A custom titled and color-coded label that can be attached to selected Citation, Event, Family, Media, Note, Person, Place, Repository or Source objects for the purpose of easy identification and filtering.

A keyword or phrase used to group the collection to produce a report. Multiple tags may be used to label and categorize objects into multiple groups when filtering by other attributes is not viable.

**Toolbar**

*(graphical user interface terminology)* - The **Toolbar** is a ribbon (located below the application menubar) with button shortcuts for the most widely needed functions associated with the current view. The selection of buttons changes in response to the context of the current view. (e.g., toolbar buttons for switching mapping view modes will only appear for the *Geography view*.)

**Typographical conventions**

The **customary formatting** having special (and possibly peculiar) meaning when used throughout the MediaWiki driven Gramps manual and documentation. The different typeface accents, highlighting and enclosures indicate specific parts of the Gramps **Graphical User Interface (GUI)** or prompt a User activity.

**U**

**Unknown**

*(event role)* A placeholder for when the role of a participant in an Event has not yet been defined. Gramps sets an appropriate default Role as each new Event type is created. But when a new participant is associated with an existing Event via Share or drag’n’drop, the Role isn't as predictable. In such a case, an Unknown placeholder is inserted.

Any Unknown Event Role type causes a variety of reporting problems. Persons and Families with Unknown Roles should be found and the Roles manually replaced as soon as is practical.

**User Directory**

*(core concept)* An alias for the file folder (directory) location where customizations (e.g.: preferences files, addons, plug-ins) are stored for the Gramps family of genealogy tools. Since this folder location varies by which Operating System and which Gramps fork has been installed, the **User Directory** is an 'alias' (a.k.a. placeholder) used in instructions about re-configuring Gramps.

This alias allows instructions for locating your specific User Directory file location to be consolidated in the documentation.

**V**

**View category**

*(graphical user interface terminology)* - a **View category** (often simply called a "*View*") is a Gramps-specific name for the collection of View modes (display layouts) presenting information in a structured and predictable manner. Different Views are selected from the **Navigator** (left sidebar).

Layouts are in table, outline or graphical formats; depending on the preferred way to represent how the data elements relate to one another. Gramps divides and organizes the information about each Primary Object into a series of Categories, each with their own View. Each of the Category Views displays a smaller, more digestible portion of the total information that comprises a Genealogical Tree. The View categories are: Dashboard, People, Relationships, Families, Charts, Events, Places, Geography, Sources, Citations, Repositories, Media, Notes.

**View mode**

*(graphical user interface terminology)* - a **View mode** is a Gramps-specific name for the display layouts presenting **View category** information in a structured and predictable manner. A View category may have alternate **view modes** (subcategories) of display layout. (e.g., Views with Table layouts might have flat listed or hierarchically grouped modes.) Navigating between View modes is from the toolbar and Navigator.

Each mode of a category can be independently configured. Each mode may maintain a separate object selection, filtering, and organization for its Gramplet bars.

View data may be further subdivided with tabbed pages of layouts.
(Hawaiian loanword) meaning ‘quick’; or ‘wikiwiki’ meaning ‘very quick’. For Gramps users, the Wiki (a.k.a. Wiki Manual) refers to the collaborative website of educational material which is organized using the MediaWiki content management system. The core pages of that website being the structured reference-style Gramps software user's operating guide. (Note that specific tutorial documents are also part of the wiki.) For most internet users, the word is most often an inadvertent allusion to the 1995 WikiWikiWeb, the first website that built-in tools encouraging users to quickly & easily collaborate to expand the content of the site. See the term: 'wiki' in Wiktionary.

Witness
(event role) The term that applies to the people asked to be present at an event so as to be able to testify to its having taken place.

X

XML
acronym: Extensible Markup Language. A schema used to define the expected structure of data in a text format. The system annotates a document in a way that data elements are syntactically distinguishable from identifying tags. A markup language defines a set of rules for encoding documents in a fault tolerant format that is both (marginally) human-readable and machine-readable. Gramps will generate XML format natively in compressed and uncompressed forms identified with a .gramps or .gpkg file extension. It is the format that definitively supports every piece of genealogical data stored by Gramps. Used as the working format until Gramps 2.0 started using a database backend to improve performance, XML is now the standard Tree data backup format and recommended data exchange format. See the reference documentation for the versions of Gramps RELAX NG (REgular LAnguage for XML Next Generation)(.rng) schema XML and DTD.

Y

Z