
GRAMPS Manual V2.9

Alex Roitman, GRAMPS Project <shura@gramps-project.org>
Donald N. Allingham, GRAMPS Project <don@gramps-project.org>

Donald N. Allingham
GRAMPS Project

 <don@gramps-project.org> 



GRAMPS Manual V2.9
by Alex Roitman and Donald N. Allingham
Donald N. Allingham
GRAMPS Project

 <don@gramps-project.org> 

Copyright © 2001 Donald N. Allingham
Copyright © 2003-2006 Alex Roitman

Abstract

The GRAMPS Manual is the user manual helping users to find their way around GRAMPS software. All aspects
are covered, including the general details, subtle tips, preferences, tools, reports, etc.

This manual is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the
Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This manual is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation,
Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
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Preface
GRAMPS is a software package designed for genealogical research. Although similar to other genealogical pro-
grams, GRAMPS offers some unique and powerful features, which we'll discuss below.

GRAMPS is an Open Source Software package, which means you are free to make copies and distribute it to
anyone you like. It's developed and maintained by a worldwide team of volunteers whose goal is to make GRAMPS
powerful, yet easy to use.

1. Why use GRAMPS?
Most genealogy programs allow you to enter information about your ancestors and descendants. Typically, they
can display family relationships through charts, graphs, or reports. Some allow you to include pictures or other
media. Most let you include information about people even if those people are not related to the primary family
you happen to be researching. And they may include features that let you exchange data with other programs and
print different types of reports.

GRAMPS has all these capabilities and more. Notably, it allows you to integrate bits and pieces of data as they arise
from your research and to put them in one place -- your computer. You can then use your computer to manipulate,
correlate, and analyze your data, rather than messing with reams of paper.

2. Typographical conventions
In this book, some words are marked with special typography:

• Applications

• Commands you type at the command line

• Filenames

• Replaceable text

• Labels for buttons and other portions of the graphical interface

• Menu selections look like this: Menu->Submenu->Menu Item

• Buttons you can click

• Anything you type in

The manual also provides assorted bits of additional information in tips and notes, as follows.

Example Tip

Tips and bits of extra information will look like this.

Example Note

Notes will look like this.

Finally, there are warnings, notifying you where you should be careful:

Example Warning

This is what a warning looks like. If there's a chance you'll run into trouble, you will be warned
beforehand.
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Chapter 1. Getting Started
In this chapter, we'll begin with the basics. We'll show you how to start GRAMPS and how to get help when
you need it.

1.1. To Start GRAMPS
You can start GRAMPS in the following ways:

From the Applications menu Select GRAMPS from the list of programs displayed in your computer's Appli-
cations menu. (The location and appearance of this menu vary slightly from one
distribution of Linux to another. On the default GNOME desktop, you'll find
GRAMPS in the Applications->Other menu.

From the command line If you're adept with Linux and like to work from the command line, you can start
GRAMPS by calling up a terminal window, typing gramps, and then pressing
Enter.

If you would like GRAMPS to open a specific database or to import a specific
file on startup, you can supply the filename as a command line argument:

gramps filename.grdb

where filename.grdb is the name of the file you want to open. The com-
mand line provides many more ways to start GRAMPS and perform different
tasks.

1.2. Choosing a database
If GRAMPS is started without a database selected, the initial screen will have little functionality. Most operations
will not be available. To load a database, select either New to create a new database, or Open to open an existing
database. GRAMPS keeps track of your recently opened databases, and these can be selected by clicking on the
arrow next to the Open button and choosing from the drop down menu.

Figure 1.1. Initial Window
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1.3. Obtaining Help
GRAMPS has a Help menu that you can consult at any time. It includes the following items:

User manual An electronic version of the manual that you can access while you work in
GRAMPS.

FAQ A list of Frequently Asked Questions about GRAMPS.

Tip of the day Displays the "Tip of the day" dialog.

Plugin status Use this item to display the status of any plugins you may have added.

GRAMPS home page This item opens your web browser and connects to the GRAMPS' project web
site.

GRAMPS mailing lists This item opens your web browser to the GRAMPS mailing list page. At this
page, you can browse the mailing list archives or join the mailing list

Report a bug Choose this item to file a bug report in our bug tracking system. (Remember,
GRAMPS is a living project. We want to know about any problems you encounter
so we can work to solve them for everyone's benefit.)

About This item displays a dialog with general information about the GRAMPS version
you are running.
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Chapter 2. Main Window
When you open a database (either existing or new), the following window is displayed:

Figure 2.1. GRAMPS Main Window

The main GRAMPS window contains the following elements:

Menubar The menubar is located at the very top of the window (right below the window title) and
provides access to all the features of GRAMPS.

Toolbar The toolbar is located right below the menubar. It gives you access to the most frequently
used functions of GRAMPS. You can set options that control how it appears by going to
Edit->Preferences. You can also hide it entirely by going to View->Toolbar.

Progress Bar The Progress Bar is located in the lower left corner of the GRAMPS window. It displays the
progress of time consuming operations, such as opening and saving large databases, importing
and exporting to other formats, generating web sites, etc. When you are not doing these types
of operations, the Progress Bar is not shown.

Status Bar The Status Bar is located to the right of the Progress Bar, on the very bottom of the GRAMPS
window. It displays information about current GRAMPS activity and contextual information
about the selected items.

Display area The largest area in the center of the GRAMPS window is the display area. What it displays
depends on the currently selected View. We'll discuss Views in detail below.

2.1. Views
Genealogical information is very broad and can be extremely detailed. Displaying it poses a challenge that
GRAMPS takes on by dividing and organizing the information into a series of Views. Each View displays a por-
tion of the total information, selected according to a particular category. This will become clearer as we explore
the different Views, listed below:

People View Displays the list of people in the database
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Relationships View Shows the relationships between the Active Person and other people. This includes
parents, spouses, and children

Family List View Shows the list of families in the database

Pedigree View Displays a graphical ancestor tree for the selected person

Events View Displays the list of events in the database

Sources View Displays the list of sources in the database

Places View Displays the list of places in the database

Media View Displays the list of media objects in the database

Repositories View Displays the list of repositories in the database.

Before we launch into a description of each View, let's first explain how to switch between Views.

2.1.1. Switching Views and Viewing Modes

As mentioned above there are nine different Views. In addition, there are two different Viewing Modes. You can
tell at a glance which Viewing Mode you are in: If you see icons listed vertically in a sidebar at the left of the
window, you are in the Sidebar Viewing Mode. If instead you see a series of "notebook tabs" (labeled People,
Relationships, Family List, Pedigree, Events, Sources, Places, Media and Repositories) that run horizontally across
the window, then you are in the Tabbed Viewing Mode. You can switch from one Viewing Mode to another by
selecting View->Sidebar from the Sidebar menu item.

If you're in the Sidebar Viewing Mode, you can select the View you want by clicking one of the sidebar icons.

Figure 2.2. Sidebar Viewing Mode

If you're in the Tabbed Viewing Mode, you can select the View you want by clicking the corresponding notebook
tab.
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Figure 2.3. Tabbed Viewing Mode

2.1.2. People View

The People View lists the people stored in the database. You'll note that people are grouped according to their
family names. To the left of each family name is typically either an arrow or some other type of indicator. Clicking
it once will reveal the entire list of people sharing that name. Clicking the indicator again will "roll up" the list
and show only the family name.

By default, the People View, displays the several columns of information about each person. You can add or
remove columns to and from the display by calling up the Column Editor dialog ( Edit->Column Editor) and
checking or unchecking the boxes listed. You can also change the position of a column in People View by clicking
and dragging it to a new position in the Editor. Once you have made the changes you want, click OK to exit the
Editor and see your changes in the People View.

Column Editor

The Column Editor is available in all Views and works the same way in each.
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Figure 2.4. Column Editor Dialog

2.1.2.1. Filters

Genealogical databases can contain information on many people, families, places, and objects. It's therefore pos-
sible for a View to contain a long list of data that's difficult to work with. GRAMPS gives you two different means
for controlling this condition by allowing you to filter a list to a more manageable size. These methods are Search
and Filtering. A search will search the text displayed in list, whereas filters display people whose data match the
criteria of the filter.

Search is a simple but fast method of searching the columns displayed on the screen. Typing the characters into
the Search box and clicking the Find button will display only lines that match the text.

Alternatively, you can enable the Filter sidebar, which will be displayed on the right hand side of the display.
When the filter sidebar is displayed, the Search bar is not displayed. The Filter side bar allows you to interactively
build a set of filter rules that can be applied to the display. The filter is applied based on the rules and the data,
not on the screen display.

Searching vs. Filtering

Searching only searches for exact text matches. If the date displayed is "Jan 1, 2000", a search of
"1/1/2000" will fail, but a filter of "1/1/2000" will match.
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Figure 2.5. Filter Controls Displayed

When GRAMPS opens a database, no filtering is in effect. In People View, for example, all people in the database
are listed by default.

2.1.3. Relationships View
The Relationships View displays all the relationships of the Active Person (the selected person). Specifically, it
shows his or her parents, siblings, spouses, and children.

The Relationships View is designed to allow for quick navigation. You can quickly change the Active Person
simply by clicking the name of any person listed on the page. Each name is actually a hypertext link, similar to
a web page.

Figure 2.6. Relationships View

The Relationships View displays the following sections:
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Active Person At the top of the screen, name, ID, birth, and death information of the Active Person is
displayed. If a photo of the person is available, it is shown on the right hand side. Next to the
person's name is a symbol indicating gender, and an Edit button. Clicking the Edit button
will allow you to edit all of the person's individual information in an Edit Person dialog.

Parents The next section, the Parents section, displays the families in which the person is a child.
Since it is possible for a person to have multiple sets of parents, it is possible to have several
Parents sections.

You can control how much information is displayed by using the View menu. The view
menu allows you to show or hide details (the birth and death information) and to show or
hide siblings. Next to each person listed is an Edit button, which will allow you to edit all
the details of that particular person.

You may add a new set of parents by either selecting the Add Parents or the Share Parents.
The Add Parents button will create a new family with the Active Person listed as a child.
The Share Parents button will allow you to choose from a list of existing families, and then
add the person as a child to that family.

You may edit an existing parents by selecting the Edit button next to the parents. If you
select the Delete next to a set of parents, then the Active Person will be removed as a child
from the parents. This button does not delete the parents' relationship.

Warning

If you are not careful, it is possible to create multiple families with the same
parents. This is rarely what the user wants to do. If you attempt to add a new
family that has the same parents as an existing family, GRAMPS will issue
a warning dialog. If you get this dialog, you should probably Cancel the edit,
and then use the Select button to select the existing family.

Family Similar to the Parents section is the Family section, which displays families where the Active
Person is a parent. Because it is possible to have multiple familes, it is possible to have
multiple Family sections. Each family section displays the spouse and any children.

Note

We use the term spouse for sake of simplicity. However, please note that
spouse may in fact be a domestic partner, a partner in a civil union, or various
other similar relationships between two people. Spouse relationships are not
required to be only between a male and female.

You may add a family by selecting the Add Spouse in the toolbar. This will create a new
family with the Active Person listed as a father or mother.

Selecting the Edit button next to the spouse will allow you to edit the displayed family.
Clicking the Delete button will remove the person from the displayed family.

Warning

Removing a person from a family does not delete the family. The person is
removed as the father or mother, and any other relationships in the family
continue to exist.

Note

We use the terms father and mother for the sake of simplicity. Even if there
are no children in a family, the father and mother terminology is still used. In
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the case of male/male or female/female relationships, the father and mother
labels should be considered to be convenience labels.

You can reorder the parents and spouses by selecting the Reorder. This option will only be
enabled if more than one set of parents or more than one set of spouses exists for the Active
Person. Selecting this button will display a dialog that will allow you to reorder the families.

Figure 2.7. Relationship Reordering Window

2.1.4. Family List View

The Family List View displays a list of all families in the database. From this view, you may add, edit, or delete
families. The default display lists the ID, Father, Mother, and Relationship. Children cannot be displayed on the
screen in this view.
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Figure 2.8. Family List View

Warning

Unlike the Relationships View, clicking the Remove button in this view will remove the family from
the database. All people will remain, but all relationships between the people in the family will be
removed.

2.1.5. Pedigree View

The Pedigree View displays a family tree of the Active Person's ancestors. The Pedigree View shows up to five
generations, depending on the size of the window. Each person is indicated by a box labeled with his or her name,
birth and death information, and optionally an image if available. Two lines branch from each box. The top one
shows the person's father and the bottom one the mother. Solid lines represent birth relations, while dashed lines
represent non-birth relations such as adoption, step-parenthood, guardianship, etc.
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Figure 2.9. Pedigree View

To the left of the Active Person is a left arrow button. If the Active Person has children, clicking this button expands
a list of the Active Person's children. Selecting one of the children makes that child the Active Person.

The appearance of the children's names in the menu differentiates the dead ends of the tree from the continuing
branches. Children who have children themselves appear in the menu in the boldface and italic type, while children
without children (dead ends) appear in a regular font. If the Active Person has only one child, no menu will be
displayed (since there is only one choice) and the child will become the Active Person when the arrow button
is clicked.

Figure 2.10. Children Menu

The right-hand side of the window shows two right arrow buttons. When the top button is clicked, the Father of
the Active Person becomes the Active Person. When the bottom button is clicked, the Mother of the Active Person
becomes the Active Person.
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Figure 2.11. Personal Context Menu

Right-clicking on any person's box in the Pedigree View will bring up the "context menu". Among other useful
items, the context menu has sub-menus listing Spouses, Siblings, Children, and Parents of that person. "Greyed-
out" sub-menus indicate the absence of the data in the appropriate category. Similar to the children menu above,
Childrens' and Parents' menus distinguish continuing lines from dead ends.

2.1.6. Events View

New in version 2.2 is the inclusion of an Events View. Events can be shared between multiple people and multiple
families. The Events View lists the all the events recorded in the database. The default view displays the Descrip-
tion, ID, Type, Date, Place and Cause of the event.
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Figure 2.12. Events View

Warning

Because events can be shared, you should take the extra time to give each event a unique and mean-
ingful description. This will help you find the correct event if you decide to share events.

The list of Events can be sorted in the usual manner, by clicking on the column heading. Clicking once sorts in
ascending order, clicking again sorts in descending order. The Column Editor dialog can be used to add, remove
and rearrange the displayed columns.

2.1.7. Sources View

Sources View lists the sources of certain information stored in the database. These can include various documents
(birth, death, and marriage certificates, etc.), books, films, journals, private diaries, - nearly anything that can
provide genealogical evidence. GRAMPS gives you the option to provide a source for each event you record
(births, deaths, marriages, etc.). The Sources View lists the Title, ID, and Author of the source, as well as any
Publication information that may be associated with it.

The list of Sources can be sorted by clicking on a column heading. Clicking once sorts in ascending order, clicking
again sorts in descending order. The Column Editor dialog can be used to add, remove and rearrange the displayed
columns.
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Figure 2.13. Sources View

2.1.8. Places View

The Places View lists the geographical places in which the events of the database took place. These could be places
of birth, death, and marriages of people, as well as their home, employment, education addresses, or any other
conceivable reference to the geographical location. The Places View lists the places' Name, ID, Church Parish,
City, County, State, and Country. All of these columns can be used for sorting by clicking on a column heading.
Clicking once sorts in ascending order, clicking again sorts in descending order. The Column Editor dialog may
be used to add, remove and rearrange the displayed columns.

If a place has been highlighted, you may select the Google Maps button to attempt to display the place in a web
browser. Your default web browser should open, attempting to use either the longitude and lattitude coordinates
or the place name to display the location using the Google Maps web site. This feature is limited, and may not
always produce the results you desire.
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Figure 2.14. Places View

2.1.9. Media View
The Media View is a list of Media Objects used in the database. Media Objects are any files that relate somehow
to the stored genealogical data. Technically, any file can be stored as a Media Object. Most frequently, these are
images, audio files, animation files, etc. The list box on the bottom lists the Name, ID, Type, and Path of the Media
Object. The Column Editor dialog may be used to rearrange the displayed columns, which obey usual sorting rules.
The top part of the GRAMPS window shows a preview (if available) and information about the Media Object.

Figure 2.15. Media View

2.1.10. Repositories View
Version 2.2 adds support for Repositories. A repository can be thought of as a collection of sources. Each source in
the database can reference a repository (such as a library) in which it belongs. The functionality of the Repositories
View is similar to the other views.
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Figure 2.16. Repositories View
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Chapter 3. Usage
Now we turn to a detailed exploration of the day-to-day use of GRAMPS. First, we should point out that GRAMPS
often offers more than one way to do the same task. We'll try to point out some of these alternatives where ap-
propriate.

3.1. Starting a New Database
To start a new database, choose File->New or select the New button from the toolbar. You will then be asked to
give the new database a name.

GRAMPS databases

GRAMPS stores your data in a Berkeley database, sometimes known as BSDDB. These files have
".grdb" as their default extension. The extension is automatically added to your filename.

3.2. Opening a Database
To open a database, either choose File->Open or click the Open button on the Toolbar. The Open database dialog
will appear and you'll see a list of files. If you don't see the file you're looking for, make sure the All files filter is
selected. (This dialog has a "filetype" filter, meaning it may only be showing files that have a certain extension.)

To open a recently accessed database, choose either File->Open Recent or the down arrow next to the Open button
and select the filename from the list.

If you do not have "write permissions" for the selected database, it will be opened in a Read Only mode. In this
mode, the data may be viewed, but no changes will be made to the database. To indicate this mode, the title of
the main window will be appended with (Read Only) text.

GRAMPS allows you to open certain databases that have not been saved in GRAMPS' own file format. These
include XML and GEDCOM databases. But you should be aware that if the XML or GEDCOM database is rela-
tively large, you may encounter some performance problems. These can be avoided by creating a new GRAMPS
database and importing your XML/GEDCOM data into it.

Opening XML and GEDCOM databases

XML and GEDCOM databases require all data to be held in memory. GRAMPS' native grdb format
does not. Thus, a database with a grdb format can access data quicker and more efficiently.

GEDCOM Editing

Please keep in mind that some information in a GEDCOM file may be lost during import into
GRAMPS. Simply opening and viewing the file will not change it. However, if any changes were
made and they were not abandoned upon exit, exiting GRAMPS will save the data, with possible
data loss.

3.3. Saving Changes to Your Database
GRAMPS saves your changes as soon as you apply them. This means, for example, that any time you click OK
when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command
(although there is a "save as" command that we'll discuss later.)

You can undo changes you've made by selecting Edit->Undo. If you select this command repeatedly, your most
recent changes will be undone one at a time. To roll back multple commands at a time, you can using the Undo
History dialog available from the Edit menu.
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If you want to return your database to the way it was when you opened it, select File->Abandon changes and quit.
(This is just like quitting without saving in other programs.)

If you would like to save your database under a different name, you can do so by choosing File->Save as... and
specifying the name (and, optionally, the format) of your new database. Note that Save as will allow you to
continue editing the newly saved database. If this is not what you want to do, you may wish to use the Export
command instead.

3.4. Importing Data
Importing allows you to bring data from other genealogy programs into a GRAMPS database. Currently, GRAMPS
can import data from the following formats:

• Another GRAMPS database (having the grdb file extension),

• GEDCOM

• GRAMPS XML

• GRAMPS package

• GeneWeb

Importing vs. opening

Please recognize that importing a database is different from opening a database. When you import,
you are actually bringing data from one database into a GRAMPS database. When you open a file,
you are editing your original file.

To import data, select File->Import. The Import database dialog will open, asking you to specify the file you wish
to import.

Data loss with some formats

It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databas-
es. There is a chance that some of the data in these databases will not be imported into GRAMPS.

The GRAMPS database (grdb), GRAMPS XML, and GRAMPS package are all native GRAMPS formats. There
is no risk of information loss when import or exporting to these formats.

GRAMPS database (grdb) The native GRAMPS database format is a specific form of Berkeley database
(BSDDB) with a special structure of data tables. This format is binary and ar-
chitecture-dependent. It is very quick and efficient, but not generally portable
across computers with different binary architecture (e.g. i386 vs alpha).

GRAMPS XML The GRAMPS XML file was the default format for older versions of
GRAMPS. Unlike the grdb format, it is architecture independent and human-
readable. The database may also have references to non-local (external) media
objects, therefore it is not guaranteed to be completely portable. The GRAMPS
XML database is created by saving ( File->Save As... ) or exporting ( File-
>Export... ) data in that format

GRAMPS package The GRAMPS package is a compressed archive containing the GRAMPS
XML file and all media objects (images, sound files, etc.) to which the database
refers. Because it contains all the media objects, this format is completely
portable. The GRAMPS package is created by exporting ( File->Export... )
data in that format.
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If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress
of the operation in the progress bar of GRAMPS' main window.

3.5. Exporting Data
Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable
you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats:
GRAMPS database (grdb), GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, and GeneWeb.

Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another
file with a copy of your data. Note that the database that remains opened in your GRAMPS window
is NOT the file saved by your export. Additional editing of the currently opened database will not
alter the copy produced by the export.

To export data, choose File->Export. This will bring up the Export assistant. Its pages will guide you through the
format selection (see Figure 3.1, “Export assistant: format selection”), file selection, and format specific export
options (see Figure 3.2, “Export assistant: GEDCOM options”). After a final confirmation page, the export will be
performed according to the choices you have made. At any time, you can click the Back and revise any selection,
and then go forward to redo the export.

Figure 3.1. Export assistant: format selection

3.5.1. Exporting into the GEDCOM format
GRAMPS allows you to export a database into the common GEDCOM format. It provides options that allow you
to fine tune your export (see Figure 3.2, “Export assistant: GEDCOM options”).

Encoding Since different languages use different characters, it is important to tell a
GEDCOM file what character set is used. The two formats traditionally ac-
cepted are ASCII and ANSEL. Since all ASCII characters are valid ANSEL
characters, GRAMPS does not provide an option for ASCII.

Because ANSEL is not commonly used, some genealogy programs will
accept ANSI (more commonly know as ISO-8859-1) and Unicode character
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sets. Only select ANSI or Unicode if you know any program that attempts
to read the GEDCOM file will understand these character sets.

Filter The filter allows you to export a limited amount of data, based on the criteria
you select.

Target While GEDCOM is a standard, not every program implements it in the same
way. This can lead to data loss. GRAMPS can reduce the data loss in some
cases. You can tell GRAMPS what program is the target, and GRAMPS
will customize the exported file for that program. If your program is not
listed, choose the "GEDCOM 5.5 Standard".

Copyright Allows you to select a statement to describe your Copyright claim.

Do not include records marked pri-
vate

Check this box to prevent private records from being included in the ex-
ported file.

Restrict data on living people Check this box to limit the information exported for living people. This
means that all information concerning their birth, death, addresses, signif-
icant events, etc., will be omitted in the exported GEDCOM file. If you
choose this option, you will be given additional options to limit further the
data on living people. For example, you can choose to substitute the word
"Living" for the first name; you can exclude notes; and you can exclude
sources for living people.

Sometimes, it is not always obvious from the data if someone is actually
alive. GRAMPS uses an advanced algorithm to try to determine if a person
could still be alive. Remember, GRAMPS is making its best guess, and it
may not always be able to guess correctly all the time. Please double check
your data.

Reference images from path Check this box to tell GRAMPS to use the specific path for your images
when writing image references in GEDCOM.

This option allows specify where your image files are located. This is useful
when you are transfering your GEDCOM file from one computer to anoth-
er. It tells the program that is importing the data where your images are.
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Figure 3.2. Export assistant: GEDCOM options

3.5.2. Export into GRAMPS formats

GRAMPS database (grdb) export Exporting to the GRAMPS native format will simply make a copy of your
data under another name. Exporting to this format can also be useful if you
have directly opened an XML or GEDCOM file and would like to save it
as the grdb file.

GRAMPS XML database export Exporting into GRAMPS XML format will produce a database compatible
with the previous versions of GRAMPS. As XML is a text-based human-
readable format, you may also use it to take a look at your data.

GRAMPS package export Exporting to the GRAMPS package format will create a compressed file
that contains the database and copies of all associated media files. This is
useful if you want to move your database to another computer or to share
it with someone.

Export to CD Exporting to CD will prepare your database and copies of all media object
files for recording onto a CD. To actually burn the CD, you will need to go to
the GNOME burn:/// location, which can be accessed by navigating through
Nautilus: After exporting to CD, select Go->CD Creator in the Nautilus
menu. Your database directory will show up. To burn it to the CD, click the
CD icon on the Nautilus toolbar, or select File->Write to CD in the Nautilus
menu.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GED-
COM export.
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3.5.3. Export into other formats
Web Family Tree Exporting to Web Family Tree will create a text file that can be used by the Web

Family Tree program. Export options include filter selection and the ability to limit
data on living people to that of their family ties.

GeneWeb Exporting to GeneWeb will save a copy of your data into a popular web genealogy
format. To find out more about GeneWeb and its format, visit http://cristal.inria.fr/
~ddr/GeneWeb/en/.

vCalendar and vCard Exporting to vCalendar or vCard will save information in a format used in many
calendaring and addressbook applications, sometimes called PIM for Personal In-
formation Manager.

3.6. Entering and Editing Data: Quick Start
Overview
This section is designed to give you the basic knowledge necessary to start putting your genealogical information
into GRAMPS. It will explain how to enter people into the database and how to specify their family relationships.
(A more detailed explanation will follow in the section entitled Section 3.7, “Entering and Editing Data: Complete
Description”.)

First, let's identify the types of information you can enter into your GRAMPS database. These include:

• Personal information about an individual (names, addresses, birth and death dates, etc.)

• Information about an individual's relationships (marriages, divorces, civil unions, etc.)

• Information about an individual's parents and children

• Sources that document your research

Keybindings

In addition to interacting with GRAMPS through menu items and buttons, you can use its extensive
set of "keybindings." For more information, see Appendix B, Keybindings reference.

Now let's take a quick look at how you can enter and edit these various types of information.

3.6.1. To Add or Edit a Person
There are multiple ways to add a person to the database. We will cover some of them as we proceed. The simplest
way to enter a person to add them from the People View. While you are in the People View (Figure 2.2, “Sidebar
Viewing Mode”), click the Add on the toolbar. Enter any data you know about this person into the Edit Person
dialog (see Figure 3.8, “Edit Person dialog” for details).

To edit information about a person already present in the database, select the person from the People View and
click the Edit button on the toolbar.

Alternate ways of adding or editing a person from the People View

You can also use Add... and Edit... menu items available under Edit. Or you can right-click on the
person and select Add... or Edit... from the context menu that pops up.

People can also be added to the database in the Relationships View, Edit Family dialog, and other places where
it makes sense.

http://cristal.inria.fr/~ddr/GeneWeb/en/
http://cristal.inria.fr/~ddr/GeneWeb/en/


3.6.2. To Specify a Relationship

23

3.6.2. To Specify a Relationship

There are two primary ways to specify relationships between people - using the Relationships View and using the
Edit Family dialog from the Family List View. The Family List is usually used to build all the relationships within
a single family at a time. The Relationships View is usually used to build multiple relationships to a single person.

To specify a new relationship to the Active Person, switch to the Relationships View (Figure 2.6, “Relationships
View”) and you'll see this individual indicated as the "Active Person". Next to the Family label is a Add button
(typically represented by a + sign). Clicking the Add button will display the Edit Family dialog with the Active
Person set as either the father or the mother.

Figure 3.3. Editing a family

Now a question: Does the person who will form the relationship with the Active Person already exist in the
database? If yes, click the Select button to the other person. You'll then be able to browse through the list of people
in the database to select the one you want. If not, click the Add button. This will allow you to add a new person
to the database and to specify the relationship this person has to the Active Person.
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Figure 3.4. Selecting a person

Filtering

By default, GRAMPS filters the displayed list to show only those people who could theoretically
have a relationship with the Active Person. That is, GRAMPS only shows those people whose birth
dates and death dates fit within the lifetime of the Active Person. If you wish, you can add a person
to the list by clicking the + button. To completely override the filter and display all people from the
database, check the Show all box.

To edit an existing relationship from the Relationships View, click on the Edit button next to corresponding Family
entry. If there is more than one relationship in the list, you can select the spouse or partner you want by clicking
the corresponding Edit button next to the relationship.

To specify a new relationship in the Family List View, click on the Add button on the toolbar, and an empty Edit
Family dialog will open. At this point, you can add people to the family.

3.6.3. To Specify Parents

You can specify Active Person's parents in the Relationship View(Figure 2.6, “Relationships View”). A little care
is required to prevent the creation of duplicate families. If you wish to add the Active Person to an already existing
family, you should click the Select button. If the family including the parents does not already exist, you should
click the Add button.

If you click on the Select button, you are presented with the Select Family dialog. This will allow you to select
the existing family, and then the Active Person will be added as a child to the family.



3.6.4. To Specify Children

25

Figure 3.5. Selecting a family

If you click on the Add button, a new Edit Family dialog is presented with the Active Person listed a child of
the new family. You can add the parents to the family by either adding new people as the parents or selecting
existing people as the parents.

Warning

If you create a new family and select parents that are already in an existing family, GRAMPS will
issue a warning message. If you proceed by saving the new famiy, you will have a duplicate family.

Figure 3.6. Duplicate family warning

You can also specify the parents of a person in the Family List View. If the family already exists, click on the Edit
button on the tool bar and add the person as a child when the Edit Family dialog is displayed. If the family does
not already exist, click the Add button to create a new family, and add the appropriate parents and children.

3.6.4. To Specify Children
Adding children to a relationship is done through a similar proceedure. From the Relationships View or the Family
List View, select the existing family or create a new family. Children can be added by selecting the Add button
or Select button to the right of the child list.
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Clicking the Add button will display the Edit Person dialog, allowing you to enter a new person. Clicking on the
Select button, will allow you to select an existing person from a list. By default, the child is added with a the
relationship type of birth to both parents.

If you wish to change the parent/child relationship from the default setting of birth, select the child and click on
the Edit button. This will display the Edit Child Reference dialog.

Figure 3.7. Child Reference Editor

3.6.5. Adding Photos and Other Media Objects

You can add photos and other media objects to individual people, events, sources, and places. You can also add
images that might not be limited to a single person or event (for example, group family photos).

If you want to add an image to a single person, switch to the People View (Figure 2.2, “Sidebar Viewing Mode”),
select a person, and then click the Edit icon on the toolbar. This will bring up the Edit Person dialog (Figure 3.8,
“Edit Person dialog”). Next, select the Gallery tab, and click the + button to call up the Select a media object
dialog. Type a filename or browse to find the image file you want and then provide a title for that image. Keep
adding images until you are done.

To add images related to a relationship (for example, a marriage), switch to the Family View (Figure 2.6, “Rela-
tionships View”) and double-click on the Spouse box. This calls up the Marriage/Relationship editor dialog. Select
the Gallery tab and click the + button to add an image.

To add images related to a source or a place, first switch to the Source View (Figure 2.13, “Sources View”) or
Place View (Figure 2.14, “Places View”). Select the source or place you want and then either double-click on it
or click the Edit icon on the toolbar. Select the Gallery tab and click the + button to add an image.

Finally, to add images that you want to include in the database, but hare are not limited to any particular person,
relationship, source or place, switch to the Media View (Figure 2.15, “Media View”). Then click the Add icon
on the toolbar to add an image. If you have already added any images to any individual galleries, you will also
find them listed in the Media View.
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Alternate way of adding images to galleries

An image can always be added to any gallery by using drag-and-drop. Items can be dragged from
the Media View, any gallery, the desktop, the file manager or a web browser and dropped on the
target gallery, adding the image to the gallery.

In any gallery, you can also use the Edit to edit image information and the - button and to remove the image
reference from that gallery.

Removing an image from a gallery

Removing a media object from a gallery does not remove the image from the database. To completely
remove the image from the database, delete it from Media View by first selecting it and then clicking
the Remove icon on the toolbar.

3.6.6. To Edit Events, Sources, Places, and Repositories
To add an event, a source, a place, or a repository to the database, switch to the appropriate Events View (Fig-
ure 2.12, “Events View”), Sources View (Figure 2.13, “Sources View”), Places View (Figure 2.14, “Places View”),
or Repositories View (Figure 2.16, “Repositories View”). Then click the Add icon on the toolbar to add the cor-
responding object. Enter the information into the Event Editor (Source Editor, Place Editor, or Repository Editor)
dialog.

To edit information about events, sources, places, and repositories already present in the database, switch to the
appropriate view, select an entry you would like to view/modify, and then click the Edit icon on the toolbar.
Alternatively, you may double-click on the entry to edit it.

3.7. Entering and Editing Data: Complete De-
scription
The previous section offered you a quick overview of how to enter and edit data in GRAMPS. This section con-
tinues that discussion in much greater detail.

As we have seen above, GRAMPS offers you a series of Views. Each of these Views gives you opportunities to
enter and edit information. In fact, you can often get to the same information from different Views.

In GRAMPS, information is entered and edited through what we call dialogs. Since we use that term frequently,
we should define what we mean by it:

A dialog is a pop-up window that provides one or more forms for entering and editing data that fits a certain
category. Examples in GRAMPS include the Edit Person dialog and the Family Editor dialog, among many others.

A dialog often includes a series of "notebook tabs" that group the information into subcategories. For example, the
Edit Person dialog has notebook tabs for subcategories such as Events, Attributes, Addresses, and Notes, among
others.

Add, Remove, and Edit buttons

In most cases, GRAMPS uses a + to correspond to Add, a - correspond to Remove, and an icon of
a pen on a sheet of paper to denote Edit. We will continue referring to the latter as the Edit button,
while using + and - to denote the two former buttons.

3.7.1. Editing Information About People
Information about people is entered and edited through the Edit Person dialog. This dialog can be invoked from
different Views in the following ways:

From the People View: • Double-click the name of the person whose data you would like to edit
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• Select the name by single click and then click the Edit button on the
toolbar.

• Select the name and then press Enter.

• Select Edit... from the Edit menu of GRAMPS

• Select Edit from the context menu that appears upon right-click on the
name.

From the Relationships View: To edit the Active Person's data, click on the Edit button next to the Active
Person's name.

From the Pedigree View: Double-click in the box having the name of the person whose data you want
to edit.

In each of the above cases, the Edit Person dialog will appear:

Figure 3.8. Edit Person dialog

The top of the window shows the basic information about the person whose data is being edited. Below are several
"notebook tabs" containing different categories of available information. Click any tab to view and edit its contents.
Clicking the OK button at the bottom will apply all the changes made in all tabs and close the dialog window.
Clicking the Cancel button will close the window without applying any changes. If any data in any tabs were
modified, an alert window will appear, prompting you to choose from the following options: close the dialog
without saving changes, cancel the initial cancel request, or save the changes.

Note

Clicking OK will immediately save changes to the database. There is no need for a Save operation,
since all changes are immediate.

Tip

If a tab label is in boldface type, this means it contains data. If not, it has no data.
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The general information is at the top of the window. This includes the primary name and general information.:

Primary Name includes Given name, Family name, Family prefix (such as "de" or "van"), Suffix (e.g. Jr.
or III), Title (e.g. Dr. or Rev.), Nickname (Bob for Robert), Type of the name (birth name,
married name, etc.). Some of these Family name and Type fields provide "autocompletion"
feature: as you type in these fields, a menu appears below the field containing database entries
that match your partial input. This gives you a shortcut by letting you select an entry that
already exists in the database rather than having to type it all out. You can select the entry
using your mouse or using your arrow and Enter keys.

The Edit (that is, the "pen and paper" icon) next to the Prefix entry field invokes the Name
Editor dialog. This dialog allows editing the preferred name in full detail (see Section 3.7.9,
“Names”).

General The Gender menu offers the choice of person's gender : male, female, and unknown.

The field ID displays the GRAMPS ID number which identifies the user in the database. This value
helps you distiguish between people who have the same name. You may enter any unique value you
want. If you do not provide a value, GRAMPS will automatically select a value for you.

The Marker allows you to specify some basic information on the status of your research.

The Privacy button lets you mark whether or not the person's record is considered private.

Image The Image area shows the first image available in the Gallery of this person (if any exist).

The tabs reflect the following categories of personal data:

Events The Events tab lets you view and edit any events relevant to the person. The bottom part of the window
lists all such events stored in the database. The top part shows the details of the currently selected
event in the list (if any). The buttons +, Edit, and - allow you to add, modify, and remove an event
record from the database. Note that the Edit and - buttons become available only when an event is
selected from the list.

Names The Names tab lets you view and edit any alternate names the person may have. The bottom part of the
window lists all alternate names for the person stored in the database. The top part shows the details of
the currently selected name in the list (if any). The buttons +, Edit, and - allow the addition, modification,
and removal of an alternate name from the database. Note that the Edit and - buttons become available
only when an alternate name is selected from the list.
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Figure 3.9. Edit Person dialog - Names

When you add a new name or edit an existing name, the Name Editor dialog is invoked. This dialog is
described in the section below (see Section 3.7.9, “Names”).

Attributes The Attributes tab lets you view and assign attributes to the person. You have complete freedom
to define and use attributes. For example, attributes might be assigned to describe the person's
physical characteristics or personality traits.

Note that each attribute listed in the Attribute dialog consists of two parts: the Attribute itself and
a Value associated with that Attribute. This so-called "Parameter-Value" pairing can help you
organize and systematize your research. For example, if you define "Hair color" as an Attribute
for a person, "Hair Color" will become a selectable Attribute for all other people. The Value of
Hair Color for person A might be red, and brown for person B. In similar fashion, you might
define an Attribute like "Generosity" and use the Value of "Enormous" to describe a particularly
generous person.

The bottom part of the dialog window displays the list of all Attributes stored in the database.
The top part shows the details of the currently selected attribute in the list (if any). The buttons
+, Edit, and - let you add, modify, and remove an attribute record from the database. Note that
the Edit and - buttons become available only when an attribute is selected from the list.
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Figure 3.10. Edit Person dialog - Attributes

Addresses The Addresses tab lets you view and record the various addresses of the person. The bottom part of
the window lists all addresses stored in the database. The top part shows the details of the currently
selected address in the list (if any). The buttons +, Edit, and - allow you to correspondingly add,
modify, and remove an address record from the database. Note that the Edit and - buttons become
available only when an address is selected from the list.

Some reports allow you to restrict data on living people. In particular, that option will omit their
addresses.
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Figure 3.11. Edit Person dialog - Addresses

Notes Figure 3.12. Edit Person dialog - Notes

The Notes tab provides a place to record various items about the person that do not fit neatly into other
categories. To add a note or modify existing notes simply edit the text in the text entry field.

The Format option lets you set the way the note will appear in reports and web pages. If you select
"Flowed," the text generated will have single spaces put in place of all multiple spaces, tabs, and single
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end-of-line characters. A blank line inserted between two blocks of text will signal a new paragraph;
additional inserted lines will be ignored.

If you select the Preformatted option, the text in reports and web pages will appear exactly as you enter
it in the Notes dialog.

Sources Figure 3.13. Edit Person dialog - Sources

The Sources tab allows you to view and document the sources for the information you collect. These
might be general sources that do not describe a specific event, but which nevertheless yield informa-
tion about the person. For example, if Aunt Martha's memoirs mention her great-grandson Paul, the
researcher may assume that this Paul actually existed and cite Aunt Martha's memoirs as the source
that justifies this assumption.

Tip

Sources which document specific events are best recorded as sources of the event (under
the Events tab) instead of as a source of the person. The person's Sources tab is best
used for any sources not specificly connected to any other data.

The central part displays the list of all source references stored in the database in relation to the person.
The buttons +, Edit, and - allow you to correspondingly add, modify, and remove a source reference
to this person. Note that the Edit and - buttons become available only when a source reference is
selected from the list.

Gallery The Gallery tab lets you view and store photos, videos, and other media objects that are associated
with the person. The central part of the window lists all such media objects. Any object in the form of
a valid image file will result in the display of a thumbnail view of the image. For other objects such
as audio files, movie files, etc., a corresponding file type icon is displayed instead.

Tip

The first available image in the gallery will be also displayed in the Image area in the
General tab.
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The buttons +, Select, Edit, and - let you add a new image to the database, link to an image already
stored in the database, modify an image, and remove a given media object from the person's gallery.
Note that the Edit and - buttons become available only when a media object is selected from the list.

Figure 3.14. Edit Person dialog - Gallery

Note

Removing a media object from a person's gallery does not remove it from the database.
It only removes the reference to that object from this person's record.

Internet The Internet tab displays Internet addresses relevant to the person. The bottom part lists all such
Internet addresses and accompanying descriptions. The top part shows the details of the currently
selected addresses in the list (if any). The buttons +, Edit, and - let you add, modify, and remove an
Internet address. The "Go" button (represented by an icon having a green arrow and yellow circle)
opens your web browser and takes you directly to the highlighted page. Note that the Edit, -, and
Go buttons become available only when an address is selected from the list.
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Figure 3.15. Edit Person dialog - Internet

Associations The Associations tab lets you view and edit information about the associations between people
in the database. The associations may include Godparents, family friends, or any other types
of associations you may wish to record.

Figure 3.16. Edit Person dialog - Associations
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LDS The LDS (Latter Days Saints) tab lets you view and edit information about LDS ordinances of the person.
These are LDS Baptism, Endowment, and Sealed to Parents ordinances, as labeled inside the tab. Each
ordinance is described by its date, LDS temple, and Place where it happened. An additional pop-up menu,
"Parents," is available for the Sealed to Parents ordinance. Each ordinance can be further described through
the selections available in the Status pop-up menu. It can also be include notes and references to sources
through the corresponding Sources... and Note buttons.

Figure 3.17. Edit Person dialog - LDS

3.7.2. Editing Dates
This section describes how to enter and modify dates. Since dates are so important in genealogical research,
GRAMPS takes special care to preserve and use any date information available.

Information can be entered into a date field by directly typing it or by invoking the Date selection dialog. Both
methods will be discussed below, but first, we will cover some important features of dates as they are used in
GRAMPS.

3.7.2.1. Date types

Dates in GRAMPS are classified according to the following types:

Regular A "regular" date is one which includes a specific day, date, or month. It can be complete (e.g., June
6, 1990) or partial (e.g., July 1977).

Before A "before" date is one that can only be identified as occurring before a certain day, month, or year.

After An "after" date is one that occurs after a certain day, month, or year.

Range A "range" describes a time period during which the event occurred. For example, "between January
1932 and March 1932."

Span A "span" describes a time period during which a condition existed. For example, "from May 12, 2000
to February 2, 2002."
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3.7.2.2. Date formats and parsing rules

GRAMPS recognizes dates entered in a variety of formats. The default numeric format is that which is conven-
tional for the environment is which GRAMPS is operating; that is, DD.MM.YYYY for most European countries,
MM/DD/YYYY for the U.S., and so on.

Besides exact dates, GRAMPS recognizes many dates that are not regular: before, after, about, ranges and spans.
It also understands the quality: estimated or calculated. Finally, it supports partial dates and many alternative
calendars. Below is the list of date entry rules to allow precise date parsing.

Date parsing rules

The list only applys to the English version of GRAMPS. If you are using localized version of
GRAMPS, your version may or may not provide a localized date parser. At the time of this writing,
localized parsers exist for French, German, Russian, Finnish, Dutch and Spanish languages.

If the localized parser is available for your version, chances are that other rules are in effect. If there
is no manual in your language yet, you may try following your instinct and go with the common ways
of denoting dates in your language. If all else fails, use the Date selection dialog described below.

• Regular single dates can be entered just as you would write them. Examples: May 24, 1961 or January 1, 2004.

• Dates that are not regular should start with the quality: estimated or calculated, if applicable. Example: est.
1961, or calc 2005. (Note that a quality does not need to be specified for regular dates.)

• After the quality should appear the type. If the type is before, after, or about, you scan specify the type by
writing "before", "after" or "about". If the type is a range, write "between DATE and DATE", and if the type
is a span, write "from DATE to DATE". patterns, where DATE is a single date.

Examples: est from 2001 to 2003, before June 1975, est about 2000, calc between May 1900 and January 1,
1990.

• Partial dates are entered simply by omitting unknown information. Examples: May 1961 and 2004.

• Alternate calendars are calendars other than the Gregorian calendar. Currently, GRAMPS supports Hebrew,
French Republican, Julian, Islamic, and Persian alternate calendars. To specify the calendar other than the
default Gregorian, append the name of the calendar to the date string, e.g. "January 9, 1905 (julian)".

3.7.2.3. Date Validity Indicators

GRAMPS uses color circles to indicate the validity of the entered date.

Date LED buttons

The color circles are also referred to as the LED buttons. Clicking on an LED button will invoke
the Date selection dialog described in detail below, see Section 3.7.2.4, “Graphical User Interface
for Entering Dates”

• A green circle means that the date is valid and complete regular date (e.g. May 24, 1961). In simple terms,
green means that the date corresponds to a unique date.

• Yellow circle means that the date is valid but is not a regular date. This could be the date of a different type:
a before date (before May 25, 1962), an after date (after May, 1960), an about date (about May 23, 1961), a
range (between May 1, 1961 and May 31, 1961), or a span (from May 1, 1961 to May 31, 1961). It can also
be a complete single date, but with quality of Estimated or Calculated. Finally, it could be a partial date, i.e.
a regular quality single date missing some portion, e.g. May 1961 or 1961.

While partial dates do not uniquely define the day, they allow at least for some type of comparisons between
the dates.
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• Red circle means that the date is not recognized as a valid date (e.g. "Christmas week of 61", or "the summer
when I had surgery"). In such a case the date will be stored as a text string and therefore cannot be compared
other dates. As you can see, it is best to avoid such date entries. It would be better, for example, to enter a date
of "December 1961" and then to add the note "Christmas week of '61."

3.7.2.4. Graphical User Interface for Entering Dates

While the above parsing rules provide a guide for you to type in most common dates, you can also use Date
selection dialog. The dialog is particularly useful for building a complex date or for simply insuring that your
information is entered in a way GRAMPS will understand. The Date selection dialog can be invoked by clicking
the colored circle button next to the date entry field.

Figure 3.18. Date selection dialog

The Calendar menu lets you choose a calendar other than the default Gregorian. The Quality menu gives you the
choices of Regular, Estimated, or Calculated. The Type menu allows you establish the exact date type: Regular,
Before, After, About, Range, Span, and Text only. You can set the Date by setting the day, the month, and the year.
In the event that your date type is Range or Span, the Second date will be activated. Finally, the Text comment
text entry field allows storing an arbitrary text string along with the date.

Note

If you have an important comment to make about a date, you are better off doing so in a Note that
corresponds to the event than in the Text comment field of the Date selection dialog. We recommend
this for the following reason: If you enter a date by typing it directly into the date field (that is, not
via the Date selector dialog), your entry will be copied and stored as the text comment string when
GRAMPS parses the entered text. Thus, any comment that may have been there prior to the parsing
will be overwritten.

3.7.3. Editing Information About Relationships
Information about relationships is entered and edited through the Family Editor dialog. This dialog may be invoked
in a number of ways:

• From Relationships View: click on an Edit button in the family that you want to edit.
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• From Family List View: select the family in the list and then click the Edit button on the Toolbar, or double-
click on the family.

• From Pedigree View: point your mouse over the black line connecting the spouses, right-click and select Edit
from the context menu, or double-click on the black line.

Any of these methods will prompt you with the following Family Editor dialog:

Figure 3.19. Family Editor dialog

The top of the window shows the names of the people whose relationship is being edited, as well as their birth
and death information. The main part of the window displays three Relationship Information fields and the seven
notebook tabs representing different categories of information about the relationship. Click any tab to view or
edit the information it contains. The bottom part has OK and Cancel buttons. Clicking the OK button at any time
will apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button at any time
will close the window without applying any changes. If any of the data in any tab is modified, an alert window
will appear that will prompt you choose between closing the dialog without saving changes, canceling the initial
cancel request, or saving the changes.

Note

Clicking OK will immediately save changes to the database. This version of GRAMPS does not have
a separate saving function, all changes are immediate.

Tip

If a tab label is in boldface type, this means it contains data. If not, it has no data.

The Relationship Information section fields have the basic desciption of the relationship. The GRAMPS ID field
displays the ID number which labels this relationship in the database. The available types (such as Married, Un-
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married, etc.) can be chosen from the drop-down Relationship type menu. The Marker allows you to specify some
basic information on the status of your research.

The tabs provide the following information categories of relationship data:

Children The Children tab lets you view and edit the list of children in this relationship. The + button
allows entering a new person to the database and adding that person as a child in this relationship.
The Select button lets you select an existing person to be a child in the relationship. The Edit
button allows for editing the relations between the selected child and the parents. Finally, the
- lets you remove the selected child from the relationship. Note that the Edit and - buttons become
available only when a child is selected from the list.

Note

Removing a child from the list does not delete that child from the database. It simply
removes the child from this relationship.

Events The Events tab lets you view and edit the list of events relevant to the relationship. The buttons
+, Edit, and - let you add, modify, or remove an event record from the database. Note that the
Edit and - buttons become available only when an event is selected from the list.

Note

Removing an event from the list does not delete that event from the database. It
simply removes the event reference from this relationship.

Sources The Sources tab lets you view and edit a list of references to the sources that provide evidence for
the relationship. These might be documents that refer to the relationship, but which do not nec-
essarily document it officially. For example, if Aunt Martha's memoirs mention that her great-
grandson Paul was married, the researcher may take this as evidence of the relationship between
Paul and his wife existed and cite the memoirs as the source for this assumption.

Tip

Sources that document specific events such as marriages or divorces are better filed
in relation to those events, under the Events tab.

The buttons +, Edit, and - allow let you add, modify, and remove a source reference to this
relationship. Note that the Edit and - buttons become available only when a source reference is
selected from the list.

Note

Removing an entry from the list does not delete that source from the database. It
simply removes the source reference from this relationship.

Attributes The Attributes tab lets you view and edit particular information about the relationship that can
be expressed as attributes. The buttons +, Edit, and - let you add, modify, or remove an attribute.
Note that the Edit and - buttons become available only when an attribute is selected from the list.

Notes The Notes tab lets you view and edit notes associated with the relationship. These could be any
comments which do not naturally fit into the "Parameter-Value" pairs available to Attributes. To
add a note or modify existing notes simply edit the text in the text entry field.

The Format option lets you set the way the note will appear in reports and web pages. If you
select Flowed, the text generated will have single spaces put in place of all multiple spaces, tabs,
and single end-of-line characters. A blank line inserted between two blocks of text will signal a
new paragraph; additional inserted lines will be ignored.
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If you select the Preformatted option, the text in reports and web pages will appear exactly as
you enter it in the Notes dialog.

Gallery The Gallery tab lets you store and display photos and other media objects associated with the
relationship. The central part of the window lists all such objects and gives you a thumbnail
preview of image files. Other objects such as audio files, movie files, etc., are represented by
a generic GRAMPS icon. The buttons +, Select, Edit, and - let you add a new image, add a
reference to an existing image, modify an existing image, and remove a media object's link to
the relationship. Note that the Edit and - buttons become available only when a media object is
selected from the list.

LDS The LDS (Latter Days Saints) tab displays information about the LDS Sealed to Spouse ordi-
nance. The data can include date, LDS temple, and Place. The status of the ordinance can be
described through the selections available in the Status pop-up menu and can also be referenced
in the corresponding Sources... and Note buttons.

3.7.4. Editing Information About Sources
To edit source data, switch to the Sources View and select the desired entry in the list of sources. Double-click
that entry or click the Edit icon on the toolbar to invoke the following Source Editor dialog:

Figure 3.20. Source Editor dialog

The main part of the window displays four notebook tabs containing different categories of information. Click a
tab to view or edit its contents. The bottom part of the window has OK and Cancel buttons. Clicking OK will apply
all the changes made in all tabs and close the dialog window. Clicking the Cancel button will close the window
without applying any changes.
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Note

Clicking OK will immediately save changes to the database (write on disk). All changes are imme-
diate.

Tip

If a tab label is in boldface type, this means it contains data. If not, it has no data.

The general information at the top of the window lets you define basic information about the source: its Title,
Author, Abbreviation, and Publication information. You can type this information directly into the adjacent fields.

The tabs provide the following information categories of source data:

Note The Note tab provides a place to record various information about the source that does not fit neatly into
other categories. To add a note or modify existing notes simply edit the text in the text entry field.

Gallery The Gallery tab lets you store and display photos and other media objects associated with a given
source (for example, a photo of a birth certificate). The central part of the window lists all such media
objects and gives you a thumbnail preview of image files. Other objects such as audio files, movie
files, etc., are represented by a generic GRAMPS icon. The buttons +, Select, Edit, and - let you add
a new image, add a reference to an existing image, modify an existing image, and remove a media
object's link to the source. Note that the Edit and - buttons become available only when a media object
is selected from the list.

Data The Data tab displays "Key/Value" pairs that may be associated with the source. These are similar to the
"Attributes" used for other types of GRAMPS records. The difference between these Key/Value pairs and
Attributes is that Attributes may have source references and notes, while Key/Value data may not.

The central part of the window lists all existing Key/Value pairs. The buttons + and - let you add and
remove pairs. To modify the text of Key or Value, first select the desired entry. Then click in either the
Key or Value cell of that entry and type your text. When you are done, click outside the cell to exit editing
mode.

Repositories The Repositories tab displays the references to the repositories in which the source is con-
tained. The list can be ordered by any of its column headings: ID, Title, Call Number,and
Type. Double-clicking an entry allows you to view and edit the record. You may also edit the
reference. The buttons on the side of the tab allow you add a new repository, link to (or share)
an existing repository, edit the reference to the repository, or remove the reference.

References The References tab lists all the database records that refer to this source, if any. The list can be
ordered by any of its column headings: Type, ID, or Name. Double-clicking an entry allows you
to view and edit the record.

Note

Only primary objects can be shown in the References tab: Person, Family, Event,
Place, or Media object. Secondary objects such as Names and Attributes can only
be accessed through the primary objects to which they belong.

3.7.5. Editing Information About Places

To edit information about places, switch to the Places View and select the desired entry from the list of places.
Double-click that entry or click the Edit button on the toolbar to bring up the following Place Editor dialog:
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Figure 3.21. Place Editor dialog

The main part of the window displays seven notebook tabs containing different categories of information. Click
a tab to view or edit its contents. The bottom part of the window has OK and Cancel buttons. Clicking OK will
apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button will close the
window without applying any changes.

Note

Clicking OK will immediately save changes to the database). All changes are immediate.

Tip

If a tab label is in boldface type and displays an icon, this means it contains data. If not, it has no data.

The tabs represent following categories of place data:

General The General tab you view and edit the basic information about the place: the Title which labels it
in the database, City, Church parish, County, State, Country, Longitude, and Latitude. You can type
this information directly into the adjacent fields.

Other names The Other names tab lets you view and edit other names by which the place might be known.
The bottom part of the window lists all other names of the place stored in the database. The
top part of the window shows the details of the currently selected name in the list (if any). The
buttons +, Edit, and - let you add, modify, and remove a name record. Note that the Edit and
- buttons become available only when a name is selected from the list.
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Note The Note tab displays any comments or notes concerning the place. To add a note or modify existing
notes simply edit the text in the text entry field.

Sources The Sources tab lets you view and edit sources relevant to a place. The central part of the window lists
all such source references stored in the database. The buttons +, Edit, and - let you add, modify, and
remove a source reference associated with a place. Note that the Edit and - buttons become available
only when a source reference is selected from the list.

Gallery The Gallery tab lets you store and display photos and other media objects associated with a given
place. The central part of the window lists all such media objects and gives you a thumbnail preview of
image files. Other objects such as audio files, movie files, etc., are represented by a generic GRAMPS
icon. The buttons +, Select, Edit, and - let you add a new image, add a reference to an existing image,
modify an existing image, and remove a media object's link to the place. Note that the Edit and
- buttons become available only when a media object is selected from the list.

Internet The Internet tab contains Internet addresses relevant to the place. The bottom part of the window
lists all such Internet addresses stored in the database. The top part shows the details of the currently
selected address in the list (if any). The buttons +, Edit, and - let you add, modify, and remove an
Internet address. The Go button (represented by an icon with a green arrow and yellow circle) opens
your browser and takes you to the web page corresponding to the highlighted Internet address. Note
that the Edit, -, and Go buttons become available only when an address is selected from the list.

References The References tab indicates any database records (events or LDS ordinances) that refer to a
place. This information cannot be modified from the Place Editor dialog. Instead, the correspond-
ing database record (e.g., a birth event) has to be brought up and its place reference edited.

3.7.6. Editing Information About Media Objects

To edit media data, switch to the Media View and select the desired entry in the list of sources. Double-click on
that entry or click Edit on the toolbar to invoke the following Media Properties Editor dialog:
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Figure 3.22. Media Properties Editor dialog

A thumbnail preview of the object is presented, along with a summary of its properties (ID, path, and object type).
The central part of the window displays five notebook tabs containing different categories of information. Click
a tab to view or edit its contents. The bottom part of the window has OK and Cancel buttons. Clicking OK will
apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button will close the
window without applying any changes.

Note

Clicking OK will immediately save changes to the database (write on disk). All changes are imme-
diate.

Tip

If a tab label is in boldface type, this means it contains data. If not, it has no data.

The tabs represent the following categories of media data:

General The General tab lets you view and edit the object's Title and Date. You can type this information
directly into the corresponding fields. For the Date, you can also enter information by clicking the
LED button and invoking the Date selection dialog.
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Note

Every media object is referred to by its Path. The user is responsible for keeping track
of the object files. GRAMPS will only reference and display the contents, not manage
the files themselves.

Attributes The Attributes tab lets you view and edit particular information about the media object that can
be expressed as Attributes. The bottom part displays the list of all such attributes stored in the
database. The top part shows the details of the currently selected attribute in the list (if any). The
buttons +, Edit, and - let you add, modify, or remove an attribute. Note that the Edit and - buttons
become available only when an attribute is selected from the list.

Notes The Note tab provides a place to record various information about the source that does not fit neatly
into other categories. This area is particularly useful for recording information that does not naturally fit
into the "Parameter/Value" pairs available to Attributes. To add a note or modify existing notes simply
edit the text in the text entry field.

References The References tab indicates any database records that refer to a given media object. The list
can be ordered according to any of its column headings: Type, ID, or Name. Double-clicking an
entry allows you to view and edit the corresponding record.

Note

Only primary objects can be shown in the References tab: Person, Family, Event,
Source, or Place. The secondary objects such as Names and Attributes, although
able to refer the media object, will only show up through their primary objects to
which they belong.

3.7.7. Editing Information About Events

Events are edited through the Event Editor dialog. This dialog can be accessed from either the Edit Person dialog
or the Marriage/Relationship dialog.



3.7.7. Editing Infor-
mation About Events

47

Figure 3.23. Event Editor dialog

The central part of the window displays five notebook tabs containing different categories of information. Click
a tab to view or edit its contents. The bottom part of the window has OK and Cancel buttons. Clicking OK will
apply all the changes made in all tabs and close the dialog window. Clicking the Cancel button will close the
window without applying any changes.

Tip

If a tab label is in boldface type, this means it contains data. If not, it has no data.

The tabs provide the following information categories of the event data:

General The General tab lets you view and edit basic information about the event: its Type, Date, Place,
Cause, and Description. You can type this information directly into the adjacent fields. The type can
be selected from available types listed in the Event type drop-down menu. The rest of the information
can be typed in the appropriate text entry fields. Checking the Private record box marks the event
record as private and allows it to be omitted from reports.

Sources The Sources tab lets you view and edit sources relevant to an event. The central part of the window
lists all such source references stored in the database. The buttons +, Edit, and - let you add, modify,
and remove a source reference associated with a place. Note that the Edit and - buttons become
available only when a source reference is selected from the list.

Note The Note tab provides a place to record notes or comments about the event. To add a note or modify
existing notes simply edit the text in the text entry field.
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3.7.8. Editing Source References

Source references connect a Source to another object and allow you to provide additional information about the
source. When adding source references to events, places, etc., the following dialog appears:

Figure 3.24. Source Information dialog

The dialog includes two main headings, Source selection and Source details. Source selection displays the Title of
the Source, its Author, and Publication information. The Title can be selected from the available sources listed in
the drop-down menu. If the source you are referencing is not already in the database, you can enter it by clicking
New... and filling out the invoked Source Editor dialog.

The Source details section indicates the details associated with the particular reference to this Source: Confidence,
Volume/Film/Page, Date, Text, and Comments. You can choose the Confidence level from the Confidence drop-
down menu. The remaining details can be typed in the corresponding text entry fields.
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Tip

Information in this dialog is specific to the particular reference. A single source can be referenced
many times, and all such references will have in common the overall source information. This dialog
lets you provide reference-specific data, such as relevant quotes, comments, confidence, page num-
bers, etc., to further specify and document the reference.

3.7.9. Names
Names are edited through the following Name Editor dialog:

Figure 3.25. Name Editor dialog

The top of the window shows the dialog title including the name of the person whose name is being edited. The
central part of the window displays three notebook tabs containing different categories of available information.
You can bring any tab to the top for viewing or editing by clicking on the appropriate tab heading. The bottom part
has OK and Cancel buttons. Clicking the OK button at any time will apply all the changes made in all tabs and close
the dialog window. Clicking the Cancel button at any time will close the window without applying any changes.

Tip

The tab labels reflect the presence of corresponding information: if the tab contains any data, its label
appears boldface; if the tab has no data then its label appears regular (not bold).

The tabs provide the following information categories of the name data:

General The General tab allows editing of general information about the name: given name, family name,
patronymic (a form of father's name used in some languages, e.g. Russian), family prefix, suffix, title,
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and type of the name. The information can be typed in the appropriate text entry fields. The family
name and the type can be also selected from available choices listed in the appropriate drop-down
menus.

Options allow you to adjust specific grouping, sorting, and displaying properties of this name, as
well as to provide the date corresponding to the name. The Grouping field provides an alternative
grouping node for a given name, overriding the default grouping based on the family name. This
may be necessary with similar family names that need to be grouped together -- for example Russian
names Ivanov and Ivanova are considered the same, but difference in gender is reflected in different
spelling. To enable typing into this field, check the Override check button. The Sort as and Display as
determine the manner in which the name appears in the People View and in the reports. The Date can
provide information on the validity of this name -- use spans as necessary. Check the Private record
box to mark this name record as private. This will give you a chance to omit this name from being
included in reports, if you choose so among the report generation options.

Sources The Sources tab displays information about sources relevant to this name and controls allowing its
modification. The central part displays the list of all such sources' references stored in the database.
The buttons +, Edit, and - allow you to correspondingly add, modify, and remove a source reference
to this name. Note that the Edit and - buttons become available only when a source reference is
selected from the list.

Note The Note tab displays any notes concerning the name. To add a note or modify existing notes simply edit
the text in the text entry field.

The Format option allows you to set the appearance of the note in the output (i.e. in reports and web
pages). Selecting Flowed will replace all multiple spaces, tabs, and single end-of-line characters with
single space in the output. The two consecutive new lines (i.e. an empty line) denote a new paragraph.
Selecting Preformatted will honor all multiple spaces tabs, and new lines, so that the output will appear
as it is entered into the text entry field.

3.7.10. Attributes

Attributes are edited through the following Attribute Editor dialog:
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Figure 3.26. Attribute Editor dialog

The top of the window shows the dialog title including the name of the person whose attribute is being edited. The
central part of the window displays three notebook tabs containing different categories of available information.
You can bring any tab to the top for viewing or editing by clicking on the appropriate tab heading. The bottom part
has OK and Cancel buttons. Clicking the OK button at any time will apply all the changes made in all tabs and close
the dialog window. Clicking the Cancel button at any time will close the window without applying any changes.

Tip

The tab labels reflect the presence of corresponding information: if the tab contains any data, its label
appears boldface; if the tab has no data then its label appears regular (not bold).

The tabs provide the following information categories of the attribute data:

General The General tab allows editing of the most general information about the attribute: name of the at-
tribute and its value. The information can be typed in the appropriate text entry fields. The attribute
name can also be selected from available choices (if any) listed in the Attribute drop-down menu.
Check the Private record box to mark this attribute record as private. This will give you a chance to
omit this attribute from being included in the reports, if you choose so among the report generation
options.

Sources The Sources tab displays information about sources relevant to this attribute and controls allowing its
modification. The central part displays the list of all such sources references stored in the database.
The buttons +, Edit, and - allow you to correspondingly add, modify, and remove a source reference
to this attribute. Note that the Edit and - buttons become available only when a source reference is
selected from the list.

Note The Note tab displays any notes concerning the attribute. To add a note or modify existing notes simply
edit the text in the text entry field.
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The Format option allows you to set the appearance of the note in the output (i.e. in reports and web
pages). Selecting Flowed will replace all multiple spaces, tabs, and single end-of-line characters with
single space in the output. The two consecutive new lines (i.e. an empty line) denote a new paragraph.
Selecting Preformatted will honor all multiple spaces tabs, and new lines, so that the output will appear
as it is entered into the text entry field.

3.7.11. Addresses
Addresses are edited through the following Address Editor dialog:

Figure 3.27. Address Editor dialog

The top of the window shows the dialog title including the name of the person whose address is being edited. The
central part of the window displays three notebook tabs containing different categories of available information.
You can bring any tab to the top for viewing or editing by clicking on the appropriate tab heading. The bottom part
has OK and Cancel buttons. Clicking the OK button at any time will apply all the changes made in all tabs and close
the dialog window. Clicking the Cancel button at any time will close the window without applying any changes.

Tip

The tab labels reflect the presence of corresponding information: if the tab contains any data, its label
appears boldface; if the tab has no data then its label appears regular (not bold).

The tabs provide the following information categories of the address data:

General The General tab allows editing of the most general information about the address: date, street address,
city or county, state or province, country, the postal code, and the phone number. The information
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can be typed in the appropriate text entry fields. Check the Private record box to mark this address
record as private. This will give you a chance to omit this address from being included in reports, if
you choose so among the report generation options.

Sources The Sources tab displays information about sources relevant to this address and controls allowing its
modification. The central part displays the list of all such sources references stored in the database.
The buttons +, Edit, and - allow you to correspondingly add, modify, and remove a source reference
to this address. Note that the Edit and - buttons become available only when a source reference is
selected from the list.

Note The Note tab displays any notes concerning the address. To add a note or modify existing notes simply
edit the text in the text entry field.

The Format option allows you to set the appearance of the note in the output (i.e. in reports and web
pages). Selecting Flowed will replace all multiple spaces, tabs, and single end-of-line characters with
single space in the output. The two consecutive new lines (i.e. an empty line) denote a new paragraph.
Selecting Preformatted will honor all multiple spaces tabs, and new lines, so that the output will appear
as it is entered into the text entry field.

3.7.12. Merging records

Sometime several records in the database turn out to be describing the same object: same person, same place, or
same source. It could happen either when the data is entered twice by mistake, or when new information reveals
that the two entries refer to the same person. It can also happen after importing GEDCOM obtained from a relative,
whose database overlaps with your existing data.

Whenever you detect duplicate records, merging them a useful way of correcting the situation.

Tip

To make a merge, exactly two records have to be selected in the appropriate view (People View,
Sources View, or Places View). This is accomplished by selecting one entry and then selecting an-
other person while holding down Ctrl key.

3.7.12.1. Merge People

There are two ways of merging personal records: Compare and Merge and Fast Merge, both available from the
Edit menu.

Note

Merging people does not discard any information with either method. The decisions you make during
the merge only affect which data will become primary and which will become secondary for the
resulting merged record.

Compare and Merge When exactly two people are selected, choose Edit->Compare and Merge... to invoke
Compare People dialog.
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Figure 3.28. Compare People dialog

The dialog allows you to make a decision on whether or not the selected records should
be merged. If you decide that the records should not be merged, despite similar names,
you may click Cancel to close the dialog without making any changes. If you decide to
proceed with merging, select the appropriate Select radio button to specify the record
to be used as the source of primary data, then click Merge and close.

The data from the other record will be kept as alternate data. Specifically, all names
from the other record will become alternate names of the merged record. Similarly,
parents, spouses, and children of the other record will become alternate parents, spous-
es, and children of the merged record, and so on.

Fast Merge When exactly two people are selected, choose Edit->Fast Merge to invoke Merge People dialog.

Figure 3.29. Merge People dialog

The dialog allows you to quickly merge two records, specifying the record to be used as the
source of primary data. The data from the other record will be kept as alternate data. Specifically,
all names from the other record will become alternate names of the merged record. Similarly,
parents, spouses, and children of the other record will become alternate parents, spouses, and
children of the merged record, and so on.
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Tip

If you are not certain whether or not you need to merge the records, or which record
to specify as the source of primary data, use Compare and Merge method described
above..

3.7.12.2. Merge Sources

When exactly two sources are selected, choose Edit->Compare and Merge... to invoke Merge Sources dialog.

Figure 3.30. Merge Sources dialog

The dialog allows you to make a decision on whether or not the selected records should be merged. If you decide
that the records should not be merged, despite similar titles, you may click Cancel to close the dialog without
making any changes. If you decide to proceed with merging, choose the appropriate radio button to specify the
title, author, abbreviated title, publication information, and the ID to be used for the merged record, then click OK.

3.7.12.3. Merge Places

When exactly two places are selected, choose Edit->Compare and Merge... to invoke Select title dialog.

Figure 3.31. Merge Places dialog

The dialog allows you to make a decision on whether or not the selected records should be merged. If you decide
that the records should not be merged, despite similar titles, you may click Cancel to close the dialog without
making any changes. If you decide to proceed with merging, choose the appropriate radio button to specify the
title of the merged record, or specify Other and enter new text, then click OK.
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3.8. Navigation
As long as any database is open, GRAMPS is focused on a single person usually referred to as an Active Person.
This allows you to view or modify the data concerning this person, his or her immediate family, etc. Navigating in
the database (i.e. moving from person to person) is in fact nothing else but changing the Active Person. This section
describes many alternative ways to navigate through the database using both the complex and the convenient
interfaces GRAMPS provides. All these ways eventually accomplish the same thing, but some are more convenient
than others, depending what you are doing in GRAMPS at the moment.

3.8.1. Using the People View
The most intuitive way to select an Active Person is to use the People View (see Section 2.1.2, “People View”).
When in the People View, just select the name of the desired person from the list by clicking that list entry. The
person you have selected becomes active. The statusbar updates to reflect the change of the active person.

3.8.2. Using the Family View
When in the Family View (see Section 2.1.3, “Relationships View”), you can easily navigate between the members
of the displayed family as follows:

• To make the currently selected spouse the Active Person, click the double-arrow button to the right of the
Active Person box. Alternatively, right-click into the spouse box and select Make the selected spouse an Active
Person item from the context menu.

• To make the currently selected parents the active family (thereby making father the Active Person and mother
the selected spouse), click the right-arrow button to the right of the active person's parents box. Alternatively,
right-click into the active person's parents box and select Make the selected parents the active family item
from the context menu.

• To make the currently selected spouse's parents the active family (thereby making father the Active Person and
mother the selected spouse), click the right-arrow button to the right of the spouse's parents box. Alternatively,
right-click into the spouse's parents box and select Make the selected parents the active family item from the
context menu.

• To make the currently selected child the Active Person, click the left-arrow button to the right of the children
box. Alternatively, right-click into the children box and select Make the selected child an Active Person item
from the context menu.

In addition to this, GRAMPS provides an extensive set of keyboard navigation options. The detailed reference to
the key bindings is found in the Appendix B, Keybindings reference.

3.8.3. Using the Pedigree View
The Pedigree View (see Section 2.1.5, “Pedigree View”) also allows you to move along the family tree. The benefit
of this method is that you can see more than one generation of the family tree. Also, you can jump directly from
a great-grandson to a great-grandfather without going through the intermediate generations.

Note that after changing the Active Person in the Pedigree View, the display is re-adjusted to show up to five
generations, starting from the newly selected Active Person. When in the Pedigree View, you can easily navigate
between the members of the displayed family tree as follows:

• To make any displayed person the Active Person, right-click the corresponding box and choose the first entry
in the context menu.

• To make a child of the currently Active Person (if any) the Active Person, click the left arrow button to the left
of the corresponding box. If there is more than one child, the button expands to the menu listing the children
to choose from.
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• To move the whole family tree one generation back, click on the corresponding right arrow button on the
right-hand side of the display area. Clicking the upper button will move the tree along the paternal line. Clicking
the lower button will move the tree along the maternal line.

Clicking either of these buttons is completely equivalent to double-clicking the lines connecting to the left of
the corresponding boxes for father and mother.

You can also quickly access any of the spouses, siblings, children, or parents of any displayed person. To do this,
move the mouse over the desired person's box and right-click to invoke a context menu. The appropriate menu
items will contain submenus listing all spouses, siblings, children, and parents of the corresponding person.

Advantages of using right-click menus

• Direct access to spouse and siblings

• Complete lists of all member of all categories, not only the preferred members.

3.8.4. Setting the Home Person

One and only one person in the database can be selected as the Home person. Once the Home person is selected,
moving to that person becomes a matter of a single click, regardless of which view you are using at the moment.

To set the Home person, first navigate to that person using any method you like. Then choose Edit->Set Home
person. Once this is done, you can move to the Home person from anywhere in the database by simply clicking
the Home icon on the toolbar. You can also choose Go->Home from the menu or select Home item from any
context menu available on the right click.

3.8.5. Using history-based tools

GRAMPS also features a powerful set of history-based navigation tools. These tools are similar to those commonly
used in web browsers. They include Back and Forward items available from the Go menu, context menus (available
in People, Family, and Pedigree views), and the toolbar buttons. They also include the list of the recent selections
available under the Go menu that allows you to jump directly to any of the recent selections. Finally, right-clicking
on the Back and Forward toolbar buttons invokes the popup menu with corresponding portion of the history. Select
any item from the menu to jump directly to it.

3.8.6. Bookmarking People

Similar to setting the Home person, you can bookmark other people from the database to simplify further naviga-
tion. To bookmark a person, first navigate to that person, then choose Bookmarks->Add bookmark. To move to
that person from anywhere in the database, choose Bookmarks->Go to bookmark->Person's name.

You can manage your bookmarks by choosing Bookmarks->Edit bookmarks.... This opens the following Edit
Bookmarks dialog with the list of bookmarks and the controls to modify this list.
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Figure 3.32. Edit Bookmarks dialog

3.8.7. Finding records
To find a record in a database, first switch to the appropriate View that provides the list of the desired records:
People, Sources, Places, or Media. Then start typing the name of a person or the title of a Source, Place, or Media
object that you are looking for, respectively. You may also press Ctrl+F to turn on the search mode, but simply
starting to type is also enough.

Figure 3.33. Type-ahead find

As you type, the first record in the list that is compatible with your input will be selected.

Finding People

For more complex people searches you may want to use filters. Enable filter controls by choosing
View->Filter, select the desired filter, and click Apply. For details, see Section 2.1.2.1, “Filters”

3.9. Generating Reports
Reports are the most common form of the output produced by genealogical research. The majority of genealogical
software puts a lot of emphasis on developing nice looking reports. GRAMPS is no exception in this regard,
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offering a choice of a variety of reports. GRAMPS can generate reports in a multitude of open formats, both text
based and graphical. GRAMPS can also produce screen based reports that are convenient for viewing a summary
of your database. Finally, GRAMPS can generate a web site suitable for immediate posting on the Internet. All of
these are almost infinitely flexible. If you wish to modify or extend the default format of GRAMPS report, you
can design and choose the style for each of your reports.

All reports can be accessed through the menu by choosing Reports->Report Type->Particular Report.
Alternatively, you can browse the complete selection of available reports along with their brief descriptions in a
Report Selection dialog invoked by clicking the Reports icon on the toolbar.

3.9.1. Substitution Values

Many of the graphical reports allow you to customize the information on the display. Variable substitutions are
used to substitute date for a particular symbol. There are two styles of variables. The difference between the two
styles is how empty data is handled.

The first style of variables are preceeded by a '$'. If the variable evaluates to an empty string, the variable is
replaced with the empty string. The second style of variables are preceeded by a '%'. If the variable evaluates to
an empty string, the line that contains the variable is removed from the output.

$n/%n Displays the person's name in the form of FirstName LastName

$N/
%N

Displays the person's name in the form of LastName, FirstName

$i/%i Displays the GRAMPS ID associated with the person.

$b/%b Displays the person's date of birth

$B/%B Displays the person's place of birth

$d/%d Displays the person's date of death

$D/
%D

Displays the person's place of death

$s/%s Displays the name of the person's preferred spouse in the form of FirstName LastName

$S/%S Displays the name of the person's preferred spouse in the form of LastName, FirstName.

$m/
%m

Displays the marriage date of the person and the preferred spouse.

$M/
%M

Displays the place assocated with the marriage of the person and the preferred spouse.

3.9.2. Books

Currently, the only available report under this category is the Book Report.

The Book Report creates a single document (i.e. a Book) containing a collection of graphical and textual reports.
Consequently, this allows for a very rich set of documents that GRAMPS can produce.

When Book Report is selected, the following book configuration dialog appears:
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Figure 3.34. Book Report dialog

The Book name text entry field is used to save the book (a set of configured selections) for future use. The top
pane lists the items available for inclusion in the book. The bottom pane lists the currently selected items in the
order they will appear in the book.

The horizontal set of buttons by the Book name field operates on the whole book. Click the Clear button to clear
all items from the current book. Click the Save button to save the current book (under the name typed in the Book
name text entry field) for future use.

Tip

Saving the book also saves the configuration for each item.

Click the Open button to load the book from the list of previously saved books. Finally, click the Edit books button
to invoke the editable list of available books.

The vertical set of buttons to the right of the bottom pane operates on the selected book item. Click the Add button
to add selected item from the available list to the current book. Click the Remove button to remove an item from
the current book. Use Up and Down to change the items order in the current book. Click the Setup button to
configure the options of the selected item of the current book.

The configuration dialogs invoked by Setup are item-specific. If you choose not to configure the item, same
defaults will be used for all needed options. The common option for almost all book items is the center person:
the person on whom the item is centered. Thanks to this option, you can create a book with items centered on
different people (e.g. your mom's and dad's ancestors as separate chapters). By default, the center person is set
to the Active Person.

Almost all items available for inclusion in the book are textual or graphical reports, and are therefore available in
the form of standalone reports. The exception is the following items which are only available as book items:

Title Page This item produces a customized Title page. You can configure the text of title, subtitle, and
the footer of the page. An image can be optionally placed between the subtitle and the footer.
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Because of its configurability, this item can be used to create title pages for the whole book,
its chapter, or even a single item.

Custom Text This item produces a page with three paragraphs, each containing custom text. The appearance
of the text can be adjusted by using custom styles. This item was meant to be used for epigraphs,
dedications, explanations, notes, and so forth.

3.9.3. Code Generators
This category contains reports that produce files that are meant to be processed by other programs. By themselves,
the files will not provide meaningful information; the files must first be processed by another program. The only
code generator currently available in GRAMPS is the Relationship Graph producing the GraphViz description
of the graph.

The Relationship Graph creates a complex relationship graph in GraphViz format. The GraphViz dot tool can
transform the graph into postscript, jpeg, png, vrml, svg, and other formats. GraphViz tools are freely available
from the GraphViz site [http://www.graphviz.org]. Specific options for this report include filter and number of
generations considered, as well as several GraphViz-specific options related to pagination, color, and details of
the graph.

Tip

If you are not interested in GraphViz code itself and just want to generate graphical output, GRAMPS
can do it for you under the hood. Look for Relationship Graph in the Graphical Reports category,
Section 3.9.4, “Graphical Reports”

3.9.4. Graphical Reports
Graphical reports represent information in forms of charts and graphs. Most of the options are common among
graphical reports, therefore they will be described only once, at the end of this section. The few options which are
specific to a given report will be described directly in that report's entry.

The following graphical reports are currently available in GRAMPS:

Ancestor Chart This report generates the chart of people who are ancestors of the Active
Person. Specific options include the number of generations considered and
the format of the displayed entries.

Ancestor Chart (Wall Chart) This report is similar to the Ancestor Chart report. It provides more options
which make it useful for generating huge charts suitable for a poster or a
wall chart. These options include the ability to compress the report (getting
rid of an empty space) and the option to fit the whole chart on to a single
page. In the latter case, the contents of the chart is scaled down appropri-
ately.

Descendant Graph This report generates a graph of people who are descendants of the Active
Person. Specific options include the format of the displayed entries.

Fan Chart This report produces a chart resembling a fan, with Active person in the
center, parents the the semicircle next to it, grandparents in the next semi-
circle, and so on, for a total of five generations.

Relationship Graph This report creates a complex relationship graph in GraphViz format and
then converts into graphical output running it through the the GraphViz dot
tool behind the scene. Specific options for this report include filter, options
for dates and places for the events, and whether to include URLs and IDs for
individuals and families. There are also several GraphViz-specific options
related to pagination, color, and details of the graph.

http://www.graphviz.org
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Statistics Chart This report can collect and display a wealth of statistical data about your
database. Specific options include filter, sorting methods, and additional
birth- and gender-based limit for inclusion into statistics. You can also set
the minimum number of items to qualify for the bar chart, so that the charts
with fewer items will generate a pie chart instead. The Chart Selection tab
allows you to check which charts you want to include in your report.

Timeline Graph This report outputs the list of people with their lifetimes represented by
intervals on a common chronological scale. Specific options include filter,
sorting method, and the title of the report.

Common options for graphical reports are the filename of the output, the format of the output, selected style, page
size and orientation. Optionally, the reports can be immediately opened with the default application.

Tip

The options used in reports are persistent: each report remembers its options used last time.

3.9.5. Text Reports
Text reports represent the desired information as formatted text. Most of the options are common among text
reports, therefore they will be described only once, at the end of this section. The options which are specific to a
given report will be described directly in that report's entry.

The following text reports are currently available in GRAMPS:

Ahnentafel Report This report lists the Active Person and his or her ancestors along with their
vital data. The people are numbered in a special way which is an established
standard called Ahnentafel. The Active Person is given number 1. His or
her father and mother have numbers 2 and 3, respectively. This rule holds
for every person while going back in generations: father's parents are num-
bered 4 and 5, and mother's parents are numbered 6 and 7, fathers always
numbered with even and mothers with odd numbers. Therefore, for any
person having number N in this tree, the numbers of father and mother are
2N and 2N+1, respectively.

Complete Individual Report This report provides individual summaries similar to that of the Individual
Summary report. The advantage of this report is the specific filter option.
Depending on the filter choice (Active Person only, his or her descendants,
his or her ancestors, or entire database), the report may contain from one to
many individual summaries. Another option for this report is the inclusion
of source information when listing events.

Comprehensive Ancestors Report This report produces a comprehensive description of ancestors of the Active
Person. The highlights of this report include elaborate layout, images of
children, present and former spouses, and source citations. Specific options:
number of backward generations to consider, whether to cite sources, and
whether to break pages between generations.

Descendant Report This report produces a brief description of descendants of the Active Per-
son. Specific options: number of forward generations to consider.

Detailed Ancestral Report This report covers in detail the ancestors of the active person. It includes
vital data (birth and death) as well as marriages. Specific options: number of
backward generations to consider, as well as a variety of options regarding
the exact contents to include.

Detailed Descendant Report This report covers in detail the descendants of the active person. It includes
vital (birth and death) information as well as marriages. Specific options:
number of forward generations to consider.
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FTM Style Ancestral Report This report creates an ancestral report similar to that produced by the Family
Tree Maker (tm) program. It covers in detail the Active Person and his/her
ancestors It includes vital information as well as marriages, children, and
notes. Specific options: number of backward generations to consider.

FTM Style Descendant Report This report creates a descendant report similar to that produced by the Fam-
ily Tree Maker (tm) program. It covers in detail the Active Person and his/
her descendants. It includes vital information as well as marriages, children,
and notes. Specific options: number of forward generations to consider.

Family Group Report This creates a family group report, showing information on a set of parents
and their children. Specific options: the spouse (available only if the Active
Person has more than one spouse).

Individual Summary This report produces a detailed summary on the active person. The report
includes all the facts known to the database about that person.

Common options for text reports are the filename of the output, the format of the output, selected style, page size
and orientation. For HTML reports, there is no page information. Instead, HTML options include the choice of
the HTML template, either available in GRAMPS or a custom template defined by you. Optionally, the reports
can be immediately opened with the default application.

Tip

The options used in reports are persistent: each report remembers its options used last time.

3.9.6. View Reports

View reports are representing overall summaries of the database information available immediately for on-screen
viewing. The following view reports are currently available in GRAMPS:

Number of ancestors This report displays the number of ancestors of the active person.

Summary of the database This report displays the overall statistics concerning number of individuals
of each gender, various incomplete entries statistics, as well as family and
media statistics.

3.9.7. Web Page

The only available report in this category is the Narrative Web Site report. It generates a web site (that is, a set
of linked web pages), for a set of selected individuals.

3.9.7.1. Narrative Web Site

Introduction GRAMPS 2.0.6 introduced the Narrative Web generator. The new tool pro-
vides considerably more functionality than the older web generator. Instead
of using HTML templates to customize the pages, CSS style sheets are used.

More information is now displayed about each person, along with informa-
tion about sources, places, and media objects. Introduction pages can be
added to provide additional information, such as family history.

Selecting the output Genealogy records can generate a lot of files. Many web servers have a dif-
ficult time with many files in a single directory. The Narrative Web Gener-
ator strives to keep the number of files per directory to a managable level.
To do this, a hierarchy of directores is created. The generated files names
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are not intuitive, but are unique per person. Subsequent runs will geneate
identical file names, making it easy to replace files.

By default, the output files are written to the specified directory. Because
of the number of files and directories that are created, it may be difficult to
transfer the files to an external web host. To aid in this, you may directly
create a gzip'd tar file to more easily upload the data. This is the format
that should be used if you would like to take advantage of the free geneal-
ogy page hosting at the GRAMPS web hosting site [http://family.gramps-
project.org].

To select the gzip'd tar file, select the Store web pages in .tar.gz archive
option.

Applying a filter Like the previous web page generator, and most of the other GRAMPS re-
ports, you can control what is included in the output by choosing a filter.
Several default filters are provided for you, but you are free to use the Cus-
tom Filter Editor tool to create your own.

Any person matching this filter who is not excluded due to the privacy rules,
will be included in the output. The default filter includes all people in the
database.

Applying a style sheet GRAMPS provides six built in style sheets for your web page. Each of these
style sheets produces a unique look for your pages. The generated style
sheet is named narrative.css. You may edit this file if you wish to
further customize your site.

If you make modifications to your style sheet, you need to be aware the
regenerating the pages with the same output directory will overwrite your
changes to this file. To prevent this from happening, make sure you choose
No style sheet for subsequent runs.

Character set encoding Because of GRAMPS internationalization ability, the default character set
for the HTML pages is UTF-8. This provides support for virtually all char-
acters.

The Apache web server is sometimes misconfigured to override the char-
acter set specified in an HTML page. This causes problems with the UTF-8
character set generated by GRAMPS, distorting characters on the screen.

If your web server is misconfigured and you do not have priveledge to fix
the configururation, you may solve this problem by overriding the default
character set to match what your web server may be expecting.

Copyright notice International copyright law reserves all rights to your data. You own the
data, and people must get your permission to use it. In genealogy, however,
sharing data is a common ideal. It this case, you may wish to grant the user
more rights.

While the default for GRAMPS is to place a notice indicating that all rights
are reserved, we give you the option to place your site under one of several
of the Create Commons licenses. With a Creative Commons license, you
grant user's certain permission to use your data without requiring them to
contact you directly for permission.

See the Creative Commons [http://creativecommons.org/] web site for
more information.

Controlling page generation Three additional pages can be generated by the web page generator. The
Home page is a page that will display an image and a whatever text you

http://family.gramps-project.org
http://creativecommons.org/
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wish. To enable this page, choose a Media Object from the Home Media/
Note ID menu on the Page Generation tab. If the Media Object contains an
image, the image is displayed at the top of the page. If the Media Object
contains a Note, the Note's text is used for the text of the page. A second
page, the Introduction page, works similarly. Just choose the Media Object
in the Introduction Media/Note ID menu.

If you choose to include a contact page, the researcher information stored
in the database is displayed, along with the information specified in the
Publisher contact/Note ID menu. Please use this page with caution, since
you may consider your contact information to be private.

Privacy Privacy of personal information is an important issue on the web today.
GRAMPS tries to give you control over the information that is presented.

GRAMPS provides two options to control the privacy of your information.
If you select the Do not include records marked private option, any data
that is marked as private will not be displayed on the generated site. If you
select Restrict information on living people, GRAMPS will attempt to de-
termine which people have the potential of still being alive, and will omit
these people from the database. Some countries have laws that indicate that
a certain number of years must pass after someone's death before informa-
tion can be published. The Years to restrict from person's death option al-
lows you to specifiy how many years a person must be deceased before the
information is included.

Please note that it is your responsibility to double check all information in
the pages for any privacy information. GRAMPS cannot be held responsi-
ble for any privacy issues.

Adding custom code your pages If you are not interested in customizing your pages, you may skip the sec-
tion.

The previous web generator allowed you to customize your pages using
HTML templates. Your data would be substituted for certain markers in
the code.

This method proved to be too cumbersome for most users. The Narrative
Web Page Generator introduces a simpler mechanism. On the Page Gener-
ation tab, you may specify text (including HTML code) that will be inserted
into each page, separately for the header and the footer.

To create this code, you need to create a Media Object marked as an internal
note. To create this, add a new Media Object in the Media View, and select
the internal note option. You may then enter your HTML code.

To insert the code from the internal notes into the web pages, select the
appropriate Media Objects from the HTML user header and HTML user
footer menus. Two div sections will be added to the pages - userheader and
userfooter. The corresponding HTML code is inserted into the HTML page
surrounded by div markers. You can customize your style sheet to provide
additional formatting and positioning information to control these sections.

3.10. Running Tools
GRAMPS tools allow you to perform various types of analysis of your genealogical data. Typically, the tools do
not produce output in form of printouts or files. Instead, they produce screen output immediately available for the
researcher. However, when appropriate, you can save the results of running a tool into a file. Tools present one of
the major strengths of GRAMPS compared to the most genealogical software.
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The tools can be accessed through the menu by choosing Tools->Tool Section->Particular Tool.
Alternatively, you can browse the complete selection of available tools along with their brief descriptions in a
Tool Selection dialog invoked by clicking the Tools icon on the toolbar.

3.10.1. Analysis and Exploration
This section contains tools which analyze and explore the database, but do not alter it. The following analysis and
exploration tools are currently available in GRAMPS:

Compare individual events This tool compares events across the selected group of people. The peo-
ple for this comparison are chosen with the use of custom filters. The cus-
tom filters can be created in the Custom Filter Editor (see Section 3.10.3.1,
“Custom Filter Editor”) that can be invoked by clicking the Custom Filter
Editor button. The resulting table produced by this tool can be saved as a
spreadsheet.

Interactive descendant browser This tool builds a tree with the Active Person being the root. Children
branch from their parents in the usual manner. Use this tool for a quick
glance of a person's descendants.

Tip

Double-clicking on tree node will bring up the Edit Person
dialog allowing to view or modify the personal data.

3.10.2. Database Processing
This section contains tools which may modify your database. The tools from this section are used mostly for finding
and correcting errors in the data. The following database processing tools are currently available in GRAMPS:

Note

The modifications will only be performed upon your explicit consent, except for the automatic fixes
performed by Check and repair database tool.

Check and repair database This tool checks the database for integrity problems, fixing the problems it
can. Specifically, the tool is checking for:

• Broken family links. These are the cases when a person's record refers
to a family while the family's record does not refer to that person, and
vice versa.

• Missing media objects. The missing media object is the object whose
file is referenced in the database but does not exist. This can happen
when the file is accidentally deleted, renamed, or moved to another lo-
cation.

• Empty families. These are the family entries which have no reference
to any person as their member.

• Parent relationship. This checks all families to ensure that father and
mother are not mixed up. The check is also made that parents have dif-
ferent gender. If they have common gender then their relationship is
renamed to "Partners".

Extract information from names This tool searches the entire database and attempts to extract titles and nick-
names that may be embedded in a person's Given name field. If any infor-
mation could be extracted, the candidates for fixing will be presented in the
table. You may then decide which to repair as suggested and which not to.
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Find possible duplicate people This tool searches the entire database, looking for the entries that may rep-
resent the same person.

Fix capitalization of family names This tool searches the entire database and attempts to fix the capitalization
of family names. The aim is to have conventional capitalization: capital first
letter and lower case for the rest of the family name. If deviations from this
rule are detected, the candidates for fixing will be presented in the table.
You may then decide which to repair as suggested and which not to.

Rename personal event types This tool allows all the events of a certain name to be renamed to a new
name.

Reorder GRAMPS IDs This tool reorders the GRAMPS IDs according to the defaults of GRAMPS.

3.10.3. Utilities
This section contains tools allowing you to perform a simple operation on a portion of data. The results can be
saved in your database, but they will not modify your existing data. The following utilities are currently available
in GRAMPS:

3.10.3.1. Custom Filter Editor

The Custom Filter Editor builds custom filters that can be used to select people included in reports, exports, and
other tools and utilities. This is in fact a very powerful tool in genealogical analysis.

When you launch it, the User defined filters dialog appears that lists all the filters (if any) previously defined by
you. Click the Add... button to define a new filter. Once you have designed your filters, you can edit, test, and
delete selected filters using the Edit..., Test..., and Delete buttons, respectively. All the filters displayed in the list
will be automatically saved along with your database and will be available with subsequent sessions of GRAMPS.

Note

The changes made to the filters only take effect when you click the Apply and close button.

Clicking the Add... button invokes the following Define filter dialog:

Figure 3.35. Define filter dialog
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Type the name for your new filter into the Name field. Enter any comment that would help you identify this filter
in the future into the Comment field. Add as many rules to the Rule list as you would like to your filter using
Add... button. If the filter has more than one rule, select one of the Rule operations. This allows you to choose
whether all rules must apply, only one (either) rule must apply, or exactly one (either) rule must apply, in order
for the filter to generate a match. If your filter has only one rule, this selection has no effect.

Check Return values that do not match the filter rules to invert the filter rule. For example, inverting "has a common
ancestor with I1" rule will match everyone who does not have a common ancestor with that person).

Clicking the Add... button invokes the following Add Rule dialog:

Figure 3.36. Add Rule dialog

The pane on the left-hand side displays available filter rules arranged by their categories in an expandable tree.
For detailed filter rule reference, see Appendix C, Filter rules reference. Click on the arrows to fold/unfold the
appropriate category. Select the rule from the tree by clicking on its name. The right-hand side displays the name,
the description, and the values for the currently selected rule. Once you are satisfied with your rule selection and
its values, click OK to add this rule to the rule list of the currently edited filter. Clicking Cancel will abort adding
the rule to the filter.

Tip

A filter you have already designed may be used as a rule for another filter. This gives you nearly
infinite flexibility in custom-tailoring your selection criteria that can be later used in most of the
exports, reports, and some of the tools (such as comparing individual events).

3.10.3.2. Scratch Pad

This tool provides a temporary note pad to store database records for easy reuse. In short, this is a sort of the
copy-and-paste functionality extended from textual objects to other types of records used in GRAMPS.

Tip

Scratch Pad makes extensive use of drag-and-drop technique.

To invoke Scratch Pad, either choose Tools->Utilities->Scratch Pad or click the ScratchPad button on the toolbar.
The following window will appear:
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Figure 3.37. Scratch Pad tool

Scratch Pad supports addresses, attributes (both personal and family), events (both personal and family), names,
media objects references, source references, URLs, and of course textual information of notes and comments. To
store any type of these records, simply drag the existing record on to the Scratch Pad from the corresponding
editor dialog. To reuse the record, drag it from the Scratch Pad on to the corresponding place in the editor, e.g.
Address tab, Attribute tab, etc.

Tip

Some objects are showing the link icon on the left. This indicates that dragging such selection will
produce a reference to an existing object, not copy the object itself.

For example, the media object file will not be duplicated. Instead, the reference will be made to an
existing media object, which will result in the local gallery entry.

Tip

Scratch Pad storage is persistent within a single GRAMPS session. Closing the window will not lose
the stored records. However, exiting GRAMPS will.

3.10.3.3. Other tools

Generate SoundEx codes This utility generates SoundEx codes for the names of people in
the database. Please visit the NARA Soundex Indexing page [http://
www.archives.gov/research_room/genealogy/census/soundex.html] to learn
more about Soundex Indexing System.

Relationship calculator This utility calculates and displays the relationship of any person to the Ac-
tive Person.

Verify the database This utility allows you to verify the database based on the set of criteria spec-
ified by you.

Difference between Verify tool and
previously described Check tool

The Check tool detects inconsistencies in the database struc-
ture. The Verify tool, however, is detecting the records that do
not satisfy your particular criteria.

For example, you may want to make sure that nobody in your database had
children at the age of 98. Based on common sense, such a record would indi-
cate an error. However, it is not a consistency error in the database. Besides,

http://www.archives.gov/research_room/genealogy/census/soundex.html
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someone might have a child at the age of 98 (although this rarely happens).
The Verify tool will display everything that violates your criteria so that you
can check whether the record is erroneous or not. The ultimate decision is
yours.
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Chapter 4. Settings
4.1. Preferences
Most of the settings in GRAMPS, are configured in the Preferences dialog. To invoke it, choose Edit->Prefer-
ences....

Figure 4.1. Preferences dialog

The tabs on the top display the available option categories.

4.1.1. General
This category contains preferences relevant to the general operation of the program. Options are:

Automatically load last database Check this box to automatically load the last open database on startup.

Add default source on import This option affects the importing of data. If this is set, each item that is
imported will contain a source reference to the imported file.

Note

Adding a default source can significantly slow down the im-
porting your data.

Enable spelling checker This option controls the enabling and disabling of the spelling checker for
notes. The gtkspell package must be loaded for this to have an effect.

Display Tip of the Day This option controls the enabling and disabling of the Tip of the Day dialog
at startup.

Use shading in Relationship View This option controls the enabling and disabling of shading in the Relation-
ship View. If enabled, information will be grouped together in regions with
a shaded background.
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Enable database transactions This option controls the enabling and disabling of transactions during
database operations.

Warning

Care must be taken with selecting this option. By default,
transactions are enabled. This improves database perfor-
mance and protects database integrity. However, if your sys-
tem is using a version of the Python language prior to version
2.5, your database will not be portable to other machines, and
if you want to transfer your data to another machine, you will
need to export using the GRAMPS XML format. Disabling
this option will allow databases to be portable, but at a risk of
database integrity problems.

4.1.2. Display
This category contains preferences relevant to the display of data. Options are:

Date format This option controls the display of dates. Several different formats are avail-
able, which may be dependent on your locale.

Surname Guessing This option affects the initial family name of a child when he/she is added
to the database.

Tip

This option only affects the initial family name guessed by
GRAMPS when the Edit Person dialog is launched. You can
modify that name the way you see fit. Set this option to the
value that you will most frequently use, as it will save you a
lot of typing.

If None is selected, no guessing will be attempted. Selecting Father's sur-
name will use the family name of the father. Selecting Combination of
mother's and father's surname will use the father's name followed by the
mother's name. Finally, Icelandic style will use the father's given name fol-
lowed by the "sson" suffix (e.g. the son of Edwin will be guessed as Ed-
winsson).

Status bar This option controls the information displayed in the status bar. This can
be either the Active Person's name and GRAMPS ID or Active Person's
relationship to the Home person.

Show text in sidebar buttons This option controls whether or not a text description is displayed next to
the icon in the sidebar. This option takes effect after the program has been
restarted.

4.1.3. Name Display
This category contains preferences relevant to the display of names. In GRAMPS there are two type of name
display formats: the predefined formats, and the user defined custom formats. The predefined formats are:

• Family name, Given name Patronymic

• Given name Family name

• Patronymic, Given name

• Given name
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When predefined formats are not suitable one can define it's own format.

Display format The system wide name format is selected here from a list, which contains both
the predefined and custom name formats (if any).

Note

Besides the system wide setting GRAMPS allows deciding the
name display format individually for every single name via the
Name Editor dialog (see Section 3.7.9, “Names”).

Custom format details It expands the custom format handling user interface.

Note

Custom name display formats are stored in the databases, thus be-
fore loading any database the Custom format details expander is
disabled.

Add Opens the Name Format Editor window to define a new custom for-
mat.

Remove Deletes the selected custom Name Display format.

Edit Opens the Name Format Editor window to modify the selected cus-
tom Name Display format.

4.1.3.1. Name Format Editor

New formats are created, and existing formats are modified using this editor.

Format name The name of the custom format. The format name can be any string, it is
used only to recognize the format later on the Display format list.

Format definition The actual format is defined here using special formatting characters. Be-
fore and after these special characters any other character or string is al-
lowed. For exmple:  "(%t) %L, %f" will give "(Dr.) SMITH,
Edwin". The formatting characters are:

Character Name Character Name

%f Given Name %F GIVEN NAME

%l Surname %L SURNAME

%t Title %T TITLE

%p Prefix %P PREFIX

%s Suffix %S SUFFIX

%c Call name %C CALL NAME

%y Patronymic %Y PATRONYMIC

Example Shows a dynamic example how the name will be displayed with the current
Format definition string.

Format definition details Shows a quick reminder of the special formatting characters.

4.1.4. ID Formats
This category contains preferences relevant to the automatic generation of GRAMPS IDs.
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Tip

The ID prefixes use formatting conventions common for C, Python, and other programming lan-
guages. For example, the %04d expands to an integer, prepended with zeros to have the total width
of four digits. If you would like IDs to be 1, 2, 3, etc, simply set the formatting parameter to %d.

Person Provides the template for generating IDs for a Person.

Family Provides the template for generating IDs for a Family.

Place Provides the template for generating IDs for a Place.

Source Provides the template for generating IDs for a Source.

Media Object Provides the template for generating IDs for a Media Object.

Event Provides the template for generating IDs for an Event.

Repository Provides the template for generating IDs for a Repository.

4.1.5. Warnings
This category controls the display of warning dialogs, allowing the re-enabling of dialogs that have been disabled.

4.1.6. Researcher Information
Enter your personal information in the corresponding text entry fields. Although GRAMPS requests information
about you, this information is used only so that GRAMPS can create valid GEDCOM output files. A valid GED-
COM file requires information about the file's creator. If you choose, you may leave the information empty, how-
ever none of your exported GEDCOM files will be valid.

4.1.7. Marker Colors
This category controls the highlight color of items in the Person list when a marker has been set for a person.

4.2. Other settings
Besides Preferences dialog, there are other settings available in GRAMPS. For various reasons they have been
made more readily accessible, as listed below.

Column Editor The columns of the list views may be added, removed, or reordered in a Col-
umn Editor Dialog, see Figure 2.4, “Column Editor Dialog”. Only checked
columns will be shown in the view. To change their order, drag any column
to its desired place inside the editor. Clicking OK will reflect the changes in
the appropriate view. To invoke Column Editor Dialog, choose Edit->Col-
umn Editor....

Tip

The Column Editor is available and works in the same way
for all list views. Specifically, it is available for People View,
Family View (children list). Sources View, Places View, and
Media View.

Setting Home person The Home person is the person who becomes active when database opened,
when Home button is clicked or the Home menu item is selected from either
Go menu or the right-click context menu anywhere.
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To set Home person, make the desired person active and then choose Ed-
it->Set Home person....

Adjusting viewing controls Whether the toolbar, the sidebar, or the filter (People View only) are dis-
played in the main window is adjusted through the View menu.

4.3. Advanced manipulation of settings
Warning

The contents of this section is outside the scope of interest of a general user of GRAMPS. If you
proceed with tweaking the options on the low level you may damage your GRAMPS installation.
Be careful. YOU HAVE BEEN WARNED!

By default, GRAMPS stores its settings using gconf2 system. All the settings used in this version of GRAMPS
are stored in subdirectories under /apps/gramps/ in the gconf2 namespace. Accessing the keys can be done
either using gconftool-2 command line tool, or the gconf-editor GUI tool.

All keys are documented, and the notification mechanisms are used as appropriate. Therefore, updating keys from
outside of GRAMPS should lead to updating GRAMPS in real time, without necessarily restarting it.
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Appendix A. Frequently Asked
Questions
This appendix contains the list of questions that frequently come up in mailing list discussions and forums. This
list is by no means complete. If you would like to add questions/answers to this list, please email your suggestions
to gramps-devel@lists.sf.net [mailto:gramps-devel@lists.sf.net]

What is GRAMPS? GRAMPS is the Genealogical Research and Analysis Management Pro-
gram System. In other words, it is a personal genealogy program letting
you store, edit, and research genealogical data using the powers of your
computer.

Where do I get it and how much
does it cost?

GRAMPS can be downloaded from http://sf.net/projects/gramps at no
charge. GRAMPS is an Open Source project covered by the GNU General
Public License. You have full access to the source code and are allowed to
distribute the program and source code freely.

Does it work with Windows (tm)? No. GRAMPS uses the GTK and GNOME libraries. While the GTK li-
braries have been ported to Windows, the GNOME libraries have not. This,
however, may change in the future.

Does it work with the Mac? The Fink project [http://fink.sourceforge.net] has ported  some older ver-
sions [http://fink.sourceforge.net/pdb/package.php/gramps] of GRAMPS
to OSX (tm). The Mac OSX port is not directly supported by the GRAMPS
project, primarily because none of the GRAMPS developers have access to
Mac OSX and because OSX is not Free Software.

This version of GRAMPS (2.2.0) does not appear to have been ported by
the Fink project. Please contact the Fink project for more information.

Some people have had success using the DarwinPorts instead of the Fink
project.

Does it work with KDE? Yes, as long as the required GNOME libraries are installed.

Do I really have to have GNOME
installed?

Yes, but you do not have to be running the GNOME desktop.

What version of GNOME do I
need?

This version of gramps requires GNOME 2.8.0 or higher. Previous versions
in 1.0.x series required GNOME 2.0.

Is GRAMPS compatible with other
genealogical software?

GRAMPS makes every effort to maintain compatibility with GEDCOM,
the general standard of recording genealogical information. We have import
and export filters that enable GRAMPS to read and write GEDCOM files.

It is important to understand that the GEDCOM standard is poorly imple-
mented -- virtually every genealogical software has its own "flavor" of
GEDCOM. As we learn about new flavor, the import/export filters can be
created very quickly. However, finding out about the unknown flavors re-
quires user feedback. Please feel free to inform us about any GEDCOM
flavor not supported by GRAMPS, and we will do our best to support it!

Can GRAMPS read files created by
other genealogy programs?

See above.

Can GRAMPS write files readable
by other genealogy programs?

See above.

mailto:gramps-devel@lists.sf.net
http://sf.net/projects/gramps
http://fink.sourceforge.net
http://fink.sourceforge.net/pdb/package.php/gramps
http://fink.sourceforge.net/pdb/package.php/gramps
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Can GRAMPS print a genealogical
tree for my family?

Yes. Different people have different ideas of what a genealogical tree is.
Some think of it as a chart going from the distant ancestor and listing all
his/her descendants and their families. Others think it should be a chart
going from the person back in time, listing the ancestors and their families.
Yet other people think of a table, text report, etc.

GRAMPS can produce any of the above, and many more different charts
and reports. Moreover, the plugin architecture enables users (you) to create
their own plugins which could be new reports, charts, or research tools.

In what formats can GRAMPS out-
put its reports?

Text reports are available in HTML, PDF, AbiWord, KWord, LaTeX, RTF,
and OpenOffice formats. Graphical reports (charts and diagrams) are avail-
able in PostScript, PDF, SVG, OpenOffice, and GraphViz formats.

Is GRAMPS compatible with the
Internet?

GRAMPS can store web addresses and direct your browser to them. It can
import data that you download from the Internet. It can export data that
you could send over the Internet. GRAMPS is familiar with the standard
file formats widely used on the Internet (e.g. JPEG, PNG, and GIF images,
MP3, OGG, and WAV sound files, QuickTime, MPEG, and AVI movie
files, etc). Other than that, there is little that a genealogical program can do
with the Internet.

Can I create custom reports/filters/
whatever?

Yes. There are many levels of customization. One is creating or modifying
the templates used for the reports. This gives you some control over the
fonts, colors, and some layout of the reports. You can also use GRAMPS
controls in the report dialogs to tell what contents should be used for a par-
ticular report. In addition to this, you have an ability to create your own
filters -- this is useful in selecting people based on criteria set by you. You
can combine these filters to create new, more complex filters. Finally, you
have an option to create your own plugins. These may be new reports, re-
search tools, import/export filters, etc. This assumes some knowledge of
programming in Python.

What standards does GRAMPS
support?

The nice thing about standards is that there never is a shortage of them.
GRAMPS is tested to support the following flavors of GEDCOM: GED-
COM5.5, Brother's Keeper, Family Origins, Family Tree Maker, Ftree, Ge-
neWeb, Legacy, Personal Ancestral File, Pro-Gen, Reunion, and Visual Ge-
nealogie.

What is the maximum database size
(bytes) GRAMPS can handle?

GRAMPS has no hard limits on the size of a database that it can handle.
Starting with this release, GRAMPS no longer loads all data into memory,
which allows it to work with a much larger database than before. In reality,
however, there are practical limits. The main limiting factors are the avail-
able memory on the system and the cache size used for BSDDB database
access. With common memory sizes these days, GRAMPS should have no
problem using databases with tens of thousands of people.

How many people can GRAMPS
database handle?

We have found that on a typical system, GRAMPS tends to bog down after
the database has around 150,000 people. Again, this is dependent on how
much memory you have.

Why is GRAMPS running so slow-
ly?

It does not anymore! Just try out the current version, 2.2.0.

My database is really big. Is there a
way around loading all the data into
memory?

Starting with this release, GRAMPS no longer loads all data into memory,
which allows it to work with a much larger database than before.

I want to rerun the Startup dialog.
How do I do this?

GRAMPS keeps a flag in the GNOME configuration database to indicate
that the startup dialog has been run. To cause GRAMPS to rerun this, the
flag needs to be reset. This can be done with the following command:
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gconftool-2 -u /apps/gramps/behavior/startup

Why are non-latin characters dis-
played as garbage in PDF/PS re-
ports?

This is a limitation of the builtin fonts of PS and PDF formats. To print
non-latin text, use the Print... in the format selection menu of the report
dialog. This will use the gnome-print backend, which supports PS and PDF
creation, as well as direct printing.

If you only have latin text, the PDF option will produce a smalled PDF
compared to that created by gnome-print, simply because no font informa-
tion will be embedded.

Why can I not add/remove/edit
columns to the lists in People View
and Family View?

Now you can! Just try out the current version, 2.2.0.

I would like to contribute to
GRAMPS by writing my favorite
report. How do I do that?

The easiest way to contribute to reports, filters, tools, etc. is to copy
an existing GRAMPS report, filter, or tool. If you can create what you
want by modifying existing code -- great! If your idea does not fit in-
to the logic of any existing GRAMPS tool, the following page [http:/
/gramps.sourceforge.net/phpwiki/index.php/GrampsDevelopersPage] may
provide some help in writing your own plugin from scratch.

If you need more help or would like to discuss your idea with us, please
do not hesitate to contact us at gramps-devel@lists.sf.net [mailto:gramps-
devel@lists.sf.net]

To test your work in progress, you may save your plugin under $HOME/
.gramps/plugins directory and it should be found and imported on
startup. The correctly written plugin will register itself with GRAMPS, cre-
ate menu item, and so on.

If you are happy with your plugin and would like to contribute your code
back to the GRAMPS project, you are very welcome to do so by contacting
us at gramps-devel@lists.sf.net [mailto:gramps-devel@lists.sf.net]

I found a bug and I want it fixed
right now! What do I do?

The best thing you can do is to fix the bug and send the patch to gramps-
devel@lists.sf.net [mailto:gramps-devel@lists.sf.net] :-)

A good bug report would include:

• Version of gramps you were using when you encountered the bug
(available through Help->About menu item).

• Language under which gramps was run (available by executing

echo $LANG

in your terminal).

• Symptoms indicating that this is indeed a bug.

• Any Traceback messages, error messages, warnings, etc, that showed
up in your terminal or a in separate traceback window.

Most problems can be fixed quickly provided there is enough information.
To ensure this, please follow up on your bug reports. In particular, if you
file a bug report with sf.net bug tracker, PLEASE log in to sf.net before
filing (register your free account if you don't have one). Then we will have
a way of contacting you should we need more information. If you choose

http://gramps.sourceforge.net/phpwiki/index.php/GrampsDevelopersPage
mailto:gramps-devel@lists.sf.net
mailto:gramps-devel@lists.sf.net
mailto:gramps-devel@lists.sf.net
mailto:gramps-devel@lists.sf.net
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to file your report anonymously, at least check every so often whether your
report page has something new posted, as it probably would.

If the above explanations seem vague, please follow this link. [http://
www.chiark.greenend.org.uk/~sgtatham/bugs.html]

It is obvious that GRAMPS abso-
lutely needs to become a (client-
server/web-based/PHP/weblog/
Javascript/C++/distributed/KDE/
Motif/Tcl/Win32/C#/You-name-it)
application. When is this going to
happen?

The surest way to see it happen is to get it done by yourself. Since GRAMPS
is free/open source, nobody prevents you from taking all of the code and
continuing its development in whatever direction you see fit. In doing so,
you may consider giving your new project another name to avoid confu-
sion with the continuing GRAMPS development. If you would like the
GRAMPS project to provide advice, expertise, filters, etc., we will gladly
cooperate with your new project, to ensure compatibility or import/export
options to your new format of a project.

If, however, you would like the GRAMPS project to to adopt your strategy,
you would need to convince GRAMPS developers that your strategy is good
for GRAMPS and superior to the present development strategy.

http://www.chiark.greenend.org.uk/~sgtatham/bugs.html
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Appendix B. Keybindings reference
Most of the standard menu items define equivalent keybindings. These are apparent because they are displayed
on the right of the menu item. However, some keybindings are not associated with any items in the menu.

This appendix contains the list of keybindings that are not displayed in menus of GRAMPS.

B.1. List Views

B.1.1. Common bindings
The following bindings are available in all list views: People View, Sources View, Places View, and Media View.

Key Function

<Alt>N Changes the view to the next view

<Alt>P Changes the view to the previous view

<Alt>S Open the Scratch Pad

<Ctrl>B Edit the bookmarks

<Ctrl>D Add the selected item as a bookmark

<Ctrl>H Open the Undo History dialog

B.1.2. People View bindings

Key Function

<Ctrl>Enter Edits the selected person

<Ctrl>Insert Adds a new person to the database

<Ctrl>Delete Deletes the selected person
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Appendix C. Filter rules reference
This appendix lists of all the filter rules currently defined in GRAMPS. Each of these rules is available for use
when creating custom filters, see Section 3.10.3.1, “Custom Filter Editor”. The rules are listed by their categories.

C.1. General filters
This category includes the following most general rules:

Has complete record This rule matches all people whose records are marked as complete. Cur-
rently, the completeness of personal information is marked manually, in the
Edit Person dialog.

People with incomplete names This rule matches all people with either given name or family name missing.

Is bookmarked person This rule matches all people who are on the bookmark list.

Has text matching substring of This rule matches all people whose records contain specified substring. All
textual records are searched. Optionally, the search can be made case sen-
sitive, or a regular expression match.

Everyone This rule matches any person in the database. As such it is not very useful
on its own except for testing purposes. However, it may be useful in com-
binations with other rules.

People probably alive This rule matches all people whose records do not indicate their death and
who are not unreasonably old, judging by their available birth data and
today's date.

Has a name This rule matches any person whose name matches the specified value in
full or in part. For example, Marta Ericsdotter will be matched by the rule
using the value "eric" for the family name.

Separate values can be used for Given name, Family name, Suffix, and the
Title. The rule returns a match if, and only if, all non-empty values are
(partially) matched by a person's name. To use just one value, leave the
other values empty.

Has the Id This rule matches any person with a specified GRAMPS ID. The rule re-
turns a match only if the ID is matched exactly.

You can either enter the ID into a text entry field, or select a person from
the list by clicking Select... button. In the latter case, the ID will appear in
the text field after the selection was made.

Is default person This rule matches the default (home) person.

People marked private This rule matches people whose records are marked as private.

Is a female This rule matches any female person.

People who have images This rule matches people with images in their galleries.

People without a birth date This rule matches people missing birth date.

Is a male This rule matches any male person.

C.2. Event filters
This category includes the following rules that match people based on their recorded events:
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Has the birth This rule matches people whose birth event matches specified values for
Date, Place, and Description. The rule returns a match even if the person's
birth event matches the value partially. The matching rules are case-insen-
sitive. For example, anyone born in Sweden will be matched by the rule
using the value "sw" for the Place.

The rule returns a match if, and only if, all non-empty values are (partially)
matched by a person's birth. To use just one value, leave the other values
empty.

Has the death This rule matches people whose death event matches specified values for
Date, Place, and Description. The rule returns a match even if the person's
death event matches the value partially. The matching rules are case-insen-
sitive. For example, anyone who died in Sweden will be matched by the
rule using the value "sw" for the Place.

The rule returns a match if, and only if, all non-empty values are (partially)
matched by a person's death. To use just one value, leave the other values
empty.

Has source of This rule matches people whose records refer to the specified source.

Has the personal event This rule matches people that have a personal event matching specified
values for the Event type, Date, Place, and Description. The rule returns a
match even if the person's event matches the value partially. The matching
rules are case-insensitive. For example, anyone who graduated in Sweden
will be matched by the rule using the Graduation event and the value "sw"
for the Place.

The personal events should be selected from a pull-down menu. The rule
returns a match if, and only if, all non-empty values are (partially) matched
by the personal event. To use just one value, leave the other values empty.

Has the family event This rule matches people that have a family event matching specified values
for the Event type, Date, Place, and Description. The rule returns a match
even if the person's event matches the value partially. The matching rules
are case-insensitive. For example, anyone who was married in Sweden will
be matched by the rule using the Marriage event and the value "sw" for the
Place.

The family events should be selected from a pull-down menu. The rule
returns a match if, and only if, all non-empty values are (partially) matched
by the personal event. To use just one value, leave the other values empty.

Witness This rule matches people who are present as a witness in the event. If the
personal or family event type is specified, only the events of this type will
be searched.

People with incomplete events This rule matches people missing date or place in any personal event.

Families with incomplete events This rule matches people missing date or place in any family event of any
of their families.

C.3. Family filters
This category includes the following rules that match people based on their family relationships:

People with children This rule matches people with children.
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People with multiple marriage
records

This rule matches people with more than one spouse.

People with no marriage records This rule matches people with no spouses.

People who were adopted This rule matches adopted people.

Has the relationships This rule matches people with a particular relationship. The relationship
must match the type selected from the menu. Optionally, the number of
relationships and the number of children can be specified.

The rule returns a match if, and only if, all non-empty values are (partially)
matched by a person's relationship. To use just one value, leave the other
values empty.

Is spouse of filter match This rule matches people married to someone who is matched by the spec-
ified filter. The specified filter name should be selected from the menu.

Is a child of filter match This rule matches people for whom either parent is matched by the specified
filter. The specified filter name should be selected from the menu.

Is a parent of filter match This rule matches people whose child is matched by the specified filter. The
specified filter name should be selected from the menu.

Is a sibling of filter match This rule matches people whose sibling is matched by the specified filter.
The specified filter name should be selected from the menu.

C.4. Ancestral filters
This category includes the following rules that match people based on their ancestral relations to other people:

Is an ancestor of This rule matches people who are ancestors of the specified person. The
Inclusive option determines whether the specified person should be consid-
ered his/her own ancestor (useful for building reports).

You can either enter the ID into a text entry field, or select a person from
the list by clicking Select... button. In the latter case, the ID will appear in
the text field after the selection was made.

Is an ancestor of person at least N
generations away

This rule matches people who are ancestors of the specified person and are
at least N generations away from that person in their lineage. For example,
using this rule with the value of 2 for the number of generations will match
grandparents, great-grandparents, etc., but not the parents of the specified
person.

Is an ancestor of person not more
than N generations away

This rule matches people who are ancestors of the specified person and are
no more than N generations away from that person in their lineage. For
example, using this rule with the value of 2 for the number of generations
will match parents and grandparents, but not great-grandparents, etc., of the
specified person.

Has a common ancestor with This rule matches people who have common ancestors with the specified
person.

Has a common ancestor with filter
match

This rule matches people who have common ancestors with someone who is
matched by the specified filter. The specified filter name should be selected
from the menu.

Is an ancestor of filter match This rule matches people who are ancestors of someone who is matched
by the specified filter. The specified filter name should be selected from
the menu.
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C.5. Descendant filters
This category includes the following rules that match people based on their descendant relations to other people:

Is a descendant of This rule matches people who are descendants of the specified person. The
Inclusive option determines whether the specified person should be consid-
ered his/her own descendant (useful for building reports).

You can either enter the ID into a text entry field, or select a person from
the list by clicking Select... button. In the latter case, the ID will appear in
the text field after the selection was made.

Is a descendant of person at least N
generations away

This rule matches people who are descendants of the specified person and
are at least N generations away from that person in their lineage. For exam-
ple, using this rule with the value of 2 for the number of generations will
match grandchildren, great-grandchildren, etc., but not the children of the
specified person.

Is a descendant of person not more
than N generations away

This rule matches people who are descendants of the specified person and
are no more than N generations away from that person in their lineage. For
example, using this rule with the value of 2 for the number of generations
will match children and grandchildren, but not great-grandchildren, etc., of
the specified person.

Is a descendant of filter match This rule matches people who are descendants of someone who is matched
by the specified filter. The specified filter name should be selected from
the menu.

Is a descendant family member of This rule not only matches people who are descendants of the specified
person, but also those descendants' spouses.

C.6. Relationship filters
This category includes the following rules that match people based on their mutual relationship:

Relationship path between two peo-
ple

This rule matches all ancestors of both people back to their common an-
cestors (if exist). This produces the "relationship path" between these two
people, through their common ancestors.

You can either enter the ID of each person into the appropriate text entry
fields, or select people from the list by clicking their Select... buttons. In the
latter case, the ID will appear in the text field after the selection was made.

C.7. Miscellaneous filters
This category includes the following rules which do not naturally fit into any of the above categories:

Has the personal attribute This rule matches people who have the personal attribute of the specified
value. The specified personal attribute name should be selected from the
menu. The specified value should be typed into the text entry field.

Has the family attribute This rule matches people who have the family attribute of the specified
value. The specified family attribute should be selected from the menu. The
specified value should be typed into the text entry field.

Matches the filter named This rule matches people who are matched by the specified filter. The spec-
ified filter name should be selected from the menu.
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Appendix D. Command line reference
This appendix provides the reference to the command line capabilities available when launching GRAMPS from
the terminal.

Note

GRAMPS was designed to be an interactive program. Therefore it uses graphical display and cannot
run from the true non-graphical console. It would take an enormous amount of effort to enable it to
run in a text-only terminal. This is why the set of command line options does not aim to completely
get rid of dependency on the graphical display. Rather, it merely makes certain (typical) tasks more
convenient. It also allows one to execute these tasks from the scripts. However, the graphical display
must be accessible at all times!

Tip

To summarize, the use of the command line options provides non-interactive behavior, but does not
get rid of graphical display dependency. Take it or leave it!

D.1. Available options
This section provides the reference list of all command line options available in GRAMPS. If you want to know
more than just a list of options, see next sections: Section D.2, “Operation” and Section D.3, “Examples”.

D.1.1. Format options
The format of any file destined for opening, importing, or exporting can be specified with the -f format option.
The acceptable format values are listed below.

grdb GRAMPS database. This format is available for opening, import, and export. When not specified,
it can be guessed if the filename ends with .grdb

gramps-xml GRAMPS XML database. This format is available for opening, import, and export. When not
specified, it can be guessed if the filename ends with .gramps

gedcom GEDCOM file. This format is available for opening, import, and export. When not specified, it
can be guessed if the filename ends with .ged

gramps-pkg GRAMPS package. This format is available for import and export. When not specified, it can
be guessed if the filename ends with .gpkg

geneweb GeneWen file This format is available for import and export. When not specified, it can be
guessed if the filename ends with .gw

wft Web Family Tree. This format is available for export only. When not specified, it can be guessed
if the filename ends with .wft

iso CD image. This format is available for export only. It must always be specified explicitly.

D.1.2. Opening options
There are two ways to give GRAMPS the name of the file to be opened:

• supply bare file name

• use the -O filename or -open=filename option
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If the filename is given without any option flag, the attempt to open the file will be made, and then the interactive
GRAMPS session will be launched.

Tip

If no option is given, just the file name, GRAMPS will ignore the rest of the command line arguments.
Use the -O flag to open the file and do something with the data.

The format can be specified with the -f format or --format=format option, immediately following the file-
name. If not specified, the guess will be attempted based on the filename.

Tip

Only grdb, gramps-xml, and gedcom formats can be opened directly. For other formats, you will
need to use the import option which will set up the empty database and then import data into it.

Tip

Only a single file can be opened. If you need to combine data from several sources, you will need
to use the import option.

D.1.3. Import options
The files destined for import can be specified with the -i filename or --import=filename option. The format
can be specified with the -f format or --format=format option, immediately following the filename. If not
specified, the guess will be attempted based on the filename.

Tip

More than one file can be imported in one command. If this is the case, GRAMPS will incorporate
the data from the next file into the database available at the moment.

When more than one input file is given, each has to be preceded by -i flag. The files are imported in the specified
order, i.e.  -i file1 -i file2  and  -i file2 -i file1  might produce different GRAMPS IDs in the resulting
database.

D.1.4. Export options
The files destined for export can be specified with the -o filename or --output=filename option. The format
can be specified with the -f option immediately following the filename. If not specified, the guess will be
attempted based on the filename. For iso format, the filename is actually the name of directory the GRAMPS
database will be written into. For grdb, gramps-xml, gedcom, wft, geneweb, and gramps-pkg, the filename is
the name of the resulting file.

Tip

More than one file can be exported in one command. If this is the case, GRAMPS will attempt to
write several files using the data from the database available at the moment.

When more than one output file is given, each has to be preceded by -o flag. The files are written one by one,
in the specified order.

D.1.5. Action options
The action to perform on the imported data can be specified with the -a action or --action=action option.
This is done after all imports are successfully completed.
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Currently available actions are:

summary This action is the same as Reports->View->Summary

check This action is the same as Tools->Database Processing->Check and Repair.

report This action allows producing reports from the command line. As reports generally have many options
of their own, this action should be followed by the report option string. The string is given using the
-p option_string or --options=option_string option.

Tip

The report option string should satisfy the following conditions:

• It must not contain any spaces. If some arguments need to include spaces, the string
should be enclosed with quotation marks.

• Option string must list pairs of option names and values.

• Within a pair, option name and value must be separated by the equal sign.

• Different pairs must be separated by commas.

Most of the report options are specific for every report. However, there some common options.

name=report_name This mandatory option determines which report will be generated. If the
supplied report_name does not correspond to any available report, the error
message will be printed followed by the list of available reports.

show=all This will produce the list of names for all options available for a given
report.

show=option_name This will print the description of the functionality supplied by the
option_name, as well as what are the acceptable types and values for this
option.

Use the above options to find out everything about a given report.

Tip

If an option is not supplied, the last used value will be used. If this report has never
been generated before, then the value from last generated report will be used when
applicable. Otherwise, the default value will be used.

When more than one output action is given, each has to be preceded by -a flag. The actions are performed one
by one, in the specified order.

D.2. Operation
• If the first argument on the command line does not start with dash (i.e. no flag), GRAMPS will attempt to

open the file with the name given by the first argument and start interactive session, ignoring the rest of the
command line arguments.

• If the -O flag is given, then GRAMPS will try opening the supplied file name and then work with that data,
as instructed by the further command line parameters.

Note

Only one file can be opened in a single invocation of GRAMPS. If you need to get data from
multiple sources, use the importing options by using -i flag.
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• With or without the -O flag, there could be multiple imports, exports, and actions specified further on the
command line by using -i, -o, and -a flags.

• The order of -i, -o, or -a options with respect to each does not matter. The actual execution order always is:
all imports (if any) -> all exports (if any) -> all actions (if any).

Note

But opening must always be first!

• If no -O or -i option is given, GRAMPS will launch its main window and start the usual interactive session
with the empty database, since there is no data to process, anyway.

• If no -o or -a options are given, GRAMPS will launch its main window and start the usual interactive
session with the database resulted from opening and all imports (if any). This database resides in the
import_db.grdb file under the ~/.gramps/import/ directory.

• Any errors encountered during import, export, or action, will be either dumped to stdout (if these are exceptions
handled by GRAMPS) or or to stderr (if these are not handled). Use usual shell redirections of stdout and stderr
to save messages and errors in files.

D.3. Examples
To import four databases (whose
formats can be determined from
their names) and then check the re-
sulting database for errors, one may
type:

gramps -ifile1.ged -i file2.gpkg -i ~/db3.gramps -i
file4.wft -a check

To explicitly specify the formats
in the above example, append file-
names with appropriate -f options:

gramps -i file1.ged -f gedcom -i file2.gpkg -f gramps-pkg -i
~/db3.gramps -f gramps-xml -i file4.wft -f wft -a check

To record the database resulting
from all imports, supply -o flag
(use -f if the filename does not al-
low GRAMPS to guess the format):

gramps -i file1.ged -i file2.gpkg -o ~/new-package -f
gramps-pkg

To save any error messages of the
above example into files outfile
and errfile, run:

gramps -i file1.ged -i file2.dpkg -o ~/new-package -f
gramps-pkg >outfile 2>errfile

To import three databases and start
interactive GRAMPS session with
the result:

gramps -i file1.ged -i file2.gpkg -i ~/db3.gramps

To open a database and, based on
that data, generate timeline report
in PDF format putting the output
into the my_timeline.pdf file:

gramps -O file.grdb -a report -p
name=timeline,off=pdf,of=my_timeline.pdf

Tip

Use the name=timeline,show=all to find out about
all available options for the timeline report. To find out de-
tails of a particular option, use show=option_name, e.g.
name=timeline,show=off string.

To learn about available report names, use name=show
string.
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Finally, to start normal interactive
session type:

gramps
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Appendix E. About GRAMPS
GRAMPS was written by Donald N. Allingham (<don@gramps-project.org>).

The somewhat incomplete list of contributors includes (in alphabetical order):

• Tim Allen

• Larry Allingham

• Jens Arvidsson

• Kees Bakker

• Marcos Bedinelli
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• Stefan Bjork

• Douglas S. Blank

• Radu Bogdan Mare

• Alexander Bogdashevsky

• Richard Bos

• Matt Brubeck

• Nathan Bullock

• Lorenzo Cappelletti

• Pier Luigi Cinquantini

• Bruce J. DeGrasse

• Daniel Durand

• Alexandre Duret-Lutz

• Billy C. Earney

• Baruch Even

• Bernd Felsche

• Egyeki Gergely

• Michel Guitel

• Steve Hall

• David R. Hampton

• Martin Hawlisch

• Arpad Horvath

• Anton Huber
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• Frode Jemtland

• Mark Knoop

• Greg Kuperberg

• Arkadiusz Lipiec

• Lars Kr. Lundin

• Radek Malcic

• Benny Malengier

• Leonid Mamtchenkov

• Brian Matherly

• Tino Meinen

• Serge Noiraud

• Frederick Noronha

• Jeffrey C. Ollie

• Jiri Pejchal

• Donald A. Peterson

• Guillaume Pratte

• Alexandre Prokoudine

• Laurent Protois

• Matthieu Pupat

• Jérôme Rapinat

• Trevor Rhodes

• Alexander Roitman

• Soren Roug

• Jason Salaz

• Julio Sanchez

• Bernd Schandl

• Martin Senftleben

• Yaakov Selkowitz

• Gary Shao

• Arturas Sleinius

• Jim Smart
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• Eero Tamminen

• Samuel Tardieu

• Richard Taylor

• James Treacy

• Lubo Vasko

• Sebastian Voecking

• Xing Wang

• Tim Waugh

• Jesper Zedlitz

If you know of somebody else who should be listed here, please let us know.

To find more information about GRAMPS, please visit the GRAMPS Project Web page [http://gramps-
project.org].

To report a bug or make a suggestion regarding this application or this manual, use the help menu in GRAMPS,
or follow the directions on this site. [http://gramps.sourceforce.net/contact.html]

This program is distributed under the terms of the GNU General Public license as published by the Free Software
Foundation; either version 2 of the License, or (at your option) any later version. A copy of this license can be
found at this link [ghelp:gpl], or in the file COPYING included with the source code of this program.

http://gramps-project.org
http://gramps.sourceforce.net/contact.html
ghelp:gpl
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