Gramps 3.4.4 released

In order to fix some bugs introduced in 3.4.3 and to prepare for the imminent release of version 4.0.0, the Gramps team releases version 3.4.4 of Gramps!

 “The Ministry of Silly Names”, a maintenance and bug fix release. We advise everybody on 3.x versions to upgrade to this latest and most stable of Gramps versions.For all users on Linux versions older than October 2012, the 3.4 releases will be the last versions of Gramps that can be easily installed. Therefore, bug fixes will continue for the 3.4 series for at least another year.
Most important changes:
 
* infinite recursion bug in narrative web generation
* protection on family trees when using version 3.4 and 4.0 on the same PC (road to 4.0)
* merging notes of media with citations now works
* crash during Calculate Preview of a filtered XML export
* fix annoying errors on navigation related to citations gramplet and tag object.
* listing the Family Trees can corrupt them.
 
Other changes are:
 
* various fix around handling Gedcom file format
* fix citations and sources import on ProGen format 
* better date handling and better alternate translation support on some textual reports according to locale under windows 
* avoid Errors when setting wrong value as markup for invalid dates (Preferences)
* fix paragraph layout on PDF format or print output
* New: New-Zealand holidays
* Polish and backport code on XML import (road to 4.0)
* Regular expression rules now use search rather than match, fix design issues on regex filter rules
* Disable/Enable indent spouse on descendants tree
* fix regular expressions on Place filter rule
* consistency on cli arguments (road to 4.0)
* fix call of non-existant process on references proxy, enhanced tests on proxy filter
* fix NarWeb creation via cli for some non-english locales
* Various updated translations: ca, de, fr, it, nl, pt_BR, ru, sv, uk
 
See the Changelog for more details.
 
The latest releases can always be found on our Sourceforge page.
 
 
Thank you all!

8 Comments

  • Robert K. Tompsett

    will this update the Ubuntu version automatically?

  • Benny

    No, you need to download the .deb file on our sourceforge download page. Double click on it after download, and your package manager will ask you password to install it

  • Bernard

    does this gramps release use the same berkeley DB release, in the three OS Mac OSX, Linux and Windows ?

  • Benny

    No, they will be different. So best don’t work from a network drive with different OS!. Use .gramps or .gpkg files to move between operating systems.

  • Daniel

    The alternate dates for births/deaths (such as baptisms and burial dates) are still not written in italics as they were. This creates a problem when doing my sources because the italtic dates being displayed lets me know that I have entered the data correctly (as a baptism/burial) as opposed to mistaking a baptism date for a birth date.

  • Gramps » Gramps 3.4.5 released

    […] order to fix one issue introduced in 3.4.4 and to continue support for the 3.4.x branch, the Gramps team releases version […]

  • Joe Mackey

    I am trying to compile 4.0 on Scientific Linux. When I run python setup.py install I get /usr/bin/python cannot execute binary file.
    I am a new kid any reading suggestions
    Joe

  • Benny

    Please very that Scientific Linux has the requirements for Gramps. See the README and INSTALL file for pieces Gramps needs to work. Scientific Linux typically only has older versions of software, as it wants to be as stable as possible, so using 3.4.5 instead of 4.0 might be the only option. You can run a newer linux inside virtualbox though on Scientific Linux

Join the Conversation!