Gramps 4.0.0-alpha1 released

“UNSTABLE” Gramps 4.0.0 Alpha1 release.

This is a technology preview to allow plugin writers and packagers-installer
writers to update their plugins and scripts. This release is not production
ready, so use for testing!”

It is recommended to use Gramps 4.0.0 with python 3.2 so as to be ready
for the future (python 2.7 works though).

The dependencies for Gramps 4.0.0 are completely different than 3.4 due
to the switch to GObject introspection, and the removal of autotools. So
only install 4.0.0 if you are certain you can obtain the dependencies,
see README and INSTALL.

For linux, in Ubuntu 12.10 you can install 4.0.0, but you will need to
compile and install osmgpsmap manually to have the maps working (see
OsmGpsMap for Geography)

Major enhancements in Gramps 4.0.0:

* GEP 8 : Code reorganization

* GEP 26 : Replace make

* GEP 29 : Gtk 3

* GEP 31 : Python 3 support

More info in the manual.

Everybody is invited to update the manual to make it current!

You can download Gramps 4.0.0-alpha1 from sourceforge unstable section.

4 Comments

Join the Conversation!