Status GTK 3 for Gramps 4.0

For users, programmers talking about changing a library Gramps uses for another one, is normally dull matter. If that library is however GTK, it actually means the way the program looks will change. And that is of some importance to most of us.

In this case, Gramps moves from the old GTK 2.x series, to the new GTK 3.x series, and this means a lot of changes. When users in 4 or 5 months try out Gramps 4.0, they will be confronted with some problems:

  1. Gramps 4.0 will only work on computers that have a very recent GTK install. Gramps requires GTK python bindings 3.3.2, which is from june 2012. So users will need to upgrade, or keep on using version 3.4 of Gramps (which is a good version!)
  2. Assuming the computer was upgraded, they will need a theme that is GTK 3 compatible. In linux, themes are in /usr/share/themes, and GTK 3 support means a gtk-3.0 folder is present. For example Ubuntu 12.10 might still ship with a theme that is not fully GTK3 compatible. To solve this, the user will have to set the theme to a theme that supports GTK 3. For the time being, inkscape, gimp, firefox, … are still GTK 2, so good GTK 2 support is also required.

For users, to make it worthwhile to upgrade, the new version must offer something good. Will that be the case? Well, first of all, Gramps will look somewhat different, hopefully you find it more pretty. And of course, as every new version, some new features will be present.

To have an idea, a screenshot from the status end of August 2012:

First Gramps 3.4 in Adwaita style, and second Gramps 4.0 in the same style. Main thing that can be said is that all is the same and yet a bit different. It will be important to use a good style, but once you do, all can be as before. Note that in 4.0 links can be in the style link color.

Apart from looking different, there will also be some new features, but that is for another post.

5 Comments

  • Tomas Forsman

    Gramps for GTK2 is now officially stopped developing and only for recent GTK3 will get latest updates?

  • Benny

    There is a 3.5 branch, just in case, but that will not see real new features normally. So all will move to GTK 3.
    All other applications also are busy with GTK 3 conversion, as GTK 2 sees no longer development.

  • Gramps » Fanchart in 4.0, what features?

    […] Status GTK 3 for Gramps 4.0 […]

  • george baynes

    Do tell how I can stop Gramps being “full screen”

    I use “focus follows mouse” so when I open a picture in a gallery, invariably it opens behind Gramps.

    On Linux Mint I can minimise ALL windows but only because I have two displays and I have to move the status bar across to the second display before opening Gramps, in order to be able to use the Minimise All.

    Otherwise I would have to close Gramps down in order to view the picture. Extreme behaviour.

  • Benny

    Please, subscribe to users mailing list in order to ask questions.

Join the Conversation!