Gramps 3.2.4 released!

Today we released Gramps 3.2.4, the “Tententen” bug fix release.  I ran a few simple scripts against subversion to get a feel for what has changed in the 5 months since our previous release.  This is what I found:

1) There were 17 individual developers who committed code changes.  (The number may actually be slightly higher since some people commit on behalf of others who don’t have write access to subversion.)

2) There were more than 120 bug fix commits against gramps32 since the release of 3.2.3.

3) There were almost 40 additional commits that were purely translation updates.

Thanks to the core group of developers responsible for bringing us this bug fix release!  As usual, you can find it on SourceForge download page:  https://sourceforge.net/projects/gramps/files/

14 Comments

  • Ian Goddard

    Despite Python 2.5 being the stated prerequisite Gramps version 3.2.4-1 actually needs Python 2.6.

    **Don’t try to install it on Python 2.5.**

  • Ian Goddard

    The handling of this reflects badly on the approach of the developers.

    We have a .deb which has an erroneous dependency in it. A distro which meets the stated dependency will attempt to install it but the installation will crash and leave a broken system. The closure of the bug is on the grounds that it will be fixed in the next releas, not many people run 3.2.5 and that “Version 8.04 of ubuntu is eg no longer supported on the desktop.” This last statement surprises me because 8.04 is an LTS version and still maintained.

    So, by deliberate decision, the current version of 3.2.4 is and will remain with a known bug in it. At the very least there should be a corrected version with the appropriate dependency so it will not attempt to install on an unsuitable system.

    I for one have been recommending Gramps on the genealogical newsgroups. I will be much less supportive in the future.

  • alpha1

    I am completely new to genealogy software in general, and Gramps in particular. I tried a few times to subscribe to one of the lists, but nothing has happened. I also tried to install Gramps on Windows 7, but got Python related errors (I tried to install all the dependencies first — didn’t do any good). I have got it installed in LINUX (Kubuntu 10.04 and Zorin-OS which is really a flavour of Ubuntu 10.04).

    Does anyone know when there will be a complete Windows installer? I recall that some years ago, I had to go through all the pain of installing pre-requisites for the GIMP on Windows, but in the past several releases, Windows installers became available which would take care of all these problems quite automatically.

    Will there be a “Gramps to go” with the latest version sometime relatively soon?

    Thanks for any help or advice which will help me to find out how to get started and to get help for problems I encounter.

    alpha1

  • Jason Simanek

    @Ian: If you would like to influence the development of Gramps, you should join our developer mailing list. Bad-mouthing our project over an installer bug that affects an older version of Ubuntu (a newer LTS version was released in April 2010, but you’re right, 8.04 is technically supported through April 2011) seems a bit unfair. Especially when most Linux users are installing Gramps through their distribution’s package manager. As much as we would like to have Gramps and its installers work perfectly on all supported systems, we do have limited resources. We could always use more developers. Thanks for highlighting the importance of this bug.

  • Duncan Lithgow

    @alpha1

    Send me a message using my website: http://lithgow-schmidt.dk/contact-duncan-lithgow and I’ll try and help you get onto a discussion list. Basically Windows support is experimental and we don’t have enough windows developers to put in the work needed for a one-stop installer.

  • Duncan Lithgow

    @Ian

    If you know enough about dependencies to describe this problem then you also know that the correct way to report a problem is by making a bug report. If you’ve done that then please provide a link to this bug, I can’t find it.

    If you haven’t yet then please do this either directly to gramps at http://www.gramps-project.org/bugs or via Ubuntu on launchpad http://launchpad.net

  • Duncan Lithgow

    Sorry, that link to Launchpad should have been https://bugs.launchpad.net/ubuntu/+source/gramps

  • lcc

    Ian, you are right, I filed a bug about this but it seems people who decided on this change, which was at the time I pointed to it quite unnecessary, forgot to let the releasers know it. Anyway, the .deb could be fixed shortly and the damage mitigated. A small text change would fix it for 2.5 back then, see http://www.gramps-project.org/bugs/view.php?id=4069 and hopefully have a workaround to debian dependency requirements.

  • Ian Goddard

    LI have been strongly recommending Gramps on genealogy newsgroups for a long time. If good-mouthing is the opposite of bad-mouthing then that’s what I’ve been in the habit of doing.

    I did report the bug. It appears that there was already a fixed file in trunk so it wouldn’t have been difficult, assuming that was the only problem, to release a 3.2.4-2 with that in. Alternatively a 3.2.4-2 could have been released with the Python dependency set to 2.6. But the decision was to defer the release until 3.2.5.

    That leaves Gramps with a current version sitting on Sourceforge which will break, and which the devs know will break, if anyone tries to install or upgrade it on a platform with Python 2.5 despite that platform meeting the declared dependencies.

    I can’t, in all conscience, continue to recommend Gramps whilst that is the situation.

  • Duncan Lithgow

    @Ian: found that bug here: http://www.gramps-project.org/bugs/view.php?id=4286 it was solved back on the 12th. Looks like it was probably you who reported it. Thanks for bringing it to our attention.

  • lcc

    Ian, indeed, perhaps a new version should be released for this. Let’s wait and see.

  • A Nony Mous

    Will a new version of the live CD be made available?

    [ http://gramps-project.org/wiki/index.php?title=Linux_Genealogy_CD ]

    The Linux Genealogy Desktop CD 4.0 (Released: 2008-06-26) (The CD is available only for the x86 architecture.)

    Includes the following pre-installed genealogy software:

    GRAMPS 3.0.1

  • Michael Convey

    I’m so grateful for a solid genealogy application for Linux. Just curious, is there any plans to certify the program with Family Search?
    https://devnet.familysearch.org/certification

    Once certified, Gramps could be listed on the following site:
    http://www.familysearch.org/eng/affiliates/index.html#legendOfCertifiedFeatures

    Among other things, this would help Gramps gain greater exposure to the huge population of Family Search users – which may lead to recruiting more community developers. Thoughts?

  • teancum

    Much thanks for an excellent genealogy application for Linux. Just curious, have you considered getting Gramps certified for integration with family search?:
    https://devnet.familysearch.org/certification

    If certified, Gramps could be listed on the following site:
    http://www.familysearch.org/eng/affiliates/index.html#legendOfCertifiedFeatures

    This may help Gramps gain exposure to the huge FamilySearch user-base, and may even attract developers to the cause. Thoughts?

Join the Conversation!